Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

La recherche a retourné 118 résultats

par Didier43
28 nov. 2019, 09:07
Forum : Raspberry Pi
Sujet : Raspberry Pi 4 Model B - New !
Réponses : 178
Vues : 20396

Re: Raspberry Pi 4 Model B - New !

Les entretoises sont reçues, voici le résultat avec PI4 + Msata : IMG_20191116_135312.jpg La carte Z-wave dépasse un peu, il faudra trouver une solution. Au passage le Z-wave ne fonctionne pas sur le pi4 avec le BT (idem pi3), il faudra donc désactiver le BT via la fonction sudo nano /boot/config.t...
par Didier43
26 nov. 2019, 14:50
Forum : [Catégorie] Energie
Sujet : [Suivi Conso] Tuto Corriger des données fausses
Réponses : 10
Vues : 1195

Re: [Suivi Conso] Tuto Corriger des données fausses

Bonjour, je rebondi sur le sujet. J'ai pour ma part une conso éronné sur un équipement. L'index est hchp à bondi de 134500 unité ( donc à doublé en 1s) . Du coup, cette index c'est incrementé avec cette valeur erroné. J'ai donc soustrait cette velru eronné sur tout l'index de la table : UPDATE conso...
par Didier43
24 oct. 2019, 22:22
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

/** * Set the active mode to the given mode * @param $mode the activeMode( "standby","dhw","dhwAndHeating","forcedReduced","forcedNormal") * @param null $circuitId */ public function setActiveMode($mode, $circuitId = NULL) Effectivement... merci. La commande "standby" passe bien la pac en veille, t...
par Didier43
24 oct. 2019, 21:18
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

Oui les info du txt sont bien issu de la capture de traffic de mon app vicare. Sinon j'aimerai bien pouvoir passer la pac en veille, je pense que la fonction est heating.circuits.0.operating.programs.standby Une fonction dans l'api est dispo pour cela ? Pour le reste je te regarde ça dans le wekend....
par Didier43
24 oct. 2019, 14:25
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

Bon en fouillant dans le json de getAllFeatures j'ai trouvé la bonne feature. C'était heating.compressors.0 et non heating.compressors tout court. Par défaut, le 0 est le circuitId fourni à la création du ViessmannApi mais on peut le surcharger en le passant en paramètre lors de l'appel à la méthod...
par Didier43
23 oct. 2019, 22:36
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

J'ai l'impression que le mp ne part pas, dans le doute je te laisse les infos ici :
En pj ce qui semble le plus intéressant
par Didier43
23 oct. 2019, 22:23
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

Je viens de t'envoyer quelques infos que j'ai pu capturé, dit moi si ça te va
par Didier43
23 oct. 2019, 20:08
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

Hum c'est que le json renvoie toujours un 0 donc c'est pas la bonne feature. Faudrait que je regarder pour trouver quelle est la bonne "feature" qui correspond à l'activité du compresseur ou pas. Tu peux tester la méthode getHeatingConfigurationCoolingMode() et me dire si ça retourne bien quelque c...
par Didier43
23 oct. 2019, 14:33
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

Je viens de tester la methode "getHeatingTemperatureReturn", impec ça fonctionne.

Par contre le "isHeatingCompressorsActive" j'ai bien essayé de bidouillé mais n'arrive qu'a sortir un 0... :cry:
par Didier43
23 oct. 2019, 09:00
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

Salut, j'ai mis à jour le git et je viens de faire un essai sur "isHeatingCompressorsActive();" avec un fichier php de ce type : <?php include __DIR__.'/bootstrap.php'; echo (int)$viessmannApi->isHeatingCompressorsActive(); Mais j'ai toujours un 0 renvoyé , que le compresseur tourne ou pas ( que je ...
par Didier43
22 oct. 2019, 22:03
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

Je t'ai envoyer un mp, si la pj n'est pas passé dit le moi, je te renverrai un lien.
par Didier43
22 oct. 2019, 20:30
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

Oui j'ai bien cette info dans l'appli vicare, ainsi que le temps d'utilisation du compresseur. Voila le résultat de la commande (j'ai modifié la série de chiffre par des 0, je ne sait pas si c’était lié à mon compte) : Merci pour ton aide. Résultat de la commande : {"links":[{"rel":["self"],"href":"...
par Didier43
22 oct. 2019, 17:21
Forum : [Plugin officiel] Scripts
Sujet : Api Viessmann pour récupération de données avec Vitoconnect
Réponses : 717
Vues : 16009

Re: Api Viessmann pour récupération de données avec Vitoconnect

Bonjour à tous. J'utilise l'api sans pb avec des requêtes du fichiers exemple ( t° extérieure, intérieur), ça fonctionne nickels. Toutefois je voudrai récupérer l'état de marche de ma chaudière ( PAC vitocal200). J'ai essayé avec " GetHeatingBurnerActive.php " ( en binaire) mais j'ai tjs comme résul...
par Didier43
17 oct. 2019, 20:28
Forum : [Catégorie] Objets connectés
Sujet : worxLandroidS
Réponses : 689
Vues : 26626

Re: worxLandroidS

Je viens de faire le test, tout fonctionne à nouveau ( sur strech).
Quand j'aurai 5 minhe retenterai sous buster.
Merci pour le temps passé scc.
par Didier43
16 oct. 2019, 21:36
Forum : [Catégorie] Objets connectés
Sujet : worxLandroidS
Réponses : 689
Vues : 26626

Re: worxLandroidS

Bon comme j'avais d'autres probléme sous buster j'ai downgradé sous strech...
Je viens de mettre le plugins mais j'ai le même affichage zarbi ... quelqu'un reinstall le plugin pour confirmer le pb..ou pas
par Didier43
16 oct. 2019, 08:41
Forum : [Catégorie] Objets connectés
Sujet : worxLandroidS
Réponses : 689
Vues : 26626

Re: worxLandroidS

Oui je comprend... Si besoin je peux fait faire des tests .
par Didier43
15 oct. 2019, 22:23
Forum : [Catégorie] Objets connectés
Sujet : worxLandroidS
Réponses : 689
Vues : 26626

Re: worxLandroidS

Le problème devrait se résoudre en appuyant sur le bouton refresh? Je ne sais pas pourquoi ça ne d'initialise pas toujours correctement. Malheureusement non, l’affichage reste désespérément ainsi... il faudrait essayer de mettre le plugin en log niveau debug et voir s'il y a un message d'erreur. A ...
par Didier43
15 oct. 2019, 21:38
Forum : [Catégorie] Objets connectés
Sujet : worxLandroidS
Réponses : 689
Vues : 26626

Re: worxLandroidS

ssc a écrit :
15 oct. 2019, 16:10
Didier43 a écrit :
15 oct. 2019, 15:57
Maintenant le robot se créé et le démon ne tombe plus. Par contre affichage zarbi :

1.PNG
Le problème devrait se résoudre en appuyant sur le bouton refresh?
Je ne sais pas pourquoi ça ne d'initialise pas toujours correctement.
Malheureusement non, l’affichage reste désespérément ainsi...
par Didier43
15 oct. 2019, 15:57
Forum : [Catégorie] Objets connectés
Sujet : worxLandroidS
Réponses : 689
Vues : 26626

Re: worxLandroidS

Maintenant le robot se créé et le démon ne tombe plus. Par contre affichage zarbi :
1.PNG
1.PNG (16.17 Kio) Consulté 462 fois

Aller sur la recherche avancée