Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Pour échanger sur les plugins classés en catégorie "Protocoles domotiques"
nordix
Actif
Messages : 858
Inscription : 02 déc. 2014, 13:29

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par nordix » 10 avr. 2016, 02:36

pvodoz a écrit :
rol-rider a écrit :Non, pas de champ sur la puissance, j'ai fais un test sur les antennes ( plus haut dans le sujet) avec la bipolaire j'ai aussi des problèmes sur ma sonde extérieure, mais avec 3m de câble, on peut modifier la position.
J'ai effectivement vu tes tests mais je suis tellement sceptique quand je vois que le RFLINK ne capte pas un module à 5 m, antenne d'origine ou pas...
Dommage que l'on ait pas la puissance du signal reçu comme sur la Zibase... Ca pourrait être très instructif!

Esperons que la nouvelle antenne pourra résoudre mon problème!!

Je crois que tes problèmes ne sont pas dus à un enjeu de réception. Si ce sont des sondes Oregon avec hygromètre tels que la THGR122N, il y a un bug avec la version de Rflink actuel qui a été réglé avec la version R40.

http://www.esp8266.nu/forum/viewtopic.p ... 5796#p5796

pvodoz
Timide
Messages : 85
Inscription : 22 août 2014, 19:28

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par pvodoz » 10 avr. 2016, 08:43

nordix a écrit : Je crois que tes problèmes ne sont pas dus à un enjeu de réception. Si ce sont des sondes Oregon avec hygromètre tels que la THGR122N, il y a un bug avec la version de Rflink actuel qui a été réglé avec la version R40.
http://www.esp8266.nu/forum/viewtopic.p ... 5796#p5796
Merci pour l'info!!
J'ai tenté tant bien que mal de flasher le RFLINK en R40 et j'ai enfin réussi...
Par contre j'ai ça quasi toutes les 5 secondes dans les logs...

10-04-2016 08:41:15 | error | connection error - trying to reconnect: Error: Port is already open
10-04-2016 08:41:15 | info | Save Gateway Status 0
10-04-2016 08:41:15 | debug | Got response saveSensor: 200

Une idée?
Jeedom sur VM ESX
Clé Sigma Zwave+
Station Netatmo
Modules Chacon, Oregon, Fibaro, Serrure Danalock
IPX800, X4VR, X8R,X-THL...
EDRT2

rol-rider
Actif
Messages : 5097
Inscription : 10 août 2014, 23:50

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par rol-rider » 10 avr. 2016, 09:21

Peut être une mauvaise liaison (câble) entre le rflink et le PI ?
Ou l'alim ?
Pour la sonde oregon thgr122n, c'est ce que j'ai (en intérieur) et il est vrai quand fonction des versions .....c'est plus ou moins bon, je suis actuellement en R40, et j'ai l'impression que ça fonctionne moins bien qu'avant, ( j'ai le RFXcom sur la même sonde en // pour pouvoir comparer).

Envoyé de mon Nexus 7 en utilisant Tapatalk
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

pvodoz
Timide
Messages : 85
Inscription : 22 août 2014, 19:28

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par pvodoz » 10 avr. 2016, 09:27

Pour moi le passage en R40 est fantastique, plus de problème de reception de mes sondes Oregon... En revanche, j'ai ce polling toutes les 5 secondes qui me dit que la connection est impossible...
J'ai fait un netstat -an et je vois simplement que j'ai le port 8020 en écoute....
Pour info, le RFLINK est branché sur un Serveur HP sur lequel je fais tourner Jeedom sur une VM ESX...
J'ai tenté de redémarrer le serveur, de débrancher le module, de désactiver et réactiver le plugin... sans effet....
Sais tu à quoi correspond ce polling toutes les 5 secondes? c'est un heartbeat?
Jeedom sur VM ESX
Clé Sigma Zwave+
Station Netatmo
Modules Chacon, Oregon, Fibaro, Serrure Danalock
IPX800, X4VR, X8R,X-THL...
EDRT2

totovaauski
Actif
Messages : 1926
Inscription : 05 juil. 2014, 11:21

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par totovaauski » 10 avr. 2016, 12:22

Bonjour à tous !
Quelqu'un pourrait -il me confirmer que le flash du RFLINK est bien passé ? Car, je pense l'avoir fait avec la version R40 mais l'info de version remontée par le plugin jeedom m'indique R34.

Code : Tout sélectionner

pi@jeedom:~/RFLINK $ /usr/bin/avrdude -v -v -v -p atmega2560 -c stk500v2 -P /dev/ttyACM0 -b 115200 -U flash:w:/home/pi/RFLink.cpp.hex:i

avrdude: Version 6.1, compiled on Jul  7 2015 at 10:29:47
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/etc/avrdude.conf"
         User configuration file is "/home/pi/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyACM0
         Using Programmer              : stk500v2
         Overriding Baud Rate          : 115200
avrdude: stk500v2_getsync(): found AVRISP programmer
         AVR Part                      : ATmega2560
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PA0
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    10     8    0 no       4096    8      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           flash         65    10   256    0 yes    262144  256   1024  4500  4500 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : STK500V2
         Description     : Atmel STK500 Version 2.x firmware
         Programmer Model: AVRISP
         Hardware Version: 15
         Firmware Version Master : 2.10
         Vtarget         : 0.0 V
         SCK period      : 0.1 us

avrdude: AVR device initialized and ready to accept instructions

Reading |                                                    | 0% 0.Reading | #################                                  | 33% 0Reading | #################################                  | 66% 0Reading | ################################################## | 100% 0.02s

avrdude: Device signature = 0x1e9801
avrdude: safemode read 1, lfuse value: ff
avrdude: safemode read 2, lfuse value: ff
avrdude: safemode read 3, lfuse value: ff
avrdude: safemode: lfuse reads as FF
avrdude: safemode read 1, hfuse value: d8
avrdude: safemode read 2, hfuse value: d8
avrdude: safemode read 3, hfuse value: d8
avrdude: safemode: hfuse reads as D8
avrdude: safemode read 1, efuse value: ff
avrdude: safemode read 2, efuse value: ff
avrdude: safemode read 3, efuse value: ff
avrdude: safemode: efuse reads as FF
avrdude: NOTE: "flash" memory has been specified, an erase cycle will be performed
         To disable this feature, specify the -D option.
avrdude: erasing chip
avrdude: stk500v2_command(): command failed

avrdude done.  Thank you.

pi@jeedom:~/RFLINK $ 
Merci d'avance
RPI3 + Dongle Aeon
Jeedom sur : Raspberry Pi + Raspberry compute
Mysensors , z-wave, xiaomi ...

https://www.youtube.com/watch?v=-bjbUg9d64g
https://www.youtube.com/watch?v=GPj1ozB ... _b-Toq47NQ

nordix
Actif
Messages : 858
Inscription : 02 déc. 2014, 13:29

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par nordix » 10 avr. 2016, 14:35

Non pas eu de flash dans ton cas @totovauski, on ne voit aucune phase d'écriture du flash:
Normalement on devrait voir ceci au minimum;
Writing | ################################################## | 100% 19.48s

@Pvodoz, Rflink écoute sur un port USB, mais sur un Esx ce port doit être configuré en mode passthrough pour ta VM Jeedom. Surement qu'il en mode sharing et alors tu as d'autres VM ou le host qui essaye aux 5 secondes d'y accéder.

pvodoz
Timide
Messages : 85
Inscription : 22 août 2014, 19:28

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par pvodoz » 10 avr. 2016, 15:37

@Nordix, je n'ai pas d'option possible pour allouer le device USB sur ma VM Jeedom...
De plus, je parle de port TCP (le 8020) qui me semble t'il est le port d'écoute du démon RFLINK... donc pour moi le problème n'est pas niveau hardware...
Et c'est bien dans la log Jeedom que j'ai le message d'erreur. Pour moi pas de doute, c'est un composant de Jeedom qui semble tenter la connexion toutes les 5 secondes et pas mon ESX...
J'ai tenté une réinstallation mais je souhaiterai tenter de vraiment supprimer le plugin avant de le réinstaller...Vous savez comment faire?
Ou qq'un aurait il une idée au sujet de mon problème?
Jeedom sur VM ESX
Clé Sigma Zwave+
Station Netatmo
Modules Chacon, Oregon, Fibaro, Serrure Danalock
IPX800, X4VR, X8R,X-THL...
EDRT2

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 10 avr. 2016, 15:45

@pvodoz si le PB c'est ta config hard, nordix t'as explique la raison.
La tu as des instabilités USB. C'est pour ça que le service s'y reconnecte

Envoyé de mon A0001
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

pvodoz
Timide
Messages : 85
Inscription : 22 août 2014, 19:28

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par pvodoz » 10 avr. 2016, 16:30

@lunarok, bon j'ai avancé sur mon pb...
J'ai restauré une sauvegarde de Jeedom du début de semaine où j'étais en R39 et sans ce polling toutes les 5 secondes...
Si je vais dans les logs, je vois que je suis en R39 alors que j'ai flashé mon module en R40... le flashage est il refait à l'installation du plugin? je suis étonné de voir que je ne suis plus en R40...
Du coup, pour corriger mon problème de sonde Oregon, je souhaite repasser en R40...
Je remets le cpp de la R40 dans le bon repertoire et je lance le flash depuis Jeedom...

Verdict... plus de polling et sonde Oregon OK!!!

Va comprendre!!!
Jeedom sur VM ESX
Clé Sigma Zwave+
Station Netatmo
Modules Chacon, Oregon, Fibaro, Serrure Danalock
IPX800, X4VR, X8R,X-THL...
EDRT2

nordix
Actif
Messages : 858
Inscription : 02 déc. 2014, 13:29

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par nordix » 10 avr. 2016, 16:48

Si tu as vraiment fashé la R40, une restauration de Jeedom ne pourra en aucun cas ramener une R39 sur ton arduino. Le flash est sur arduino pas Jeedom.
Tant mieux si c'est réglé finalement
Dernière édition par nordix le 10 avr. 2016, 19:17, édité 1 fois.

f6dmn
Timide
Messages : 211
Inscription : 01 mars 2015, 10:43
Localisation : orne

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par f6dmn » 10 avr. 2016, 17:34

petite question = dans quel répertoire de jeedom mettre le R40 ? et avec quel outil ? je flash avec Windows mais je vois qu il y a plus simple. Merci

nordix
Actif
Messages : 858
Inscription : 02 déc. 2014, 13:29

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par nordix » 10 avr. 2016, 19:17

En SCP ou SFTP, mettre RFLink.cpp.hex dans /usr/share/nginx/www/jeedom/plugins/rflink/resources/rflink
Flasher ensuite via la gestion du plugin.

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 10 avr. 2016, 19:43

Et c'est fait toutes les nuits par le plugin en auto

Envoyé de mon A0001
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

totovaauski
Actif
Messages : 1926
Inscription : 05 juil. 2014, 11:21

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par totovaauski » 10 avr. 2016, 19:56

nordix a écrit :Non pas eu de flash dans ton cas @totovauski, on ne voit aucune phase d'écriture du flash:
Normalement on devrait voir ceci au minimum;
Writing | ################################################## | 100% 19.48s
Merci pour ta réponse, mais j'ai bien lancé cette commande issu de la doc auquel j'ai juste adapté le chemin de l'hex:

Code : Tout sélectionner

/usr/bin/avrdude -v -v -v -p atmega2560 -c stk500v2 -P /dev/ttyACM0 -b 115200 -U flash:w:/home/pi/RFLINK/RFLink.cpp.hex:i
Qu'est ce que je rate ?
RPI3 + Dongle Aeon
Jeedom sur : Raspberry Pi + Raspberry compute
Mysensors , z-wave, xiaomi ...

https://www.youtube.com/watch?v=-bjbUg9d64g
https://www.youtube.com/watch?v=GPj1ozB ... _b-Toq47NQ

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 10 avr. 2016, 19:59

@totovaauski : pourquoi tu utilises pas le bouton directement de mise à jour du plugin ?
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

rol-rider
Actif
Messages : 5097
Inscription : 10 août 2014, 23:50

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par rol-rider » 10 avr. 2016, 20:07

@ totovaauski:
je crois qu'il manque dans la doc l'argument -D ....regarde ici :viewtopic.php?f=28&t=12567&start=320
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

totovaauski
Actif
Messages : 1926
Inscription : 05 juil. 2014, 11:21

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par totovaauski » 10 avr. 2016, 20:09

@lunarok, parce que j'ai réinstaller mon jeedom de test et donc le plugin RFLINK, tout juste ce matin donc j'ai supposé que le flash me "reflashais" la version R34 du plugin ...
Je tente donc de le faire à la mano à l'aide de la doc ...

Je vais z'ieuter ca @rol-rider ...
RPI3 + Dongle Aeon
Jeedom sur : Raspberry Pi + Raspberry compute
Mysensors , z-wave, xiaomi ...

https://www.youtube.com/watch?v=-bjbUg9d64g
https://www.youtube.com/watch?v=GPj1ozB ... _b-Toq47NQ

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 10 avr. 2016, 20:28

Ah OK, mais ca doit être une R37 de base. Sinon vu que c'est le Jeedom de test tu peux relancer le crondaily dans le gestionnaire de taches

Envoyé de mon A0001
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

patmtp35
Timide
Messages : 254
Inscription : 30 juil. 2014, 19:11

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par patmtp35 » 10 avr. 2016, 20:42

lunarok a écrit :Ah OK, mais ca doit être une R37 de base. Sinon vu que c'est le Jeedom de test tu peux relancer le crondaily dans le gestionnaire de taches

Envoyé de mon A0001
Hum suis en 39 ça n'a pas basculer en 40 j ai tenter un flash manuel via le plugin mais pas mieux...

Envoyé de mon RIDGE 4G en utilisant Tapatalk
ESXi6 N54L => VM_Jeedom 3.2.11 + VM Xpenology 6.2
RFLINK USB + USB AeonTek Gen5 + USB Bluetooth + USB Teleinfo + XiaomiHome + 4 Ipcam
Imperihome Pro => AssusTAB 9"
Google Home Mini
SmartledMessenger
Rpi Musicman
Rpi SqueezePlayer

f6dmn
Timide
Messages : 211
Inscription : 01 mars 2015, 10:43
Localisation : orne

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par f6dmn » 10 avr. 2016, 20:55

pareil pas reussit a flasher via le plugin ....

Répondre

Revenir vers « [Catégorie] Protocoles domotiques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 5 invités