Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Pour échanger sur les plugins classés en catégorie "Protocoles domotiques"
Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 17 nov. 2015, 17:02

Tu l'as mis à jour le plugin ? (yes soir j'ai poussé un update qui rend le flash ok, je viens de le refaire chez moi à l'instant pour vérifier le flash)
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 17 nov. 2015, 17:34

J'ai la version du 16/11 à 21h36, donc la dernière version normalement oui.
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 17 nov. 2015, 23:58

Hello,

J'ai pu regarder un peu ce soir (mais pas eu le temps de tester avec le RFlink sur mon master)

Les NodeJS sont en vert sur mon master et mon esclave Jeedom, les 2 plugins sont bien last version.

J'ai créé un binding persistant sur mon RPi pour que mon RFLink soit vu en /dev/ttyUSB22 (qui pointe tout seul sur /dev/ttyACM0), du coup, je peux le voir maintenant dans la liste des chemins possibles dans la configuration du plugin, et bien vu avec la mention Arduino.

Mais rien de plus, Service et dépendances sont bien en vert et Ok, Gateway reste en rouge.

Voici le log du flash (seul moyen que j'ai trouvé pour tester le path)

Code : Tout sélectionner

root@Pigeon:/usr/share/nginx/www/jeedom/log# more rflink_flash

avrdude: Version 6.1, compiled on May 29 2015 at 01:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/etc/avrdude.conf"
         User configuration file is "/var/www/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : Array
         Using Programmer              : wiring
         Overriding Baud Rate          : 115200
avrdude: ser_open(): can't open device "Array": No such file or directory
avrdude: wiring_open(): releasing DTR/RTS
ioctl("TIOCMGET"): Inappropriate ioctl for device
avrdude: wiring_open(): asserting DTR/RTS
ioctl("TIOCMGET"): Inappropriate ioctl for device
C'est bizarre le coup du device "Array" non ?
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 18 nov. 2015, 13:56

@Golgautier : là ton RFlink est branché sur le Pi esclave c'est ca ? (je fais pas le flash sur esclave encore, donc ca serait "normal" ce que tu vois, je vais regarder pour l'ajouter)
Mais si ton rflink est déjà flashé, tu devrais pas avoir besoin de l'option ca devrait déjà passer. Vu que j'aurais surement la possibilité de configurer un esclave que ce week-end, si tu peux me passer un accès à ton Jeedom par MP que je regarde directement ca ira plus vite
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 18 nov. 2015, 14:13

lunarok a écrit :si tu peux me passer un accès à ton Jeedom par MP que je regarde directement ca ira plus vite
Hummmm, faut que je te créé un compte VPN alors :) Car j'ouvre pas mon Jeedom sur le Net ;) Si j'y pense ce soir.
Mais effectivement c'est bien l'esclave qui porte mon RFlink (le maître est au sous sol, et j'ai peur pour la portée)

Cela dit, le flash n'est sûrement pas mon souci, mais c'est le seul moyen que j'ai trouvé pour tester la communication sur le port USB.

Si tu as d'autres moyen pour tester la comm' sur le port USB avec l'arduino, je prends.
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 18 nov. 2015, 15:19

@Golgautier : réessaye là, j'ai corrigé la fonction d'échange conf entre maitre et esclave, ca devrait mieux marcher pour le service et flash
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

toyann
Timide
Messages : 87
Inscription : 09 avr. 2015, 11:23

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par toyann » 18 nov. 2015, 15:24

bonjour à tous,

Question d'un débutant :
j'utilise actuellement jeedom avec un Raspberry Pi2 avec un RFXCOM en USB.
Puis-je utiliser un RFlink en plus afin de palier à l'incompatibilité de certains protocoles ? (Lighting4 pour mes détecteurs d'ouverture et Rubicson pour les sondes température par exemple)

Merci

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 18 nov. 2015, 15:34

Oui pas de soucis, si c'est des protocoles qui fonctionnent avec rflink tu les auras
Après tu risques de trouver tes périphériques des 2 cotes si ils sont compatible rfxcom et rflink

Envoyé de mon A0001 en utilisant Tapatalk
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 18 nov. 2015, 15:56

Bon,

Déjà, merci Lunarok pour ta réactivité :)

J'ai mis à jour les 2 plugins.

Sur l'esclave, j'ai ces messages dans la logs lorsqu'il créé les dépendances :

Code : Tout sélectionner

root@Pigeon:/usr/share/nginx/www/jeedom/log# tail -f rflink_dep
  node-github-url-from-git node-glob node-graceful-fs node-gyp node-inherits
  node-ini node-json-stringify-safe node-lockfile node-lru-cache node-mime
  node-minimatch node-mkdirp node-mute-stream node-node-uuid node-nopt
  node-normalize-package-data node-npmlog node-once node-osenv node-qs
  node-read node-read-package-json node-request node-retry node-rimraf
  node-semver node-sha node-sigmund node-slide node-tar node-tunnel-agent
  node-underscore node-which
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 51 not upgraded.
mkdir: cannot create directory '/var/www': File exists

> serialport@2.0.5 install /usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport
> node-pre-gyp install --fallback-to-build

Usage: gyp_main.py [options ...] [build_file ...]

gyp_main.py: error: no such option: --no-parallel
gyp ERR! configure error
gyp ERR! stack Error: `gyp` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onCpExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:355:16)
gyp ERR! stack     at ChildProcess.emit (events.js:110:17)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:1074:12)
gyp ERR! System Linux 3.18.0-trunk-rpi
gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "configure" "--fallback-to-build" "--module=/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/build/Release/node-v14-linux-arm/serialport.node" "--module_name=serialport" "--module_path=/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/build/Release/node-v14-linux-arm"
gyp ERR! cwd /usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport
gyp ERR! node -v v0.12.6
gyp ERR! node-gyp -v v2.0.1
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute '/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/build/Release/node-v14-linux-arm/serialport.node --module_name=serialport --module_path=/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/build/Release/node-v14-linux-arm' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:110:17)
node-pre-gyp ERR! stack     at maybeClose (child_process.js:1015:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
node-pre-gyp ERR! System Linux 3.18.0-trunk-rpi
node-pre-gyp ERR! command "node" "/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport
node-pre-gyp ERR! node -v v0.12.6
node-pre-gyp ERR! node-pre-gyp -v v0.6.13
node-pre-gyp ERR! not ok
Failed to execute '/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/build/Release/node-v14-linux-arm/serialport.node --module_name=serialport --module_path=/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/build/Release/node-v14-linux-arm' (1)
npm ERR! Linux 3.18.0-trunk-rpi
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "--unsafe-perm" "serialport"
npm ERR! node v0.12.6
npm ERR! npm  v2.11.2
npm ERR! code ELIFECYCLE

npm ERR! serialport@2.0.5 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the serialport@2.0.5 install script 'node-pre-gyp install --fallback-to-build'.
npm ERR! This is most likely a problem with the serialport package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-pre-gyp install --fallback-to-build
npm ERR! You can get their info via:
npm ERR!     npm owner ls serialport
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /usr/share/nginx/www/jeedom/plugins/rflink/node/npm-debug.log
npm WARN peerDependencies The peer dependency sshpk@^1.4.6 included from http-signature will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
request@2.66.0 node_modules/request
âââ aws-sign2@0.6.0
âââ forever-agent@0.6.1
âââ is-typedarray@1.0.0
âââ caseless@0.11.0
âââ stringstream@0.0.5
âââ oauth-sign@0.8.0
âââ tunnel-agent@0.4.1
âââ isstream@0.1.2
âââ json-stringify-safe@5.0.1
âââ extend@3.0.0
âââ node-uuid@1.4.7
âââ combined-stream@1.0.5 (delayed-stream@1.0.0)
âââ qs@5.2.0
âââ mime-types@2.1.7 (mime-db@1.19.0)
âââ tough-cookie@2.2.1
âââ form-data@1.0.0-rc3 (async@1.5.0)
âââ bl@1.0.0 (readable-stream@2.0.4)
âââ har-validator@2.0.2 (pinkie-promise@1.0.0, commander@2.9.0, chalk@1.1.1, is-my-json-valid@2.12.3)
âââ hawk@3.1.1 (cryptiles@2.0.5, sntp@1.0.9, boom@2.10.1, hoek@2.16.3)
âââ sshpk@1.6.2 (assert-plus@0.1.5, dashdash@1.10.1, jsbn@0.1.0, asn1@0.2.3, jodid25519@1.0.2, tweetnacl@0.13.2, ecc-jsbn@0.0.1)
âââ http-signature@1.0.2 (assert-plus@0.1.5, jsprim@1.2.2, sshpk@1.6.2)
Fin de l'installtion
Je ne sais pas si c'est grave

Pour le flash, qui veut bien se lancer maintenant, j'ai ça... Ca semble pas tout tout bon :-(

Code : Tout sélectionner

root@Pigeon:/usr/share/nginx/www/jeedom/log# more rflink_flash

avrdude: Version 6.1, compiled on May 29 2015 at 01:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/etc/avrdude.conf"
         User configuration file is "/var/www/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyUSB22
         Using Programmer              : wiring
         Overriding Baud Rate          : 115200
avrdude: wiring_open(): releasing DTR/RTS
avrdude: wiring_open(): asserting DTR/RTS
avrdude: stk500v2_getsync(): found AVRISP programmer
         AVR Part                      : ATmega2560
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PA0
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    10     8    0 no       4096    8      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           flash         65    10   256    0 yes    262144  256   1024  4500  4500 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : Wiring
         Description     : Wiring
         Programmer Model: AVRISP
         Hardware Version: 15
         Firmware Version Master : 2.10
         Vtarget         : 0.0 V
         SCK period      : 197.5 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.02s

avrdude: Device signature = 0x1e9801
avrdude: NOTE: "flash" memory has been specified, an erase cycle will be performed
         To disable this feature, specify the -D option.
avrdude: erasing chip
avrdude: stk500v2_command(): command failed

avrdude done.  Thank you.
J'ai vraiment l'impression d'être un boulet mais j'avoue que si je me démerde correctement avec un linux, ça c'est un peu trop bas niveau pour moi :-(
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 18 nov. 2015, 16:20

Au passage, je pense que j'ai un souci sur le NodeJS de mon esclave, car le point est passé de gris à vert, et là il est à nouveau gris :-(
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

toyann
Timide
Messages : 87
Inscription : 09 avr. 2015, 11:23

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par toyann » 18 nov. 2015, 17:25

Cool, merci de ton retour, pouvoir utiliser les deux en // m'arrange. il me suffit de bloquer la détection automatique du RFXCOM qui gère déjà plus d'une vingtaine de périphériques et tout ce qui est sondes météo passerons via le rflink (pour le prix de deux sondes Oregon, je peux avoir le RFLink + 2 sondes à 8€ !)

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 18 nov. 2015, 22:01

Bon, j'avance un peu, j'ai réglé le souci de la création des dépendances sur mon Esclave, les logs sont propres.

Mais ça ne change rien au flash du RFlink, ou même à mon NodeJS qui reste gris (je sais même pas si c'est anormal).
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 18 nov. 2015, 22:25

Tu as les logs de lancement du service de l'esclave ?

Envoyé de mon A0001 en utilisant Tapatalk
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 18 nov. 2015, 23:04

Tu parles du service RFLink ?
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 18 nov. 2015, 23:12

Pour info, j'ai réussi à remettre le nodeJS en marche sur l'esclave... Ouf.

Bon, ça change rien à ma gateway qui reste rouge mais au moins tout ce qui est autour est clean.
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 18 nov. 2015, 23:19

Dans le log rflink, j'ai ça quand je démarre l'esclave

Code : Tout sélectionner

Error: Cannot find module '/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/build/Release/node-v11-linu
x-arm/serialport.node'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/serialport.js:14:25)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)

Je ne sais pas si ce sont les logs que tu voulais.
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par lunarok » 18 nov. 2015, 23:25

Ok, si t'as réinstallé ton nodejs, les modules ne matchent plus, donc il faut lancer la réinstallation des dépendances mais pas sur que ca la lance sur l'esclave, je sais plus je regarde demain (sinon il faut réactiver le plugin)
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 18 nov. 2015, 23:29

Je reactive le plugin de suite sur l'esclave.
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 18 nov. 2015, 23:40

Il m'a bien recréé les dépendances avec succès à la réactivation sur l'esclave, mais quand je resauvegarde la conf sur le plugin (sur le maître), il remet les mêmes erreurs dans le fichier de log "rflink" :-(
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Golgautier
Actif
Messages : 514
Inscription : 10 avr. 2015, 10:56

Re: [Sujet officiel] Rflink : passerelle RF433 multi-protoco

Message par Golgautier » 19 nov. 2015, 00:28

Je transmets mes dernières investigations pour ce soir...

En désactivant/réactivant les plugins sur les 2 Jeedom, et en recréant les dépendances (qui se fait sur l'esclave d'après les logs), j'ai le service et les dépendances en vert, et la gateway en rouge.

Quand je sauvegarde la config sur le master, le log rflink de l'esclave se peuple avec ça :

Code : Tout sélectionner

root@Pigeon:/usr/share/nginx/www/jeedom/log# tail -f rflink

module.js:340
    throw err;
          ^
Error: Cannot find module '/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/build/Release/node-v11-linux-arm/serialport.node'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/serialport.js:14:25)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
Le truc c'est que je n'ai pas de "node-v11-linux-arm" dans plugins/rflink/node/node_modules/serialport/build/Release, mais j'ai un node-v14-linux-arm

J'ai essayé de ruser en mettant un lien symbolique node-v11-linux-arm pointant vers node-v14-linux-arm. Ca ne démarre toujours pas, mais la log est différente :

Code : Tout sélectionner


module.js:356
  Module._extensions[extension](this, filename);
                               ^
Error: /usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/build/Release/node-v14-linux-arm/serialport.node: undefined symbol: node_module_register
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/usr/share/nginx/www/jeedom/plugins/rflink/node/node_modules/serialport/serialport.js:14:25)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
Voilà où j'en suis...
Jeedom en DIY
Plugins : Alarme, BBox TV, Energie, Google Agenda, Monitoring, Nabaztag, NetAtmo Station et Thermostat, Notify My Android, Pluie à 1h, PushBullet, Script, SMS, Surveillance Station, Vigilance Météo, Widget, Zwave
Liste du matériel

Répondre

Revenir vers « [Catégorie] Protocoles domotiques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 4 invités