Page 5 sur 61

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 26 juin 2019, 18:20
par akenad
m.georgein a écrit :
26 juin 2019, 16:10
... quelques soucis à l'install de deconz.

Bonjour @m.georgein,

Pour connaitre les modules python3 installés :

Code : Tout sélectionner

$ pip3 list
Si websocket-client n'est pas dans la liste, tu peux tenter :

Code : Tout sélectionner

$ sudo pip3 install websocket-client
akenad :)

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 26 juin 2019, 19:01
par m.georgein
OK, mais pour ouvrir un ticket il ne faut pas de plugin en beta. Hors DECONZ est un plugin payant MAIS EN BETA ! :(

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 26 juin 2019, 19:04
par m.georgein
Merci akenad
je l'ai tenté, cela m'a fait passer à la version 19.1.1(18.1 avant) mais même après relance des dépendances, découverte et 'récupérer API', toujours pas de daemon ni de Port Socket ni de Clef API :(

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 26 juin 2019, 19:07
par akenad
@m.georgein,

Le plugin Deconz est en stable depuis le 21-06-2019.

Je n'ai pas dis de faire 'pip install --upgrade pip'

Si tu fais ce que j'ai proposé, dans la log Deconz as-tu toujours ? :

Code : Tout sélectionner

from websocket import create_connection
ImportError: cannot import name 'create_connection'
Le module python ne doit pas être dans le dossier attendu par le plugin.

akenad :)

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 26 juin 2019, 19:13
par m.georgein
je l'ai acheté cet AM, là je viens de faire un print du market :
Capture.PNG
Capture.PNG (15.52 Kio) Consulté 1088 fois
Je vais donc tenter une réinstall en stable

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 26 juin 2019, 19:47
par m.georgein
Désinstallation, install de la stable, seule différence la découverte ne trouve plus le dongle ....

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 26 juin 2019, 19:53
par akenad
@m.georgein,

Je t'invites à republier les 3 logs sur le forum.
Et maintenant que tu es en stable, tu pourrais ouvrir un ticket auprès du support comme suggéré par @loic.

akenad :)

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 26 juin 2019, 20:38
par m.georgein
Oui, c'est ce que je compte faire demain ;) Merci de ton aide

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 26 juin 2019, 23:06
par paulnux
Je voudrais bien acheter le plugin pour tester mais je possède beaucoup d'ampoule Xiaomi lumi.light.aqcn02 ZNLDP12LM et je ne l'ai voit pas dans la liste compatible.
Est ce que quelqu’un a essayé ?

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 28 juin 2019, 17:30
par HugoVal11
paulnux a écrit :
26 juin 2019, 23:06
Je voudrais bien acheter le plugin pour tester mais je possède beaucoup d'ampoule Xiaomi lumi.light.aqcn02 ZNLDP12LM et je ne l'ai voit pas dans la liste compatible.
Est ce que quelqu’un a essayé ?
https://github.com/dresden-elektronik/d ... ssues/1057

La liste de matériel, n'est pas a jour, faut chercher sur le github, ou demander direct.

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 28 juin 2019, 17:44
par Theking31
mortyre a écrit :
09 mai 2019, 09:50

Actuellement, le plugin ne marche que sur rpi ou x86-64, vous ne pouvez donc pas l'installer sur une smart, un odroid C2, ou une jeedom pro. Il est à noté que sur smart/odroid C2 il ne sera pas possible de faire du Docker à cause du kernel qui est utilisé et modifié, et donc n'est pas compatible Docker.
La doc a écrit :Le plugin support plusieurs gateway deconz (1 clef conbee par gateway). Une gateway conbee peut etre installer sur :

jeedom lui meme (smart, rpi et x64_86 supporté)
un rpi deporté
ou tout autre carte compatible avec deconz.
Platforms.png
Platforms.png (9.71 Kio) Consulté 962 fois





Bonjour,

Désolé si ma question est bien bête pour certains ;)
Mais pouvez vous m'enlever un doute :

Non compatible avec mon Intel NUC 6CAYH avec debian-live-9.6.0-amd64 ?

Et si tel est le cas, le sera t'il un jour (pour Loic) ?

Merci

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 28 juin 2019, 19:10
par loic
C'est compatible pas de soucis je m'en sers c'est sous ubuntu.

Pour information deconz que tu vois n'est pas de nous donc si ca l'avait pas été j'aurais rien pu y faire ni meme savoir si ca sera fait un jour

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 28 juin 2019, 21:46
par typhoe
Bonsoir,

Loic, j'ignore si quelqu'un a déjà ouvert un ticket donc je viens de le faire au cas où.

Je rencontre le problème du websocket moi aussi, installation fraîche de ce soir, la clé conBee II vient d'arriver ;-)
Les logs d'installation des dépendances et de deconz en local semblent ok.
A noter que j'ai eu le pb du pip3 introuvable aussi (pour un autre plugin, je crois lors de la mise à jour d'open-zwave??) et que j'avais résolu ça en désinstallant et reinstallant le paquet python3-pip.

Merci.

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 28 juin 2019, 22:24
par loic
Ok je regarde ça lundi je pense j'ai peur que ce weekend il fasse trop chaud pour que j'arrive à me mettre devant un pc....

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 28 juin 2019, 22:27
par typhoe
Aucun soucis, et cela me parait même plus que normal ;-)
Bon we!

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 29 juin 2019, 08:53
par Deepcore
Bonjour,

Juste pour dire que j'ai également le même problème de socket.

J'ai installé le plugin sur mon raspi 2 de test (qui est à jour) avec une Conbee II (bien détectée). Ras pour les modules python

Je ne peux pas ouvrir de ticket car j'ai un plug-in en beta. Mais si vous avez besoin de tester je suis dispo.

Tssuu

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 30 juin 2019, 10:12
par loic
Bonjour,
J'ai trouvé le soucis et je viens de pousser la correction, il faut forcer la reinstallation des dépendances et ensuite lancer le démon.

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 30 juin 2019, 12:43
par supermenteur
Toujours pareil après avoir suivi ta procédure.

Code : Tout sélectionner

 [2019-06-30 12:41:09][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
Traceback (most recent call last):
File "/var/www/html/plugins/deconz/resources/deconzd/deconzd.py", line 32, in <module>
from websocket import create_connection
File "/usr/local/lib/python3.4/dist-packages/websocket/__init__.py", line 23, in <module>
from ._app import WebSocketApp
File "/usr/local/lib/python3.4/dist-packages/websocket/_app.py", line 36, in <module>
from ._core import WebSocket, getdefaulttimeout
File "/usr/local/lib/python3.4/dist-packages/websocket/_core.py", line 34, in <module>
from ._handshake import *
File "/usr/local/lib/python3.4/dist-packages/websocket/_handshake.py", line 40, in <module>
if six.PY34:
AttributeError: 'module' object has no attribute 'PY34'
[2019-06-30 12:41:42][ERROR] : Impossible de lancer le démon deconz, vérifiez le port


Envoyé de mon iPad en utilisant Tapatalk

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 30 juin 2019, 13:05
par typhoe
loic a écrit :
30 juin 2019, 10:12
J'ai trouvé le soucis et je viens de pousser la correction, il faut forcer la reinstallation des dépendances et ensuite lancer le démon.
Merci Loic!
Et merci doublement pour avoir bossé là-dessus un dimanche matin!

Je confirme que ma clé conBee II est désormais reconnue et le demon deconz démarre bien.
La "découverte" et la "récupération clé api" ont fonctionné nickel aussi!

Me reste à tester quelques inclusions et attendre votre tuto de migration (j'ai du Xiaomi et du Hue chacun sur leurs plugins respectifs) pour garder mes ids pour tous mes scenarios.

Bon dimanche

Re: [Plugin Officiel] Zigbee (deconz) beta

Publié : 30 juin 2019, 13:22
par flocon81
loic a écrit :Bonjour,
J'ai trouvé le soucis et je viens de pousser la correction, il faut forcer la reinstallation des dépendances et ensuite lancer le démon.
Nickel ça marche. Merci.

Envoyé de mon LLD-L31 en utilisant Tapatalk