Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Plugin Tiers][Sujet Principal] Pushbullet

Pour échanger sur les plugins classés en catégorie "Communication"
tom62490
Timide
Messages : 142
Inscription : 02 juin 2015, 23:46

Re: [Sujet officiel] Plugin Pushbullet

Message par tom62490 » 07 juil. 2016, 15:48

Bonjour a tous
N ayant pas de reponse Est ce quelqu un peu me dire si les snapshot du plugin camera envoyé par pushbullet fonctionne chez lui. Est ce qu il faut la version pro de l appli pushbullet.
Merci
HP N54l Xpenology + Jeedom V3 Debian Chroot
rfxcom USB + Contrôleur USB Z-Wave Plus Z-Stick (GEN5)

extrapitou
Actif
Messages : 1332
Inscription : 27 juin 2015, 21:53
Localisation : Dijon

Re: [Sujet officiel] Plugin Pushbullet

Message par extrapitou » 07 juil. 2016, 16:43

Je croyais qu'on ne pouvait pas envoyer de PJ avec Pushbullet ?

Envoyé avec TapataCash !
Mon Matos

Mon Blog où vous trouverez des astuces et tutos Tasker/Jeedom
Mon alarme sous Jeedom
Tuto pour la Gestion de la présence

tom62490
Timide
Messages : 142
Inscription : 02 juin 2015, 23:46

Re: [Sujet officiel] Plugin Pushbullet

Message par tom62490 » 07 juil. 2016, 18:17

D apres la doc du plugin pushbullet il est possible d envoyer des images et c integrer dans le plugin camera pour envoyer une capture.
HP N54l Xpenology + Jeedom V3 Debian Chroot
rfxcom USB + Contrôleur USB Z-Wave Plus Z-Stick (GEN5)

tom62490
Timide
Messages : 142
Inscription : 02 juin 2015, 23:46

Re: [Sujet officiel] Plugin Pushbullet

Message par tom62490 » 08 juil. 2016, 14:50

Bonjour me revoilà avec mon souci de snapshot : voici les logs debug pushbullet

[2016-07-08 01:06:10][pushbullet][DEBUG] : execute a:3:{s:5:"title";s:0:"";s:7:"message";s:0:"";s:5:"files";a:1:{i:0;s:89:"/usr/share/nginx/www/jeedom/core/php/../../tmp/camera_records/270/2016-07-08_01:06:09.jpg";}}
[2016-07-08 01:06:10][pushbullet][DEBUG] : file detected
[2016-07-08 01:06:10][pushbullet][DEBUG] : R
[2016-07-08 01:06:10][pushbullet][DEBUG] : (273) curl request POST https://api.pushbullet.com/v2/upload-request (a:2:{s:9:"file_name";s:23:"2016-07-08_01:06:09.jpg";s:9:"file_type";s:40:"application/octet-stream; charset=binary";})
[2016-07-08 01:06:10][pushbullet][DEBUG] : A
[2016-07-08 01:06:11][pushbullet][DEBUG] : (273) curl response (s:518:"{"data":{"acl":"public-read","awsaccesskeyid":"AKIAJJIUQPUDGPM4GD3W","content-type":"image/jpeg","key":"rRuzkkjhdkuuZy9cJ6S2oMSOIpP4sltV6jGx/2016-07-08_01:06:09.jpg","policy":"eyKjb25kaXRpb25zIjTE6MzcuMjLDJGUURHNwWiJ9","signature":"UX5s1uIy1ov6+xlj58JY7rGFKcs="},"file_name":"2016-07-08_01:06:09.jpg","file_type":"image/jpeg","file_url":"https://dl2.pushbulletusercontent.com/r ... l0avr1qkVE"}";)

je retrouve bien la photo dans le dossier /tmp/camera_records/270

désolé d'insister mais je n'y comprend rien et je suis incapable de déchiffrer les logs. merci pour votre aide
HP N54l Xpenology + Jeedom V3 Debian Chroot
rfxcom USB + Contrôleur USB Z-Wave Plus Z-Stick (GEN5)

extrapitou
Actif
Messages : 1332
Inscription : 27 juin 2015, 21:53
Localisation : Dijon

Re: [Sujet officiel] Plugin Pushbullet

Message par extrapitou » 08 juil. 2016, 15:28

Je n'avais jamais tester avant cette fonctionnalité, mais par mail déjà ça ne fonctionne pas chez moi.

Tu as tester l'envoi par mail ?

Envoyé avec TapataCash !
Mon Matos

Mon Blog où vous trouverez des astuces et tutos Tasker/Jeedom
Mon alarme sous Jeedom
Tuto pour la Gestion de la présence

tom62490
Timide
Messages : 142
Inscription : 02 juin 2015, 23:46

Re: [Sujet officiel] Plugin Pushbullet

Message par tom62490 » 08 juil. 2016, 15:48

oui par mail ça fonctionne impec avec la photo , je suis chez free c peut etre pour ça que ça fonctionne.
HP N54l Xpenology + Jeedom V3 Debian Chroot
rfxcom USB + Contrôleur USB Z-Wave Plus Z-Stick (GEN5)

tom62490
Timide
Messages : 142
Inscription : 02 juin 2015, 23:46

Re: [Sujet officiel] Plugin Pushbullet

Message par tom62490 » 08 juil. 2016, 18:54

personne pour interpréter ces logs ?
Je n'ai pas de nouvelles du concepteur du plugins @zoboton ,il est peut être en vacances.
C bête j'ai acheté le plugin caméra juste pour cette fonction.
HP N54l Xpenology + Jeedom V3 Debian Chroot
rfxcom USB + Contrôleur USB Z-Wave Plus Z-Stick (GEN5)

zoboton
Timide
Messages : 275
Inscription : 14 août 2014, 10:34

Re: [Sujet officiel] Plugin Pushbullet

Message par zoboton » 09 juil. 2016, 13:25

Je viens de regarder les logs que tu m'as envoyés en MP. Ils ne montrent pas d'erreur, mais il manque la fin où on devrait voir la requête d'upload du fichier image.

Je confirme que de mon côté, ça fonctionne bien et je n'ai pas l'application pro.

Tu as plus d'infos et/ou de logs à m'envoyer ?

tom62490
Timide
Messages : 142
Inscription : 02 juin 2015, 23:46

Re: [Sujet officiel] Plugin Pushbullet

Message par tom62490 » 09 juil. 2016, 13:45

je t'ai tous envoyé pour les logs pushbullet, par contre j'ai peut être une piste : le log du scenario_exécution est " PHP Fatal error: Call to undefined function curl_file_create() in /usr/share/nginx/www/jeedom/plugins/pushbullet/core/class/pushbullet.class.php on line 807 "
apres une recherche sur internet j'ai cru comprendre que la fonction "curl_file_create" ne fonctionne qu'a partir de php 5.5 alors que je suis en 5.4.
Pense que c'est l 'explication de mon problème ?
HP N54l Xpenology + Jeedom V3 Debian Chroot
rfxcom USB + Contrôleur USB Z-Wave Plus Z-Stick (GEN5)

zoboton
Timide
Messages : 275
Inscription : 14 août 2014, 10:34

Re: [Sujet officiel] Plugin Pushbullet

Message par zoboton » 09 juil. 2016, 14:59

Oui c'est ça le problème. Tu as quoi comme installation de jeedom ?

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Plugin Pushbullet

Message par lunarok » 09 juil. 2016, 15:08

Il est sue une wheezy obsolete, @tom62490 ca serait sympa de préciser ce genre de chose qu'on t'a déjà signaler pour que les devs ne perdent pas leur temps, et aussi de ne pas étaler ca sur plusieurs fils sur le forum.
Déjà tu dois le voir sur la page santé que c'est pas bon.
Donc t'as pas de bug sur ce plugin, c'est ton xpenlogy qui est pas a jour comme tu l'as dit.
Attends qu'un spécialiste xenology réponde a tes questions ou si t'es presse regarde du cote des forums dédiés vu que ce sont pas des questions jeedom

Envoyé de mon A0001 en utilisant Tapatalk
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

tom62490
Timide
Messages : 142
Inscription : 02 juin 2015, 23:46

Re: [Sujet officiel] Plugin Pushbullet

Message par tom62490 » 09 juil. 2016, 16:16

@lunarok j'ai poste en premier sur ce post car je croyais que c etait un probleme du plugin ensuite en faisant une recherche ( j'ai pas attendu qu'on me donne la solution sans chercher) j'ai compris que c'etait surement un probleme de version php et j'ai poser la question dans la sous section dédié a jeedom synology car je pense que les gens qui consulte cette sous section sont plus apte a me répondre.
maintenant effectivement dans la santé de mon jeedom c'est ecrit que je suis en php 5.4 mais a coté c'est ecrit "Si vous êtes en version 5.4.x on vous indiquera quand la version 5.5 sera obligatoire"
j'attendait d'avoir un message pour me notifier que la version 5.5 est obligatoire

Désolé de ne pas être un crack de linux comme vous

également je n'ai pas preciser ma version dans ce post car je ne pensais pas que c'était la cause de mon probléme ( si tu regarde plus haut j'ai posté tous les logs que j'avais) (logs pushbullet et logs scenario execution).

@zoboton mon installation est sur un nas HP n54l en debian chroot wheezy obsolete.
HP N54l Xpenology + Jeedom V3 Debian Chroot
rfxcom USB + Contrôleur USB Z-Wave Plus Z-Stick (GEN5)

zoboton
Timide
Messages : 275
Inscription : 14 août 2014, 10:34

Re: [Sujet officiel] Plugin Pushbullet

Message par zoboton » 09 juil. 2016, 16:53

Pas de souci me concernant, je comprends qu'il n'ait pas eu le réflexe de penser que le pb pouvait venir de la version de PHP (moi non plus en fait, et du coup la prochaine fois j'y penserai).

@tom62490 : je t'ai envoyé une solution à tester par MP

tom62490
Timide
Messages : 142
Inscription : 02 juin 2015, 23:46

Re: [Sujet officiel] Plugin Pushbullet

Message par tom62490 » 10 juil. 2016, 11:16

Bonjour la solution que @zoboton fonctionne je reçois bien les notifications comme ceci
2.jpg
2.jpg (192.05 Kio) Consulté 2742 fois
mais quand j appui sur la notif pour l ouvrir j'ai ça comme message
3.jpg
3.jpg (82.02 Kio) Consulté 2742 fois
je pense que c'est plus un probleme de mon galaxy note 3 ou d'android
mais si quel'qu un a une idée je suis preneur

pourtant la photo est bien dans le dossier download de mon note 3 et quand j'ouvre l'appli pushbullet moi même je vois egalement la photo
(je viens d’essayer avec un samsung J7 2016 et même type de message)
HP N54l Xpenology + Jeedom V3 Debian Chroot
rfxcom USB + Contrôleur USB Z-Wave Plus Z-Stick (GEN5)

Avatar de l’utilisateur
Phil56
Actif
Messages : 773
Inscription : 11 août 2015, 11:36

Re: [Sujet officiel] Plugin Pushbullet

Message par Phil56 » 05 août 2016, 13:41

Bonjour,

merci pour ce plugin il marche impec pour moi.

Au passage sur mon installe, j'ai changé l'icone si ça te dit....
pushbullet_icon.png
pushbullet_icon.png (10.27 Kio) Consulté 2630 fois
ken@vo
Phil
Box : Jeedom Maitre dans VM Esxi NUC intel i5, Jeedom Esclave RPI2 avec Zwave, Rfxcom, Blink1, EDISIO et TTS + VM Zoneminder
Protocoles : Zwave, X10, DI-O, HUE, EDISIO
Teleinfo (Dauguet rs232 mise en réseau avec une arduino mega)

zoboton
Timide
Messages : 275
Inscription : 14 août 2014, 10:34

Re: [Sujet officiel] Plugin Pushbullet

Message par zoboton » 06 août 2016, 10:06

Merci, elle est très bien !
Je la mettrai à la prochaine mise à jour.

kashin
Timide
Messages : 139
Inscription : 20 avr. 2015, 16:50

Re: [Sujet officiel] Plugin Pushbullet

Message par kashin » 08 août 2016, 13:44

Hello,

Il semble que la configuration du plugin Camera aie changé dans la dernière mise à jour et que le champ où introduire la commande Pushbullet a disparu.
08-08-_2016_13-41-36.png
Plugin Camera
08-08-_2016_13-41-36.png (76.31 Kio) Consulté 2523 fois
Pourriez-vous me dire comment faire ou mettre la doc à jour?
(tous mes plugin sont en version stable)
2 x RPI3 avec plugin Jeelink, Zwave, RFXcom), 9 FGS221, 4 Aeonlan DSB05 multisensor, 2 Fibaro RGBW, 1 Oeil Fibaro, 2 TZ65D, 3 CH54700, 4 sondes température Oregon, 5 capteur d'ouverture Chacon, 7 thermostat Danfoss, etc

Avatar de l’utilisateur
Phil56
Actif
Messages : 773
Inscription : 11 août 2015, 11:36

Re: [Sujet officiel] Plugin Pushbullet

Message par Phil56 » 08 août 2016, 16:01

Bonjour,

En fait maintenant c'est dans ton scénario qui doit envoyer la capture que tu donnes la commande pushbullet

exemple :
push.jpg
push.jpg (28.74 Kio) Consulté 2488 fois

Edit :
En plus dans la partie "Commande message d'envoi des captures" on peut mettre plusieurs commandes séparées par des "&&"

ken@vo
Phil
Box : Jeedom Maitre dans VM Esxi NUC intel i5, Jeedom Esclave RPI2 avec Zwave, Rfxcom, Blink1, EDISIO et TTS + VM Zoneminder
Protocoles : Zwave, X10, DI-O, HUE, EDISIO
Teleinfo (Dauguet rs232 mise en réseau avec une arduino mega)

kashin
Timide
Messages : 139
Inscription : 20 avr. 2015, 16:50

Re: [Sujet officiel] Plugin Pushbullet

Message par kashin » 09 août 2016, 22:21

Merci!!!

J'ai loupé ça dans la Doc?


Envoyé de mon iPhone en utilisant Tapatalk
2 x RPI3 avec plugin Jeelink, Zwave, RFXcom), 9 FGS221, 4 Aeonlan DSB05 multisensor, 2 Fibaro RGBW, 1 Oeil Fibaro, 2 TZ65D, 3 CH54700, 4 sondes température Oregon, 5 capteur d'ouverture Chacon, 7 thermostat Danfoss, etc

Jordan
Timide
Messages : 10
Inscription : 15 juin 2015, 14:57

Re: [Sujet officiel] Plugin Pushbullet

Message par Jordan » 22 août 2016, 18:21

Bonjour tout le monde,

Depuis la maj 2.3.17 il semble que la réception des push ne soit plus fonctionnelle. Suis-je le seul dans ce cas la ?

Merci !

Edit : Je ne sais pas comment, mais j'ai un 2e device qui s'est créé après la mise à jour, avec le même nom que le premier. Après l'avoir supprimé sur pushbullet, tout est fonctionnel, désolé !
RPI3 - ZWave - Hue - Téléinfo

Répondre

Revenir vers « [Catégorie] Communication »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité