Page 1 sur 63

[Plugin Tiers] Plugin Alexa-API

Publié : 05 mars 2019, 19:39
par sigalou
alexaapi.png
alexaapi.png (7.64 Kio) Consulté 8042 fois
Sujet du forum qui sera dédié au Plugin Alexa-API

Le Plugin Alexa-API passe en version Stable 1.0.0

Il n'est pas terminé mais il peut déja :

:arrow: Scanner automatiquement tous les Echo du compte Amazon

:arrow: Faire parler les Amazon Echo

:arrow: Régler le volume

:arrow: Programmer des alarmes et les supprimer

:arrow: Programmer des rappels et les supprimer

Ce plugin ne commande pas Jeedom depuis Alexa (contrairement au plugin Alexa) mais commande Alexa depuis Jeedom.

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 05 mars 2019, 20:49
par Networks514
Bascule du git vers le market sans soucis !! Très beau boulot à toi et tes acolytes :)

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 05 mars 2019, 21:20
par Moctesuma
Et voilà,

passage du Git au market sans soucis ni régressions 8-)

Merci et encore bravo aux actifs :!:

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 05 mars 2019, 23:27
par HadesDT
Migration faites sans aucun soucis et maintenant j'ai bien le tableau récap des alarmes et rappels :)

Boulot au top,

encore la gestion de la musique/livre audio et le lancement de routines à la demande et ça sera au top :D

Merci et pensez à dormir ;)

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 05 mars 2019, 23:54
par thierry38090
Installé en 2 temps 3 mouvements, fonctionne nickel avec mes 4 échos, 2 Fire TV et applications !
Bravo !

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 00:41
par ffp17
Bonjour,

Bravo pour le plugin que je découvre.
Je viens de le tester sur ma vm de test en jeedom beta 3.3.16 et ça fonctionnel nickel.
J'en profite pour demander un petit quelque chose que je cherche depuis un moment sur le net.
Y aurait-il un moyen de rendre un ECHO compatible avec Squeezecenter en upnp ou autre ?
L'objectif est de diffuser mes musiques locales via l'ECHO.

En tout cas, c'est un plugin que je vais adopter sur ma prod :)
Bonne nuit

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 12:11
par darkwinter
Bravo pour ce plug-in c'est vraiment très bien.

Peut être à rajouter pour celle et ceux qui utilise amazon echo spot : arrêter la diffusion en cours et mettre en veille l'echo Spot.

Merci encore pour ce plugin :)

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 13:25
par remyg83
Bonjour, souci de dépendances sur ma part , jeedom en dernière version stable sur smart.. Je joins les logs
alexaapi_dep.txt
(3.13 Kio) Téléchargé 96 fois

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 13:28
par Nebz
remyg83 a écrit :Bonjour, souci de dépendances sur ma part , jeedom en dernière version stable sur smart.. Je joins les logs
alexaapi_dep.txt
Lance la réparation dans la configuration du plugin


Envoyé de mon iPhone en utilisant Tapatalk

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 13:49
par remyg83
Re, alors j'ai rebooté la smart, j'ai lancé la réparation, et toujours la même erreur dans les logs

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 13:50
par Nebz
Tu peux m'envoyer le log que je puisse voir stp ?


Envoyé de mon iPhone en utilisant Tapatalk

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 13:52
par remyg83
Oui, j'ai oublié de les mettre!!

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 13:53
par Nebz
Ça c'est pas les logs après la réparation...


Envoyé de mon iPhone en utilisant Tapatalk

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 13:55
par remyg83
ah si, je viens de vider le log et relancer une réparation, je te joint le nouveau log, mais il me semble que c'est la même chose

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 13:56
par daniel.louvel
Bonjour
J'essai d’installé le plugin sans suces a premier vu il me manque ./lib/alexa-remote

Merci pour ton aide

Code : Tout sélectionner

[2019-03-06 13:40:24][INFO] : Lancement du démon cookie
[2019-03-06 13:40:24][INFO] : Démon cookie lancé
/var/www/html/plugins/alexaapi/resources/initCookie.js:1
(function (exports, require, module, __filename, __dirname) { let Alexa = require('./lib/alexa-remote');
^^^
SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:387:25)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Function.Module.runMain (module.js:447:10)
at startup (node.js:142:18)
at node.js:939:3
[2019-03-06 13:44:22][INFO] : Lancement du démon cookie
[2019-03-06 13:44:22][INFO] : Démon cookie lancé
/var/www/html/plugins/alexaapi/resources/initCookie.js:1
(function (exports, require, module, __filename, __dirname) { let Alexa = require('./lib/alexa-remote');
^^^
SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:387:25)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Function.Module.runMain (module.js:447:10)
at startup (node.js:142:18)
at node.js:939:3

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 13:59
par Nebz
remyg83 a écrit :
06 mars 2019, 13:55
ah si, je viens de vider le log et relancer une réparation, je te joint le nouveau log, mais il me semble que c'est la même chose
on dirait que tu as un problème sur ton système, il s'obstine à installer une 4.8.5 alors qu'on lui dit de mettre une 8...

reboot et relance une réparation

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 14:00
par remyg83
Nebz a écrit :
06 mars 2019, 13:59
remyg83 a écrit :
06 mars 2019, 13:55
ah si, je viens de vider le log et relancer une réparation, je te joint le nouveau log, mais il me semble que c'est la même chose
on dirait que tu as un problème sur ton système, il s'obstine à installer une 4.8.5 alors qu'on lui dit de mettre une 8...

reboot et relance une réparation
Ok je fais ça et je reviens si ca bug encore!

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 14:01
par Nebz
daniel.louvel a écrit :
06 mars 2019, 13:56
Bonjour
J'essai d’installé le plugin sans suces a premier vu il me manque ./lib/alexa-remote

Merci pour ton aide

Code : Tout sélectionner

[2019-03-06 13:40:24][INFO] : Lancement du démon cookie
[2019-03-06 13:40:24][INFO] : Démon cookie lancé
/var/www/html/plugins/alexaapi/resources/initCookie.js:1
(function (exports, require, module, __filename, __dirname) { let Alexa = require('./lib/alexa-remote');
^^^
SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:387:25)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Function.Module.runMain (module.js:447:10)
at startup (node.js:142:18)
at node.js:939:3
[2019-03-06 13:44:22][INFO] : Lancement du démon cookie
[2019-03-06 13:44:22][INFO] : Démon cookie lancé
/var/www/html/plugins/alexaapi/resources/initCookie.js:1
(function (exports, require, module, __filename, __dirname) { let Alexa = require('./lib/alexa-remote');
^^^
SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:387:25)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Function.Module.runMain (module.js:447:10)
at startup (node.js:142:18)
at node.js:939:3
non ca ne semble pas être ca... mais tu peux de toute façon confirmer s'il est là ou pas en allant voir dans le dossier ;)

sinon je pense à un problème de version de node, tu peux envoyer ton log _dep stp ?

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 14:08
par remyg83
remyg83 a écrit :
06 mars 2019, 14:00
Nebz a écrit :
06 mars 2019, 13:59
remyg83 a écrit :
06 mars 2019, 13:55
ah si, je viens de vider le log et relancer une réparation, je te joint le nouveau log, mais il me semble que c'est la même chose
on dirait que tu as un problème sur ton système, il s'obstine à installer une 4.8.5 alors qu'on lui dit de mettre une 8...

reboot et relance une réparation
Ok je fais ça et je reviens si ca bug encore!
Bon toujours le meme souci, j'ai vais essayer de forcer l'install en version 8

Re: [Plugin Tiers] Plugin Alexa-API

Publié : 06 mars 2019, 14:11
par daniel.louvel
sinon je pense à un problème de version de node, tu peux envoyer ton log _dep stp ?
ls.jpg
ls.jpg (64.06 Kio) Consulté 7823 fois

Code : Tout sélectionner

--0%
--10%
Lancement de l'installation/mise à jour des dépendances
--20%
--30%
Version actuelle : v5.9.1
--40%
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Reading package lists...
Building dependency tree...
Reading state information...
Package 'npm' is not installed, so not removed
Package 'nodejs' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
--45%
Utilisation du dépot officiel
## Installing the NodeSource Node.js 8.x LTS Carbon repo...
## Populating apt-get cache...
+ apt-get update
Hit http://security.debian.org jessie/updates InRelease
Ign http://http.us.debian.org jessie InRelease
Hit https://deb.nodesource.com jessie InRelease
Ign http://httpredir.debian.org jessie InRelease
Hit http://httpredir.debian.org jessie-updates InRelease
Hit http://http.us.debian.org jessie Release.gpg
Hit http://httpredir.debian.org jessie-backports InRelease
Hit http://http.us.debian.org jessie Release
Hit https://repo.mosquitto.org stretch InRelease
Hit http://httpredir.debian.org jessie Release.gpg
Get:1 https://deb.nodesource.com jessie/main Sources [762 B]
Get:2 http://mirrors.digitalocean.com jessie-backports InRelease [166 kB]
Hit http://apt.armbian.com jessie InRelease
Get:3 http://httpredir.debian.org jessie-updates/main arm64 Packages/DiffIndex [11.8 kB]
Get:4 http://http.us.debian.org jessie/non-free arm64 Packages [68.6 kB]
Get:5 https://deb.nodesource.com jessie/main arm64 Packages [1003 B]
Get:6 http://httpredir.debian.org jessie-updates/contrib arm64 Packages [20 B]
Get:7 http://httpredir.debian.org jessie-updates/non-free arm64 Packages/DiffIndex [736 B]
Get:8 http://apt.armbian.com jessie/main arm64 Packages [239 kB]
Get:9 http://httpredir.debian.org jessie-updates/main armhf Packages/DiffIndex [11.8 kB]
Get:10 http://http.us.debian.org jessie/non-free armhf Packages [74.9 kB]
Get:11 https://deb.nodesource.com jessie/main armhf Packages [1000 B]
Get:12 http://httpredir.debian.org jessie-updates/contrib armhf Packages [20 B]
Get:13 http://httpredir.debian.org jessie-updates/non-free armhf Packages/DiffIndex [736 B]
Get:14 http://httpredir.debian.org jessie-backports/main arm64 Packages/DiffIndex [27.8 kB]
Get:15 http://httpredir.debian.org jessie-backports/contrib arm64 Packages/DiffIndex [23.9 kB]
Get:16 http://httpredir.debian.org jessie-backports/non-free arm64 Packages/DiffIndex [8530 B]
Get:17 http://httpredir.debian.org jessie-backports/main armhf Packages/DiffIndex [27.8 kB]
Get:18 http://apt.armbian.com jessie/utils arm64 Packages [6011 B]
Get:19 http://apt.armbian.com jessie/jessie-desktop arm64 Packages [9902 B]
Get:20 http://apt.armbian.com jessie/main armhf Packages [452 kB]
Get:21 http://httpredir.debian.org jessie-backports/contrib armhf Packages/DiffIndex [26.7 kB]
Get:22 http://httpredir.debian.org jessie-backports/non-free armhf Packages/DiffIndex [8530 B]
Hit http://httpredir.debian.org jessie Release
Get:23 http://httpredir.debian.org jessie/main arm64 Packages [8593 kB]
Get:24 http://mirrors.digitalocean.com jessie-backports/main arm64 Packages [1115 kB]
Get:25 http://apt.armbian.com jessie/utils armhf Packages [7950 B]
Get:26 http://apt.armbian.com jessie/jessie-desktop armhf Packages [22.6 kB]
Get:27 http://httpredir.debian.org jessie/contrib arm64 Packages [41.2 kB]
Get:28 http://httpredir.debian.org jessie/non-free arm64 Packages [68.6 kB]
Get:29 http://httpredir.debian.org jessie/main armhf Packages [8898 kB]
Get:30 http://mirrors.digitalocean.com jessie-backports/main armhf Packages [1123 kB]
Get:31 http://httpredir.debian.org jessie/contrib armhf Packages [44.3 kB]
Get:32 http://httpredir.debian.org jessie/non-free armhf Packages [74.9 kB]
Fetched 21.2 MB in 21s (992 kB/s)
W: Failed to fetch http://security.debian.org/dists/jessie/updates/InRelease  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)
W: Failed to fetch https://repo.mosquitto.org/debian/dists/stretch/InRelease  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)
E: Some index files failed to download. They have been ignored, or old ones used instead.
Error executing command, exiting
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
nodejs
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
Need to get 0 B/12.9 MB of archives.
After this operation, 64.7 MB of additional disk space will be used.
Selecting previously unselected package nodejs.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 59764 files and directories currently installed.)
Preparing to unpack .../nodejs_8.15.1-1nodesource1_arm64.deb ...
Unpacking nodejs (8.15.1-1nodesource1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up nodejs (8.15.1-1nodesource1) ...
Version actuelle : v5.9.1
--50%
--60%
Installation...
alexa-remote-http@1.0.0 /var/www/html/plugins/alexaapi/resources
+-- alexa-cookie2@2.0.1
+-- cookie@0.3.1
+-- express@4.16.4
| +-- accepts@1.3.5
| | +-- mime-types@2.1.22
| | | `-- mime-db@1.38.0
| | `-- negotiator@0.6.1
| +-- array-flatten@1.1.1
| +-- body-parser@1.18.3
| | +-- bytes@3.0.0
| | +-- http-errors@1.6.3
| | +-- iconv-lite@0.4.23
| | | `-- safer-buffer@2.1.2
| | `-- raw-body@2.3.3
| +-- content-disposition@0.5.2
| +-- content-type@1.0.4
| +-- cookie-signature@1.0.6
| +-- debug@2.6.9
| | `-- ms@2.0.0
| +-- depd@1.1.2
| +-- encodeurl@1.0.2
| +-- escape-html@1.0.3
| +-- etag@1.8.1
| +-- finalhandler@1.1.1
| | `-- unpipe@1.0.0
| +-- fresh@0.5.2
| +-- merge-descriptors@1.0.1
| +-- methods@1.1.2
| +-- on-finished@2.3.0
| | `-- ee-first@1.1.1
| +-- parseurl@1.3.2
| +-- path-to-regexp@0.1.7
| +-- proxy-addr@2.0.4
| | +-- forwarded@0.1.2
| | `-- ipaddr.js@1.8.0
| +-- qs@6.5.2
| +-- range-parser@1.2.0
| +-- safe-buffer@5.1.2
| +-- send@0.16.2
| | +-- destroy@1.0.4
| | `-- mime@1.4.1
| +-- serve-static@1.13.2
| +-- setprototypeof@1.1.0
| +-- statuses@1.4.0
| +-- type-is@1.6.16
| | `-- media-typer@0.3.0
| +-- utils-merge@1.0.1
| `-- vary@1.1.2
+-- extend@3.0.2
+-- http-proxy-middleware@0.19.1
| +-- http-proxy@1.17.0
| | +-- eventemitter3@3.1.0
| | +-- follow-redirects@1.7.0
| | | `-- debug@3.2.6
| | |   `-- ms@2.1.1
| | `-- requires-port@1.0.0
| +-- is-glob@4.0.0
| | `-- is-extglob@2.1.1
| +-- lodash@4.17.11
| `-- micromatch@3.1.10
|   +-- arr-diff@4.0.0
|   +-- array-unique@0.3.2
|   +-- braces@2.3.2
|   | +-- arr-flatten@1.1.0
|   | +-- extend-shallow@2.0.1
|   | | `-- is-extendable@0.1.1
|   | +-- fill-range@4.0.0
|   | | +-- extend-shallow@2.0.1
|   | | +-- is-number@3.0.0
|   | | | `-- kind-of@3.2.2
|   | | |   `-- is-buffer@1.1.6
|   | | +-- repeat-string@1.6.1
|   | | `-- to-regex-range@2.1.1
|   | +-- isobject@3.0.1
|   | +-- repeat-element@1.1.3
|   | +-- snapdragon-node@2.1.1
|   | | +-- define-property@1.0.0
|   | | | `-- is-descriptor@1.0.2
|   | | |   +-- is-accessor-descriptor@1.0.0
|   | | |   `-- is-data-descriptor@1.0.0
|   | | `-- snapdragon-util@3.0.1
|   | |   `-- kind-of@3.2.2
|   | `-- split-string@3.1.0
|   +-- define-property@2.0.2
|   | `-- is-descriptor@1.0.2
|   |   +-- is-accessor-descriptor@1.0.0
|   |   `-- is-data-descriptor@1.0.0
|   +-- extend-shallow@3.0.2
|   | +-- assign-symbols@1.0.0
|   | `-- is-extendable@1.0.1
|   |   `-- is-plain-object@2.0.4
|   +-- extglob@2.0.4
|   | +-- define-property@1.0.0
|   | | `-- is-descriptor@1.0.2
|   | |   +-- is-accessor-descriptor@1.0.0
|   | |   `-- is-data-descriptor@1.0.0
|   | +-- expand-brackets@2.1.4
|   | | +-- define-property@0.2.5
|   | | +-- extend-shallow@2.0.1
|   | | `-- posix-character-classes@0.1.1
|   | `-- extend-shallow@2.0.1
|   +-- fragment-cache@0.2.1
|   | `-- map-cache@0.2.2
|   +-- kind-of@6.0.2
|   +-- nanomatch@1.2.13
|   | `-- is-windows@1.0.2
|   +-- object.pick@1.3.0
|   +-- regex-not@1.0.2
|   | `-- safe-regex@1.1.0
|   |   `-- ret@0.1.15
|   +-- snapdragon@0.8.2
|   | +-- base@0.11.2
|   | | +-- cache-base@1.0.1
|   | | | +-- collection-visit@1.0.0
|   | | | | +-- map-visit@1.0.0
|   | | | | `-- object-visit@1.0.1
|   | | | +-- get-value@2.0.6
|   | | | +-- has-value@1.0.0
|   | | | | `-- has-values@1.0.0
|   | | | |   `-- kind-of@4.0.0
|   | | | +-- set-value@2.0.0
|   | | | | `-- extend-shallow@2.0.1
|   | | | +-- to-object-path@0.3.0
|   | | | | `-- kind-of@3.2.2
|   | | | +-- union-value@1.0.0
|   | | | | `-- set-value@0.4.3
|   | | | |   `-- extend-shallow@2.0.1
|   | | | `-- unset-value@1.0.0
|   | | |   `-- has-value@0.3.1
|   | | |     +-- has-values@0.1.4
|   | | |     `-- isobject@2.1.0
|   | | +-- class-utils@0.3.6
|   | | | +-- arr-union@3.1.0
|   | | | +-- define-property@0.2.5
|   | | | `-- static-extend@0.1.2
|   | | |   +-- define-property@0.2.5
|   | | |   `-- object-copy@0.1.0
|   | | |     +-- copy-descriptor@0.1.1
|   | | |     +-- define-property@0.2.5
|   | | |     `-- kind-of@3.2.2
|   | | +-- component-emitter@1.2.1
|   | | +-- define-property@1.0.0
|   | | | `-- is-descriptor@1.0.2
|   | | |   +-- is-accessor-descriptor@1.0.0
|   | | |   `-- is-data-descriptor@1.0.0
|   | | +-- mixin-deep@1.3.1
|   | | | +-- for-in@1.0.2
|   | | | `-- is-extendable@1.0.1
|   | | `-- pascalcase@0.1.1
|   | +-- define-property@0.2.5
|   | | `-- is-descriptor@0.1.6
|   | |   +-- is-accessor-descriptor@0.1.6
|   | |   | `-- kind-of@3.2.2
|   | |   +-- is-data-descriptor@0.1.4
|   | |   | `-- kind-of@3.2.2
|   | |   `-- kind-of@5.1.0
|   | +-- extend-shallow@2.0.1
|   | +-- source-map@0.5.7
|   | +-- source-map-resolve@0.5.2
|   | | +-- atob@2.1.2
|   | | +-- decode-uri-component@0.2.0
|   | | +-- resolve-url@0.2.1
|   | | +-- source-map-url@0.4.0
|   | | `-- urix@0.1.0
|   | `-- use@3.1.1
|   `-- to-regex@3.0.2
+-- http-proxy-response-rewrite@0.0.1
| +-- bufferhelper@0.2.1
| `-- concat-stream@1.6.2
|   +-- buffer-from@1.1.1
|   +-- inherits@2.0.3
|   +-- readable-stream@2.3.6
|   | +-- core-util-is@1.0.2
|   | +-- isarray@1.0.0
|   | +-- process-nextick-args@2.0.0
|   | +-- string_decoder@1.1.1
|   | `-- util-deprecate@1.0.2
|   `-- typedarray@0.0.6
+-- https@1.0.0
`-- querystring@0.2.0
--95%
--100%
Installation des dépendances alexaapi terminée, vérifiez qu'il n'y a pas d'erreur