Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] PlayTTS : Jeedom parle et lit des fichiers

Pour échanger sur les plugins classés en catégorie "Multimédia"
Anonyme
Actif
Messages : 10082
Inscription : 09 août 2014, 12:15

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par Anonyme » 10 sept. 2016, 12:32

Contenu supprimé à la demande de son auteur

crinq
Timide
Messages : 20
Inscription : 24 févr. 2015, 23:05

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par crinq » 16 sept. 2016, 18:35

Salut à tous !

pour améliorer la qualité du son de la sortie jack du Pi, j'ai trouvé un driver audio expérimental mais qui marche du tonnerre ! Voici la procédure d'installation :
sudo apt-get install rpi-update
sudo rpi-update

dans /boot/config.txt , ajouter la ligne :
audio_pwm_mode=2

puis ensuite reboot :
sudo reboot now

Voilà ! L'amélioration est frappante ! Maintenant, j'arrive à faire parler mon Pi en SSH mais toujours pas avec le plugin PlayTTS et je n'ai pas la moindre idée de quoi faire, même après m'être tapé les 15 pages de ce fil... si vous avez une idée, je suis preneur !

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par zep57 » 16 sept. 2016, 19:10

magicgg91 a écrit :
zep57 a écrit :bonjour,
Quelqu'un peut nous donner la procédure pour régler la vitesse de lecture?
Merci
Tu peux faire 1 petit effort et lire les quelques messages au-dessus du tien je pense ;)
Merci
Je suis un très vieux ....
Tout fonctionne bien et sous putty je n'arrive pas a modifier la vitesse de lecture
A votre bon cœur,
Merci d'avance
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

Anonyme
Actif
Messages : 10082
Inscription : 09 août 2014, 12:15

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par Anonyme » 16 sept. 2016, 19:21

Contenu supprimé à la demande de son auteur

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par zep57 » 16 sept. 2016, 19:33

dom@jeedom:~ $ -ao alsa -speed 0.85
-bash: -ao: command not found
jeedom@jeedom:~ $
jeedom@jeedom:~ $ jeedom@jeedom:~ $ -ao alsa -speed 0.85
-bash: jeedom@jeedom:~: command not found
jeedom@jeedom:~ $ -bash: -ao: command not found
-bash: -bash:: command not found
jeedom@jeedom:~ $ jeedom@jeedom:~ $
-bash: jeedom@jeedom:~: command not found
jeedom@jeedom:~ $
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

Anonyme
Actif
Messages : 10082
Inscription : 09 août 2014, 12:15

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par Anonyme » 16 sept. 2016, 19:55

Contenu supprimé à la demande de son auteur

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par zep57 » 16 sept. 2016, 20:21

Merci beaucoup Guillaume (le prénom de mon fils aussi)
Regarde quand même ma signature ....
Quand tu aura 57 balais , plein de prothèses et un Alzheimer naissant!!!, tu sera aussi content quand quelqu'un te viens en aide.
Il faudrait mieux faire la doc pour les vieux C.. comme moi.
Et dire que je fait tout ça pour un autre plus jeune que moi de 3 semaines
MERCI encore
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

romainh41
Timide
Messages : 371
Inscription : 22 mars 2016, 10:21

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par romainh41 » 17 sept. 2016, 10:23

Slt à tous

j'ai installé hier soir une version raspian complète, avec interface graphique. Après quelques manip, le son est sorti sur une enceinte bluetooth... Donc bluetooth et Jessie ça fonctionne !

Je teste aujourd'hui la meme chose sur Jessie "lite"...

EDIT : pas d'intall sur Jessie Lite mais directement sur l'image Jeedom et verdict......

Avec quelques commandes en ligne, 5 minutes de boulot, le son sort de mon enceinte BT !

Après des jours et des heures a essayer des tonnes de commandes et paramétrages, en fait c'est tout simple. Je teste sur mon RI2 de prod et je vous redis si c'est également ok, mais y'a pas de raison !

enfin le BT fonctionne, alleluiaaaaaaaaaaaaaaa !!!!!!!!!!!!!!!!!!!!!!!!! :-)
Jeedom sur RPI 2 RAM 1Go - Clé GEN 5

Avatar de l’utilisateur
prohand
Timide
Messages : 139
Inscription : 26 mai 2015, 18:47
Localisation : Lyon
Contact :

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par prohand » 17 sept. 2016, 16:18

Bonjour,

J'ai essayé avec le mode deporté mais le son ne sort pas.
Les dépendances sur ma machine déporté se sont bien installées.
Le fichier .wav et .mp3 sont bien dans le /tmp de ma machine déportée.
Quand je fais cette commande :

Code : Tout sélectionner

 mplayer voice.wav
Aucun son ne sort et voici le résultat :

Code : Tout sélectionner

MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team
Cannot open file '/root/.mplayer/input.conf': No such file or directory
Failed to open /root/.mplayer/input.conf.
Cannot open file '/etc/mplayer/input.conf': No such file or directory
Failed to open /etc/mplayer/input.conf.

Playing voice.wav.
Detected file format: WAV / WAVE (Waveform Audio) (libavformat)
[lavf] stream 0: audio (pcm_s16le), -aid 0
Load subtitles in .
Selected audio codec: Uncompressed PCM [pcm]
AUDIO: 16000 Hz, 1 ch, s16le, 256.0 kbit/100.00% (ratio: 32000->32000)
AO: [pulse] Init failed: Connection refused
AO: [alsa] 48000Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   1.0 (01.0) of 1.1 (01.0)  0.1%
Il faut que je créer le fichier input.conf dans /etc/mplayer ?
Si oui il faut que je mette quoi ? Sachant qu'il s'agit d'une enceinte branché sur la prise Jack.

Merci.

EDIT : J'ai créer les fichiers input.conf et j'ai fais un apt-get install pulseaudio sur ma machine déporté.
J'ai plus que l'erreur suivante :

Code : Tout sélectionner

AO: [pulse] Init failed: Connection refused

Avatar de l’utilisateur
nonolerobot
Actif
Messages : 541
Inscription : 06 juin 2015, 12:15
Localisation : Rouen

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par nonolerobot » 20 sept. 2016, 23:13

crinq a écrit :Salut à tous !

pour améliorer la qualité du son de la sortie jack du Pi, j'ai trouvé un driver audio expérimental mais qui marche du tonnerre ! Voici la procédure d'installation :
sudo apt-get install rpi-update
sudo rpi-update

dans /boot/config.txt , ajouter la ligne :
audio_pwm_mode=2

puis ensuite reboot :
sudo reboot now

Voilà ! L'amélioration est frappante ! Maintenant, j'arrive à faire parler mon Pi en SSH mais toujours pas avec le plugin PlayTTS et je n'ai pas la moindre idée de quoi faire, même après m'être tapé les 15 pages de ce fil... si vous avez une idée, je suis preneur !
J'ai essayé et perso, je ne vois pas la différence...

EDIT : Ah si, il y a une petite différence que je n'entendais pas sur mon enceinte 1er prix. Il y a moins de souffle quand mplayer lit le fichier de pico TTS. C'est toujours bon à prendre.


Sinon, on arrive à ralentir la lecture du fichier audio avec MPLAYER mais est-il aussi possible de garder la même tonalité afin d'éviter la déformation de la voix ? Je suis Dj dans mon temps libre et mes platines et logiciels possèdent ce genre de fonction. Je ne sais pas si MPLAYER possède ce genre de fonction...

EDIT : trouvé : ajouter "-af scaletempo"
C'est inclus dans mon MPLAYER mais sinon il est disponible ici : https://sourceforge.net/projects/scaletempo/

Pour ceux qui rame :
Sans titre.png
Sans titre.png (443.34 Kio) Consulté 920 fois
Serveur domotique : Raspberry PI 3 + PI desktop + SSD mSata 30 Go + Onduleur
Contrôleur Zwave : Aeon Labs z-stick gen5
Logiciel : Jeedom 3.1.7
Modules Zwave : 39 devices (Düwi, Fibaro, Aeon Labs, Qubino, NeoCoolCam) dont 14 à piles

Gorgluk
Timide
Messages : 292
Inscription : 09 déc. 2014, 00:33
Localisation : paca

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par Gorgluk » 21 sept. 2016, 20:21

@nonolerobot,

merci, ça fonctionne super

si tu en as d'autres comme ça, n'hésites pas
DIY nuc | Jeedom sur Proxmox | Zwave Aeon Gen5, RFXtrx433E, X10 CM15, BT 4.0, Xiaomi

Gorgluk
Timide
Messages : 292
Inscription : 09 déc. 2014, 00:33
Localisation : paca

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par Gorgluk » 21 sept. 2016, 20:31

Bonsoir,

à ceux qui ont réussi à faire fonctionner une enceinte bluetooth...

Pensez-vous qu'il est possible d'envoyer le son simultanément à plusieurs enceintes bluetooth ?
Merci pour vos retours.
Dernière édition par Gorgluk le 27 sept. 2016, 21:16, édité 1 fois.
DIY nuc | Jeedom sur Proxmox | Zwave Aeon Gen5, RFXtrx433E, X10 CM15, BT 4.0, Xiaomi

Avatar de l’utilisateur
nonolerobot
Actif
Messages : 541
Inscription : 06 juin 2015, 12:15
Localisation : Rouen

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par nonolerobot » 21 sept. 2016, 21:59

Je viens enfin de réussir à connecter mon enceinte BT au raspberry pi 3 ! Je vous détaillerai ce que j'ai fais plus tard mais il y a des points à amélioré comme démarrer automatiquement pulseaudio et la connexion de l'enceinte BT au Raspberry car lors d'un reboot, il faut reconnecter l'enceinte et démarrer pulseaudio

J'arrive donc en ssh (en root) à faire parler mon enceinte :

Code : Tout sélectionner

pico2wave -l fr-FR -w test.wav "Jeedome : fermeture des volets" && mplayer test.wav
Cependant via Jeedom, je n'y arrive pas...

J'ai pensé à un problème de droits. J'ai ajouter l'utilisateur www-data dans le groupe Pulse, mais rien.
Si vous avez une idée car j'y suis presque.
Serveur domotique : Raspberry PI 3 + PI desktop + SSD mSata 30 Go + Onduleur
Contrôleur Zwave : Aeon Labs z-stick gen5
Logiciel : Jeedom 3.1.7
Modules Zwave : 39 devices (Düwi, Fibaro, Aeon Labs, Qubino, NeoCoolCam) dont 14 à piles

romainh41
Timide
Messages : 371
Inscription : 22 mars 2016, 10:21

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par romainh41 » 21 sept. 2016, 23:27

nonolerobot a écrit :Je viens enfin de réussir à connecter mon enceinte BT au raspberry pi 3 ! Je vous détaillerai ce que j'ai fais plus tard mais il y a des points à amélioré comme démarrer automatiquement pulseaudio et la connexion de l'enceinte BT au Raspberry car lors d'un reboot, il faut reconnecter l'enceinte et démarrer pulseaudio

J'arrive donc en ssh (en root) à faire parler mon enceinte :

Code : Tout sélectionner

pico2wave -l fr-FR -w test.wav "Jeedome : fermeture des volets" && mplayer test.wav
Cependant via Jeedom, je n'y arrive pas...

J'ai pensé à un problème de droits. J'ai ajouter l'utilisateur www-data dans le groupe Pulse, mais rien.
Si vous avez une idée car j'y suis presque.
j'en suis au même point sur RI2....
Jeedom sur RPI 2 RAM 1Go - Clé GEN 5

Avatar de l’utilisateur
nonolerobot
Actif
Messages : 541
Inscription : 06 juin 2015, 12:15
Localisation : Rouen

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par nonolerobot » 22 sept. 2016, 10:06

Voila où j'en suis dans ma connexion de l'enceinte BT :

J'utilise l'image Raspbian et non l'image Jeedom car je ne sais pas comment elle a été faite. Pour faire du lab, mieux partir sur l'image d'origine et neuf.

Code : Tout sélectionner

# MAJ
sudo apt-get update
sudo apt-get upgrade

# Installation des packages (Déjà présent dans la dernière version de raspbian)
sudo apt-get install pi-bluetooth
sudo apt-get install blueman pulseaudio pulseaudio-module-bluetooth


# Démarrer l’application de gestion audio
sudo pulseaudio -D

# Executer le gestionnaire bluetooth
sudo bluetoothctl
  power on
  scan on
  agent on
  default-agent
  pair **:**:**:**:**:**
  trust  **:**:**:**:**:**
  connect  **:**:**:**:**:**

# Test audio avec pico TTS
sudo pico2wave -l fr-FR -w test.wav "Ceci est un test audio" && mplayer test.wav -af scaletempo –ao alsa –speed 0.85
Serveur domotique : Raspberry PI 3 + PI desktop + SSD mSata 30 Go + Onduleur
Contrôleur Zwave : Aeon Labs z-stick gen5
Logiciel : Jeedom 3.1.7
Modules Zwave : 39 devices (Düwi, Fibaro, Aeon Labs, Qubino, NeoCoolCam) dont 14 à piles

johndoe2011
Timide
Messages : 266
Inscription : 22 févr. 2015, 20:20

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par johndoe2011 » 25 sept. 2016, 10:18

Croixamus a écrit :
m.georgein a écrit :Parmis les amateurs de VM, y'en a t il un qui à réussi à faire sortir le son de la VM ??? Personnellement je cale (et ce n'est la faute ni à Zola ni au Plugin visiblement)
Bonjour,
oui ca marche chez moi avec une carte son USB générique (de base) sous une VM Debian sur Esxi6
https://www.amazon.fr/SODIAL-Adaptateur ... te+son+usb
Avec dans "Option mplayer" du plugin = -ao alsa:device=hw=1.0
Cdt,
J'ai une VM sous ESXi 5.1 avec debian et la derniere version de Jeedom. Tout marche impec ....je souhaites installer le plugin PlayTTS via une carte son USB (avec le parametrage qui va bien sur la VM - idem celui que j'avais sous Homesser qui marchait au top ...juste un petit silence a mettre pour reveiller l'enceinte sans fil)
Je voulais avoir des retours sur l'utilisation sous VM ? Est ce que le plugin marche bien ?
Merci

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par zep57 » 26 sept. 2016, 15:43

Salut nonolerobot
j'ai mon enceinte bluetooth de connecté mais le son continue de sortir de la prise jacck!
Comment on change la sortie son?
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par zep57 » 26 sept. 2016, 17:56

magicgg91 a écrit :Bonjour à tous,

Pour ceux qui sont dans l'attente, voici 1 petit tuto pour configurer la sortie son sur 1 Raspberry Pi (testé et fonctionnel sur Pi 1, 2 et 3)
Bonjour Domopi,
J'ai mis le bazar en asseyant de brancher le bluetooth sur pi3
J'ai réinstallé mais ton lien est mort!
Pourrais tu le réactiver ?
Merci d'avance
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

Anonyme
Actif
Messages : 10082
Inscription : 09 août 2014, 12:15

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par Anonyme » 26 sept. 2016, 18:12

Contenu supprimé à la demande de son auteur

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: [Sujet officiel] PlayTTS : Jeedom parle et lit des fichi

Message par zep57 » 26 sept. 2016, 18:20

titeuf te remercie magicgg91
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

Répondre

Revenir vers « [Catégorie] Multimédia »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités