Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Plugin Tiers][Sujet Principal] Google Cast

Pour échanger sur les plugins classés en catégorie "Multimédia"
gjouguet
Timide
Messages : 9
Inscription : 28 févr. 2019, 15:50

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par gjouguet » 30 sept. 2019, 13:12

Viald a écrit :
29 sept. 2019, 18:10
J'ai trouvé mon problème. Ca se passe du coté de la config réseau. J'avais changé l'adresse IP privé de jeedom par son nom de domaine suite à l'installation d'un DNS local. Même si le fdqn répond bien, il semblerait que ca ne plaise pas à Jeedom. J'ai remis l'IP privé et tout est revenu dans l'ordre.
Malheureusement moi pas la config réseau est bonne je n'arrive pas a comprendre le problème

NICO77720
Timide
Messages : 10
Inscription : 26 mai 2017, 19:33

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par NICO77720 » 01 oct. 2019, 19:34

Bonsoir,
Savez-vous si le plugin fonctionne avec Jeedom Smart ?
Je ne parviens pas à lancer les dépendances.
J'ai testé le stable et le béta et j'ai toujours les mêmes erreurs dans le log. Mais aucune idée de ce qu'il faut faire.
Bonne soirée à tous
Pièces jointes
Log googlecast_update.txt
Log
(24.36 Kio) Téléchargé 21 fois

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1386
Inscription : 20 oct. 2015, 17:32

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par Jeandhom » 01 oct. 2019, 20:32

Il faut migrer vers Stretch.

NICO77720
Timide
Messages : 10
Inscription : 26 mai 2017, 19:33

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par NICO77720 » 01 oct. 2019, 21:19

Ok merci, j'hésite encore pour Stretch vu mon niveau. Je vais déjà voir pour une bonne clef USB et après je me lancerai.
A+

temium62
Timide
Messages : 167
Inscription : 30 avr. 2019, 10:31

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par temium62 » 01 oct. 2019, 21:48

salut
pareil que vous, sans avoir modifié quoi que ce soit, plus de voix, la commande se lance car j entends le bip bip , sur l ecran j ai une indication tts puis l icone cast mais ensuite rie, ça reste muet !
j ai fait une reinstallation des dépendances, ca n a rien changé
Intel Z8530 2Go Ram, 64 Go SSD
Controleur ZWave+ Aeon Labs Gen5 / 2 Gateway Xiaomi V2 / capteurs ouverture et sonde température Xiaomi / RfxCom + Porte motorisée RTS /5 Shutter 3 / Aspirateur Xiaomi Vacuum /Smart Display Lenovo + Google Home Mini

NICO77720
Timide
Messages : 10
Inscription : 26 mai 2017, 19:33

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par NICO77720 » 04 oct. 2019, 20:41

Bonsoir à tous !
J'ai une petite question pour les pros. Je viens de tester le plugin après changement de l'OS de Jeedom smart. Il fonctionne parfaitement.
En revanche j'ai fais un scénario comme suit : Si une personne ouvre le portillon avec le bouton 1 de la télécommande, alors mon google home prononce une phrase et le chrome cast affiche l'image d'un portail sur la TV.
Problème, le scénario ne fonctionne qu'une fois pour la chrome cast (sans erreur). Il faut que depuis le plugin, sur le chrome cast, je test un son (ou une autre fonction) pour que le scénario fonctionne à nouveau une fois.
Pourriez vous me dire d'où vient mon erreur svp.

Voici le programme (RAS coté log) :
- Nom du scénario : Activation de la prise de commande portillon
- Objet parent : Garage
- Mode du scénario : provoke
- Evènement : #[Garage][Télécommande portillon][bt1]#

Activation de la prise DIO pour ouverture du portillon


SI #[Garage][Télécommande portillon][bt1]# == 1
ALORS
#[Garage][Prise activation portillon][On]# - Options : {"enable":"1","background":"0"}
#[Garage][Prise activation portillon][Off]# - Options : {"enable":"1","background":"0"}
#[Salon][Google Home Salon][Parle !]# - Options : {"enable":"1","background":"0","title":"","message":"Attention. Le portillon extairieur est ouvert"}
#[Aucun][Chomecast Salon][Custom Cmd]# - Options : {"enable":"1","background":"0","title":"","message":"app=web|cmd=load_url|value='https:\/\/www.aj-automatisme.com\/page\/accueil_1.jpg',True,10"}
SINON

Merci à tous.

temium62
Timide
Messages : 167
Inscription : 30 avr. 2019, 10:31

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par temium62 » 11 oct. 2019, 18:33

Hello
Chez moi ca semble être de nouveau opérationnel.
Intel Z8530 2Go Ram, 64 Go SSD
Controleur ZWave+ Aeon Labs Gen5 / 2 Gateway Xiaomi V2 / capteurs ouverture et sonde température Xiaomi / RfxCom + Porte motorisée RTS /5 Shutter 3 / Aspirateur Xiaomi Vacuum /Smart Display Lenovo + Google Home Mini

cpatrice95
Timide
Messages : 5
Inscription : 19 févr. 2019, 16:18

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par cpatrice95 » 12 oct. 2019, 19:04

Bonjour à tous,
j'utilise le plugin Google Cast depuis environ 5 mois.
Il fonctionne correctement et je fait parler ma Jeedom avec ma Google Home dans tous mes scénarios.
Cela fonctionne bien encore aujourd'hui mais depuis environ 3 mois les interactions avec la Google Home ne fonctionnent plus.

Voici le message de la Google Home après avoir dit:
"parler à jeedom"

Réponse de la Google Home:
"Pas de problème !
Je vous mets en relation avec Jeedom.
Erreur votre le serveur de configuration n'a pas répondu correctement.
Merci d'aller voir la documentation code 500. Autre chose ?"

J'ai ouvert un ticket (le 9 Août, puis le 4 Septembre puis le 28 Septembre) dans l'onglet demande de support de la Jeedom mais j'ai uniquement reçu un mail qui me confirme que ma demande a été envoyée au développeur du plugin tierce.
N'ayant aucune réponse à ce jour, je me tourne vers ce forum qui j'espère pourra m'aider.

Cordialement.
Patrice
Cordialement
cpatrice95

Jeedom Smart Z + RFP1000 pour remplacer une Zibase qui s'est arrêtée en Mars 2019. Périphériques: OWL CM160, OREGON THGR122NX, Google Home.

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par Mips2648 » 13 oct. 2019, 17:45

Ce que tu décris est l'usage du plugin dialog flow (plugin officiel), pas google cast.
Tu dois ouvrir un ticket sur ce plugin.

Question bête: t'as payé l'abonnement ? ca fait environ 3 mois que jeedom a rendu payant l'usage de dialog flow et google home
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Rvitch
Actif
Messages : 683
Inscription : 21 juin 2016, 10:31

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par Rvitch » 13 oct. 2019, 22:02

Juste pour faire un retour a ceux qui ont des soucis pour faire parler Google home alors que les dépendances et le plug-in est ok...
Faites un reboot de la Google home, ça résoudra le problème.

Envoyé de mon Mi 9 SE en utilisant Tapatalk


Uwe Von B
Timide
Messages : 7
Inscription : 27 janv. 2019, 17:28

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par Uwe Von B » 15 oct. 2019, 10:04

Idem chez moi, le TTS ne fonctionne plus depuis le migration de Jeedom de mon Raspberry vers la Freebox Delta.

Avatar de l’utilisateur
sbr
Timide
Messages : 70
Inscription : 28 janv. 2018, 02:16

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par sbr » 16 oct. 2019, 00:33

Hello,

Est-ce que vous arrivez à récupérer/tester le cast spotify avec le wp_spotify_token, car pour ma part, impossible de trouver un token valide. J'ai cherché dans les traces/cookies/... des requêtes du site et du player spotify, rien !!

J'ai pourtant un token valide que j'utilise avec l'API spotify connect, mais il ne fonctionne pas sur spotify via cast !!

Ou trouver de la doc la dessus ?

Merci :-) ++

cpatrice95
Timide
Messages : 5
Inscription : 19 févr. 2019, 16:18

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par cpatrice95 » 19 oct. 2019, 18:15

Mips2648 a écrit :
13 oct. 2019, 17:45

Ce que tu décris est l'usage du plugin dialog flow (plugin officiel), pas google cast.
Tu dois ouvrir un ticket sur ce plugin.

Question bête: t'as payé l'abonnement ? ca fait environ 3 mois que jeedom a rendu payant l'usage de dialog flow et google home


Bonjour,
en effet j'ai réinstallé le plugin dialogflow en payant une abonnement sur 12 mois.
Maintenant quand je dit à ma GH: OK Google Parler à jeedom"
j'ai le message suivant:
" Vous n'etes pas autorisé à effectuer cette action. Clef API invalide. Merci de corriger la clef API sur votre page profils du market et d'attendre 24h avant de réessayer."

Je ne trouve pas ou je dois mettre le clef API 'je suppose que c'est celle du plugin dialogflow ?) mais ou dans le market ?

Merci de votre aide.
Cordialement.
Cordialement
cpatrice95

Jeedom Smart Z + RFP1000 pour remplacer une Zibase qui s'est arrêtée en Mars 2019. Périphériques: OWL CM160, OREGON THGR122NX, Google Home.

PHDB
Timide
Messages : 298
Inscription : 01 mars 2016, 13:42

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par PHDB » 20 oct. 2019, 18:51

Bonjour

le pljugin est-il comptatible php 7.3?

Merci!

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par mortyre » 21 oct. 2019, 20:00

oui pas de pb sous buster en V4
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

mccyrille
Timide
Messages : 90
Inscription : 22 nov. 2015, 09:40

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par mccyrille » 21 oct. 2019, 20:53

Bonjour

Je suis en v4 sur install propre, et je n'arrive pas à faire du TTS. Quand j'installe les dépendances, j'ai une erreur car il manque ffmpeg.

Sous buster à priori ce n'est pas inclu d'origine. Il faudrait que google cast soit mis à jour ou prenne en compte ça ?

Voici mes logs d'installation de dépenance :

Code : Tout sélectionner

Launch install of googlecast dependancies
-- Updating repo...
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://ftp.fr.debian.org/debian buster InRelease
Hit:3 http://ftp.fr.debian.org/debian buster-updates InRelease
Reading package lists...
-- Installation of python3 and dependancies
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.6).
python-dev is already the newest version (2.7.16-1).
python3 is already the newest version (3.7.3-1).
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
-- Installed version of Python :
Python 3.7.3
-- Installation of pip for python3 and necessary libraries
Reading package lists...
Building dependency tree...
Reading state information...
python3-pip is already the newest version (18.1-5).
python3-dev is already the newest version (3.7.3-1).
python-requests is already the newest version (2.21.0-1).
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
-- Installation of TTS libraries
Reading package lists...
Building dependency tree...
Reading state information...
sox is already the newest version (14.4.2+git20190427-1).
libttspico-utils is already the newest version (1.0+git20130326-9).
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
-- Installation of libav/ffmpeg libraries
Reading package lists...
Building dependency tree...
Reading state information...
Package libav-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
ffmpeg
E: Package 'libav-tools' has no installation candidate
-- Upgrade setuptools with command pip3 if not up to date
Requirement already satisfied: setuptools in /usr/local/lib/python3.7/dist-packages (41.4.0)
-- Installed version of pip :
pip 18.1 from /usr/lib/python3/dist-packages/pip (python 3.7)
-- Installation of python library 'netifaces' with command pip3
Requirement already satisfied: netifaces in /usr/local/lib/python3.7/dist-packages (0.10.9)
-- Installation of python library 'requests' with command pip3
Requirement already satisfied: requests in /usr/lib/python3/dist-packages (2.21.0)
-- Installation of python library 'protobuf' with command pip3
Requirement already satisfied: protobuf in /usr/local/lib/python3.7/dist-packages (3.9.1)
Requirement already satisfied: setuptools in /usr/local/lib/python3.7/dist-packages (from protobuf) (41.4.0)
Requirement already satisfied: six>=1.9 in /usr/lib/python3/dist-packages (from protobuf) (1.12.0)
-- Installation of python library 'zeroconf' with command pip3
Requirement already satisfied: zeroconf in /usr/local/lib/python3.7/dist-packages (0.23.0)
Requirement already satisfied: ifaddr in /usr/local/lib/python3.7/dist-packages (from zeroconf) (0.1.6)
-- Installation of python library 'click, bs4 and six' for TTS with command pip3
Requirement already satisfied: click in /usr/local/lib/python3.7/dist-packages (7.0)
Requirement already satisfied: bs4 in /usr/local/lib/python3.7/dist-packages (0.0.1)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (1.12.0)
Requirement already satisfied: beautifulsoup4 in /usr/local/lib/python3.7/dist-packages (from bs4) (4.8.0)
Requirement already satisfied: soupsieve>=1.2 in /usr/local/lib/python3.7/dist-packages (from beautifulsoup4->bs4) (1.9.3)
-- Installation of python library 'tqdm, websocket-client' for plex with command pip3
Requirement already satisfied: tqdm in /usr/local/lib/python3.7/dist-packages (4.36.1)
Requirement already satisfied: websocket-client in /usr/local/lib/python3.7/dist-packages (0.56.0)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from websocket-client) (1.12.0)
-- Installation of dependencies is done !

mccyrille
Timide
Messages : 90
Inscription : 22 nov. 2015, 09:40

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par mccyrille » 21 oct. 2019, 20:58

J'ai résolu le problème en lancant simplement ffmpeg :

sudo apt -y install ffmpeg

mais idéalement, si ça pouvait être pris en compte pour les autres :)

PHDB
Timide
Messages : 298
Inscription : 01 mars 2016, 13:42

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par PHDB » 25 oct. 2019, 10:04

Bonjour,

je suis en train de migrer de Mini+ jessie vers RPI 3B+ avec SSD (stretch).
J’ai restaure ma sauvegarde et j’ai encore quelques plugins qui ne sont pas ok dont googlecast

Mes dependances sont marquees ok mais en lisant le log ca n’a pas si ok que ca
Notamment sur libavcodec57 et aussi “Installation of python library ‘click, bs4 and six’ for TTS with command pip3”

Code : Tout sélectionner

Launch install of googlecast dependancies
-- Updating repo...
Réception de:1 http://archive.raspberrypi.org/debian stretch InRelease [25,4 kB]
Atteint:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
25,4 ko réceptionnés en 1s (22,6 ko/s)
Lecture des listes de paquets…
-- Installation of python3 and dependancies
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential is already the newest version (12.3).
python-dev is already the newest version (2.7.13-2).
python-dev passé en « installé manuellement ».
python3 is already the newest version (3.5.3-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
-- Installed version of Python :
Python 3.5.3
-- Installation of pip for python3 and necessary libraries
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
python-requests is already the newest version (2.12.4-1).
python3-dev is already the newest version (3.5.3-1).
python3-pip is already the newest version (9.0.1-2+rpt2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
-- Installation of TTS libraries
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
sox is already the newest version (14.4.1-5+deb9u2).
libttspico-utils is already the newest version (1.0+git20130326-5).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
-- Installation of libav/ffmpeg libraries
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
libav-tools is already the newest version (7:3.2.14-1~deb9u1+rpt1).
Les paquets suivants seront ENLEVÉS :
libavcodec57
Les NOUVEAUX paquets suivants seront installés :
libavcodec-extra libavcodec-extra57
0 mis à jour, 2 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 4 229 ko dans les archives.
Après cette opération, 105 ko d'espace disque supplémentaires seront utilisés.
Réception de:1 http://archive.raspberrypi.org/debian stretch/main armhf libavcodec-extra57 armhf 7:3.2.14-1~deb9u1+rpt1 [4 169 kB]
Réception de:2 http://archive.raspberrypi.org/debian stretch/main armhf libavcodec-extra all 7:3.2.14-1~deb9u1+rpt1 [60,0 kB]
debconf: Impossible d'initialiser l'interface : Dialog
debconf: (L'interface dialog ne fonctionnera pas avec un terminal rustique (« dumb »), un tampon shell d'Emacs ou sans terminal de contrôle.)
debconf: Utilisation de l'interface Readline en remplacement
debconf: Impossible d'initialiser l'interface : Readline
debconf: (Cette interface a besoin d'un terminal de contrôle.)
debconf: Utilisation de l'interface Teletype en remplacement
dpkg-preconfigure: impossible de réouvrir stdin :
4 229 ko réceptionnés en 5s (810 ko/s)
dpkg: libavcodec57:armhf : problème de dépendance, mais suppression comme demandé :
vlc-plugin-base:armhf dépend de libavcodec57 (>= 7:3.2.14) | libavcodec-extra57 (>= 7:3.2.14) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
libavformat57:armhf dépend de libavcodec57 (>= 7:3.2.14) | libavcodec-extra57 (>= 7:3.2.14) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
ffmpeg dépend de libavcodec57 (>= 7:3.2.14) | libavcodec-extra57 (>= 7:3.2.14) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
vlc-plugin-video-output:armhf dépend de libavcodec57 (>= 7:3.2.14) | libavcodec-extra57 (>= 7:3.2.14) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
libopencv-highgui2.4-deb0:armhf dépend de libavcodec57 (>= 7:3.2.4) | libavcodec-extra57 (>= 7:3.2.4) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
omxplayer dépend de libavcodec57 (>= 7:3.2.14) | libavcodec-extra57 (>= 7:3.2.14) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
libavfilter6:armhf dépend de libavcodec57 (>= 7:3.2.14) | libavcodec-extra57 (>= 7:3.2.14) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
libchromaprint1:armhf dépend de libavcodec57 (>= 7:3.2.2) | libavcodec-extra57 (>= 7:3.2.2) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
libavdevice57:armhf dépend de libavcodec57 (>= 7:3.2.14) | libavcodec-extra57 (>= 7:3.2.14) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
gstreamer1.0-libav:armhf dépend de libavcodec57 (>= 7:3.2.4) | libavcodec-extra57 (>= 7:3.2.4) ; cependant :
Le paquet libavcodec57:armhf doit être supprimé.
Le paquet libavcodec-extra57 n'est pas installé.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 94339 fichiers et répertoires déjà installés.)
Suppression de libavcodec57:armhf (7:3.2.14-1~deb9u1+rpt1) ...
Sélection du paquet libavcodec-extra57:armhf précédemment désélectionné.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 94332 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libavcodec-extra57_7%3a3.2.14-1~deb9u1+rpt1_armhf.deb ...
Dépaquetage de libavcodec-extra57:armhf (7:3.2.14-1~deb9u1+rpt1) ...
Sélection du paquet libavcodec-extra précédemment désélectionné.
Préparation du dépaquetage de .../libavcodec-extra_7%3a3.2.14-1~deb9u1+rpt1_all.deb ...
Dépaquetage de libavcodec-extra (7:3.2.14-1~deb9u1+rpt1) ...
Paramétrage de libavcodec-extra57:armhf (7:3.2.14-1~deb9u1+rpt1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u4) ...
Paramétrage de libavcodec-extra (7:3.2.14-1~deb9u1+rpt1) ...
-- Upgrade setuptools with command pip3 if not up to date
Requirement already satisfied: setuptools in /usr/local/lib/python3.5/dist-packages
-- Installed version of pip :
pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.5)
-- Installation of python library 'netifaces' with command pip3
Collecting netifaces
Downloading https://www.piwheels.org/simple/netifaces/netifaces-0.10.9-cp35-cp35m-linux_armv7l.whl (40kB)
Installing collected packages: netifaces
Successfully installed netifaces-0.10.9
-- Installation of python library 'requests' with command pip3
Requirement already satisfied: requests in /usr/lib/python3/dist-packages
-- Installation of python library 'protobuf' with command pip3
Collecting protobuf
Downloading https://files.pythonhosted.org/packages/ad/c2/86c65136e280607ddb2e5dda19e2953c1174f9919b557d1d154574481de4/protobuf-3.10.0-py2.py3-none-any.whl (434kB)
Requirement already satisfied: six>=1.9 in /usr/lib/python3/dist-packages (from protobuf)
Requirement already satisfied: setuptools in /usr/local/lib/python3.5/dist-packages (from protobuf)
Installing collected packages: protobuf
Successfully installed protobuf-3.10.0
-- Installation of python library 'zeroconf' with command pip3
Collecting zeroconf
Downloading https://files.pythonhosted.org/packages/c0/1a/b594e55ed85942789ceb4233f8cbca946873be5f77a02c1c75ef6944e6fe/zeroconf-0.23.0-py3-none-any.whl
Collecting ifaddr (from zeroconf)
Downloading https://www.piwheels.org/simple/ifaddr/ifaddr-0.1.6-py3-none-any.whl
Installing collected packages: ifaddr, zeroconf
Successfully installed ifaddr-0.1.6 zeroconf-0.23.0
-- Installation of python library 'click, bs4 and six' for TTS with command pip3
Exception:
Traceback (most recent call last):
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connection.py", line 138, in _new_conn
(self.host, self.port), self.timeout, **extra_kw)
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/util/connection.py", line 75, in create_connection
for res in socket.getaddrinfo(host, port, family, socket.SOCK_STREAM):
File "/usr/lib/python3.5/socket.py", line 733, in getaddrinfo
for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno -3] Échec temporaire dans la résolution du nom
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 594, in urlopen
chunked=chunked)
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 350, in _make_request
self._validate_conn(conn)
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 837, in _validate_conn
conn.connect()
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connection.py", line 281, in connect
conn = self._new_conn()
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connection.py", line 147, in _new_conn
self, "Failed to establish a new connection: %s" % e)
requests.packages.urllib3.exceptions.NewConnectionError: <requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7598a2d0>: Failed to establish a new connection: [Errno -3] Échec temporaire dans la résolution du nom
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/pip/basecommand.py", line 215, in main
status = self.run(options, args)
File "/usr/lib/python3/dist-packages/pip/commands/install.py", line 353, in run
wb.build(autobuilding=True)
File "/usr/lib/python3/dist-packages/pip/wheel.py", line 749, in build
self.requirement_set.prepare_files(self.finder)
File "/usr/lib/python3/dist-packages/pip/req/req_set.py", line 380, in prepare_files
ignore_dependencies=self.ignore_dependencies))
File "/usr/lib/python3/dist-packages/pip/req/req_set.py", line 620, in _prepare_file
session=self.session, hashes=hashes)
File "/usr/lib/python3/dist-packages/pip/download.py", line 821, in unpack_url
hashes=hashes
File "/usr/lib/python3/dist-packages/pip/download.py", line 659, in unpack_http_url
hashes)
File "/usr/lib/python3/dist-packages/pip/download.py", line 853, in _download_http_url
stream=True,
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 501, in get
return self.request('GET', url, **kwargs)
File "/usr/lib/python3/dist-packages/pip/download.py", line 386, in request
return super(PipSession, self).request(method, url, *args, **kwargs)
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 488, in request
resp = self.send(prep, **send_kwargs)
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 609, in send
r = adapter.send(request, **kwargs)
File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/adapter.py", line 47, in send
resp = super(CacheControlAdapter, self).send(request, **kw)
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/adapters.py", line 423, in send
timeout=timeout
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 643, in urlopen
_stacktrace=sys.exc_info()[2])
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/util/retry.py", line 315, in increment
total -= 1
TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'
Requirement already satisfied: click in /usr/lib/python3/dist-packages
Collecting bs4
Downloading https://www.piwheels.org/simple/bs4/bs4-0.0.1-py3-none-any.whl
Requirement already satisfied: six in /usr/lib/python3/dist-packages
Collecting beautifulsoup4 (from bs4)
-- Installation of python library 'tqdm, websocket-client' for plex with command pip3
Collecting tqdm
Downloading https://files.pythonhosted.org/packages/e1/c1/bc1dba38b48f4ae3c4428aea669c5e27bd5a7642a74c8348451e0bd8ff86/tqdm-4.36.1-py2.py3-none-any.whl (52kB)
Collecting websocket-client
Downloading https://files.pythonhosted.org/packages/29/19/44753eab1fdb50770ac69605527e8859468f3c0fd7dc5a76dd9c4dbd7906/websocket_client-0.56.0-py2.py3-none-any.whl (200kB)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from websocket-client)
Installing collected packages: tqdm, websocket-client
Successfully installed tqdm-4.36.1 websocket-client-0.56.0
-- Installation of dependencies is done !
Dans le log googlecast_local j’ai tout le temps

Code : Tout sélectionner

File "/var/www/html/plugins/googlecast/resources/gtts/lang.py", line 2, in <module>
from bs4 import BeautifulSoup
ImportError: No module named 'bs4’
qui s’empile.

Des idees pour resoudre le souci?

Heracles44
Actif
Messages : 538
Inscription : 23 juil. 2018, 13:06

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par Heracles44 » 27 oct. 2019, 22:25

bonjour,
pouvez vous mettre les images du Nest Hub et Nest Hub Max svp? Ainsi que du JBL Link 10 et JBL Link 20 dans le plugin?
merci

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: [Plugin Tiers][Sujet Principal] Google Cast

Message par mortyre » 29 oct. 2019, 09:36

Tu peux les ajouter toit meme en modifiant un seul fichier, j'ai indiqué la procédure sur un post dans ce thread
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

Répondre

Revenir vers « [Catégorie] Multimédia »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité