Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Pour échanger sur les plugins classés en catégorie "Nature"
rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 03 juin 2017, 22:26

damstrib a écrit :
03 juin 2017, 21:34
hello,
je viens de voir sur Jeedom que tu as produit une nouvelle version. cool. Pas contre lorsqu je télécharge via le market, il m'installe toujours la version du "2017-03-18 21:59:45". Il doit manquer une action de plublication sans doute.
Peux tu regarder ?

Merci en tout cas.
cdlt
Damien
Je l'ai publié à nouveau, en vérifiant la version beta et la version stable, ca devrait être bon.

damstrib
Timide
Messages : 3
Inscription : 24 mai 2017, 12:51

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par damstrib » 21 juil. 2017, 23:50

Bonjour,
encore moi, désolé :-)
Je suis super content de ce plugin! A tel point que je commence à avoir des mi plant un peu éloignés et je pense m'orienté vers le mode déporté.
Question : est il possible que le plugin récupère les infos de miplant en direct lorsqu'ils sont à portée et via un rebond lorsu'ils sont éloignés ?
Est ce configurable par équipement quelque part, je n'ai pas trouvé dans les écrans ?

Dans tous les cas : bonnes vacances!!
Damien

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 23 juil. 2017, 22:50

damstrib a écrit :
21 juil. 2017, 23:50
Bonjour,
encore moi, désolé :-)
Je suis super content de ce plugin! A tel point que je commence à avoir des mi plant un peu éloignés et je pense m'orienté vers le mode déporté.
Question : est il possible que le plugin récupère les infos de miplant en direct lorsqu'ils sont à portée et via un rebond lorsu'ils sont éloignés ?
Est ce configurable par équipement quelque part, je n'ai pas trouvé dans les écrans ?

Dans tous les cas : bonnes vacances!!
Damien
Bonsoir,

Je n ai pas prévu ce mode, car ca me semblait compliqué à parametrer. J'ai prevu le deporté pour le cas ou le device jeedom n'a pas de bluetooth ou pour le cas ou il est deja pris par le flower power (mon cas en fait)
Pour étendre, j'utilise jeedom link avec des raspberry, chaque jeedom gere ses MiFlora et par link tu peux tous les centraliser sur un jeedom pour tes scenarios. J'ai mon jeedom central et un autre pres du jardin juste pour gerer les miflora.

C'etait en fait le comportement de ma toute premiere version parce que c'etait plus simple pour un premier jet mais c'est vraiment galere de dupliquer toutes les infos pour ceux qui n'en ont pas besoin.

René.

Florent054
Timide
Messages : 50
Inscription : 22 juin 2017, 07:03

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Florent054 » 17 déc. 2017, 16:50

Bonjour a tous,

J'ai un petit probleme avec mon Xiaomi mi plant, il fonctionnait jusque la mais depuis quelques jour il ne communique plus avec mon jeedom...
J'ai le message d'erreur "Miflora No route to host (113)" et "gattool ne répond pas"
soyez indulgent je suis plein de bonne volonté mais galère un peu dans les termes :oops:

Avec putty:

Image

Quelq'un peut me remettre sur les rails??? Merci!

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 17 déc. 2017, 18:48

Bonsoir,

Le probleme n'est pas sur le plugin. Tu as un probleme avec le bluetooth de ton Jeedom.
As tu installé un autre plugin avec des dependences bluetooth ? Modifie le systeme d'une maniere ou d'une autre ?

Tu peux regarder dans dmesg s'il y a des messages (dmesg|grep -i Blue)
essayer hciconfig (sudo hciconfig hci0 down; sudo hciconfig hci0 up)

Il faut que la commande gatttool fonctionne:
* gatttool -b <macAddMiFlora> --char-read -a 0x038
* Characteristic value/descriptor: 3d 10 32 2e 36 2e 32

René

Hopper
Helper
Messages : 26
Inscription : 17 févr. 2016, 00:12

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Hopper » 18 déc. 2017, 00:27

J'avais l'erreur suivante avec mon MiFlora :

Code : Tout sélectionner

  # python /var/www/html/plugins/MiFlora/3rparty/getMiFloraData.py "C4:7C:8D:65:61:75" 2.7.0 1 hc1 high
       connect error: Connection refused (111)
       ('Error ', 1, ' from gatttool (', '', ')')
  # gatttool --device=hci0 -b C4:7C:8D:65:61:75 --char-read -a 0x38 --sec-level=high
       connect error: Connection refused (111)
Je n'ai pas trouvé la solution ici mais là « https://openclassrooms.com/forum/sujet/ ... -connecter » :
J'ai resolu mon problème en désactivant un plugin réputé instable : pnat.
Dans /etc/bluetooth/main.conf, faut ajouter DisablePlugins=pnat
Et cela fonctionnait parfaitement après :

Code : Tout sélectionner

  # python  /var/www/html/plugins/MiFlora/3rparty/getMiFloraData.py "C4:7C:8D:65:61:75" 2.7.0 1 hc1 high
       ('MI_TEMPERATURE=', 15.2)
       ('MI_MOISTURE=', 64)
       ('MI_LIGHT=', 79)
       ('MI_CONDUCTIVITY=', 830)
       ('read_ble:', [152, 0, 0, 79, 0, 0, 0, 64, 62, 3, 2, 60, 0, 251, 52, 155])
  # gatttool --device=hci1 -b C4:7C:8D:65:61:75 --char-read -a 0x38 --sec-level=high
       Characteristic value/descriptor: 64 15 32 2e 37 2e 30 

NB : par contre, la commande "gatttool" fonctionne avec 0x38 mais pas 0x35.

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Fabrice » 18 déc. 2017, 07:09

Merci pour la solution :
- A noter, il semble que cela soit une spécificité à faire sur les Raspberry PI

https://stackoverflow.com/questions/313 ... ns-pnat-do
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Hopper
Helper
Messages : 26
Inscription : 17 févr. 2016, 00:12

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Hopper » 18 déc. 2017, 07:59

Je pensais aussi mais cela a fonctionné sur mon Lenovo Yoga 300-11BY sous Ubuntu 16.04.




rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 25 déc. 2017, 21:46

Hopper a écrit :
18 déc. 2017, 00:27
NB : par contre, la commande "gatttool" fonctionne avec 0x38 mais pas 0x35.
Oui, dans les versions > 2.6.2 il faut envoyer 2 gatttool rapidement pour lire le 0x35
Voici une explication récente du fonctionnement de MiFlora: https://www.fanjoe.be/?p=2741
Dans ce plug-in, je suis aligné sur ce post sauf pour la temperature et l'ensoleillement pour lequel j'utilise 2 octets pour les mesures contrairement a ce qui est indique dans ce post, je ne sais pas quelle est la doc correcte. Je ne vois pas l'interêt de coder la temperature sur plus de 2 octets, la sonde va fondre avant (3276 degrés) !

videohone
Timide
Messages : 61
Inscription : 29 janv. 2017, 18:14

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par videohone » 29 janv. 2018, 07:03

Bonjour, je compte acheter un Xiaomi Mi Plant Flowers.
Est ce qu il fonctionne toujours sous jeedom?
Merci d'avance

Avatar de l’utilisateur
nakor
Timide
Messages : 106
Inscription : 25 nov. 2015, 10:39

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par nakor » 05 févr. 2018, 18:59

Salut videohone. Sous blea il fonctionne, sous ce plugin spécifique je ne sais pas je n'ai pas encore essayé, je me demandais ce qu'il ajoutait de plus par rapport à blea. Un lien avec les infos plantes type taux d'humidité à maintenir peut-être ?

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 05 févr. 2018, 19:06

nakor a écrit :Salut videohone. Sous blea il fonctionne, sous ce plugin spécifique je ne sais pas je n'ai pas encore essayé, je me demandais ce qu'il ajoutait de plus par rapport à blea. Un lien avec les infos plantes type taux d'humidité à maintenir peut-être ?
J ai créé ce plugin avant BLEA, il est utile si vous avez seulement des miflora à gérer en BLE. Il fonctionne toujours et n a pas de dépendances.

René


Envoyé de mon iPhone en utilisant Tapatalk

Swatmorpheus
Actif
Messages : 919
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Swatmorpheus » 05 févr. 2018, 19:13

Florent054 a écrit :
17 déc. 2017, 16:50
Bonjour a tous,

J'ai un petit probleme avec mon Xiaomi mi plant, il fonctionnait jusque la mais depuis quelques jour il ne communique plus avec mon jeedom...
J'ai le message d'erreur "Miflora No route to host (113)" et "gattool ne répond pas"
soyez indulgent je suis plein de bonne volonté mais galère un peu dans les termes :oops:

Avec putty:

Image

Quelq'un peut me remettre sur les rails??? Merci!
As tu résolue ton pb de BT ? si non essaye

Code : Tout sélectionner

sudo systemctl enable hciuart
sudo systemctl start hciuart
et réessaye

Code : Tout sélectionner

bluetoothctl
et

Code : Tout sélectionner

power on
Prod: jeedom V3.2.12 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
AppleTV4k
PI3 : Max2play
PiZéro: PiCoreplayer
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
En préinstall pour migration: Nuc hystou ,ESXi6.7,jeedom V3.2.12, LMS ,Owncloud

Avatar de l’utilisateur
nakor
Timide
Messages : 106
Inscription : 25 nov. 2015, 10:39

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par nakor » 06 févr. 2018, 19:24

rene.jullien a écrit :
05 févr. 2018, 19:06
nakor a écrit :Salut videohone. Sous blea il fonctionne, sous ce plugin spécifique je ne sais pas je n'ai pas encore essayé, je me demandais ce qu'il ajoutait de plus par rapport à blea. Un lien avec les infos plantes type taux d'humidité à maintenir peut-être ?
J ai créé ce plugin avant BLEA, il est utile si vous avez seulement des miflora à gérer en BLE. Il fonctionne toujours et n a pas de dépendances.

René


Envoyé de mon iPhone en utilisant Tapatalk
Ok merci de la précision et de ton travail. Moi je suis tombé dessus par hasard, mais vu que j'ai déjà blea ce n'est peut être pas la peine pour mon utilisation. Merci de ta réponse.
Un vrai plus ça aurait été un lien avec les 'bibliothèques' de plante pour savoir le taux d'humidité à maintenir par plante mais ça semble très compliqué à mettre en place pour un gain faible... Par curiosité vous gérez comment vous ? Vous avez une alerte à un taux d'humidité (10%?)?

Florent054
Timide
Messages : 50
Inscription : 22 juin 2017, 07:03

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Florent054 » 27 févr. 2018, 14:33

Swatmorpheus a écrit :
05 févr. 2018, 19:13
Florent054 a écrit :
17 déc. 2017, 16:50
Bonjour a tous,

J'ai un petit probleme avec mon Xiaomi mi plant, il fonctionnait jusque la mais depuis quelques jour il ne communique plus avec mon jeedom...
J'ai le message d'erreur "Miflora No route to host (113)" et "gattool ne répond pas"
soyez indulgent je suis plein de bonne volonté mais galère un peu dans les termes :oops:

Avec putty:

Image

Quelq'un peut me remettre sur les rails??? Merci!
As tu résolue ton pb de BT ? si non essaye

Code : Tout sélectionner

sudo systemctl enable hciuart
sudo systemctl start hciuart
et réessaye

Code : Tout sélectionner

bluetoothctl
et

Code : Tout sélectionner

power on

Merci pour ta réponse, désolé je viens seulement de la voir.
Non le problème n’est pas résolu, je vais tenter ça et je te retiens au courant 🤞🏻

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 04 mars 2018, 10:14

nakor a écrit :
06 févr. 2018, 19:24
[Par curiosité vous gérez comment vous ? Vous avez une alerte à un taux d'humidité (10%?)?
En fait j'adapte progressivement mes alertes. J'utilise les MiFlora et Jeedom pour m'alerter le soir avec TTS quand une plante a besoin d'être arrosée
Le seuil d'humidité depend aussi du substrat. Pour les Orchidées, c est en general en dessous de 16% qu'il faut arroser (source parrot flower) cela dit j'en ai une qui est dans des écorces et autre substrats peu humide qui ne monte pas au dessus de 9% sauf si elle trempe dans l'eau.
Il faut adapter le seuil a chaque plante. Je n'ai pas trouve de BD ouverte sur ce sujet.
J'utilise aussi des MiFlora pour l'humidité du jardin et adapter l'arrosage en fonction. Ils semblent bien resister aux intempéries.
René.

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 04 mars 2018, 10:27

Florent054 a écrit :
27 févr. 2018, 14:33
Merci pour ta réponse, désolé je viens seulement de la voir.
Non le problème n’est pas résolu, je vais tenter ça et je te retiens au courant 🤞🏻
Attention, la pile dure un an max, ensuite le MiFlora n est plus accessible. Le niveau de batterie est visible en cliquant sur l'équipement
Il faut essayer de faire un scan et verifier si le MiFlora est visible:
https://jeedom-plugins-extra.github.io/ ... Anchor-1-5
Si vous avez d'autres périphériques BLE, il faut voir s'ils sont detectable pour determiner si le problème vient du MiFlora ou du récepteur BLE
Il faut parfois le rebooter complètement le MiFlora en enlevant la pile. Le pile est standard, CR2032, facile a changer.

ikariya
Timide
Messages : 50
Inscription : 27 août 2017, 09:33

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par ikariya » 01 avr. 2018, 19:31

J'interviens egalement car j'ai un soucis avec mon miflora.
J'ai du reinstaller mon jeedom a cause d'un plantage, et depuis impossible d'avoir les remontées du miflora alors qu'avant ça marchait assez bien.
J'ai fait 2 ou 3 fois l'install, sous des configs / distribs differentes, avec le bluetooth du pi ou avec un dongle qui fonctionnait avant aussi et tjrs meme pb.

Le miflora est bien detecté, les valeurs sont lues à la premeire connexion et puis apres ... jamais, a part le rssi et la presence et le firmware, impossible d'avoir les données de la plante. Ca se met a jour une fois quand ca veut, en gros une fois par jour ou tous les 2 ou 3 jours.

j'ai, je crois, tout testé, même les modifs dans le main.conf

voici les logs que j'ai

Code : Tout sélectionner

[2018-04-01 19:26:14][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2018-04-01 19:26:15][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=E8U549j5RI3ThqNlQcts22ENH0mrxIf3 HTTP/1.1" 200 0
[2018-04-01 19:26:23][DEBUG] : SCANNER------[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'95fe'), (22, '16b Service Data', u'95fe7120980003d3f0658d7cc40d0910020000'), (9, 'Complete Local Name', u'Flower care')] True public c4:7c:8d:65:f0:d3
[2018-04-01 19:26:23][DEBUG] : SCANNER------This is a miflora device c4:7c:8d:65:f0:d3
[2018-04-01 19:26:23][DEBUG] : SENDER------Send to jeedom : {u'devices': {u'C4:7C:8D:65:F0:D3': {'name': u'Flower care', 'source': 'local', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'95fe'), (22, '16b Service Data', u'95fe7120980003d3f0658d7cc40d0910020000'), (9, 'Complete Local Name', u'Flower care')]", 'rssi': -68, 'type': 'miflora', 'id': u'C4:7C:8D:65:F0:D3', 'present': 1}}}
[2018-04-01 19:26:23][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2018-04-01 19:26:24][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=E8U549j5RI3ThqNlQcts22ENH0mrxIf3 HTTP/1.1" 200 0
[2018-04-01 19:26:24][DEBUG] : SCANNER------This is a miflora device c4:7c:8d:65:f0:d3
[2018-04-01 19:26:24][DEBUG] : SENDER------Send to jeedom : {u'devices': {u'C4:7C:8D:65:F0:D3': {'name': u'Flower care', 'source': 'local', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'95fe'), (22, '16b Service Data', u'95fe7120980004d3f0658d7cc40d041002d800'), (9, 'Complete Local Name', u'Flower care')]", 'rssi': -71, 'type': 'miflora', 'id': u'C4:7C:8D:65:F0:D3', 'present': 1}}}
[2018-04-01 19:26:24][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2018-04-01 19:26:25][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=E8U549j5RI3ThqNlQcts22ENH0mrxIf3 HTTP/1.1" 200 0
[2018-04-01 19:26:27][DEBUG] : HEARTBEAT------Couldn't get cpu, skip once
[2018-04-01 19:26:30][DEBUG] : SCANNER------[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'1d18'), (9, 'Complete Local Name', u'MI_SCALE'), (22, '16b Service Data', u'1d18820000e20703040e3a31'), (255, 'Manufacturer', u'5701880f10a62f07')] True public 88:0f:10:a6:2f:07
[2018-04-01 19:26:30][DEBUG] : SCANNER------This is a miscale device 88:0f:10:a6:2f:07
[2018-04-01 19:26:30][DEBUG] : MISCALE------Miscale this is a dummy measure
[2018-04-01 19:26:30][DEBUG] : SENDER------Send to jeedom : {u'devices': {u'88:0F:10:A6:2F:07': {'name': u'MI_SCALE', 'source': 'local', 'rawdata': "[(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'1d18'), (9, 'Complete Local Name', u'MI_SCALE'), (22, '16b Service Data', u'1d18820000e20703040e3a31'), (255, 'Manufacturer', u'5701880f10a62f07')]", 'rssi': -86, 'type': 'miscale', 'id': u'88:0F:10:A6:2F:07', 'present': 1}}}
[2018-04-01 19:26:30][INFO] : Starting new HTTP connection (1): 127.0.0.1
ca se repete a l'infini ...

de plus chose etrange, impossible de detecgter les devices inconnus en bluetooth, que je coche ou que je coche pas l'option dans la config du plugin. Ca ne voit ni les telephone, ni les mibox, ... ni rien en fait

Meme comportement sur une install située sur une Zbox avec debian 8

Le plugin BLEA a ete modifié le 27/3 et ca colle avec ma date de reinstallation et depuis rien ne marche. Y-aurait-il un bug ?

Les données du miflora remontent sans pb à l'appli du telephone !

ikariya
Timide
Messages : 50
Inscription : 27 août 2017, 09:33

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par ikariya » 01 avr. 2018, 19:52

bon je me repond a moi meme car j'avais pasa vu que j'etais pas dans la section BLEA !
j'ai installe le plugin Miflora et ça a l'air de marcher ! donc il y a bien un souci avec le plugin BLEA !

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 01 avr. 2018, 20:03

ikariya a écrit :
01 avr. 2018, 19:52
bon je me repond a moi meme car j'avais pasa vu que j'etais pas dans la section BLEA !
j'ai installe le plugin Miflora et ça a l'air de marcher ! donc il y a bien un souci avec le plugin BLEA !
Ok pas de soucis. C'est ce que je me disais en regardant tes logs
MiFlora est plus simple mais gère seulement les MiFlora.
Je suis en train de mettre des tests automatisés, pour limiter les régressions dans les nouvelles releases.

Répondre

Revenir vers « [Catégorie] Nature »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités