Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Pour échanger sur les plugins classés en catégorie "Nature"
fbell58
Timide
Messages : 79
Inscription : 15 janv. 2017, 16:46

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par fbell58 » 18 avr. 2018, 22:23

attention du coup il te manque ligne 127 le parametre suplementaire pour la fonction !!!!

la bonne ligne devrait etre (enfin je pense !)

au lieu de
if (MiFlora::isProcessMiFlora($frequenceItem) == 0){

if (MiFlora::isProcessMiFlora($frequenceItem , $MinutesStartCron) == 0){
...
Helper Officiel Jeedom

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 18 avr. 2018, 22:31

Je n ai pas de log MiFlora dans https.error
Tu as la derniere version stable de jeedom ?

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 18 avr. 2018, 22:34

fbell58 a écrit :
18 avr. 2018, 22:23
attention du coup il te manque ligne 127 le parametre suplementaire pour la fonction !!!!

la bonne ligne devrait etre (enfin je pense !)

au lieu de
if (MiFlora::isProcessMiFlora($frequenceItem) == 0){

if (MiFlora::isProcessMiFlora($frequenceItem , $MinutesStartCron) == 0){
Oui en regardant le diff, j ai pris 3 modifs, celle la, un log et la simplification de ton test des heures

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 18 avr. 2018, 22:35

Code : Tout sélectionner

ps j aimerai pouvoir lancer un refresh par scenario je vais voir si c est compliqué ou pas !!! dites moi si cela interesse du monde ?
Oui il faudrait le faire, tu peux creer une issue dans GitHub: https://github.com/Jeedom-Plugins-Extra ... ora/issues

fbell58
Timide
Messages : 79
Inscription : 15 janv. 2017, 16:46

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par fbell58 » 19 avr. 2018, 06:54

Merci

Je viens de mettre a jour pour être sur et
pour les messages de log je les ai toujours .....en https.....
mais peut etre que tu fais pas de Https mais juste du HTTP ? mon adresse reseau externe est en https dans la config
car effectivement pas de message en HTTP sur la machine de qualification qui elle fait pas de HTTPS mais juste du HTTP .....
(c est quand meme mieux d avoir du https pour exposer sur internet non!!!)

merci d avance pour ton aide car la je vois pas trop ou chercher

[Thu Apr 19 06:47:32.433038 2018] [:error] [pid 16578] [client 89.2.42.176:52349] PHP Warning: Declaration of MiFloraCmd::execute(array $_options = NULL) should be compatible with cmd::execute($_options = Array) in /var/www/html/plugins/MiFlora/core/class/MiFloraCmd.class.php on line 22, referer: https://jeedom.famille-bellanger.fr/ind ... =dashboard
[Thu Apr 19 06:47:32.578755 2018] [:error] [pid 16721] [client 89.2.42.176:52348] PHP Warning: Declaration of MiFloraCmd::execute(array $_options = NULL) should be compatible with cmd::execute($_options = Array) in /var/www/html/plugins/MiFlora/core/class/MiFloraCmd.class.php on line 22, referer: https://jeedom.famille-bellanger.fr/ind ... =dashboard
...
Helper Officiel Jeedom

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Bono2007 » 30 avr. 2018, 13:46

Bonjour, je viens d'acquérir un Mi Flora et j'ai un problème de portée du BT.
Avec mon Galaxy et l'appli android, à 2m c'est mort.
Avec Jeedom, le capteur est introuvable ( 6m )
Une idée ? Merci
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

Idaho947
Actif
Messages : 1281
Inscription : 30 mai 2017, 21:36

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Idaho947 » 30 avr. 2018, 13:51

A part mettre une antenne BLEA je vois pas

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 30 avr. 2018, 13:56

Bono2007 a écrit :Bonjour, je viens d'acquérir un Mi Flora et j'ai un problème de portée du BT.
Avec mon Galaxy et l'appli android, à 2m c'est mort.
Avec Jeedom, le capteur est introuvable ( 6m )
Une idée ? Merci
C est bizarre, avec un RPI3, Bluetooth intégré je les capte dans la maison et dans le jardin. Je n installe pas l appli, mais avec un RPI tu dois les capter à plusieurs mètres. Essaye avec les commandes de la doc MiFlora.

Code : Tout sélectionner

bluetoothctl
scan on
Les adresses des MiFlora apparaissent comme ci-dessous:

[NEW] Device C4:7C:8D:xx:xx:xx Flower mate
[NEW] Device C4:7C:8D:xx:xx:xx Flower care

Code : Tout sélectionner

scan off
quit

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Bono2007 » 30 avr. 2018, 14:05

j'ai déjà essayé hcitool lescan et j'ai :

Code : Tout sélectionner

84:C0:EF:57:6B:82 [TV] Samsung 6 Series (65)
37:C4:B1:9A:38:E5 (unknown)
7D:DD:8D:90:81:87 (unknown)
7D:DD:8D:90:81:87 (unknown)
84:C0:EF:57:6B:82 (unknown)
84:C0:EF:57:6B:82 [TV] Samsung 6 Series (65)
7D:DD:8D:90:81:87 (unknown)
Pas de

Code : Tout sélectionner

C4:7C:8D:61:57:A0 Flower care
J'ai installé le 2e Mi Flora, j'ai mis le pot à 10 cm de mon dongle BT 4.0
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 30 avr. 2018, 14:19

Bono2007 a écrit :
30 avr. 2018, 14:05
j'ai déjà essayé hcitool lescan et j'ai :

Code : Tout sélectionner

84:C0:EF:57:6B:82 [TV] Samsung 6 Series (65)
37:C4:B1:9A:38:E5 (unknown)
7D:DD:8D:90:81:87 (unknown)
7D:DD:8D:90:81:87 (unknown)
84:C0:EF:57:6B:82 (unknown)
84:C0:EF:57:6B:82 [TV] Samsung 6 Series (65)
7D:DD:8D:90:81:87 (unknown)
Pas de

Code : Tout sélectionner

C4:7C:8D:61:57:A0 Flower care
J'ai installé le 2e Mi Flora, j'ai mis le pot à 10 cm de mon dongle BT 4.0
Je ne peux pas verifier, je ne suis pas sur place, mais d apres ce site: https://www.raspberrypi.org/forums/vie ... p?t=151419
hcitool donne des resultats differents de bluetoothctl
Tu as plusieurs MIFlora ? Les autres marchent ?

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Bono2007 » 30 avr. 2018, 14:24

J'ai installé un dongle tout neuf ( en fait j'ignorais l'existence du bt intégré au pi3 ).
J'ai 2 Mi Flora, un seul a été reconnu à 10 cm par le plugin BLEA, mais pas par le plugin Mi Flora.
Puis à 6m, mon tél portable déconnecte de temps en temps mais le retrouve.
Pour l'instant je tente une mise à jour du rasp et une install du bluetooth interne
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 30 avr. 2018, 14:39

Bono2007 a écrit :
30 avr. 2018, 14:24
J'ai installé un dongle tout neuf ( en fait j'ignorais l'existence du bt intégré au pi3 ).
J'ai 2 Mi Flora, un seul a été reconnu à 10 cm par le plugin BLEA, mais pas par le plugin Mi Flora.
Puis à 6m, mon tél portable déconnecte de temps en temps mais le retrouve.
Pour l'instant je tente une mise à jour du rasp et une install du bluetooth interne
Moi ca marche super avec le BT interne. Je capte a 5-10m moins s'il y a un mur.
Ne mets pas 2 plugins actifs a la fois sur le meme RPI avec le meme BT (hci0 par ex), ils vont tenter d utiliser le device en meme temps et ca va faire des erreurs random.
Pour MiFlora il faut mettre la mac add a main (pour le moment), ensuite tu passes en debug et tu regardes s il arrive a se connecter au MiFlora.
Ne laisse pas le debug si ca marche, il récupère les données toutes les minutes et va gaspiller la pile du MiFlora

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Bono2007 » 30 avr. 2018, 14:48

Alors j'ai pas réussi à activer le bt interne. J'ai essayé tout un tas de commandes, y compris en mettant à jour et en réinstallant le bluetooth.
En remettant le dongle, avec : bluetoothctl , le dongle apparait, j'ai fait un "power on" et ensuite un "scan on" pour voir apparaitre le Mi Flora
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 30 avr. 2018, 16:34

Tu as essayé:

sudo systemctl start bluetooth

dmesg | grep Blue

Tu es sous Raspbian Stretch ?

Avatar de l’utilisateur
Bono2007
Timide
Messages : 182
Inscription : 27 août 2014, 19:47

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Bono2007 » 01 mai 2018, 18:47

Non pas fait, mais j'avais les 2 mi Flora sous jeedom, via blea et via le plugin Mi Flora
Mais en fait j'ai viré le dongle bluetooth, je n'avais plus de remontée de mes sondes de température sous rfxcom... La lose intégrale.
Et comme à priori, remettre le bluetooth du rasp poserait des pb à ma carte zwave... Je ne vois pas trop quoi faire. Et pas trop envie d'investir dans un nouveau dongle

Bon je vais quand même retenter en virant un plugin pour l'instant.

Edit : ce dongle me casse les c.... il génère des erreurs sur rfxcom.
J'ai pourtant installé comme lu dans les autres posts, y compris apt-get update, upgrade, dist-upgrade et rpi-update.

Un dmesg | grep Blue me donne :

Code : Tout sélectionner

root@raspberrypi:/home/pi# dmesg | grep Blue
[    7.120974] Bluetooth: Core ver 2.22
[    7.121045] Bluetooth: HCI device and connection manager initialized
[    7.121069] Bluetooth: HCI socket layer initialized
[    7.121084] Bluetooth: L2CAP socket layer initialized
[    7.121117] Bluetooth: SCO socket layer initialized
[    7.314420] Bluetooth: hci0: BCM: chip id 63
[    7.315334] Bluetooth: hci0: BCM: features 0x07
[    7.331330] Bluetooth: hci0: BCM20702A
[    7.332317] Bluetooth: hci0: BCM20702A1 (001.002.014) build 0000
[    7.332451] Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0a5c-21e8.hcd not found
[    8.973901] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    8.973909] Bluetooth: BNEP filters: protocol multicast
[    8.973926] Bluetooth: BNEP socket layer initialized
Et je suis sous Jessie
Jeedom VM + RFXCom + Z-wave + blea sur Proxmox VE
5 volets Somfy – prises AN158 – Wallplugs – OWL CM180 – compteurs d'eau Gianola – Oeil FGMS001 – Eco-Device – sondes THGR810 - FGS 212 - FGBS321 - DS18B20 - ESCAM Pearl QF100 IP[/size]

jerryzz
Timide
Messages : 69
Inscription : 18 janv. 2018, 11:53

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par jerryzz » 02 mai 2018, 15:04

Question TRES bête, ne m'en voulez pas...

Qu'apporte ce plugin par rapport à BLEA, où toutes les infos de mes MiFlora y sont déjà remontées ?

Merci

PS: j'aime bcp l'icône ^_^

Anonyme
Actif
Messages : 10082
Inscription : 09 août 2014, 12:15

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Anonyme » 02 mai 2018, 16:23

Contenu supprimé à la demande de son auteur

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 02 mai 2018, 23:02

jerryzz a écrit :Question TRES bête, ne m'en voulez pas...

Qu'apporte ce plugin par rapport à BLEA, où toutes les infos de mes MiFlora y sont déjà remontées ?

Merci

PS: j'aime bcp l'icône ^_^
J ai fait ce plugin au tout début , maintenant qu il y a BLEA, les deux plugins gèrent les MiFlora.
Je vais ajouter les parrots
Il est plus simple et n a pas de dépendances, mais fait seulement les MiFlora, pas tout les objets Bluetooth.

Je me suis posé la question de l arrêter mais avec le Bluetooth interne sur RPI3 j ai des problèmes de stabilité et j ai aussi un petit problème de gestion des températures négatives avec BLEA.

J ai une version bêta, grâce à une contribution open source, presque prête avec pas mal de nouveautés notamment la gestion d antennes déportées, un onglet santé, un refresh à la demande, des warnings batterie, tout en restant simple.

René


Envoyé de mon iPhone en utilisant Tapatalk

Anonyme
Actif
Messages : 10082
Inscription : 09 août 2014, 12:15

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par Anonyme » 02 mai 2018, 23:23

Contenu supprimé à la demande de son auteur

rene.jullien
Timide
Messages : 326
Inscription : 24 mai 2015, 17:31
Localisation : Alpes Maritimes

Re: [Plugin Tiers][Sujet Principal] MiFlora - Xiaomi mi plants

Message par rene.jullien » 02 mai 2018, 23:24

Bono2007 a écrit :Non pas fait, mais j'avais les 2 mi Flora sous jeedom, via blea et via le plugin Mi Flora
Mais en fait j'ai viré le dongle bluetooth, je n'avais plus de remontée de mes sondes de température sous rfxcom... La lose intégrale.
Et comme à priori, remettre le bluetooth du rasp poserait des pb à ma carte zwave... Je ne vois pas trop quoi faire. Et pas trop envie d'investir dans un nouveau dongle

Bon je vais quand même retenter en virant un plugin pour l'instant.

Edit : ce dongle me casse les c.... il génère des erreurs sur rfxcom.
J'ai pourtant installé comme lu dans les autres posts, y compris apt-get update, upgrade, dist-upgrade et rpi-update.

Un dmesg | grep Blue me donne :

Code : Tout sélectionner

root@raspberrypi:/home/pi# dmesg | grep Blue
[    7.120974] Bluetooth: Core ver 2.22
[    7.121045] Bluetooth: HCI device and connection manager initialized
[    7.121069] Bluetooth: HCI socket layer initialized
[    7.121084] Bluetooth: L2CAP socket layer initialized
[    7.121117] Bluetooth: SCO socket layer initialized
[    7.314420] Bluetooth: hci0: BCM: chip id 63
[    7.315334] Bluetooth: hci0: BCM: features 0x07
[    7.331330] Bluetooth: hci0: BCM20702A
[    7.332317] Bluetooth: hci0: BCM20702A1 (001.002.014) build 0000
[    7.332451] Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0a5c-21e8.hcd not found
[    8.973901] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    8.973909] Bluetooth: BNEP filters: protocol multicast
[    8.973926] Bluetooth: BNEP socket layer initialized
Et je suis sous Jessie
Désolé pas d idée d ou vient le pb, le log dmesg est ok


Envoyé de mon iPhone en utilisant Tapatalk

Répondre

Revenir vers « [Catégorie] Nature »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité