Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[tuto] [Pi3] Jeedom netinstall direct sur SSD

gcherel
Timide
Messages : 202
Inscription : 01 mai 2015, 15:19

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par gcherel » 23 août 2017, 09:40

Bonjour,
Jeedom a parfaitement fonctionné pendant 36 heure sur le msata sans soucis, et ce matin j'ai le message "502 Bad Gateway". Le redémarrage du Rapsberry change rien, plus d'accès en SSH... Que faire ?

lone
Actif
Messages : 511
Inscription : 06 juil. 2017, 16:57

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par lone » 23 août 2017, 10:40

Salut,
Jette un œil ici si ça peut t'aider :
https://github.com/jeedom/issues/wiki/depannage

Et sinon avec un écran ça dit quoi ?

gcherel
Timide
Messages : 202
Inscription : 01 mai 2015, 15:19

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par gcherel » 24 août 2017, 07:49

lone a écrit :
23 août 2017, 10:40
Salut,
Jette un œil ici si ça peut t'aider :
https://github.com/jeedom/issues/wiki/depannage

Et sinon avec un écran ça dit quoi ?
Bonjour,

Avec un écran,ça ne disais plus rien non plus... Après avoir relu le tuto, je me suis toutefois aperçu que j'avais activé le BT du Pi, alors que j'utilise Zwave. Peut-être est-ce une piste ? En tout cas, j'ai refais complètement mon installation hier soir et ça semble fonctionner ce matin.

Avatar de l’utilisateur
sela
Actif
Messages : 526
Inscription : 21 janv. 2016, 09:37
Localisation : Région parisienne

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par sela » 25 août 2017, 17:35

sela a écrit :
25 juil. 2017, 19:58
OK ! Je passe commande... Merci pour vos conseils ! Je vous dirai...
Salut !

Je vous avais quitté fin juillet avec mes échecs successifs pour faire booter directement sur mon SSD 120Go... et bien j'ai suivi vos conseils avisés j'ai acheté un mSATA 16 Go (Transcend Sata III 6 Gb/s MSA370) et bingo... !!! le tuto de Cocapic fonctionne niquel !
Grand merci et à bientôt pour de nouvelles aventures !
Jeedom V3.3 (RPI3)
Stick Zwave Gen5 + RFXtrx433E + téléinfo USB
Zwave:FGBS-001 Universal Relay|FGSD-002 DaaF|FGFS-101 Flood Sensor|FGD-212 Dimmer 2 | PST02-C Zipato|Powernode|ZMNHJD1 Fil Pilote|Siren Gen5 (ZW080)

Avatar de l’utilisateur
sela
Actif
Messages : 526
Inscription : 21 janv. 2016, 09:37
Localisation : Région parisienne

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par sela » 26 août 2017, 11:37

Salut,
Mon Jeedom a ses 4 ports USB occupés (SSD, dongle Zwave, RFXcom, + hub avec TéléInfo et USB connecté sur mon onduleur APC).
Lorsque je souhaite rebooter mon Jeedom en laissant tout branché, mon Jeedom ne boot pas.
Je dois débrancher toutes les prises USB sauf le SSD (bien sûr !). Là, Jeedom boot et je peux ensuite reconnecter les 3 ports USB restants.
Je pense que RPI3 connecté à 4 ports USB ne sait pas sur quel port booter...
Y a-t-il une astuce pour l'obliger à booter obligatoirement sur le port du SSD ?
Merci
Jeedom V3.3 (RPI3)
Stick Zwave Gen5 + RFXtrx433E + téléinfo USB
Zwave:FGBS-001 Universal Relay|FGSD-002 DaaF|FGFS-101 Flood Sensor|FGD-212 Dimmer 2 | PST02-C Zipato|Powernode|ZMNHJD1 Fil Pilote|Siren Gen5 (ZW080)

androme
Timide
Messages : 176
Inscription : 08 avr. 2017, 18:32
Localisation : Arles, France

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par androme » 26 août 2017, 11:41

Bonjour.
L'alimentation est suffisante ?
RPI3B Jeedom 3.1.7 SSD mSATA

leon-99
Timide
Messages : 238
Inscription : 09 févr. 2016, 18:34
Localisation : Limoges (ou presque)

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par leon-99 » 26 août 2017, 11:45

Bonjour
C'est certainement un problème d'alimentation car j'ai un rpi3 avec 4 ports usb de pris et il boot très bien sur le ssd. .

Envoyé de mon SM-G903F en utilisant Tapatalk


Avatar de l’utilisateur
Fabe
Timide
Messages : 328
Inscription : 05 déc. 2016, 09:56

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par Fabe » 26 août 2017, 14:19

Hello je pense que cocapic l'a dit et répété les hub usb sont sources d'ennuis...

Envoyé de mon A0001 en utilisant Tapatalk


Dernière édition par Fabe le 26 août 2017, 14:19, édité 1 fois.
Jeedom 4.0.31 - Mini PC Z83II - Clé ZWave GEN5 - Gateway Xiaomi
BLEA - XIAOMI - ZWAVE - ALARME - CAMERA - THERMOSTAT - SIGRI LINKY - TELEINFO- SUIVI CONSO - APP MOBILE - DIALOG FLOW - METEO - GSH - IFTTT - GCAST - WEBOS TV - DYNDNS - WIFILIGHT V2

Avatar de l’utilisateur
cyber152
Timide
Messages : 372
Inscription : 27 août 2014, 01:18

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par cyber152 » 26 août 2017, 14:44

.
Dernière édition par cyber152 le 26 août 2017, 15:04, édité 1 fois.
Jeedom sur AZW Z83 II MINI PC
RfxCom+aeon labs z-stick gen5 Sondes oregon , modules DIO/Zwave - Blink1- Google Home -
VR Somfy -Nabaztag - Karotz - Mirror - Imperihome - Orbivo - Phillips Hue

krislec
Timide
Messages : 252
Inscription : 12 sept. 2015, 17:37

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par krislec » 26 août 2017, 14:51

Bonjour à tous,
Encore une fois, ma box Jeedom n'est plus accessible. Apparemment le rpi 3 ne boot plus en SSD (Ok en sd)
J'ai donc monté le SSD sur mon ordi et j'ai rajouté à la main dans le fichier config.txt (à la racine du raspi et non en /boot/config.txt puisque les dossiers ne sont pas accessibles quand le SSD est monté sur l'ordi)

Code : Tout sélectionner

program_usb_boot_mode=1
Mais cela ne fonctionne pas.
Y-a-t-il un autre paramètre à utiliser ?
Le raspi est inaccessible puisque évident il ne trouve pas le disque SSD... donc pas d'accès aux fichiers ni en SSH...
Comment faire ?
JEEDOM Raspi 3 B
AEON Labs Z-Wave Gen5 + RFXcom
FIBARO door sensor FGK-101, QUBINO ZMNHJD1, Oregeon THN132N, Oregon THGR 122 NX, Swiid Cord Switch, PST02-A 4 en 1, IPX800 V3

Avatar de l’utilisateur
sela
Actif
Messages : 526
Inscription : 21 janv. 2016, 09:37
Localisation : Région parisienne

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par sela » 26 août 2017, 15:02

J'ai bien saisi la commande sudo echo "max_usb_current=1" >> /boot/config.txt (OK dans le fichier config.txt)
J'ai testé avec 2 alim. différentes de 3mA (dont celle-ci https://www.amazon.fr/gp/product/B01AHY ... UTF8&psc=1 et une Aukru power).
Mon RPi3 ne veut pas booter avec les 4 ports USB connectés dont 1 hub-usb D-link (modèle DUB-H7).
Si je débranche la clé Zwave et la TéléInfo s'est OK.
Ca me plait moyen car si je laisse en l'état je ne pourrais pas faire de reboot à distance. Je devrais être présent pour débrancher / rebrancher ces 2 ports.
J'ai testé différentes combinaisons (SSD sur le hub, seulement le SSD sur le RPi3+reste sur le hub, ...).

Bref... je parviens à booter sur le SSD en retirant le hub usb. C'est-à-dire que les 4 ports usb du RPI3 sont occupés par SSD + RfxCom + clé Zwave Gen3 + TéléInfo GCE.
Je perds l'usb relié à mon onduleur APC. C'est la solution la moins pénalisante pour mon Jeedom.

Si vous avez des idées pour tester autre chose...
Je ne comprends pas pourquoi ce hub usb bouffe de la puissance lors du boot. Il est alimenté donc le RPI3 ne devrait pas être impacté (?)

Je suis conscient que c'est pas top d'utiliser un hub usb mais c'est difficile de faire autrement lorsqu'on a 5 périphériques à connecter. Hormis monter un autre Jeedom...
Jeedom V3.3 (RPI3)
Stick Zwave Gen5 + RFXtrx433E + téléinfo USB
Zwave:FGBS-001 Universal Relay|FGSD-002 DaaF|FGFS-101 Flood Sensor|FGD-212 Dimmer 2 | PST02-C Zipato|Powernode|ZMNHJD1 Fil Pilote|Siren Gen5 (ZW080)

Avatar de l’utilisateur
Fabe
Timide
Messages : 328
Inscription : 05 déc. 2016, 09:56

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par Fabe » 26 août 2017, 16:32

Tu as trouvé la réponse tout seul car pour la télé info j'utilise un autre jeedom simplement... Vu le coût d'un RPI3 je dirais que c'est dérisoire pour ta tranquillité non ?

Envoyé de mon A0001 en utilisant Tapatalk

Jeedom 4.0.31 - Mini PC Z83II - Clé ZWave GEN5 - Gateway Xiaomi
BLEA - XIAOMI - ZWAVE - ALARME - CAMERA - THERMOSTAT - SIGRI LINKY - TELEINFO- SUIVI CONSO - APP MOBILE - DIALOG FLOW - METEO - GSH - IFTTT - GCAST - WEBOS TV - DYNDNS - WIFILIGHT V2

vincecoco
Actif
Messages : 1181
Inscription : 12 oct. 2015, 09:31

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par vincecoco » 26 août 2017, 17:31

Ou sinon moins cher une carde micro SD 2go pour booter à l'ancienne.
De mon coteem même avec un hub acheté sur Gearbest sur lequel se trouve le SSD ça boot :)
À plus

kerm'j
Timide
Messages : 199
Inscription : 18 sept. 2015, 16:29

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par kerm'j » 26 août 2017, 19:49

cocapic a écrit :
25 juil. 2017, 18:52
Pic de charge au boot essaye un câble en Y que tu trouveras sur Amazon livre demain
DeLOCK USB data / power cable câble USB - câbles USB https://www.amazon.fr/dp/B001BHVMIU/ref ... Dzb0H3YGRE

Par exemple + alim ou chargeur à côté


Envoyé de mon iPhone en utilisant Tapatalk

Bonjour à tous,

juste pour vous dire que j'ai également un ssd Transcend de 16 Go (cité en page 8) qui n'a jamais voulu démarrer directement sans sd.

Après plusieurs tests en suivant vos recommandations, j'ai finalement réussi en utilisant le cable en Y que tu cites, @cocapic :D
Merci pour l'infos et également pour ce tuto qui m'a donné envie de passer sur un ssd.

Bon je vais en rester avec cette config mais dommage que cela requiert une deuxième alim...

Je ne sais pas au final si ce n'est pas mieux d'utiliser la sd juste pour démarrer ?!


EDIT quelques minutes après...

Je viens de tester sans l'alim du ssd tout en gardant le cable Y (donc le rasp est branché directement sur secteur et le ssd au rasp avec l'une des extrémité du cable Y) et ça démarre aussi...
Je n'ai pas d'autre cable pour vérifier mais le cable usb du boitier ssd semble bien en cause...
Raspberry PI3+ / z-stick aeon gen5 / Jeedom v3.3.33 / 50+ modules zwave

*** Un grand merci à toute l'équipe Jeedom et aux membres actifs du forum pour leur aide ! ***

lone
Actif
Messages : 511
Inscription : 06 juil. 2017, 16:57

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par lone » 26 août 2017, 20:48

Salut,
Testez avec d'autres cables déjà, un microUSB traditionnel fait l'affaire, ça se branche sur la prise du SSD (c'est de l'USB2 au lieu d'USB3 mais le pi ne gère que le 2 de tte façon).
Vous avez quoi de branché sur les hubs ? pas un disque dur ou un truc qui pourrait ressembler à une partition ?
@kriselc, c'est à la racine de la partition boot qu'est le config.txt, il n'y a pas de "racine de raspi". Je n'utilise pas windows depuis longtemps mais il me semble que normalement tu devrais voir tes partitions avec un SSD (avec une carte SD, windows ne te montre effectivement que la 1ère partition).
Tu peux tjrs rajouter cela dans le config.txt: program_usb_timeout=1 ça lui demande de patienter encore un peu le temps de trouver ton SSD.
Sinon est ce que ton SSD boote avec la SD ? (il faut que le cmdline.txt de la SD ait root=/dev/sda2 pour ça). Tape sudo lsblkid une fois démarré pour savoir.
max_usb_current=1 ne sert plus sur le pi3 apparement car ils ont completement modifié l'alim usb, ça marche pour le pi2 par contre.
program_usb_boot_mode=1 pareil, je ne suis pas persuadé de l'utilité du truc pour un pi3... ça force le pi à booter sur l'usb mais de tte façon le pi3 boote dessus s'il ne trouve pas de SD (si raspbian est à jour).
Dernière édition par lone le 26 août 2017, 20:59, édité 2 fois.

lone
Actif
Messages : 511
Inscription : 06 juil. 2017, 16:57

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par lone » 26 août 2017, 20:50

@kerm'j : J'ai un SSD transcend monté dans un boitier inateck qui boote tout seul. Par contre c'est vrai qu'il est un peu capricieux, parfois il préfère certaines prises usb...

snoopy10800
Timide
Messages : 267
Inscription : 25 mai 2016, 20:57
Localisation : entre Troyes et Quimper...

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par snoopy10800 » 31 août 2017, 08:21

Bonjour à tous,

Ce matin, mise à jour de deux plugin de mon jeedom et gros plantage. Plus rien.

Bon, j'ai voulu en profiter pour refaire une install propre, et j'ai ce message à l'étape 8 :

Start step_8_jeedom_configuration
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
Could not execute CREATE USER 'jeedom'@'localhost' IDENTIFIED BY 'dfdcc809b1db658'; into mysql - abort

Vous savez d'ou ça peut venir ?

Franck54550
Timide
Messages : 103
Inscription : 19 janv. 2017, 20:40
Localisation : Nancy

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par Franck54550 » 31 août 2017, 08:32

Bonjour
Quelle procédure as tu utilisé ?
DIY RPI 3 B / SSD : Jeedom 3.3.x / Strecth

snoopy10800
Timide
Messages : 267
Inscription : 25 mai 2016, 20:57
Localisation : entre Troyes et Quimper...

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par snoopy10800 » 31 août 2017, 10:43

Franck54550 a écrit :
31 août 2017, 08:32
Bonjour
Quelle procédure as tu utilisé ?

J'ai utilisé la procédure habituelle, indiquée en première page de ce topic...
Entre-temps, j'ai tout recommencé à zéro, et cette fois, ça fonctionne... Rien compris...

snoopy10800
Timide
Messages : 267
Inscription : 25 mai 2016, 20:57
Localisation : entre Troyes et Quimper...

Re: [tuto] [Pi3] Jeedom netinstall direct sur SSD

Message par snoopy10800 » 31 août 2017, 16:08

Petite question : (je crois que ça n'a pas été abordé dans les pages précédentes)

Quand on suit ce tuto de A à Z, comment se fait l'accès SSH ? avec l'utilisateur pi ou root ?
Je pose cette question, car avec ma version 2.4.6, l'accès SSH se faisait via root.
Ici, il n'y a que pi + mdp qui fonctionne
Si je rentre root + mdp, il me dit que le mdp est incorrect. (essayé avec Mjeedom96, et avec mon mot de passe habituel)

Je voulais refaire l'accès SSL sur ma nouvelle install. Mais apparemment, via l'utilisateur pi, ça ne fonctionne pas. Normal ?

Répondre

Revenir vers « Raspberry Pi »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités