Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Pb connexion sécurisée

Répondre
maryric80
Timide
Messages : 9
Inscription : 27 févr. 2019, 12:33
Localisation : Hauts de France

Pb connexion sécurisée

Message par maryric80 » 19 mars 2019, 22:46

Bonjour a tous
nouveau depuis peu, j'avance doucement dans l'installation de jeedom et ces composants, mais je tourne en rond pas moyen de passe en connexion sécurisèe .
j'ai suivi le tuto sur domo blog ,en faisant un configtest d'apache j'ai cette réponse
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Syntax OK

et la c'est le bug je tourne en rond et je pense qu'il doit y avoir plusieurs problèmes.
merci de votre aide car je voudrais bien avancer ...

schwarzy77
Timide
Messages : 34
Inscription : 17 avr. 2018, 11:32
Localisation : Seine et marne

Re: Pb connexion sécurisée

Message par schwarzy77 » 20 mars 2019, 09:52

Bonjour,

Ce n'est pas grave comme erreur, le plus important est à la fin: "Syntax OK".
Pour le message "Could not reliably determine ....", c'est qu'il n'y a pas de servername de définit par défaut dans Apache. Pour corriger cela, il te suffit d'ajouter (n'importe où) dans le fichier /etc/apache2/apache2.conf un nom de serveur (de préférence le nom que tu vas utiliser pour te connecter à jeedom). Tu peux même mettre son adresse IP. Cela donne par exemple dans le fichier apache2.conf:

...
ServerName 192.168.0.10
...

puis vérifier que la configuration est ok:
apache2ctl -t

Et relancer apache:
service apache2 restart

maryric80
Timide
Messages : 9
Inscription : 27 févr. 2019, 12:33
Localisation : Hauts de France

Re: Pb connexion sécurisée

Message par maryric80 » 20 mars 2019, 19:44

Bonsoir,
en controlant avec cette commande apache2ctl -t
voici la reponse
: Syntax error on line 10 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
SSLCertificateFile: file '/etc/letsencrypt/live/xxxxxxxxxxxxx/fullchain.pem' does not exist or is empty
Action '-t' failed.
The Apache error log may have more information.

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Pb connexion sécurisée

Message par Bosquetia » 20 mars 2019, 19:53

127.0.1.1 mmmm
l'adresse de loopback c'est 127.0.0.1

maryric80
Timide
Messages : 9
Inscription : 27 févr. 2019, 12:33
Localisation : Hauts de France

Re: Pb connexion sécurisée

Message par maryric80 » 20 mars 2019, 19:58

c,est dans le fichier sudo nano /etc/hosts

127.0.0.1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.1.1 raspberrypi
ServerName www.xxxxxxxxxx.ovh

les x c'est moi qui remplace mon adresse

maryric80
Timide
Messages : 9
Inscription : 27 févr. 2019, 12:33
Localisation : Hauts de France

Re: Pb connexion sécurisée

Message par maryric80 » 20 mars 2019, 20:05

la je viens de remplacer 127.0.1.1 raspberrypi par 127.0.1.1 par xxxxxx

resultat
$ sudo apachectl configtest
Syntax OK

maryric80
Timide
Messages : 9
Inscription : 27 févr. 2019, 12:33
Localisation : Hauts de France

Re: Pb connexion sécurisée

Message par maryric80 » 20 mars 2019, 20:08

redemarrage d'apache
$ sudo /etc/init.d/apache2 restart
[....] Restarting apache2 (via systemctl): apache2.serviceWarning: apache2.service changed on disk. Run 'systemctl daemon-reload' to reload units.
. ok

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Pb connexion sécurisée

Message par Bosquetia » 20 mars 2019, 20:14

Je répète l'adresse de loopback correcte est 127.0.0.1 et pas 127.0.1.1

maryric80
Timide
Messages : 9
Inscription : 27 févr. 2019, 12:33
Localisation : Hauts de France

Re: Pb connexion sécurisée

Message par maryric80 » 20 mars 2019, 20:20

127.0.0.1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.0.1 xxxxxxxxx
ServerName www.xxxxxx.ovh

comme ca?

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Pb connexion sécurisée

Message par Bosquetia » 20 mars 2019, 20:23

tu es en ip v6 ?
Je ne pense pas je pense que tu es en ip v4

maryric80
Timide
Messages : 9
Inscription : 27 févr. 2019, 12:33
Localisation : Hauts de France

Re: Pb connexion sécurisée

Message par maryric80 » 20 mars 2019, 20:30

127.0.0.1 localhost ip4-localhost ip4-loopback
ff02::1 ip4-allnodes
ff02::2 ip4-allrouters

127.0.0.1 XXXXXXXX
ServerName www.XXXXXXXXXXXX.ovh

par contre j'ai toujours ca
$ apache2ctl -t
AH00526: Syntax error on line 10 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
SSLCertificateFile: file '/etc/letsencrypt/live/xxxxxxxxxxx.ovh/fullchain.pem' does not exist or is empty
Action '-t' failed.
The Apache error log may have more information.

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Pb connexion sécurisée

Message par Bosquetia » 20 mars 2019, 20:44

La le message d'erreur c'est qu'il manque un des fichiers du certificat, le .pem ...

maryric80
Timide
Messages : 9
Inscription : 27 févr. 2019, 12:33
Localisation : Hauts de France

Re: Pb connexion sécurisée

Message par maryric80 » 20 mars 2019, 20:57

ca se corrige comment ?

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Pb connexion sécurisée

Message par Bosquetia » 20 mars 2019, 21:00

Tu as été voir ce post viewtopic.php?t=35339 ?

maryric80
Timide
Messages : 9
Inscription : 27 févr. 2019, 12:33
Localisation : Hauts de France

Re: Pb connexion sécurisée

Message par maryric80 » 20 mars 2019, 21:13

je vais aller le lire en partie car la famille me réclame.....
un grand merci pour ton aide, j'ai avancé un peu ce soir y'a encore du boulot mais ca va le faire.
merci et bonne soirée.
Eric

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Pb connexion sécurisée

Message par Bosquetia » 20 mars 2019, 21:16

Pas de souci.
Perso je génère un certificat officiel et j'ai 3 fichiers (je passe pas par let's encrypt) mais j'ai une autorité officielle pour générer des certificats...

Répondre

Revenir vers « Raspberry Pi »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité