Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

Plugin blea

guirem
Timide
Messages : 276
Inscription : 31 août 2017, 00:41

Re: Plugin blea

Message par guirem » 06 mars 2018, 18:55

Bonsoir,

Tu peux essayer de forcer ta lampe en EGLO/AWOX qui fonctionne aussi avec le bluetooth mesh mais aucune garantie que ça fonctionne (et y'a même très peu de chance)...
(fil de discussion viewtopic.php?f=141&t=27245#p579884)
redsectors a écrit :
02 mars 2018, 21:15
pawnies a écrit :
17 janv. 2018, 16:23
Bonjour.
J'ai acheté ces ampoules boulanger RGB détéctées par Blea comme périphérique inconnu avec comme nom devant la mac@ "BLE leedarsonmesh "

https://www.boulanger.com/ref/8003066

Quelqu’un saurait comment les piloter via Jeedom?

Merci

Bonsoir,

j'ai également ces ampoules boulanger mais qui ne sont ni plus ni moins que ce modèle vendues sous reférence essentiel B :
http://www.leedarson.com/index.php/Prod ... ail/id/160

Les ampoules fonctionnent en réseau mesh bluetooth associé à un cryptage AES.
Je ne suis pas sur que le plugin BLEA supporte cela?

Pour info, du code java ainsi que les librairies crypto AES telink nécessaires pour dialoguer avec ces bulb sont disponibles ici :
https://github.com/zhourenjun/BleMeshLib

Je vais commencer à m'amuser avec histoire de voir...

Cordialement,

Elie

laurentm
Timide
Messages : 23
Inscription : 14 déc. 2017, 22:05

Re: Plugin blea

Message par laurentm » 06 mars 2018, 21:27

Bonjour,

Rien à faire de mon côté, depuis la dernière version du plugin, impossible de réinstaller les dépendances. Je crois avoir tout essayé... Pourtant, d'après le log de l'install, il n'y a aucune erreur et tout s'installe avec succès! Ci-joint une copie de mon log:
blea_dependancy.txt
(8.71 Kio) Téléchargé 19 fois
Et malgré ça :
Dépendances.jpg
Dépendances.jpg (55.29 Kio) Consulté 1466 fois
Quelqu'un peut-il me proposer une piste?

daytoju
Timide
Messages : 52
Inscription : 02 sept. 2016, 08:57

Re: Plugin blea

Message par daytoju » 06 mars 2018, 23:48

Hello
je viens de faire l'install blea aussi chez moi sur un vieux pi2 qui trainé auquel j'ai ajouté un dongle bluetooh.
Le script d'install n'a pas fonctionné ( faut dire que je tourne sur un vie raspbmc 3.12 ... mais ca cohabite avec mon mediacenter pour le moment..
Bref, j'ai regardé la log et en fin de compte j'ai du passer quasi toutes les commandes a la main car pour une raison que je n'ai pas encore saisie les install n'ont pas marché via le script.
A la main ca a fonctionné, a ceci pret que j'ai du adapter les commandes pip pour spécifier de passer sur l'url https de pypi... la commande est donc su genre: sudo pip install --index-url=https://pypi.python.org/simple/ cryptography
Egalement pour le module crypto , l'install pip a planté sur quelques depandances, que j'ai passé a la main ( cffi : sudo pip install --index-url=https://pypi.python.org/simple/ cffi) ..
Bref, malgré tout cela, le daemon est lancé mais j'ai des erreurs dans la log une fois le daemon démmarré:
[2018-03-06 22:45:23][ERROR] : Error on send request to jeedom request() got an unexpected keyword argument 'json' retry : 0/3
[2018-03-06 22:45:23][ERROR] : Error on send request to jeedom request() got an unexpected keyword argument 'json' retry : 1/3
[2018-03-06 22:45:23][ERROR] : Error on send request to jeedom request() got an unexpected keyword argument 'json' retry : 2/3
... si quelqu'un a deja euca .. je continue de creuser ,car ce plug-in est juste top pour ce que je veux faire :)

daytoju
Timide
Messages : 52
Inscription : 02 sept. 2016, 08:57

Re: Plugin blea

Message par daytoju » 07 mars 2018, 00:02

sarakha63 a écrit :
01 janv. 2017, 20:26
Ah oui en wheezy la lib request ne sait pas.envoyer du json

Envoyé de mon SM-G930F en utilisant Tapatalk
bon j'ai trouvé la reponse quelques pages en arriere... je deterre pour ceux que ca interesse...

je vais devoir me lancer dans l'ugrade du coup :)

Avatar de l’utilisateur
Titi007
Timide
Messages : 104
Inscription : 23 févr. 2017, 16:31

Re: Plugin blea

Message par Titi007 » 10 mars 2018, 13:35

Installation ce matin de la mise à jour et j'ai retrouvé le réseau sur le plugin . Ne reste plus que la page santé de blea qui reste blanche mais ça n'empêche en rien son fonctionnement.
Merci pour le dev

Envoyé de mon Redmi Note 4 en utilisant Tapatalk


trifouille
Timide
Messages : 59
Inscription : 05 juin 2017, 16:03

Re: Plugin blea

Message par trifouille » 11 mars 2018, 17:06

Bonjour,
Pour moi tout ok

Santé ok
Réseau ok
Antenne ok

J'ai juste les dépendance que je n'arrive pas à relancer....
Capture d’écran 2018-03-11 à 17.01.25.png
Capture d’écran 2018-03-11 à 17.01.25.png (53.61 Kio) Consulté 1324 fois
Merci

David

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2714
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 11 mars 2018, 18:19

Regarde dans les logs de 'Update' ou 'Blea'
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

Avatar de l’utilisateur
Antoinekl1
Actif
Messages : 3927
Inscription : 23 mai 2015, 08:14

Re: Plugin blea

Message par Antoinekl1 » 12 mars 2018, 13:27

bonjour à tous

petite question, j'ai une box android XIAOMI avec une télécommande BT, pas pratique

il y a t'il une solution pour récupérer la fonction ON/OFF de la télécommande afin de pouvoir réveiller le box dans un scenario ?

merci
JEEDOM Smart Ultimate + 40 modules zwave
A vendre ; pack POWER jeedom - Jeedom Mini+ - Console Clazio sous Android 6

Avatar de l’utilisateur
cadavor
Actif
Messages : 1284
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: Plugin blea

Message par cadavor » 12 mars 2018, 13:56

Antoinekl1 a écrit :
12 mars 2018, 13:27
bonjour à tous

petite question, j'ai une box android XIAOMI avec une télécommande BT, pas pratique

il y a t'il une solution pour récupérer la fonction ON/OFF de la télécommande afin de pouvoir réveiller le box dans un scenario ?

merci
Pas avec ce plugin.
Jeedom Stable 3.3
NUC Z83 + Aeotec Z-Stick Gen5
Z-Wave FGR + FGMS + FGDS + FGFS + FGK + FGWPE + ZW062 + ZW080
GH Mini + Orvibo AllOne + Playbulb + Miband2

laurentm
Timide
Messages : 23
Inscription : 14 déc. 2017, 22:05

Re: Plugin blea

Message par laurentm » 12 mars 2018, 18:51

C'est bizarre cette histoire de dépendances... j'ai plus ou moins le même problème (qq post plus haut), et l'update du plugin n'a rien changé. J'avoue que j'ai mis le problème de côté pour le moment, et que quand j'aurai le temps, je tenterai une réinstallation complète de jeedom. C'est juste chronophage et source de cheveux blancs...

Cela étant, si quelqu'un trouve une piste, je suis preneur! Merci à tous! Laurent
trifouille a écrit :
11 mars 2018, 17:06
Bonjour,
Pour moi tout ok

Santé ok
Réseau ok
Antenne ok

J'ai juste les dépendance que je n'arrive pas à relancer....

Capture d’écran 2018-03-11 à 17.01.25.png

Merci

David

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2714
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 12 mars 2018, 21:12

Il est possible que l'installation se bloque sur une question posée à l'utilisateur... comme c'est lancé via Jeedom, forcément on n'a pas la main pour répondre. Dans ce cas ça se voit dans les logs... et il faut lancer une ligne de commande pour finir l'installation, après s'être loggé en 'root' :
dpkg --configure -a
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

SimonT
Timide
Messages : 102
Inscription : 18 déc. 2015, 09:04

Re: Plugin blea

Message par SimonT » 14 mars 2018, 05:40

Bonjour

J'ai un problème avec le plugin quand je redemarre jeedom je vois bien le Port clef bluetooth HC0 ou HC1 (Bluetooth du rpi3 ou d'une clé) j'arrive a faire des scans pour trouver les appareils mais après quelque minute mes Port clef bluetooth disparaissent et le démon passe au rouge
pourtant en ssh je vois bien les clés, quelqu'un aurait déjà eu ce problème?

Seblam
Timide
Messages : 73
Inscription : 30 déc. 2016, 22:41

Re: Plugin blea

Message par Seblam » 14 mars 2018, 20:20

Bonsoir,
J'ai le souci de temps en temps mais pas forcément après quelques minutes. Après test des commandes hcitools, je me suis rendu compte que c'était ma carte SD qui donnaient des signes de fatigue...

Avatar de l’utilisateur
pinault22
Timide
Messages : 144
Inscription : 05 nov. 2015, 15:23

Re: Plugin blea

Message par pinault22 » 14 mars 2018, 21:43

J'ai un raspberry pi3 (bt intégré avec jeedom en netinstall en 3.1.7) et j'ai mis un msata et j'ai refais une installation complète (tout fonctionne, enfin presque).
Dans le tuto il disait qu'il fallait désactiver le bt sur les raspi3 avec la commande "sudo echo "dtoverlay=pi3-disable-bt" >> /boot/config.txt"
Puis en fait on m'a dit que pour le rpi3 ne vaut que dans le cas de l'utilisation de la carte zwave razberry (qui se monte sur le port gpio).
Du coup, je vire le dtoverlay=pi3-disable-bt du /boot/config.txt

et dans le dmesg j'ai
[ 83.721435] Bluetooth: Core ver 2.22
[ 83.721538] NET: Registered protocol family 31
[ 83.721544] Bluetooth: HCI device and connection manager initialized
[ 83.722624] Bluetooth: HCI socket layer initialized
[ 83.722642] Bluetooth: L2CAP socket layer initialized
[ 83.722684] Bluetooth: SCO socket layer initialized
Je me dis, banco ca va être de la rigolade :lol:

Je met a jour les dépendances :
[ 83.721435] Bluetooth: Core ver 2.22
[ 83.721538] NET: Registered protocol family 31
[ 83.721544] Bluetooth: HCI device and connection manager initialized
[ 83.722624] Bluetooth: HCI socket layer initialized
[ 83.722642] Bluetooth: L2CAP socket layer initialized
[ 83.722684] Bluetooth: SCO socket layer initialized
Je vérifie une derniere fois si y'a des mises à jours du plugin ! et la paf y'a le plugin blea (UPDATE market / plugin : blea 2018-03-01 17:16:17)
Je me dis, mince je ne suis pas dans la bonne version, je regarde ma version actuelle : Version2018-03-01 17:16:17
Je me dis, bah WTF, bon pas grave je relance la mise à jour à travers la page d'update !

Du coup je re-relance les dépendances :

Code : Tout sélectionner

Launch install of blea dependancy
Hit:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libssl-dev is already the newest version (1.1.0f-3+deb9u1).
python-dev is already the newest version (2.7.13-2).
python-requests is already the newest version (2.12.4-1).
bluetooth is already the newest version (5.43-2+rpt2+deb9u2).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 59 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version (1:2.11.0-3+deb9u2).
libglib2.0-dev is already the newest version (2.50.3-2).
0 upgraded, 0 newly installed, 0 to remove and 59 not upgraded.
Requirement already satisfied: pyudev in /usr/lib/python2.7/dist-packages
Requirement already satisfied: pyserial in /usr/lib/python2.7/dist-packages
Requirement already satisfied: requests in /usr/lib/python2.7/dist-packages
Requirement already satisfied: cryptography in /usr/lib/python2.7/dist-packages
Requirement already satisfied: pycrypto in /usr/lib/python2.7/dist-packages
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib.linux-armv7l-2.7
creating build/lib.linux-armv7l-2.7/bluepy
copying bluepy/sensortag.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/scanner.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/thingy52.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/get_services.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/btle.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/blescan.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/__init__.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/uuids.json -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluez-src.tgz -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluepy-helper.c -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/Makefile -> build/lib.linux-armv7l-2.7/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib.linux-armv7l-2.7/bluepy
running install_lib
copying build/lib.linux-armv7l-2.7/bluepy/sensortag.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluepy-helper.c -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/scanner.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/thingy52.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/get_services.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/btle.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/blescan.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluepy-helper -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/__init__.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluez-src.tgz -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/uuids.json -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/Makefile -> /usr/local/lib/python2.7/dist-packages/bluepy
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/sensortag.py to sensortag.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/scanner.py to scanner.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/thingy52.py to thingy52.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/get_services.py to get_services.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/btle.py to btle.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/blescan.py to blescan.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/__init__.py to __init__.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing bluepy.egg-info/PKG-INFO
writing top-level names to bluepy.egg-info/top_level.txt
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing entry points to bluepy.egg-info/entry_points.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python2.7/dist-packages/bluepy-1.1.2.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python2.7/dist-packages/bluepy-1.1.2.egg-info
running install_scripts
Installing blescan script to /usr/local/bin
Installing thingy52 script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Everything is successfully installed!
Hit:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
libssl-dev is already the newest version (1.1.0f-3+deb9u1).
python-dev is already the newest version (2.7.13-2).
python-requests is already the newest version (2.12.4-1).
bluetooth is already the newest version (5.43-2+rpt2+deb9u2).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 59 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version (1:2.11.0-3+deb9u2).
libglib2.0-dev is already the newest version (2.50.3-2).
0 upgraded, 0 newly installed, 0 to remove and 59 not upgraded.
Requirement already satisfied: pyudev in /usr/lib/python2.7/dist-packages
Requirement already satisfied: pyserial in /usr/lib/python2.7/dist-packages
Requirement already satisfied: requests in /usr/lib/python2.7/dist-packages
Requirement already satisfied: cryptography in /usr/lib/python2.7/dist-packages
Requirement already satisfied: pycrypto in /usr/lib/python2.7/dist-packages
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib.linux-armv7l-2.7
creating build/lib.linux-armv7l-2.7/bluepy
copying bluepy/sensortag.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/scanner.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/thingy52.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/get_services.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/btle.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/blescan.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/__init__.py -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/uuids.json -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluez-src.tgz -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/bluepy-helper.c -> build/lib.linux-armv7l-2.7/bluepy
copying bluepy/Makefile -> build/lib.linux-armv7l-2.7/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib.linux-armv7l-2.7/bluepy
running install_lib
copying build/lib.linux-armv7l-2.7/bluepy/sensortag.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluepy-helper.c -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/scanner.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/thingy52.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/get_services.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/btle.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/blescan.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluepy-helper -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/__init__.py -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/bluez-src.tgz -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/uuids.json -> /usr/local/lib/python2.7/dist-packages/bluepy
copying build/lib.linux-armv7l-2.7/bluepy/Makefile -> /usr/local/lib/python2.7/dist-packages/bluepy
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/sensortag.py to sensortag.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/scanner.py to scanner.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/thingy52.py to thingy52.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/get_services.py to get_services.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/btle.py to btle.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/blescan.py to blescan.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/bluepy/__init__.py to __init__.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing bluepy.egg-info/PKG-INFO
writing top-level names to bluepy.egg-info/top_level.txt
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing entry points to bluepy.egg-info/entry_points.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python2.7/dist-packages/bluepy-1.1.2.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python2.7/dist-packages/bluepy-1.1.2.egg-info
running install_scripts
Installing blescan script to /usr/local/bin
Installing thingy52 script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Everything is successfully installed!
Bon bah la je me dis qu'il faut que je relance la mise a jours des plugins généralement, je trouve 2,3 plugin a mettre a jour, puis je vire surveillance station qui ne me sert plus a rien et la je retourne dans les logs !
Je n'avais que les logs blea_dependance qui apparaissaient, mais la j'ai les logs ble
Voici ce que ca donne :

Code : Tout sélectionner

[2018-03-14 21:09:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2018-03-14 21:10:39][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2018-03-14 21:15:11][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45s entre 2 lancements du démon
[2018-03-14 21:15:17][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45s entre 2 lancements du démon
[2018-03-14 21:15:40][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2018-03-14 21:20:39][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2018-03-14 21:25:38][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2018-03-14 21:30:41][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2018-03-14 21:31:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2018-03-14 21:35:38][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2018-03-14 21:37:36][ERROR] : Impossible de lancer le démon blea, vérifiez la log
Dans le menu défilant "Port clef bluetooth" je ne peux pas choisir mon module bt... (j'ai le bt interne du raspi3)
Le truc aussi c'est que pour les dépendances dans les logs ca a l'air de bien se passer mais dans les fait la mise à jour de la date du plugin plea ne se fait pas : 2017-11-27 21:39:10 (reste bloqué).
Comme j'ai redémarré jeedom il n'y a pas longtemps, je me dis que je vais me coucher et que peut etre que tout reviendra demain...

Affaire a suivre...

*Edit dans le log blea_local :

Code : Tout sélectionner

Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 491, in <module>
globals.IFACE_DEVICE = int(globals.device[-1:])
ValueError: invalid literal for int() with base 10: 'y'
Bon bah on dirait que mon debian ne trouve pas mon bt alors qu'au début de mon post je croyais que c'était le cas avec le dmesg viewtopic.php?f=157&t=27797&p=572492&hi ... 27#p572492

Vu la désactivation du bt que j'ai fait au début et la réactivation, ca pourrait bien expliquer des choses, et a mon avis un petit : apt-get update && apt-get upgrade réglera le problème, je vous tiens au jus (je laisse le post car ca pourra servir...)

Vu les installations des packages ca sent bon

Code : Tout sélectionner

 bluez-firmware bsdutils cron dbus dbus-x11 firmware-atheros firmware-brcm80211 firmware-libertas firmware-misc-nonfree firmware-realtek isc-dhcp-client
  isc-dhcp-common libapparmor1 libblkid1 libc-bin libc-dev-bin libc-l10n libc6 libc6-dbg libc6-dev libdbus-1-3 libdbus-1-dev libdirectfb-1.2-9 libfdisk1
  libmount1 libncurses5 libncursesw5 libpam-systemd libraspberrypi-bin libraspberrypi-dev libraspberrypi-doc libraspberrypi0 libsmartcols1 libsystemd0
  libtinfo5 libudev-dev libudev1 libuuid1 locales mount multiarch-support ncurses-base ncurses-bin ncurses-term ntp ntpdate openssh-client openssh-server
  openssh-sftp-server raspberrypi-bootloader raspberrypi-kernel raspi-config ssh systemd systemd-sysv tzdata udev util-linux
Bon bah j'ai trouvé la solution sur un autre topic et cela a fonctionné pour moi donc je post

Code : Tout sélectionner

Pignonduclan a écrit :
AlexD a écrit :
Bonjour,

J'aurais besoin de votre aide pour ceci svp :

J'ai un souci avec le demon du plugin Blea qui est bloqué sur NOK "Le port n'est pas configuré".( J'ai fait une capture plus bas)

Lorsque j'essaye de configurer le port clef bluetooth plus bas : je n'ai comme option que "Aucun" et pas d'autre choix.
et je ne vois pas comment régler ce problème.

Je précise que j'ai un RPi3 qui possède donc le Bluetooth. J'ai aussi déjà essayé de re-installer les dépendances mais ça ne change rien au problème.

Pour info le plugin fonctionnait très bien avant.
Le problème est apparu depuis que j'ai redémarré mon Rpi3 car j'ai eu à faire une sauvegarde de la Carte SD. (on est jamais trop prudent avec ça)

Est ce que du fait que j'ai relancé mon jeedom/rspi3 le bluetooth ce serait désactivé ? et je devrait le réactiver ? 

Je ne sais pas quoi faire.

Quelqu'un aurait une idée svp ?

Merci !
Lance en SSH
•	sudo systemctl enable hciuart
•	sudo systemctl start hciuart
et ça va résoudre ton problème. J'ai eu la même chose. Normalement, il ne faut pas relancer ces commandes même après un reboot... Mais j'ai quand-même dû le faire 1x sur environ 10 reboot.

Cedric
Roooh, ça fait des mois que j'ai ce problème sur mon Pi3 et impossible de trouver la solution et je viens de tester tes 2 commandes et... mon Bluetooth remarche !!! Merci infiniment !
Tout simplement :
Lance en SSH
• sudo systemctl enable hciuart
• sudo systemctl start hciuart
Dernière édition par pinault22 le 15 mars 2018, 22:24, édité 1 fois.

Avatar de l’utilisateur
Shyrka973
Actif
Messages : 555
Inscription : 18 août 2014, 18:17
Localisation : Kourou / Guyane

Re: Plugin blea

Message par Shyrka973 » 15 mars 2018, 18:20

Bonjour,

Le bon de code qui tourne sur les antennes, a-t-il été mis à jour ? Et depuis quand ?
Lors d'une mise à jour de BLEA, si ce bout de code est mis à jour, BLEA nous prévient-il de faire la mise à Jours sur les antennes ?

Merci.
DIY Proxmox 5.1 / i3-6100U @ 2.30GHz / 4Go RAM / 128 Go SSD : Jeedom 3.2.12 - Stretch
Protocol: Z-Wave, EnOcean, RFXtrx433E, Xiaomi, BLEA, MQTT, ESPeasy, Jeeduino, Abeille

Avatar de l’utilisateur
minscof
Actif
Messages : 587
Inscription : 27 janv. 2015, 21:37

Re: Plugin blea

Message par minscof » 24 mars 2018, 09:12

Swr a écrit :
08 sept. 2017, 22:36
Je viens de découvrir le module ESP32 qui intègre un BT LE et interface wifi, est il possible de l'utiliser en antenne?
Je relance cette question à laquelle une réponse avait été de dire qu'il ne supportait pas lInux donc peu de chance. Mais néanmoins, une antenne blea n'a pas nécessairement besoin de Linux, donc cela doit être envisageable : est-ce que quelqu'un a regardé un peu le sujet ?

Swr
Actif
Messages : 707
Inscription : 08 nov. 2016, 20:56
Localisation : 44

Re: Plugin blea

Message par Swr » 24 mars 2018, 13:17

minscof a écrit :
24 mars 2018, 09:12
Swr a écrit :
08 sept. 2017, 22:36
Je viens de découvrir le module ESP32 qui intègre un BT LE et interface wifi, est il possible de l'utiliser en antenne?
Je relance cette question à laquelle une réponse avait été de dire qu'il ne supportait pas lInux donc peu de chance. Mais néanmoins, une antenne blea n'a pas nécessairement besoin de Linux, donc cela doit être envisageable : est-ce que quelqu'un a regardé un peu le sujet ?
on peu probablement remonter les infos via le dev de Andreas Spiess
https://www.youtube.com/watch?v=KNoFdKgvskU

AlainM
Actif
Messages : 1036
Inscription : 20 mars 2016, 14:21
Localisation : Hérault

Re: Plugin blea

Message par AlainM » 24 mars 2018, 17:35

Bonjour,
Dernière édition par AlainM le 25 mars 2018, 10:37, édité 1 fois.

Avatar de l’utilisateur
kris1208
Actif
Messages : 661
Inscription : 18 juin 2015, 15:53
Contact :

Re: Plugin blea

Message par kris1208 » 25 mars 2018, 03:48

Bonjour,
Avez vous eu des problemes cette nuit apres le changement d'heure ?
J'ai ete reveillé parce que ca faisais des bip en permanence suite au nut qui me disais que j'etait present et 2mn apres absent. j'ai rebooté jeedom mais c'est pareil, je vois les 2 nut qui aleatoirement l'un apres l'autre ou les 2 passe de present a absent de cela depuis 2h du mat (juste au changement d'heure).
J'ai du desactivé la fonction de mon scenario sinon ca serai plus possible.
tout est au vert dans l'analyse santé.
Merci.

Avatar de l’utilisateur
yoyo
Timide
Messages : 67
Inscription : 09 déc. 2014, 19:55
Localisation : Essonne

Re: Plugin blea

Message par yoyo » 25 mars 2018, 03:56

Exactement la même réveillé cette nuit avec mes scénario de présence qui se déclenche intempestivement !
Impossible de trouver la tête dans le sac !

J'ai enlever les piles de mes nuts afin d'éviter les actualisations de valeurs !

Vive la domotique mdr !! Allez bonne nuit !!

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 4 invités