Page 150 sur 168

Re: Plugin blea

Publié : 23 juil. 2019, 21:31
par Dautrip
Je suis sous Debian 9.9 j'ai desinstallé le plugin et réinstallé, j'en profite pour rapatrier la clé bluetooth en local. Je viens de redécouvrir mes appareils, merci pour la mise à jour. Tout est ok maintenant, je n'avais que 4 périphériques dont 2 hectors et 2 tag.

Re: Plugin blea

Publié : 23 juil. 2019, 21:32
par Mad Ein
j'ai lancé ça:

Code : Tout sélectionner

sudo pip install virtualenv --upgrade
a priori ça fonctionne.

Re: Plugin blea

Publié : 23 juil. 2019, 21:44
par Spine
Bonsoir, je viens de passer la dernière MAJ et mon démon est KO comme bcp d'autres, dites moi comment je peux vous aider...
Sans titre2.png
Sans titre2.png (147.76 Kio) Consulté 812 fois

Re: Plugin blea

Publié : 23 juil. 2019, 21:53
par chris777c
Je m'auto repond :

Il faut refaire une installation de la mise à jour de Blea et cela fonctionne à nouveau derrière.

Re: Plugin blea

Publié : 23 juil. 2019, 22:23
par Fabrice
Bonsoir,

Il y a eu une mise à jour à 2019-07-24 16:19:09

Ceux qui l"on installé avant, doivent effectivement mettre de nouveau à jour.

Re: Plugin blea

Publié : 23 juil. 2019, 22:30
par Swr
chris777c a écrit :
23 juil. 2019, 21:53
Je m'auto repond :

Il faut refaire une installation de la mise à jour de Blea et cela fonctionne à nouveau derrière.
Ça fonctionne, mais j'ai perdu toute la config au passage


J'ai cette erreur au niveau de l'antenne pi zero:
File "/home/pluginblea/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Traceback (most recent call last):
File "/home/pluginblea/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'

Re: Plugin blea

Publié : 24 juil. 2019, 01:25
par Spine
Je m'auto repond :

Il faut refaire une installation de la mise à jour de Blea et cela fonctionne à nouveau derrière.
Merci pour l'info ça a fonctionné chez moi sans perte de config., RPI 3B+ et stretch lite, merci..

Re: Plugin blea

Publié : 24 juil. 2019, 06:50
par Laco
Bonjour à tous

Depuis la mise à jour de ce matin, le démon ne redémarrait plus et le plugin BLEA demandait la mise à jour des dépendances.
Mais cette mise à jour s'arrête à 20% avec un message au niveau du démon
Sans titre.png
Sans titre.png (53.43 Kio) Consulté 730 fois
Je veux bien un coup de main svp :roll:

Merci par avance, et bonne journée

Re: Plugin blea

Publié : 24 juil. 2019, 07:19
par Swr
Swr a écrit :
23 juil. 2019, 22:30
chris777c a écrit :
23 juil. 2019, 21:53
Je m'auto repond :

Il faut refaire une installation de la mise à jour de Blea et cela fonctionne à nouveau derrière.
Ça fonctionne, mais j'ai perdu toute la config au passage


J'ai cette erreur au niveau de l'antenne pi zero:
File "/home/pluginblea/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Traceback (most recent call last):
File "/home/pluginblea/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Après plusieurs clicks pour relancer le démon (il faut dire que le Pi zéro, c'est pas rapide), tout refonctionne ce matin
Version Démon Local2.4
Version Démon Pi zero2.4
Version Démon snips2.4

Re: Plugin blea

Publié : 24 juil. 2019, 08:22
par Fabrice
Laco a écrit :
24 juil. 2019, 06:50
Bonjour à tous

Depuis la mise à jour de ce matin, le démon ne redémarrait plus et le plugin BLEA demandait la mise à jour des dépendances.
Mais cette mise à jour s'arrête à 20% avec un message au niveau du démon

Je veux bien un coup de main svp :roll:

Merci par avance, et bonne journée
Bonjour,

Il faut la log des dépendances au minimum pour comprendre.

Re: Plugin blea

Publié : 24 juil. 2019, 09:20
par Fabrice
Bonjour à tous,

Sur Raspberry PI 3B+, à jour de tout Jeedom (3.3.28) / Raspbian (en version 9.9 Strech).
L'installation du nouveau plugin BLEA n'a pas posée de difficulté chez moi.
1) Installation du plugin
2) Réinstallation des dépendances du plugin
3) J'ai juste du relancer l'installation des dépendances sur une antenne déportée (Raspberry PI 3B), car le bouton prévu à cet effet n'a pas réalisé la mise à jour sur l'antenne déportée. Je l'ai donc fait depuis l'antenne.

Après j'ai relancé de Deamon du BLEA puis j'ai relancé l'antenne depuis le panneau de configuration du plugin BLEA et c'est partie.

Re: Plugin blea

Publié : 24 juil. 2019, 09:33
par Juju31
Hello,

J'en vois qui font tourner BLEA sous Stretch.
J'en étais resté au fait que BLEA ne fonctionnait pas sous Stretch (plantage complet de Jeedom au bout d'un moment).
J'ai loupé quelque chose ?

Sinon, concernant le problème de dépendances, je l'ai eu aussi, mais en forçant l'installation/réinstallation du plugin (update datée d'hier soir), plus de problème. Les dépendances s'affichent OK, et je n'ai eu qu'à relancer le démon.

Re: Plugin blea

Publié : 24 juil. 2019, 09:34
par Idaho947
Bonjour,

Je suis en Jeedom 3.3.28 avec le plugin blea en Beta. J'essaie de faire la maj de hier soir 21h29 mais la roue tourne constement et l'instalation ne se fait pas. J'ai vidé mes log avant la maj et là je n'ai rien qui s'inscrit dans Blea_update.
J'ai ça en boucle dans Blea :
2019-07-24 09:32:52][INFO] : Envoie du fichier /tmp/folder-blea.tar.gz
[2019-07-24 09:32:52][INFO] : Envoie de fichier sur 192.168.1.10
[2019-07-24 09:32:52][INFO] : Files successfully sent to 192.168.1.10
[2019-07-24 09:32:52][INFO] : Décompression du dossier distant
[2019-07-24 09:32:52][INFO] : Commande par SSH rm -Rf /home/pi/blead sur 192.168.1.10
[2019-07-24 09:33:02][INFO] : Restarting daemon on remote BLEA
[2019-07-24 09:33:02][INFO] : Lancement du démon distant
[2019-07-24 09:33:02][INFO] : Lancement du démon distant /usr/bin/python3 /home/pi/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://192.168.1.37:80/plugins/blea/cor ... eeBlea.php --apikey YpGJFOEq8IFUHitEICYb9p6XMq6KbCQx --daemonname "BLEA" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 &
[2019-07-24 09:33:02][INFO] : Commande par SSH /usr/bin/python3 /home/pi/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://192.168.1.37:80/plugins/blea/cor ... eeBlea.php --apikey YpGJFOEq8IFUHitEICYb9p6XMq6KbCQx --daemonname "BLEA" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 & sur 192.168.1.10

Re: Plugin blea

Publié : 24 juil. 2019, 09:37
par gun1705
Salut à tous,

J'ai mis à jour le BLEA sans trop de souci (juste mis les dépendances à jour).
J'ai modifié un périph existant (créé hier soir, mais avant mise à jour) et j'ai pu sélectionner Mi Band 4 (merci !)

Sauf que je n'ai rien dans les commandes, j'ai beau tenter de les recréer, il ne se passe rien. J'ai bien vu qu'il n'y avait que la Présence de détectée, mais je ne l'ai pas dans les commandes. C'est vide...

Merci

[Edit]
Je me réponds tout seul.
Mes antennes n'étaient en cours de mise à jour. Une fois terminées, j'ai eu mes commandes sur le mi band 4. Surement une désactivation de la création de commande pendant la mise à jour. Problème résolu pour moi en tout cas. Patience...

Re: Plugin blea

Publié : 24 juil. 2019, 10:01
par defmy
Pareil, mise à jour effectuée et sans trop de souci sur jeedom. Par contre mes déportés j'ai du toucher au code pour garder la compatibilité en python2. Il y a pas moyen de gérer les import en fonction de la version de python ? Par exemple SocketServer en python2, socketserver en python3

Re: Plugin blea

Publié : 24 juil. 2019, 10:18
par Sigri44
J'ai pas de MàJ moi ?!

Re: Plugin blea

Publié : 24 juil. 2019, 10:30
par propositionjoe
Salut,

J'ai mis à jour le plugin,
Mais la maj reste figée sur cette dernière étape:
Image

Aussi, j'ai mis à jour les scripts pour les antennes:
Tout se passe bien pour les rapsbian sous stretch,
Ceux sous jessie, la log me donne ça:
- J'ai ajouté l'user au grp sudo, sans effet...
Image

Je continue à chercher mais si des personnes connaissent la solution ;)

EDIT:

- J'ai fait le cochon en ajoutant:

Code : Tout sélectionner

visudo
pi ALL=(ALL) NOPASSWD: ALL
- Du coup l'antenne renvoie du log, mais ce n'est pas fameux:

Code : Tout sélectionner

Can't get device info: No such device
Can't get device info: No such device
[2019-07-24 08:55:11.099][WARNING] : GLOBAL------Exception on scanner (trying to resolve by myself 19): Failed to execute management command 'le on' (code: 17, error: Invalid Index)
Can't get device info: No such device
Can't get device info: No such device
[2019-07-24 08:55:11.243][WARNING] : GLOBAL------Exception on scanner (trying to resolve by myself 20): Failed to execute management command 'le on' (code: 17, error: Invalid Index)
Can't get device info: No such device
Can't get device info: No such device
[2019-07-24 08:55:11.391][ERROR] : GLOBAL------Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute management command 'le on' (code: 17, error: Invalid Index)
[2019-07-24 08:55:11.391][INFO] : GLOBAL------Shutting down due to errors
[2019-07-24 08:55:11.392][DEBUG] : Send to jeedom :  {'learn_mode': 0, 'source': 'pi-bureau'}
[2019-07-24 08:55:11.397][INFO] : Starting new HTTP connection (1): 10.0.0.200
[2019-07-24 08:55:11.406][DEBUG] : "POST /plugins/blea/core/php/jeeBlea.php?apikey=XXXXXXXXXXXXXXXXXXXXXXXXXXHTTP/1.1" 200 0
[2019-07-24 08:55:13.394][DEBUG] : GLOBAL------Shutdown
[2019-07-24 08:55:13.394][DEBUG] : GLOBAL------Removing PID file /tmp/blead.pid
[2019-07-24 08:55:13.395][DEBUG] : GLOBAL------Closing all potential bluetooth connection
[2019-07-24 08:55:13.834][DEBUG] : LoopNetServer Thread stopped
[2019-07-24 08:55:13.834][DEBUG] : Exit 0

Re: Plugin blea

Publié : 24 juil. 2019, 10:33
par Idaho947
Je remarque autre chose. Depuis la dernière maj je n'ai plus de date et heure de dernière vérification en haut de la page des mise à jours. Il y a peut-être un soucis de synchro entre jeedom et ma machine ?

Re: Plugin blea

Publié : 24 juil. 2019, 10:43
par Fabrice
Je viens de signaler cela sur le forum Partenaires.
- C'est (je pense) lié au core et pas au plugin BLEA.

Edit : Le problème sera corrigé en Jeedom 3.3.29, merci pour l'alerte.

Re: Plugin blea

Publié : 24 juil. 2019, 11:00
par madcow
Bonjour,

J'ai lancé la mise à jour, mais elle reste bloquée sur la dernière étape "post-installation".
Elle s'est interrompue sur time out, et le plugin est resté en précédente version.

Je n'ai pas d'antenne locale, et j'ai une antenne déportée sous VM Proxmox.