Page 47 sur 168

Re: Plugin blea

Publié : 30 janv. 2017, 22:32
par sakuraba
Qui pourrait me dire comment restaurer les images par défaut du dotti, je les ai plus ....

Elles se trouvent où normalement ?

merci

Re: Plugin blea

Publié : 31 janv. 2017, 11:35
par soofiane84
ferritales a écrit :Bluetooth et PI3. si jamais sur les premier model il ne fonctionne pas tres bien (du moins c'est ce que j'ai lu sur le net, mais ca me semble pas tres savant). j'en ai plusieur et sur 1 y a rien a faire il tombe toujours..

- du coup j'ai un pi ou je lance un script pour remonter le bluetooth toute les 30min (et au debut des regle) c'est moche et je pert 4sec. , mais dans mon cas cela me suffit.
- si tu ne vois pas ton bluetooth dans la confid du plugin (Deamon), alors c'est qu'il n'est pas up... (toute les reponses sont dans le forum, on ne connais pas ton problème.

la portée du dotti? chez moi c'est plus de 5m (avec 2 murs).
Peux-tu poster ton script qui remonte le Bluetooth STP ?

Merci.

Re: Plugin blea

Publié : 31 janv. 2017, 13:37
par Tauks
C'est dans le thread. Fais une recherche sur script dans ce sujet blea...

Re: Plugin blea

Publié : 31 janv. 2017, 15:03
par caplam
caplam a écrit :
magicgg91 a écrit :Pas possible sur openelec ou librelec. Passez à OSMC, beaucoup plus ouvert ;)
J'ai tenté sur un rpi2 avec libreelec, ça n'a evidemment pas marché. Puis j'ai lu ce topic plus en détail. Du coup j'ai installé un rpi3 avec osmc.
Ca ne marche pas non plus. J'ai un problème avec l'installation des dépendances:

Voici un extrait du fichier /tmp/blea_dependancy du rpi3:

Code : Tout sélectionner

debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (you may need to install the Term::ReadLine module) (@INC contains: /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.20.2 /usr/local/share/perl/5.20.2 /usr/lib/arm-linux-gnueabihf/perl5/5.20 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7, <> line 18.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin: 
1 upgraded, 17 newly installed, 0 to remove and 43 not upgraded.
Need to get 0 B/22.8 MB of archives.
After this operation, 74.9 MB of additional disk space will be used.
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)
sudo: pip: command not found
sudo: pip: command not found
sudo: pip: command not found
sudo: pip: command not found
sudo: git: command not found
/home/osmc/blead/resources/install.sh: line 20: cd: /tmp/bluepy: No such file or directory
python: can't open file 'setup.py': [Errno 2] No such file or directory
python: can't open file 'setup.py': [Errno 2] No such file or directory
rm: cannot remove '/tmp/bluepy': No such file or directory
Everything is successfully installed!
Je vais chercher un peu quoi faire mais j'arrive à mes limites de compétences.
Bon j'ai eu un peu de temps pour voir ce problème. Alors pour ceux qui galèrent pour installer une antenne (avec le même genre de log que moi) sur osmc c'est tout con.
Créez votre antenne dans le plugin
Cliquez sur envoyer les fichiers
connectez vous en ssh sur osmc
allez dans le répertoire /home/"nom du compte utilisé"/blead/resources/
lancez l'installation avec ./install.sh
Normalement à la fin de l'install ça sera bon.

Il me reste un problème que je n'identifie pas pour l'instant. Dans la page santé j'ai une erreur d'indiquée pour le plugin mais tout me semble fonctionner correctement.
Est-ce que ça peut venir du faible niveau de réception d'une antenne ?

Re: Plugin blea

Publié : 31 janv. 2017, 16:22
par ferritales
soofiane84 a écrit :
ferritales a écrit :Bluetooth et PI3. si jamais sur les premier model il ne fonctionne pas tres bien (du moins c'est ce que j'ai lu sur le net, mais ca me semble pas tres savant). j'en ai plusieur et sur 1 y a rien a faire il tombe toujours..

- du coup j'ai un pi ou je lance un script pour remonter le bluetooth toute les 30min (et au debut des regle) c'est moche et je pert 4sec. , mais dans mon cas cela me suffit.
- si tu ne vois pas ton bluetooth dans la confid du plugin (Deamon), alors c'est qu'il n'est pas up... (toute les reponses sont dans le forum, on ne connais pas ton problème.

la portée du dotti? chez moi c'est plus de 5m (avec 2 murs).
Peux-tu poster ton script qui remonte le Bluetooth STP ?

Merci.
je suis pas chez moi mais je me suis inspiré de ca
http://php.net/manual/en/function.exec.php

et apres je fais les commande suivantes (selon les besoins)
sudo systemctl enable hciuart
sudo systemctl start hciuart
hciconfig hci0 up

pour l'instant c'est moche, l'idée c'est de detecter l'erreur (genre dans les logs jeedom ou avec un grep sur le porcess ou je sais pas quoi) et alors seulement lancer les scripts (voir un reboot dans certain cas)...
en meme temps j'ai un temps limité, c'est pas du sérieux, du coup je m'enfiche un peu si c'est pas "by the book" le but étant de passé un max de temps sur les trucs sympa.

F,

Re: Plugin blea

Publié : 31 janv. 2017, 18:35
par bluntananas
Bonjour à tous !

Je n'ai plus rien dans le démon du Bluetooth sur BLEA, quelqu'un a une idée d'où ça peut venir par hasard ? Je suis sur RBP3 avec le module intégré. Quand en SSH je fais " scan on " après " bluetoothctl " j'ai le droit à un " No default controller available "


Merci :)

Re: Plugin blea

Publié : 31 janv. 2017, 19:36
par Tauks
Si tu utilises uniquement le bluetooth du RpI3, ça ne m'étonne pas :). Le mien est capricieux et disparaît dans les heures qui suivent l'install d'une image jeedom. Je l'ai depuis longtemps remplacé par un dongle (ce qui ne me dispense pas de devoir relancer le service bluetooth fréquemment, voir pour ça mes échanges sur ce thread). Pour ton souci, tu peux tenter :

Code : Tout sélectionner

sudo hciconfig hci0 up
et voir si tu as message d'erreur que tu peux googler, notamment à propos du SAP server ou RFKill. Voir aussi, car le service peut etre lancé mais bancal :

Code : Tout sélectionner

sudo service bluetooth status
Enfin, pour ton bluetoothctl, bien vérifier qu'il te donne immédiatement une adresse MAC. Si oui, c'est ptet tout betement que ta carte n'est pas alimentée. La séquence de base est :

Code : Tout sélectionner

bluetoothctl
power on
agent on
default-agent
pairable on (si on veut apparier de façon ferme of course. Donc pas forcément judicieux pour blea)
discoverable on
scan on

Re: Plugin blea

Publié : 31 janv. 2017, 20:07
par bluntananas
root@jeedom:~# sudo hciconfig hci0 up
Can't get device info: No such device
root@jeedom:~# sudo service bluetooth status
● bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
Active: inactive (dead)
Docs: man:bluetoothd(8)
root@jeedom:~# bluetoothctl
[bluetooth]# power on
No default controller available
[bluetooth]# agent on



J'ai ça .... Du coup c'est pas très grave, je m'acheterai un dongle bluetooth, mais c'est dommage qu'il crash autant

Re: Plugin blea

Publié : 01 févr. 2017, 02:42
par franckam6
Bonjour,
y a t il une chance de pouvoir se servir du plugin avec une apple watch comme pour un bracelet mi-band??
Par avance merci.

Re: Plugin blea

Publié : 01 févr. 2017, 08:17
par Anonyme
Contenu supprimé à la demande de son auteur

Re: Plugin blea

Publié : 01 févr. 2017, 18:11
par fwehrle
En même temps, une apple Watch non connectée à un iPhone, ca serait un peu dommage... :))

Cela dit, ca me fait penser à une question : pourquoi le plugin ne pourrait pas aussi faire de la détection BT (non BLE) , juste pour la présence?

Re: Plugin blea

Publié : 01 févr. 2017, 20:47
par franckam6
Effectivement, vu comme ça c'est très con comme question. lol
Désolé. Je vais prendre autre chose pour la présence.
Bonne soirée à tous .

Re: Plugin blea

Publié : 01 févr. 2017, 23:12
par Clingo
Bonsoir,

Je n'arrive pas à faire fonctionner le plugin BLEA sur Docker sur mon syno. La clé bluetooth est bien visible et fonctionne dans DSM 6 mais n'est pas vu dans le container.
J'arrive pourtant à faire tourner RFXcom + Z-wave + SMS avec une clé 3G qui utilisent tous aussi des ports USB (j'ai donc du mal à comprendre pourquoi ce serait différent pour le BT mais je ne suis pas un expert Linux).

Après de nombreuses recherches et lectures sur des forums je comprends que c'est normal car l'implémentation de Docker sur Syno n'est pas 100% "standard" et que la seule solution est d'avoir un RPi pour faire une antenne BLEA en dehors de Docker.

Je serais néanmoins ravi que quelqu’un me contredise ici :)


Merci et bonne soirée

Re: Plugin blea

Publié : 01 févr. 2017, 23:16
par Anonyme
Contenu supprimé à la demande de son auteur

Re: Plugin blea

Publié : 01 févr. 2017, 23:29
par treker
hello je suis sur une version VMWare player qui fonctionne a merveille normalement. en revanche je tente de brancher la clé ASUS recommandée par Sarakha63.
Mon serveur est un HP NL40 sous Win8 avec le player VMWare.
mais pour le coup je n'ai jamais branché de device USB sur mon jeedom.
J'ai bien plugué ma clé sur un port USB et fait connect via removal devices.

Le probleme c'est que dans le plugin et bien ce n'est pas detecté et que dans port Clé Bluetooth j'ai juste AUCUN.
Donc ma clé n'est pas detectée ou du moins je suppose que je n'ai pas le bluetooth installé sur mon jeedom.

en lisant le forum j'ai pu confirmé cela en faisant la commande suivante: systemctl status bluetooth
qui me retourne:

bluetooth.service
Loaded: not-found (reason: no such file or directory)
Active: inactive (dead)

C'est la que je bloque car je ne suis pas du tout expert ou sachant sous linux et je ne sais pas comment faire pour charger le bluetooth sur mon image jeedom.
J'ai trouvé des infos ici (http://www.domopi.eu/ajout-et-configura ... pberry-pi/) mais avant de faire de grosses betises, je prefere me tounrer vers quelqu'un sur le forum qui pourra m'aider a monter cela.

Si quelqu'un a un peu de temps a me consacrer ou peut m'aiguiller vers un bon tuto ce serait cool, j'apprend vite.; enfin j'essaye :-)

merci d'avance, et Sarakha63, super plugin broadlink j'ai donc hate de jouer avec le BLEA :-)

Re: Plugin blea

Publié : 01 févr. 2017, 23:43
par Anonyme
Contenu supprimé à la demande de son auteur

Re: Plugin blea

Publié : 02 févr. 2017, 00:09
par sakuraba
Qui pourrait me dire comment restaurer les images par défaut du dotti, je les ai plus ....

Elles se trouvent où normalement ?

merci

Re: Plugin blea

Publié : 02 févr. 2017, 00:19
par treker
magicgg91 a écrit :Hello,
Je connais bien ce tuto, c'est le mien :)
Mais il est plutot orienté Raspberry et un peu ancien, ça me fait pensée qu'il faudrait que je le mette à jour !

Les paquets à installer ont déjà été donnés plusieurs fois, sinon c'est Google qui pourra plus t'aider, le plugin blea n'y est pour rien pour le coup
Hey hey :-)
Oui je pensais aussi que le plugin n y était pour rien.
Bon faut que je trouve l info sur le forum ailleurs donc... damned 2 jours a lire sans trouver.
Vais tacher de chercher sur paquets... si je trouve pas je reviendrais demandef un peu d aide ;-)

edit: je l'avais dit que j'apprenais vite !! j'ai trouvé!!! :P bluetooth installé, et activé et je le retrouve bien maintenant dans mon config et mon Daemon est OK.
Bon y a plus qu'à tester et scanner.; on verra ca demain matin.

mille merci @magicgg91 pour m'avoir mis sur la piste.. recherche paquets, puis install bluetooth et au bout de 3 fils hop solution! de diou.. 2 jours que je cherche mais sans rien trouver !! tout est la sous mes yeux :-)

edit2: j'ai pas patienté et lancé un scan! ma balance Miscale est bien detectée.. vais bien dormir cette nuit je pense !! :-)

Re: Plugin blea

Publié : 02 févr. 2017, 02:48
par thera314
bluntananas a écrit :root@jeedom:~# sudo hciconfig hci0 up
Can't get device info: No such device
root@jeedom:~# sudo service bluetooth status
● bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
Active: inactive (dead)
Docs: man:bluetoothd(8)
root@jeedom:~# bluetoothctl
[bluetooth]# power on
No default controller available
[bluetooth]# agent on

J'ai ça .... Du coup c'est pas très grave, je m'acheterai un dongle bluetooth, mais c'est dommage qu'il crash autant
J'étais dans le même cas. Seul un downgrade à la version précédente de pi-bluetooth a corrigé le pb :

Code : Tout sélectionner

wget http://archive.raspberrypi.org/debian/pool/main/p/pi-bluetooth/pi-bluetooth_0.1.0_armhf.deb
puis

Code : Tout sélectionner

sudo dpkg -i pi-bluetooth_0.1.0_armhf.deb
et

Code : Tout sélectionner

apt-mark hold pi-bluetooth

Plugin blea

Publié : 02 févr. 2017, 07:45
par Tauks
Intéressant ! Si bluntananas valide que ça résout aussi son souci, je vais ptet tenter le coup (mais j'ai peur de la régression niveau dongle...). Car ça me permettrait d'avoir deux interfaces Bluetooth. L'interne apparié pour le TTS que j'ai du laisser tomber (en attendant que blea le permette) et le dongle pour blea :)


Envoyé de mon iPhone en utilisant Tapatalk