Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Demon antenne BLEA décroche sans arrêt

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Demon antenne BLEA décroche sans arrêt

Message par Fabrice » 29 déc. 2018, 23:54

Étonnant alors, j'ai cela sur mes 4 Raspberry pi.
- vous êtes certain de vos adresses Mac ?

Sinon, vous avez quelle version de bluepy ?
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

mistert
Timide
Messages : 30
Inscription : 28 avr. 2018, 21:24

Re: Demon antenne BLEA décroche sans arrêt

Message par mistert » 30 déc. 2018, 03:33

J'ai le même problème que vous sur mon raspberry pi zéro W. Des décrochage sans raisons apparentes. Je vais faire un script pour relancer automatiquement. En attendant une solution...

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Demon antenne BLEA décroche sans arrêt

Message par Fabrice » 30 déc. 2018, 10:09

Je viens de mettre à jour bluepy pour voir si cela le rend plus stable.
- Je n'ai fait cela que sur le Raspberry pi Zéro w.

D'après le changelog de bluepy il est fort possible que cela apporte beaucoup de corrections.

Il faut maintenant attendre. Car il arrive qu'il plante une fois par jour ou une fois tous les 10 jours...
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Jef73
Timide
Messages : 366
Inscription : 27 déc. 2017, 10:41
Localisation : Nantes

Re: Demon antenne BLEA décroche sans arrêt

Message par Jef73 » 30 déc. 2018, 11:04

Je l'ai fait aussi il y a une dizaine de jours, ainsi que la totalité de mon Raspbian et le "firmware" du RPI : aucun changement.
Mes 3 R.Pi sont en versions différentes et deux sont des 3B, le troisième un 3B+ : ils font les mêmes décrochages.

Dapolux
Timide
Messages : 229
Inscription : 12 déc. 2016, 13:48
Localisation : Lille

Re: Demon antenne BLEA décroche sans arrêt

Message par Dapolux » 30 déc. 2018, 17:09

Bonjour,

Pour ma part j'ai également ces décrochages (RPI3 egalement), mais pas aussi aléatoirement que vous, pour ma part c'est dans les secondes/minutes qui suivent le lancement. C'est à dire que je fait le lancement, l'antenne passe en vert, puis si je rechecke 30 secondes après, ça a déccorché.
Coté log, j'ai ceci:
Can't get device info: No such device
[2018-12-30 17:07:05][ERROR] : GLOBAL------Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'le on'

Une idée?
Jeedom DIY@RPI3
Aeon Stick Zwave : 15 FGR222, 2 FGS222, 6 FGD212, Oeil de Fibaro, 1 Wallplug
RFXCOM : 3 Prises, Téléco, 4 Sondes temp. / Moteur Somfy
Multimédia: Nas Synology / 2 KODI@RPI / Max2Play@RPI3
Xiaomi: 3 RGB Yeelight

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Demon antenne BLEA décroche sans arrêt

Message par Fabrice » 30 déc. 2018, 17:53

Bonjour.

Vous avez cela avec la bluetooth interne du Raspberry pi 3 ?
- c'est très étonnant. Le message indique qu'il ne trouve pas de dongle bluetooth compatible (bt4 minimum).

Vous avez bien sélectionné le bon port ?
Les dépendances sont bien installées ?
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Dapolux
Timide
Messages : 229
Inscription : 12 déc. 2016, 13:48
Localisation : Lille

Re: Demon antenne BLEA décroche sans arrêt

Message par Dapolux » 30 déc. 2018, 18:47

Oui c'est bien celui interne au RPI, ce qui est encore plus étonant, c'est que ça fonctionne correctement pendant quelques secondes.
Jeedom DIY@RPI3
Aeon Stick Zwave : 15 FGR222, 2 FGS222, 6 FGD212, Oeil de Fibaro, 1 Wallplug
RFXCOM : 3 Prises, Téléco, 4 Sondes temp. / Moteur Somfy
Multimédia: Nas Synology / 2 KODI@RPI / Max2Play@RPI3
Xiaomi: 3 RGB Yeelight

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Demon antenne BLEA décroche sans arrêt

Message par Fabrice » 30 déc. 2018, 18:56

Testez cette commande en ssh :
sudo hciconfig hci0

Contrôlez que vous n'avez pas cette ligne dans le fichier boot/config.txt
dtoverlay=pi3-disable-bt

Testez aussi avec un redémarrage du Raspberry pi.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Dapolux
Timide
Messages : 229
Inscription : 12 déc. 2016, 13:48
Localisation : Lille

Re: Demon antenne BLEA décroche sans arrêt

Message par Dapolux » 30 déc. 2018, 19:07

De plus en plus étonnant:

pi@RPI:~ $ sudo hciconfig hci0
Can't get device info: No such device

Sinon, je confirme ne pas avoir la ligne mentionnée dans le config.txt
Jeedom DIY@RPI3
Aeon Stick Zwave : 15 FGR222, 2 FGS222, 6 FGD212, Oeil de Fibaro, 1 Wallplug
RFXCOM : 3 Prises, Téléco, 4 Sondes temp. / Moteur Somfy
Multimédia: Nas Synology / 2 KODI@RPI / Max2Play@RPI3
Xiaomi: 3 RGB Yeelight

mistert
Timide
Messages : 30
Inscription : 28 avr. 2018, 21:24

Re: Demon antenne BLEA décroche sans arrêt

Message par mistert » 02 janv. 2019, 00:09

Fabrice a écrit :
30 déc. 2018, 10:09
Je viens de mettre à jour bluepy pour voir si cela le rend plus stable.
- Je n'ai fait cela que sur le Raspberry pi Zéro w.

D'après le changelog de bluepy il est fort possible que cela apporte beaucoup de corrections.

Il faut maintenant attendre. Car il arrive qu'il plante une fois par jour ou une fois tous les 10 jours...
Vous avez des bugs depuis ?

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Demon antenne BLEA décroche sans arrêt

Message par Fabrice » 02 janv. 2019, 00:12

Uniquement sur l'antenne blea sur un Raspberry pi Zéro w.
L'autre n'a jamais eu le moindre problème.

Je vais la remplacer par un Raspberry pi 3 b+ pour voir si cela fait disparaitre ce problème.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2714
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Demon antenne BLEA décroche sans arrêt

Message par Theduck38 » 06 janv. 2019, 14:15

J'ai fait quelques tests sur ma GH avec un scanner BLE sur mon téléphone...

Il s'avère que la GH spamme des émissions toutes les secondes (ou 2s ?), et change d'adresse mac toutes les 6 minutes.Dans mon cas elle est à 4m du récepteur Blea ; et je perds en niveau de réception très rapidement en m'éloignant de la GH. C'est peut-être pour cela que je n'ai pas de décrochage...
Je n'ai pas testé, mais il est aussi possible qu'elle augmente sa puissance d'émission en cas de perte wifi.
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

coolfunk
Timide
Messages : 30
Inscription : 30 nov. 2018, 12:41
Localisation : Essonne

Re: Demon antenne BLEA décroche sans arrêt

Message par coolfunk » 09 janv. 2019, 09:44

Bonjour,

je galère pas mal avec le plugin BLEA, j'ai essayé l'antenne interne du RPI et ensuite un dongle Trendnet.
Mais à chaque fois j'ai l'antenne qui reste en vert (avec le cœur) quelque secondes et ensuite se déconnecte.

J'ai fais pas mal de manipulation en SSH, et j'ai peur que cela causes plus de problèmes maintenant.

Je souhaiterais repartir d'une base saine si je peux dire, car le fait de supprimer le plugin BLEA et les antennes ne suffit pas.
Je ne sais pas qu'elles sont les commandes à lancer pour cela.

Merci

coolfunk
Timide
Messages : 30
Inscription : 30 nov. 2018, 12:41
Localisation : Essonne

Re: Demon antenne BLEA décroche sans arrêt

Message par coolfunk » 10 janv. 2019, 10:39

Bonjour,

j'ai mon antenne qui décroche au bout d'1 minute et en regardant sur les log apparait une adresse IP que je ne connais pas (127.0.0.1:80).

Est ce que c'est normal?

[2019-01-10 10:10:10][INFO] : Lancement démon blea : sudo /usr/bin/python /var/www/html/plugins/blea/resources/blead/blead.py --loglevel debug --device hci0 --socketport 55008 --sockethost 127.0.0.1 --callback http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php --apikey hHQvD8juvQ76Atljriqrux4QFpp2csYS --daemonname local --pid /tmp/jeedom/blea/deamon.pid



Merci

Avatar de l’utilisateur
cadavor
Actif
Messages : 1284
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: Demon antenne BLEA décroche sans arrêt

Message par cadavor » 10 janv. 2019, 10:46

coolfunk a écrit :
10 janv. 2019, 10:39
Bonjour,

j'ai mon antenne qui décroche au bout d'1 minute et en regardant sur les log apparait une adresse IP que je ne connais pas (127.0.0.1:80).

Est ce que c'est normal?

[2019-01-10 10:10:10][INFO] : Lancement démon blea : sudo /usr/bin/python /var/www/html/plugins/blea/resources/blead/blead.py --loglevel debug --device hci0 --socketport 55008 --sockethost 127.0.0.1 --callback http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php --apikey hHQvD8juvQ76Atljriqrux4QFpp2csYS --daemonname local --pid /tmp/jeedom/blea/deamon.pid

Merci
Si c'est bien les logs de l'antenne (et non ceux du demon principal) alors non ce n'est pas normal.
Vérifie la configuration Réseau de Jeedom.
Jeedom Stable 3.3
NUC Z83 + Aeotec Z-Stick Gen5
Z-Wave FGR + FGMS + FGDS + FGFS + FGK + FGWPE + ZW062 + ZW080
GH Mini + Orvibo AllOne + Playbulb + Miband2

coolfunk
Timide
Messages : 30
Inscription : 30 nov. 2018, 12:41
Localisation : Essonne

Re: Demon antenne BLEA décroche sans arrêt

Message par coolfunk » 10 janv. 2019, 11:02

Dans la config reseau, est indiqué Lo 127.0.0.1 (mais je connais pas cette ip) et en bas eth0 192.168.1.103 , qui est bien l'adresse que j'utilise pour communiquer avec mon RPI.

Gouzou
Timide
Messages : 94
Inscription : 17 déc. 2014, 13:00

Re: Demon antenne BLEA décroche sans arrêt

Message par Gouzou » 10 janv. 2019, 15:40

127.0.0.1 signifie "moi meme" en gros. Un ping sur 127.0.0.1 signifie se pinger directement

coolfunk
Timide
Messages : 30
Inscription : 30 nov. 2018, 12:41
Localisation : Essonne

Re: Demon antenne BLEA décroche sans arrêt

Message par coolfunk » 10 janv. 2019, 17:06

Ok merci donc rien d'anormal de ce coté alors.
Je continue mes recherches pour trouver pourquoi mon demon ne tient pas dans le temps (pas plus d'1-2 minutes)

Jef73
Timide
Messages : 366
Inscription : 27 déc. 2017, 10:41
Localisation : Nantes

Re: Demon antenne BLEA décroche sans arrêt

Message par Jef73 » 10 janv. 2019, 17:54

Bah pour la même raison que beaucoup d'entre nous ;-)
Relis à partir de la page 5 de ce même topic et éventuellement les 4 ou 5 autres sujets de cette même section du forum qui parlent aussi de décrochage et/ou de plantage des antennes.
Y'a un tuto pas loin pour relancer automatiquement le démon sur les antenne avec l'outil "monit" : ça marche parfaitement chez moi ;)

coolfunk
Timide
Messages : 30
Inscription : 30 nov. 2018, 12:41
Localisation : Essonne

Re: Demon antenne BLEA décroche sans arrêt

Message par coolfunk » 25 janv. 2019, 10:05

Bonjour,

merci Jef73, j'ai également parcourus plusieurs pages et sujets à ce sujet mais je n'arrive toujours pas une solution qui fonctionne correctement.

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités