Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Nut mini toujours présent

Répondre
Fabske
Timide
Messages : 38
Inscription : 09 juil. 2018, 09:14

Nut mini toujours présent

Message par Fabske » 29 janv. 2019, 20:19

Hello,

Je viens d'acheter 2 nut mini et j'ai pas mal de problème avec.
J'ai lu la plupart des sujet, et hier j'ai donc bien mis le mode toujours actif (qu'il signale quand le nut et plus là) sur l'application, ensuite je me suis déconnecté de l'app (j'ai pas trouvé la manière douce, donc j'ai fait la manière forte: supprimer le cache et les data de l'app, ça a marché).
Ca me semblait un peu mieux (moins de passage absent/présent), mais à vérifier dans la durée.

Par contre aujourd'hui, là je suis au bureau (et oui, encore là à passé 20h :( ) et je vois que je suis présent à la maison ... pareil pour ma femme, tous les deux présents toute la journée. Là elle est réellement présente, et 2x/min j'ai bien le log en real time du genre:
[2019-01-29 20:02:03][INFO] : Evènement sur la commande [Aucun][Nut M][Rssi local] valeur : -82
[2019-01-29 20:02:03][INFO] : Evènement sur la commande [Aucun][Nut M][Present] valeur : 1
[2019-01-29 20:02:03][INFO] : Evènement sur la commande [Aucun][Nut M][Données brutes] valeur : [(9, 'Complete Local Name', u'nut'), (3, 'Complete 16b Services', u'0318'), (255, 'Manufacturer', u'59000018'), (22, '16b Service Data', u'0a18ecc1ad497011'), (1, 'Flags', u'06')] (répétition)
Par contre pour mon nut, aucun log.
Si j'execute la commande refresh, elle n'apparait pas dans le log (si je fais de même pour celui de ma femme il apparait bien)
Dans "Santé BLEA" la dernière communication date de ce matin (2019-01-29 08:57:20), j'ai statut OK vert, rssid -87 orange.
Mon nut apparaît dans le réseau.
J'ai pas d'antenne additionnelle.

J'ai redémarré le service blea, executé la commande refresh, rien à faire il me considère toujours comme présent. J'ai vérifié j'ai bien mon nut dans la poche, donc soit y a un bug soit j'ai le bluetooth qui capte à 40km de distance :D

Une idée pour que ce cas soit bien géré ? Car le nut me servira a me rappeller d'activer l'alarme donc j'aimerais que ce soit stable

(Accessoirement, j'ai google sur 'Nut mini toujours présent" et le 1er topic ici me mène sur une page qui dit que le sujet est introuvable ... j'ai ça assez souvent sur les liens retourné par google. Et le sujet n'existe pas quand je fais la recherche directement sur le forum)

Merci pour votre aide

winhex
Actif
Messages : 3799
Inscription : 23 janv. 2015, 01:41

Re: Nut mini toujours présent

Message par winhex » 29 janv. 2019, 21:18

bonjour
oublie jeedom
concentre toi sur le demon du plug blea

si le plug à une erreur (bug) jeedom la retransmet

icône santé
Screenshot_20190129-211428_Chrome.jpg
Screenshot_20190129-211428_Chrome.jpg (232.16 Kio) Consulté 1009 fois
si la date de dernière com est > 2mn la tu as une erreur de plug

a relancer
a mon avis le status n'est pas ok
Screenshot_20190129-211736_Chrome.jpg
Screenshot_20190129-211736_Chrome.jpg (325.19 Kio) Consulté 1009 fois
ou/et gestion automatique désactivé
tu ne dois pas voir l'icône stop
(relance le plug automatiquement)

le tuto du créateur du plug t'en dira plus
http://sarakha63-domotique.fr/blea-plug ... th-jeedom/

znation
Actif
Messages : 1951
Inscription : 12 nov. 2014, 15:48

Re: Nut mini toujours présent

Message par znation » 29 janv. 2019, 23:17

J'ai déjà rencontré ce genre de problème avec mes but, la présence c'était plus bien gérée.

Mon seul échappatoire était de le supprimer et de rededecter en nouveau device

Envoyé de mon Mi A2 en utilisant Tapatalk

JEEDOM v3.3.31 - NUC Z83 II

Fabske
Timide
Messages : 38
Inscription : 09 juil. 2018, 09:14

Re: Nut mini toujours présent

Message par Fabske » 30 janv. 2019, 23:01

@winhex merci pour tes idées
Le statut est bien sur OK dans blea, et j'avais essayé de relancer le plugin (qui est configuré sur automatique)

Quand je suis présent la date de dernière communication se met bien à jour.
D'après lui aujourd'hui je n'ai pas quitté la maison depuis mardi 9h ... j'aurais bien voulu :D
Par contre apparemment mardin 9h correspondrait +/- à l'heure de coupure du courant par l'électricien ... donc je crois pas aux coïncidences, ça doit être lié.

@znation je vais essayer et voir ce que ça donne, merci :)

winhex
Actif
Messages : 3799
Inscription : 23 janv. 2015, 01:41

Re: Nut mini toujours présent

Message par winhex » 30 janv. 2019, 23:40

donc tu as à eu un redémarrage jeedom sans relancé du démon ?
j'ai déjà lu se soucis

Fabske
Timide
Messages : 38
Inscription : 09 juil. 2018, 09:14

Re: Nut mini toujours présent

Message par Fabske » 31 janv. 2019, 00:19

Oui redémarrage abrupt ... faudrait que je mette un ondulateur.
Le daemon était lancé quand j'ai regardé, et je l'ai relancé pour être sûr mais pas de changement
là j'ai exclus / inclu le nut, on verra demain si il me met absent quand je pars :)

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: Nut mini toujours présent

Message par Mips2648 » 31 janv. 2019, 09:28

Bête question peut-être, mais as-tu bien une valeur de retour d'état configurée?
En principe c'est fait automatiquement mais vérifie:
- sur la commande info "present", tu dois avoir un retour d'état à 0 après 2min (au moins), si tu met plus, ca mettra plus de temps à te voir absent
- sur toutes les commandes info "rssixxx" tu dois avoir un retour d'état à -200 après 2min aussi.

c'est ce principe de retour d'état qui fait que tu es vu comme absent, le nut signalant sa présence environ toutes les min. dès qu'il n'est plus vu pendant assez longtemps, tu es absent.

si tu n'as aucun log sur ton nut, le retour d'état aurait du te mettre absent...
et d'après moi, ce n'est pas un problème démon qui empêcherait de passer absent, au contraire...
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Fabske
Timide
Messages : 38
Inscription : 09 juil. 2018, 09:14

Re: Nut mini toujours présent

Message par Fabske » 02 févr. 2019, 16:51

@Mips2648 Très bonne idée, j'y avait pas pensé. Mais comme j'y ai pas touché il y a en effet bien ces valeurs présentes.

Image

Sinon, j'ai pas pu tester si exclure/inclure le nut avait fonctionné, car j'ai un souci matériel sur la box. Je traiterais donc ce pb de nut plus tard :)

chesmet
Timide
Messages : 27
Inscription : 21 mars 2018, 00:21

Re: Nut mini toujours présent

Message par chesmet » 10 févr. 2019, 17:43

J'ai eu un problème identique, c'était du au Bluetooth du Raspberry.
Je te conseille de voir s'il est bien activé, en suivant ce qu'il y a ici:
viewtopic.php?t=24818

Perso ça avait résolu le problème

scotty92fr
Timide
Messages : 262
Inscription : 07 mars 2017, 20:31

Re: Nut mini toujours présent

Message par scotty92fr » 30 avr. 2019, 18:30

bonjour,

Sur un de mes « Nut find 3 », la présence est toujours signalée, bien que la dernière communication date de "2019-04-28 17:30:01" soit il y a 2 jours.

C'est en vérifiant, après l'application de la MAJ de Jeedom 3.3.24, ce matin, que je me suis aperçu de l'état du « Nut find 3 », mais je ne pense pas que cette MAJ soit est en cause, car même après restauration d'avant le passage, le « Nut find 3 », reste présent.

Le retour d'état de présent à 0 au bout de 2 min ne se fait plus.

Jusqu'à présent, ce « Nut » fonctionnait parfaitement. Rien de changé du côté du Bluetooth ou du plugin blea (version 2019-01-16 16:50:30) . Les autres « Nut find 3 » semblent fonctionner correctement en tout cas au moins 2 d'entre eux.

La commande « Refresh » ne change rien.

J'ai vérifié et rebooté Jeedom (rpi3+) et les 2 antennes (RPI zéro W et RPI 3 avec adaptateur BT USB) . Le Bluetooth fonctionne correctement sur chaque RPI.

la zone sont bien renseignés : Valeur retour d'état = 0 et Durée avant retour d'état (min) = 2

J’ai essayé de modifier ces valeurs, histoire de réinitialiser la mécanique, mais rien n’y fait.

Si je n’ai pas le choix, je vais être obligé de supprimer et recréer le « Nut », mais étant donné qu'il n'est pas là (mes enfants ne sont plus à la maison :) ) et cela va être un peu compliqué.

Est-ce que quelqu'un aurait une idée pour remettre la valeur à 0 ?

Edit: ce qui est bizarre c'est que sur le graphique d'historique la valeur est à zero depuis le 28-04 à 17:44:06
Jeedom 4.0.35 DIY RPI3/SSD , Zwave - Rfxcom - ...

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Nut mini toujours présent

Message par Fabrice » 30 avr. 2019, 21:28

Bonsoir.

Il ne faut rien faire. Quand le Nut rêvera l'antenne il fonctionnera de nouveau.

La fois où j'ai eu cela, c'était lors d'un arrêt de BLEA (ou de la désactivation du Nut) et que le Nut était partie de la maison entre temps. Donc le plugin ne l'a pas vue partir.
- C'est la seule explication logique que j'y vois.

Cela est arrivé à d'autre personnes dans des situations identiques.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

scotty92fr
Timide
Messages : 262
Inscription : 07 mars 2017, 20:31

Re: Nut mini toujours présent

Message par scotty92fr » 30 avr. 2019, 22:30

Ok je vais laisser en l’état. Merci beaucoup.

Mais je pense qu’il y a un bug la durée avant retour d’état devrait être là pour parer à ce genre de problème si j’ai bien compris? Je devrais peut être ouvrir un ticket ?


Envoyé de mon iPhone en utilisant Tapatalk
Jeedom 4.0.35 DIY RPI3/SSD , Zwave - Rfxcom - ...

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Nut mini toujours présent

Message par Fabrice » 30 avr. 2019, 22:39

Le Nut en question a-t-il quitté la maison alors qu'il était désactivé ou que le plugin était désactivé ?
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

scotty92fr
Timide
Messages : 262
Inscription : 07 mars 2017, 20:31

Nut mini toujours présent

Message par scotty92fr » 30 avr. 2019, 23:02

Le nut est plus ressent que le miens et je n’ai pas encore changé de batterie. Et je n’ai pas désactivé le plugin.

Seul chose possible, un plantage du système. Et c’est possible. Le RPI de Jeedom a bien planté ce jour là, mais je ne sais plus exactement quand, surtout si c’est avant l’arrivée des enfants ou pas.

Ce qui corrobore probablement ton analyse. Ce doit être sur le principe de cron. Une fois l’heure passé c’est passé, dommage.

Merci Fabrice.

Envoyé de mon iPhone en utilisant Tapatalk
Jeedom 4.0.35 DIY RPI3/SSD , Zwave - Rfxcom - ...

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités