Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Répondre
agasi34
Timide
Messages : 71
Inscription : 31 mai 2017, 10:23

[HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par agasi34 » 02 mai 2019, 14:36

Bonjour à tous,

Je suis désolé je sais que le sujet a été abordé dans plusieurs posts sur le forum, mauis n'arrivant toujours pas à trouver la solution, j'ai décidé de poster mon soucis.

Voici ma config :

- 1 rpi3 avec jeedom + connecteur bluetooth sena qui me sert d'antenne BLEA principale
- 1 rpi3 avec osmc qui me sert principalement de média center auquel j'aimerai rajouté une antenne secondaire BLEA avec son bluetooth interne.

Ca parait simple, j'ai bien suivi les procédures d'installation des dépendances sur mon 2ème rpi osmc, mais impossible de faire fonctionner cette antenne bluetooth. Voici mon problème :

Quand je renseigne mes id de connexion ssh dans le plugin BLEA de mon 1er rpi jeedom, et que j'envoie les fichiers, ça me marque" envoi réussi" et directement après un message sur l'interface jeedom "connexion ssh ko". Je supose donc qu'il n'arrive pas à envoyer via ssh les fichiers d'installation des dépendances. Je me suis connecté via ssh à osmc, et effectivement je ne vois aucun fichier de dépendance... Je pense donc que le problème vient de là.

Quelqu'un à t'il la même config que moi ?

Merci par avance !

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par Fabrice » 02 mai 2019, 15:57

Bonjour.

C'est les identifiants du Rpi cible qu'il faut indiquer et pas ceux du source.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

agasi34
Timide
Messages : 71
Inscription : 31 mai 2017, 10:23

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par agasi34 » 02 mai 2019, 16:47

Fabrice a écrit :
02 mai 2019, 15:57
Bonjour.

C'est les identifiants du Rpi cible qu'il faut indiquer et pas ceux du source.
Merci Fabrice pour ta réponse !

C'est bien les ids ssh du rpi cible (celui sous osmc) que je renseigne dans le plugin. Et je suis sûr des identifiants car j'arrive à me connecter via putty dessus sans prob.
Vraiement je ne comprends pas pourquoi le plugin BLEA n'arrive pas à envoyer via ssh sur mon rpi cible ...

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par Fabrice » 02 mai 2019, 17:17

Vous avez bien mis le numéro du port 22 (il est indiqué par défaut mais il faut le saisir).
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

agasi34
Timide
Messages : 71
Inscription : 31 mai 2017, 10:23

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par agasi34 » 02 mai 2019, 18:38

Fabrice a écrit :
02 mai 2019, 17:17
Vous avez bien mis le numéro du port 22 (il est indiqué par défaut mais il faut le saisir).
Oui ...

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par Fabrice » 02 mai 2019, 20:09

Testez avec le compte root
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

agasi34
Timide
Messages : 71
Inscription : 31 mai 2017, 10:23

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par agasi34 » 02 mai 2019, 20:25

Fabrice a écrit :
02 mai 2019, 20:09
Testez avec le compte root
Merci Fabrice de me répondre, oui j'ai activé l'utilisateur Root et défini un mdp mais même chose ... L'envoi des fichiers me génère un beau connexion ssh KO ... Peut être une incompatibilité avec osmc ?

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par Fabrice » 02 mai 2019, 20:34

Non c'est compatible, plusieurs l'on déjà fait ici.

En suivant ce tutoriel regardez si cela ne vous aide pas à trouver la solution :
http://sarakha63-domotique.fr/rasberry- ... -possible/

Pour moi c'est une problème de droit ou de réseau.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

agasi34
Timide
Messages : 71
Inscription : 31 mai 2017, 10:23

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par agasi34 » 03 mai 2019, 10:03

Fabrice a écrit :
02 mai 2019, 20:34
Non c'est compatible, plusieurs l'on déjà fait ici.

En suivant ce tutoriel regardez si cela ne vous aide pas à trouver la solution :
http://sarakha63-domotique.fr/rasberry- ... -possible/

Pour moi c'est une problème de droit ou de réseau.
Salut Fabrice, oui je pense que c'est bien un problème de droit sudo ou autre ... Je vais plutôt me tourner vers une installation raspbian qui a l'air plus adaptée. Merci en tout cas pour ton aide !

Jef73
Timide
Messages : 366
Inscription : 27 déc. 2017, 10:41
Localisation : Nantes

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par Jef73 » 11 mai 2019, 16:13

Il faut aussi vérifier si les noms des dossiers utilisés par les script d'installation sont bien existants et il me semble aussi de mémoire que le Home de l'utilisateur doit être pareil aussi (root, pi, etc. celui qui est utilisé quoi).

phyllox
Timide
Messages : 113
Inscription : 22 janv. 2019, 17:47

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par phyllox » 12 mai 2019, 13:33

Bonjour tout le monde

Je me permets d'intervenir car j'ai aussi un souci d'installation d'antenne sur un Raspberry 3 avec OSMC.
Hier, je l'avais installé sous Raspbian, mais Kodi (18.2) ne fonctionnait pas - je lis les fichiers sur mon NAS Synology, et si la base de donnée était bien changée, les vidéos ne se lisaient pas (pas de démarrage, sauf avec un Esc, puis un click sur la vidéo toujours en cours... Et grosse lenteurs avec freeze. Enfin, ça n'est pas le sujet.
Avec Raspbian, l'antenne fonctionnait parfaitement, installation sans anicroche.

J'ai donc réinstallé le Pi avec OSMC et là, Kodi fonctionne à merveille, toute ma base est là, et les vidéo sont lues sans souci.
Version de OSMC 2019.04-1

Par contre impossible d'avoir l'antenne fonctionnelle.
J'ai bien renseignée l'IP et le port 22, les identifiant et mot de passe de la machine OSMC. L'envoi fonctionne en tous cas j'ai le message.
Le Pi est un 3 B+ et il est connecté en Ethernet (wifi désactivé tant pour les essais Raspbian que OSMC).
Le système est installé sur une clé USB (avec boot sur carte SD obligatoire à priori pour OSMC).

Je rencontre des erreurs dans l'installation des dépendances, et les logs me donnent aussi des erreurs.
Déjà, côté Pi, je ne trouve pas le répertoire blead dont j'ai lu sur un tutoriel qu'il était créé par l'envoi des fichiers.

Voici les logs de l'installation des dépendances.
Launch install of blea dependancy
Get:1 http://security.debian.org stretch/updates InRelease [94.3 kB]
Ign:2 http://ftp.debian.org/debian stretch InRelease
Hit:4 http://ftp.debian.org/debian stretch-updates InRelease
Hit:5 http://ftp.debian.org/debian stretch Release
Hit:3 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Fetched 94.3 kB in 1s (47.2 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
python-requests is already the newest version (2.12.4-1).
The following additional packages will be installed:
binutils bluez bzip2 cpp cpp-6 dpkg-dev g++ g++-6 gcc gcc-6 libasan3
libatomic1 libc-dev-bin libc6-dev libcc1-0 libdpkg-perl libexpat1-dev
libgcc-6-dev libgdbm3 libgomp1 libisl15 libmpc3 libmpfr4 libperl5.24
libpython-dev libpython2.7-dev libstdc++-6-dev libubsan0 linux-libc-dev make
patch perl perl-modules-5.24 python-pip-whl python2.7-dev
Suggested packages:
binutils-doc bluez-cups bluez-obexd bzip2-doc cpp-doc gcc-6-locales
debian-keyring gcc-6-doc libstdc++6-6-dbg gcc-multilib manpages-dev autoconf
automake libtool flex bison gdb gcc-doc libgcc1-dbg libgomp1-dbg libitm1-dbg
libatomic1-dbg libasan3-dbg liblsan0-dbg libtsan0-dbg libubsan0-dbg
libcilkrts5-dbg libmpx2-dbg libquadmath0-dbg glibc-doc libstdc++-6-doc
make-doc ed diffutils-doc perl-doc libterm-readline-gnu-perl
| libterm-readline-perl-perl
Recommended packages:
fakeroot libalgorithm-merge-perl manpages manpages-dev
libfile-fcntllock-perl liblocale-gettext-perl libssl-doc rename
python-all-dev python-setuptools python-wheel
The following NEW packages will be installed:
binutils bluetooth bluez build-essential bzip2 cpp cpp-6 dpkg-dev g++ g++-6
gcc gcc-6 libasan3 libatomic1 libc-dev-bin libc6-dev libcc1-0 libdpkg-perl
libexpat1-dev libffi-dev libgcc-6-dev libgdbm3 libgomp1 libisl15 libmpc3
libmpfr4 libperl5.24 libpython-dev libpython2.7-dev libssl-dev
libstdc++-6-dev libubsan0 linux-libc-dev make patch perl perl-modules-5.24
python-dev python-pip python-pip-whl python2.7-dev
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (you may need to install the Term::ReadLine module) (@INC contains: /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/arm-linux-gnueabihf/perl5/5.24 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/arm-linux-gnueabihf/perl-base .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7, <> line 41.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 41 newly installed, 0 to remove and 11 not upgraded.
Need to get 0 B/67.9 MB of archives.
After this operation, 182 MB of additional disk space will be used.
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
dh-python git-man libc-dev-bin libc6-dev libcurl3-gnutls libdpkg-perl
liberror-perl libgdbm3 libglib2.0-bin libglib2.0-data libmpdec2 libpcre16-3
libpcre3-dev libpcre32-3 libperl5.24 libpython3-stdlib libpython3.5-minimal
libpython3.5-stdlib linux-libc-dev perl perl-modules-5.24 pkg-config python3
python3-minimal python3.5 python3.5-minimal zlib1g-dev
Suggested packages:
gettext-base git-daemon-run | git-daemon-sysvinit git-doc git-el git-email
git-gui gitk gitweb git-arch git-cvs git-mediawiki git-svn glibc-doc
manpages-dev debian-keyring gcc | c-compiler binutils patch libglib2.0-doc
perl-doc libterm-readline-gnu-perl | libterm-readline-perl-perl make
python3-doc python3-tk python3-venv python3.5-venv python3.5-doc
binfmt-support
Recommended packages:
patch rsync manpages manpages-dev libfile-fcntllock-perl
liblocale-gettext-perl bzip2 rename
The following NEW packages will be installed:
dh-python git git-man libc-dev-bin libc6-dev libcurl3-gnutls libdpkg-perl
liberror-perl libgdbm3 libglib2.0-bin libglib2.0-data libglib2.0-dev
libmpdec2 libpcre16-3 libpcre3-dev libpcre32-3 libperl5.24 libpython3-stdlib
libpython3.5-minimal libpython3.5-stdlib linux-libc-dev perl
perl-modules-5.24 pkg-config python3 python3-minimal python3.5
python3.5-minimal zlib1g-dev
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (you may need to install the Term::ReadLine module) (@INC contains: /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/arm-linux-gnueabihf/perl5/5.24 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/arm-linux-gnueabihf/perl-base .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7, <> line 29.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 29 newly installed, 0 to remove and 11 not upgraded.
Need to get 0 B/29.0 MB of archives.
After this operation, 118 MB of additional disk space will be used.
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)
sudo: pip: command not found
sudo: pip: command not found
sudo: pip: command not found
sudo: pip: command not found
sudo: pip: command not found
sudo: git: command not found
/home/osmc/blead/resources/install.sh: line 21: cd: /tmp/bluepy: No such file or directory
python: can't open file 'setup.py': [Errno 2] No such file or directory
python: can't open file 'setup.py': [Errno 2] No such file or directory
rm: cannot remove '/tmp/bluepy': No such file or directory
Everything is successfully installed!
Ensuite voici les logs de la machine antenne
Traceback (most recent call last):
File "/home/osmc/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named bluepy.btle
Traceback (most recent call last):
File "/home/osmc/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named bluepy.btle
Traceback (most recent call last):
File "/home/osmc/blead/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named bluepy.btle
Il y a visiblement quelque chose qui cloche. Puisque d'autres y sont arrivés, un souci avec la version de OSMC ??

Je ne peux pas installer une version plus ancienne car j'ai 2 autres Kodi sur d'autres machines, tout le monde accède à la même base dans sa dernière version.

Est-ce que ces logs parlent à quelqu'un ? Quelque chose que je peux vérifier ?
Merci d'avance.

Rave
Timide
Messages : 53
Inscription : 02 avr. 2016, 23:57

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par Rave » 12 juin 2019, 12:11

Bonjour,

J'ai le même problème que Agasi34, mais avec une Vero 4k (OSMC).
Quand j'essaie d'envoyer les fichiers j'ai droit à un beau

Code : Tout sélectionner

connexion SSH KO for OSMC (antenne)
en retour. Pourtant tout comme Agasi34 le SSH fonctionne bien avec Putty avec les usr/mdp par défaut (osmc/osmc). Y a-t-il quelqu'un qui a une Vero 4k et pour qui ça marche? Ou bien y a-t-il quelqu'un qui peut m'aider?

Merci

Jef73
Timide
Messages : 366
Inscription : 27 déc. 2017, 10:41
Localisation : Nantes

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par Jef73 » 12 juin 2019, 16:16

Je dirais à vue de nez qu'il vous manque probablement un de ces éléments-là :
- python
- pip
- le paquet pip "bluepy"

Et dans le dossiers suivant, vérifier que les fichiers d'installation se copient bien :
- /home/root/blead/resources/
[ou]
- /home/osmc/blead/resources/

Samuel14
Timide
Messages : 454
Inscription : 27 août 2014, 17:39
Localisation : Caen

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par Samuel14 » 30 juil. 2019, 14:14

Je suis actuellement dans le même cas que vous, ce qui m’énerve un peu c'est que j'ai fait un tuto spécial installation de BLEA sur OSMc mais que ce dernier a été supprimé du forum :(
De mémoire il fallait créer ou activer le compte root, basculer en root, faire l'installation de BLEA en ligne de commande depuis le compte root.
+ différentes bidouilles et ensuite le démon se lançait correctement depuis jeedom avec le compte OSMC.
Z83II + zstick Aeotec sw090 (51 nœuds Z-Wave), Clé 3G Huawei E172, rfplayer (portail, Pergola Somfy), Station météo Netatmo, Xiaomi (Gateway 31 nœuds, Aspi v1, lampe de chevet v1 et v2, rideau), nut, Google Home, Alexa, Squeezebox, Tondeuse Worx

Avatar de l’utilisateur
cadavor
Actif
Messages : 1284
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par cadavor » 30 août 2019, 23:57

Pour ma part, avec la dernière version de OSMC, il manquerait juste un paquet Python
Un petit coup de SSH sur l'antenne :

Code : Tout sélectionner

sudo pip3 install wheel
Puis relancer l'installation des dépendances depuis Jeedom pour cette antenne OSMC et tout s'est bien passé.
Jeedom Stable 3.3
NUC Z83 + Aeotec Z-Stick Gen5
Z-Wave FGR + FGMS + FGDS + FGFS + FGK + FGWPE + ZW062 + ZW080
GH Mini + Orvibo AllOne + Playbulb + Miband2

Samuel14
Timide
Messages : 454
Inscription : 27 août 2014, 17:39
Localisation : Caen

Re: [HELP] Mettre en place une antenne BLEA avec Rpi3 interne

Message par Samuel14 » 16 sept. 2019, 17:22

C'est plus simple !
N'utilisant plus kodi sur le RPI mais sur une Shield, j'ai réinstallé le RPI en Raspbian.
Z83II + zstick Aeotec sw090 (51 nœuds Z-Wave), Clé 3G Huawei E172, rfplayer (portail, Pergola Somfy), Station météo Netatmo, Xiaomi (Gateway 31 nœuds, Aspi v1, lampe de chevet v1 et v2, rideau), nut, Google Home, Alexa, Squeezebox, Tondeuse Worx

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité