Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin SMS

leon-99
Timide
Messages : 238
Inscription : 09 févr. 2016, 18:34
Localisation : Limoges (ou presque)

Re: Plugin SMS

Message par leon-99 » 04 avr. 2019, 14:20

Chez moi texte mode n'est PAS coché..... et ca a toujours bien fonctionné comme ca !!(j'ai une Huawei E220)

Avatar de l’utilisateur
Chrisax
Timide
Messages : 104
Inscription : 09 oct. 2017, 15:05

Re: Plugin SMS

Message par Chrisax » 04 avr. 2019, 19:22

Chez moi également. Je viens de le cocher et j'ai l'erreur d'encodage.
Jeedom sur nuc/proxmox + dongle Aeotec GEN5 et RfxCom
Ecran de contrôle sur Rpi 3B+ et Google Voice Kit

Idaho947
Actif
Messages : 1281
Inscription : 30 mai 2017, 21:36

Re: Plugin SMS

Message par Idaho947 » 04 avr. 2019, 20:29

J'ai un soucis avec ce plug-in. Tout est ok (deamon, dependance...) mais je ne reçois aucun sms pourtant comme je le disais tout passe bien dans les logs. J'ai essayé vers d'autres portable mais c'est pareil. Quand j'envois les sms j'ai l'impression que jeedom ne les reçois pas. Quelqu'un a une idée ?

Avatar de l’utilisateur
Chrisax
Timide
Messages : 104
Inscription : 09 oct. 2017, 15:05

Re: Plugin SMS

Message par Chrisax » 04 avr. 2019, 20:41

Tu as ajouté les numéros des expéditeurs dans la config de ton équipement ?
Dans l'administration de jeedom, l'accès API est en localhost ?
Jeedom sur nuc/proxmox + dongle Aeotec GEN5 et RfxCom
Ecran de contrôle sur Rpi 3B+ et Google Voice Kit

Idaho947
Actif
Messages : 1281
Inscription : 30 mai 2017, 21:36

Re: Plugin SMS

Message par Idaho947 » 04 avr. 2019, 20:51

Oui tout fonctionnais jusqu'à hier. Et tout a l'air de toujours fonctionné en théorie mais je ne reçois aucun message.

EDIT : OK probablement pb réseau ça refonctionne

romu044
Timide
Messages : 89
Inscription : 01 déc. 2015, 12:59

Re: Plugin SMS

Message par romu044 » 05 avr. 2019, 14:15

Chrisax a écrit :
04 avr. 2019, 19:22
Chez moi également. Je viens de le cocher et j'ai l'erreur d'encodage.
Sur mon RPi2 c'était coché et cela fonctionne bien (avec ma huawei E1752, j'ai pas testé la E220 dessus)

Je vais essayé en décochant et je te dis.

Merci pour ton aide

Titof2375
Helper
Messages : 656
Inscription : 22 août 2017, 18:59

Re: Plugin SMS

Message par Titof2375 » 05 avr. 2019, 18:49

bonjour, depuis hier je suis bloquée sur le plugin sms, quand mon jeedom etait sur le rpi tout fonctionner bien et depuis que j'ai mie mon jeedom sur le pc avec debian 9 impossible de le faire fonctionne. Mon moden est un E220 qui fonctionne bien sur mon rpi.
voila le log
[2019-04-05 18:40:02][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-04-05 18:40:03][INFO] : Lancement démon sms : /usr/bin/python /var/www/html/plugins/sms/resources/smsd/smsd.py --device auto --loglevel debug --socketport 55002 --serialrate 115200 --pin None --textmode no --smsc None --cycle 30 --callback http://127.0.0.1:80/plugins/sms/core/php/jeeSMS.php --apikey ggg --pid /tmp/jeedom/sms/deamon.pid
[2019-04-05 18:40:04][INFO] : Start smsd
[2019-04-05 18:40:04][INFO] : Log level : debug
[2019-04-05 18:40:04][INFO] : Socket port : 55002
[2019-04-05 18:40:04][INFO] : Socket host : 127.0.0.1
[2019-04-05 18:40:04][INFO] : PID file : /tmp/jeedom/sms/deamon.pid
[2019-04-05 18:40:04][INFO] : Device : auto
[2019-04-05 18:40:04][INFO] : Apikey : 6rD7QEXmaFbVWuPx7xIwN0fQu3Vf2IjL
[2019-04-05 18:40:04][INFO] : Callback : http://127.0.0.1:80/plugins/sms/core/php/jeeSMS.php
[2019-04-05 18:40:04][INFO] : Cycle : 30.0
[2019-04-05 18:40:04][INFO] : Serial rate : 115200
[2019-04-05 18:40:04][INFO] : Pin : None
[2019-04-05 18:40:04][INFO] : Text mode : no
[2019-04-05 18:40:04][INFO] : SMSC : None
[2019-04-05 18:40:04][INFO] : Find device : /dev/ttyUSB2
[2019-04-05 18:40:04][DEBUG] : Writing PID 4665 to /tmp/jeedom/sms/deamon.pid
[2019-04-05 18:40:04][DEBUG] : Init request module v2.21.0
[2019-04-05 18:40:04][DEBUG] : Starting new HTTP connection (1): 127.0.0.1:80
[2019-04-05 18:40:04][DEBUG] : http://127.0.0.1:80 "GET /plugins/sms/core/php/jeeSMS.php?apikey=6rD7QEXmaFbVWuPx7xIwN0fQu3Vf2IjL HTTP/1.1" 200 0
[2019-04-05 18:40:04][DEBUG] : Socket interface started
[2019-04-05 18:40:04][DEBUG] : Start listening...
[2019-04-05 18:40:04][DEBUG] : Connecting to GSM Modem...
[2019-04-05 18:40:04][DEBUG] : Text mode false
[2019-04-05 18:40:04][INFO] : Connecting to modem on port /dev/ttyUSB2 at 115200bps
[2019-04-05 18:40:04][DEBUG] : LoopNetServer Thread started
[2019-04-05 18:40:04][DEBUG] : Listening on: [127.0.0.1:55002]
[2019-04-05 18:40:04][DEBUG] : write: ATZ
[2019-04-05 18:40:04][DEBUG] : response: ['OK']
[2019-04-05 18:40:04][DEBUG] : write: ATE0
[2019-04-05 18:40:04][DEBUG] : response: ['ATE0
', 'OK']
[2019-04-05 18:40:04][DEBUG] : write: AT+CFUN?
[2019-04-05 18:40:04][DEBUG] : response: ['+CFUN: 1', 'OK']
[2019-04-05 18:40:04][DEBUG] : write: AT+CMEE=1
[2019-04-05 18:40:04][DEBUG] : response: ['OK']
[2019-04-05 18:40:04][DEBUG] : write: AT+CPIN?
[2019-04-05 18:40:04][DEBUG] : response: ['+CPIN: READY', 'OK']
[2019-04-05 18:40:04][DEBUG] : write: AT+CLAC
[2019-04-05 18:40:04][DEBUG] : response: ['COMMAND NOT SUPPORT']
[2019-04-05 18:40:04][DEBUG] : write: AT+WIND?
[2019-04-05 18:40:04][DEBUG] : response: ['COMMAND NOT SUPPORT']
[2019-04-05 18:40:04][DEBUG] : write: AT+CGMI
[2019-04-05 18:40:04][DEBUG] : response: ['huawei', 'OK']
[2019-04-05 18:40:04][INFO] : Loading Huawei call state update table
[2019-04-05 18:40:04][DEBUG] : write: AT+COPS=3,0
[2019-04-05 18:40:04][DEBUG] : response: ['OK']
[2019-04-05 18:40:04][DEBUG] : write: AT+CMGF=0
[2019-04-05 18:40:04][DEBUG] : response: ['OK']
[2019-04-05 18:40:04][DEBUG] : write: AT+CSCA?
[2019-04-05 18:40:04][DEBUG] : response: ['+CSCA: "002B00330033003600390035003000300030003600390035",145', 'OK']
[2019-04-05 18:40:04][DEBUG] : write: AT+CSMP=49,167,0,0
[2019-04-05 18:40:09][ERROR] : Exception: None
[2019-04-05 18:40:09][ERROR] : Exit 1 because this exeption is fatal
[2019-04-05 18:40:09][DEBUG] : Shutdown
[2019-04-05 18:40:09][DEBUG] : Removing PID file /tmp/jeedom/sms/deamon.pid
[2019-04-05 18:40:09][DEBUG] : Send to jeedom : {'message': 'None', 'number': 'none'}
[2019-04-05 18:40:09][DEBUG] : Starting new HTTP connection (1): 127.0.0.1:80
[2019-04-05 18:40:09][DEBUG] : http://127.0.0.1:80 "POST /hhhh HTTP/1.1" 200 0
[2019-04-05 18:40:09][DEBUG] : LoopNetServer Thread stopped
[2019-04-05 18:40:09][DEBUG] : Exit 0
Dernière édition par Titof2375 le 07 avr. 2019, 08:56, édité 1 fois.
Rpi 3 avec jeedom
Plugins zwave, Plugins volets, Plugins rflinq, Plugins blea,Plugin

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1386
Inscription : 20 oct. 2015, 17:32

Re: Plugin SMS

Message par Jeandhom » 05 avr. 2019, 19:22

Et si tu retire "texte mode" ?
Also, if in text mode, you need to enable the report feature by setting <AT+CSMP=49,167,0,0>

romu044
Timide
Messages : 89
Inscription : 01 déc. 2015, 12:59

Re: Plugin SMS

Message par romu044 » 05 avr. 2019, 19:28

romu044 a écrit :
05 avr. 2019, 14:15
Chrisax a écrit :
04 avr. 2019, 19:22
Chez moi également. Je viens de le cocher et j'ai l'erreur d'encodage.
Sur mon RPi2 c'était coché et cela fonctionne bien (avec ma huawei E1752, j'ai pas testé la E220 dessus)

Je vais essayé en décochant et je te dis.

Merci pour ton aide
Bon alors j'ai testé mes 3 clés : E1752, E1752 reconnue comme une E220 et une E367 toutes des huawei, elles fonctionnent très bien sur mon rpi2
avec "texte mode" coché.

Mais dès que je passe sur le rpi3 dans les logs j'ai :

Code : Tout sélectionner

[2019-04-05 17:43:27][DEBUG] : Message read from socket: {"apikey":"xxxxxxxxxxxxxxxxxxx","number":"06xxxxxxxx","message":"essai"}
[2019-04-05 17:43:27][DEBUG] : Client disconnected from [127.0.0.1:59496]
[2019-04-05 17:43:39][DEBUG] : write: AT+CREG?
[2019-04-05 17:43:39][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-04-05 17:43:40][DEBUG] : write: AT+CSQ
[2019-04-05 17:43:40][DEBUG] : response: ['+CSQ: 12,99', 'OK']
[2019-04-05 17:43:40][DEBUG] : write: AT+CMGL="REC UNREAD"
[2019-04-05 17:43:40][DEBUG] : response: ['OK']
[2019-04-05 17:43:40][DEBUG] : write: AT+CSQ
[2019-04-05 17:43:40][DEBUG] : response: ['+CSQ: 12,99', 'OK']
[2019-04-05 17:43:40][DEBUG] : write: AT+CSQ
[2019-04-05 17:43:40][DEBUG] : response: ['+CSQ: 12,99', 'OK']
[2019-04-05 17:43:40][DEBUG] : write: AT+CSQ
[2019-04-05 17:43:40][DEBUG] : response: ['+CSQ: 12,99', 'OK']
[2019-04-05 17:43:40][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2019-04-05 17:43:40][DEBUG] : Send to jeedom :  {'message': '12', 'number': 'signal_strength'}
[2019-04-05 17:43:40][DEBUG] : write: AT+CREG?
[2019-04-05 17:43:40][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2019-04-05 17:43:40][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-04-05 17:43:40][DEBUG] : http://127.0.0.1:80 "POST /plugins/sms/core/php/jeeSMS.php?apikey=xxxxxxxxxxxxxxxxxxxxxxxxxHTTP/1.1" 200 0
[2019-04-05 17:43:41][DEBUG] : write: AT+CSQ
[2019-04-05 17:43:41][DEBUG] : response: ['+CSQ: 12,99', 'OK']
[2019-04-05 17:43:41][DEBUG] : write: AT+CMGS="06xxxxxxxx"
[2019-04-05 17:43:41][DEBUG] : response: ['> ']
[2019-04-05 17:43:41][DEBUG] : write: essai
[2019-04-05 17:43:41][ERROR] : unicode strings are not supported, please encode to bytes: u'essai\x1a'
et en décochant "texte mode" le démon tombe, je reboot le rpi3, fait un test, je reçois le sms et j'ai les logs :

Code : Tout sélectionner

[2019-04-05 18:09:03][DEBUG] : Message read from socket: {"apikey":"xxxxxxxxxxxxxxxxxxx","number":"06xxxxxxxx","message":"essai"}
[2019-04-05 18:09:03][DEBUG] : Client disconnected from [127.0.0.1:44502]
[2019-04-05 18:09:31][DEBUG] : write: AT+CREG?
[2019-04-05 18:09:31][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-04-05 18:09:32][DEBUG] : write: AT+CSQ
[2019-04-05 18:09:32][DEBUG] : response: ['+CSQ: 12,99', 'OK']
[2019-04-05 18:09:32][DEBUG] : write: AT+CMGL=0
[2019-04-05 18:09:32][DEBUG] : response: ['OK']
[2019-04-05 18:09:32][DEBUG] : write: AT+CSQ
[2019-04-05 18:09:32][DEBUG] : response: ['+CSQ: 12,99', 'OK']
[2019-04-05 18:09:32][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2019-04-05 18:09:32][DEBUG] : write: AT+CREG?
[2019-04-05 18:09:32][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-04-05 18:09:33][DEBUG] : write: AT+CSQ
[2019-04-05 18:09:33][DEBUG] : response: ['+CSQ: 12,99', 'OK']
[2019-04-05 18:09:33][DEBUG] : write: AT+CMGS=17
[2019-04-05 18:09:33][DEBUG] : response: ['> ']
[2019-04-05 18:09:33][DEBUG] : write: 0021670AA16034461872000005E5F93C9C06
[2019-04-05 18:09:35][DEBUG] : response: ['+CMGS: 103', 'OK']
[2019-04-05 18:10:05][DEBUG] : write: AT+CREG?
[2019-04-05 18:10:05][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-04-05 18:10:06][DEBUG] : write: AT+CSQ
[2019-04-05 18:10:06][DEBUG] : response: ['+CSQ: 12,99', 'OK']
[2019-04-05 18:10:06][DEBUG] : write: AT+CMGL=0
[2019-04-05 18:10:06][DEBUG] : response: ['+CMGL: 0,0,,25', '07913396050056F906670B913346638421F7914050919053809140509190538000', 'OK']
[2019-04-05 18:10:06][DEBUG] : write: AT+CMGD=0,0
[2019-04-05 18:10:06][DEBUG] : response: ['OK']
[2019-04-05 18:10:06][DEBUG] : Got SMS message : <gsmmodem.modem.StatusReport object at 0x7553f210>
[2019-04-05 18:10:06][DEBUG] : No text so nothing to do
[2019-04-05 18:10:06][DEBUG] : write: AT+CSQ
[2019-04-05 18:10:06][DEBUG] : response: ['+CSQ: 12,99', 'OK']
je ne comprends pas cette différence de fonctionnement, la version de jeedom est la même (v3.3.19) celle du plugin aussi.

Avatar de l’utilisateur
Chrisax
Timide
Messages : 104
Inscription : 09 oct. 2017, 15:05

Re: Plugin SMS

Message par Chrisax » 05 avr. 2019, 22:20

Quelles sont les versions de python ?
Jeedom sur nuc/proxmox + dongle Aeotec GEN5 et RfxCom
Ecran de contrôle sur Rpi 3B+ et Google Voice Kit

Titof2375
Helper
Messages : 656
Inscription : 22 août 2017, 18:59

Re: Plugin SMS

Message par Titof2375 » 05 avr. 2019, 22:41

Chrisax a écrit :
05 avr. 2019, 22:20
Quelles sont les versions de python ?
bonjour tu vois comment?
Rpi 3 avec jeedom
Plugins zwave, Plugins volets, Plugins rflinq, Plugins blea,Plugin

Avatar de l’utilisateur
Chrisax
Timide
Messages : 104
Inscription : 09 oct. 2017, 15:05

Re: Plugin SMS

Message par Chrisax » 05 avr. 2019, 23:31

python --version ou python -V
Jeedom sur nuc/proxmox + dongle Aeotec GEN5 et RfxCom
Ecran de contrôle sur Rpi 3B+ et Google Voice Kit

romu044
Timide
Messages : 89
Inscription : 01 déc. 2015, 12:59

Re: Plugin SMS

Message par romu044 » 06 avr. 2019, 08:29

re-test ce matin,
émission sms de jeedom vers mobile ok :

Code : Tout sélectionner

[2019-04-06 07:18:55][DEBUG] : Client connected to [127.0.0.1:46914]
[2019-04-06 07:18:55][DEBUG] : Message read from socket: {"apikey":"xxxxxxxxxxxxxxxxxxxxxxxx","number":"06xxxxxxxx","message":"essai"}
[2019-04-06 07:18:55][DEBUG] : Client disconnected from [127.0.0.1:46914]
[2019-04-06 07:18:58][DEBUG] : write: AT+CREG?
[2019-04-06 07:18:58][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-04-06 07:18:59][DEBUG] : write: AT+CSQ
[2019-04-06 07:18:59][DEBUG] : response: ['+CSQ: 13,99', 'OK']
[2019-04-06 07:18:59][DEBUG] : write: AT+CMGL=0
[2019-04-06 07:19:04][ERROR] : Exception on GSM : None
[2019-04-06 07:19:04][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2019-04-06 07:19:04][DEBUG] : write: AT+CREG?
[2019-04-06 07:19:04][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-04-06 07:19:05][DEBUG] : write: AT+CSQ
[2019-04-06 07:19:05][DEBUG] : response: ['+CSQ: 13,99', 'OK']
[2019-04-06 07:19:05][DEBUG] : write: AT+CMGS=17
[2019-04-06 07:19:05][DEBUG] : response: ['> ']
[2019-04-06 07:19:05][DEBUG] : write: 00216B0AA16034461872000005E5F93C9C06
[2019-04-06 07:19:08][DEBUG] : response: ['+CMGS: 107', 'OK']
mais une fois le message envoyé voici le log :

Code : Tout sélectionner

[2019-04-06 07:19:38][DEBUG] : write: AT+CREG?
[2019-04-06 07:19:38][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-04-06 07:19:39][DEBUG] : write: AT+CSQ
[2019-04-06 07:19:39][DEBUG] : response: ['+CSQ: 13,99', 'OK']
[2019-04-06 07:19:39][DEBUG] : write: AT+CMGL=0
[2019-04-06 07:19:44][ERROR] : Exception on GSM : None
et ce dernier ce répète !!!

le sms mobile vers jeedom est KO, je ne vois rien dans les logs

pour la version de python la voici :
Python 2.7.13

Titof2375
Helper
Messages : 656
Inscription : 22 août 2017, 18:59

Re: Plugin SMS

Message par Titof2375 » 06 avr. 2019, 08:52

Chrisax a écrit :
05 avr. 2019, 23:31
python --version ou python -V
J ai python 2.7.13.
Rpi 3 avec jeedom
Plugins zwave, Plugins volets, Plugins rflinq, Plugins blea,Plugin

Avatar de l’utilisateur
Chrisax
Timide
Messages : 104
Inscription : 09 oct. 2017, 15:05

Re: Plugin SMS

Message par Chrisax » 07 avr. 2019, 08:35

Vous avez de la doc sur les commandes AT ici si ça peut être utile.
AT+CMGL=0 sert à récupérer les messages non lus
AT+CSMP=49,167,0,0 sert à recevoir un acquit de dépôt en mode texte. Je viens de vérifier dans mes logs et j'ai également cette instruction alors que le mode texte est désactivé.

Titof2375, tu devrais éditer tes messages et supprimer ta clé api.
Je ne vois pas trop comment vous aider, désolé.
Jeedom sur nuc/proxmox + dongle Aeotec GEN5 et RfxCom
Ecran de contrôle sur Rpi 3B+ et Google Voice Kit

Tooms
Timide
Messages : 63
Inscription : 28 nov. 2014, 15:36

Re: Plugin SMS

Message par Tooms » 08 avr. 2019, 13:39

Bonjour,
de mon côté j'ai complètement supprimé ma clé Huawei E220 car impossible de la faire fonctionner de manière stable depuis quelques temps (avec une Jeedom smart, cela fonctionnait depuis plusieurs mois). J'ai testé avec hub usb auto alimenté sans amélioration. Il me semble avoir compris que certains ont réussi à stabiliser en passant sous Debian Stretch mais je n'ai pas encore sauté le pas.

Titof2375
Helper
Messages : 656
Inscription : 22 août 2017, 18:59

Re: Plugin SMS

Message par Titof2375 » 08 avr. 2019, 14:38

Tooms a écrit :
08 avr. 2019, 13:39
Bonjour,
de mon côté j'ai complètement supprimé ma clé Huawei E220 car impossible de la faire fonctionner de manière stable depuis quelques temps (avec une Jeedom smart, cela fonctionnait depuis plusieurs mois). J'ai testé avec hub usb auto alimenté sans amélioration. Il me semble avoir compris que certains ont réussi à stabiliser en passant sous Debian Stretch mais je n'ai pas encore sauté le pas.
Salut moi j était sous rpi et stretch et ça marche super bien
Rpi 3 avec jeedom
Plugins zwave, Plugins volets, Plugins rflinq, Plugins blea,Plugin

denisb88
Timide
Messages : 243
Inscription : 12 mars 2016, 08:53

Re: Plugin SMS

Message par denisb88 » 19 avr. 2019, 08:58

Bonjour
Je viens d'installer une clé Huawei 3531 qui émet bien des sms mais le log me donne un message d'erreur un peu bizarre
Quelqu'un saurait-il d'où cela vient et comment le supprimer.
Je pense que c'est pour cela que je ne reçois pas les SMS sur ma box
Lancement démon sms : /usr/bin/python /var/www/html/plugins/sms/resources/smsd/smsd.py --device /dev/ttyUSB1 --loglevel info --socketport 55002 --serialrate 115200 --pin None --textmode no --smsc +33695000695 --cycle 15 --callback http://127.0.0.1:80/plugins/sms/core/php/jeeSMS.php --apikey UHQlkxCKjfP1DyGmS2nllRLvZ9FM1F2u --pid /tmp/jeedom/sms/deamon.pid
[2019-04-19 08:48:36][INFO] : Start smsd
[2019-04-19 08:48:36][INFO] : Log level : info
[2019-04-19 08:48:36][INFO] : Socket port : 55002
[2019-04-19 08:48:36][INFO] : Socket host : 127.0.0.1
[2019-04-19 08:48:36][INFO] : PID file : /tmp/jeedom/sms/deamon.pid
[2019-04-19 08:48:36][INFO] : Device : /dev/ttyUSB1
[2019-04-19 08:48:36][INFO] : Apikey : xxxxxxxxxxxxxxx
[2019-04-19 08:48:36][INFO] : Callback : http://127.0.0.1:80/plugins/sms/core/php/jeeSMS.php
[2019-04-19 08:48:36][INFO] : Cycle : 15.0
[2019-04-19 08:48:36][INFO] : Serial rate : 115200
[2019-04-19 08:48:36][INFO] : Pin : None
[2019-04-19 08:48:36][INFO] : Text mode : no
[2019-04-19 08:48:36][INFO] : SMSC : +33695000695
[2019-04-19 08:48:36][INFO] : Connecting to modem on port /dev/ttyUSB1 at 115200bps
[2019-04-19 08:48:57][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:49:13][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:49:30][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:49:46][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:50:02][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:50:18][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:50:34][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:50:50][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:51:07][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:51:23][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:51:39][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:51:55][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:52:11][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:52:27][INFO] : +CREG check disabled due to invalid response or unsupported command
[2019-04-19 08:52:44][INFO] : +CREG check disabled due to invalid response or unsupported command

romu044
Timide
Messages : 89
Inscription : 01 déc. 2015, 12:59

Re: Plugin SMS

Message par romu044 » 13 mai 2019, 13:51

Bonjour,

Depuis passage d'un rpi2 avec SD vers un rpi3 avec SSD, pas moyen de faire fonctionner ma clé E1752, du coup j'ai récupéré un E220, mais le fonctionnement n'est pas stable du tout, cela fonctionne le temps des tests mais après :

Code : Tout sélectionner

[2019-05-11 20:39:51][DEBUG] : write: AT+CSQ
[2019-05-11 20:39:51][DEBUG] : response: ['+CSQ: 6,99', 'OK']
[2019-05-11 20:40:21][DEBUG] : write: AT+CREG?
[2019-05-11 20:40:21][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-05-11 20:40:22][DEBUG] : write: AT+CSQ
[2019-05-11 20:40:22][DEBUG] : response: ['+CSQ: 6,99', 'OK']
[2019-05-11 20:40:22][DEBUG] : write: AT+CMGL=0
[2019-05-11 20:40:22][DEBUG] : response: ['OK']
[2019-05-11 20:40:22][DEBUG] : write: AT+CSQ
[2019-05-11 20:40:22][DEBUG] : response: ['+CSQ: 6,99', 'OK']
[2019-05-11 20:40:52][DEBUG] : write: AT+CREG?
[2019-05-11 20:40:52][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-05-11 20:40:53][DEBUG] : write: AT+CSQ
[2019-05-11 20:40:58][ERROR] : Exception on GSM : None
[2019-05-11 20:41:28][DEBUG] : write: AT+CREG?
[2019-05-11 20:41:33][ERROR] : Exception on GSM : None
[2019-05-11 20:42:03][DEBUG] : write: AT+CREG?
[2019-05-11 20:42:08][ERROR] : Exception on GSM : None
[2019-05-11 20:42:38][DEBUG] : write: AT+CREG?
[2019-05-11 20:42:43][ERROR] : Exception on GSM : None
[2019-05-11 20:43:13][DEBUG] : write: AT+CREG?
[2019-05-11 20:43:18][ERROR] : Exception on GSM : None
[2019-05-11 20:43:48][DEBUG] : write: AT+CREG?
[2019-05-11 20:43:53][ERROR] : Exception on GSM : None
[2019-05-11 20:44:23][DEBUG] : write: AT+CREG?
[2019-05-11 20:44:28][ERROR] : Exception on GSM : None
[2019-05-11 20:44:58][DEBUG] : write: AT+CREG?
[2019-05-11 20:45:03][ERROR] : Exception on GSM : None
[2019-05-11 20:45:33][DEBUG] : write: AT+CREG?
[2019-05-11 20:45:38][ERROR] : Exception on GSM : None
[2019-05-11 20:46:08][DEBUG] : write: AT+CREG?
[2019-05-11 20:46:13][ERROR] : Exception on GSM : None
[2019-05-11 20:46:43][DEBUG] : write: AT+CREG?
[2019-05-11 20:46:48][ERROR] : Exception on GSM : None
[2019-05-11 20:47:18][DEBUG] : write: AT+CREG?
[2019-05-11 20:47:23][ERROR] : Exception on GSM : None
[2019-05-11 20:47:53][DEBUG] : write: AT+CREG?
[2019-05-11 20:47:58][ERROR] : Exception on GSM : None
[2019-05-11 20:48:28][DEBUG] : write: AT+CREG?
[2019-05-11 20:48:33][ERROR] : Exception on GSM : None
[2019-05-11 20:49:03][DEBUG] : write: AT+CREG?
Et si j'essaye d'envoyer un sms depuis jeedom j'ai :

Code : Tout sélectionner

[2019-05-13 12:47:08][DEBUG] : Client connected to [127.0.0.1:55928]
[2019-05-13 12:47:08][DEBUG] : Message read from socket: {"apikey":"ma_cle_api","number":"06xxxxxxxx","message":"essais"}
[2019-05-13 12:47:08][DEBUG] : Client disconnected from [127.0.0.1:55928]
Est-ce que cela vous parle ?

romu044
Timide
Messages : 89
Inscription : 01 déc. 2015, 12:59

Re: Plugin SMS

Message par romu044 » 23 mai 2019, 14:04

Personne pour me répondre :cry:

J'ai essayé avec une autre clé et aussi changé de câble (1752), ça fonctionne mais pas longtemps j'ai tjrs la même erreur :

Code : Tout sélectionner

[2019-05-23 12:56:50][DEBUG] : write: 0021820AA16034461872000005E5F93C9C06
[2019-05-23 12:56:51][DEBUG] : response: ['+CMGS: 130', 'OK']
[2019-05-23 12:57:21][DEBUG] : write: AT+CREG?
[2019-05-23 12:57:22][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-05-23 12:57:23][DEBUG] : write: AT+CSQ
[2019-05-23 12:57:23][DEBUG] : response: ['+CSQ: 10,99', 'OK']
[2019-05-23 12:57:23][DEBUG] : write: AT+CMGL=0
[2019-05-23 12:57:28][ERROR] : Exception on GSM : None
[2019-05-23 12:57:58][DEBUG] : write: AT+CREG?
[2019-05-23 12:57:58][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-05-23 12:57:59][DEBUG] : write: AT+CSQ
[2019-05-23 12:57:59][DEBUG] : response: ['+CSQ: 10,99', 'OK']
[2019-05-23 12:57:59][DEBUG] : write: AT+CMGL=0
[2019-05-23 12:58:04][ERROR] : Exception on GSM : None
[2019-05-23 12:58:34][DEBUG] : write: AT+CREG?
[2019-05-23 12:58:34][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-05-23 12:58:35][DEBUG] : write: AT+CSQ
[2019-05-23 12:58:35][DEBUG] : response: ['+CSQ: 11,99', 'OK']
[2019-05-23 12:58:35][DEBUG] : write: AT+CMGL=0
[2019-05-23 12:58:40][ERROR] : Exception on GSM : None
[2019-05-23 12:59:10][DEBUG] : write: AT+CREG?
[2019-05-23 12:59:10][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-05-23 12:59:11][DEBUG] : write: AT+CSQ
[2019-05-23 12:59:11][DEBUG] : response: ['+CSQ: 10,99', 'OK']
[2019-05-23 12:59:11][DEBUG] : write: AT+CMGL=0
[2019-05-23 12:59:16][ERROR] : Exception on GSM : None
[2019-05-23 12:59:46][DEBUG] : write: AT+CREG?
[2019-05-23 12:59:46][DEBUG] : response: ['+CREG: 0,1', 'OK']
[2019-05-23 12:59:47][DEBUG] : write: AT+CSQ
[2019-05-23 12:59:47][DEBUG] : response: ['+CSQ: 11,99', 'OK']
[2019-05-23 12:59:47][DEBUG] : write: AT+CMGL=0
[2019-05-23 12:59:52][ERROR] : Exception on GSM : None
Cette satané erreur "Exception on GSM : None"

Répondre

Revenir vers « [Plugin Officiel] SMS »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités