Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

Plugin SMS

jax24fr
Timide
Messages : 467
Inscription : 24 juil. 2014, 22:41

Re: Plugin SMS

Message par jax24fr » 04 mars 2015, 22:01

Je l'avais mis en deporté pour test (pour le pb de non reception des sms au bout de quelques heures) mais l'ai remis sur le master.
pour les log je redemarre le démon now

EDIT :
04-03-2015 22:00:31 | info | Lancement démon sms : /usr/bin/python /usr/share/nginx/www/jeedom/plugins/sms/ressources/smscmd/smscmd.py -l -o /usr/share/nginx/www/jeedom/plugins/sms/ressources/smscmd/config.xml
04-03-2015 22:00:32 | info | Démon sms lancé
Dernière édition par jax24fr le 04 mars 2015, 22:03, édité 1 fois.
Matos :
DIY DEBIAN 9 (sous VM PROXMOX) Jeedom

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Plugin SMS

Message par loic » 04 mars 2015, 22:02

a en déporté a mon avis tu as un soucis au niveau de l'IP de l'esclave (a configurer sur l'esclave)
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

jax24fr
Timide
Messages : 467
Inscription : 24 juil. 2014, 22:41

Re: Plugin SMS

Message par jax24fr » 04 mars 2015, 22:13

pourtant j'ai verifier les confs reseau et c'est bon maitre et esclave.
Dans le doute, j'ai desactivé le plugin sms sur le deporté.

Je suppose que c'est pour les warnings..
Tu sais a quoi correspond le
DEBUG: write: AT+CMGL=0
DEBUG: response: ['+CMS ERROR: 500']
Matos :
DIY DEBIAN 9 (sous VM PROXMOX) Jeedom

jax24fr
Timide
Messages : 467
Inscription : 24 juil. 2014, 22:41

Re: Plugin SMS

Message par jax24fr » 04 mars 2015, 22:21

En desactivant le plugin sur le deporté, j'ai plus les warning
2015-03-04 13:15:04,847 - Thread-8 - smscmd:185 - DEBUG - Got SMS message :
DEBUG: Got SMS message :
2015-03-04 13:15:04,848 - Thread-8 - smscmd:188 - DEBUG - Execute shell : /usr/bin/php /usr/share/nginx/www/jeedom/plugins/sms/ressources/smscmd/../../core/php/jeeSMS.php number="+xxxx" message="j'ai un colis ?"
DEBUG: Execute shell : /usr/bin/php /usr/share/nginx/www/jeedom/plugins/sms/ressources/smscmd/../../core/php/jeeSMS.php number="+xxxxx" message="j'ai un colis ?"
2015-03-04 13:15:04,848 - Thread-9 - smscmd:108 - DEBUG - Thread started, timeout = 10
DEBUG: Thread started, timeout = 10
2015-03-04 13:15:04,931 - Thread-4 - smscmd:137 - DEBUG - Client connected to [127.0.0.1:47313]
DEBUG: Client connected to [127.0.0.1:47313]
2015-03-04 13:15:04,932 - Thread-4 - smscmd:140 - DEBUG - Message read from socket: {"number":"+xxxxxx","message":"Oui, tu as re\u00e7u un Colis "}
DEBUG: Message read from socket: {"number":"+xxxxxx","message":"Oui, tu as re\u00e7u un Colis "}
2015-03-04 13:15:04,932 - Thread-4 - smscmd:142 - DEBUG - Client disconnected from [127.0.0.1:47313]
DEBUG: Client disconnected from [127.0.0.1:47313]
2015-03-04 13:15:04,941 - Thread-9 - smscmd:111 - DEBUG - Return code: 0
DEBUG: Return code: 0
2015-03-04 13:15:04,941 - Thread-9 - smscmd:112 - DEBUG - Thread finished
DEBUG: Thread finished
DEBUG: write: AT+CREG?
DEBUG: response: ['+CREG: 0,1', 'OK']
DEBUG: write: AT+CSQ
DEBUG: response: ['+CSQ: 12,99', 'OK']
DEBUG: write: AT+CMGL=0
DEBUG: response: ['OK']
DEBUG: write: AT+CSQ
DEBUG: response: ['+CSQ: 12,99', 'OK']
2015-03-04 13:15:06,633 - MainThread - smscmd:363 - DEBUG - Message received in socket messageQueue
DEBUG: Message received in socket messageQueue
2015-03-04 13:15:06,634 - MainThread - smscmd:365 - DEBUG - Message : {"number":"+xxxxxx","message":"Oui, tu as re\u00e7u un Colis "}
DEBUG: Message : {"number":"+xxxxxx","message":"Oui, tu as re\u00e7u un Colis "}
DEBUG: write: AT+CREG?

Par contre j'ai plus l'erreur avec le CMGL, c'est bizarre:
DEBUG: Thread finished
DEBUG: write: AT+CREG?
DEBUG: response: ['+CREG: 0,1', 'OK']
DEBUG: write: AT+CSQ
DEBUG: response: ['+CSQ: 12,99', 'OK']
DEBUG: write: AT+CMGL=0
DEBUG: response: ['OK']
DEBUG: write: AT+CSQ
DEBUG: response: ['+CSQ: 12,99', 'OK']
Matos :
DIY DEBIAN 9 (sous VM PROXMOX) Jeedom

Avatar de l’utilisateur
alexzen
Actif
Messages : 526
Inscription : 07 août 2014, 14:57

Re: Plugin SMS

Message par alexzen » 07 mars 2015, 16:36

Une question. Avez vous un délai pour la réception de sms suite à une demande d'interactions ?

Perso des fois ca passe et des fois je lance plusieurs sms qui me renvoie tout en paquet au bout de 15 min.

Sniff.
Vm vbox Jeedom + 1 rpi2 razberry/rfxcom/sms déporté + 1 rpib+ rfxcom/1wire déporté.
30 modules zwave, 9 sondes 1wire, 13 modules chacon, 12 volets ematronic, Karotz, 5 squeezebox, 1 rpi squeezeplug, 2 nas n40l, etc.

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Plugin SMS

Message par loic » 07 mars 2015, 16:55

Si tu as des délai c'est un soucis de reception en generale
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
alexzen
Actif
Messages : 526
Inscription : 07 août 2014, 14:57

Re: Plugin SMS

Message par alexzen » 07 mars 2015, 16:59

Cela serait sûrement possible vu que j'utilise un abo free rien que pour ca ... Et free reste free.

Vous avez des plans pour avoir un abo pas cher mais ailleurs ?

(Pour la réception je peux le voir dans les logs ?)
Vm vbox Jeedom + 1 rpi2 razberry/rfxcom/sms déporté + 1 rpib+ rfxcom/1wire déporté.
30 modules zwave, 9 sondes 1wire, 13 modules chacon, 12 volets ematronic, Karotz, 5 squeezebox, 1 rpi squeezeplug, 2 nas n40l, etc.

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Plugin SMS

Message par loic » 07 mars 2015, 17:28

Tu as une commande qui te donne le niveau de réception
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
Syll
Actif
Messages : 1577
Inscription : 14 janv. 2015, 18:46
Contact :

Re: Plugin SMS

Message par Syll » 11 mars 2015, 20:42

Retour d'un acharné qui voulait absolument faire fonctionner la clef E220 : j'ai nommé moi-même lol

Symptomes : Dongle Huawei E220 et SIM Free : accroche réseau à chier :)
DU coup, les ports USB décrochait, etc...

Ce que j'ai fait :

En SSH, installer une sorte d'hyper-terminal directement sur jeedom

Code : Tout sélectionner

sudo apt-get install picocom
Vérifier le port USB utilisé par le dongle

Code : Tout sélectionner

sudo dmesg | grep usb
Pour te connecter sur le dongle via le port ttyUSB0

Code : Tout sélectionner

picocom /dev/ttyUSB0 -b 115200 -l
Passer la clef en mode modem only :

Code : Tout sélectionner

AT^U2DIAG=0
Voir le mode de réseau (GPRS/UMTS/3G) utilisé par le modem

Code : Tout sélectionner

AT^SYSCFG?
Exemple :
Only GPRS/EDGE: 13,1,3FFFFFFF,2,4
Only 3G: 14,2,3FFFFFFF,2,4
Preferred GPRS/EDGE: 2,1,3FFFFFFF,2,4
Preferred 3G: 2,2,3FFFFFFF,2,4

Passer le clef en GPRS/EDGE

Code : Tout sélectionner

AT^SYSCFG=13,1,3FFFFFFF,2,4
Sortir du mode pico

Code : Tout sélectionner

Faire CTRL A puis en maintenant CTRL relacher A et faire X
J'ai rebooté, fait des MAJ du systèmes, aucun problème.
SI ça peut aider certains :)
Jeedom - ESXi 6.7U2 - VM Debian 9.9 | 60 Modules Zwave | 12 Modules RFXCom | 15 modules Xiaomi | GSM/JPI | Kodi | SqueezeBox | GH |

jax24fr
Timide
Messages : 467
Inscription : 24 juil. 2014, 22:41

Re: Plugin SMS

Message par jax24fr » 13 mars 2015, 23:04

salut @SBO , alors plus de soucis de deconnexion de ton coté ?
Matos :
DIY DEBIAN 9 (sous VM PROXMOX) Jeedom

Avatar de l’utilisateur
SBO
Actif
Messages : 1371
Inscription : 17 sept. 2014, 18:31

Re: Plugin SMS

Message par SBO » 14 mars 2015, 07:58

jax24fr a écrit :salut @SBO , alors plus de soucis de deconnexion de ton coté ?
Si j'ai toujours les déconnexions avec la vm à chaque reboot de la vm. Je dois déporter la clé sur un esclave, mais pas encore fait.

La solution de mon côté, après reboot :
- Arracher la clée et le replug
- reconfigurer le port dans le plugin SMS
et c'est reparti.
Ex-Bêta-Testeur | Jeedom | VM Debian 9

Pas de logs, pas d'infos, pas de réponse possible

Charte du forum | Doc jeedom | Trucs et astuces

jax24fr
Timide
Messages : 467
Inscription : 24 juil. 2014, 22:41

Re: Plugin SMS

Message par jax24fr » 14 mars 2015, 13:15

Moi j'ai pas ce genre de pb avec ma VM.. (Esxi)
Moi c'est plutôt qu'au bout d'un moment la clef ne réceptionne plus de messages. Si je me renvoi un test car repart. Donc pas besoin de deco/reco

Je vais déporter la carte une nouvelle fois (pas réussi lors de ma 1° tentative pour voir et viendrais mettre ici le resultat.
Matos :
DIY DEBIAN 9 (sous VM PROXMOX) Jeedom

Avatar de l’utilisateur
freshare
Timide
Messages : 187
Inscription : 15 janv. 2015, 08:45
Localisation : 80 - Picardie

Re: Plugin SMS

Message par freshare » 21 mars 2015, 09:04

Bonjour à tous,

Jeddom me remonte ce type d'erreur: Error : ['^BOOT:85914411,0,0,0,6']

Cela veut dire quoi ?
Tout petit Guru avec deux mini
> Liste de mon matériel <

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Plugin SMS

Message par loic » 21 mars 2015, 09:20

Il faudrait lancer en debug mais ca c'est la clef GSM qui envoi une notification après te dire ce que dit la notification c'est autre chose
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
Yjo
Timide
Messages : 20
Inscription : 16 févr. 2015, 18:43
Localisation : Arpajon

Re: Plugin SMS

Message par Yjo » 24 mars 2015, 17:59

Syll a écrit :Retour d'un acharné qui voulait absolument faire fonctionner la clef E220 : j'ai nommé moi-même lol

Symptomes : Dongle Huawei E220 et SIM Free : accroche réseau à chier :)
DU coup, les ports USB décrochait, etc...
Même clé E220 et même opérateur Free, j'ai observé exactement les mêmes symptômes : déconnexion du réseau et pas de reconnexion... Du coup impossible de joindre la box au bout de quelques heures. L'ajout d'un hub USB auto-alimenté n'y a rien changé.

Je confirme que notre cas bien précis, la solution que tu proposes @Syll fonctionne à merveille : plus aucun problème depuis 2 jours malgré quelques pertes de réseau (remontées par mail grâce à la commande "signal" du plugin SMS) qui ne sont donc plus létales.

Sur la page de configuration du plugin SMS, on peut lire que la clé est sur le réseau Orange alors qu'avant le blocage en mode GPRS/Edge par la commande

Code : Tout sélectionner

AT^SYSCFG=13,1,3FFFFFFF,2,4
le réseau indiqué était celui de Free.
Jeedom v2.4.4
Raspberry Pi 2 B + Razberry + Clé 3G Huawei E220
Fibaro : 2xFGMS-001, 1xFGK-101, 2xFGS-221, 1xFGS-222; Vision Security : 1xZS-6101

Avatar de l’utilisateur
Syll
Actif
Messages : 1577
Inscription : 14 janv. 2015, 18:46
Contact :

Re: Plugin SMS

Message par Syll » 24 mars 2015, 19:39

@Yjo : Content que ça ait aidé quelqu'un d'autre :)
Jeedom - ESXi 6.7U2 - VM Debian 9.9 | 60 Modules Zwave | 12 Modules RFXCom | 15 modules Xiaomi | GSM/JPI | Kodi | SqueezeBox | GH |

Avatar de l’utilisateur
freshare
Timide
Messages : 187
Inscription : 15 janv. 2015, 08:45
Localisation : 80 - Picardie

Re: Plugin SMS

Message par freshare » 03 avr. 2015, 00:00

malgré les manipulations que tu décris, j'ai toujours des problèmes avec ma clef E220 et free.
Depuis que j'ai fait la manip j'ai un troisième port usb qui apparait désormais lorsque je branche la clef (au lieu de 2 précédemment)

je ne sais plus quoi faire, dommage que les interactions ne fonctionne pas avec les mails
Tout petit Guru avec deux mini
> Liste de mon matériel <

Avatar de l’utilisateur
Syll
Actif
Messages : 1577
Inscription : 14 janv. 2015, 18:46
Contact :

Re: Plugin SMS

Message par Syll » 03 avr. 2015, 07:44

freshare a écrit :malgré les manipulations que tu décris, j'ai toujours des problèmes avec ma clef E220 et free.
Depuis que j'ai fait la manip j'ai un troisième port usb qui apparait désormais lorsque je branche la clef (au lieu de 2 précédemment)

je ne sais plus quoi faire, dommage que les interactions ne fonctionne pas avec les mails
Ta clef fonctionne sous WIndows ? Avec une autre SIM ?
QU'as-tu dans les logs ?
Jeedom - ESXi 6.7U2 - VM Debian 9.9 | 60 Modules Zwave | 12 Modules RFXCom | 15 modules Xiaomi | GSM/JPI | Kodi | SqueezeBox | GH |

Avatar de l’utilisateur
freshare
Timide
Messages : 187
Inscription : 15 janv. 2015, 08:45
Localisation : 80 - Picardie

Re: Plugin SMS

Message par freshare » 03 avr. 2015, 08:05

la clef fonctionne bien avec la même sim sous windows, un peu de difficulté à accrocher le réseau orange mais cela fonctionne
par contre dés que je la branche sous jeedom, il commence à rechercher le réseau puis au bout d'un moment j'ai :
DEBUG: write: AT+CREG?

en fait le clef est rapidement reconnu comme une clef usb et je ne retrouve plus les ports modem.
Tout petit Guru avec deux mini
> Liste de mon matériel <

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Plugin SMS

Message par loic » 03 avr. 2015, 08:15

Si tu as ca c'est que la clef n'arrive pas accrocher le réseau
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Répondre

Revenir vers « [Plugin Officiel] SMS »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité