Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Sujet officiel] Plugin sonos

maxtofurious
Timide
Messages : 174
Inscription : 29 juil. 2015, 22:04
Localisation : Amiens

Re: [Sujet officiel] Plugin sonos

Message par maxtofurious » 30 oct. 2015, 22:15

Masterfion a écrit :Non, avec un scénario (fonction DIRE)... tout simplement.
Put**n ! Tout simplement ! Bravo Loic pour cette simplicité !!!!


Par contre j'ai un message sur Sonos qui me dit que mon partage n'existe pas ... Je regarderais demain ... mais si c'est Sonos qui me dit ça, c'est que la conf Jeedom est bonne et que j'ai loupé quelque chose sur Sonos ... Je vais aller dormir et m'y pencherai à tête reposé =)
JeeDOM sur Raspberry PI 2 + RFXCom

ITL-3500 - Module commutateur 3 charges
CH54700 - Module émetteur
CH54758 - module récepteur
CH54781 - Contacteur de porte sans fil
Volet SIMU - RTS
Sonos Play:1

marlot
Actif
Messages : 584
Inscription : 03 déc. 2014, 18:24

Re: [Sujet officiel] Plugin sonos

Message par marlot » 31 oct. 2015, 00:17

Ca marche pour moi aussi le TTS. Mais c'est pas super rapide. Y a peut être des voix plus rapide que d'autre ?

Par contre j'ai une inversion dans les équipements mais pas de mes adresses IP qui sont bien différentes
Quand le lance de la musique dans la chambre c'est la cuisine qui démarre ! et c'est l'équipement cuisine qui se met en lecture
J'ai recréé à la main. Mais ça marche pas. L'équipement chambre de fonctionne pas
Dois y avoir un loup quelque part
Jeedom Smart

marlot
Actif
Messages : 584
Inscription : 03 déc. 2014, 18:24

Re: [Sujet officiel] Plugin sonos

Message par marlot » 31 oct. 2015, 01:25

Par-contre le smbclient est au taquet !!!
smbclient.jpg
smbclient.jpg (18.46 Kio) Consulté 400 fois
Jeedom Smart

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 31 oct. 2015, 09:02

Jeedom se connect au partage samba seulement une fois lors de l'envoi de la commande donc pas sur que ca soit lui
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
fredester
Timide
Messages : 90
Inscription : 04 oct. 2014, 09:06

Re: [Sujet officiel] Plugin sonos

Message par fredester » 31 oct. 2015, 09:13

Pour moi, rien à faire, le TTS ne marche plus avec le nouveau plugin.

Dépendences installées, rien dans les logs, php5.6.13, rien changé au niveau du répertoire de partage, et copié/collé les chemins depuis la config précédente. Pourtant Sonos ne génère aucun fichier dans le partage. Je ne vois pas ce que j'ai raté.

TTS trop important pour ma petite famille, donc pour l'instant retour à l'ancienne version par restauration...
Et on a retrouvé la douce voix d'Electra :)
Jeedom 3.3.18 ESXi - PC BRIX GB-BXBT-1900 - Debian Stretch

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 31 oct. 2015, 09:21

Je pense c'est un soucis de conf car la ca semble marché chez pas mal de monde tu peux mettre une capture de la configuration ?
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
fredester
Timide
Messages : 90
Inscription : 04 oct. 2014, 09:06

Re: [Sujet officiel] Plugin sonos

Message par fredester » 31 oct. 2015, 09:56

loic a écrit :Je pense c'est un soucis de conf car la ca semble marché chez pas mal de monde tu peux mettre une capture de la configuration ?
Voilà :
Sans titre.png
Sans titre.png (26.59 Kio) Consulté 425 fois
Jeedom 3.3.18 ESXi - PC BRIX GB-BXBT-1900 - Debian Stretch

xapi
Actif
Messages : 581
Inscription : 15 janv. 2015, 20:54
Localisation : PNR Vallée de Chevreuse

Re: [Sujet officiel] Plugin sonos

Message par xapi » 31 oct. 2015, 10:07

loic a écrit :Merci pour le retour j'ai ajouté le bouton d'installation de dépendance
mis à jour, cliqué sur le bouton d'ajout des dépendances => ça marche du premier coup :)

Un excellent truc que ce bouton d'ajout des dépendances !
une pincée de Smart, une dose de ZWave et d'objets connectés, pleins de plugin dans le coffre à jouets

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 31 oct. 2015, 10:09

@fredester : essaye en enlevant le premier / de chemin sur le nas et surtout le /tts dans l'adresse du nas a mon avis tu as mélanger la conf la vu ce que tu as fait
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

xapi
Actif
Messages : 581
Inscription : 15 janv. 2015, 20:54
Localisation : PNR Vallée de Chevreuse

Re: [Sujet officiel] Plugin sonos

Message par xapi » 31 oct. 2015, 10:10

fredester a écrit :
loic a écrit :Je pense c'est un soucis de conf car la ca semble marché chez pas mal de monde tu peux mettre une capture de la configuration ?
Voilà :
Sans titre.png
enlève le /tts du nom du partage et ça va rouler

[edit] grillé par loic qui ne fait jamais de grasse matinée :mrgreen:
une pincée de Smart, une dose de ZWave et d'objets connectés, pleins de plugin dans le coffre à jouets

thebobx
Timide
Messages : 7
Inscription : 22 juil. 2014, 18:07

Re: [Sujet officiel] Plugin sonos

Message par thebobx » 31 oct. 2015, 10:19

Bonjour,

De mon coté lorsque je lance la mise à jour j'ai le message d'erreur suivant :

Code : Tout sélectionner

Début de la mise à jour de : sonos3
Téléchargement de sonos3...
OK
Action de pre update...
OK
Décompression du zip...
OK
Installation de sonos3...
OK
PHP Fatal error:  Call to undefined function GuzzleHttp\Handler
Une idée ?
Merci.

Avatar de l’utilisateur
fredester
Timide
Messages : 90
Inscription : 04 oct. 2014, 09:06

Re: [Sujet officiel] Plugin sonos

Message par fredester » 31 oct. 2015, 10:22

@xapi :
Même pour le TTS ?!
Chez moi, il n'y a que la musique qui est OK avec le nouveau plugin.

@loic :
Ne marche toujours pas avec cette config (je fais bien "sauvegarde" après avoir changé la config avant de tester)
Sans titre.png
Sans titre.png (23.05 Kio) Consulté 387 fois
Ajouter le "/" à la fin du chemin sur le nas ne change rien (idem pour le "/" devant).
Jeedom 3.3.18 ESXi - PC BRIX GB-BXBT-1900 - Debian Stretch

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 31 oct. 2015, 10:40

Tu mets un chemin absolument dans chemin sur le nas alors qu'il faut un relatif..... met tts tout cours comme ca tu as bien 192.168.1.5/tts comme chemin complet quand tu additionnes

@thebobx : non aucune on dirait qu'il a pas pris les fichier relance l'installation pour voir
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
fredester
Timide
Messages : 90
Inscription : 04 oct. 2014, 09:06

Re: [Sujet officiel] Plugin sonos

Message par fredester » 31 oct. 2015, 10:56

Cool, ça marche comme ça:
Nom ou IP du partage: 192.168.1.6
Chemin sur le nas : tts

Ne pourrait-on pas simplier la page configuration en une seule ligne du genre : "Dossier de partage : 192.168.1.6/tts" ? (pour reprendre mon cas)
Parce que entre les "/" ou pas sur deux lignes (sans compter en début ou fin) et les chemins relatifs et absolus, la combinatoire pour se planter est bien bien élevée !

En tout cas merci pour l'aide !
Jeedom 3.3.18 ESXi - PC BRIX GB-BXBT-1900 - Debian Stretch

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 31 oct. 2015, 11:21

Effectivement je viens d'envoyer une version qui je pense vous simplifiera la configuration
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
fredester
Timide
Messages : 90
Inscription : 04 oct. 2014, 09:06

Re: [Sujet officiel] Plugin sonos

Message par fredester » 31 oct. 2015, 11:34

Super Loic, toujours aussi réactif !
Jeedom 3.3.18 ESXi - PC BRIX GB-BXBT-1900 - Debian Stretch

maxtofurious
Timide
Messages : 174
Inscription : 29 juil. 2015, 22:04
Localisation : Amiens

Re: [Sujet officiel] Plugin sonos

Message par maxtofurious » 31 oct. 2015, 19:18

Bon c'est bon pour moi, par contre j'ai du mettre un sous répertoire TTS sinon ca marchait pas ! Merci encore pour cette merveille =)

Avant \\192168.0254\Sonos\ --> KO
Maintenant \\192168.0254\Sonos\ --> OK

@ Loic, il ne te reste plus qu'à inclure la possibilité de tester les voix avant de la sélectionner ... Genre une case ou on précise notre phrase de test, on choisi la voix et clic sur Tester. (Pas obligé que ça soit lu sur Sonos pour le test, sur le pc c'est suffisant...) Ca éviterai de mettre à jour les dépendances Sonos à chaque changement de voix ....
JeeDOM sur Raspberry PI 2 + RFXCom

ITL-3500 - Module commutateur 3 charges
CH54700 - Module émetteur
CH54758 - module récepteur
CH54781 - Contacteur de porte sans fil
Volet SIMU - RTS
Sonos Play:1

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 31 oct. 2015, 19:25

@maxtofurious : désolé mais non aps de test il y a le site du moteur tts a la limite pour le faire mais j'ai pas trop envie de passer du temps la dessus je pense qu'il y a beaucoup plus important a faire (comme jeedom 2.0 par exemple)
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

maxtofurious
Timide
Messages : 174
Inscription : 29 juil. 2015, 22:04
Localisation : Amiens

Re: [Sujet officiel] Plugin sonos

Message par maxtofurious » 31 oct. 2015, 19:52

loic a écrit :@maxtofurious : désolé mais non aps de test il y a le site du moteur tts a la limite pour le faire mais j'ai pas trop envie de passer du temps la dessus je pense qu'il y a beaucoup plus important a faire (comme jeedom 2.0 par exemple)

T'as un lien ...?
JeeDOM sur Raspberry PI 2 + RFXCom

ITL-3500 - Module commutateur 3 charges
CH54700 - Module émetteur
CH54758 - module récepteur
CH54781 - Contacteur de porte sans fil
Volet SIMU - RTS
Sonos Play:1

guillaumex
Timide
Messages : 24
Inscription : 13 déc. 2014, 09:49

Re: [Sujet officiel] Plugin sonos

Message par guillaumex » 31 oct. 2015, 21:19

Bonsoir à tous,

Je suis sur RPI2 avec Wheezy et je vois qu'il faut une version PHP 5.6 pour cette nouvelle version. Je suis en 5.4.39-0+deb7u2 actuellement...
Mes capacités Linux étant plus que limitées, auriez vous un tuto afin de passer en PHP 5.6. J'en ai trouvé une multitude sur le net mais
je ne voudrais pas tenter le diable et préfère me tourner vers vous.
J'ai recherché sur le forum mais avec les mots clés PHP .... aucune chance de trouver !
Merci à vous

Répondre

Revenir vers « [Plugin Officiel] Sonos controller »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités