Page 115 sur 127

Re: [Sujet officiel] Plugin sonos

Publié : 21 janv. 2019, 16:28
par Kermitlagrenouille
Petit rappel

Pour l'instant sonos3 ne marche qu'en beta sur PHP7 Stretch

Passez en Stretch = remise à zero avec clé usb et nouveau backupJeedomStretch-beta.tar.gz renommé en backupJeedom.tar.gz (à télécharger depuis un PC)

Puis remonté de sauvegarde (après en avoir fait plusieurs bien sûr)

Tu transpires pendant la manip :oops: mais ça marche ;)

voir lien Loic viewtopic.php?t=38294#p646587

Capture d’écran 2019-01-21 à 16.17.35.png
Capture d’écran 2019-01-21 à 16.17.35.png (189.96 Kio) Consulté 680 fois

Re: [Sujet officiel] Plugin sonos

Publié : 22 janv. 2019, 10:45
par BaaTuuC
Hello,
Est ce qu'il existe une liste des options pour la lecture favoris et playlist du plugin ? Par exemple lecture aléatoire, ou en boucle (chansin / liste), fondue automatique etc ?

merci

Re: [Sujet officiel] Plugin sonos

Publié : 22 janv. 2019, 11:25
par loic
Bonjour,
Tu as une option pour la lecture aléatoire en mettant simplement random dans option

Re: [Sujet officiel] Plugin sonos

Publié : 22 janv. 2019, 21:08
par BaaTuuC
yes celui là je l'avais, mais existe t'il les autres options ? boucle / fondu :-D ?

Re: [Sujet officiel] Plugin sonos

Publié : 22 janv. 2019, 22:01
par loic
Non non sinon je l'aurais dit

Re: [Sujet officiel] Plugin sonos

Publié : 23 janv. 2019, 07:28
par imodiris
J'ai un truc bizarre depuis le dernier update (noyau + sonos)
Mes sonos ne parlent plus. Et je les fait beaucoup parler.
J'ai ce message dans les logs :
2019-01-23 07:23:01 sonos3 Erreur exécution de la commande [Cuisine][192.168.86.155 - Sonos One][Dire] : cURL error 7: Failed to connect to 192.168.86.24 port 1400: No route to host (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)
2019-01-23 07:21:14 sonos3 Erreur sur [Salle de bain][192.168.86.24 - Sonos Play:1] : Unable to find a speaker for the IP address '192.168.86.24'
2019-01-23 07:21:14 sonos3 Erreur sur [Salon][192.168.86.233 - Sonos Beam] : Unable to find a speaker for the IP address '192.168.86.233'
Et dans les logs du senario j'ai ceci
[2019-01-23 07:22:58][SCENARIO] Start : Scenario lance manuellement.
[2019-01-23 07:22:58][SCENARIO] Exécution du sous-élément de type [action] : action
[2019-01-23 07:22:58][SCENARIO] Exécution de la commande [Cuisine][192.168.86.155 - Sonos One][Dire] avec comme option(s) : {"background":"0","title":"50","message":"il est 7 heure, killiane doit entrer en phase de r\u00e9veil."}
[2019-01-23 07:23:01][SCENARIO] cURL error 7: Failed to connect to 192.168.86.24 port 1400: No route to host (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)
[2019-01-23 07:23:01][SCENARIO] Fin correcte du scénario
la 24 est en effet débranché mais ne fait pas parti des sonos concerné par ce sénario.
seule la .155 est concernée
La .233 est dans le premier quote marquée comme unable to find, alors que la beam est bien en route

Je sèche un peu.

[EDIT] si je rebranche la sonos en .24 le son fonctionne. C'est etrange que cela ne marche plus si elle est debranchée alors qu'elle n'est pas concernée par le sénario

Re: [Sujet officiel] Plugin sonos

Publié : 23 janv. 2019, 08:32
par ferritales
Hello,

Idem chez moi.
Je debranche via une prise connectée certain sonos pour qu'il ne consomme pas de courant (la nuit et lorsqu'il y a personne dans la maison).
Si un des sonos est débranché le plugin me donne la meme erreure, même si le sonos débranché ne fait pas partie de la regle.
Example: j'ai mon sonos de la chambre débranché, si je fait stop sur ma playbar j'ai cette erreur (cURL error 7: Failed to connect to 192.168.1.122 port 1400: No route to host (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) => ,22 etant le sonos de ma chambre)

Cela dit, ce problème ne date pas de la dernière mise a jour.

Bonne journée
F.

Re: [Sujet officiel] Plugin sonos

Publié : 23 janv. 2019, 09:12
par loic
Bonjour,
J'ai corrigé ce soucis lundi en beta ca arrivera prochainement en stable. Pour information c'est du au nouveau mode de fonctionnement qui permet d'ajouter des sonos à la main sans la decouverte.

Re: [Sujet officiel] Plugin sonos

Publié : 23 janv. 2019, 09:24
par ferritales
Super Merci Loic.

Re: [Sujet officiel] Plugin sonos

Publié : 23 janv. 2019, 11:19
par imodiris
loic a écrit :
23 janv. 2019, 09:12
Bonjour,
J'ai corrigé ce soucis lundi en beta ca arrivera prochainement en stable. Pour information c'est du au nouveau mode de fonctionnement qui permet d'ajouter des sonos à la main sans la decouverte.
Super merci loic.
PS la derniere beta que j'ai c'est la version market / plugin : sonos3 beta 2019-01-18 06:21:21 (default / core : jeedom 3.3.8)

Re: [Sujet officiel] Plugin sonos

Publié : 23 janv. 2019, 14:31
par loic
Je l'avais pas encore mis en ligne (je testé juste chez moi). Ca sera en ligne demain

Re: [Sujet officiel] Plugin sonos

Publié : 23 janv. 2019, 22:14
par akenad
Kermitlagrenouille a écrit :
21 janv. 2019, 16:28
Petit rappel

Pour l'instant sonos3 ne marche qu'en beta sur PHP7 Stretch

Passez en Stretch = remise à zero avec clé usb et nouveau backupJeedomStretch-beta.tar.gz renommé en backupJeedom.tar.gz (à télécharger depuis un PC)

Puis remonté de sauvegarde (après en avoir fait plusieurs bien sûr)

Tu transpires pendant la manip :oops: mais ça marche ;)

[...]
Bonjour @Kermitlagrenouille,

Pour passer la JeedomSmart de Jessie en Stretch par Recovery mode c'est ici

akenad :)

Re: [Sujet officiel] Plugin sonos

Publié : 24 janv. 2019, 08:47
par Kermitlagrenouille
hello @akenad, bien vu, j'avais oublié ton tuto. Ca doit être l'âge... :lol: :lol:

Re: [Sujet officiel] Plugin sonos

Publié : 25 janv. 2019, 14:02
par ferritales
loic a écrit :
23 janv. 2019, 09:12
Bonjour,
J'ai corrigé ce soucis lundi en beta ca arrivera prochainement en stable. Pour information c'est du au nouveau mode de fonctionnement qui permet d'ajouter des sonos à la main sans la decouverte.
Bonjour Loic,

Merci pour la mise a jour.
Pour ton information, j'ai toujours le soucis avec la dernière version. Rien de tres grave, mais si un des sonos n'est pas branché, on peut rien faire avec tout les autres.
si je fait play sur mon sonos 192.168.1.106 j'ai le message d'erreur suivant:
(cURL error 7: Failed to connect to 192.168.1.122 port 1400: No route to host (see https://curl.haxx.se/libcurl/c/libcurl-errors.html))
.122 c'est mon sonos débranché (j'ai aucun grouping entre le 122 et le 106).

F.

Re: [Sujet officiel] Plugin sonos

Publié : 25 janv. 2019, 14:56
par loic
Tu es en beta ? Car cette correction n'est que en beta, attention il faut dans jeedom désactiver le sonos débranché.

Re: [Sujet officiel] Plugin sonos

Publié : 25 janv. 2019, 15:11
par ferritales
oui oui je suis en béta. je comprends ta reponse mais c'est pas le but.
il est branché/débranché avec une regle, c'est voulu comme fonctionnement (gestion de la conso de la playbar).
Avant (genre mi 2018) ca marchait.
Avec l'app sonos, ou d'autre development ca marche aussi, meme avec un ou plusieur sonos débranché(s).

Rien de bien grave, mais ennuyeux dans certain cas. Penses-tu qu'il est possible de résoudre cette contrainte?

Merci d'avance.

F.

Re: [Sujet officiel] Plugin sonos

Publié : 25 janv. 2019, 15:42
par loic
J'ai donné la réponse juste au dessus... quand tu coupe le courant il faut dans jeedom désactiver l'équipement sonos.

Re: [Sujet officiel] Plugin sonos

Publié : 25 janv. 2019, 16:15
par ferritales
Ok, je ne savais pas que l'on pouvait faire ca dans une regle.
EDIT: TOP MERCI en plus j'ai appris un truc !

Re: [Sujet officiel] Plugin sonos

Publié : 27 janv. 2019, 19:09
par hansc
hello

je vient de faire la mise à jours vers la version 2019-01-27 06:26:25 (beta)

j'ai un souci avec le sonos ONE, je peux ajouter un autre sonos ( play:1) quand je veux le supprimer j'ai une erreur:

Code : Tout sélectionner

	Erreur exécution de la commande [Multimedia][Bureau Sonos One][Supprimer un haut parleur] : You cannot create a Controller instance from a Speaker that is not the coordinator of its group
le debug log au moment de l'erreur:

Code : Tout sélectionner

[2019-01-27 19:01:53][INFO] : creating speaker instances
[2019-01-27 19:01:53][NOTICE] : requesting xml from: http://172.17.247.215:1400/xml/device_description.xml
[2019-01-27 19:01:53][DEBUG] : 172.17.247.215 model: S13
[2019-01-27 19:01:53][INFO] : getting xml from cache: http://172.17.247.215:1400/xml/device_description.xml
[2019-01-27 19:01:53][NOTICE] : requesting xml from: http://172.17.247.180:1400/xml/device_description.xml
[2019-01-27 19:01:53][DEBUG] : 172.17.247.180 model: S14
[2019-01-27 19:01:53][INFO] : getting xml from cache: http://172.17.247.180:1400/xml/device_description.xml
[2019-01-27 19:01:53][NOTICE] : requesting xml from: http://172.17.247.168:1400/xml/device_description.xml
[2019-01-27 19:01:53][DEBUG] : 172.17.247.168 model: S12
[2019-01-27 19:01:53][INFO] : getting xml from cache: http://172.17.247.168:1400/xml/device_description.xml
[2019-01-27 19:01:53][NOTICE] : requesting xml from: http://172.17.247.165:1400/xml/device_description.xml
[2019-01-27 19:01:53][DEBUG] : 172.17.247.165 model: S12
[2019-01-27 19:01:53][INFO] : getting xml from cache: http://172.17.247.165:1400/xml/device_description.xml
[2019-01-27 19:01:53][INFO] : sending soap request to: http://172.17.247.215:1400/ZoneGroupTopology/Control
[2019-01-27 19:01:53][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-01-27 19:01:53][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Bureau + 1</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_7828CAA4443201400:1624635169</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_7828CACEB04C01400,RINCON_7828CAA3B2DA01400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-01-27 19:01:53][INFO] : sending soap request to: http://172.17.247.180:1400/ZoneGroupTopology/Control
[2019-01-27 19:01:53][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-01-27 19:01:53][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Salle TV</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_347E5C914D3601400:314167282</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_347E5C914D3601400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-01-27 19:01:53][INFO] : sending soap request to: http://172.17.247.168:1400/ZoneGroupTopology/Control
[2019-01-27 19:01:53][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-01-27 19:01:53][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName></CurrentZoneGroupName><CurrentZoneGroupID>RINCON_7828CAA4443201400:1624635169</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_7828CACEB04C01400,RINCON_7828CAA3B2DA01400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-01-27 19:01:53][INFO] : sending soap request to: http://172.17.247.165:1400/ZoneGroupTopology/Control
[2019-01-27 19:01:53][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-01-27 19:01:53][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Salon</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_7828CAA4443201400:1624635173</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_7828CAA4443201400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
j'ai tester depuis l'appli sonos --> pas de soucis

j'ai tester sur un autre Play:1 pas de souci .....

j'ai tester vers la barre beam --> même problème

j'ai re demmaré le daemon sa change rien ...

une autre idées ???

merci

Chris

Re: [Sujet officiel] Plugin sonos

Publié : 29 janv. 2019, 12:27
par i-magin
Bonjour

Je viens d'effectuer la mise à jour du plugin sonos en beta version 2019-01-29 06:26:27

Tout fonctionne bien, sauf un détail que j'avais signalé lors de ma précédente maj beta en octobre 2018
Lorsque mes sonos diffusent le son d'une station radio, l'information affichée par le plugin est : "entrée de ligne"

Voici le lien comprenant mon précédent message et la réponse de @zeflash qui avait examiné le code :
viewtopic.php?f=171&t=6631&start=2200#p667680

Pas de souci par contre avec des listes de lecture, ou la musique en ligne (Spotify), l'image de la pochette étant bien affichée

Je rappelle que mon installation comporte un Sonos Connect

Merci

Pour info : suite à maj du plugin, le demon n'est pas relancé (il est bien démarré et conserve la date du dernier lancement)