Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Sujet officiel] Plugin sonos

Avatar de l’utilisateur
hansc
Timide
Messages : 133
Inscription : 16 févr. 2017, 20:14
Localisation : Belgique

Re: [Sujet officiel] Plugin sonos

Message par hansc » 03 févr. 2019, 13:31

après quelques test avec la dernière version Beta.

quand j'ajoute une pause ou un stop dans un scenario:

Code : Tout sélectionner

#[Multimedia][Sonos Chambre][Pause]#
#[Multimedia][Sonos Chambre][Stop]#
mes sonos passent en Muet ....

le debug log;

Code : Tout sélectionner

[2019-02-03 13:28:43][INFO] : creating speaker instances
[2019-02-03 13:28:43][NOTICE] : requesting xml from: http://172.17.247.215:1400/xml/device_description.xml
[2019-02-03 13:28:43][DEBUG] : 172.17.247.215 model: S13
[2019-02-03 13:28:43][INFO] : getting xml from cache: http://172.17.247.215:1400/xml/device_description.xml
[2019-02-03 13:28:43][NOTICE] : requesting xml from: http://172.17.247.180:1400/xml/device_description.xml
[2019-02-03 13:28:43][DEBUG] : 172.17.247.180 model: S14
[2019-02-03 13:28:43][INFO] : getting xml from cache: http://172.17.247.180:1400/xml/device_description.xml
[2019-02-03 13:28:43][NOTICE] : requesting xml from: http://172.17.247.168:1400/xml/device_description.xml
[2019-02-03 13:28:43][DEBUG] : 172.17.247.168 model: S12
[2019-02-03 13:28:43][INFO] : getting xml from cache: http://172.17.247.168:1400/xml/device_description.xml
[2019-02-03 13:28:43][NOTICE] : requesting xml from: http://172.17.247.165:1400/xml/device_description.xml
[2019-02-03 13:28:43][DEBUG] : 172.17.247.165 model: S12
[2019-02-03 13:28:43][INFO] : getting xml from cache: http://172.17.247.165:1400/xml/device_description.xml
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.168:1400/ZoneGroupTopology/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Chambre</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_7828CAA3B2DA01400:887690118</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_7828CAA3B2DA01400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.215:1400/ZoneGroupTopology/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Bureau</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_7828CAA4443201400:1624635180</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_7828CACEB04C01400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.180:1400/ZoneGroupTopology/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Salle TV</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_347E5C914D3601400:314167285</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_347E5C914D3601400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.165:1400/ZoneGroupTopology/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Salon</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_7828CAA4443201400:1624635181</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_7828CAA4443201400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.168:1400/MediaRenderer/RenderingControl/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:RenderingControl:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:SetMute><Channel xsi:type="xsd:string">Master</Channel><DesiredMute xsi:type="xsd:string">1</DesiredMute><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:SetMute></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:SetMuteResponse xmlns:u="urn:schemas-upnp-org:service:RenderingControl:1"></u:SetMuteResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.168:1400/MediaRenderer/AVTransport/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:AVTransport:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:Pause><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:Pause></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:PauseResponse xmlns:u="urn:schemas-upnp-org:service:AVTransport:1"></u:PauseResponse></s:Body></s:Envelope>
Je ne voit pas trop ou sa coince ...

Chris
PC Debian Stretch / Raspberry PI 3
SIGMA DESIGNS Contrôleur Z-Wave Plus USB
Fibaro Wall Plug FGWPF-102 ZW5
philips hue | netatmo weather | netatmo Welcome
Google Home | Xiaomi | SONOS | Awtrix | Shelly

i-magin
Actif
Messages : 987
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: [Sujet officiel] Plugin sonos

Message par i-magin » 03 févr. 2019, 15:04

Bonjour

Ma version du plugin Sonos est la suivante : 2019-02-01 06:28:26
Mais ce que je vais décrire n'est pas propre à cette version, mon constat datant d'un certain temps déjà

Pour lancer la lecture d'une musique depuis Spotify sur un Sonos, il existe deux méthodes :

1 - Depuis l'application Sonos
Voici deux copies d'écran prises depuis l'application Sonos sur mon iPhone
Sonos Spotify sonos 1.PNG
Sonos Spotify sonos 1.PNG (325.74 Kio) Consulté 662 fois
Sonos Spotify sonos 2.PNG
Sonos Spotify sonos 2.PNG (169.53 Kio) Consulté 662 fois

Voici ce que j'obtiens sous Jeedom

Sonos Spotify 1.PNG
Sonos Spotify 1.PNG (98.54 Kio) Consulté 662 fois
J'ouvre un deuxième message pour la suite (limite du nombre de fichiers dans un message)
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

i-magin
Actif
Messages : 987
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: [Sujet officiel] Plugin sonos

Message par i-magin » 03 févr. 2019, 15:05

2 - Lancement de la musique directement depuis l'application Spotify sur un Sonos

Sonos Spotify Spotify 1.PNG
Sonos Spotify Spotify 1.PNG (338.22 Kio) Consulté 651 fois
Sonos Spotify Spotify 2.PNG
Sonos Spotify Spotify 2.PNG (180.67 Kio) Consulté 651 fois

On peut constater des indications différentes dans l'application Sonos, par rapport aux informations obtenues lors d'un lancement de la musique depuis l'application sonos : "Lecture depuis Spotify" et "Démarré depuis Spotify"
Par contre rien de changé au niveau Widget Sonos de Jeedom.... et ce n'est pas un problème

Si on lance de la musique Spotify sur un Sonos depuis Alexa, on se retrouve dans ce deuxième cas.... et comme j'utilise de plus en plus cette possibilité j'ai pu me rendre compte du petit défaut suivant :

Si j'envoie un TTS sur un Sonos, la reprise ne se fera pas sur le dernier morceau en cours de lecture, qui avait été lancé directement depuis Spotify.
La lecture reprendra sur le dernier morceau lancé depuis l'application Sonos et mémorisé... quelque part

Avez-vous fait le même constat ?

C'est un peu gênant...
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

Avatar de l’utilisateur
Kermitlagrenouille
Actif
Messages : 1770
Inscription : 07 juin 2017, 20:46
Localisation : Alsace

Re: [Sujet officiel] Plugin sonos

Message par Kermitlagrenouille » 03 févr. 2019, 19:45

i-magin a écrit :
03 févr. 2019, 15:05
Si j'envoie un TTS sur un Sonos, la reprise ne se fera pas sur le dernier morceau en cours de lecture, qui avait été lancé directement depuis Spotify.
Hello
Tu confirmes que TWS fonctionne vers les Sonos?
Bizarre, chez moi plus rien et impossible de trouver le bug... :shock: :oops:
Domotique Atlantique Concept depuis 1998 et toujours à la recherche d’autre utilisateur de ce système
Fan d'Apple & Homebridge

i-magin
Actif
Messages : 987
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: [Sujet officiel] Plugin sonos

Message par i-magin » 03 févr. 2019, 19:59

J’ai écrit TTS et non TWS ;)
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

Avatar de l’utilisateur
Kermitlagrenouille
Actif
Messages : 1770
Inscription : 07 juin 2017, 20:46
Localisation : Alsace

Re: [Sujet officiel] Plugin sonos

Message par Kermitlagrenouille » 04 févr. 2019, 07:19

i-magin a écrit :
03 févr. 2019, 19:59
J’ai écrit TTS et non TWS ;)
Ahahah zut :shock: :? :lol:
Merci
Domotique Atlantique Concept depuis 1998 et toujours à la recherche d’autre utilisateur de ce système
Fan d'Apple & Homebridge

Avatar de l’utilisateur
BaaTuuC
Actif
Messages : 802
Inscription : 19 oct. 2015, 19:48

Re: [Sujet officiel] Plugin sonos

Message par BaaTuuC » 04 févr. 2019, 08:58

hansc a écrit :
03 févr. 2019, 13:31
après quelques test avec la dernière version Beta.

quand j'ajoute une pause ou un stop dans un scenario:

Code : Tout sélectionner

#[Multimedia][Sonos Chambre][Pause]#
#[Multimedia][Sonos Chambre][Stop]#
mes sonos passent en Muet ....

le debug log;

Code : Tout sélectionner

[2019-02-03 13:28:43][INFO] : creating speaker instances
[2019-02-03 13:28:43][NOTICE] : requesting xml from: http://172.17.247.215:1400/xml/device_description.xml
[2019-02-03 13:28:43][DEBUG] : 172.17.247.215 model: S13
[2019-02-03 13:28:43][INFO] : getting xml from cache: http://172.17.247.215:1400/xml/device_description.xml
[2019-02-03 13:28:43][NOTICE] : requesting xml from: http://172.17.247.180:1400/xml/device_description.xml
[2019-02-03 13:28:43][DEBUG] : 172.17.247.180 model: S14
[2019-02-03 13:28:43][INFO] : getting xml from cache: http://172.17.247.180:1400/xml/device_description.xml
[2019-02-03 13:28:43][NOTICE] : requesting xml from: http://172.17.247.168:1400/xml/device_description.xml
[2019-02-03 13:28:43][DEBUG] : 172.17.247.168 model: S12
[2019-02-03 13:28:43][INFO] : getting xml from cache: http://172.17.247.168:1400/xml/device_description.xml
[2019-02-03 13:28:43][NOTICE] : requesting xml from: http://172.17.247.165:1400/xml/device_description.xml
[2019-02-03 13:28:43][DEBUG] : 172.17.247.165 model: S12
[2019-02-03 13:28:43][INFO] : getting xml from cache: http://172.17.247.165:1400/xml/device_description.xml
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.168:1400/ZoneGroupTopology/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Chambre</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_7828CAA3B2DA01400:887690118</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_7828CAA3B2DA01400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.215:1400/ZoneGroupTopology/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Bureau</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_7828CAA4443201400:1624635180</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_7828CACEB04C01400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.180:1400/ZoneGroupTopology/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Salle TV</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_347E5C914D3601400:314167285</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_347E5C914D3601400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.165:1400/ZoneGroupTopology/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ZoneGroupTopology:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:GetZoneGroupAttributes><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:GetZoneGroupAttributes></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:GetZoneGroupAttributesResponse xmlns:u="urn:schemas-upnp-org:service:ZoneGroupTopology:1"><CurrentZoneGroupName>Salon</CurrentZoneGroupName><CurrentZoneGroupID>RINCON_7828CAA4443201400:1624635181</CurrentZoneGroupID><CurrentZonePlayerUUIDsInGroup>RINCON_7828CAA4443201400</CurrentZonePlayerUUIDsInGroup><CurrentMuseHouseholdId>Sonos_UhS1rf0fcgGDYKhIWRk8WLJqqW.QAyNmqdnRTFZYfaO7y9Q</CurrentMuseHouseholdId></u:GetZoneGroupAttributesResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.168:1400/MediaRenderer/RenderingControl/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:RenderingControl:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:SetMute><Channel xsi:type="xsd:string">Master</Channel><DesiredMute xsi:type="xsd:string">1</DesiredMute><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:SetMute></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:SetMuteResponse xmlns:u="urn:schemas-upnp-org:service:RenderingControl:1"></u:SetMuteResponse></s:Body></s:Envelope>
[2019-02-03 13:28:43][INFO] : sending soap request to: http://172.17.247.168:1400/MediaRenderer/AVTransport/Control
[2019-02-03 13:28:43][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:AVTransport:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Body><ns1:Pause><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:Pause></SOAP-ENV:Body></SOAP-ENV:Envelope> 
[2019-02-03 13:28:43][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:PauseResponse xmlns:u="urn:schemas-upnp-org:service:AVTransport:1"></u:PauseResponse></s:Body></s:Envelope>
Je ne voit pas trop ou sa coince ...

Chris
J'ai la même chose. Mais pas à chaque fois :)
Si ca marche .. c'est que ca peut faire plus !!

Merci à toute la communauté pour le boulot !

Avatar de l’utilisateur
Kermitlagrenouille
Actif
Messages : 1770
Inscription : 07 juin 2017, 20:46
Localisation : Alsace

Re: [Sujet officiel] Plugin sonos

Message par Kermitlagrenouille » 04 févr. 2019, 16:10

Hello
Je viens de remarquer un truc:
Avant pour pause et play d'un groupe je commandais le Sonos "maitre"
Mais ça marche aussi en commandant tous les sonos malgré qu'ils soit groupés et dans n'importe quel ordre, et ça m'arrange bien :D
Capture d’écran 2019-02-04 à 16.06.27.png
Capture d’écran 2019-02-04 à 16.06.27.png (68.69 Kio) Consulté 572 fois
Domotique Atlantique Concept depuis 1998 et toujours à la recherche d’autre utilisateur de ce système
Fan d'Apple & Homebridge

Avatar de l’utilisateur
BaaTuuC
Actif
Messages : 802
Inscription : 19 oct. 2015, 19:48

Re: [Sujet officiel] Plugin sonos

Message par BaaTuuC » 04 févr. 2019, 17:07

Après quelques tests je dirais meme plus que si tu fais un stop que sur le maitre ca n'arrete pas les autres .. mais j'ai besoin de faire quelques tests supplémentaires pour valider
Si ca marche .. c'est que ca peut faire plus !!

Merci à toute la communauté pour le boulot !

Avatar de l’utilisateur
Kermitlagrenouille
Actif
Messages : 1770
Inscription : 07 juin 2017, 20:46
Localisation : Alsace

Re: [Sujet officiel] Plugin sonos

Message par Kermitlagrenouille » 04 févr. 2019, 17:33

Si ça arrête les autres, mais ce matin non... comprend plus rien... en tous cas plus de message d'erreur en faisant comme ça...
Sonos me fait des caprices depuis quelques jours... :twisted: :mrgreen: :o
Domotique Atlantique Concept depuis 1998 et toujours à la recherche d’autre utilisateur de ce système
Fan d'Apple & Homebridge

Avatar de l’utilisateur
BaaTuuC
Actif
Messages : 802
Inscription : 19 oct. 2015, 19:48

Re: [Sujet officiel] Plugin sonos

Message par BaaTuuC » 05 févr. 2019, 08:42

Ca a l'air d'etre sacrément compliqué à gérer Sonos .. ils changent leurs API tous les 4 matins j'ai l'impression et ce qui marche un jour ne sera psa forcément vrai le lendemain ..
Si ca marche .. c'est que ca peut faire plus !!

Merci à toute la communauté pour le boulot !

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 05 févr. 2019, 09:47

Oui si c'était a refaire je prendrais surtout pas du Sonos leur api est super compliqué et change trop... Perso un bon google home ou home max c'est pas mal et surtout c'est compatible google home.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
BaaTuuC
Actif
Messages : 802
Inscription : 19 oct. 2015, 19:48

Re: [Sujet officiel] Plugin sonos

Message par BaaTuuC » 05 févr. 2019, 10:17

loic a écrit :
05 févr. 2019, 09:47
Oui si c'était a refaire je prendrais surtout pas du Sonos leur api est super compliqué et change trop... Perso un bon google home ou home max c'est pas mal et surtout c'est compatible google home.
Ah je pense que les utilisations sont différentes ..
Sonos c'est avant tout des enceintes .. Tu n'as pas la meme qualité sur un google home .. et puis google ... c'est google :D
Si ca marche .. c'est que ca peut faire plus !!

Merci à toute la communauté pour le boulot !

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 05 févr. 2019, 10:32

Entre un sonos 5 et un google home max je serais curieux d'écouter la différence a mon avis ça doit être très proche surtout avec le systeme de réglage automatique du google home max.
Alors oui c'est google mais faut relativiser tu l'as déjà sur ton téléphone et puis dire "ok google mais du ACDC" c'est quand meme top
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
BaaTuuC
Actif
Messages : 802
Inscription : 19 oct. 2015, 19:48

Re: [Sujet officiel] Plugin sonos

Message par BaaTuuC » 05 févr. 2019, 11:58

loic a écrit :
05 févr. 2019, 10:32
Entre un sonos 5 et un google home max je serais curieux d'écouter la différence a mon avis ça doit être très proche surtout avec le systeme de réglage automatique du google home max.
Alors oui c'est google mais faut relativiser tu l'as déjà sur ton téléphone et puis dire "ok google mais du ACDC" c'est quand meme top
Je l'ai désactivé sur le téléphone .. et je préfère dire "hey snips mets du Rolling Stones" :lol:
Si ca marche .. c'est que ca peut faire plus !!

Merci à toute la communauté pour le boulot !

chauchse
Timide
Messages : 4
Inscription : 28 déc. 2017, 22:36

Re: [Sujet officiel] Plugin sonos

Message par chauchse » 05 févr. 2019, 13:07

Bonjour,


Nouvel utilisateur des merveilleuses enceintes Sonos :) , je me pose des questions sur le fonctionnement du plugin.

J'utilise Jeedom en v 3.2.3 sur RPI3
J'ai installé le plugin sonos depuis les sources Github car il n'était pas visible depuis le Market.

J'ai réussi à le faire fonctionner, cependant je n'arrive qu'à lire des playlist sonos depuis un scénario.
Mon Compte DEEZER est connecté à mon compte Sonos. N'est il pas possible de demander à lire "Flow" ou une autre playlist Deezer depuis les scénario ?

Si oui quelle est la syntaxe SVP ?

Merci pour votre aide

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: [Sujet officiel] Plugin sonos

Message par mortyre » 05 févr. 2019, 13:18

Je l'ai désactivé sur le téléphone .. et je préfère dire "hey snips mets du Rolling Stones" :lol:
Snips l'avenir de la commande vocale sans GAFA/cloud je suis bien d'accord !!!
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: [Sujet officiel] Plugin sonos

Message par mortyre » 05 févr. 2019, 13:20

loic a écrit :
05 févr. 2019, 10:32
Entre un sonos 5 et un google home max je serais curieux d'écouter la différence a mon avis ça doit être très proche surtout avec le systeme de réglage automatique du google home max.
Je ne sais pas la différence concernant la qualité sonore entre les deux MAIS l'application SONOS est quand même d'un tout autre niveau pour jouer de la musique que sur Google
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

Avatar de l’utilisateur
BaaTuuC
Actif
Messages : 802
Inscription : 19 oct. 2015, 19:48

Re: [Sujet officiel] Plugin sonos

Message par BaaTuuC » 05 févr. 2019, 13:55

chauchse a écrit :
05 févr. 2019, 13:07
Bonjour,


Nouvel utilisateur des merveilleuses enceintes Sonos :) , je me pose des questions sur le fonctionnement du plugin.

J'utilise Jeedom en v 3.2.3 sur RPI3
J'ai installé le plugin sonos depuis les sources Github car il n'était pas visible depuis le Market.

J'ai réussi à le faire fonctionner, cependant je n'arrive qu'à lire des playlist sonos depuis un scénario.
Mon Compte DEEZER est connecté à mon compte Sonos. N'est il pas possible de demander à lire "Flow" ou une autre playlist Deezer depuis les scénario ?

Si oui quelle est la syntaxe SVP ?

Merci pour votre aide
Je crois bien qu'il faut ajouter les playlist deezer a la liste des tes playlist Sonos depuis l'appli Sonos puis lancer une détection d'équiepements depuis le plugin
Pour ce qui est de la syntaxe il faut utiliser jouer une playlist, tu mets la première lettre et si il connait la playlist tu auras le menu déroulant. Si il propose pas c'est que la playlist n'est pas remontée dans le plugin.
Si ca marche .. c'est que ca peut faire plus !!

Merci à toute la communauté pour le boulot !

Avatar de l’utilisateur
BaaTuuC
Actif
Messages : 802
Inscription : 19 oct. 2015, 19:48

Re: [Sujet officiel] Plugin sonos

Message par BaaTuuC » 06 févr. 2019, 16:45

Comme beaucoup ici j'ai quelques soucis autour de la liaison / déliaison des sonos que je fais un coup via jeedom un coup a la main.
J'avais des soucis si je faisais des liaisons a la main que je ne supprimais pas et après j'utilisais mes sonos dans mes scénarios ..

J'avais donc fait un scénario qui tourne tous les 1/4 d'h et pour chaque sonos si il est arrété je supprimais les autres.
mais j'ai rencontré un drôle de comportement.
Voici ce que je fais

Si SonosA=Stop
SonosA.Supprimer SonosB
SonosA.Supprimer SonosC
SonosA.Supprimer SonosD
Si SonosB=Stop
SonosB.Supprimer SonosA
SonosB.Supprimer SonosB
SonosB.Supprimer SonosD

etc.

Le problème interviens lorsque je n'ai qu'un seul sonos qui tourne (par exemple C) et que le script s'execute.
Lors de SonosA.supprimer sonosC cela met le sonosC en stop..

Du coup comment pouvoir supprimer automatiquement mes liaisons que si ils sont arrétés ?
sachant que si A est lié avec B (avec A en maitre) si A est stopé le statut de B n'est pas forcément Stop ..
Si ca marche .. c'est que ca peut faire plus !!

Merci à toute la communauté pour le boulot !

Répondre

Revenir vers « [Plugin Officiel] Sonos controller »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité