Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Sujet officiel] SqueezeBox Control

Ricardo
Timide
Messages : 227
Inscription : 14 mars 2015, 15:26

Re: [Sujet officiel] SqueezeBox Control

Message par Ricardo » 18 juil. 2015, 11:22

Bonjour,

Je veux pas faire mon pénible mais, vous faites comment pour avoir la jaquette de ce que la squeezebox est en train de diffuser :?: chez moi cela ne fonctionne pas. Il y a une configuration à faire quelque part :!: j'ai 3 squeezebox et sur le dashboard de jeedom cela ne marche pas. Tout fonctionne correctement sauf l'affichage de la jaquette.
Je suis en version LMS 7.9

Si quelqu'un a une solution :idea: je suis preneur.

Bon week-*end à tous
;)
Dernière édition par Ricardo le 18 juil. 2015, 11:23, édité 1 fois.
HP T610 - Jeedom
56 modules Zwave - 32 modules Enocean - 3 modules Edisio - 7 modules Rfxcom - 40 modules Zigbee
Cam : 2 Dafang - 3 Foscam - 3 Wanscam
3 Broadlink - 7 Nuts
5 Amazon Echo - 4 Amazon Echo Dot
5 SqueezeBox - 4 Xiaomi Speaker

Ricardo
Timide
Messages : 227
Inscription : 14 mars 2015, 15:26

Re: [Sujet officiel] SqueezeBox Control

Message par Ricardo » 18 juil. 2015, 11:24

Oui pas de problème la dessus. Le plugin est bien installé sur le LMS et bien configuré avec l'IP et la clé jeedom. Redémarré le zinzin au moins 10 fois mais sans succés :(

J'ai un nom d'utilisateur et un mot de passe pour me connecter sur mon LMS. Il est bien renseigné sur la page de configuration du plugin. Tout est correctement paramétré puisque je peux allumer, éteindre, synchroniser les squeezebox depuis le dashboard............. :shock:

;)
HP T610 - Jeedom
56 modules Zwave - 32 modules Enocean - 3 modules Edisio - 7 modules Rfxcom - 40 modules Zigbee
Cam : 2 Dafang - 3 Foscam - 3 Wanscam
3 Broadlink - 7 Nuts
5 Amazon Echo - 4 Amazon Echo Dot
5 SqueezeBox - 4 Xiaomi Speaker

Avatar de l’utilisateur
domomat
Actif
Messages : 943
Inscription : 21 juil. 2014, 20:19
Localisation : Johannesburg

Re: [Sujet officiel] SqueezeBox Control

Message par domomat » 18 juil. 2015, 13:57

@sarakha63,
je ne sais pas si c'est possible mais, il y a pour moi un truc qui manque sur le widget c'est une barre de progression de la musique (et la possibilité de choisir la place du curseur pour la position de la lecture).

C'est faisable ?

MERCI
Jeedom --> Depuis Juillet 2014
VM Debian (NUC i5) - 100% Xiaomi Aqara & Yeelight
Détails ici

Ekinox
Timide
Messages : 407
Inscription : 07 mars 2015, 13:17
Localisation : Toulouse

Re: [Sujet officiel] SqueezeBox Control

Message par Ekinox » 18 juil. 2015, 14:28

Hello,

Je n'arrive pas à faire fonctionner le TTS. J'ai la dernière version du plugin et de Jeedom.
J'essaie de faire parler sur une squeezebox (squeezelite sur RaspPi + LMS sous Win7) avec un scénario:
SqueezeBoxTTS01.png
SqueezeBoxTTS01.png (5.51 Kio) Consulté 462 fois
J'ai une erreur dans le LOG "scenario_execution":

Code : Tout sélectionner

/usr/share/nginx/www/jeedom/plugins/squeezeboxcontrol/3rdparty/pydub/utils.py:165: RuntimeWarning: Couldn't find ffmpeg or avconv - defaulting to ffmpeg, but may not work
  warn("Couldn't find ffmpeg or avconv - defaulting to ffmpeg, but may not work", RuntimeWarning)
Traceback (most recent call last):
  File "/usr/share/nginx/www/jeedom/plugins/squeezeboxcontrol/core/class/../../3rdparty/executer_action.py", line 187, in 
    actions[sys.argv[6]](p)
  File "/usr/share/nginx/www/jeedom/plugins/squeezeboxcontrol/core/class/../../3rdparty/executer_action.py", line 111, in parle
    song = AudioSegment.from_mp3(filename)
  File "/usr/share/nginx/www/jeedom/plugins/squeezeboxcontrol/3rdparty/pydub/audio_segment.py", line 358, in from_mp3
    return cls.from_file(file, 'mp3')
  File "/usr/share/nginx/www/jeedom/plugins/squeezeboxcontrol/3rdparty/pydub/audio_segment.py", line 342, in from_file
    retcode = subprocess.call(convertion_command, stderr=open(os.devnull))
  File "/usr/lib/python2.7/subprocess.py", line 522, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1335, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Je n'ai pas d'autre souci avec le plugin.

Merci pour votre aide.
NUC i5+ESXi 6.0 (Jeedom sur Debian 8 avec zWave+RFXCom+MySensors+HuaweiG200)+IPX800v4+RaspPi (Multiroom SqueezeBox, Arrosage). 35 zWave/10 RFXCom/4 MySensors/Alarme filaire sur IPX (ouv, mvt, sirène ext), 4 Cameras

totovaauski
Actif
Messages : 1926
Inscription : 05 juil. 2014, 11:21

Re: [Sujet officiel] SqueezeBox Control

Message par totovaauski » 18 juil. 2015, 14:33

@ekinox, Je pense que tu n as pas du mettre a jour les dépendances ...

Envoyer avec mon pouce ...
RPI3 + Dongle Aeon
Jeedom sur : Raspberry Pi + Raspberry compute
Mysensors , z-wave, xiaomi ...

https://www.youtube.com/watch?v=-bjbUg9d64g
https://www.youtube.com/watch?v=GPj1ozB ... _b-Toq47NQ

rol-rider
Actif
Messages : 5097
Inscription : 10 août 2014, 23:50

Re: [Sujet officiel] SqueezeBox Control

Message par rol-rider » 18 juil. 2015, 14:49

Je viens d'installer SqueezeBox Control .....super ma Squeezebox DYI Picoreplayer fonctionne....je n'ai pas encore tout testé !
J'ai juste un problème dans "Message" qui revient (même après reboot) bon, je suis pas fortiche en linux!
mais comme j'avais l'ancien plugin, (avec un virtuel) que j'ai désinstallé (le virtuel aussi)
du coup je ne sais pas d’où ça vient:
CaptureSqueezeBoxControl.PNG
CaptureSqueezeBoxControl.PNG (13.13 Kio) Consulté 459 fois
Encore merci à sarakha63 ;)
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Ekinox
Timide
Messages : 407
Inscription : 07 mars 2015, 13:17
Localisation : Toulouse

Re: [Sujet officiel] SqueezeBox Control

Message par Ekinox » 18 juil. 2015, 15:12

Effectivement, les dépendances sont "NOK" sur l'ecran du plugin, merci.
Un click sur "Installer" m'ouvre une fenetre m'indiquant :

########### Installation en cours ##########
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libav-tools : Depends: libavdevice55 (>= 6:11~beta1) but it is not going to be installed
Depends: libavfilter5 (>= 6:11~beta1) but it is not going to be installed
linux-image-extra-3.16.0-41-generic : Depends: linux-image-3.16.0-41-generic but it is not going to be installed
linux-image-generic : Depends: linux-image-3.16.0-41-generic but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
########### Fin ##########


Si je me connecte sur Linux (VM Jeedom avec Ubuntu), et que je fais un 'apt-get -f install', ca ne fonctionne pas:

jeedom@jeedom:~$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
linux-headers-3.16.0-23 linux-headers-3.16.0-23-generic linux-headers-3.16.0-33 linux-headers-3.16.0-33-generic
linux-headers-3.16.0-34 linux-headers-3.16.0-34-generic linux-headers-3.16.0-36 linux-headers-3.16.0-36-generic
linux-image-3.16.0-23-generic linux-image-3.16.0-30-generic linux-image-3.16.0-33-generic linux-image-3.16.0-34-generic
linux-image-3.16.0-36-generic linux-image-extra-3.16.0-23-generic linux-image-extra-3.16.0-30-generic
linux-image-extra-3.16.0-33-generic linux-image-extra-3.16.0-34-generic linux-image-extra-3.16.0-36-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
linux-image-3.16.0-41-generic
Paquets suggérés :
fdutils linux-doc-3.16.0 linux-source-3.16.0 linux-tools
Les NOUVEAUX paquets suivants seront installés :
linux-image-3.16.0-41-generic
0 mis à jour, 1 nouvellement installés, 0 à enlever et 23 non mis à jour.
29 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/16,3 Mo dans les archives.
Après cette opération, 45,6 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 277271 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-image-3.16.0-41-generic_3.16.0-41.57_amd64.deb ...
Done.
Dépaquetage de linux-image-3.16.0-41-generic (3.16.0-41.57) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/linux-image-3.16.0-41-generic_3.16.0-41.57_amd64.deb (--unpack) :
impossible de copier les données extraites pour « ./boot/System.map-3.16.0-41-generic » vers « /boot/System.map-3.16.0-41-generic.dpkg-new » : fin de fichier ou de flux inattendue
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.16.0-41-generic /boot/vmlinuz-3.16.0-41-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.16.0-41-generic /boot/vmlinuz-3.16.0-41-generic
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/linux-image-3.16.0-41-generic_3.16.0-41.57_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Auriez-vous une idée ?
NUC i5+ESXi 6.0 (Jeedom sur Debian 8 avec zWave+RFXCom+MySensors+HuaweiG200)+IPX800v4+RaspPi (Multiroom SqueezeBox, Arrosage). 35 zWave/10 RFXCom/4 MySensors/Alarme filaire sur IPX (ouv, mvt, sirène ext), 4 Cameras

Avatar de l’utilisateur
bristow
Timide
Messages : 413
Inscription : 04 oct. 2014, 19:46
Localisation : Lyon

Re: [Sujet officiel] SqueezeBox Control

Message par bristow » 18 juil. 2015, 15:27

Ton problème est spécifiquement linux, je pense que le mieux est de voir avec le forum Ubuntu, tu trouveras sûrement une réponse.

En vrac :
- vérifier que les partitions ne sont pas saturées : df -h
- non saturation par les inodes : df -i
- réinstallation du paquet cassé : sudo apt-get install --reinstall linux-image-3.16.0-41-generic
- mise à jour des dépôts : sudo apt-get update
- puis apt-get -f install
- relancer la config de dpkg : sudo dpkg --configure -a

... je sais pas si cela résoudra le problème
JeeDOM 3.2.6 sur ODROID-C1+ avec eMMC + RazBerry + RFXCom
5xFGRM-222 / FGMS-001 / 2xFGK-101) + FGD / GreenWave / Sirène ZW080
1 Mir:ror + 1 NabazTag
NAS Synology 110+ avec 7 SqueezeBox

Ekinox
Timide
Messages : 407
Inscription : 07 mars 2015, 13:17
Localisation : Toulouse

Re: [Sujet officiel] SqueezeBox Control

Message par Ekinox » 18 juil. 2015, 16:23

Merci @bistrow pour ton aide.
Cela venait effectivement d'un manque de place sur le /boot (Note: j'utilise la VM "officielle" Ubuntu de Jeedom qui tourne sous VMWare player). Résolu avec un "sudo apt-get autoremove" et quelques broutilles.

Les dépendances sont "OK" et le TTS fonctionne bien. Merci à vous.
NUC i5+ESXi 6.0 (Jeedom sur Debian 8 avec zWave+RFXCom+MySensors+HuaweiG200)+IPX800v4+RaspPi (Multiroom SqueezeBox, Arrosage). 35 zWave/10 RFXCom/4 MySensors/Alarme filaire sur IPX (ouv, mvt, sirène ext), 4 Cameras

Avatar de l’utilisateur
Syll
Actif
Messages : 1577
Inscription : 14 janv. 2015, 18:46
Contact :

Re: [Sujet officiel] SqueezeBox Control

Message par Syll » 18 juil. 2015, 19:08

Oui l'image officielle VM Ubuntu a quelques soucis de place si on ne fait pas gaffe avec les kernels qui prennent la place dans le /boot :)

@Ekinox : Si tu lit le message où tu demande de l'aide c'est bien indiqué de faire le autoremove xD

Code : Tout sélectionner

Veuillez utiliser « apt-get autoremove » pour les supprimer.
Je t'accorde qu'il est un peu perdu dans tout ce qu'affiche le shell ^^

@Sarakha : J'ai un souci de synchro dans un sens.
SI je synchronise ma SB Cuisine (en wifi) depuis ma SB salon en filaire, la synchro est décalé jusqu'à 1 secondes.
SI je synchro ma SB cuisine vers ma SB salon, la synchro est tip top.

ça vient du Wifi tu penses ? J'attends un dongle wifi pour tester sur ma nouvelle SB chambre pour voir si ça ferait pareil...
Jeedom - ESXi 6.7U2 - VM Debian 9.9 | 60 Modules Zwave | 12 Modules RFXCom | 15 modules Xiaomi | GSM/JPI | Kodi | SqueezeBox | GH |

Avatar de l’utilisateur
Syll
Actif
Messages : 1577
Inscription : 14 janv. 2015, 18:46
Contact :

Re: [Sujet officiel] SqueezeBox Control

Message par Syll » 18 juil. 2015, 19:35

Outch oui je connaissais pas l'option (y'en a tellement)

Merci de l'info :)
Jeedom - ESXi 6.7U2 - VM Debian 9.9 | 60 Modules Zwave | 12 Modules RFXCom | 15 modules Xiaomi | GSM/JPI | Kodi | SqueezeBox | GH |

Avatar de l’utilisateur
minscof
Actif
Messages : 587
Inscription : 27 janv. 2015, 21:37

Re: [Sujet officiel] SqueezeBox Control

Message par minscof » 18 juil. 2015, 20:29

@rol-rider, je rencontre le même problème. As-tu trouvé un moyen de désinstaller proprement cet autre plugin ?
rol-rider a écrit :Je viens d'installer SqueezeBox Control .....super ma Squeezebox DYI Picoreplayer fonctionne....je n'ai pas encore tout testé !
J'ai juste un problème dans "Message" qui revient (même après reboot) bon, je suis pas fortiche en linux!
mais comme j'avais l'ancien plugin, (avec un virtuel) que j'ai désinstallé (le virtuel aussi)
du coup je ne sais pas d’où ça vient:
CaptureSqueezeBoxControl.PNG
Encore merci à sarakha63 ;)

rol-rider
Actif
Messages : 5097
Inscription : 10 août 2014, 23:50

Re: [Sujet officiel] SqueezeBox Control

Message par rol-rider » 19 juil. 2015, 00:07

ba oui et non!!
dans les logs j'ai viré, debug, info et error
du coup je n'ai plus de message ! (je crois que error doit suffire)
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
Syll
Actif
Messages : 1577
Inscription : 14 janv. 2015, 18:46
Contact :

Re: [Sujet officiel] SqueezeBox Control

Message par Syll » 21 juil. 2015, 13:27

Question à la con : Y'a moyen d'avoir d'autres voix que la dame ? :p
Jeedom - ESXi 6.7U2 - VM Debian 9.9 | 60 Modules Zwave | 12 Modules RFXCom | 15 modules Xiaomi | GSM/JPI | Kodi | SqueezeBox | GH |

Avatar de l’utilisateur
minscof
Actif
Messages : 587
Inscription : 27 janv. 2015, 21:37

Re: [Sujet officiel] SqueezeBox Control

Message par minscof » 21 juil. 2015, 13:29

La commande parle ne fonctionne plus alors qu'elle a fonctionné précédemment sur mon système, le fichier mp3 généré est créé et il est juste.
La musique en cours est interrompue, mais je n'entends rien.


Je pense que le problème vient de l'adresse IP utilisée pour faire jouer la commande : on voit dans les logs qu'on utilise l'adresse IP 127.0.0.1, donc l'adresse locale du serveur squeezebox et non l'adresse de jeedom où le fichier mp3 a été généré.

Voici les logs que j'ai
21-07-2015 12:25:10 | debug | Execution de la commande suivante : /usr/bin/python /usr/share/nginx/www/jeedom/plugins/squeezeboxcontrol/core/class/../../3rdparty/executer_action.py 192.168.0.15 9090 0 0 00:1a:92:62:dc:2b parle "test de la fonction parole" "http://127.0.0.1:80/jeedom" nochange dingdong
21-07-2015 12:25:12 | debug | Received : {"titre":"http://127.0.0.1/jeedom/plugins/squeeze ... ":"Lecture"} de : 00:1a:92:62:dc:2b
21-07-2015 12:25:12 | debug | Received : Plugin-Plugin-http://127.0.0.1/jeedom/plugins/squeeze ... 35bc0a.mp3
21-07-2015 12:25:12 | debug | Image à récupérer : http://192.168.0.15:9000/music/current/ ... 0.16672700 1437474312
21-07-2015 12:25:16 | debug | Received : {"volume":"71"} de : 00:1a:92:62:dc:2b
21-07-2015 12:25:16 | debug | Received : old-old-old

Ricardo
Timide
Messages : 227
Inscription : 14 mars 2015, 15:26

Re: [Sujet officiel] SqueezeBox Control

Message par Ricardo » 21 juil. 2015, 17:35

Bonjour,

Je confirme pour la fonction "Parle" cela fonctionnait très bien hier et depuis la mise à jour plus rien.
Voici les logs :

2015/07/21 17:20:03 [error] 2258#0: *3068 FastCGI sent in stderr: "PHP message: PHP Notice: Undefined index: api in /usr/share/nginx/www/jeedom/core/api/jeeApi.php on line 142" while reading response header from upstream, client: 192.168.2.41, server: , request: "POST /jeedom/core/api/jeeApi.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "192.168.2.3"
2015/07/21 17:30:03 [error] 2258#0: *3671 FastCGI sent in stderr: "PHP message: PHP Notice: Undefined index: api in /usr/share/nginx/www/jeedom/core/api/jeeApi.php on line 142" while reading response header from upstream, client: 192.168.2.41, server: , request: "POST /jeedom/core/api/jeeApi.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "192.168.2.3"

@+

;)
HP T610 - Jeedom
56 modules Zwave - 32 modules Enocean - 3 modules Edisio - 7 modules Rfxcom - 40 modules Zigbee
Cam : 2 Dafang - 3 Foscam - 3 Wanscam
3 Broadlink - 7 Nuts
5 Amazon Echo - 4 Amazon Echo Dot
5 SqueezeBox - 4 Xiaomi Speaker

Ricardo
Timide
Messages : 227
Inscription : 14 mars 2015, 15:26

Re: [Sujet officiel] SqueezeBox Control

Message par Ricardo » 21 juil. 2015, 17:59

tu as certainement raison ! mais l'adresse 192.168.2.41 correspond exactement à mon serveur LMS et 192.168.2.3 est celle de mon Jeedom. Ce message apparaît en fait lors du chargement du dashboard. Certainement à l'affichage de mes squeeze.

;)
HP T610 - Jeedom
56 modules Zwave - 32 modules Enocean - 3 modules Edisio - 7 modules Rfxcom - 40 modules Zigbee
Cam : 2 Dafang - 3 Foscam - 3 Wanscam
3 Broadlink - 7 Nuts
5 Amazon Echo - 4 Amazon Echo Dot
5 SqueezeBox - 4 Xiaomi Speaker

Ricardo
Timide
Messages : 227
Inscription : 14 mars 2015, 15:26

Re: [Sujet officiel] SqueezeBox Control

Message par Ricardo » 21 juil. 2015, 20:24

Ok je teste le truc.

C'est tout bon la voix fonctionne à nouveau :D

Merci à toi :P
HP T610 - Jeedom
56 modules Zwave - 32 modules Enocean - 3 modules Edisio - 7 modules Rfxcom - 40 modules Zigbee
Cam : 2 Dafang - 3 Foscam - 3 Wanscam
3 Broadlink - 7 Nuts
5 Amazon Echo - 4 Amazon Echo Dot
5 SqueezeBox - 4 Xiaomi Speaker

Avatar de l’utilisateur
Croixamus
Actif
Messages : 521
Inscription : 28 nov. 2014, 15:43
Localisation : 56

Re: [Sujet officiel] SqueezeBox Control

Message par Croixamus » 21 juil. 2015, 22:29

TTS testé avec Max2Play sur un Pi déporté, ca fonctionne
J'ai juste à la fin du message, un petit retour de son (0,5s) quand la squeezelite est en pause.
Pas de retour de son si en arrêt.
Juste pour info sarakha63, j'ai pas d’icône sur mon modèle "Squeezeplayer" (et non pas SqueezePlayer)
...et pas le background_color, désolé :oops:

Version 1.1.4 - 2015-07-19 14:05:36
Rajout icone SqueezePlayer

Cdt,
JEEDOM sur VM Debian avec RFXcom/Téléinfo GCE/raZberry en USB-TTL
Esxi6 avec VM Jeedom / VM MotionEye / VM OpenMediaVault / VM OpenVPN-AS

Avatar de l’utilisateur
Croixamus
Actif
Messages : 521
Inscription : 28 nov. 2014, 15:43
Localisation : 56

Re: [Sujet officiel] SqueezeBox Control

Message par Croixamus » 21 juil. 2015, 22:37

Ok pas de soucis (pas le feu :D ), et merci pour ton travail, c'est top !
JEEDOM sur VM Debian avec RFXcom/Téléinfo GCE/raZberry en USB-TTL
Esxi6 avec VM Jeedom / VM MotionEye / VM OpenMediaVault / VM OpenVPN-AS

Répondre

Revenir vers « [Plugin Officiel] SqueezeBox Control »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité