Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Résolu] Letsencrypt, impasse OVH également

De l'installation à l'utilisation venez discuter de JEEDOM au quotidien
Gouzou
Timide
Messages : 94
Inscription : 17 déc. 2014, 13:00

[Résolu] Letsencrypt, impasse OVH également

Message par Gouzou » 25 mars 2018, 21:05

Bonsoir à tous.

Petit appel à votre expertise à tous, je pense avoir tout retourné jusque là.

J'ai voulu anticiper sur l'expiration de mon certificat sur domaine freeboxos d'une semaine.
Le renouvellement en CLI ne marchant pas (avec en erreur l'histoire du virtual host sur le port 80), j'ai appris pour la faille TLS-SNI-01, mettant le renouvellement impossible sur le dos de mon certificat non renouvelable.

J'ai donc suivi le tuto de domoblog (https://www.domo-blog.fr/securiser-jeed ... ge-http-01) sur la partie Révocation du certificat histoire de forcer la création d'un nouveau certificat plutôt que de le renouveler, (toujours avec freeboxos.fr autant que possible)
Mauvaise idée, jeedom planté, j'ai des messages d'erreur sur la config apache (les fichiers ssl.conf) avec des infos erronées. J'édite les lignes qui font référence à mon ancien certificat, # d'abord, puis suppression, interface Jeedom injoignable, et impossible de relancer apache. Je supprime le contenu de /etc/apache2/sites-available et enable, apache se relance, ainsi que l'interface jeedom, ouf.

Toujours avec le domaine en freeboxos, je relance certbot-auto pour la création d'un nouveau certificat, erreur sur l'hôte port 80, pareil avec la variante webroot qui me donne l'erreur DNS.

Je précise que jeedom est joignable de l'exterieur avec freeboxos sur les 80 et 443 (en non sécurisé bien sur)

Je me décide à suivre le tuto jusqu'au bout à la suite d'un achat de nom de domaine sur ovh, en mettant tout sur le domaine en freeboxos, et même avec les nouveaux elements, je me heurte aux mêmes erreurs.
je repeuple /etc/apache2/sites-available et enable avec les backups, apache plante, et avec les .conf nettoyés aussi.

Code : Tout sélectionner

root@JeedomVm:/etc# systemctl status apache2.service
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
  Drop-In: /lib/systemd/system/apache2.service.d
           └─forking.conf
   Active: failed (Result: exit-code) since dim. 2018-03-25 20:10:02 CEST; 4s ago
  Process: 113332 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
  Process: 114106 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

mars 25 20:10:02 JeedomVm apache2[114106]: Starting web server: apache2 failed!
mars 25 20:10:02 JeedomVm apache2[114106]: The apache2 configtest failed. ......
mars 25 20:10:02 JeedomVm apache2[114106]: Output of config test was:
mars 25 20:10:02 JeedomVm apache2[114106]: AH00526: Syntax error on line 8 o...:
mars 25 20:10:02 JeedomVm apache2[114106]: SSLCertificateFile: file '/etc/le...y
mars 25 20:10:02 JeedomVm apache2[114106]: Action 'configtest' failed.
mars 25 20:10:02 JeedomVm apache2[114106]: The Apache error log may have mor....
mars 25 20:10:02 JeedomVm systemd[1]: apache2.service: control process exit...=1
mars 25 20:10:02 JeedomVm systemd[1]: Failed to start LSB: Apache2 web server.
mars 25 20:10:02 JeedomVm systemd[1]: Unit apache2.service entered failed state.
J'ai à nouveau effacé le contenu de /etc/apache2/sites-available et enable pour pouvoir relancer apache, et utiliser Jeedom, la maison est déjà utilisable, hormis via les commandes Telegram et IFTTT.

On en vient aux questions:

En plus de la procédure de révocation du tuto, y a-t-il le moyen de nettoyer proprement apache? Une réinstallation d'apache va-t-elle impacter jeedom?

Quelqu'un aurait-il 1 minute pour m'expliquer pourquoi letsencrypt bloquerai avec les domaines freeboxos (hormis si c'est la limite des 20 nouveaux certificats par jour...). Pas que je sois à une adresse OVH près, mais j'aime les systèmes le plus simple possible, et rajouter une strate OVH avant d'atteindre Jeedom me chagrine.

Et si vous avez des fichiers config vierges des répertoire /etc/apache2/sites-available et enable , et que vous pensez que ça peut débloquer le truc...

Merci d'avance
Dernière édition par Gouzou le 29 mars 2018, 22:16, édité 1 fois.

znation
Actif
Messages : 1951
Inscription : 12 nov. 2014, 15:48

Re: Letsencrypt, impasse OVH également

Message par znation » 26 mars 2018, 08:31

Reinstaller apache, mauvaise idée (je l'ai fait jeedom etait complement inaccessible).

Moi aussi j'ai énormément pédalé avec les fichiers de config apache qui m'ont foutu la merde. je suis pas assez expert pour t'aider la dessus.

Oublies freeboxos ca ne marche pas comme leur adresse redirige obligatoirement vers le port 443 (et donc le renouvellement sur le port 80 échoue).

Donc la case OVH (ou autre) est obligatoire.
JEEDOM v3.3.31 - NUC Z83 II

Gouzou
Timide
Messages : 94
Inscription : 17 déc. 2014, 13:00

Re: Letsencrypt, impasse OVH également

Message par Gouzou » 26 mars 2018, 09:23

J'ai du mal à comprendre le coup de la redirection impérative sur le port 443 vu que j'accède à jeedom également sur le 80 avec freeboxos.

Le pire est que j'ai les mêmes soucis avec le nom de domaine en .ovh et en .fr ...

znation
Actif
Messages : 1951
Inscription : 12 nov. 2014, 15:48

Re: Letsencrypt, impasse OVH également

Message par znation » 26 mars 2018, 09:30

Ton apache doit etre à la rue ...
JEEDOM v3.3.31 - NUC Z83 II

Gouzou
Timide
Messages : 94
Inscription : 17 déc. 2014, 13:00

Re: Letsencrypt, impasse OVH également

Message par Gouzou » 26 mars 2018, 09:37

znation a écrit :
26 mars 2018, 09:30
Ton apache doit etre à la rue ...
Je sais, je sais, mais mes compétences le sont aussi pour m'en sortir sur ce coup!

Avatar de l’utilisateur
kerdale
Actif
Messages : 1644
Inscription : 25 sept. 2016, 11:38
Localisation : Penn-ar-Bed

Re: Letsencrypt, impasse OVH également

Message par kerdale » 26 mars 2018, 10:23

Pas assez expert pour aider mais Juste une info sur ma config person:
j'ai suivit pas à pas
Un nom de domaine gratuit de chez https://freedns.afraid.org
mise en place de l'enregistrement type AAAAA (j'ai une adresse IpV6 fixe, mais ça marche de la même façon avec un enregistrement type A Ipv4 fixe)
Installation du certificat telle que décrite (nouveau challenge) avec cerbot et juste pour cette première installation ouverture du port 80 vers Jeedom
(pour que le test de letsencrypt aboutisse)
Fermeture du port 80 après la fin de l'installation du certificat
(réponse 1 (non) à la question de redirection automatiques des requêtes HTTP vers HTTPS.)
Sur le routeur ouverture du port 443 vers ip interne Jeedom.
Le renouvellement auto se fait par commande sshcommander avec cron tous les deux mois:

Code : Tout sélectionner

/etc/./certbot-auto renew --force-renew && /etc/init.d/apache2 restart
c'est tout. Aucun pb de renouvellement (un mémo me rappelle de tester la validité du certif après le renouvellement auto)
C'est tout
1 NUC & 1 RPI3/Msata V3.3.31, EnOcean, Z-wave,
Rflink, IPX800V3, carte 8 rl IP, IR_V3, Xiaomi gateway, JPI/APK/tel Android dédié, Somfy RTS, Rf433Mhz, Xiaomi, Bm280 , Broadlink,WifiLights

Gouzou
Timide
Messages : 94
Inscription : 17 déc. 2014, 13:00

Re: Letsencrypt, impasse OVH également

Message par Gouzou » 26 mars 2018, 11:31

Bonjour kerdale.

De mon coté l'inscription DNS est bonne en IPv4, même avec les deux ports ouverts vers Jeedom j'ai l’échec avec le host sur le port 80

Code : Tout sélectionner

root@JeedomVm:/etc# ./certbot-auto --apache -d xxxxx.fr                         
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for xxxxx.fr
Cleaning up challenges
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

znation
Actif
Messages : 1951
Inscription : 12 nov. 2014, 15:48

Re: Letsencrypt, impasse OVH également

Message par znation » 26 mars 2018, 11:50

C'est sur c'est ton ta conf apache qui est bancale avec les virtual hosts.
JEEDOM v3.3.31 - NUC Z83 II

Avatar de l’utilisateur
poluket
Helper
Messages : 1908
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Letsencrypt, impasse OVH également

Message par poluket » 26 mars 2018, 13:06

bon, comme tu as déjà acheter le ovh, tu as aussi cette solution:
letsencrypt dns-01 OVH - créer un certificat sans devoir ouvrir Jeedom sur internet
plus de problème de port pour renouveler le certificat.

donne nous une copie de ton fichier. on pourra te dire ce qui sert a rien. de mémoire, ce qui est ajouté avec letsencrypt, c'est le lien vers les fichiers pour le certificat. le reste peut rester.
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

Gouzou
Timide
Messages : 94
Inscription : 17 déc. 2014, 13:00

Re: Letsencrypt, impasse OVH également

Message par Gouzou » 26 mars 2018, 14:00

Salut poluket, merci pour le lien, je jeterai un coup d'oeil à ça si jamais

pour les fichiers, voila 000-default.conf et 000-default-le-ssl.conf

Code : Tout sélectionner

000-default.conf

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

	<Directory /var/www/html>
        	Options FollowSymLinks
	</Directory>
        ErrorLog /var/www/html/log/http.error
RewriteEngine on
RewriteCond %{SERVER_NAME} =xxxxxxxxx.fr
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
[\code]

et le 000-default-le-ssl.conf

[code]
<IfModule mod_ssl.c>
<VirtualHost *:443>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ErrorLog /var/www/html/log/http.error
Include /etc/letsencrypt/options-ssl-apache.conf
#ServerName xxxxxxx.fr
#SSLCertificateFile /etc/letsencrypt/live/xxxxxxxx.fr/fullchain.pem
#SSLCertificateKeyFile /etc/letsencrypt/live/xxxxxxxxx.fr/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost>
</IfModule>
J'avais déjà commenté quelques lignes, essayé de les effacer, impossible de relancer apache après. pour l'instant /etc/apache2/sites-available et enabled sont vides.

les repertoires /ect/letsencrypt/live, archive et renewal sont vides, et j'ai 56 fichiers certbot dans csr et keys (de type 00XX_csr-certbot.pem et 00XX_key-certbot.pem)

Avatar de l’utilisateur
poluket
Helper
Messages : 1908
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Letsencrypt, impasse OVH également

Message par poluket » 26 mars 2018, 15:42

peux tu mettre ce qu'il y a dans /etc/letsencrypt/options-ssl-apache.conf

tu peux en desactiver une des 2 lignes. :)

Merci,
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

Gouzou
Timide
Messages : 94
Inscription : 17 déc. 2014, 13:00

Re: Letsencrypt, impasse OVH également

Message par Gouzou » 26 mars 2018, 16:09

Merci poluket pour ton temps!

Voila pour le option-ssl-apache.conf

Code : Tout sélectionner

# This file contains important security parameters. If you modify this file
# manually, Certbot will be unable to automatically provide future security
# updates. Instead, Certbot will print and log an error message with a path to
# the up-to-date file that you will need to refer to when manually updating
# this file.

SSLEngine on

# Intermediate configuration, tweak to your needs
SSLProtocol             all -SSLv2 -SSLv3
SSLCipherSuite          ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES256-SHA:ECDHE-ECDSA-DES-CBC3-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:DES-CBC3-SHA:!DSS
SSLHonorCipherOrder     on
SSLCompression          off

SSLOptions +StrictRequire

# Add vhost name to log entries:
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-agent}i\"" vhost_combined
LogFormat "%v %h %l %u %t \"%r\" %>s %b" vhost_common

#CustomLog /var/log/apache2/access.log vhost_combined
#LogLevel warn
#ErrorLog /var/log/apache2/error.log

# Always ensure Cookies have "Secure" set (JAH 2012/1)
#Header edit Set-Cookie (?i)^(.*)(;\s*secure)??((\s*;)?(.*)) "$1; Secure$3$4"
Pour la ligne à désactiver je vais tenter pile ou face! J'efface celles qui font référence au nom de domaine?

De plus j'ai tous les symlinks qui ont disparu de /etc/apache/sites-enabled, le fait de les recréer suffira?

Avatar de l’utilisateur
poluket
Helper
Messages : 1908
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Letsencrypt, impasse OVH également

Message par poluket » 27 mars 2018, 09:25

essaye une fois de relancer ta generation de certificat mais avant, disable (#) la ligne ci dessous dans le fichier 000-default.conf.

Code : Tout sélectionner

RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
elle sert a faire une redirection sur le port 443 que letsencrypt ne supporte pas a mon avis.

et si apache ne redémarre pas essaye en desactivant les 3 lignes:

Code : Tout sélectionner

RewriteEngine on
RewriteCond %{SERVER_NAME} =xxxxxxxxx.fr
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

Gouzou
Timide
Messages : 94
Inscription : 17 déc. 2014, 13:00

Re: Letsencrypt, impasse OVH également

Message par Gouzou » 27 mars 2018, 17:50

Rentré du boulot, je me colle à jeedom

fichiers modifiés comme conseillé, interface jeedom injoignable, httpd ne se lance toujjours pas (mais apache ne me donne pas de message lors du restart)

Code : Tout sélectionner

root@JeedomVm:/etc# ./certbot-auto --apache -d xxxxxxx.fr
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for xxxxx.fr
Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.


Cleaning up challenges
Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.

Encountered exception during recovery
Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.

Traceback (most recent call last):
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/error_handler.py", line 100, in _call_registered
    self.funcs[-1]()
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/auth_handler.py", line 303, in _cleanup_challenges
    self.auth.cleanup(achalls)
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot_apache/configurator.py", line 2109, in cleanup
    self.restart()
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot_apache/configurator.py", line 1989, in restart
    self._reload()
  File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot_apache/configurator.py", line 2000, in _reload
    raise errors.MisconfigurationError(str(err))
MisconfigurationError: Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.

Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.
les fichiers sont configurés comme suit:

000-default.conf

Code : Tout sélectionner

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

	<Directory /var/www/html>
        	Options FollowSymLinks
	</Directory>
        ErrorLog /var/www/html/log/http.error
#RewriteEngine on
#RewriteCond %{SERVER_NAME} =xxxxx.fr
#RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
000-default-se-ssl

Code : Tout sélectionner

<IfModule mod_ssl.c>
<VirtualHost *:443>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ErrorLog /var/www/html/log/http.error
Include /etc/letsencrypt/options-ssl-apache.conf
#ServerName xxxx.fr
#SSLCertificateFile /etc/letsencrypt/live/xxxxx.fr/fullchain.pem
#SSLCertificateKeyFile /etc/letsencrypt/live/xxxxx.fr/privkey.pem
</VirtualHost>
</IfModule>
le apache error log me donne une vingtaine de ligne de ce genre ci:
[Tue Mar 27 17:34:02.317880 2018] [ssl:warn] [pid 30911] AH01909: xxxxxx.fr:443:0 server certificate does NOT include an ID which matches the server name

Tout les changements ont été fait pour pointer vers le nouveau serveur (cf tuto au premier post)

Le apachectl configtest me dit OK

Je vais me chercher un valium...

Avatar de l’utilisateur
poluket
Helper
Messages : 1908
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Letsencrypt, impasse OVH également

Message par poluket » 27 mars 2018, 18:27

dans le 000-default-se-ssl, laisse les certificats, si tu n'en a pas fourni, la partie SSL ne sait pas démarrer. et si apache démarre, tu peux lance de nouveau ton job pour generer le nv certificat


je te donne ma config:

000-default.conf:

Code : Tout sélectionner

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ErrorLog /var/www/html/log/http.error
</VirtualHost>
default-ssl.conf:

Code : Tout sélectionner

<IfModule mod_ssl.c>
        <VirtualHost _default_:443>
                ServerAdmin webmaster@localhost
                ServerName jeedom.XXxxXXXx.ovh:443
                DocumentRoot /var/www/html

                ErrorLog ${APACHE_LOG_DIR}/error.log
                CustomLog ${APACHE_LOG_DIR}/access.log combined

                SSLEngine on

                SSLCertificateFile      /etc/letsencrypt/live/jeedom.XXxxXXXx.ovh/fullchain.pem
                SSLCertificateKeyFile /etc/letsencrypt/live/jeedom.XXxxXXXx.ovh/privkey.pem

                <FilesMatch "\.(cgi|shtml|phtml|php)$">
                                SSLOptions +StdEnvVars
                </FilesMatch>
                <Directory /usr/lib/cgi-bin>
                                SSLOptions +StdEnvVars
                </Directory>


        </VirtualHost>
</IfModule>
ports.conf

Code : Tout sélectionner

Listen 80

<IfModule ssl_module>
        Listen 443
</IfModule>

<IfModule mod_gnutls.c>
        Listen 443
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
attention que j'ai fait différemment pour créer mon certificat letsencrypt. je suis passé par la méthode DNS et dons je n'ai pas utilisé l'option apache dans le script
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

Gouzou
Timide
Messages : 94
Inscription : 17 déc. 2014, 13:00

Re: Letsencrypt, impasse OVH également

Message par Gouzou » 27 mars 2018, 23:30

Le soucis c'est que les certificats ayant été révoquées, et nettoyés, je n'ai plus rien dans /etc/letsencript/live...

Le seul moyen de démarrer apache est de supprimer le contenu de /etc/apache2/sites-available

Impossible de lancer certbot-auto, je me heurte toujours à ce message:

Code : Tout sélectionner

http-01 challenge for xxxxx.fr
Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.


Cleaning up challenges
Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
The Apache error log may have more information.


Encountered exception during recovery
Error while running apache2ctl graceful.
httpd not running, trying to start
Action 'graceful' failed.
SI je supprime complètement le contenu de /etc/apache2/sites-available et enable, apache se lance, mais je me heurte à l'erreur:
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

c'est un peu penible qu'il soit impossible de récupérer les fichiers conf par default de apache, chaque install de certificat s'inscrit en dur dans les fichiers apache?...

Avatar de l’utilisateur
poluket
Helper
Messages : 1908
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Letsencrypt, impasse OVH également

Message par poluket » 28 mars 2018, 09:38

essaye en supprimant tout comme tu as fait et crée le fichier 000-default.conf a partir du mien.
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

fred59190
Timide
Messages : 261
Inscription : 26 janv. 2016, 10:13

Re: Letsencrypt, impasse OVH également

Message par fred59190 » 29 mars 2018, 12:43

bonjour
je galere aussi
du coup je viens de commander un .ovh et je vire freeboxos.fr
cependant je me posais la question si il falait éditer partout genre iftt etc..
remplacer domaine.freeboxos.fr par domaine.ovh
si oui c'est un boulot de malade

Avatar de l’utilisateur
poluket
Helper
Messages : 1908
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Letsencrypt, impasse OVH également

Message par poluket » 29 mars 2018, 13:54

tout dépend comment fonctionne ces sites. pour éviter les problèmes, je te conseil de faire un alias (cname) de ton .ovh vers freeboxos.fr. cela devrait marcher et tous tes services existants devraient continuer a fonctionner :).
faut voir aussi si les sites extérieurs vont accepter un certificat OVH pour un host freeboxos.fr. A tester...
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

znation
Actif
Messages : 1951
Inscription : 12 nov. 2014, 15:48

Re: Letsencrypt, impasse OVH également

Message par znation » 29 mars 2018, 13:58

ovh je suis pas contre mais bon si c'est 'juste' pour avoir un certificat valide sans payer et que vous voulez pas à tout prix un .fr ou .com alors afraid.org est votre ami, des milliers de nom de domaines dispo !

... qui fonctionne sans soucis pour les certificats OVH.
JEEDOM v3.3.31 - NUC Z83 II

Répondre

Revenir vers « Utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités