Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Résolu] Migration Jeedom docker d'un NAS à l'autre - pb réseau

De l'installation à l'utilisation venez discuter de JEEDOM au quotidien
dragonslore
Timide
Messages : 49
Inscription : 20 mai 2017, 14:15

[Résolu] Migration Jeedom docker d'un NAS à l'autre - pb réseau

Message par dragonslore » 15 déc. 2019, 17:43

Bonsoir à tous :)

Je change de NAS Synology, je passe d'un 1812+ à un 1819+.
J'ai exporté / importé mes conteneurs Docker vers le nouveau NAS, toujours en mode bridge.
Jeedom est OK, Abeille avec ma Zigate OK, mais j'ai un problème avec le Zwave visiblement du à la configuration réseau.

Code : Tout sélectionner

[2019-12-15 17:40:02][INFO] : Lancement démon openzwave : /usr/bin/python /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py  --device auto --loglevel debug --port 9081 --config_folder /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/config --data_folder /var/www/html/plugins/openzwave/core/class/../../data --callback http://127.0.0.1:8080/plugins/openzwave/core/php/jeeZwave.php --apikey fJAenDR5OWgCwM96O477UpFwuaOSC3wBFwgwOWlfN93s3q7V --suppressRefresh 0 --cycle 0.3 --pid /tmp/jeedom/openzwave/deamon.pid
[2019-12-15 16:40:03][INFO] : Start openzwaved
[2019-12-15 16:40:03][INFO] : Log level : debug
[2019-12-15 16:40:03][DEBUG] : PID file : /tmp/jeedom/openzwave/deamon.pid
[2019-12-15 16:40:03][INFO] : Device : auto
[2019-12-15 16:40:03][DEBUG] : Apikey : fJAenDR5OWgCwM96O477UpFwuaOSC3wBFwgwOWlfN93s3q7V
[2019-12-15 16:40:03][INFO] : Callback : http://127.0.0.1:8080/plugins/openzwave/core/php/jeeZwave.php
[2019-12-15 16:40:03][INFO] : Cycle : 0.3
[2019-12-15 16:40:03][DEBUG] : Initial disabled nodes list: []
[2019-12-15 16:40:03][DEBUG] : Init request module v2.12.4
[2019-12-15 16:40:03][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2019-12-15 16:40:03][ERROR] : Callback result as a unknown error: HTTPConnectionPool(host='127.0.0.1', port=8080): Max retries exceeded with url: /plugins/openzwave/core/php/jeeZwave.php?apikey=fJAenDR5OWgCwM96O477UpFwuaOSC3wBFwgwOWlfN93s3q7V (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7fbe608db890>: Failed to establish a new connection: [Errno 111] Connection refused',)). Please check your network configuration page
[2019-12-15 16:40:03][ERROR] : Network communication issues. Please fixe your Jeedom network configuration.
[2019-12-15 17:40:32][ERROR] : Impossible de lancer le démon openzwave, relancer le démon en debug et vérifiez la log
Voici la configuration telle qu'elle était sur mon ancien NAS
2019-11-16_10h03_04.png
2019-11-16_10h03_04.png (82.88 Kio) Consulté 268 fois
Voilà comment elle apparait sur le nouveau
2019-12-15_17h38_50.png
2019-12-15_17h38_50.png (87.15 Kio) Consulté 268 fois
J'ai deux lignes étranges:
sit0@NONE
eth0@if12

Si je fais un nstat voilà ce que j'ai
2019-12-15_17h40_17.png
2019-12-15_17h40_17.png (15.54 Kio) Consulté 268 fois
Avez-vous une idée de comment régler tout ça ?

Merci beaucoup :D
Manu
Dernière édition par dragonslore le 18 déc. 2019, 00:26, édité 1 fois.
Manu
Jeedom 4.0.27/Debian 9 Docker sur Synology 1812+
Snips 0.64.0/Raspbian 9
Zwave+ et Zigbee

Avatar de l’utilisateur
PrFalKeN
Actif
Messages : 936
Inscription : 27 nov. 2017, 18:51

Re: Migration Jeedom docker d'un NAS à l'autre - pb réseau

Message par PrFalKeN » 15 déc. 2019, 17:49

Quelle IP utilises-tu pour accéder à Jeedom ? (depuis ton PC)

Car avoir dans la configuration interne jeedom en ip la 127.0.0.1 qui est une adresse particulière puisque c'est l'adresse de loopback, cela ne me partait pas correcte.

De plus le log te dis bien de vérifier la config réseau !

dragonslore
Timide
Messages : 49
Inscription : 20 mai 2017, 14:15

Re: Migration Jeedom docker d'un NAS à l'autre - pb réseau

Message par dragonslore » 15 déc. 2019, 17:52

Oui j'ai bien vérifié la configuration réseau j'ai essayé ce que j'ai pu.
Sur le réseau c'est 192.168.1.2 (ip de mon NAS) sur le port 9081.
Mais Jeedom est dans un container docker.
Dans les logs ont dirait qu'il me garde toujours 127.0.0.1 quoi que je change dans la config.

Quand je fais un ifconfig depuis mon container docker je vois que l'ip ETH0 est 172.17.0.3.
2019-12-15_19h28_23.png
2019-12-15_19h28_23.png (40.93 Kio) Consulté 243 fois
C'est cette IP que je dois utiliser j'imagine mais elle n'apparait pas dans la config ETH0 sous jeedom, comment la forcer ?
2019-12-15_19h28_56.png
2019-12-15_19h28_56.png (11 Kio) Consulté 243 fois
Manu
Jeedom 4.0.27/Debian 9 Docker sur Synology 1812+
Snips 0.64.0/Raspbian 9
Zwave+ et Zigbee

dragonslore
Timide
Messages : 49
Inscription : 20 mai 2017, 14:15

Re: Migration Jeedom docker d'un NAS à l'autre - pb réseau

Message par dragonslore » 15 déc. 2019, 23:23

Je m’en sors, c’est lié à la configuration Apache2, virtual hosts etc…
Par contre mon soucis c’est que je peux changer la configuration apache mais dès que je redémarre mon conteneur, mes changements disparaissent, avez-vous une idée ?
Manu
Jeedom 4.0.27/Debian 9 Docker sur Synology 1812+
Snips 0.64.0/Raspbian 9
Zwave+ et Zigbee

dragonslore
Timide
Messages : 49
Inscription : 20 mai 2017, 14:15

Re: Migration Jeedom docker d'un NAS à l'autre - pb réseau

Message par dragonslore » 18 déc. 2019, 00:26

J'ai compris...le fichier /root/init.sh comprend des instructions pour regénérer dynamiquement la configuration Apache entre autre. Je l'ai modifié quelque peu pour qu'il ne pénalise pas mon installation (HTTPS...)
Manu
Jeedom 4.0.27/Debian 9 Docker sur Synology 1812+
Snips 0.64.0/Raspbian 9
Zwave+ et Zigbee

Répondre

Revenir vers « Utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités