Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

Zwave voisins en NOK

Retrouvez ici des sujets concernant le protocole Z-Wave et les modules domotiques de type Z-Wave utilisés avec JEEDOM
fab_93
Timide
Messages : 60
Inscription : 19 juil. 2015, 10:36
Localisation : Rosny sous bois

Zwave voisins en NOK

Message par fab_93 » 16 oct. 2018, 16:55

Bonjour,

après un reboot, pratiquement tous mes modules sous Zwave n'arrive pas à se connecter au voisin qui est en NOK.

j'ai rebooté, relancé les dépendances, soigner le réseau , recharger une ancienne sauvegarde etc ...

je ne sais plus quoi faire , mon syteme aquaponie, alarme et aquarium est HS maintenant :(

Merci pour votre aide
Pièces jointes
jeedom.JPG
jeedom.JPG (113.23 Kio) Consulté 1730 fois
Brix GB-BXBT-J1900 / 8Go /SSD 120 Go
Virtualisé avec PROMOX
Zwave(Z-WAVE.ME - Mini contrôleur USB Z-Wave Plus) RFXcom (Interface RFXtrx433E USB)
Jeedom Version : Stable

BLRPERES
Actif
Messages : 1118
Inscription : 31 août 2016, 10:51
Localisation : Bourg-La-Reine

Re: Zwave voisins en NOK

Message par BLRPERES » 16 oct. 2018, 19:14

Est-ce que les piles sont mortes ?!


Envoyé de mon iPhone en utilisant Tapatalk

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Zwave voisins en NOK

Message par Bosquetia » 16 oct. 2018, 20:05

..........
Dernière édition par Bosquetia le 19 oct. 2018, 09:04, édité 1 fois.

fab_93
Timide
Messages : 60
Inscription : 19 juil. 2015, 10:36
Localisation : Rosny sous bois

Re: Zwave voisins en NOK

Message par fab_93 » 16 oct. 2018, 22:00

merci , non je n'ai pas de pile, je ferai la manip de la clé demain et je vous tiens au courant.
bonne nuit
Brix GB-BXBT-J1900 / 8Go /SSD 120 Go
Virtualisé avec PROMOX
Zwave(Z-WAVE.ME - Mini contrôleur USB Z-Wave Plus) RFXcom (Interface RFXtrx433E USB)
Jeedom Version : Stable

fab_93
Timide
Messages : 60
Inscription : 19 juil. 2015, 10:36
Localisation : Rosny sous bois

Re: Zwave voisins en NOK

Message par fab_93 » 17 oct. 2018, 17:41

j'ai laissé cette nuit ma jeedom eteinte et j'ai enlevé la clé zwave . c'est toujours pareil.
je ne vois rien dans les logs.
il te faut quoi comme logs ?
merci
Pièces jointes
Capture2.JPG
Capture2.JPG (126.65 Kio) Consulté 1686 fois
Brix GB-BXBT-J1900 / 8Go /SSD 120 Go
Virtualisé avec PROMOX
Zwave(Z-WAVE.ME - Mini contrôleur USB Z-Wave Plus) RFXcom (Interface RFXtrx433E USB)
Jeedom Version : Stable

fab_93
Timide
Messages : 60
Inscription : 19 juil. 2015, 10:36
Localisation : Rosny sous bois

Re: Zwave voisins en NOK

Message par fab_93 » 17 oct. 2018, 21:55

voici les logs en mode debug, y a pas mal de chose
Pièces jointes
openzwaved.txt
(413.09 Kio) Téléchargé 27 fois
Brix GB-BXBT-J1900 / 8Go /SSD 120 Go
Virtualisé avec PROMOX
Zwave(Z-WAVE.ME - Mini contrôleur USB Z-Wave Plus) RFXcom (Interface RFXtrx433E USB)
Jeedom Version : Stable

fab_93
Timide
Messages : 60
Inscription : 19 juil. 2015, 10:36
Localisation : Rosny sous bois

Re: Zwave voisins en NOK

Message par fab_93 » 21 oct. 2018, 14:35

je suis toujours embête, j'ai essayé de coupé électricité et c'est encore pire.
je ne sais plus quoi faire , le chauffage ne fonctionne plus comme les modules ne communiquent pas :(


logs de openzawed
2018-10-21 14:27:12.530 Info, Node007, Sending (Send) message (Callback ID=0xa7, Expected Reply=0x04) - SwitchBinaryCmd_Get (Node=7): 0x01, 0x09, 0x00, 0x13, 0x07, 0x02, 0x25, 0x02, 0x25, 0xa7, 0x45
2018-10-21 14:27:13.531 Error, Node007, ERROR: Dropping command, expected response not received after 1 attempt(s)
2018-10-21 14:27:13.531 Detail, Node007, Removing current message
2018-10-21 14:27:13.531 Detail, Node007, Notification: Notification - TimeOut
2018-10-21 14:27:30.106 Detail, Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2018-10-21 14:27:30.106 Detail, ZW_SEND_DATA delivered to Z-Wave stack
2018-10-21 14:27:30.125 Detail, CAN received...triggering resend
2018-10-21 14:27:30.125 Warning, m_currentMsg was NULL when trying to set MaxSendAttempts
Pièces jointes
jeedom.JPG
jeedom.JPG (61.61 Kio) Consulté 1650 fois
Brix GB-BXBT-J1900 / 8Go /SSD 120 Go
Virtualisé avec PROMOX
Zwave(Z-WAVE.ME - Mini contrôleur USB Z-Wave Plus) RFXcom (Interface RFXtrx433E USB)
Jeedom Version : Stable

Pinson99
Timide
Messages : 53
Inscription : 13 sept. 2018, 10:23
Localisation : Bruxelles

Re: Zwave voisins en NOK

Message par Pinson99 » 21 oct. 2018, 16:24

Bonjour,
Je suis intéressé par la solution à ton problème parce que c'est aussi le mien depuis une semaine...
C'est arrivé après un plantage du Zwave, suite à une inclusion foireuse de modules Wall Plug. J'ai restauré une version Zwave d'avant cette inclusion et c'est là que le contrôleur principal a été signalé NOK.
Pourtant, tous les modules avaient leurs voisins mais le contrôleur principal (box smart) n'en n'avait pas et était signalé NOK car inclus dans aucun groupe.
J'ai alors régénéré la détection de ce nœud et maintenant, plus aucun module n'a de voisin ...

Nb: Chaque action est très difficile, voire impossible car cela ne fait qu'allonger la queue sortante.
Pinson99

fab_93
Timide
Messages : 60
Inscription : 19 juil. 2015, 10:36
Localisation : Rosny sous bois

Re: Zwave voisins en NOK

Message par fab_93 » 21 oct. 2018, 18:56

bonsoir,
après avoir essayé pas mal de chose, j'ai enlevé des modules qui étaient hs de mon jeedom Zwave et que j'avais gardé en mémoire. Après cela, cela à l'air de fonctionner.j'ai vu que c’était dû au matériel car comme j'ai un système virtualisé j'ai pris une ancienne sauvegarde qui avait le même problème.

essaye d'enlever ton module qui à planté ton système.
comme l'inclusion est dans le hard du contrôleur cela ne sert a rien de revenir sur une ancienne sauvegarde de jeedom
bon courage
Brix GB-BXBT-J1900 / 8Go /SSD 120 Go
Virtualisé avec PROMOX
Zwave(Z-WAVE.ME - Mini contrôleur USB Z-Wave Plus) RFXcom (Interface RFXtrx433E USB)
Jeedom Version : Stable

Pinson99
Timide
Messages : 53
Inscription : 13 sept. 2018, 10:23
Localisation : Bruxelles

Re: Zwave voisins en NOK

Message par Pinson99 » 21 oct. 2018, 23:11

le hic est que celui qui plante actuellement est le contrôleur principal ...
Les autres modules ont retrouvé leurs voisins depuis mon post mais le contrôleur principal, n'en n'a toujours aucun.
Comme prévu, je ne peux plus ni exclure ni inclure aucun nœud du réseau Zwave.
Pinson99

fab_93
Timide
Messages : 60
Inscription : 19 juil. 2015, 10:36
Localisation : Rosny sous bois

Re: Zwave voisins en NOK

Message par fab_93 » 22 oct. 2018, 21:17

essaye de débrancher ton contrôleur une nuit et de le remettre
Brix GB-BXBT-J1900 / 8Go /SSD 120 Go
Virtualisé avec PROMOX
Zwave(Z-WAVE.ME - Mini contrôleur USB Z-Wave Plus) RFXcom (Interface RFXtrx433E USB)
Jeedom Version : Stable

Philippe77
Timide
Messages : 25
Inscription : 02 févr. 2019, 14:21

Re: Zwave voisins en NOK

Message par Philippe77 » 05 févr. 2019, 20:49

Bonjour, petit nouveau sous jeedom et dans le monde de la domotique...
J'ai un raspberry Pi 3 avec la version Raspbian GNU/Linux 9.6 (stretch)
J'ai une carte RaZberry pour le protocol z-wave
J'ai acheté un thermostat euretronic spirit (le but est de gérer via domotique mon chauffage)
Mais impossible de faire une inclusion, rien ne se passe (pile neuves sur le thermostat)
La seule "erreur" est au niveau des nœud ou les nœud voisin sont NOK
j'avais bien un swap avec0% de dispo mais j'ai modifié la valeur du swap à 1024 (dans le fichier /etc/dphys-swapfile jai mis le "conf-swapsize=1024) et le swapiness à 10 %, (dans /etc/sysctl.conf j'ai ajouté vm.swappiness=10) : depuis le swap est Ok

J'ai mis les copies d'écran concernant :
Installation de jeedom : OK
installation z-wave : OK
Noeud voisin : NOK


j'ai essayer de réparer les nœuds sans succès, de les supprimer... sans plus de succès.
j'ai regardé sur les forum et les différents guides d'installation, mais rien trouvé de probant.
Si quelqu'un a une solution je serais super content.. car je ne vois pas comment résoudre le problème


ps :
Les log peuvent sembler petit mais en fait j'ai réinstallé complètement plusieurs fois le system (en corrigeant a chaque fois les pbmes rencontrés)

log openzwave
[2019-02-02 22:55:48][ERROR] : Le noeud [Aucun][1 RaZberry Controller 2016 ZWave+] (1) est présumé mort
[2019-02-02 22:55:58][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:56:53][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:56:53][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:57:23][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:57:23][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:58:19][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:58:19][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:59:00][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:59:00][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:59:29][ERROR] : RequestHandler Unknow node id 1
[2019-02-02 22:59:29][ERROR] : RequestHandler Unknow node id 1
[2019-02-03 14:30:04][ERROR] : CreateNewPrimary. (NotSecondary)
[2019-02-03 14:30:07][ERROR] : CreateNewPrimary. (NotSecondary)
[2019-02-03 14:37:49][ERROR] : CreateNewPrimary. (NotSecondary)



Log d'openzwaved :
2019-02-03 20:39:17.316 Always, OpenZwave Version 1.4.0 Starting Up
2019-02-05 20:13:36.978 Always, ***************************************************************************
2019-02-05 20:13:36.980 Always, ********************* Cumulative Network Statistics *********************
2019-02-05 20:13:36.981 Always, *** General
2019-02-05 20:13:36.981 Always, Driver run time: . . . 1 days, 23 hours, 34 minutes
2019-02-05 20:13:36.981 Always, Frames processed: . . . . . . . . . . . . . . . . . . . . 31
2019-02-05 20:13:36.981 Always, Total messages successfully received: . . . . . . . . . . 31
2019-02-05 20:13:36.981 Always, Total Messages successfully sent: . . . . . . . . . . . . 31
2019-02-05 20:13:36.981 Always, ACKs received from controller: . . . . . . . . . . . . . 31
2019-02-05 20:13:36.981 Always, *** Errors
2019-02-05 20:13:36.981 Always, Unsolicited messages received while waiting for ACK: . . 0
2019-02-05 20:13:36.981 Always, Reads aborted due to timeouts: . . . . . . . . . . . . . 0
2019-02-05 20:13:36.981 Always, Bad checksum errors: . . . . . . . . . . . . . . . . . . 0
2019-02-05 20:13:36.981 Always, CANs received from controller: . . . . . . . . . . . . . 0
2019-02-05 20:13:36.981 Always, NAKs received from controller: . . . . . . . . . . . . . 0
2019-02-05 20:13:36.982 Always, Out of frame data flow errors: . . . . . . . . . . . . . 0
2019-02-05 20:13:36.982 Always, Messages retransmitted: . . . . . . . . . . . . . . . . . 0
2019-02-05 20:13:36.982 Always, Messages dropped and not delivered: . . . . . . . . . . . 0
2019-02-05 20:13:36.982 Always, ***************************************************************************
2019-02-05 20:13:40.074 Error, mgr, Manager::GetDriver failed - Home ID 0xda238a58 is unknown
Pièces jointes
erreur noeud.png
erreur noeud.png (15.89 Kio) Consulté 1440 fois
zwave.png
zwave.png (13.96 Kio) Consulté 1440 fois
jeedom.png
jeedom.png (70.44 Kio) Consulté 1440 fois

Philippe77
Timide
Messages : 25
Inscription : 02 févr. 2019, 14:21

Re: Zwave voisins en NOK

Message par Philippe77 » 05 févr. 2019, 20:51

Désolé...manque l'erreur au niveau des nœuds
Pièces jointes
erreur noeud.png
erreur noeud.png (15.89 Kio) Consulté 1439 fois
erreur noeud.png
erreur noeud.png (15.89 Kio) Consulté 1439 fois

Philippe77
Timide
Messages : 25
Inscription : 02 févr. 2019, 14:21

Re: Zwave voisins en NOK

Message par Philippe77 » 12 févr. 2019, 16:50

Bonjour, aucune réponse pour le moment, galérant toujours je suis preneur de vos remarques avec plaisir
Je ne comprend toujours pas pourquoi les nœud voisin sont NOK
Bonne journée

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Zwave voisins en NOK

Message par Bosquetia » 12 févr. 2019, 16:56

Hello

Je n'ai pas trop suivi mais votre controleur zwave est il en mode SUC ?
Car de mémoire Nechry m'avait dit que sinon cela pouvait poser souci
Capture.JPG

Philippe77
Timide
Messages : 25
Inscription : 02 févr. 2019, 14:21

Re: Zwave voisins en NOK

Message par Philippe77 » 13 févr. 2019, 12:24

Bonjour Bosquetia,
et merci pour la réponse
mais l'info n'est pas apparente pour moi et cela même si j'ajoute dans
/etc/fail2ban/filter.d/openhab.conf
la ligne
zwave:setSUC=true
mode SUC non present.png
mode SUC non present.png (33.84 Kio) Consulté 1332 fois
conf openhab.conf.png
conf openhab.conf.png (29.27 Kio) Consulté 1332 fois

Philippe77
Timide
Messages : 25
Inscription : 02 févr. 2019, 14:21

Re: Zwave voisins en NOK

Message par Philippe77 » 13 févr. 2019, 17:08

Bonjour,
j'ai bon chercher comment activer le SUC, je ne trouve que des ref au fichier /etc/fail2ban/filter.d/openhab.conf
Avez vous une autre solution pour activer le mode SUC avec une carte zwave raZberry sous jeedom.
Bonne journée

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Zwave voisins en NOK

Message par Bosquetia » 13 févr. 2019, 17:24

Hello

Je ne crois pas que l'on puisse sur ce controleur...
par contre c'est clair qu'il n'y a pas de rapport avec fail2ban...

néanmoins tu es sur raspberry, j'espère que tu as coupé le bluetooth car sinon ta zwave marchera pas

Philippe77
Timide
Messages : 25
Inscription : 02 févr. 2019, 14:21

Re: Zwave voisins en NOK

Message par Philippe77 » 13 févr. 2019, 20:38

Bonsoir,
oui le bluetooth est bien coupé, je ne vois aucun problème sur la configuration a part le problème des nœuds voisin NOK.
J'avais désactivé la gestion du réseau par Jeedom.
Je l'ai réactivé mais cela ne change rien sauf un message d'erreur au niveau des LOG qui me dit
"Configuration réseau externe NOK Allez sur Administration -> Configuration -> Réseaux, puis configurez correctement la partie réseau"
Mais je ne pense pas ce que soit lié car cela concerne le réseaux externe
J'ai déjà réinstallé plusieurs fois, je vais certainement recommencer car à force de tester, modifier, le risque de problème doit augmenter..et donc encore plus galère pour trouver une conf qui soit OK.
la manière dont je procède (enfin de mémoire car à force de tester...). Si tu vois quelques choses qui semble pas bon.... :
- OS réinitialisé
- @ IP fixe, SSh activé
- raspberry arrêté et mise en place physiquement de la carte raZberry
- arrêt du raspberry
- puis installation avec des drivers pour la carte razberry : wget -O - razberry.z.wave.me/install|sudo bash
- aller sur http://@IP:8083 et donner le mot de passe z-wave (crée dans un des premiers test de configuration)
- installation de jeedom wget https://raw.githubertusercontent.com/je ... install.sh
- application des droits : sudo chmod +x install.sh PUIS sudo ./install.sh
- Dans le navigateur lancement de jeedom , paramétrage de la double authentification et changement mot de passe admin
- Dans Jeedom, on rentre les identifiants pour accéder au market jeedom, puis sauvegarde
- et enfin installation du plugin z-wave, on paramètre le port clé Z-wave et on sauvegarde.
Normalement tout est Ok sauf wue j'ai ce problème de voisin NOK qui empêche d'aller plus loin

- Je modifie aussi la taille su swap pour éviter les erreurs
- sudo nano /etc/dphys-swapfile
- on modifie conf-swapsize=100 PAR conf-swapsize=1024
- on arrête puis redémarre le swap : sudo /ect/init.d/dphys-swapfile stop PUIS sudo /ect/init.d/dphys-swapfile start

Philippe77
Timide
Messages : 25
Inscription : 02 févr. 2019, 14:21

Re: Zwave voisins en NOK

Message par Philippe77 » 14 févr. 2019, 16:43

Bonjour,
ca progresse... un peu (description un peu poussée mais si ca peut aider quelqu'un....)
Réinstallation de raspian : OK
activation du SSH : OK
mise en place d'une adresse IP fixe en ethO et Wlan : OK
SSID non configuré
Arret de la machine pour mettre physiquement la carte Raspian
puis installation des drivers :
wget -q -O - http://razberry.z-wave.me/install | sudo bash
puis wget -q -O - support.zwave.eu/libs | sudo bash car j'utilise la version strech)
reboot de la machine : le bluetooth est bien désactivé -)
@IP:8083 : OK
Puis récupération de JEEDOM :
wget https://raw.githubusercontent.com/jeedo ... install.sh
puis modif des droits :
sudo chmod +x install.sh
Installation de jeedom :
sudo ./install.sh
reboot de la machine....
Paramétrage jeedom :
donner un nom à la machine jeedom (roue cranté/général) - on sauvegarde
changer le mot de passe par default (roue cranté/utilisateur - on sauvegarde
activer la double autentification : symbole utilisateur/profil admin/sécurité
Création d'un objet
Installation du plugin zwave
Modification de la taille du swap :
sudo nano /etc/dphys-swapfile et modifier la valeur de conf-swapfile=100 par conf-swapfile=1024
Un petit sudo /etc/init.d/dphys-swapfile restart
définir le swappiness à 10 pourcent
Pour cela ajouter la ligne vm.swappiness=10 au fichier de conf /etc/sysctl.conf
On reboot....
On relance si besoin les demon au niveau du plugin zwave...

j'ai toujours le noeud voisin NOK mais mais maintenant j'ai bien le SUC d'activé !!!!

Moralité...toujours pas d'inclusion possible, la réparation des noeuds (ou mise à jour) ne changeant rien mais j'ai le mode SUC qui est OK


Si quelqu'un à une idée pour continuer à avance -)
Bonne journée

Répondre

Revenir vers « [Plugin Officiel] Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité