Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

RFXCOM se fige depuis la dernière MAJ

Retrouvez ici des sujets concernant le protocole RFXcom et les modules domotiques compatibles RFXcom (Chacon, DI-O, Oregon, Blyss, etc...) utilisés avec JEEDOM
vince_007
Timide
Messages : 60
Inscription : 13 nov. 2016, 10:15

Re: RFXCOM se fige depuis la dernière MAJ

Message par vince_007 » 26 mars 2019, 19:22

Salut,

Je viens donner des nouvelles car ça tourne de façon stable depuis plusieurs jours, j'ai remplacé mon alimentation précédente, une raspberry officielle de 5,1V et 2,5A par une autre officielle de 5V et 2A.

Ça parait bizarre car la nouvelle est moins puissante mais ça fonctionne parfaitement. Je pense que le problème vient de la tension trop élevée, l'alim de 5,1V sort en réalité 5,2V et le rfxcom semble ne pas apprécier.
La nouvelle alim sort 5V pil poil.

Vous pouvez faire l'essai et vérifier si vous avez une alim 5,1 ou 5,2V comme le sont certaines alim récentes.

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: RFXCOM se fige depuis la dernière MAJ

Message par mortyre » 26 mars 2019, 23:09

Je suis sur NAS donc l'alimentation n'est pas un probleme
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

Avatar de l’utilisateur
DuplO
Actif
Messages : 716
Inscription : 17 sept. 2015, 14:04

Re: RFXCOM se fige depuis la dernière MAJ

Message par DuplO » 27 mars 2019, 07:51

Salut Vince007,
Aurais tu la référence de ton alim?
Histoire d acheter la même.

Merci

vince_007
Timide
Messages : 60
Inscription : 13 nov. 2016, 10:15

Re: RFXCOM se fige depuis la dernière MAJ

Message par vince_007 » 27 mars 2019, 08:55

L'alim je l'avais depuis un moment, c'est la blanche Raspberry avec la prise 230V qui s'enlève pour l'adaptation monde.

Avatar de l’utilisateur
DuplO
Actif
Messages : 716
Inscription : 17 sept. 2015, 14:04

Re: RFXCOM se fige depuis la dernière MAJ

Message par DuplO » 27 mars 2019, 09:14

Ok, merci.
Je vais regarder ça

freeman32
Timide
Messages : 428
Inscription : 27 mars 2016, 10:44

Re: RFXCOM se fige depuis la dernière MAJ

Message par freeman32 » 05 avr. 2019, 21:12

moi j'ai un autre problème, j'ai 2 interrupteur DIO un double et un simple je m'en sert pour déclencher un scénario qui m'ouvre une électrovanne et m'active une pompe de boucle ECS pendant une minute et depuis la dernière mise à jour le RFXCOM reçoit bien l'info de l'inter mais le scénario ce lance à retardement et c'est complètement aléatoire certaine fois au bout de 30s d'autre fois 10 minutes et c'est pénible d'attendre l'eau à la douche pendant tout ce temps. j'avais des widgets sur les module Zwave qui pilote les electrovannes et la pompe je les ais enlever pensant que ça venais de la mais ça n'a rien changé je commence à perdre patience !

Voici le scénario en question l'inter est en déclencheur
scenario.png
scenario.png (47.83 Kio) Consulté 998 fois
Gigabyte Brix + Debian 9.9 + Jeedom 3.3.24
UZB Sigma Designs + RFXCom + Ecodevice
8 Sondes Oregon + 1 Consomètre Oregon
Station Météo Netatmo + Pluviomètre + Anémomètre
8 FGRM-222
3 FGS-222
1 Qubino ZMNHJD1
1 Qubino ZMNHBD1

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: RFXCOM se fige depuis la dernière MAJ

Message par Fabrice » 06 avr. 2019, 14:11

Vous perdez patience ?
- En étant hors sujet sur ce fil...
- Sans formule de politesse...
- Sans log...
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

jarnoy
Timide
Messages : 2
Inscription : 23 juin 2018, 21:51

Re: RFXCOM se fige depuis la dernière MAJ

Message par jarnoy » 13 avr. 2019, 14:29

Bonjour,
Exactement le même problème ,

Au bout d'un certain temps je ne recois plus de données des sondes ( oregon et aussi OWL )
Par contre en émission ( volets somfy) tout continue de fonctionner normalement

Le redémarrage du plugin résoud le problèe ....pour un certain temps ....

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: RFXCOM se fige depuis la dernière MAJ

Message par Fabrice » 13 avr. 2019, 21:38

Bonjour,

J'ai :
- 12 prises en RFXCom
- 6 sondes Oregon

Et je n'ai pas ces problèmes.

Regardez ce que dit la documentation de ce plugin sur ce problème. De plus, juste pour "voir", supprimez vos sondes OWL (ôtez les piles) pour voir si vous n'avez pas du spam d'un équipement.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

drs
Actif
Messages : 1534
Inscription : 04 nov. 2016, 10:44

Re: RFXCOM se fige depuis la dernière MAJ

Message par drs » 14 avr. 2019, 18:14

Bonjour

J’ai aussi ce problème (j’en ai déjà parlé ici): à certaines périodes, pendant un temps plus ou moins long, plus de réception (alors que l’émission fonctionne).
Après pas mal de temps passé à chercher, j’en arrive à la conclusion de la cause environnementale : quelqu’un (peut-être radioamateur dans mon entourage me pollue ma réception).
C’est le problème du 433mhz...une bande de fréquence sur-utilisée par tout le monde, et qui n’a rien de fiable.

J’ai basculé mes sondes importantes sur un autre protocole et pour le reste, je fais avec!

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: RFXCOM se fige depuis la dernière MAJ

Message par mortyre » 06 mai 2019, 11:05

Fabrice a écrit :
13 avr. 2019, 21:38
Bonjour,

J'ai :
- 12 prises en RFXCom
- 6 sondes Oregon

Et je n'ai pas ces problèmes.

Regardez ce que dit la documentation de ce plugin sur ce problème. De plus, juste pour "voir", supprimez vos sondes OWL (ôtez les piles) pour voir si vous n'avez pas du spam d'un équipement.
Fabrice ce n'est pas parce que tu n'as pas ce problème que cela veut dire que les autres ont juste un problème de configuration. J'ai 4 sondes de températures oregon, des sondes xiaomi, des sondes zwave et des sondes enocean, et je n'ai le problème que depuis quelque temps sur les sondes oregon.

Elles sont configurés en "toujours répéter" et pourtant j'ai le problème indiqué précédemment. J'ai changé les piles de chaque sonde...

Cela vient t'il d'un problème de spam d'un équipement je ne pense pas, ça a fonctionné pendant 3 ans sans soucis. Un pb d'ondes voisin je ne crois pas non plus. Un problème sur l'alimentation du RFXCOM peut-être. Un problème de compatibilité entre le plugin rfxcom, le drivers/firmware rfxcom et les sondes peut-être.

Alors pour palier aux problèmes j'ai fait un scénario pour redémarrer le deamon du plugin rfxcom mais c'est du bricolage. J'ai depuis la dernière version X redémarrage par jour (5 sondes sont sur 75mn et 1 sonde au sous-sol sur 8 heures).

Les Logs RFXCOM sur moins d'un jour plusieurs redémarrage du aux scénarios

Code : Tout sélectionner

[2019-05-05 22:05:12][INFO] : Démon RFXcom lancé
[2019-05-05 22:05:37][ERROR] : Timeout waiting status
[2019-05-05 22:10:07][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device /dev/ttyUSB1 --loglevel info --socketport 55000 --serialrate 38400 --protocol 7,18,21,22 --callback http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php --apikey e5csY --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
[2019-05-05 22:10:09][INFO] : Start rfxcomd
[2019-05-05 22:10:09][INFO] : Log level : info
[2019-05-05 22:10:09][INFO] : Socket port : 55000
[2019-05-05 22:10:09][INFO] : Socket host : 127.0.0.1
[2019-05-05 22:10:09][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2019-05-05 22:10:09][INFO] : Device : /dev/ttyUSB1
[2019-05-05 22:10:09][INFO] : Apikey : e5csY 
[2019-05-05 22:10:09][INFO] : Callback : http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php
[2019-05-05 22:10:09][INFO] : Cycle : 0.3
[2019-05-05 22:10:09][INFO] : Serial rate : 38400
[2019-05-05 22:10:09][INFO] : Serial timeout : 9
[2019-05-05 22:10:09][INFO] : Protocol : 7,18,21,22
[2019-05-05 22:10:12][INFO] : Démon RFXcom lancé
[2019-05-05 23:05:09][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device /dev/ttyUSB1 --loglevel info --socketport 55000 --serialrate 38400 --protocol 7,18,21,22 --callback http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php --apikey e5csY --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
[2019-05-05 23:05:10][INFO] : Start rfxcomd
[2019-05-05 23:05:10][INFO] : Log level : info
[2019-05-05 23:05:10][INFO] : Socket port : 55000
[2019-05-05 23:05:10][INFO] : Socket host : 127.0.0.1
[2019-05-05 23:05:10][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2019-05-05 23:05:10][INFO] : Device : /dev/ttyUSB1
[2019-05-05 23:05:10][INFO] : Apikey : e5csY 
[2019-05-05 23:05:10][INFO] : Callback : http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php
[2019-05-05 23:05:10][INFO] : Cycle : 0.3
[2019-05-05 23:05:10][INFO] : Serial rate : 38400
[2019-05-05 23:05:10][INFO] : Serial timeout : 9
[2019-05-05 23:05:10][INFO] : Protocol : 7,18,21,22
[2019-05-05 23:05:13][INFO] : Démon RFXcom lancé
[2019-05-06 00:10:08][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device /dev/ttyUSB1 --loglevel info --socketport 55000 --serialrate 38400 --protocol 7,18,21,22 --callback http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php --apikey e5csY --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 00:10:09][INFO] : Start rfxcomd
[2019-05-06 00:10:09][INFO] : Log level : info
[2019-05-06 00:10:09][INFO] : Socket port : 55000
[2019-05-06 00:10:09][INFO] : Socket host : 127.0.0.1
[2019-05-06 00:10:09][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 00:10:09][INFO] : Device : /dev/ttyUSB1
[2019-05-06 00:10:09][INFO] : Apikey : e5csY 
[2019-05-06 00:10:09][INFO] : Callback : http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php
[2019-05-06 00:10:09][INFO] : Cycle : 0.3
[2019-05-06 00:10:09][INFO] : Serial rate : 38400
[2019-05-06 00:10:09][INFO] : Serial timeout : 9
[2019-05-06 00:10:09][INFO] : Protocol : 7,18,21,22
[2019-05-06 00:10:12][INFO] : Démon RFXcom lancé
[2019-05-06 01:05:09][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device /dev/ttyUSB1 --loglevel info --socketport 55000 --serialrate 38400 --protocol 7,18,21,22 --callback http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php --apikey e5csY --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 01:05:11][INFO] : Start rfxcomd
[2019-05-06 01:05:11][INFO] : Log level : info
[2019-05-06 01:05:11][INFO] : Socket port : 55000
[2019-05-06 01:05:11][INFO] : Socket host : 127.0.0.1
[2019-05-06 01:05:11][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 01:05:11][INFO] : Device : /dev/ttyUSB1
[2019-05-06 01:05:11][INFO] : Apikey : e5csY 
[2019-05-06 01:05:11][INFO] : Callback : http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php
[2019-05-06 01:05:11][INFO] : Cycle : 0.3
[2019-05-06 01:05:11][INFO] : Serial rate : 38400
[2019-05-06 01:05:11][INFO] : Serial timeout : 9
[2019-05-06 01:05:11][INFO] : Protocol : 7,18,21,22
[2019-05-06 01:05:13][INFO] : Démon RFXcom lancé
[2019-05-06 02:05:08][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device /dev/ttyUSB1 --loglevel info --socketport 55000 --serialrate 38400 --protocol 7,18,21,22 --callback http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php --apikey e5csY --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 02:05:10][INFO] : Start rfxcomd
[2019-05-06 02:05:10][INFO] : Log level : info
[2019-05-06 02:05:10][INFO] : Socket port : 55000
[2019-05-06 02:05:10][INFO] : Socket host : 127.0.0.1
[2019-05-06 02:05:10][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 02:05:10][INFO] : Device : /dev/ttyUSB1
[2019-05-06 02:05:10][INFO] : Apikey : e5csY 
[2019-05-06 02:05:10][INFO] : Callback : http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php
[2019-05-06 02:05:10][INFO] : Cycle : 0.3
[2019-05-06 02:05:10][INFO] : Serial rate : 38400
[2019-05-06 02:05:10][INFO] : Serial timeout : 9
[2019-05-06 02:05:10][INFO] : Protocol : 7,18,21,22
[2019-05-06 02:05:12][INFO] : Démon RFXcom lancé
[2019-05-06 03:10:07][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device /dev/ttyUSB1 --loglevel info --socketport 55000 --serialrate 38400 --protocol 7,18,21,22 --callback http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php --apikey e5csY --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 03:10:08][INFO] : Start rfxcomd
[2019-05-06 03:10:08][INFO] : Log level : info
[2019-05-06 03:10:08][INFO] : Socket port : 55000
[2019-05-06 03:10:08][INFO] : Socket host : 127.0.0.1
[2019-05-06 03:10:08][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 03:10:08][INFO] : Device : /dev/ttyUSB1
[2019-05-06 03:10:08][INFO] : Apikey : e5csY 
[2019-05-06 03:10:08][INFO] : Callback : http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php
[2019-05-06 03:10:08][INFO] : Cycle : 0.3
[2019-05-06 03:10:08][INFO] : Serial rate : 38400
[2019-05-06 03:10:08][INFO] : Serial timeout : 9
[2019-05-06 03:10:08][INFO] : Protocol : 7,18,21,22
[2019-05-06 03:10:11][INFO] : Démon RFXcom lancé
[2019-05-06 04:05:09][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device /dev/ttyUSB1 --loglevel info --socketport 55000 --serialrate 38400 --protocol 7,18,21,22 --callback http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php --apikey e5csY --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 04:05:10][INFO] : Start rfxcomd
[2019-05-06 04:05:10][INFO] : Log level : info
[2019-05-06 04:05:10][INFO] : Socket port : 55000
[2019-05-06 04:05:10][INFO] : Socket host : 127.0.0.1
[2019-05-06 04:05:10][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2019-05-06 04:05:10][INFO] : Device : /dev/ttyUSB1
[2019-05-06 04:05:10][INFO] : Apikey : e5csY 
[2019-05-06 04:05:10][INFO] : Callback : http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php
[2019-05-06 04:05:10][INFO] : Cycle : 0.3
[2019-05-06 04:05:10][INFO] : Serial rate : 38400
[2019-05-06 04:05:10][INFO] : Serial timeout : 9
[2019-05-06 04:05:10][INFO] : Protocol : 7,18,21,22
[2019-05-06 04:05:13][INFO] : Démon RFXcom lancé
Mon Log du scénario exécuté avec le test sur stateDuration(sonde) :

Code : Tout sélectionner

[2019-05-06 04:05:03][SCENARIO] Start : Scenario execute automatiquement sur programmation.
[2019-05-06 04:05:03][SCENARIO] Exécution du sous-élément de type [condition] : if
[2019-05-06 04:05:06][SCENARIO] Evaluation de la condition : [2172 > 4200 OU 1678 > 4200 OU 364 > 4200 OU 625 > 4200 OU 40170 > 32000] = Vrai
[2019-05-06 04:05:06][SCENARIO] Exécution du sous-élément de type [action] : then
[2019-05-06 04:05:06][SCENARIO] Exécution d'un bloc élément : 382
[2019-05-06 04:05:06][SCENARIO] Exécution du sous-élément de type [action] : code
[2019-05-06 04:05:06][SCENARIO] Exécution d'un bloc code
[2019-05-06 04:05:09][SCENARIO] Exécution de la commande [Communication][hotmail][Jeedom hotmail] avec comme option(s) : {"background":"0","title":"arret du deamon rfxcom","message":"arret du deamon rfxcom pour pb temperature le 0506 \u00e0 405
sonde salon : 2177 > 4200
sonde eva :  1683 > 4200
sonde parents :  368 > 4200
sonde v\u00e9randa : 629 > 4200
sonde sous-sol : 40174 > 32000"}
[2019-05-06 04:05:10][SCENARIO] Fin correcte du scénario
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: RFXCOM se fige depuis la dernière MAJ

Message par bronche » 06 mai 2019, 17:02

Bonjour,

Moi j'utilise la relance du daemon en faisant un contrôle toutes les 30 minutes sur 5 sondes. Deux Oregon et 3 chinoises. Cela fonctionne parfaitement et je n'ai plus de problème de chauffage.

Je viens d'aller voir les logs par curiosité suite à vos messages.

Sur les 20 derniers jours, j'ai 3 journées (non continues) de relance incessante du daemon sur non réponse d'une de mes sondes chinoises. Cela finit par rentrer dans l'ordre sans intervention de ma part (résidence secondaire).

J'ai déjà rencontré le cas avec mon Portail. Impossible de le faire fonctionner sauf à coller la télécommande sur le boitier. J'ai tout vérifié, je n'ai rien trouvé ! Il a ce comportement de temps à autre.

Donc je pense qu'on ne peut pas écarter la perturbation du signal, pour mon cas c'est la seule explication rationnelle.

Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: RFXCOM se fige depuis la dernière MAJ

Message par mortyre » 06 mai 2019, 17:19

Si on ne trouve pas de raison pragmatique je vais changer mes sondes oregon pour un autre protocole, car ça ne me plait pas de redémarrer le deamon automatiquement si les températures ne sont pas remontés.
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: RFXCOM se fige depuis la dernière MAJ

Message par Fabrice » 06 mai 2019, 17:25

C'est aussi ce que j'ai voulu dire.

Si c'était un problème du plugin on seraient 100% à avoir ce problème. Ce qui n'est pas le cas !

Donc que des personnes rencontre un problème oui... que cela soit ce un problème du plugin non.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: RFXCOM se fige depuis la dernière MAJ

Message par mortyre » 06 mai 2019, 17:53

Fabrice c'est fort possible que cela ne soit pas un pb de plugin mais pas forcément vrai non plus. Je le répète ce n'est pas parce que cela fonctionne pour toi et d'autres que cela veut dire forcément qu'il n'y pas un problème de plugin. On ne peut pas savoir car cela dépend de beaucoup de paramètres, et des installations de chacun (matériel, config, ..) et du nombre de plugins aussi installés qui peuvent avoir des effet de bord et l'environnement externe (ondes, ...).

Dans mon cas je n'ai jamais eu de problème en 3 ans avec mes sondes Oregon et depuis quelque temps c'est le cas, et je ne suis pas le seul, et c'est arrivé à peu près en même temps à plusieurs personnes, donc coïncidence où pas on peut se poser la question et essayez de trouver des réponses.

Donc oui ça peut venir d'une mise à jour du plugin qui dans mon cas ferait cela ou peut être que cela peut venir d'un facteur extérieur au plugin comme je l'ai indiqué dans mon post précédent. LA nuance c'est bien.

Je viens de désactiver mes deux derniers device ajoutés depuis le pb (RFPlayer et Clé Zigbee pour voir si elle ne perturbe pas le signal). JE vous tient au courant je continue à chercher hors plugin.
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

drs
Actif
Messages : 1534
Inscription : 04 nov. 2016, 10:44

Re: RFXCOM se fige depuis la dernière MAJ

Message par drs » 06 mai 2019, 19:17

bronche a écrit :
06 mai 2019, 17:02
J'ai déjà rencontré le cas avec mon Portail. Impossible de le faire fonctionner sauf à coller la télécommande sur le boitier. J'ai tout vérifié, je n'ai rien trouvé ! Il a ce comportement de temps à autre.

Donc je pense qu'on ne peut pas écarter la perturbation du signal, pour mon cas c'est la seule explication rationnelle.

Phil
Bonjour

En ce qui me concerne, je suis arrivé à la conclusion d’une perturbation externe justement à cause de mon portail.
Les moments où mon rfxcom fonctionne mal, je dois etre à côté du portail pour l’ouvrir (avec sa télécommande, donc rien à voir avec Jeedom). Il est à plus de 25m de mon boitier rfxcom et avec tous les murs (donc hors de portée).

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: RFXCOM se fige depuis la dernière MAJ

Message par mortyre » 06 mai 2019, 20:41

De mon coté, aucun probleme d'émission d'action avec mon RFXCOM et pourtant mon portail est vraiment à l'opposé, idem pour le peux de chose que j'ai dessus comme ma VMC, et un éclairage au sous sol et un au comble (en fait tout ce qui est loin de la clé).

J'ai un problème que sur les valeurs de température qui ont la même valeur malgré le toujours répéter sur la valeur.

Exemple à l'instant avec deux capteurs qui ont dépassés les 60mn avec la commande stateDuration

Code : Tout sélectionner

------------------------------------
[2019-05-06 19:05:03][SCENARIO] Start : Scenario execute automatiquement sur programmation.
[2019-05-06 19:05:03][SCENARIO] Exécution du sous-élément de type [condition] : if
[2019-05-06 19:05:05][SCENARIO] Evaluation de la condition : [1064 > 4200 OU 2624 > 4200 OU 1596 > 4200 OU 220 > 4200 OU 44 > 86000] = Faux
[2019-05-06 19:05:05][SCENARIO] Exécution du sous-élément de type [action] : else
[2019-05-06 19:05:05][SCENARIO] Fin correcte du scénario
------------------------------------
[2019-05-06 20:05:02][SCENARIO] Start : Scenario execute automatiquement sur programmation.
[2019-05-06 20:05:02][SCENARIO] Exécution du sous-élément de type [condition] : if
[2019-05-06 20:05:04][SCENARIO] Evaluation de la condition : [1154 > 4200 OU 6223 > 4200 OU 5196 > 4200 OU 36 > 4200 OU 160 > 86000] = Vrai
[2019-05-06 20:05:04][SCENARIO] Exécution du sous-élément de type [action] : then
[2019-05-06 20:05:04][SCENARIO] Exécution d'un bloc élément : 382
[2019-05-06 20:05:04][SCENARIO] Exécution du sous-élément de type [action] : code
[2019-05-06 20:05:04][SCENARIO] Exécution d'un bloc code
[2019-05-06 20:05:09][SCENARIO] Exécution de la commande [Communication][karl hotmail][Jeedom karl hotmail] avec comme option(s) : {"background":"0","title":"arret du deamon rfxcom","message":"arret du deamon rfxcom pour pb temperature le 0506 \u00e0 2005
sonde salon : 1159 > 4200
Le premier qui a en effet resté sur la même valeur depuis 18H20 sur mode graphique, d'ailleurs la valeur est de 6223 soit grossomodo les 105mn entre 18H20 et 20H05. Il n'y a donc eu aucune remontée intermédiaire depuis 18H20 malgré le répéter toujours sur cette commande dans la base.

Si je vais sur cet équipement oregon et que je regarde la commande température j'ai Date collecte : 2019-05-06 20:33:10 et Date valeur : 2019-05-06 18:21:20

Et si je vais dans mes logs RFXCOM je vois bien des valeurs remontés pour cette sonde toutes les 40sec donc ca fonctionne parfaitement à ce niveau !

Code : Tout sélectionner

[2019-05-06 20:27:44][DEBUG] : Decode data : {'temperature': '20.3', 'raw': '0A5201A2900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}
[2019-05-06 20:27:44][DEBUG] : Send to jeedom : {'devices': {'900252': {'temperature': '20.3', 'raw': '0A5201A2900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}}}
[2019-05-06 20:28:25][DEBUG] : Decode data : {'temperature': '20.3', 'raw': '0A5201A7900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}
[2019-05-06 20:28:25][DEBUG] : Send to jeedom : {'devices': {'900252': {'temperature': '20.3', 'raw': '0A5201A7900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}}}
[2019-05-06 20:29:06][DEBUG] : Decode data : {'temperature': '20.3', 'raw': '0A5201AC900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}
[2019-05-06 20:29:06][DEBUG] : Send to jeedom : {'devices': {'900252': {'temperature': '20.3', 'raw': '0A5201AC900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}}}
[2019-05-06 20:29:47][DEBUG] : Decode data : {'temperature': '20.3', 'raw': '0A5201AF900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}
[2019-05-06 20:29:47][DEBUG] : Send to jeedom : {'devices': {'900252': {'temperature': '20.3', 'raw': '0A5201AF900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}}}
[2019-05-06 20:30:28][DEBUG] : Decode data : {'temperature': '20.3', 'raw': '0A5201B5900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}
[2019-05-06 20:30:28][DEBUG] : Send to jeedom : {'devices': {'900252': {'temperature': '20.3', 'raw': '0A5201B5900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}}}
[2019-05-06 20:31:09][DEBUG] : Decode data : {'temperature': '20.3', 'raw': '0A5201BA900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}
[2019-05-06 20:31:09][DEBUG] : Send to jeedom : {'devices': {'900252': {'temperature': '20.3', 'raw': '0A5201BA900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}}}
[2019-05-06 20:31:50][DEBUG] : Decode data : {'temperature': '20.3', 'raw': '0A5201BF900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}
[2019-05-06 20:31:50][DEBUG] : Send to jeedom : {'devices': {'900252': {'temperature': '20.3', 'raw': '0A5201BF900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}}}
[2019-05-06 20:32:31][DEBUG] : Decode data : {'temperature': '20.3', 'raw': '0A5201C4900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}
[2019-05-06 20:32:32][DEBUG] : Send to jeedom : {'devices': {'900252': {'temperature': '20.3', 'raw': '0A5201C4900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}}}
[2019-05-06 20:33:12][DEBUG] : Decode data : {'temperature': '20.3', 'raw': '0A5201C8900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}
[2019-05-06 20:33:12][DEBUG] : Send to jeedom : {'devices': {'900252': {'temperature': '20.3', 'raw': '0A5201C8900200CB300169', 'battery': '9', 'signal': '6', 'humidity': '48', 'subtype': '01', 'packettype': '52', 'id': '9002'}}}
J'ai donc bien les valeurs qui remontent mais sont prises dans "Date de collecte" mais pas "Date de valeur" ce qui doit être normal.

Et si je fais un Stateduration sur cette commande ça me réponds donc : Je vais évaluer : 8167 > 4200

Le StateDuration me remonte donc la "Date de valeur" qui ne correspond pas à la dernière valeur remontée mais à la dernier valeur non changeante. D’où mon non problème en fait ?
La Doc dit : stateDuration(commande) : Donne la durée en secondes depuis le dernier changement de valeur.

Est ce que dans le plugin Thermostat je suppose que ça prends bien la date de collecte pour vérifier si une défaillance de sonde ?
Et comment avoir avec une fonction la dernière valeur de collecte pour vérifier si la sonde envois bien la température ?
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: RFXCOM se fige depuis la dernière MAJ

Message par Fabrice » 06 mai 2019, 20:55

La documentation du plugin thermostat indique que la défaillance des sondes est basée sur la valeur et pas sur une date.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

mortyre
Actif
Messages : 1247
Inscription : 17 mai 2016, 16:51

Re: RFXCOM se fige depuis la dernière MAJ

Message par mortyre » 06 mai 2019, 23:10

On peut le supposer mais la doc du thermostat ne donne pas clairement la réponse puisqu'elle parle de délai entre 2 relevés de température.

Issu de la doc thermostat :
Si les sondes utilisées par le thermostat ne renvoient pas de changement de température, par exemple en cas d’usure des piles, alors le thermostat enclenche les actions de défaillance.
TIP : Le paramètre qui permet au thermostat de décider d’une défaillance de sonde est situé dans l’onglet Avancée. Il s’agit du délai max entre 2 relevés de température.


Dans le meilleur des cas, ça voudrait dire 40 secondes dans mon exemple et dans le pire la différence entre les deux valeurs de "date de collecte" et "date de valeur".

Dans le cas de la doc sur les scénarios pour la fonction stateduration oui il est dit que cela donne la durée en secondes depuis le dernier changement de valeur. Mais on voit bien qu'il prends comme valeur la date de collecte et non la date de valeur.

--> Donc quid de la fonction pour récupérer la dernière valeur de la "date de la collecte" ?
PROD: NAS1815+ VMM Buster 10.2 / Jeedom 4.0.31 / MariaDB 10.3.18 / PHP 7.3.9
DEV: DIY Odroid C2 16gb Strech 9.11 / Jeedom 4.x Alpha / MariaDB 10.1.41 / PHP 7.0.33

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: RFXCOM se fige depuis la dernière MAJ

Message par Fabrice » 07 mai 2019, 07:11

Non, ce n'est pas une supposition, c'est directement de l'auteur du plugin (qui ne fait que redire ce qui est clairement indiqué dans la documentation) :
viewtopic.php?f=89&t=41520&start=80
(délais entre 2 relevés de température)

En clair, si sur x relevés, vous avez toujours 20.3°C pendant votre période d'alerte, alors vous allez avoir l'alerte.
Il faut donc augmenter cette période (180 minutes semble convenir à beaucoup de personne).
Par contre, si vous avez 20.3°C et dans un autre relevé, vous avez 20.4°C, alors le compteur repasse à 0.
- C'est aussi tout l'intérêt d'avoir de bonnes sondes et une bonne communication.

Et il faut surtout veiller à ce que le choix "toujours répété" soit sélectionné sur les sondes utilisées dans les thermostats.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Répondre

Revenir vers « [Plugin Officiel] RFXcom »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités