Page 1 sur 1

[Résolu] RFXCOM ne fonctionne plus du tout ?

Publié : 26 juin 2019, 09:25
par stalex
Bonjour à tous.

Tout d'abord, ça fait maintenant 3 ans que je fais de la domotique avec jeedom, avec un Rfxcom depuis le début.
Tout était fonctionnel jusqu'à hier matin, 6h30 !

Le rfxcom et donc tous les équipements associés ne fonctionnent plus. Voici ce que j'ai essayé:
- Relancer le démon, en mettant le port à Auto, ou en sélectionnant le port de mon boitier Rfxcom (TtyUSB1) : KO: le démon ne se relance pas.
- Changer de cable : KO, le démon ne se relance pas.
- Passer par un hub autoalimenté ou en direct branché sur mon Rpi: KO
- Brancher sur un PC et me servir de RfxMngr: ça fonctionne, je vois bien passer les trames.
- Relancer l'installation des dépendances: KO
- Relancer jeedom, relancer mon RPi3 : KO
- Débrancher, faire un dmesg | grep ttyUSB1 (directement sur mon Pi): je vois bien le boitier débranché
- Rebrancher => idem, je vois bien le boitier branché

Pour info, j'utilise un RaspberryPi 3B; qui fonctionne depuis des années.

Voici l'état de mon démon:
rfxcom.PNG
rfxcom.PNG (12.21 Kio) Consulté 942 fois

Voici les logs lorsque je relance le démon, j'ai mis les logs en "Debug". Je n'ai que des logs "Rfxcom", pas d'autre log (par exemple pas de log rfxcmd):
[2019-06-26 09:10:35][ERROR] : Impossible de lancer le démon RFXcom, vérifiez le log rfxcmd
[2019-06-26 09:15:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-06-26 09:15:06][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device auto --loglevel debug --socketport 55000 --serialrate 38400 --protocol 4,18,20,21,22 --callback http://127.0.0.1:80/plugins/rfxcom/core ... Rfxcom.php --apikey Eqp4eXRhH78LSk1RfCF7s94QPTwkWYkatUy1OK8tFryaCu41 --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
Traceback (most recent call last):
File "/var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py", line 34, in <module>
from jeedom.jeedom import *
File "/var/www/html/plugins/rfxcom/resources/rfxcomd/jeedom/jeedom.py", line 21, in <module>
import requests
File "/usr/lib/python2.7/dist-packages/requests/__init__.py", line 52, in <module>
from .packages.urllib3.contrib import pyopenssl
File "/usr/lib/python2.7/dist-packages/requests/packages/__init__.py", line 59, in <module>
vendored('urllib3.contrib.pyopenssl')
File "/usr/lib/python2.7/dist-packages/requests/packages/__init__.py", line 32, in vendored
__import__(vendored_name, globals(), locals(), level=0)
File "/usr/lib/python2.7/dist-packages/urllib3/contrib/pyopenssl.py", line 47, in <module>
import OpenSSL.SSL
File "/usr/lib/python2.7/dist-packages/OpenSSL/__init__.py", line 8, in <module>
from OpenSSL import rand, crypto, SSL
File "/usr/lib/python2.7/dist-packages/OpenSSL/rand.py", line 12, in <module>
from OpenSSL._util import (
File "/usr/lib/python2.7/dist-packages/OpenSSL/_util.py", line 6, in <module>
from cryptography.hazmat.bindings.openssl.binding import Binding
File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 173, in <module>
Binding.init_static_locks()
File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 137, in init_static_locks
cls._ensure_ffi_initialized()
File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 124, in _ensure_ffi_initialized
cls.lib = build_conditional_library(lib, CONDITIONAL_NAMES)
File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 94, in build_conditional_library
setattr(conditional_lib, attr, getattr(lib, attr))
AttributeError: cffi library '_openssl' has no function, constant or global variable named 'KCS7_verify'
[2019-06-26 09:15:36][ERROR] : Impossible de lancer le démon RFXcom, vérifiez le log rfxcmd

Je suis vraiment perdu, j'ai tout essayé, et toute ma domotique est régie par le rfxcom....
Quelqu'un aurait une idée svp ? Une manip à faire ?

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 26 juin 2019, 10:39
par PrFalKeN
'Jour,

la page réseau est elle OK ?
les dependances sont OK c'est sur ? On peut voir le log des dépendances ?

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 26 juin 2019, 10:48
par Theking31
Carte sd ?

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 26 juin 2019, 21:24
par stalex
Merci pour vos réponses.

Oui, carte SD.
Voici le log d'install des dépendances:
********************************************************
* Installation des dépendances *
********************************************************
Hit:1 https://deb.nodesource.com/node_8.x stretch InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Get:3 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Fetched 40.3 kB in 11s (3636 B/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
python-serial is already the newest version (3.2.1-1).
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
********************************************************
* Installation terminée *
********************************************************
Voici ma page de santé:
sante.PNG
sante.PNG (74.45 Kio) Consulté 899 fois
La conf réseau externe a toujours été KO depuis des mois, mais ça ne posait pas de souci.
Cela dit je vais y regarder, mais je ne pense pas que cela puisse venir de là.

Merci.

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 26 juin 2019, 21:36
par stalex
Bon j'ai remis en place le réseau externe, je n'ai plus que ce plugin rfxcom qui ne va pas dans ma page santé:
sante2.PNG
sante2.PNG (70.63 Kio) Consulté 894 fois
Vraiment bizarre...

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 26 juin 2019, 21:45
par Mips2648
Aurais-tu installé un nouveau plugin depuis?

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 26 juin 2019, 23:44
par stalex
heuu non :(

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 27 juin 2019, 08:35
par PrFalKeN
'Jour,

il serait bien de passer le plugin en debug et de démarrer le démon et nous donner le log en debug...

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 27 juin 2019, 08:50
par stalex
Bonjour,

mais c'est pourtant exactement ce que j'ai fait à mon premier message (hier à 9h25), je vous ai fourni les logs en debug :(
En fait concrètement ca a l'air d'etre une erreur sur openssl:
AttributeError: cffi library '_openssl' has no function, constant or global variable named 'KCS7_verify'
Mais je vois pas trop. J'ai essayé de mettre à jour ma distrib (Stretch), retirer python, openssl, résintaller.... mais rien n'y fait. :(

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 27 juin 2019, 14:40
par bronche
Bonjour,
Moi je vois plutôt un souci sur les bibliothèques python et plus particulièrement sur cryptography.
AU point ou tu en es tu peux tenter en SSH :

Code : Tout sélectionner

for x in $(pip list -o --format=columns | sed -n '3,$p' | cut -d' ' -f1); do pip install $x --upgrade; done
Pour mise à jour de toutes les bibliothèques obsolètes.
Amitiés
Phil

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 27 juin 2019, 15:25
par PrFalKeN
Oui un petit apt-get update et upgrade ne ferait pas de mal non plus...
Et pour moi le log du début n'est pas en debug...

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 27 juin 2019, 17:49
par stalex
Bonjour, merci bronche, je vais tenter ça et je fais un retour.

PrFalken, j'ai deja fait un update et upgrade. Ca je l'ai fait hier mais sans succés.

Et sinon comment mettre le log en débug alors ? Dsl mais je ne vois pas. Je pensais que c'était là ? (en jaune):
logrfxcom.PNG
logrfxcom.PNG (44.26 Kio) Consulté 820 fois

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 27 juin 2019, 18:31
par stalex
@bronche, ça fait pareil ta commande:
pi@raspberrypi:~ $ for x in $(pip list -o --format=columns | sed -n '3,$p' | cut -d' ' -f1); do pip install $x --upgrade; done
Traceback (most recent call last):
File "/usr/bin/pip", line 9, in <module>
from pip import main
File "/usr/lib/python2.7/dist-packages/pip/__init__.py", line 21, in <module>
from pip._vendor.requests.packages.urllib3.exceptions import DependencyWarning
File "/usr/lib/python2.7/dist-packages/pip/_vendor/__init__.py", line 64, in <module>
vendored("cachecontrol")
File "/usr/lib/python2.7/dist-packages/pip/_vendor/__init__.py", line 36, in vendored
__import__(modulename, globals(), locals(), level=0)
File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/__init__.py", line 9, in <module>
File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/wrapper.py", line 1, in <module>
File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/adapter.py", line 4, in <module>
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/__init__.py", line 52, in <module>
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/packages/__init__.py", line 59, in <module>
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/packages/__init__.py", line 32, in vendored
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/contrib/pyopenssl.py", line 47, in <module>
File "/usr/lib/python2.7/dist-packages/OpenSSL/__init__.py", line 8, in <module>
from OpenSSL import rand, crypto, SSL
File "/usr/lib/python2.7/dist-packages/OpenSSL/rand.py", line 12, in <module>
from OpenSSL._util import (
File "/usr/lib/python2.7/dist-packages/OpenSSL/_util.py", line 6, in <module>
from cryptography.hazmat.bindings.openssl.binding import Binding
File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 173, in <module>
Binding.init_static_locks()
File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 137, in init_static_locks
cls._ensure_ffi_initialized()
File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 124, in _ensure_ffi_initialized
cls.lib = build_conditional_library(lib, CONDITIONAL_NAMES)
File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 94, in build_conditional_library
setattr(conditional_lib, attr, getattr(lib, attr))
AttributeError: cffi library '_openssl' has no function, constant or global variable named 'KCS7_verify'
Merci pour l'aide.

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 27 juin 2019, 19:16
par bronche
Etrange... Tente :

Code : Tout sélectionner

sudo easy_install -U cryptography
puis

Code : Tout sélectionner

pip install pyopenssl 

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 27 juin 2019, 19:24
par Mips2648
Quels versions as-tu? core & rfxcom
et peux-tu executer la commande "pip freeze" pour qu'on voit les versions des packages installés

sinon je proposerais de désinstaller les dépendances et les réinstaller ou de forcer la reinstall pour être sur que les fichiers soient recopiés...
Si tu n'as rien changé, rien installé, rien supprimé, il n'y a pas de raison que cela ne fonctionne plus et que tout d'un coup openssl (psq cela semble venir de ce package) soit cassé... ou alors carte sd corrompue?

Re: RFXCOM ne fonctionne plus du tout ?

Publié : 28 juin 2019, 08:53
par stalex
Merci à tous pour votre aide.

@bronche, tu es mon sauveur, car réinstaller cryptography a solutionné le problème. Je ne connaissais pas easy_install. Merci encore pour ton avoir partagé !
Et oui Mips2648, je suis vraiment surpris que ça ai craqué comme ça, sans signe préalable..... peut être la carte SD ? J'en doute car sinon jeedom fonctionne nickel. Juste une dépendance "cryptography" qui était corrompue..... j'hallucine. J'ai quand meme cherché pendant 5j...

Et au fait, j'avais bien réinstallé les dépendances du plugin rfxcom, mais apparemment openssl n'en fait pas partie (car ca n'avait rien changé).

Re: [Résolu] RFXCOM ne fonctionne plus du tout ?

Publié : 28 juin 2019, 09:27
par Mips2648
openssl est une dépendance de crypto ;)

Re: [Résolu] RFXCOM ne fonctionne plus du tout ?

Publié : 28 juin 2019, 20:16
par bronche
Parfait.
Change ta carte SD. Cette corruption n'est pas normale.
Amitiés
Phil