Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[RESOLU] Après migration sur stretch et niveau 3.3.30, install des dépendances KO pour clé EnOcean USB300

Retrouvez ici des sujets concernant le protocole EnOcean et les modules domotiques de type EnOcean utilisés avec JEEDOM
church8
Timide
Messages : 15
Inscription : 29 avr. 2017, 18:18

[RESOLU] Après migration sur stretch et niveau 3.3.30, install des dépendances KO pour clé EnOcean USB300

Message par church8 » 07 sept. 2019, 15:08

Bonjour

Après avoir migré l'OS de ma jeedom smart, je n'arrive plus à installer le plugin EnOcean, la mise à jour des dépendances est KO.
J'ai mis le port EnOcean en "AUTO", ne sachant pas quoi mettre d'autre
J'obtiens la log suivante:
********************************************************
* Installation des dépendances *
********************************************************
Hit:1 http://repo.jeedom.com/odroid stable InRelease
Hit:2 http://security.debian.org stretch/updates InRelease
Ign:3 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ InRelease
Hit:4 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Release
Ign:5 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Release.gpg
Ign:6 http://ftp.debian.org/debian stretch InRelease
Ign:7 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Packages
Ign:8 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en_US
Ign:9 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en
Ign:7 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Packages
Ign:8 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en_US
Ign:9 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en
Hit:10 http://ftp.debian.org/debian stretch-updates InRelease
Ign:7 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Packages
Ign:8 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en_US
Ign:9 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en
Get:7 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Packages [545 B]
Hit:11 http://ftp.debian.org/debian stretch-backports InRelease
Ign:8 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en_US
Ign:9 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en
Ign:8 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en_US
Hit:12 http://ftp.debian.org/debian stretch-proposed-updates InRelease
Ign:9 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en
Ign:8 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en_US
Ign:9 http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Translation-en
Hit:13 http://ftp.debian.org/debian stretch Release
Get:14 http://repo.jeedom.com/odroid stable/main arm64 Packages [545 B]
Hit:15 http://www.deb-multimedia.org stretch InRelease
Hit:17 https://oph.mdrjr.net/meveric all InRelease
Hit:18 https://oph.mdrjr.net/meveric stretch InRelease
Fetched 545 B in 4s (112 B/s)
Reading package lists...
W: The repository 'http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Release' is not signed.
W: No Hash entry in Release file /var/lib/apt/lists/repo.jeedom.com_odroid_dists_stable_main_binary-arm64_Release
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/repo.jeedom.com_odroid_dists_stable_main_binary-arm64_Release
W: Conflicting distribution: http://repo.jeedom.com/odroid dists/stable/main/binary-arm64/ Release (expected dists/stable/main/binary-arm64/ but got )
E: Failed to stat /var/lib/apt/lists/partial/repo.jeedom.com_odroid_dists_stable_main_binary-arm64_Packages - pkgAcqTransactionItem::TransactionState-stat (2: No such file or directory)
Reading package lists...
Building dependency tree...
Reading state information...
Package 'python-enum' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 159 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python-serial is already the newest version (3.2.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
0 upgraded, 0 newly installed, 0 to remove and 159 not upgraded.
/var/www/html/plugins/openenocean/core/class/../../resources/install_apt.sh: line 16: pip: command not found
/var/www/html/plugins/openenocean/core/class/../../resources/install_apt.sh: line 18: pip: command not found
********************************************************
* Installation terminée *
********************************************************

SI quelqu'un avait une idée pour me débloquer...
Ca marchait avant mise à jour
Dernière édition par church8 le 07 sept. 2019, 16:53, édité 1 fois.

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Après migration sur stretch et niveau 3.3.30, install des dépendances KO pour clé EnOcean USB300

Message par loic » 07 sept. 2019, 15:57

Bonjour,
Essayes en ssh :
sudo apt install -y python-pip (tu peux le faire depuis configration -> OS/DB puis systeme)
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

church8
Timide
Messages : 15
Inscription : 29 avr. 2017, 18:18

Re: Après migration sur stretch et niveau 3.3.30, install des dépendances KO pour clé EnOcean USB300

Message par church8 » 07 sept. 2019, 16:38

Merci beaucoup @loic
Ca a résolu mon pb
Je devais avoir une install python bancale
encore merci !

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Après migration sur stretch et niveau 3.3.30, install des dépendances KO pour clé EnOcean USB300

Message par loic » 07 sept. 2019, 16:40

au cas ou dans la prochaine stable j'ai rajouté l'installation automatique de package ca evitera les soucis
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

church8
Timide
Messages : 15
Inscription : 29 avr. 2017, 18:18

Re: Après migration sur stretch et niveau 3.3.30, install des dépendances KO pour clé EnOcean USB300

Message par church8 » 07 sept. 2019, 16:41

je voudrais tagger ce fil "résolu" mais je ne trouve pas comment faire

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Après migration sur stretch et niveau 3.3.30, install des dépendances KO pour clé EnOcean USB300

Message par loic » 07 sept. 2019, 16:43

Faut editer le titre et mettre résolu devant
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

inoxyd
Timide
Messages : 3
Inscription : 28 mai 2019, 20:54
Localisation : Saint Orens (31650)

Re: [RESOLU] Après migration sur stretch et niveau 3.3.30, install des dépendances KO pour clé EnOcean USB300

Message par inoxyd » 11 sept. 2019, 08:34

Bonjour à tous,

Je pense avoir un problème proche de celui-ci.
Je viens de recevoir une clé officielle Enocean, avec port SMA. Après avoir installé le plugin ENOCEAN et l'avoir activé, j'ai les dépendances qui ne s'installent pas (NOK).
J'ai exécuté: "sudo apt install -y python-pip" mais rien de plus...

Log:

********************************************************
* Installation des dépendances *
********************************************************
Hit:1 http://security.debian.org stretch/updates InRelease
Hit:2 https://apt.armbian.com stretch InRelease
Ign:3 http://cdn-fastly.deb.debian.org/debian stretch InRelease
Hit:4 http://cdn-fastly.deb.debian.org/debian stretch-updates InRelease
Hit:5 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease
Hit:6 http://cdn-fastly.deb.debian.org/debian stretch Release
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Package 'python-enum' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python-serial is already the newest version (3.2.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Collecting enum-compat
Using cached https://files.pythonhosted.org/packages ... 0.2.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
ImportError: No module named setuptools
----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-GrzZ3x/enum-compat/
Requirement already satisfied: beautifulsoup4 in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied: soupsieve>=1.2 in /usr/local/lib/python2.7/dist-packages (from beautifulsoup4)
Requirement already satisfied: backports.functools-lru-cache; python_version < "3" in /usr/local/lib/python2.7/dist-packages (from soupsieve>=1.2->beautifulsoup4)
********************************************************
* Installation terminée *
********************************************************

Pouvez vous m'aider s'il vous plait ?

inoxyd
Timide
Messages : 3
Inscription : 28 mai 2019, 20:54
Localisation : Saint Orens (31650)

Re: [RESOLU] Après migration sur stretch et niveau 3.3.30, install des dépendances KO pour clé EnOcean USB300

Message par inoxyd » 11 sept. 2019, 08:49

BREAKING NEWS... Je partage car ça fait 48 heures que je craque sur ce problème.
J'ai résolu mon problème en (ré)installant DISTRIBUTE via:

wget https://bootstrap.pypa.io/ez_setup.py -O - | sudo python

ça a l'air de fonctionner maintenant !

Répondre

Revenir vers « [Plugin Officiel] EnOcean »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Bing [Bot] et 1 invité