Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Paramétrage caméra IP Wanscam HW0045

Pour parler de tout, et surtout de rien !
Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Paramétrage caméra IP Wanscam HW0045

Message par matric » 07 mars 2017, 15:01

Bonjour,

Ayant dernièrement installé une caméra Wanscam HW0045 acquise chez GBest je rencontre des difficultés pour l'utiliser correctement, en fait je ne peux pas l'utiliser normalement.

Quelques données techniques:
Caméra:
- Software Version: V6.6.8.1.1-20160310
- Webware Version : E200.0.45.21
Environnement:
- Windows 10 / Windows XP
- Internet Explorer 11
- Firefox 51.0.1
- Chrome 56.0.2924.87
- OCX installé (ClientPlus_setup 1.0.0.9)

Difficultés rencontrées en interface WEB:
- Pas d'image affichée, écran de visualisation noir
- Les boutons de navigation de la caméra (à gauche de la roue dentée) apparaissent brièvement puis disparaissent
- Il manque des options de paramètrage telles que Alarme settings (par exemple). Je ne peux pas configurer les zones de détection de mouvement.
- Le symptome est le même avec Internet Explorer, Chrome et Firefox sous Windows10
- Le symptome est le même avec Internet Explorer et Firefox sur un autre ordi sous WindowsXP

Image

Image

J'ai testé le tuto de notre ami Rosty mais faute d'options dans le menu je ne peux pas mettre en oeuvre les zones de détection.
Précision: je peux profiter de l'image au travers de Jeedom avec le plug Caméra.

J'avais eu dans l'idée de flasher un firmware récent (si tant est que celà puisse aider à la résolution) mais impossible de trouver sur le net une source, y compris chez Wanscam.

Je passe à côté de qq chose ou cela peut-il être imputable à la caméra ?
Si vous avez une idée sur le sujet, ce serait avec plaisir que j'aimerais en prendre connaissance.
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Paramétrage caméra IP Wanscam HW0045

Message par Fabrice » 07 mars 2017, 21:14

Bonjour,

Avez-vous le plugin Flash d'installé et d'actif sur vos machines ?
Avez-vous des options dans la partie vidéo ?
J'ai des caméras DLink qui n'ont plus d'image sur les navigateurs, mais qui fonctionnent bien sur les applications mobile. C'est le format vidéo qui n'est pas pris en charge dans les navigateurs (et pour Flash.. ça sent le sapin).

Attention : Sur Windows 10, le navigateur Microsoft Egde ne remplace pas du tout Microsoft Internet Explorer. Egde est un navigateur de type "nouvelle génération" qui est 100% issue d'une nouvelle écriture de code. Il ne partage rien avec Internet Explorer.
A titre de comparaison, Internet Explorer sait gérer les activeX (ce qui rend très certainement fonctionnel à 100% votre caméra) alors que Microsoft Edge ne le permet pas.
Dernière édition par Fabrice le 08 mars 2017, 14:12, édité 1 fois.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Deennoo
Timide
Messages : 450
Inscription : 05 nov. 2015, 13:51

Re: Paramétrage caméra IP Wanscam HW0045

Message par Deennoo » 08 mars 2017, 12:46

Passer avec internet explorer qui est le seul à avoir le plugin vidéo pour les cams

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 08 mars 2017, 13:20

@Fabrice

Merci pour les qq pistes à explorer.

Flash Player est activé dans Edge.
J'avais par ailleurs par 2 fois procédé à une restauration des valeurs par défaut d'usine.
J'ai modifié qq paramètres dans les caractéristiques vidéo, sans succès.
L'affichage reste désespérément vide.

Image

@Deennoo

Effectivement c'est ce qu'il est indiqué d'utiliser avec cette caméra.
Si tant est que Edge soit le remplaçant de feu IE, c'est bien ce qui est utilisé.

Merci à vous deux pour avoir pris le temps de vous être arrêté sur ce topic. :)
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

alpha13fr
Actif
Messages : 579
Inscription : 05 oct. 2015, 00:03
Localisation : Bouches du Rhone (13)

Re: Paramétrage caméra IP Wanscam HW0045

Message par alpha13fr » 08 mars 2017, 13:25

perso le zoom optique ne marche pas sur celle que je viens de recevoir !
JEEDOM sur nuc D340WYK esx

Esclave raspberry en WIFI, téléinfo EDF, AEON Labs Z-Wave Gen5


2 FGMS-001
8 FGSD-002 ( Merci aux bons plans )
2 FGFS-101 ( Merci aux bons plans )

MERCI A TOUTE L'EQUIPE POUR LE TAF

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 08 mars 2017, 13:41

@alpha12fr

Rassurant !
Il me semble bizarre de ne pas voir dans les options de config la possibilité de paramétrer la détection de mouvement dont plusieurs font état sur la toile. Je ne pense pas que cela ait à voir avec un problème de compatibilité avec un navigateur.
Peux-tu regarder si tu as les mêmes options dans les paramètres comme ci-dessus (plus, moins, pareil ?)
Merci.
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

Avatar de l’utilisateur
virux
Timide
Messages : 249
Inscription : 21 juil. 2014, 08:49
Localisation : Lorraine

Re: Paramétrage caméra IP Wanscam HW0045

Message par virux » 08 mars 2017, 13:59

Salut les gars,

J'ai créer 2 templates pour les wanscam HW0045 et HW0021 je vais les envoyer a la team Jeedom mais je met ici celle de la 45 pour ceux qui veulent (il faut supprimer l'extension .txt de la template json et copier les fichier ds le répertoire /plugins/camera/core/config/devices/)

Chez moi le zoom marche bien sur la HW0045 avec les commandes zoom+ /cgi-bin/hi3510/ptzzoomin.cgi?usr=#username#&pwd=#password# et zoom- /cgi-bin/hi3510/ptzzoomout.cgi?usr=#username#&pwd=#password#


Concernant le preview ds le navigateur je suis aussi emm***er, pas de window a la maison en plus...., même avec Synology surveillance je ne peux pas les voir.
J'utilise donc les applis ( 7view et DSCam) sur smartphone/tablette et Jeedom pour le PC.

@++
Pièces jointes
wanscam.hw0045.jpg
wanscam.hw0045.jpg (158.03 Kio) Consulté 8684 fois
wanscam.hw0045.json.txt
(6.84 Kio) Téléchargé 297 fois
Jeedom debian sur esxi
z-wave (Fibaro, Everspring, Qubino ...), RFXCom (Chacon), Synology Diskstation, Camera Heden, ... (détails)
Sur l'irc salon #jeedom
Plugin: worxLandoid

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 08 mars 2017, 14:38

Salut virux,

Merci pour le partage que tu mets à disposition. C'est sympa de ta part.
Perso j'utilise la HW0045 au travers du plug Caméra. J'ai définis les commandes proposées par Rosty auxquelles j'ai ajouté tes propositions sous la forme:
/cgi-bin/hi3510/ptzzoomin.cgi? et /cgi-bin/hi3510/ptzzoomout.cgi? (j'ai amputé du user/pswd)
Cela fonctionne nickel.

Image
(mérite à mettre au compte de rosty et virux)

J'uitilise tinycam sur la smartphone avec succès. J'aurais néanmoins aimé obtenir un résultat avec un navigateur sous W10 comme il est indiqué que cela doive fonctionner dans le descriptif de la caméra.
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 08 mars 2017, 15:04

Je viens de faire un essai avec Opera + flash installé. Le canard est toujours vivant ou plutôt mort car l'écran reste noir et toujours pas les boutons de commandes sous l'écran comme pas plus d'option de détection de mouvement :(
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

Avatar de l’utilisateur
virux
Timide
Messages : 249
Inscription : 21 juil. 2014, 08:49
Localisation : Lorraine

Re: Paramétrage caméra IP Wanscam HW0045

Message par virux » 08 mars 2017, 15:12

J'ai un peu plus de chance, je viens de réussir a faire marcher l'affichage du serveur buildin sous ubuntu avec firefox ( et chromium), plugin flash et package gstreamer installer ( mais pas sur qu'il faut que ça avec tout ce que j'ai bidouiller) ... ( mais pas via le synology)
Jeedom debian sur esxi
z-wave (Fibaro, Everspring, Qubino ...), RFXCom (Chacon), Synology Diskstation, Camera Heden, ... (détails)
Sur l'irc salon #jeedom
Plugin: worxLandoid

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 08 mars 2017, 19:04

virux a écrit :J'ai un peu plus de chance, je viens de réussir a faire marcher l'affichage du serveur buildin sous ubuntu avec firefox ( et chromium), plugin flash et package gstreamer installer ( mais pas sur qu'il faut que ça avec tout ce que j'ai bidouiller) ... ( mais pas via le synology)
Cours acheter un billet de loterie, des fois que.....dans la foulée :roll:
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

Avatar de l’utilisateur
virux
Timide
Messages : 249
Inscription : 21 juil. 2014, 08:49
Localisation : Lorraine

Re: Paramétrage caméra IP Wanscam HW0045

Message par virux » 08 mars 2017, 19:20

2€ \o/
Non je rigole :p
Pas moyen de faire fonctionné via le syno, mais c'est un vieux problème de ce que j'ai pu lire un peu partout le H264 a pas les faveurs des navigateurs :(

.
Jeedom debian sur esxi
z-wave (Fibaro, Everspring, Qubino ...), RFXCom (Chacon), Synology Diskstation, Camera Heden, ... (détails)
Sur l'irc salon #jeedom
Plugin: worxLandoid

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 08 mars 2017, 19:44

Sans doute mais toujours est-il que je ne rencontre pas de problème avec n'importe quel navigateur et les caméras suivantes:
Hikvision dôme 4MP H264/H265
Dericam 720P
Tenvis 720P
La meilleure étant sans conteste la Hikvision. Si j'avais su...!

Je me demande s'il existe une source pour obtenir un firmware up to date voir alternatif. Dans mon cas il manque des options dans les paramètres.
J'aurais aimé avoir l'avis de M. Wanscam mais ce n'est pas à l'ordre du jour.

Personne ne s'est manifesté en précisant par exemple que la visu est possible au travers d'un navigateur (lequel, dans quel environnement...).
Doit-on en déduire que cela n'est pas possible, auquel cas nous serions frappés de "menterie" :cry:
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 08 mars 2017, 21:34

Pour ceux qui ont suivi le fil de ce topic, vous savez qu'aucun navigateur sous Win10 ne me permet de visualiser en live la caméra HW0045.

A force de perséverance j'ai obtenu un résultat.

Ce que j'ai fait:

- installation de IETester: http://www.my-debugbar.com/ietester/ins ... v0.5.4.exe
- lancer ietester
- dans les icônes, sur la droite, je choisis "IE par défaut" (je n'ai pas testé toutes les émulations)
- sous l'onglet qui s'ouvre, dans la barre d'adresse, je rentre l'IP de la caméra "http://@ip:port" puis Entrée
- entrer les identifiants
- si "Erreur de script" j'ai cliqué sur "Oui" (à approfondir)
- la page principale de la cam s'ouvre avec la vidéo et les boutons de commande associés
- la cam répond aux commandes depuis le navigateur
- Cerise sur le gâteau: j'ai retrouvé les options manquantes dans les paramètres (ex: Motion detection)

J'ai rencontré un problème suite à plusieurs lancements de l'émulation "IE par défaut". En fermant et relancant IETester j'ai de nouveau pu me connecter correctement.
Ce n'est peut-être pas une solution définitive mais elle m'a permis de voir, pour la première fois, la vidéo de la caméra et de pouvoir la paramétrer.

Si cela peut aider....
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

christlep
Actif
Messages : 629
Inscription : 13 janv. 2015, 23:17
Localisation : France - 38 - Nord Isére

Re: Paramétrage caméra IP Wanscam HW0045

Message par christlep » 08 mars 2017, 21:53

Je suis sous win 10 et chez moi j'ai la vidéo aussi bien sur IE que sur FireFox.

Il y a un post sur le forum où il est dit qu'il y a un "truc" à faire sur IE (à part installé OCX) mais je sais plus où ni quoi :oops:
C'est peut etre sur le site de @rosty :oops:

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 08 mars 2017, 22:23

Suite de la saga....

Il est indiqué que le navigateur fonctionnant avec la cam est Internet Explorer.
J'utilisais Edge qui est le navigateur remplaçant IE dans Windows 10.
En fait on trouve toujours IE 11 dans Windows 10 : Toutes les applications / Accessoires Windows / Internet Explorer
Contrairement à Edge, Internet Explorer 11 fonctionne avec la HW0045. Par contre aucun résultat avec tous les autres navigateurs chez moi.
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Paramétrage caméra IP Wanscam HW0045

Message par Fabrice » 09 mars 2017, 07:18

Regardez ma réponse précédente (la fin) au sujet de Edge et IE.

Un OCX c'est un activeX, et Edge ne prend pas en charge l'installation des activeX. Pour information, Internet Explorer est présent dans Windows 10, juste pour la rétro compatibilité avec ce genre de trucs.
Microsoft pousse vers l'utilisation de Edge chez le particulier, mais conserve uniquement Internet Explorer dans l'édition Entreprise pas exemple. Les entreprises on du mal encore à se passer d'Internet Explorer. Entre autre, à cause des activeX.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 09 mars 2017, 11:52

@Fabrice

Tout à fait d'accord. C'est aussi la raison pour laquelle l'install de l'OCX n'avait pas d'effet car Edge était utilisé dans mon cas.
Je n'avais pas vu que le message avait été édité. J'aurais gagné qq heures de recherche.
Merci pour l'implication.
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

jimdu1.4
Timide
Messages : 51
Inscription : 04 déc. 2016, 18:18

Re: Paramétrage caméra IP Wanscam HW0045

Message par jimdu1.4 » 31 mars 2017, 16:12

Bonjour,

Je vient de recevoir la wanscam HW0045 1080P .

Tout est bien configuré j'ai juste une question concernant l'affichage du plugin camera sur le dashboard, j'ai une latence élevé à la réception du flux vidéo sur Jeedom alors que dans le navigateur c'est presque du direct. Cela est normal ou y'a t'il un réglage pour réduire ce temps de latence ?

A bientôt

Avatar de l’utilisateur
matric
Timide
Messages : 470
Inscription : 11 nov. 2014, 20:17
Localisation : Aquitaine

Re: Paramétrage caméra IP Wanscam HW0045

Message par matric » 31 mars 2017, 18:49

Bonjour jimdu1.4,

Si c'est bien de latence dont tu parles, chez moi j'ai un affichage à la seconde sachant que le plug caméra t'affiche des images et non pas un flux vidéo continu, ce que j'obtiens comme toi via le navigateur ou en passant par tinycam.

Ma config (standard) est la suivante:
Image

Je te ferai grâce de l'endroit actuel où je me trouve, 800km de la maison, via une connexion dont la qualité est aléatoire et via un vpn, c'est de l'ordre de 15s mais évidemment rien à voir avec l'interface Jeedom qui n'est pas en cause.
Jeedom sur NUC - Debian 9 Stretch - RFXcom433E USB - Z-Wave.ME USB - Clé 3G USB Huawei E1552 - NAS Qnap

Répondre

Revenir vers « Discussions Générales »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité