Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

zigbee2mqtt, passerelle low cost

Pour parler de tout, et surtout de rien !
Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 03 mars 2019, 22:54

Merci alexp pour ta patience. ;)
J'ai bien fait ce que tu m'a dit dans mon opt/zigbee2mqtt/configuration.yaml
homeassistant: false
permit_join: false
mqtt:
base_topic: zigbee2mqtt
server: 'mqtt://localhost'
serial:
port: /dev/ttyACM0
disable_led: true
advanced:
cache_state: false
log_level: debug
devices:
J'ai essayé aussi avec log_level: info, ainsi que les commandes que tu m'a données et malheureusement toujours le même problème de démarrage de zigbee2mqtt. :cry:
Je ne sais pas si cela peut aider, mais lorsque je lance ma commande npm start pour voir mes sonde dans le terminal, tout est OK,je les vois bien et chaque changement de valeur d'une de ces sondes, me génère une ligne dans le terminal. Or pour lancer cette commande "npm start" je doit être en mode "root" car sinon cela me met une erreur d'accès si je reste en mode utilisateur. Peut être que cela a un rapport?

alexp
Timide
Messages : 25
Inscription : 07 janv. 2019, 12:24

Re: zigbee2mqtt, passerelle low cost

Message par alexp » 03 mars 2019, 23:23

Code : Tout sélectionner

ls -alsh --color /opt/zigbee2mqtt
Ca te donne bien sebastien:sebastien ? (sauf sur la seconde ligne, root:root)
Si ce n'est pas le cas :

Code : Tout sélectionner

 sudo chown -R sebastien:sebastien /opt/zigbee2mqtt
Mais à voir, c'est peut être juste Mosquitto qui ne se lance pas ou est mal configuré.

alexp
Timide
Messages : 25
Inscription : 07 janv. 2019, 12:24

Re: zigbee2mqtt, passerelle low cost

Message par alexp » 03 mars 2019, 23:36

pour voir si zigbee2mqtt publie bien sur le broker mqtt tu peux lancer la commande :

Code : Tout sélectionner

mosquitto_sub -t "#" -v| xargs -d$'\n' -L1 bash -c 'date "+%Y-%m-%d %T.%3N $0"'

Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 04 mars 2019, 06:34

Alexp, j'essaie ça ce soir après le boulot et je te te tiens au courant 😉.

Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 04 mars 2019, 18:11

Bonsoir à tous.
Alexp, comme tu me l'a conseillé, j'ai essayé la commande: sebastien@jeedom:~$ ls -alsh --color /opt/zigbee2mqtt .
Et voici le resultat des 2 premières lignes:
total 300K
4,0K drwxr-xr-x 13 sebastien sebastien 4,0K mars 2 16:57 .
4,0K drwxr-xr-x 5 root root 4,0K mars 2 15:55 ..

Puis comme tu me l'a conseillé aussi, voici le résultat après la 2ème commande que tu m'a donné:
sebastien@jeedom:~$ mosquitto_sub -t "#" -v| xargs -d$'\n' -L1 bash -c 'date "+%Y-%m-%d %T.%3N $0"'
2019-03-04 17:43:41.569 jeedom/status offline
2019-03-04 17:43:41.574 Zigbee2mqtt/status offline
2019-03-04 17:43:41.578 zigbee2mqtt/bridge/state offline
2019-03-04 17:43:41.582 zigbee2mqtt/status online
On vois bien que tout est offline. Je vais essayer de réinstaller mosquito au cas où :|

alexp
Timide
Messages : 25
Inscription : 07 janv. 2019, 12:24

Re: zigbee2mqtt, passerelle low cost

Message par alexp » 04 mars 2019, 18:37

C'est normal le offline car zigbee2mqtt n'est pas démarré par contre mosquitto est bien démarré lui.
Lance zigbee2mqtt avec la commande sudo npm start (tu as dit que ça se lançait) puis dans un second terminal relance la commande

Code : Tout sélectionner

mosquitto_sub -t "#" -v| xargs -d$'\n' -L1 bash -c 'date "+%Y-%m-%d %T.%3N $0"'
pour voir si ça passe en online, si oui regarde dans jeedom si tu vois bien les publications en online également.
Si tu est toujours en offline c'est un problème de conf je pense, zigbee2mqtt n'a pas les droits pour publier sur mosquitto ou bien jeedom ne lit pas les publications de mosquitto.

Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 04 mars 2019, 22:40

Suite à ta commande, j'ai bien une modification de statut sur la 3ème ligne
2019-03-04 22:33:15.204 jeedom/status offline
2019-03-04 22:33:15.208 Zigbee2mqtt/status offline
2019-03-04 22:33:15.212 zigbee2mqtt/bridge/state online
2019-03-04 22:33:15.216 zigbee2mqtt/status online
Par contre en réinstallant zigbee2mqtt j'ai deja un mieu au niveau des services en lançant la commande
sudo systemctl status zigbee2mqtt
Je n'ai plus de message d'erreur.

Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 04 mars 2019, 23:08

Mais toujours pas de remontés d'info à jeedom lorsque le terminal avec la commande npm start est fermé. Dès que j'ouvre un autre terminal avec la commande npm start les valeurs remontent instantanément.

Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 04 mars 2019, 23:14

Pour info, le resultat de la commande de statut avec zigbee2mqtt.service
sebastien@jeedom:~$ systemctl status zigbee2mqtt.service
● zigbee2mqtt.service - zigbee2mqtt
Loaded: loaded (/etc/systemd/system/zigbee2mqtt.service; enabled; vendor pres
Active: active (running) since Mon 2019-03-04 21:41:31 CET; 1h 28min ago
Main PID: 462 (npm)
Tasks: 23 (limit: 4915)
CGroup: /system.slice/zigbee2mqtt.service
├─462 npm
├─718 sh -c node index.js
└─719 node index.js
Ce que je n'avait pas hier, donc un progrès.
Reste plus que cette histoire de remontée d'infos.
Bonne nuit ;)

Avatar de l’utilisateur
propositionjoe
Timide
Messages : 302
Inscription : 17 févr. 2016, 21:39
Contact :

Re: zigbee2mqtt, passerelle low cost

Message par propositionjoe » 05 mars 2019, 06:51

Sebtis77 a écrit :
04 mars 2019, 23:14
Ce que je n'avait pas hier, donc un progrès.
Reste plus que cette histoire de remontée d'infos.
Bonne nuit ;)
Tu as bien installé le plugin Jmqtt sur jeedom?
Proxmox avec VM jeedom
Zigbee2mqtt, Broadlink, Zwave, Blea, Tasmotta, EspEasy
Mon blog: https://carmagnole.ovh

Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 05 mars 2019, 07:00

propositionjoe a écrit :
05 mars 2019, 06:51
Sebtis77 a écrit :
04 mars 2019, 23:14
Ce que je n'avait pas hier, donc un progrès.
Reste plus que cette histoire de remontée d'infos.
Bonne nuit ;)
Tu as bien installé le plugin Jmqtt sur jeedom?
Bonjour propositionjoe.
Oui j'ai bien installé jMQTT sur mon jeedom😉.
J'ai mes commandes qui s'affichent au fur et à mesure que je connecte mes sondes Xiaomi.
Mais dès que je ferme mon terminal sur lequel est lancé la commande npm start, les valeurs dans jMQTT reste figées.

romanais
Actif
Messages : 1999
Inscription : 21 août 2014, 21:36
Localisation : Drôme

Re: zigbee2mqtt, passerelle low cost

Message par romanais » 05 mars 2019, 08:48

Que les valeurs restent figées quand tu fermes la console c'est "normal", puisque ça coupe le process.
C'est pour cela que dans le tuto il y a l'explication pour créer un service qui tournera en permanence en tâche de fond (et du coup c'est sur ça qu'il faut se concentrer : arriver à mettre ce service en place).
Voilà comment j'ai procédé pour avoir un système fonctionnel.
Lors de mes premiers tests j'avais aussi eu un bug avec la création/lancement du service (y compris sur un Rpi sans Jeedom).
J'avais tout désinstallé et repris proprement et par étape et c'était passé.
J'ai depuis fait 3 installations sans problème.
viewtopic.php?p=691816#p691816
Merci à toute l'équipe pour le taf

Mon matériel

Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 05 mars 2019, 10:03

Bonjour à tous.
Romanais, j'ai bien créer le fichier de configuration syctemctl avec cette commande: sudo nano /etc/systemd/system/zigbee2mqtt.service en mettant comme User sebastien.
Puis j'ai lancer le service via la commande: sudo systemctl start zigbee2mqtt,
Ensuite vérifier que tous fonctionne via la commande : sudo systemctl status zigbee2mqtt (Depuis hier, tout est OK) à ce niveau suite à la réinstallation de zigbee2mqtt.
J'ai également lancé cette commande : sudo systemctl enable zigbee2mqtt.service pour que le service démarre automatiquement.
Dans Jmqtt j'ai bien mes commandes qui remontent mais uniquement quand la commande npm start est lancer dans un terminal. Dès que je ferme ce terminal, les valeurs restent figées dans Jmqtt. La seule choses que n'ai pas fait hier c'est de désinstaller et réinstaller Jmqtt après avoir réinstaller zigbee2mqtt, ce que je vais faire ce soir.

Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 06 mars 2019, 21:40

Bonsoir à tous.
Ça y est, ça fonctionne :D . J'ai fait comme romanais m'a conseillé, j'ai tout repris de 0 ;) . Également, je pense (quasiment sur) que mon problème venait de mon fichier configuration.yaml. :? Je renommait les devices avec des espaces entre chaque mot exemple (Salle de bain) au lieu de (Salle_de_bain). J'ai lu quelque part que mqtt n'aimait pas ça :roll: . En tout cas merci à tout ceux qui m'ont aidés, également je tenais à les remercier pour leurs patiences et leurs conseils. ;)

romanais
Actif
Messages : 1999
Inscription : 21 août 2014, 21:36
Localisation : Drôme

Re: zigbee2mqtt, passerelle low cost

Message par romanais » 07 mars 2019, 09:18

Super ! C'est vrai que la structure du yaml est très stricte.
J'avais testé ton code avec https://codebeautify.org/yaml-validator
Et ça ne renvoyait pas d'erreur (mais c'était avant que je sache que tu renommais tes modules avec des espaces ;-)
Merci à toute l'équipe pour le taf

Mon matériel

Avatar de l’utilisateur
raqpub
Timide
Messages : 275
Inscription : 04 juin 2015, 08:21
Localisation : Earth

Re: zigbee2mqtt, passerelle low cost

Message par raqpub » 10 mars 2019, 10:18

picsou83 a écrit :
15 nov. 2018, 13:11
Hello,

J'apporte ma pierre à l'édifice :

J'ai acheté pour 13 euros:
CC2531 Sniffer Protocol Analyzer USB Dongle + câble Downloader for Zigbee => 8 euros (ebay)
Zigbee Emulator Debugger Programmer Support CC2531=> 5 euros (ebay)

Branché sur raspberry , j'ai flashé la clé
...
...
...
Bonjour picsou83,

Moins de chance que toi avec mon CCDebug clone car il n'est pas détecté par Windows XP, 7 et 10 et pas non plus avec mon raspbian.
Du coup je t'ai fait un MP si tu as une idée.

le CC2531 lui est reconnu.

Merci

vince66170
Timide
Messages : 11
Inscription : 22 déc. 2018, 14:28

Re: zigbee2mqtt, passerelle low cost

Message par vince66170 » 11 mars 2019, 17:49

bonjour tous le monde, je suis un peu ce sujet et je suis interessé par cette passerelle faite maison.
J'ai trouvé pas sur ebay, vous penssez que sa fonctionne pour jeedom? cela me ferais gagner pas mal de temps :
https://www.ebay.fr/itm/CC2531-ZigBee-U ... SwtNlcdrcL

merci

romanais
Actif
Messages : 1999
Inscription : 21 août 2014, 21:36
Localisation : Drôme

Re: zigbee2mqtt, passerelle low cost

Message par romanais » 11 mars 2019, 18:12

C'est possible qu'il vende simplement une clé flashée et que ça marche pour ce que tu veux faire.
Ça reste cher vu le prix de la clé en temps normal.
Tout compris pour la programmation j'en avais eu pour 14euros chez Ali, les clés suivantes étaient à 5 euros.
Merci à toute l'équipe pour le taf

Mon matériel

Sebtis77
Timide
Messages : 46
Inscription : 18 janv. 2019, 06:49

Re: zigbee2mqtt, passerelle low cost

Message par Sebtis77 » 11 mars 2019, 21:53

@Vince66170: À mon avis, il faut poser la question au vendeur 😅. À savoir si la clé est flasher pour jeedom.

vince66170
Timide
Messages : 11
Inscription : 22 déc. 2018, 14:28

Re: zigbee2mqtt, passerelle low cost

Message par vince66170 » 12 mars 2019, 21:18

Lol je lui ai demandé, il en sait rien..

Répondre

Revenir vers « Discussions Générales »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 5 invités