Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

Synchroniser son réveil avec Jeedom et Tasker

Pour parler de tout, et surtout de rien !
team18fr
Actif
Messages : 1119
Inscription : 11 oct. 2014, 18:41

Synchroniser son réveil avec Jeedom et Tasker

Message par team18fr » 15 mars 2019, 19:31

Bonjour à tous,
Il y a quelque temps de cela j'avais suivie le Tuto de SARAKha63 Synchroniser son réveil avec Jeedom et Tasker et tous fonctionné.
Mais depuis la mise à jour en 3.3 j'ai un message d'erreur :

Code : Tout sélectionner

Vous n'êtes pas autorisé à effectuer cette action 1, IP : 192.168.1.xx
Et voici les commandes qui sont envoyées depuis Tasker :

Code : Tout sélectionner

https://URLJEEDOM/core/api/jeeApi.php?apikey=APIKEYJEEDOM&type=virtual&id=IDCMD&value=%taskertime
Et je rappel que ça marché très bien avant.

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par Mips2648 » 15 mars 2019, 19:40

Il faut utiliser la clé api du plugin obligatoirement dorénavant et plus la clé jeedom
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
poluket
Helper
Messages : 1908
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par poluket » 15 mars 2019, 19:41

Il y a eu un changement de clé api. Il y en a une par plugin. Vérifie qu'elle est bien celle de ton plugin
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

team18fr
Actif
Messages : 1119
Inscription : 11 oct. 2014, 18:41

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par team18fr » 15 mars 2019, 20:17

Merci c'est tout bon.

lilp
Timide
Messages : 93
Inscription : 10 janv. 2018, 10:22

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par lilp » 03 mai 2019, 08:40

Salut, n'aurais-tu pas un soucis depuis la nouvelle version de Tasker avec la remontée du réveil?
Tasker déclenche mon scénario du matin à l'heure où il récupère l'heure du prochain réveil. Mon téléphone android vois aussi le prochain réveil à l'heure du prochain déclenchement de Tasker et non l'heure du véritable réveil.

team18fr
Actif
Messages : 1119
Inscription : 11 oct. 2014, 18:41

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par team18fr » 04 mai 2019, 15:09

Non je n'ai pas remarqué de problème. L’heure est bien configuré et sonne au bon moments.

lilp
Timide
Messages : 93
Inscription : 10 janv. 2018, 10:22

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par lilp » 06 mai 2019, 21:40

Pourrais-tu me partager ta partie tasker ?
tu utilises toujours autoalarm

team18fr
Actif
Messages : 1119
Inscription : 11 oct. 2014, 18:41

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par team18fr » 08 mai 2019, 12:10

Je suivi le tuto à la lettre et oui j'utilise autoalarm. Et donc pour la partie tasker j'ai exactement comme sur le tuto.
La seul chose que j'ai changé c'est la clés API.

KingNoobert
Timide
Messages : 44
Inscription : 25 mars 2018, 21:09

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par KingNoobert » 04 juin 2019, 07:51

lilp a écrit :
03 mai 2019, 08:40
Salut, n'aurais-tu pas un soucis depuis la nouvelle version de Tasker avec la remontée du réveil?
Tasker déclenche mon scénario du matin à l'heure où il récupère l'heure du prochain réveil. Mon téléphone android vois aussi le prochain réveil à l'heure du prochain déclenchement de Tasker et non l'heure du véritable réveil.
Salut, je viens de suivre le tuto de sarakha, et j'ai eu le même problème. Pour le régler il suffit d'aller dans les paramètres de tasker, onglet moniteur et passer "utiliser des alarmes fiables" sur Jamais et reboot le tel.

En faite dans le plugin autoalarm, si tu fais TEST, il te donne la solution :)

J'espère avoir pu t'aider. Bonne journée

MatJo
Timide
Messages : 8
Inscription : 18 avr. 2019, 09:53

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par MatJo » 20 juin 2019, 10:57

Salut !
Merci a tous pour votre aide ! J'ai suivi le tuto de SARAKha63 mais de mon côté je n'arrive pas a récupérer les variables du plugin AutoAlarm dans Tasker. Elles s'affichent bien dans le plugin avec les bonnes valeurs mais dans Tasker elles sont vides... Avez vous déjà rencontré ce soucis ?

lilp
Timide
Messages : 93
Inscription : 10 janv. 2018, 10:22

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par lilp » 27 juin 2019, 11:30

KingNoobert a écrit :
04 juin 2019, 07:51
lilp a écrit :
03 mai 2019, 08:40
Salut, n'aurais-tu pas un soucis depuis la nouvelle version de Tasker avec la remontée du réveil?
Tasker déclenche mon scénario du matin à l'heure où il récupère l'heure du prochain réveil. Mon téléphone android vois aussi le prochain réveil à l'heure du prochain déclenchement de Tasker et non l'heure du véritable réveil.
Salut, je viens de suivre le tuto de sarakha, et j'ai eu le même problème. Pour le régler il suffit d'aller dans les paramètres de tasker, onglet moniteur et passer "utiliser des alarmes fiables" sur Jamais et reboot le tel.

En faite dans le plugin autoalarm, si tu fais TEST, il te donne la solution :)

J'espère avoir pu t'aider. Bonne journée
Merci pour l'information, effectivement cela re fonctionne.

J'avais abandonné depuis, je le faisais en manuellement. Réveil programmé tous les jours ouvrés, et je le désactivait en passant en mode vacances.

Avatar de l’utilisateur
GargouilleBL
Timide
Messages : 253
Inscription : 26 janv. 2017, 09:31
Localisation : Sprimont (Province de Liège - Belgique)

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par GargouilleBL » 06 sept. 2019, 09:32

Bonjour à toutes et tous,
J'ai un petit soucis avec le réveil par Tasker, j'ai suivi comme tout le monde ici le tuto à la lettre.
Je vous explique: dans le scénario j'ai des actions qui se font avant mon réveil, lumières, chauffage salon, café, etc... Jamais de problème avec. Par contre j'ai également des actions qui se font après, genre chauffage salle de bain 1/4h après le réveil, coupé la prise café, etc...
Du lundi au jeudi elles se déclenchent bien, le problème c'est le vendredi, les actions avant se déclenchent, mais à 6h15 (heure de mon alarme) , Tasker envoi à Jeedom la prochaine alarme donc lundi, comme le lendemain samedi, pas de réveil, la condition

Code : Tout sélectionner

Evaluation de la condition : [2 == 0 ET "9/9/2019-lun. 06:16-2" != "Aucun"  ] = Faux
est fausse d'où remove_inat est lancé et toutes les actions qui devaient se faire après ne se font plus.
Je ne sais pas si j'ai été clair.
Je ne vois pas se que je dois modifier pour ne plus avoir de problème le vendredi

Merci d'avance pour votre aide
@+ GargouilleBL
Jeedom V3.3.19 sur VM ProxMox - Clef Usb Z-Wave - Clef Usb RfxCom
Caméras D-Link + Reolink, Oeil Fibaro, Rubans Leds Yeelight, Variateurs Fibaro, Ampoules Led Z-Wave, Clavier RFID, Vannes Thermostat Danfoss, Ampoules IKEA, SNIPS, etc...

madcow
Timide
Messages : 299
Inscription : 06 févr. 2019, 21:41

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par madcow » 06 sept. 2019, 10:17

Bonjour,

Problème intéressant !

Comme ça en bourrin je te dirais de lancer les actions prévues après ton réveil le vendredi (si vendredi alors lancement scénario N°2) dans un autre scénario pour que le remove_inat ne les annule pas.

Il y a peut être mieux à faire en modifiant ta condition. Par exemple si journée == lundi alors ne rien faire.
C'est ce que j'utilise pour éviter de réaliser les actions "départ boulot" le week end tout en gardant la possibilité de mettre un réveil sur mon téléphone.
DIY Proxmox sur HP Proliant
Débutant sur Jeedom

Avatar de l’utilisateur
GargouilleBL
Timide
Messages : 253
Inscription : 26 janv. 2017, 09:31
Localisation : Sprimont (Province de Liège - Belgique)

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par GargouilleBL » 06 sept. 2019, 12:25

Super merci, je vais modifier la condition
Jeedom V3.3.19 sur VM ProxMox - Clef Usb Z-Wave - Clef Usb RfxCom
Caméras D-Link + Reolink, Oeil Fibaro, Rubans Leds Yeelight, Variateurs Fibaro, Ampoules Led Z-Wave, Clavier RFID, Vannes Thermostat Danfoss, Ampoules IKEA, SNIPS, etc...

lilp
Timide
Messages : 93
Inscription : 10 janv. 2018, 10:22

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par lilp » 12 sept. 2019, 10:26

J'ai changé de téléphone.
Réinstaller Tasker, importer ma sauvegarde, bien désactivé les reliable alarmes.

Cependant, lorsque je fait un test d'alarme qui devrait remonté 07h10. Et j'ai les résultats suivants :
NOTE: This will not work correctly if the 'Relible Alarms' option is enabled in Tasker.

Time now is: Thu Sep 12 10:18:55 GMT+02:00 2019

Next alarm detected: Thu Sep 12 11:00:00 GMT+02:00 2019

You can use these variables in Tasker in the entry Task of an AutoAlarm condition:
%hours: 0,68
%daysc: 0
%dayweek: 5
%year: 2019
%minutes: 41,08
%raw: jeu. 11:00
%shortdayname: jeu.
%milis: 2464616
%error: null
%minutesc: 41
%minute: 0
%second: 0
%taskertime: 11:00
%seconds: 2464,62
%hour: 11
%month: 9
%dayname: jeudi
%secondsc: 4
%days: 0,03
%day: 12
%hoursc: 0


Je n'ai qu'une alarme de prévu le matin à 07h10, je ne voit pas d'ou vient le 11h.

J'ai tenté de supprimer et réinstaller Tasker et Autoalarm, j'ai recréer les profils à la main. Mais j'ai toujours plusieurs remontés quotidiennes d'alarmes par Autoalarm, sans que je ne sache d'où elles viennent.

Je n'ai qu'un réveil (j'ai supprimé et non pas désactivé les autres), même les jours sans rendez-vous dans mes calendriers.
Dernière édition par lilp le 01 oct. 2019, 11:01, édité 2 fois.

Mydlina
Timide
Messages : 25
Inscription : 16 déc. 2017, 13:44

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par Mydlina » 16 sept. 2019, 21:09

lilp a écrit :
12 sept. 2019, 10:26
J'ai changé de téléphone.
Réinstaller Tasker, importer ma sauvegarde, bien désactivé les reliable alarmes.

Cependant, lorsque je fait un test d'alarme qui devrait remonté 07h10. Et j'ai les résultats suivants :
NOTE: This will not work correctly if the 'Relible Alarms' option is enabled in Tasker.

Time now is: Thu Sep 12 10:18:55 GMT+02:00 2019

Next alarm detected: Thu Sep 12 11:00:00 GMT+02:00 2019

You can use these variables in Tasker in the entry Task of an AutoAlarm condition:
%hours: 0,68
%daysc: 0
%dayweek: 5
%year: 2019
%minutes: 41,08
%raw: jeu. 11:00
%shortdayname: jeu.
%milis: 2464616
%error: null
%minutesc: 41
%minute: 0
%second: 0
%taskertime: 11:00
%seconds: 2464,62
%hour: 11
%month: 9
%dayname: jeudi
%secondsc: 4
%days: 0,03
%day: 12
%hoursc: 0


Je n'ai qu'une alarme de prévu le matin à 07h10, je ne voit pas d'ou vient le 11h.
Bonjour,

J'ai le même souci. Lorsque je mets mon reveil à 06h00 pour le lendemain, le plugin me dit 00h00
j'ai testé plusieurs alarme mais en vain.

pourtant la date est bonne.

Si quelqu'un à des pistes pour débloquer la situation je suis preneur.
NUC Intel: Jeedom 3.3.18

team18fr
Actif
Messages : 1119
Inscription : 11 oct. 2014, 18:41

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par team18fr » 23 sept. 2019, 22:28

Salut je viens de remarquer quelque chose concernant le profil 22H00 / 6H00.
Il est considérait comme une alarme et donc ma prochaine alarme est 22h00 et non pas le réveil que j'ai programmé.
Si vous avez la solution je suis preneur.

lilp
Timide
Messages : 93
Inscription : 10 janv. 2018, 10:22

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par lilp » 01 oct. 2019, 10:54

Mydlina a écrit :
16 sept. 2019, 21:09
lilp a écrit :
12 sept. 2019, 10:26
J'ai changé de téléphone.
Réinstaller Tasker, importer ma sauvegarde, bien désactivé les reliable alarmes.

Cependant, lorsque je fait un test d'alarme qui devrait remonté 07h10. Et j'ai les résultats suivants :
NOTE: This will not work correctly if the 'Relible Alarms' option is enabled in Tasker.

Time now is: Thu Sep 12 10:18:55 GMT+02:00 2019

Next alarm detected: Thu Sep 12 11:00:00 GMT+02:00 2019

You can use these variables in Tasker in the entry Task of an AutoAlarm condition:
%hours: 0,68
%daysc: 0
%dayweek: 5
%year: 2019
%minutes: 41,08
%raw: jeu. 11:00
%shortdayname: jeu.
%milis: 2464616
%error: null
%minutesc: 41
%minute: 0
%second: 0
%taskertime: 11:00
%seconds: 2464,62
%hour: 11
%month: 9
%dayname: jeudi
%secondsc: 4
%days: 0,03
%day: 12
%hoursc: 0


Je n'ai qu'une alarme de prévu le matin à 07h10, je ne voit pas d'ou vient le 11h.
Bonjour,

J'ai le même souci. Lorsque je mets mon reveil à 06h00 pour le lendemain, le plugin me dit 00h00
j'ai testé plusieurs alarme mais en vain.

pourtant la date est bonne.

Si quelqu'un à des pistes pour débloquer la situation je suis preneur.
Sous quel marque de téléphone est-tu et sous quel rom?

Essaie de télécharger l'application Horloge de G, de supprimer l'alarme via l'application préinstallé et d'utiliser celle de G.

lilp
Timide
Messages : 93
Inscription : 10 janv. 2018, 10:22

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par lilp » 18 nov. 2019, 14:21

Devant mon incapacité à résoudre mon soucis avec Tasker, j'ai finit pas désactiver mon scénario du matin. J'en suis bien déçu.

team18fr
Actif
Messages : 1119
Inscription : 11 oct. 2014, 18:41

Re: Synchroniser son réveil avec Jeedom et Tasker

Message par team18fr » 18 nov. 2019, 19:32

Moi j'avais aussi le problème de la mauvaise heure et je me suis aperçu que même les alarme de tasker était prise en compte.
J'ai résolu mon problème avec Tasker > Préférences > Moniteur > Utiliser des alarmes fiables > Jamais. Et rebooter le téléphone.

Répondre

Revenir vers « Discussions Générales »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 5 invités