Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Statut Demon NOK

(anciennement dénommé plugin OpenZwave)
Répondre
zigjack
Timide
Messages : 192
Inscription : 06 sept. 2016, 09:31

Statut Demon NOK

Message par zigjack » 08 sept. 2016, 21:14

Hello a tous!

Je suis un grand newbie dans la domotique, je viens juste de me lancer dans ma 1° installation.
Tout s est pas trop mal passé jusqu'a ce que je connecte ma clé USB zstick aeotec gen5, j ai pris le plugin Zwave, suivi la doc, tout s est bien passé sauf le statut du demon qui reste bloqué en NOK...
Lorsque je regarde le log, j ai ca:

[2016-09-08 21:10:04][INFO] : Lancement démon openzwave : /usr/bin/python /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py --pidfile=/tmp/openzwaved.pid --device=auto --loglevel=debug --port=8083 --config_folder=/var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/config --data_folder=/var/www/html/plugins/openzwave/core/class/../../data --callback=http://127.0.0.1:80/plugins/openzwave/c ... eZwave.php --apikey=93MjBTIa252wgePtIu3Wp9pxJlRZI3r6wsI4qciCI9wZHVuW --serverId=0 --suppressRefresh=0
[2016-09-08 21:10:05][INFO] : Start openzwaved
[2016-09-08 21:10:05][INFO] : Log level : debug
[2016-09-08 21:10:05][DEBUG] : PID file : /tmp/openzwaved.pid
[2016-09-08 21:10:05][INFO] : Device : auto
[2016-09-08 21:10:05][DEBUG] : Apikey : 93MjBTIa252wgePtIu3Wp9pxJlRZI3r6wsI4qciCI9wZHVuW
[2016-09-08 21:10:05][INFO] : Callback : http://127.0.0.1:80/plugins/openzwave/c ... eZwave.php
[2016-09-08 21:10:05][INFO] : Cycle : 0.3
[2016-09-08 21:10:05][DEBUG] : Initial disabled nodes list: []
[2016-09-08 21:10:05][DEBUG] : Init request module v2.4.3
[2016-09-08 21:10:05][INFO] : Starting new HTTP connection (1): 127.0.0.1
[2016-09-08 21:10:05][DEBUG] : "GET /plugins/openzwave/core/php/jeeZwave.php?apikey=93MjBTIa252wgePtIu3Wp9pxJlRZI3r6wsI4qciCI9wZHVuW HTTP/1.1" 200 0
[2016-09-08 21:10:05][INFO] : Check Openzwave
[2016-09-08 21:10:05][INFO] : --> pass
[2016-09-08 21:10:05][INFO] : --> pass
[2016-09-08 21:10:05][INFO] : Check if the port REST server available
[2016-09-08 21:10:05][INFO] : --> pass
[2016-09-08 21:10:05][INFO] : USB Z-Wave Stick found : Sigma Designs, Inc at /dev/ttyACM0
Traceback (most recent call last):
File "/var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py", line 745, in <module>
options = ZWaveOption(_device, config_path=_config_folder, user_path=_data_folder, cmd_line="")
File "/usr/local/lib/python2.7/dist-packages/openzwave-0.3.0-py2.7.egg/openzwave/option.py", line 75, in __init__
raise ZWaveException(u"Error when retrieving device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: u'Zwave Generic Exception : Error when retrieving device /dev/ttyACM0 : [\'Traceback (most recent call last):
\', \' File "/usr/local/lib/python2.7/dist-packages/openzwave-0.3.0-py2.7.egg/openzwave/option.py", line 69, in __init__
raise ZWaveException(u"Can\'t write to device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
\', \'ZWaveException: u"Zwave Generic Exception : Can\'t write to device /dev/ttyACM0 : [\'None
\']"
\']'
[2016-09-08 21:10:34][ERROR] : Impossible de lancer le démon openzwave, relancer le démon en debug et vérifiez la log

Je suis deja en mode debug et j ai deja relancer le demon sans succes plusieurs fois...
J ai un peu regardé sur le web et le forum, sans succès...

Si vous avez des idées sur le sujet je suis preneur!
Merci par avance! :)

Seb

kouaw
Actif
Messages : 5933
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: Statut Demon NOK

Message par kouaw » 08 sept. 2016, 23:19

qu'elle clé utilise tu pour emettre du Zwave ?

zigjack
Timide
Messages : 192
Inscription : 06 sept. 2016, 09:31

Re: Statut Demon NOK

Message par zigjack » 09 sept. 2016, 06:12

J'utilise cette clé:
https://www.amazon.fr/Aeotec-Z-Stick-Ma ... B00YETCNOE
Elle à l'air reconnu sur mon rpi3, elle clignote bien orange rouge bleu...

Envoyé de mon Nexus 6P en utilisant Tapatalk

pipersw
Actif
Messages : 642
Inscription : 28 juil. 2014, 18:54
Localisation : Massy (91)

Re: Statut Demon NOK

Message par pipersw » 09 sept. 2016, 07:41

Il faut que tu donnes les droits sur le port /dev/ttyACM0 à www-data apparemment

zigjack
Timide
Messages : 192
Inscription : 06 sept. 2016, 09:31

Re: Statut Demon NOK

Message par zigjack » 09 sept. 2016, 07:56

OK... Heu... Je fais comment ça? [SMILING FACE WITH OPEN MOUTH AND COLD SWEAT]

Envoyé de mon Nexus 6P en utilisant Tapatalk

kouaw
Actif
Messages : 5933
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: Statut Demon NOK

Message par kouaw » 09 sept. 2016, 08:04

Tu n'as pas sélectionner le bon port :) elle est en usb donc pas /dev/acmo

Envoyé de mon HUAWEI GRA-L09 en utilisant Tapatalk

zigjack
Timide
Messages : 192
Inscription : 06 sept. 2016, 09:31

Re: Statut Demon NOK

Message par zigjack » 09 sept. 2016, 08:07

Tu veux dire dans le dashboard? Je crois que j'ai laissé la sélection en auto comme le préconisait la Doc...
Je regarderai les options que j'ai ce soir.

kouaw
Actif
Messages : 5933
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: Statut Demon NOK

Message par kouaw » 09 sept. 2016, 10:18

je parle dans la partie configuration du plugin Zwave :)

Avatar de l’utilisateur
nechry
Actif
Messages : 9644
Inscription : 24 juin 2014, 20:07
Localisation : Suisse
Contact :

Re: Statut Demon NOK

Message par nechry » 09 sept. 2016, 12:55

Avec un dongle usb on choisit Auto


Sent from my iPhone using Tapatalk
As-tu consulté la documentation avant de poser ta question?
Les demandes de support en MP ne seront pas traité mais j'accepte les dons paypal.me/nechry
Visiter mon blog http://nechry-automation.ch/

zigjack
Timide
Messages : 192
Inscription : 06 sept. 2016, 09:31

Re: Statut Demon NOK

Message par zigjack » 09 sept. 2016, 13:53

Ah OK, donc c'est bien ce que j'ai mis...
Pas d'autres idées du coup?

Envoyé avec t'as pas talc?

Avatar de l’utilisateur
nechry
Actif
Messages : 9644
Inscription : 24 juin 2014, 20:07
Localisation : Suisse
Contact :

Re: Statut Demon NOK

Message par nechry » 09 sept. 2016, 14:23

oui donner les droits, le log dit:
Zwave Generic Exception : Can\'t write to device /dev/ttyACM0
Il faut que tu donnes les droits sur le port /dev/ttyACM0

tu as quoi avec

Code : Tout sélectionner

ls -l  /dev/ttyACM0
As-tu consulté la documentation avant de poser ta question?
Les demandes de support en MP ne seront pas traité mais j'accepte les dons paypal.me/nechry
Visiter mon blog http://nechry-automation.ch/

zigjack
Timide
Messages : 192
Inscription : 06 sept. 2016, 09:31

Re: Statut Demon NOK

Message par zigjack » 09 sept. 2016, 18:00

Quand je fais ca, j obtiens:
crw-rw---- 1 root dialout 166, 0 Sep 9 17:51 /dev/ttyACM0

C est grave docteur?

zigjack
Timide
Messages : 192
Inscription : 06 sept. 2016, 09:31

Re: Statut Demon NOK

Message par zigjack » 09 sept. 2016, 22:00

Bon, du coup j ai basculé du choix "auto" en "/dev/ttyAMC0" j ai relancer le plugin et tout est passé au vert...!
Va comprendre charles...

Merci quand meme! :)

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités