Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

Plugin OpenZwave

(anciennement dénommé plugin OpenZwave)
Avatar de l’utilisateur
nechry
Actif
Messages : 9644
Inscription : 24 juin 2014, 20:07
Localisation : Suisse
Contact :

Re: Plugin OpenZwave

Message par nechry » 17 mars 2015, 11:29

@X3n0 je ne veux pas dire de mal de qubino mais tu ne semble pas être le premier a avoir des problème avec leurs module. j'ai un ami qui en as aussi avec ZiBASE et ça ne fonctionne pas toujours bien, enfin pas autant fiable que Fibaro. Fibaro ont aussi des soucies, je ne vais pas nier.
Pour en revenir a ta question ce que tu voix dans l'interface openzwave expert représente les valeurs juste et actuelles de l'ensemble de ton réseau. la vue jeedom peut interpréter ou n'est pas nécessairement phase pour les diagnostiques que l'on peut maintenant avoir avec la vue Expert. tu peux éventuellement regardé dans l'onglet Statistics et essayer de le interpréter. faut regarder de send Total et les failed, éventuellement le temps de réponse.

lorsque que le réseau semble devenir instable j'ai deux recette qui en général fonctionnent bien,
la premier on stop complètement le PC, retire la clé attend 10 sec rebranche et redémarre.
la deuxième c'est de supprimer le zwcfgxxx.xml pour forcer la détection complète de ton réseau

Il reste une dernière option, mais que je préfère éviter, c'est le HardReset, qui implique de tout ré inclure après.

tu peux aussi trouver beaucoup d'information sur le dépannage d'un réseau zwave en openzwave sur cette page:
http://www.openzwave.net/knowledge-base
As-tu consulté la documentation avant de poser ta question?
Les demandes de support en MP ne seront pas traité mais j'accepte les dons paypal.me/nechry
Visiter mon blog http://nechry-automation.ch/

Avatar de l’utilisateur
trankil
Actif
Messages : 793
Inscription : 21 juil. 2014, 15:07

Re: Plugin OpenZwave

Message par trankil » 17 mars 2015, 11:31

X3n0 a écrit :Je craque, ras le bol de la techno z-wave.
Si cela peut te rassurer, ce n'est pas la technologie en soit qui est mauvaise. Par exemple, chez moi, Jeedom fonctionne parfaitement avec mes modules zwave.
Je constate quand même que tu utilises beaucoup de composants non officiels. N'as tu pas la possibilité d'essayer de te rapprocher d'une plateforme officiellement supportée (par exemple en achetant une Jeedom Mini+ ou un RPI2) au moins temporairement le temps de faire quelques tests comparatifs , quitte à revenir ensuite sur ta plateforme Syno + OpenZwave (et renvoyer ta Mini+ ou ton RPI2 auprès du vendeur) ?
"L'erreur est la règle ; la vérité est l'accident de l'erreur." Georges Duhamel (1884 – 1966)
"Laitcronsaitpasbon et Laitsleepsaitpasbonnonplus" proverbe Trankilien (2014 – )

Avatar de l’utilisateur
tmartinez
Modérateur
Messages : 1226
Inscription : 08 juil. 2014, 11:22
Localisation : Limonest

Re: Plugin OpenZwave

Message par tmartinez » 17 mars 2015, 11:36

@trankil : il n'est pas en Syno, il est sur un raspberry déporté avec un stick zwave.
tu trouves ça pertinent comme conseil ? Je pense qu'il préfère que l'on essaie de le dépanner pour son soucis, plutôt que de lui dire de réinvestir dans du matériel !

Je te rappelle que OpenZwave est ou a été utilisé par 1/3 des utilisateurs Jeedom, donc si le plugin était si mauvais ou pas fiable, on aurait beaucoup plus de retours !
Jeedom sous Proxmox
43 Modules Z-Wave / 1x RfxCom / 20 devices connectés
Mon matériel

Avatar de l’utilisateur
trankil
Actif
Messages : 793
Inscription : 21 juil. 2014, 15:07

Re: Plugin OpenZwave

Message par trankil » 17 mars 2015, 11:41

@Tmartinez: je ne lui demande pas de changer définitivement de matériel, mais plutôt de tester sur un autre matériel (idéalement le plus proche possible d'une box officielle) afin de lever tout doute sur ces modules et/ou sur sa façon de faire , et de renvoyer ensuite auprès du vendeur le matériel testé. (en application des conditions générales de vente en vigueur)
"L'erreur est la règle ; la vérité est l'accident de l'erreur." Georges Duhamel (1884 – 1966)
"Laitcronsaitpasbon et Laitsleepsaitpasbonnonplus" proverbe Trankilien (2014 – )

Avatar de l’utilisateur
tmartinez
Modérateur
Messages : 1226
Inscription : 08 juil. 2014, 11:22
Localisation : Limonest

Re: Plugin OpenZwave

Message par tmartinez » 17 mars 2015, 11:48

Je comprends la démarche mais nous avons intégré des outils de diagnostiques / réparation de réseau dans l'interface avancée du plugin, je pense donc que la 1ère étape est d'analyser les logs pour comprendre les causes du pb.(maillage défaillant, module qui ne répond pas...)
Jeedom sous Proxmox
43 Modules Z-Wave / 1x RfxCom / 20 devices connectés
Mon matériel

zooidoo
Timide
Messages : 9
Inscription : 17 mars 2015, 11:40

Re: Plugin OpenZwave

Message par zooidoo » 17 mars 2015, 11:56

Bonjour.
Je me suis lancé recemment dans la domotique pour faire un poc dans mon appart avant le deménagement dans la maison que je veux équiper cet été.
J'ai investi sur du matos de base :
- aeon stick
- swiidplug
- senseur de porte fibaro
- bidule pour les volets roulants fibaro

Sur le plan logiciel, le serveur est un proxmox-ve, une vm toute propre en debian wheezy avec l'install de jeedom qui va bien.
Stick USB passé en natif à la vm (usbhost:), reconnu par lsusb sur la vm.
Plungin openzwave acheté et installé.
Plungin zwave installé.
Reporting en front : tout semble ok.

L'inclusion des modules dans le stick en mode "portable" se passe bien, les modules sont vus dans le listing des devices.

Physiquement, il y a 5m en ligne droite entre le sitck et le swwidplug. 7m angulaires avec le sensor de porte et 10m à tout casser jusqu'aux volet roulant.

MAIS.

Les devices ne communiquent pas entre eux !

Le stick me dit :
Neighbours: ...

Par contre le sensor de porte a comme neighboors le voletroulant et le swwidplug.
Neighbours: 6,7

Et le swwidplug et les voletsroulants sont declarés dead.

Je ne sais plus quoi faire.
J'ai testé de monter la clef usb dans une autre vm avec domoticz à la place, les devices sont vu de la memes facons, et ne communiquent pas non plus entre eux

Avatar de l’utilisateur
tmartinez
Modérateur
Messages : 1226
Inscription : 08 juil. 2014, 11:22
Localisation : Limonest

Re: Plugin OpenZwave

Message par tmartinez » 17 mars 2015, 11:58

@zooidoo du coup je t'ai répondu dans ton autre post
Jeedom sous Proxmox
43 Modules Z-Wave / 1x RfxCom / 20 devices connectés
Mon matériel

nordix
Actif
Messages : 858
Inscription : 02 déc. 2014, 13:29

Re: Plugin OpenZwave

Message par nordix » 17 mars 2015, 12:14

Cela fait maintenant près de 2 ans que je bidouille avec la technologie zwave et RF en général et je peux dire que Jeedom en terme de stabilité et de fonctionnement optimal est ce qui se fait de mieux sur tout ce que j'ai pu tester et exploiter. Jeedom a la particularité (et la chance) de ne pas dépendre de la plateforme matérielle et d'être entièrement modulaire, avec des fonctionnalités assez indépendantes. Bref beaucoup de bonheur dans mon cas malgré quelques soucis d'apprentissage et avec le peu de temps que j'ai à y accorder. Je roule d'ailleurs celui-ci de façon très "non officielle" :) , plateforme ARM A10 , contrôleur zwave en secondaire et ça marche!

Maintenant en ce qui a trait à la technologie zwave, elle est comme toutes les technologies sans fil, prompte aux interférences de toute sorte y compris par les appareils domestiques non blindés. Quelques fois aussi des modules assez mal conçus avec des antennes radios de faible portée ou avec des fréquences mal centrées, des mauvaises implémentations des classes zwave, bref un peu la jungle aussi dans ce domaine.

@X3n0, quand je tombe sur ce genre de situation, une des choses que j'essaye de faire est de rapprocher mon module le plus près du contrôleur (ou l'inverse le contrôleur du module) et j'essaye de le configurer comme cela. J'essaye de le commander à 1 ou 2 m de celui-ci et je mets le mode debug de zwave en même temps pour voir s'il réagit mieux. La plupart du temps cela fonctionne.. Une fois la configuration effectuée, je replace contrôleur et module à leur places et je lance un Heal du réseau zwave pour optimiser les routes. Le routage étant de type full mesh, plus il y a de modules zwave et plus le réseau devient efficace également!
Sinon comme a suggéré @Nechry, un effacement de la config (fichier zwcfg_XXXXX.xml dans le répertoire /opt/pyth-openzwave) peut défaire une mauvaise config et remettre de l'ordre dans le réseau.
C'est le prix à payer pour faire parler des dispositifs qui ne sont pas toujours nés pareils!

Avatar de l’utilisateur
tmartinez
Modérateur
Messages : 1226
Inscription : 08 juil. 2014, 11:22
Localisation : Limonest

Re: Plugin OpenZwave

Message par tmartinez » 17 mars 2015, 12:16

@nordix : très bonne explication et bons conseils !! Merci
Jeedom sous Proxmox
43 Modules Z-Wave / 1x RfxCom / 20 devices connectés
Mon matériel

nordix
Actif
Messages : 858
Inscription : 02 déc. 2014, 13:29

Re: Plugin OpenZwave

Message par nordix » 17 mars 2015, 12:54

Tiens, d'autres problèmes avec les modules Qubino et Raz zwave cette fois.. il est d'ailleurs indiqué dans la doc, de le rapprocher à 1m pour la config initiale et ensuite de le replacer ;)

https://forum.jeedom.fr/viewtopic.php?f=34&t=3957

Avatar de l’utilisateur
oufman
Actif
Messages : 567
Inscription : 07 sept. 2014, 00:44
Localisation : Suisse - VD

Re: Plugin OpenZwave

Message par oufman » 17 mars 2015, 12:55

Bonjour à tous,

Actuellement j'utilise un contrôleur principale avec Jeedom dessus, et un contrôleur Z-Wave (une PI avec un razberry).

Je souhaiterai de préférence tout passer sur un seul contrôleur, et utiliser uniquement un de mes NUC i3 ou i5.

Du coup 2 solutions de présente à moi, soit utiliser un adaptateur UBS-> Razberry pour brancher directement sur un de mes NUC, mais j'avais rencontré des problèmes, on m'as dit que le problème venait peut-êtres de cette solution.
Ou je peux utiliser ma clé Aeon Labs qui traîne dans un coin avec le plug-in OpenZwave que j'ai déjà acheté.
Ma question au niveau performance et stabilité : OpenZwave avec stick Z2 ou Zwave direct -> USB & Razberry ?

Merci d'avance pour votre point de vue :)

Avatar de l’utilisateur
nechry
Actif
Messages : 9644
Inscription : 24 juin 2014, 20:07
Localisation : Suisse
Contact :

Re: Plugin OpenZwave

Message par nechry » 17 mars 2015, 13:33

@oufman je pense pas qu'on peut avoir une réponse tranché, je suis sur openzwave depuis plus de 3 ans et je trouve plutôt stable. La stabilité me semble beaucoup plus venir du matériel que tu as a disposition que du choix openzwave ou zway. comme là très bien exprimé @nordix certaint device on de gros défaut de conception allant du matériel aux implémentation des CommandClass.

Je vais prêcher pour ma paroisse, mais de façon général les nouveau module zwave sont plus rapidement supporté en openzwave que sur les autres plateforme. Là encore certain son aussi très réactif et les update suive facilement.

Je pense le démarrage d'un réseau openzwave va prendre plus de temps à démarrer mais une fois up sera tout autant réactif. l'openzwave a une approche générique ce qui simplifie grandement l'implémentation.

En revanche en openzwave comme il s'agit de reverse engineering sur le protocole zwave, certaine commandClass ne sont pas encore supporté, donc certain node ne pourrait pas fonctionner de façon optimale. l'équipe derrière la librairie openzwave et très active, donnent des réponse au questions.

Donc c'est un point de vie sur l'openzwave.
As-tu consulté la documentation avant de poser ta question?
Les demandes de support en MP ne seront pas traité mais j'accepte les dons paypal.me/nechry
Visiter mon blog http://nechry-automation.ch/

Avatar de l’utilisateur
oufman
Actif
Messages : 567
Inscription : 07 sept. 2014, 00:44
Localisation : Suisse - VD

Re: Plugin OpenZwave

Message par oufman » 17 mars 2015, 16:20

@nechry merci pour ton retour. C'est toujours appréciable d'avoir des avis d'utilisateur.

DenisPac
Actif
Messages : 629
Inscription : 14 août 2014, 13:25
Localisation : Près d'Orléans (45)

Re: Plugin OpenZwave

Message par DenisPac » 17 mars 2015, 17:32

oufman a écrit :@nechry merci pour ton retour. C'est toujours appréciable d'avoir des avis d'utilisateur.
En l'occurrence @nechry est aussi développeur ;)
Jeedom Maître sur VM Debian sur ESXi (N54L) + Z-Stick 2 (non fonctionnel) + RFXCOM
Jeedom déporté Z-Wave sur Jeedom mini avec JeeLink
Antenne RPI3 BLEA, Netatmo, Philips Hue, Xiaomi Home, Yeelight, Dash Button, ...

Avatar de l’utilisateur
darghorn
Timide
Messages : 97
Inscription : 08 nov. 2014, 04:35
Localisation : 92

Re: Plugin OpenZwave

Message par darghorn » 17 mars 2015, 20:52

Je repose mon message précédent, j'ai été noyé parmi les discussions :)
Hello à tous,

Depuis la mise à jour incluant un support du tag reader zipato, je me suis lancé dans l'application de la dernière conf du market sur celui ci.

L'enregistrement des badges fonctionne, je vois bien le statut des mémoires changer sur l'interface zwave, mais par contre rien ne bouge quand je fais la manipulation "home" > "passage du badge"

La commande "événement" reste désespérément vide (donc ni 5 ni 6), et côté interface admin openzwave je ne vois comme changement que le paramètre "Alarm Level" qui passe à 255.

Une idée ?


Voila l'arbre pour info, avec les id de badges masqués, et raccourci au niveau des mémoires (255 ça rentrait pas dans le message :))

Code : Tout sélectionner

{
"data" : {
"basicType" : {
"value" : 4
},
"can_wake_up" : {
"value" : "true"
},
"genericType" : {
"value" : 64
},
"isAwake" : {
"updateTime" : 1426536255,
"value" : ""
},
"isBeaming" : {
"value" : "true"
},
"isFrequentListening" : {
"value" : "false"
},
"isListening" : {
"value" : "false"
},
"isReady" : {
"updateTime" : 1426536255,
"value" : "true"
},
"isRouting" : {
"value" : "true"
},
"isSecurity" : {
"value" : "false"
},
"isVirtual" : {
"value" : ""
},
"lastReceived" : {
"updateTime" : 1426536255
},
"manufacturerId" : {
"value" : 138
},
"manufacturerProductId" : {
"value" : 257
},
"manufacturerProductType" : {
"value" : 7
},
"maxBaudRate" : {
"value" : 40000
},
"name" : {
"value" : "Tag Reader"
},
"neighbours" : {
"value" : [
1,
3,
4,
7,
8,
10
]
},
"product_name" : {
"value" : "Tag Reader"
},
"security" : {
"value" : 0
},
"specificType" : {
"value" : 0
},
"state" : {
"value" : "Dynamic"
},
"type" : {
"value" : "Entry Control"
},
"vendorString" : {
"value" : "BeNext"
},
"version" : {
"value" : 4
}
},
"groups" : {
"1" : {
"associations" : "1",
"label" : "Group 1",
"maximumAssociations" : 5
},
"updateTime" : 1426536255
},
"instances" : {
"0" : {
"commandClasses" : {
"32" : {
"data" : {
"0" : {
"data_items" : "A byte between 0 and 255",
"genre" : "Basic",
"help" : "",
"level" : "0",
"name" : "Basic",
"poll_intensity" : 0,
"read_only" : false,
"type" : "int",
"typeZW" : "Byte",
"units" : "",
"updateTime" : 1,
"val" : "0",
"value" : "0",
"value_id" : 72057594189447000,
"write_only" : false
},
"updateTime" : 1
},
"name" : "COMMAND_CLASS_BASIC"
},
"37" : {
"data" : {
"0" : {
"data_items" : "True or False",
"genre" : "User",
"help" : "",
"level" : "false",
"name" : "Switch",
"poll_intensity" : 0,
"read_only" : false,
"type" : "bool",
"typeZW" : "Bool",
"units" : "",
"updateTime" : 1426533227,
"val" : "false",
"value" : "false",
"value_id" : 72057594193723000,
"write_only" : false
},
"level" : {
"type" : "bool",
"typeZW" : "Bool",
"value" : "false"
},
"updateTime" : 1426533227
},
"name" : "COMMAND_CLASS_SWITCH_BINARY"
},
"99" : {
"data" : {
"0" : {
"data_items" : "Read only",
"genre" : "User",
"help" : "",
"level" : "31000000000000000000",
"name" : "Enrollment Code",
"poll_intensity" : 0,
"read_only" : true,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426533241,
"val" : "31000000000000000000",
"value" : "31000000000000000000",
"value_id" : 72057594194739000,
"write_only" : false
},
"1" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "caché",
"name" : "Code 1:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426493816,
"val" : "caché",
"value" : "caché",
"value_id" : 72057594194739000,
"write_only" : false
},
"2" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "caché",
"name" : "Code 2:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426533233,
"val" : "caché",
"value" : "caché",
"value_id" : 72057594194739000,
"write_only" : false
},
"3" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "00000000000000000000",
"name" : "Code 3:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426445762,
"val" : "00000000000000000000",
"value" : "00000000000000000000",
"value_id" : 72057594194739000,
"write_only" : false
},
"4" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "caché",
"name" : "Code 4:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426493913,
"val" : "caché",
"value" : "caché",
"value_id" : 72057594194739000,
"write_only" : false
},
"5" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "caché",
"name" : "Code 5:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426534148,
"val" : "caché",
"value" : "caché",
"value_id" : 72057594194739000,
"write_only" : false
},
"6" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "00000000000000000000",
"name" : "Code 6:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426445762,
"val" : "00000000000000000000",
"value" : "00000000000000000000",
"value_id" : 72057594194739000,
"write_only" : false
},
"7" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "00000000000000000000",
"name" : "Code 7:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426445762,
"val" : "00000000000000000000",
"value" : "00000000000000000000",
"value_id" : 72057594194739000,
"write_only" : false
},
"8" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "00000000000000000000",
"name" : "Code 8:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426445762,
"val" : "00000000000000000000",
"value" : "00000000000000000000",
"value_id" : 72057594194739000,
"write_only" : false
},
"9" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "00000000000000000000",
"name" : "Code 9:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426445762,
"val" : "00000000000000000000",
"value" : "00000000000000000000",
"value_id" : 72057594194739000,
"write_only" : false
},
"10" : {
"data_items" : "Unknown",
"genre" : "User",
"help" : "",
"level" : "00000000000000000000",
"name" : "Code 10:",
"poll_intensity" : 0,
"read_only" : false,
"type" : "binary",
"typeZW" : "Raw",
"units" : "",
"updateTime" : 1426445762,
"val" : "00000000000000000000",
"value" : "00000000000000000000",
"value_id" : 72057594194739000,
"write_only" : false
},
"updateTime" : 1426445762
},
"name" : "COMMAND_CLASS_USER_CODE"
},
"112" : {
"data" : {
"1" : {
"data_items" : "A byte between 0 and 255",
"genre" : "Config",
"help" : "Set all configuration values to default values (factory settings).",
"level" : "85",
"name" : "Set to Default",
"poll_intensity" : 0,
"read_only" : false,
"type" : "int",
"typeZW" : "Byte",
"units" : "",
"updateTime" : 1426534148,
"val" : "85",
"value" : "85",
"value_id" : 72057594199147000,
"write_only" : false
},
"2" : {
"data_items" : "Disabled;Endless",
"genre" : "Config",
"help" : "To configure the time the beep is automatically turned off in seconds.",
"level" : "Disabled",
"name" : "Feedback Time",
"poll_intensity" : 0,
"read_only" : false,
"type" : "List",
"typeZW" : "List",
"units" : "",
"updateTime" : 1426534148,
"val" : "Disabled",
"value" : "Disabled",
"value_id" : 72057594199147000,
"write_only" : false
},
"3" : {
"data_items" : "A byte between 0 and 255",
"genre" : "Config",
"help" : "To configure the timeout to wait for a WAKEUP_NO_MORE_INFORMATION before the error beep is automatically sound. The error beeps are fixed 8 beeps shortly after each other.",
"level" : "0",
"name" : "Feedback Timeout",
"poll_intensity" : 0,
"read_only" : false,
"type" : "int",
"typeZW" : "Byte",
"units" : "",
"updateTime" : 1426534148,
"val" : "0",
"value" : "0",
"value_id" : 72057594199147000,
"write_only" : false
},
"4" : {
"data_items" : "A byte between 0 and 255",
"genre" : "Config",
"help" : "To configure the number of beeps per second. Every beep is fixed about 10ms.",
"level" : "2",
"name" : "Feedback Beeps per Second",
"poll_intensity" : 0,
"read_only" : false,
"type" : "int",
"typeZW" : "Byte",
"units" : "",
"updateTime" : 1426534148,
"val" : "2",
"value" : "2",
"value_id" : 72057594199147000,
"write_only" : false
},
"5" : {
"data_items" : "A byte between 0 and 255",
"genre" : "Config",
"help" : "To configure the operating mode. If any mode other then 3, that value will be reported after a get but will be handled in SW as mode 1.",
"level" : "0",
"name" : "The Mode",
"poll_intensity" : 0,
"read_only" : false,
"type" : "int",
"typeZW" : "Byte",
"units" : "",
"updateTime" : 1426534148,
"val" : "0",
"value" : "0",
"value_id" : 72057594199147000,
"write_only" : false
},
"updateTime" : 1426534148
},
"name" : "COMMAND_CLASS_CONFIGURATION"
},
"113" : {
"data" : {
"0" : {
"data_items" : "Read only",
"genre" : "User",
"help" : "",
"level" : "0",
"name" : "Alarm Type",
"poll_intensity" : 0,
"read_only" : true,
"type" : "int",
"typeZW" : "Byte",
"units" : "",
"updateTime" : 1426534393,
"val" : "0",
"value" : "0",
"value_id" : 72057594194969000,
"write_only" : false
},
"1" : {
"data_items" : "Read only",
"genre" : "User",
"help" : "",
"level" : "255",
"name" : "Alarm Level",
"poll_intensity" : 0,
"read_only" : true,
"type" : "int",
"typeZW" : "Byte",
"units" : "",
"updateTime" : 1426534393,
"val" : "255",
"value" : "255",
"value_id" : 72057594194969000,
"write_only" : false
},
"updateTime" : 1426534393
},
"name" : "COMMAND_CLASS_ALARM"
},
"128" : {
"data" : {
"0" : {
"data_items" : "Read only",
"genre" : "User",
"help" : "",
"level" : "100",
"name" : "Battery Level",
"poll_intensity" : 0,
"read_only" : true,
"type" : "int",
"typeZW" : "Byte",
"units" : "%",
"updateTime" : 1426533227,
"val" : "100",
"value" : "100",
"value_id" : 72057594195214000,
"write_only" : false
},
"last" : {
"type" : "int",
"updateTime" : 1426533227,
"value" : "100"
},
"supported" : {
"type" : "bool",
"updateTime" : 1426533227,
"value" : true
},
"updateTime" : 1426533227
},
"name" : "COMMAND_CLASS_BATTERY"
},
"132" : {
"data" : {
"0" : {
"data_items" : "An integer between 2147483648 and 2147483647",
"genre" : "System",
"help" : "",
"level" : "7200",
"name" : "Wake-up Interval",
"poll_intensity" : 0,
"read_only" : false,
"type" : "int",
"typeZW" : "Int",
"units" : "Seconds",
"updateTime" : 1426451205,
"val" : "7200",
"value" : "7200",
"value_id" : 72057594203668000,
"write_only" : false
},
"interval" : {
"type" : "int",
"updateTime" : 1426451205,
"value" : "7200"
},
"updateTime" : 1426451205
},
"name" : "COMMAND_CLASS_WAKE_UP"
},
"134" : {
"data" : {
"0" : {
"data_items" : "Read only",
"genre" : "System",
"help" : "",
"level" : "3",
"name" : "Library Version",
"poll_intensity" : 0,
"read_only" : true,
"type" : "String",
"typeZW" : "String",
"units" : "",
"updateTime" : 1426445762,
"val" : "3",
"value" : "3",
"value_id" : 72057594203701000,
"write_only" : false
},
"1" : {
"data_items" : "Read only",
"genre" : "System",
"help" : "",
"level" : "3.42",
"name" : "Protocol Version",
"poll_intensity" : 0,
"read_only" : true,
"type" : "String",
"typeZW" : "String",
"units" : "",
"updateTime" : 1426445762,
"val" : "3.42",
"value" : "3.42",
"value_id" : 72057594203701000,
"write_only" : false
},
"2" : {
"data_items" : "Read only",
"genre" : "System",
"help" : "",
"level" : "1.09",
"name" : "Application Version",
"poll_intensity" : 0,
"read_only" : true,
"type" : "String",
"typeZW" : "String",
"units" : "",
"updateTime" : 1426445762,
"val" : "1.09",
"value" : "1.09",
"value_id" : 72057594203701000,
"write_only" : false
},
"updateTime" : 1426445762
},
"name" : "COMMAND_CLASS_VERSION"
},
"data" : {
"updateTime" : 1426533227
},
"updateTime" : 1426533227
},
"updateTime" : 1426533227
},
"updateTime" : 1426536255
}
}
DIY / VM Debian sur ESXi 6.5 - ProLiant MicroServer Gen8
Protocoles : Z-Wave+ / Hue / Xiaomi

underscan
Timide
Messages : 29
Inscription : 23 févr. 2015, 20:54

Re: Plugin OpenZwave

Message par underscan » 17 mars 2015, 21:08

@nechry les versions que tu me demandais par rapport a mes souci de "Warning, Node009, No Valid Mapping for Basic Command Class and No ValueID Exported. Error?" :
OpenZwave Library Version:1.3.1021
Python-OpenZwave Library Version: 0.2.6
bizarre..

LeCapitaineCaverne
Timide
Messages : 14
Inscription : 03 févr. 2015, 10:11

Re: Plugin OpenZwave

Message par LeCapitaineCaverne » 17 mars 2015, 21:34

nechry a écrit :@LeCapitaineCaverne, hello via le binding de commande si tu utilises le bouton test, il se passe quelque chose? Si la commande ne c'exécute pas c'est peut-être que tu as un mauvais binding. Tu peux eventuellement nous montrer la commande.


@nechry : Je viens de mettre à jour... Et le problème persiste avec mes Danfoss même si je suis allé un peu plus loin.

Quand je passe directement par le serveur openZwave, et que je modifie la valeur du thermostat en cliquant sur la clef à molette, cela fonctionne bien

Code : Tout sélectionner

2015-03-17 21:26:28.241 Info, Node004, Value::Set - COMMAND_CLASS_THERMOSTAT_SETPOINT - Heating 1 - 1 - 1 - 14
2015-03-17 21:26:28.242 Detail, 
2015-03-17 21:26:28.242 Detail, Node004, Queuing (WakeUp) ThermostatSetpointCmd_Set (Node=4): 0x01, 0x0d, 0x00, 0x13, 0x04, 0x06, 0x43, 0x01, 0x01, 0x42, 0x05, 0x78, 0x25, 0x10, 0xaa
2015-03-17 21:26:28.242 Detail, 
2015-03-17 21:26:28.243 Detail, Node004, Queuing (WakeUp) ThermostatSetpointCmd_Get (Node=4): 0x01, 0x0a, 0x00, 0x13, 0x04, 0x03, 0x43, 0x02, 0x01, 0x25, 0x11, 0x95
2015-03-17 21:26:29.248 Info, mgr,     Refreshing node 4: COMMAND_CLASS_THERMOSTAT_SETPOINT index = 1 instance = 1 (to confirm a reported change)
2015-03-17 21:26:29.248 Detail, 
2015-03-17 21:26:29.248 Detail, Node004, Queuing (WakeUp) ThermostatSetpointCmd_Get (Node=4): 0x01, 0x0a, 0x00, 0x13, 0x04, 0x03, 0x43, 0x02, 0x01, 0x25, 0x12, 0x96
2015-03-17 21:26:30.254 Info, mgr,     Refreshing node 4: COMMAND_CLASS_THERMOSTAT_SETPOINT index = 1 instance = 1 (to confirm a reported change)
2015-03-17 21:26:30.254 Detail, 
2015-03-17 21:26:30.254 Detail, Node004, Queuing (WakeUp) ThermostatSetpointCmd_Get (Node=4): 0x01, 0x0a, 0x00, 0x13, 0x04, 0x03, 0x43, 0x02, 0x01, 0x25, 0x13, 0x97

Par contre, quand je clique sur "Tester" sous l'interface Jeedom, la commande Thermostat setpoint n'est pas envoyée. Je n'ai que :

Code : Tout sélectionner

2015-03-17 21:27:07.392 Detail, Node004, AdvanceQueries queryPending=0 queryRetries=0 queryStage=Dynamic live=1
2015-03-17 21:27:07.392 Detail, Node004, QueryStage_Dynamic
2015-03-17 21:27:07.392 Detail, 
2015-03-17 21:27:07.392 Detail, Node004, Queuing (WakeUp) BatteryCmd_Get (Node=4): 0x01, 0x09, 0x00, 0x13, 0x04, 0x02, 0x80, 0x02, 0x25, 0x14, 0x50
2015-03-17 21:27:07.393 Detail, 
2015-03-17 21:27:07.393 Detail, Node004, Queuing (WakeUp) ClockCmd_Get (Node=4): 0x01, 0x09, 0x00, 0x13, 0x04, 0x02, 0x81, 0x05, 0x25, 0x15, 0x57
2015-03-17 21:27:07.393 Info, 
2015-03-17 21:27:07.394 Detail, Node004, Queuing (WakeUp) Query Stage Complete (Dynamic)

Avatar de l’utilisateur
tmartinez
Modérateur
Messages : 1226
Inscription : 08 juil. 2014, 11:22
Localisation : Limonest

Re: Plugin OpenZwave

Message par tmartinez » 17 mars 2015, 21:46

@LeCapitaineCaverne : peux-tu mettre une copie d'écran de la config dans le plugin zwave ainsi qu'une copie d'écran des valeurs dans l'interface avancée ?
@darghorn : je ne peux pas t'aider sur ce module car c'est @nechry qui le maitrise bien. Il revient vers toi dès qu'il est dispo.
Jeedom sous Proxmox
43 Modules Z-Wave / 1x RfxCom / 20 devices connectés
Mon matériel

LeCapitaineCaverne
Timide
Messages : 14
Inscription : 03 févr. 2015, 10:11

Re: Plugin OpenZwave

Message par LeCapitaineCaverne » 17 mars 2015, 21:54

tmartinez a écrit :@LeCapitaineCaverne : peux-tu mettre une copie d'écran de la config dans le plugin zwave ainsi qu'une copie d'écran des valeurs dans l'interface avancée ?
@darghorn : je ne peux pas t'aider sur ce module car c'est @nechry qui le maitrise bien. Il revient vers toi dès qu'il est dispo.

@ tmartinez: Je ne suis pas sûr a 100% que cela soit les copies que tu voulais.
J'ai mis en statique (pour tester) la valeur du thermostat a 23 comme tu pourras le voir.

Merci pour ton aide.
Pièces jointes
C1.JPG
C1.JPG (137.95 Kio) Consulté 377 fois
C2.JPG
C2.JPG (141.44 Kio) Consulté 377 fois

Avatar de l’utilisateur
tmartinez
Modérateur
Messages : 1226
Inscription : 08 juil. 2014, 11:22
Localisation : Limonest

Re: Plugin OpenZwave

Message par tmartinez » 17 mars 2015, 21:57

Oui, mais comme ça, ça ne peut pas marcher.
Voici la commande que tu dois rentrer : data[1].Set(#slider#)
et si tu veux tester directement avec 23 : data[1].Set(23)
Jeedom sous Proxmox
43 Modules Z-Wave / 1x RfxCom / 20 devices connectés
Mon matériel

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité