Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

Nouveau plugin zwave/openzwave

(anciennement dénommé plugin OpenZwave)
YannickF
Timide
Messages : 50
Inscription : 21 déc. 2014, 11:30

Re: Nouveau plugin zwave/openzwave

Message par YannickF » 12 août 2015, 13:48

Même erreur chez moi (Rpi 2, image officielle Jeedom, OpenZwave beta (la compilation se passe bien avec le plugin en stable, mais Jeedom m'alerte que cette version est dépassée !)

Avatar de l’utilisateur
Pax24
Timide
Messages : 318
Inscription : 12 juin 2015, 03:42
Localisation : Périgord

Re: Nouveau plugin zwave/openzwave

Message par Pax24 » 12 août 2015, 17:26

Technopaul a écrit :
Auron007 a écrit :
domars a écrit :Bonsoir,
L'installation sur mon DIY de la dernière beta s'interrompt avec l'erreur loggée ci-dessous ;

Code : Tout sélectionner

  inflating: /opt/python-openzwave/open-zwave-0432f68a7d331bdde4c0b77b2b81bcf9bd37795c/openzwave.spec  
sed: impossible de lire openzwave/cpp/src/value_classes/ValueID.h: Aucun fichier ou dossier de ce type
sed -i '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
sed: impossible de lire openzwave/cpp/src/value_classes/ValueID.h: Aucun fichier ou dossier de ce type
Makefile:268: recipe for target 'openzwave/libopenzwave.a' failed
make: *** [openzwave/libopenzwave.a] Error 2
Error while install python-openzwave
Merci de votre aide !
Bonjour,

Exctament le même problème pour moi.
Et pareil en SSH.
Bonjour a tous
Moi aussi, même erreur

A+

Paul
Et de 5...
bonjour aussi
vu que moi aussi c'est la même erreur
comme tout le monde quoi :mrgreen:

Pi2 image Jeedom officielle...

domars
Timide
Messages : 245
Inscription : 13 mars 2015, 12:53

Re: Nouveau plugin zwave/openzwave

Message par domars » 12 août 2015, 19:02

Désolé, mais la nouvelle beta de ce soir trébuche sur un autre problème...

Code : Tout sélectionner

make[2: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
make -C /opt/python-openzwave/openzwave/cpp/examples/MinOZW/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
Building Main.o
Linking /opt/python-openzwave/openzwave/.lib/MinOZW
g++   -o /opt/python-openzwave/openzwave/.lib/MinOZW /opt/python-openzwave/openzwave/.lib/Main.o /opt/python-openzwave/openzwave/libopenzwave.so -pthread
Creating Temporary Shell Launch Script
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
python setup-lib.py build --build-base build/lib
running build
running build_ext
building 'libopenzwave' extension
error: unknown file type '.pyx' (from 'src-lib/libopenzwave/libopenzwave.pyx')
Makefile:257: recipe for target 'build' failed
make: *** [build] Error 1
Error while install python-openzwave
Dernière édition par domars le 12 août 2015, 19:29, édité 1 fois.

Technopaul
Timide
Messages : 115
Inscription : 14 nov. 2014, 19:00
Localisation : Cagnes Sur Mer

Re: Nouveau plugin zwave/openzwave

Message par Technopaul » 12 août 2015, 19:08

domars a écrit :Désolé, mais la nouvelle beta ce ce soir trébuche sur un autre problème...

Code : Tout sélectionner

make[2: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
make -C /opt/python-openzwave/openzwave/cpp/examples/MinOZW/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
Building Main.o
Linking /opt/python-openzwave/openzwave/.lib/MinOZW
g++   -o /opt/python-openzwave/openzwave/.lib/MinOZW /opt/python-openzwave/openzwave/.lib/Main.o /opt/python-openzwave/openzwave/libopenzwave.so -pthread
Creating Temporary Shell Launch Script
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
python setup-lib.py build --build-base build/lib
running build
running build_ext
building 'libopenzwave' extension
error: unknown file type '.pyx' (from 'src-lib/libopenzwave/libopenzwave.pyx')
Makefile:257: recipe for target 'build' failed
make: *** [build] Error 1
Error while install python-openzwave

Bonsoir

Pareil

A+

Paul

ph3nix
Timide
Messages : 14
Inscription : 23 sept. 2014, 16:28

Re: Nouveau plugin zwave/openzwave

Message par ph3nix » 12 août 2015, 19:35

Même problème pour moi, DEMON KO depuis les 2 dernières maj
La résintallation plante :

Code : Tout sélectionner

Lancement da l'installation/mise à jour des dépendance openzwave
Stopping system nodejs Daemon: failed!
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
cython is already the newest version.
g++ is already the newest version.
gcc is already the newest version.
git is already the newest version.
libudev-dev is already the newest version.
mercurial is already the newest version.
python-dev is already the newest version.
python-louie is already the newest version.
python-lxml is already the newest version.
python-pip is already the newest version.
python-setuptools is already the newest version.
python-sphinx is already the newest version.
unzip is already the newest version.
make is already the newest version.
The following packages were automatically installed and are no longer required:
  libc-ares2 libv8-3.14.5
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 128 not upgraded.
Installation des dependances Python
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-blockdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.4.1 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-blockdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-actdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): actdiag>=0.5.3 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.4.1 in /usr/local/lib/python2.7/dist-packages (from actdiag>=0.5.3->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->actdiag>=0.5.3->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->actdiag>=0.5.3->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->actdiag>=0.5.3->sphinxcontrib-actdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-nwdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): nwdiag>=1.0.3 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.4.1 in /usr/local/lib/python2.7/dist-packages (from nwdiag>=1.0.3->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->nwdiag>=1.0.3->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->nwdiag>=1.0.3->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->nwdiag>=1.0.3->sphinxcontrib-nwdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-seqdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): seqdiag>=0.9.3 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.4.1 in /usr/local/lib/python2.7/dist-packages (from seqdiag>=0.9.3->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->seqdiag>=0.9.3->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->seqdiag>=0.9.3->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.4.1->seqdiag>=0.9.3->sphinxcontrib-seqdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): urwid in /usr/local/lib/python2.7/dist-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): louie in /usr/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): nose>=0.8.3 in /usr/local/lib/python2.7/dist-packages (from louie)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): flask in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/local/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in /usr/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/local/lib/python2.7/dist-packages (from flask)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): flask-restful in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): aniso8601>=0.82 in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): Flask>=0.8 in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): six>=1.3.0 in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): pytz in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.8->flask-restful)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in /usr/lib/python2.7/dist-packages (from Flask>=0.8->flask-restful)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.8->flask-restful)
Cleaning up...
Sauvegarde du fichier de conf
cp: cannot stat `/opt/python-openzwave/zwcfg*': No such file or directory
Désinstallation de la version précédente
Installation de Python-OpenZwave
--2015-08-12 19:16:37--  https://github.com/OpenZWave/python-openzwave/archive/6320ae88db5c6bcd3482d962269fa624055ab557.zip
Resolving github.com (github.com)... 192.30.252.130
:443...HTTP request sent, awaiting response... 302 Found
Location: https://codeload.github.com/OpenZWave/python-openzwave/zip/6320ae88db5c6bcd3482d962269fa624055ab557 [following]
--2015-08-12 19:16:44--  https://codeload.github.com/OpenZWave/python-openzwave/zip/6320ae88db5c6bcd3482d962269fa624055ab557
Resolving codeload.github.com (codeload.github.com)... 192.30.252.144
:443... connected.HTTP request sent, awaiting response... 
200 OK
Length: unspecified [application/zip]
Saving to: `/tmp/python-openzwave.zip'
     0K .......... .......... .......... .......... ..........  245K
    50K .......... .......... .......... .......... ..........  286K
   100K .......... .......... .......... .......... ..........  501K
   150K .......... .......... .......... .......... ..........  498K
   200K .......... .......... .......... .......... ..........  591K
   250K .......... .......... .......... .......... ..........  875K
   300K .......... .......... .......... .......... .......... 1.13M
   350K .......... .......... .......... .......... ..........  590K
   400K ......
........ .......... .......... .......... 1.39M
   450K .......... .......... .......... .......... .......... 1.11M
   500K .......... .......... .......... .......... .......... 2.18M
   550K .......... .......... .......... .......... ..........  623K
   600K .......... .......... .......... .......... .......... 2.05M
   650K .......... .......... .......... .......... .......... 2.88M
   700K .......... .......... .......... .......... .......... 3.67M
   750K .......... .......... .......... .......... .......... 1.11M
   800K .......... .......... .......... .......... .......... 3.34M
   850K .......... .......... .......... .......... .......... 1.32M
   900K .......... .......... .......... .......... .......... 1.84M
   950K .......... .......... .......... .......... .......... 1.79M
  1000K .......... .......... .......... .......... .......... 1.91M
  1050K .......... .......... .......... .......... .......... 1.60M
  1100K .......... .......... .......... .......... .......... 1.90M
  1150K .......... .......... .......... .......... .......... 3.02M
  1200K .......... .......... .......... .......... .......... 1.90M
  1250K .......... .......... .......... .......... .......... 1.88M
  1300K .......... .......... .......... .......... .......... 1.90M
  1350K .......... .......... .......... .......... .......... 1.99M
  1400K .......... .......... .......... .......... .......... 3.29M
  1450K .......... .......... .......... .......... .......... 1.97M
  1500K .......... .......... .......... .......... .......... 1.55M
  1550K .......... .......... .......... .......... .......... 1.80M
  1600K .......... .......... .......... .......... .......... 1.79M
  1650K .......... .......... .......... .......... .......... 3.40M
  1700K .......... .......... .......... .......... .......... 1.84M
  1750K .......... .......... .......... .......... .......... 1.93M
  1800K .......... .......... .......... .......... .......... 1.73M
  1850K .......... .......... .......... .......... .......... 1.91M
  1900K .......... .......... .......... .......... .......... 3.05M
  1950K .......... .......... .......... .......... .......... 1.93M
  2000K .......... .......... .......... .......... .......... 1.85M
  2050K .......... .......... .......... .......... .......... 2.02M
  2100K .......... .......... .......... .......... .......... 1.54M
  2150K .......... .......... .......... .......... .......... 2.85M
  2200K .......... .......... .......... .......... .......... 2.00M
  2250K .......... .......... .......... .......... .......... 1.68M
  2300K .......... .......... .......... .......... .......... 1.31M
  2350K .......... .......... .......... .......... .......... 1.53M
  2400K .......... .......... .......... .......... .......... 1.68M
  2450K .......... .......... ......
.. .......... ..........  986K
  2500K .......... .......... .......... .......... ..........  799K
  2550K .......... .......... .......... .......... .......... 1.51M
  2600K .......... .......... .......... .......... .......... 1.85M
  2650K .......... .......... .......... .......... .......... 1.75M
  2700K .......... .......... .......... .......... .......... 1.57M
  2750K .......... .......... .......... .......... .......... 2.95M
  2800K .......... .......... .......... .......... .......... 1.76M
  2850K .......... .......... .......... .......... .......... 1.77M
  2900K .......... .......... .......... .......... .......... 1.78M
  2950K .......... .......... .......... .......... .......... 2.28M
  3000K .......... .......... .......... .......... .......... 2.41M
  3050K .......... .......... .......... .......... .......... 1.64M
  3100K .......... .......... .......... .......... .......... 1.48M
  3150K .......... .......... .......... .......... .......... 1.58M
  3200K .......... .......... .......... .......... .......... 2.31M
  3250K .......... .......... .......... .......... .......... 2.15M
  3300K .......... .......... .......... .......... .......... 1.85M
  3350K .......... .......... .......... .......... .......... 1.65M
  3400K .......... .......... .......... .......... .......... 1.67M
  3450K .......... .......... .......... .......... .......... 2.89M
  3500K .......... .......... .......... .......... .......... 2.74M
  3550K .......... .......... .......... .......... .......... 3.35M
  3600K .......... .......... .......... .......... .......... 3.26M
  3650K .......... .......... .......... .......... .......... 3.55M
  3700K .......... .......... .......... .......... .......... 1.02M
  3750K .......... .......... .......... .......... .......... 3.08M
  3800K .......... .......... .......... .......... .......... 3.63M
  3850K .......... .......... .......... .......... .......... 3.76M
  3900K .......... .......... .......... .......... .......... 2.86M
  3950K .......... .......... .......... .......... .......... 3.09M
  4000K .......... .......... .......... .......... .......... 3.63M
  4050K .......... .......... .......... .......... .......... 3.87M
  4100K .......... .......... .......... .......... .......... 3.27M
  4150K .......... .......... .......... .......... .......... 3.59M
  4200K .......... .......... .......... .......... .......... 3.81M
  4250K .......... .......... .......... .......... .......... 1.84M
  4300K .......... .......... .......... .......... .......... 2.78M
  4350K .......... .......... .......... .......... .......... 2.44M
  4400K .......... .......... .......... .......... .......... 2.01M
  4450K .......... .......... .......... .......... .......... 1.90M
  4500K .......                                                1.84M=3.0s
2015-08-12 19:16:51 (1.49 MB/s) - `/tmp/python-openzwave.zip' saved [4615688]
--2015-08-12 19:16:52--  https://github.com/OpenZWave/open-zwave/archive/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c.zip
Resolving github.com (github.com)... 192.30.252.129
:443... connected.HTTP request sent, awaiting response... 302 Found
Location: https://codeload.github.com/OpenZWave/open-zwave/zip/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c [following]
--2015-08-12 19:16:56--  https://codeload.github.com/OpenZWave/open-zwave/zip/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c
Resolving codeload.github.com (codeload.github.com)... 192.30.252.144
:443... connected.HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/zip]
Saving to: `/tmp/openzwave.zip'
     0K .......... .......... .......... .......... ..........  257K
    50K .......... .......... .......... .......... .....
.....  293K
   100K .......... .......... .......... .......... .......... 1009K
   150K .......... .......... .......... .......... ..........  486K
   200K .......... .......... .......... .......... ..........  571K
   250K .......... .......... .......... .......... .......... 1.33M
   300K .......... .......... .......... .......... ..........  657K
   350K .......... .......... .......... .......... .......... 1.98M
   400K .......... .......... .......... .......... .......... 1.42M
   450K .......... .......... .......... .......... ..........  590K
   500K .......... .......... .......... .......... .......... 1.16M
   550K .......... .......... .......... .......... .......... 1.94M
   600K .......... .......... .......... .......... .......... 1.75M
   650K .......... .......... .......... .......... .......... 1.79M
   700K .......... .......... .......... .......... .......... 1.72M
   750K .......... .......... .......... .......... .......... 1.10M
   800K .......... .......... .......... .......... .......... 4.10M
   850K .......... .......... .......... .......... .......... 1.65M
   900K .......... .......... .......... .......... .......... 1.14M
   950K .......... .......... .......... .......... .......... 1.90M
  1000K .......... .......... .......... .......... .......... 1.47M
  1050K .......... .......... .......... .......... .......... 2.44M
  1100K .......... .......... .......... .......... .......... 3.66M
  1150K .......... .......... .......... .......... .......... 3.56M
  1200K .......... .......... .......... .......... .......... 1.88M
  1250K .......... .......... .......... .......... .......... 2.67M
  1300K .......... .......... .......... .......... ........   1.12M=1.3s
2015-08-12 19:17:01 (1011 KB/s) - `/tmp/openzwave.zip' saved [1380613]
sed -i '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1]: Entering directory '/opt/python-openzwave/openzwave'
make -C /opt/python-openzwave/openzwave/cpp/build/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.3.-1
Building tinystr.o
Building tinyxmlerror.o
Building tinyxml.o
Building tinyxmlparser.o
Building hid.o
Building aeskey.o
Building aescrypt.o
Building aestab.o
Building aes_modes.o
Building SensorAlarm.o
Building Proprietary.o
Building SwitchToggleMultilevel.o
Building SensorBinary.o
Building Language.o
Building BasicWindowCovering.o
Building Color.o
Building ZWavePlusInfo.o
Building Indicator.o
Building CRC16Encap.o
Building Configuration.o
Building MeterPulse.o
Building DoorLock.o
Building ThermostatFanMode.o
Building SwitchBinary.o
Building Basic.o
Building SwitchAll.o
Building ThermostatMode.o
Building Hail.o
Building SwitchToggleBinary.o
Building SensorMultilevel.o
Building MultiInstance.o
Building Version.o
Building UserCode.o
Building TimeParameters.o
Building ThermostatFanState.o
Building SwitchMultilevel.o
Building ApplicationStatus.o
Building ManufacturerSpecific.o
Building ClimateControlSchedule.o
Building Protection.o
Building NodeNaming.o
Building DeviceResetLocally.o
Building WakeUp.o
Building MultiCmd.o
Building MultiInstanceAssociation.o
Building Association.o
Building Lock.o
Building SceneActivation.o
Building Powerlevel.o
Building Meter.o
Building AssociationCommandConfiguration.o
Building ThermostatOperatingState.o
Building Battery.o
Building CentralScene.o
Building Security.o
Building Clock.o
Building Alarm.o
Building CommandClasses.o
Building ThermostatSetpoint.o
Building NoOperation.o
Building EnergyProduction.o
Building CommandClass.o
Building DoorLockLogging.o
Building ControllerReplication.o
Building Value.o
Building ValueList.o
Building ValueButton.o
Building ValueInt.o
Building ValueStore.o
Building ValueDecimal.o
Building ValueRaw.o
Building ValueString.o
Building ValueByte.o
Building ValueBool.o
Building ValueSchedule.o
Building ValueShort.o
Building Controller.o
Building Wait.o
Building Thread.o
Building Stream.o
Building Log.o
Building HidController.o
Building Mutex.o
Building SerialController.o
Building Event.o
Building FileOps.o
Building TimeStamp.o
Building FileOpsImpl.o
Building TimeStampImpl.o
Building WaitImpl.o
Building ThreadImpl.o
Building LogImpl.o
Building MutexImpl.o
Building SerialControllerImpl.o
Building EventImpl.o
Building Options.o
Building Scene.o
Building Utils.o
Building Driver.o
Building ZWSecurity.o
Building Group.o
Building Node.o
Building Manager.o
Building Msg.o
Building Notification.o
Creating vers.cpp
Building vers.o
Linking Static Library
Linking Shared Library
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
make -C /opt/python-openzwave/openzwave/cpp/examples/MinOZW/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
Building Main.o
Linking /opt/python-openzwave/openzwave/.lib/MinOZW
g++   -o /opt/python-openzwave/openzwave/.lib/MinOZW /opt/python-openzwave/openzwave/.lib/Main.o /opt/python-openzwave/openzwave/libopenzwave.so -pthread
Creating Temporary Shell Launch Script
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
python setup-lib.py build --build-base build/lib
running build
running build_ext
building 'libopenzwave' extension
error: unknown file type '.pyx' (from 'src-lib/libopenzwave/libopenzwave.pyx')
Makefile:257: recipe for target 'build' failed
make: *** [build] Error 1
Error while install python-openzwave
Et bien sûr, plus rien ne fonctionne :(
Dernière édition par ph3nix le 12 août 2015, 20:43, édité 1 fois.

Avatar de l’utilisateur
Pax24
Timide
Messages : 318
Inscription : 12 juin 2015, 03:42
Localisation : Périgord

Re: Nouveau plugin zwave/openzwave

Message par Pax24 » 12 août 2015, 19:55

YannickF a écrit :la compilation se passe bien avec le plugin en stable, mais Jeedom m'alerte que cette version est dépassée !
Oui je suis repassé en stable aussi pour l'instant.
Et effectivement ce message d'alerte n'a pas lieu d'être puisqu'il n'y a pas d'autre version stable !
On ne peut pas dire aux utilisateurs prudents de prendre les versions stables et alerter d'un message qui demande de passer en beta.

Bon en attendant y'a une grosse cagade, quelqu'un a trouvé ?

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Nouveau plugin zwave/openzwave

Message par loic » 12 août 2015, 19:57

J'essaye de trouver le temps de regarder ça dans la semaine mais la je comprends pas trop car j'arrive pas à reproduire
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
Pax24
Timide
Messages : 318
Inscription : 12 juin 2015, 03:42
Localisation : Périgord

Re: Nouveau plugin zwave/openzwave

Message par Pax24 » 12 août 2015, 20:03

Et pour une fois je ne suis pas le seul à qui ça arrive :lol: contrairement à mon problème d'historique :?

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Nouveau plugin zwave/openzwave

Message par loic » 12 août 2015, 20:05

L'alerte c'est du au passage beta stable qui n'est pas recommandé. La beta c'est pas fait pour un système de prod sinon ça sert à rien que je membete à gérer 2 versions
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Nouveau plugin zwave/openzwave

Message par loic » 13 août 2015, 10:16

Pouvez vous retester avec la derniere beta ?
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
darghorn
Timide
Messages : 97
Inscription : 08 nov. 2014, 04:35
Localisation : 92

Re: Nouveau plugin zwave/openzwave

Message par darghorn » 13 août 2015, 10:36

Hello @Loic,

Même souci avec la beta de ce matin :

Code : Tout sélectionner

Lancement da l'installation/mise à jour des dépendance openzwave
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
cython is already the newest version.
g++ is already the newest version.
gcc is already the newest version.
git is already the newest version.
python-louie is already the newest version.
python-lxml is already the newest version.
make is already the newest version.
mercurial is already the newest version.
python-dev is already the newest version.
python-pip is already the newest version.
python-setuptools is already the newest version.
python-sphinx is already the newest version.
libudev-dev is already the newest version.
unzip is already the newest version.
The following packages were automatically installed and are no longer required:
  avahi-daemon bind9-host gyp ifenslave libavahi-client-dev libavahi-client3
  libavahi-common-data libavahi-common-dev libavahi-common3
  libavahi-compat-libdnssd1 libavahi-core7 libbind9-90 libbluetooth3
  libbrlapi0.6 libc-ares-dev libc-ares2 libdaemon0 libdbus-1-dev libdns100
  libisc95 libisccc90 libisccfg90 libjs-node-uuid liblwres90 libnss-mdns
  libv8-3.14-dev libv8-3.14.5 pkg-config
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Installation des dependances Python
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-blockdiag in /usr/local/lib/python2.7/dist-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-actdiag in /usr/local/lib/python2.7/dist-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-nwdiag in /usr/local/lib/python2.7/dist-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-seqdiag in /usr/local/lib/python2.7/dist-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): urwid in /usr/local/lib/python2.7/dist-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): louie in /usr/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): nose>=0.8.3 in /usr/lib/python2.7/dist-packages (from louie)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): flask in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/local/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in /usr/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/local/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): markupsafe in /usr/lib/python2.7/dist-packages (from Jinja2>=2.4->flask)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): flask-restful in /usr/local/lib/python2.7/dist-packages
Cleaning up...
Sauvegarde du fichier de conf
Désinstallation de la version précédente
Installation de Python-OpenZwave
converted 'https://github.com/OpenZWave/python-openzwave/archive/6320ae88db5c6bcd3482d962269fa624055ab557.zip' (ANSI_X3.4-1968) -> 'https://github.com/OpenZWave/python-openzwave/archive/6320ae88db5c6bcd3482d962269fa624055ab557.zip' (UTF-8)
--2015-08-13 10:32:17--  https://github.com/OpenZWave/python-openzwave/archive/6320ae88db5c6bcd3482d962269fa624055ab557.zip
Resolving github.com (github.com)... 192.30.252.130
Connecting to github.com (github.com)|192.30.252.130|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://codeload.github.com/OpenZWave/python-openzwave/zip/6320ae88db5c6bcd3482d962269fa624055ab557 [following]
converted 'https://codeload.github.com/OpenZWave/python-openzwave/zip/6320ae88db5c6bcd3482d962269fa624055ab557' (ANSI_X3.4-1968) -> 'https://codeload.github.com/OpenZWave/python-openzwave/zip/6320ae88db5c6bcd3482d962269fa624055ab557' (UTF-8)
--2015-08-13 10:32:17--  https://codeload.github.com/OpenZWave/python-openzwave/zip/6320ae88db5c6bcd3482d962269fa624055ab557
Resolving codeload.github.com (codeload.github.com)... 192.30.252.144
Connecting to codeload.github.com (codeload.github.com)|192.30.252.144|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4615688 (4.4M) [application/zip]
Saving to: '/tmp/python-openzwave.zip'

     0K .......... .......... .......... .......... ..........  1%  283K 16s
    50K .......... .......... .......... .......... ....
......  2%  558K 12s
   100K .......... .......... .......... .......... ..........  3% 6.96M 8s
   150K .......... .......... .......... .......... ..........  4% 11.8M 6s
   200K .......... .......... .......... .......... ..........  5%  641K 6s
   250K .......... .......... .......... .......... ..........  6% 7.53M 5s
   300K .......... .......... .......... .......... ..........  7% 9.98M 4s
   350K .......... .......... .......... .......... ..........  8% 16.8M 4s
   400K .......... .......... .......... .......... ..........  9%  664K 4s
   450K .......... .......... .......... .......... .......... 11% 17.6M 4s
   500K .......... .......... .......... .......... .......... 12% 13.0M 3s
   550K .......... .......... .......... .......... .......... 13% 7.87M 3s
   600K .......... .......... .......... .......... .......... 14% 13.5M 3s
   650K .......... .......... .......... .......... .......... 15% 11.6M 3s
   700K .......... .......... .......... .......... .......... 16% 12.5M 2s
   750K .......... .......... .......... .......... .......... 17% 11.5M 2s
   800K .......... .......... .......... .......... .......... 18% 11.3M 2s
   850K .......... .......... .......... .......... .......... 19%  916K 2s
   900K .......... .......... .......... .......... .......... 21% 7.43M 2s
   950K .......... .......... .......... .......... .......... 22% 13.1M 2s
  1000K .......... .......... .......... .......... .......... 23% 8.55M 2s
  1050K .......... .......... .......... .......... .......... 24% 14.7M 2s
  1100K .......... .......... .......... .......... .......... 25% 11.2M 2s
  1150K .......... .......... .......... .......... .......... 26% 12.0M 2s
  1200K .......... .......... .......... .......... .......... 27% 11.8M 1s
  1250K .......... .......... .......... .......... .......... 28% 11.1M 1s
  1300K .......... .......... .......... .......... .......... 29% 10.9M 1s
  1350K .......... .......... .......... .......... .......... 31% 11.3M 1s
  1400K .......... .......... .......... .......... .......... 32% 9.36M 1s
  1450K .......... .......... .......... .......... .......... 33% 14.0M 1s
  1500K .......... .......... .......... .......... .......... 34% 12.0M 1s
  1550K .......... .......... .......... .......... .......... 35%  414K 1s
  1600K .......... .......... .......... .......... .......... 36% 9.86M 1s
  1650K .......... .......... .......... .......... .......... 37% 21.2M 1s
  1700K .......... .......... .......... .......... .......... 38% 38.3M 1s
  1750K .......... .......... .......... .......... .......... 39% 22.5M 1s
  1800K .......... .......... .......... .......... .......... 41% 33.3M 1s
  1850K .......... .......... .......... .......... .......... 42% 31.2M 1s
  1900K .......... .......... .......... .......... .......... 43% 35.9M 1s
  1950K .......... .......... .......... .......... .......... 44% 30.9M 1s
  2000K .......... .......... .......... .......... .......... 45% 35.2M 1s
  2050K .......... .......... .......... .......... .......... 46% 36.7M 1s
  2100K .......... .......... .......... .......... .......... 47% 37.6M 1s
  2150K .......... .......... .......... .......... .......... 48% 24.0M 1s
  2200K .......... .......... .......... .......... .......... 49% 37.5M 1s
  2250K .......... .......... .......... .......... .......... 51% 44.8M 1s
  2300K .......... .......... .......... .......... .......... 52% 41.7M 1s
  2350K .......... .......... .......... .......... .......... 53% 44.1M 1s
  2400K .......... .......... .......... .......... .......... 54% 1.53M 1s
  2450K .......... .......... .......... .......... .......... 55% 25.9M 1s
  2500K .......... .......... .......... .......... .......... 56% 9.61M 1s
  2550K .......... .......... .......... .......... .......... 57% 6.66M 1s
  2600K .......... .......... .......... .......... .......... 58% 38.4M 1s
  2650K .......... .......... .......... .......... .......... 59% 39.2M 1s
  2700K .......... .......... .......... .......... .......... 61% 34.3M 1s
  2750K .......... .......... .......... .......... .......... 62% 12.6M 0s
  2800K .......... .......... .......... .......... .......... 63% 18.9M 0s
  2850K .......... .......... .......... .......... .......... 64% 33.4M 0s
  2900K .......... .......... .......... .......... .......... 65% 36.3M 0s
  2950K .......... .......... .......... .......... .......... 66% 11.7M 0s
  3000K .......... .......... .......... .......... .......... 67% 25.2M 0s
  3050K .......... .......... .......... .......... .......... 68% 25.6M 0s
  3100K .......... .......... .......... .......... .......... 69% 39.4M 0s
  3150K .......... .......... .......... .......... .......... 70% 29.5M 0s
  3200K .......... .......... .......... .......... .......... 72% 41.7M 0s
  3250K .......... .......... .......... .......... .......... 73% 34.4M 0s
  3300K .......... .......... .......... .......... .......... 74% 27.7M 0s
  3350K .......... .......... .......... .......... .......... 75% 27.8M 0s
  3400K .......... .......... .......... .......... .......... 76% 34.7M 0s
  3450K .......... .......... .......... .......... .......... 77% 32.4M 0s
  3500K .......... .......... .......... .......... .......... 78% 33.4M 0s
  3550K .......... .......... .......... .......... .......... 79% 17.2M 0s
  3600K .......... .......... .......... .......... .......... 80% 11.1M 0s
  3650K .......... .......... .......... .......... .......... 82% 12.5M 0s
  3700K .......... .......... .......... .......... .......... 83% 13.1M 0s
  3750K .......... .......... .......... .......... .......... 84% 9.39M 0s
  3800K .......... .......... .......... .......... .......... 85%  536K 0s
  3850K .......... .......... .......... .......... .......... 86% 45.7M 0s
  3900K .......... .......... .......... .......... .......... 87% 45.0M 0s
  3950K .......... .......... .......... .......... .......... 88% 41.0M 0s
  4000K .......... .......... .......... .......... .......... 89% 4.18M 0s
  4050K .......... .......... .......... .......... .......... 90% 44.3M 0s
  4100K .......... .......... .......... .......... .......... 92% 9.96M 0s
  4150K .......... .......... .......... .......... .......... 93% 35.5M 0s
  4200K .......... .......... .......... .......... .......... 94% 39.3M 0s
  4250K .......... .......... .......... .......... .......... 95% 40.2M 0s
  4300K .......... .......... .......... .......... .......... 96% 44.9M 0s
  4350K .......... .......... .......... .......... .......... 97% 43.7M 0s
  4400K .......... .......... .......... .......... .......... 98% 42.1M 0s
  4450K .......... .......... .......... .......... .......... 99% 36.7M 0s
  4500K .......                                               100% 36.4M=1.0s

2015-08-13 10:32:19 (4.57 MB/s) - '/tmp/python-openzwave.zip' saved [4615688/4615688]

converted 'https://github.com/OpenZWave/open-zwave/archive/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c.zip' (ANSI_X3.4-1968) -> 'https://github.com/OpenZWave/open-zwave/archive/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c.zip' (UTF-8)
--2015-08-13 10:32:19--  https://github.com/OpenZWave/open-zwave/archive/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c.zip
Resolving github.com (github.com)... 192.30.252.130
Connecting to github.com (github.com)|192.30.252.130|:443... 
connected.
HTTP request sent, awaiting response... 302 Found
Location: https://codeload.github.com/OpenZWave/open-zwave/zip/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c [following]
converted 'https://codeload.github.com/OpenZWave/open-zwave/zip/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c' (ANSI_X3.4-1968) -> 'https://codeload.github.com/OpenZWave/open-zwave/zip/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c' (UTF-8)
--2015-08-13 10:32:19--  https://codeload.github.com/OpenZWave/open-zwave/zip/0432f68a7d331bdde4c0b77b2b81bcf9bd37795c
Resolving codeload.github.com (codeload.github.com)... 192.30.252.144
Connecting to codeload.github.com (codeload.github.com)|192.30.252.144|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1380613 (1.3M) [application/zip]
Saving to: '/tmp/openzwave.zip'

     0K .......... .......... .......... .......... ..........  3%  272K 5s
    50K .......... .......... .......... .......... ..........  7%  558K 3s
   100K .......... .......... .......... .......... .......... 11% 17.4M 2s
   150K .......... .......... .......... .......... .......... 14% 11.5M 2s

   200K .......... .......... .......... .......... .......... 18%  583K 2s
   250K .......... .......... .......... .......... .......... 22% 11.7M 1s
   300K .......... .......... .......... .......... .......... 25% 12.5M 1s
   350K .......... .......... .......... .......... .......... 29% 8.60M 1s
   400K .......... .......... .......... .......... .......... 33%  674K 1s
   450K .......... .......... .......... .......... .......... 37% 12.4M 1s
   500K .......... .......... .......... .......... .......... 40% 14.1M 1s
   550K .......... .......... .......... .......... .......... 44% 11.1M 1s
   600K .......... .......... .......... .......... .......... 48% 11.5M 1s
   650K .......... .......... .......... .......... .......... 51% 11.5M 0s
   700K .......... .......... .......... .......... .......... 55% 11.5M 0s
   750K .......... .......... .......... .......... .......... 59% 10.8M 0s
   800K .......... .......... .......... .......... .......... 63%  921K 0s
   850K .......... .......... .......... .......... .......... 66% 5.78M 0s
   900K .......... .......... .......... .......... .......... 70% 17.5M 0s
   950K .......... .......... .......... .......... .......... 74% 10.8M 0s
  1000K .......... .......... .......... .......... .......... 77% 11.2M 0s
  1050K .......... .......... .......... .......... .......... 81% 11.4M 0s
  1100K .......... .......... .......... .......... .......... 85% 8.27M 0s
  1150K .......... .......... .......... .......... .......... 89% 16.8M 0s
  1200K .......... .......... .......... .......... .......... 92% 11.0M 0s
  1250K .......... .......... .......... .......... .......... 96% 11.2M 0s
  1300K .......... .......... .......... .......... ........  100% 11.5M=0.6s

2015-08-13 10:32:20 (2.25 MB/s) - '/tmp/openzwave.zip' saved [1380613/1380613]

Installing dependencies for python : 2 7 9
apt-get install -y python-pip python-dev python-docutils python-setuptools python-louie
Reading package lists...
Building dependency tree...
Reading state information...
python-louie is already the newest version.
python-dev is already the newest version.
python-docutils is already the newest version.
python-docutils set to manually installed.
python-pip is already the newest version.
python-setuptools is already the newest version.
The following packages were automatically installed and are no longer required:
  avahi-daemon bind9-host gyp ifenslave libavahi-client-dev libavahi-client3
  libavahi-common-data libavahi-common-dev libavahi-common3
  libavahi-compat-libdnssd1 libavahi-core7 libbind9-90 libbluetooth3
  libbrlapi0.6 libc-ares-dev libc-ares2 libdaemon0 libdbus-1-dev libdns100
  libisc95 libisccc90 libisccfg90 libjs-node-uuid liblwres90 libnss-mdns
  libv8-3.14-dev libv8-3.14.5 pkg-config
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
apt-get install -y build-essential libudev-dev g++
Reading package lists...
Building dependency tree...

Reading state information...
build-essential is already the newest version.
g++ is already the newest version.
libudev-dev is already the newest version.
The following packages were automatically installed and are no longer required:
  avahi-daemon bind9-host gyp ifenslave libavahi-client-dev libavahi-client3
  libavahi-common-data libavahi-common-dev libavahi-common3
  libavahi-compat-libdnssd1 libavahi-core7 libbind9-90 libbluetooth3
  libbrlapi0.6 libc-ares-dev libc-ares2 libdaemon0 libdbus-1-dev libdns100
  libisc95 libisccc90 libisccfg90 libjs-node-uuid liblwres90 libnss-mdns
  libv8-3.14-dev libv8-3.14.5 pkg-config
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
apt-get install -y cython
Reading package lists...
Building dependency tree...
Reading state information...
cython is already the newest version.
The following packages were automatically installed and are no longer required:
  avahi-daemon bind9-host gyp ifenslave libavahi-client-dev libavahi-client3
  libavahi-common-data libavahi-common-dev libavahi-common3
  libavahi-compat-libdnssd1 libavahi-core7 libbind9-90 libbluetooth3
  libbrlapi0.6 libc-ares-dev libc-ares2 libdaemon0 libdbus-1-dev libdns100
  libisc95 libisccc90 libisccfg90 libjs-node-uuid liblwres90 libnss-mdns
  libv8-3.14-dev libv8-3.14.5 pkg-config
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
pip install nose-html
Downloading/unpacking nose-html
  Downloading nose-html-1.1.tar.gz
  Running setup.py (path:/tmp/pip-build-1exAUj/nose-html/setup.py) egg_info for package nose-html
    
Requirement already satisfied (use --upgrade to upgrade): nose>=0.11.1 in /usr/lib/python2.7/dist-packages (from nose-html)
Installing collected packages: nose-html
  Running setup.py install for nose-html
    
Successfully installed nose-html
Cleaning up...
pip install nose-progressive
Downloading/unpacking nose-progressive
  Downloading nose_progressive-1.5.1-py2-none-any.whl
Requirement already satisfied (use --upgrade to upgrade): nose>=1.2.1 in /usr/lib/python2.7/dist-packages (from nose-progressive)
Downloading/unpacking blessings>=1.3,<2.0 (from nose-progressive)
  Downloading blessings-1.6.tar.gz
  Running setup.py (path:/tmp/pip-build-F94tmp/blessings/setup.py) egg_info for package blessings
    
Installing collected packages: nose-progressive, blessings
  Running setup.py install for blessings
    
Successfully installed nose-progressive blessings
Cleaning up...
pip install coverage
Downloading/unpacking coverage
  Running setup.py (path:/tmp/pip-build-9Cw5kB/coverage/setup.py) egg_info for package coverage
    
    warning: no previously-included files matching '*.pyc' found anywhere in distribution
Installing collected packages: coverage
  Running setup.py install for coverage
    building 'coverage.tracer' extension
    i586-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -I/usr/include/python2.7 -c coverage/tracer.c -o build/temp.linux-i686-2.7/coverage/tracer.o
    i586-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-i686-2.7/coverage/tracer.o -o build/lib.linux-i686-2.7/coverage/tracer.so
    
    warning: no previously-included files matching '*.pyc' found anywhere in distribution
    Installing coverage2 script to /usr/local/bin
    Installing coverage-2.7 script to /usr/local/bin
    Installing coverage script to /usr/local/bin
Successfully installed coverage
Cleaning up...
pip install nose
Requirement already satisfied (use --upgrade to upgrade): nose in /usr/lib/python2.7/dist-packages
Cleaning up...
pip install pylint
Downloading/unpacking pylint
Requirement already satisfied (use --upgrade to upgrade): six in /usr/lib/python2.7/dist-packages (from pylint)
Downloading/unpacking astroid>=1.3.6 (from pylint)
Downloading/unpacking logilab-common>=0.53.0 (from pylint)
  Running setup.py (path:/tmp/pip-build-SxqxKo/logilab-common/setup.py) egg_info for package logilab-common
    
    warning: no files found matching '*.py' under directory 'test/input'
    warning: no files found matching '*' under directory 'doc/html'
Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/lib/python2.7/dist-packages (from logilab-common>=0.53.0->pylint)
Installing collected packages: pylint, astroid, logilab-common
/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_assert_2uple.py:4: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, 2 == 2), "no error"
/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_assert_2uple.py:5: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, 2 == 2) #this should generate a warning
/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_assert_2uple.py:7: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, ), "no error"
/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_assert_2uple.py:8: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, )
/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_assert_2uple.py:9: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, 2 == 2, 3 == 5), "no error"
/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_assert_2uple.py:11: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (True, 'error msg') #this should generate a warning
Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_abc_methods.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_abc_methods.py", line 6
    class Parent(object, metaclass=abc.ABCMeta):
                                  ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_class_instantiated_py2.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_class_instantiated_py2.py", line 15
    class GoodClass(object, metaclass=abc.ABCMeta):
                                     ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_class_instantiated_py3.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_class_instantiated_py3.py", line 14
    class GoodClass(object, metaclass=abc.ABCMeta):
                                     ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_method_py2.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_method_py2.py", line 35
    class Structure(object, metaclass=abc.ABCMeta):
                                     ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_method_py3.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/abstract_method_py3.py", line 35
    class Structure(object, metaclass=abc.ABCMeta):
                                     ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/class_members_py27.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/class_members_py27.py", line 34
    class TestMetaclass(object, metaclass=ABCMeta):
                                         ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/class_members_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/class_members_py30.py", line 34
    class TestMetaclass(object, metaclass=ABCMeta):
                                         ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/no_name_in_module.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/no_name_in_module.py", line 15
    print('hello world', file=sys.stdout)
                             ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/old_style_class_py27.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/old_style_class_py27.py", line 10
    class NotOldStyle2(metaclass=type):
                                ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/raising_non_exception_py3.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/raising_non_exception_py3.py", line 13
    raise Exc from missing # [raising-non-exception]
                 ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/unbalanced_tuple_unpacking_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/unbalanced_tuple_unpacking_py30.py", line 9
    first, second, *last = (1, 2, 3, 4)
                   ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/undefined_variable_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/undefined_variable_py30.py", line 8
    def test(self)->Undefined: # [undefined-variable]
                  ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/functional/yield_outside_func.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/functional/yield_outside_func.py", line 2
    yield 1  # [yield-outside-function]
SyntaxError: 'yield' outside function

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_bad_exception_context_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_bad_exception_context_py30.py", line 14
    raise IndexError from 1
                        ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_continue_not_in_loop.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_continue_not_in_loop.py", line 8
    continue
SyntaxError: 'continue' not properly in loop

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_e0108.py ...
SyntaxError: duplicate argument '_' in function definition (func_e0108.py, line 4)

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_exec_used_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_exec_used_py30.py", line 6
    exec('a = 1', globals={})
                         ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_keyword_repeat.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_keyword_repeat.py", line 8
    function_default_arg(two=5, two=7)
SyntaxError: keyword argument repeated

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_kwoa_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_kwoa_py30.py", line 3
    def function(*, foo):
                  ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_noerror_mcs_attr_access.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_noerror_mcs_attr_access.py", line 14
    class Test(object, metaclass=Meta):
                                ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_noerror_unused_variable_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_noerror_unused_variable_py30.py", line 12
    nonlocal attr
                ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_return_outside_func.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_return_outside_func.py", line 3
    return
SyntaxError: 'return' outside function

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_return_yield_mix_py_33.py ...
SyntaxError: 'return' with argument inside generator (func_return_yield_mix_py_33.py, line 8)

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_syntax_error.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_syntax_error.py", line 1
    def toto
           ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_undefined_metaclass_var_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_undefined_metaclass_var_py30.py", line 8
    class Bad(metaclass=ABCMet):
                       ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_unused_import_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_unused_import_py30.py", line 10
    class Meta(metaclass=abc.ABCMeta):
                        ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_used_before_assignment_py30.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_used_before_assignment_py30.py", line 10
    nonlocal cnt
               ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_w0705.py ...
  File "/tmp/pip-build-SxqxKo/pylint/pylint/test/input/func_w0705.py", line 28
    __revision__ += 1
SyntaxError: default 'except:' must be last

Compiling /tmp/pip-build-SxqxKo/pylint/pylint/test/input/syntax_error.py ...
Sorry: IndentationError: expected an indented block (syntax_error.py, line 2)
Compiling /tmp/pip-build-SxqxKo/astroid/astroid/tests/testdata/python3/data/module.py ...
  File "/tmp/pip-build-SxqxKo/astroid/astroid/tests/testdata/python3/data/module.py", line 55
    print('yo', end=' ')
                   ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-SxqxKo/astroid/astroid/tests/testdata/python3/data/module2.py ...
  File "/tmp/pip-build-SxqxKo/astroid/astroid/tests/testdata/python3/data/module2.py", line 100
    print('bonjour', file=stream)
                         ^
SyntaxError: invalid syntax

  Running setup.py install for logilab-common
    changing mode of build/scripts-2.7/pytest from 644 to 755
    Skipping installation of /usr/local/lib/python2.7/dist-packages/logilab/__init__.py (namespace package)
    
    warning: no files found matching '*.py' under directory 'test/input'
    warning: no files found matching '*' under directory 'doc/html'
    Installing /usr/local/lib/python2.7/dist-packages/logilab_common-1.0.2-nspkg.pth
    changing mode of /usr/local/bin/pytest to 755
Successfully installed pylint astroid logilab-common
Cleaning up...
#pip install docutils
#pip install setuptools
#The following line crashes with a core dump
#pip install "Cython==0.22"

Dependencies for users installed (python 2 7 9)
sed -i '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1]: Entering directory '/opt/python-openzwave/openzwave'
make -C /opt/python-openzwave/openzwave/cpp/build/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.3.-1
Building tinystr.o
Building tinyxmlerror.o
Building tinyxml.o
Building tinyxmlparser.o
Building hid.o
Building aeskey.o
Building aescrypt.o
Building aestab.o
Building aes_modes.o
Building SensorAlarm.o
Building Proprietary.o
Building SwitchToggleMultilevel.o
Building SensorBinary.o
Building Language.o
Building Indicator.o
Building CRC16Encap.o
Building MeterPulse.o
Building DoorLockLogging.o
Building ThermostatFanMode.o
Building Configuration.o
Building SwitchToggleBinary.o
Building Hail.o
Building ThermostatMode.o
Building SensorMultilevel.o
Building TimeParameters.o
Building UserCode.o
Building Color.o
Building BasicWindowCovering.o
Building Lock.o
Building ThermostatSetpoint.o
Building ClimateControlSchedule.o
Building ApplicationStatus.o
Building CentralScene.o
Building DoorLock.o
Building Protection.o
Building CommandClass.o
Building NodeNaming.o
Building WakeUp.o
Building MultiCmd.o
Building MultiInstanceAssociation.o
Building Association.o
Building ManufacturerSpecific.o
Building SceneActivation.o
Building Powerlevel.o
Building MultiInstance.o
Building AssociationCommandConfiguration.o
Building ThermostatOperatingState.o
Building SwitchMultilevel.o
Building Battery.o
Building Version.o
Building ZWavePlusInfo.o
Building Security.o
Building Clock.o
Building Alarm.o
Building CommandClasses.o
Building ThermostatFanState.o
Building NoOperation.o
Building SwitchAll.o
Building Basic.o
Building EnergyProduction.o
Building DeviceResetLocally.o
Building ControllerReplication.o
Building Meter.o
Building SwitchBinary.o
Building Value.o
Building ValueList.o
Building ValueButton.o
Building ValueStore.o
Building ValueDecimal.o
Building ValueRaw.o
Building ValueString.o
Building ValueByte.o
Building ValueBool.o
Building ValueSchedule.o
Building ValueShort.o
Building Controller.o
Building Wait.o
Building Thread.o
Building Stream.o
Building Log.o
Building HidController.o
Building Mutex.o
Building SerialController.o
Building Event.o
Building FileOps.o
Building TimeStamp.o
Building FileOpsImpl.o
Building TimeStampImpl.o
Building WaitImpl.o
Building ThreadImpl.o
Building LogImpl.o
Building MutexImpl.o
Building SerialControllerImpl.o
Building EventImpl.o
Building Options.o
Building Scene.o
Building Utils.o
Building Driver.o
Building ZWSecurity.o
Building Group.o
Building Node.o
Building Manager.o
Building Msg.o
Building Notification.o
Creating vers.cpp
Building vers.o
Linking Static Library
Linking Shared Library
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
make -C /opt/python-openzwave/openzwave/cpp/examples/MinOZW/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
Building Main.o
Linking /opt/python-openzwave/openzwave/.lib/MinOZW
g++   -o /opt/python-openzwave/openzwave/.lib/MinOZW /opt/python-openzwave/openzwave/.lib/Main.o /opt/python-openzwave/openzwave/libopenzwave.so -pthread
Creating Temporary Shell Launch Script
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
python setup-lib.py build --build-base build/lib
running build
running build_ext
building 'libopenzwave' extension
error: unknown file type '.pyx' (from 'src-lib/libopenzwave/libopenzwave.pyx')
Makefile:257: recipe for target 'build' failed
make: *** [build] Error 1
sed -i '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1]: Entering directory '/opt/python-openzwave/openzwave'
make -C /opt/python-openzwave/openzwave/cpp/build/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.3.-1
Building SensorAlarm.o
Building Proprietary.o
Building SwitchToggleMultilevel.o
Building SensorBinary.o
Building Language.o
Building Indicator.o
Building CRC16Encap.o
Building MeterPulse.o
Building ThermostatFanMode.o
Building Configuration.o
Building SwitchToggleBinary.o
Building Hail.o
Building ThermostatMode.o
Building SensorMultilevel.o
Building TimeParameters.o
Building UserCode.o
Building Color.o
Building BasicWindowCovering.o
Building Lock.o
Building ThermostatSetpoint.o
Building ClimateControlSchedule.o
Building ApplicationStatus.o
Building CentralScene.o
Building DoorLock.o
Building Protection.o
Building CommandClass.o
Building NodeNaming.o
Building WakeUp.o
Building MultiCmd.o
Building MultiInstanceAssociation.o
Building Association.o
Building ManufacturerSpecific.o
Building SceneActivation.o
Building Powerlevel.o
Building MultiInstance.o
Building AssociationCommandConfiguration.o
Building ThermostatOperatingState.o
Building SwitchMultilevel.o
Building Battery.o
Building Version.o
Building ZWavePlusInfo.o
Building Security.o
Building Clock.o
Building Alarm.o
Building CommandClasses.o
Building ThermostatFanState.o
Building NoOperation.o
Building SwitchAll.o
Building Basic.o
Building EnergyProduction.o
Building DeviceResetLocally.o
Building ControllerReplication.o
Building Meter.o
Building SwitchBinary.o
Building Value.o
Building ValueList.o
Building ValueButton.o
Building ValueInt.o
Building ValueStore.o
Building ValueDecimal.o
Building ValueRaw.o
Building ValueString.o
Building ValueByte.o
Building ValueBool.o
Building ValueSchedule.o
Building ValueShort.o
Building Controller.o
Building HidController.o
Building SerialController.o
Building SerialControllerImpl.o
Building Options.o
Building Scene.o
Building Driver.o
Building ZWSecurity.o
Building Group.o
Building Node.o
Building Manager.o
Building Msg.o
Building Notification.o
Linking Static Library
Linking Shared Library
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
make -C /opt/python-openzwave/openzwave/cpp/examples/MinOZW/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
Building Main.o
Linking /opt/python-openzwave/openzwave/.lib/MinOZW
g++   -o /opt/python-openzwave/openzwave/.lib/MinOZW /opt/python-openzwave/openzwave/.lib/Main.o /opt/python-openzwave/openzwave/libopenzwave.so -pthread
Creating Temporary Shell Launch Script
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
python setup-lib.py build --build-base build/lib
running build
running build_ext
building 'libopenzwave' extension
error: unknown file type '.pyx' (from 'src-lib/libopenzwave/libopenzwave.pyx')
Makefile:257: recipe for target 'build' failed
make: *** [build] Error 1
Error while install python-openzwave
DIY / VM Debian sur ESXi 6.5 - ProLiant MicroServer Gen8
Protocoles : Z-Wave+ / Hue / Xiaomi

domars
Timide
Messages : 245
Inscription : 13 mars 2015, 12:53

Re: Nouveau plugin zwave/openzwave

Message par domars » 13 août 2015, 10:37

Pas mieux...
J'ai vu passer quelques erreurs de syntaxe vers le début du log.

Code : Tout sélectionner

pip install nose
Requirement already satisfied (use --upgrade to upgrade): nose in /usr/lib/python2.7/dist-packages
Cleaning up...
pip install pylint
Downloading/unpacking pylint
Downloading/unpacking logilab-common>=0.53.0 (from pylint)
  Running setup.py (path:/tmp/pip-build-eWF2jF/logilab-common/setup.py) egg_info for package logilab-common
    
    warning: no files found matching '*.py' under directory 'test/input'
    warning: no files found matching '*' under directory 'doc/html'
Requirement already satisfied (use --upgrade to upgrade): six in /usr/lib/python2.7/dist-packages (from pylint)
Downloading/unpacking astroid>=1.3.6 (from pylint)
Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/lib/python2.7/dist-packages (from logilab-common>=0.53.0->pylint)
Installing collected packages: pylint, logilab-common, astroid
/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_assert_2uple.py:4: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, 2 == 2), "no error"
/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_assert_2uple.py:5: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, 2 == 2) #this should generate a warning
/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_assert_2uple.py:7: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, ), "no error"
/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_assert_2uple.py:8: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, )
/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_assert_2uple.py:9: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (1 == 1, 2 == 2, 3 == 5), "no error"
/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_assert_2uple.py:11: SyntaxWarning: assertion is always true, perhaps remove parentheses?
  assert (True, 'error msg') #this should generate a warning
Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_abc_methods.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_abc_methods.py", line 6
    class Parent(object, metaclass=abc.ABCMeta):
                                  ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_class_instantiated_py2.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_class_instantiated_py2.py", line 15
    class GoodClass(object, metaclass=abc.ABCMeta):
                                     ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_class_instantiated_py3.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_class_instantiated_py3.py", line 14
    class GoodClass(object, metaclass=abc.ABCMeta):
                                     ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_method_py2.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_method_py2.py", line 35
    class Structure(object, metaclass=abc.ABCMeta):
                                     ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_method_py3.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/abstract_method_py3.py", line 35
    class Structure(object, metaclass=abc.ABCMeta):
                                     ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/class_members_py27.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/class_members_py27.py", line 34
    class TestMetaclass(object, metaclass=ABCMeta):
                                         ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/class_members_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/class_members_py30.py", line 34
    class TestMetaclass(object, metaclass=ABCMeta):
                                         ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/no_name_in_module.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/no_name_in_module.py", line 15
    print('hello world', file=sys.stdout)
                             ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/old_style_class_py27.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/old_style_class_py27.py", line 10
    class NotOldStyle2(metaclass=type):
                                ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/raising_non_exception_py3.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/raising_non_exception_py3.py", line 13
    raise Exc from missing # [raising-non-exception]
                 ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/unbalanced_tuple_unpacking_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/unbalanced_tuple_unpacking_py30.py", line 9
    first, second, *last = (1, 2, 3, 4)
                   ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/undefined_variable_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/undefined_variable_py30.py", line 8
    def test(self)->Undefined: # [undefined-variable]
                  ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/functional/yield_outside_func.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/functional/yield_outside_func.py", line 2
    yield 1  # [yield-outside-function]
SyntaxError: 'yield' outside function

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_bad_exception_context_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_bad_exception_context_py30.py", line 14
    raise IndexError from 1
                        ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_continue_not_in_loop.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_continue_not_in_loop.py", line 8
    continue
SyntaxError: 'continue' not properly in loop

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_e0108.py ...
SyntaxError: duplicate argument '_' in function definition (func_e0108.py, line 4)

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_exec_used_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_exec_used_py30.py", line 6
    exec('a = 1', globals={})
                         ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_keyword_repeat.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_keyword_repeat.py", line 8
    function_default_arg(two=5, two=7)
SyntaxError: keyword argument repeated

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_kwoa_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_kwoa_py30.py", line 3
    def function(*, foo):
                  ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_noerror_mcs_attr_access.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_noerror_mcs_attr_access.py", line 14
    class Test(object, metaclass=Meta):
                                ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_noerror_unused_variable_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_noerror_unused_variable_py30.py", line 12
    nonlocal attr
                ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_return_outside_func.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_return_outside_func.py", line 3
    return
SyntaxError: 'return' outside function

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_return_yield_mix_py_33.py ...
SyntaxError: 'return' with argument inside generator (func_return_yield_mix_py_33.py, line 8)

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_syntax_error.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_syntax_error.py", line 1
    def toto
           ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_undefined_metaclass_var_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_undefined_metaclass_var_py30.py", line 8
    class Bad(metaclass=ABCMet):
                       ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_unused_import_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_unused_import_py30.py", line 10
    class Meta(metaclass=abc.ABCMeta):
                        ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_used_before_assignment_py30.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_used_before_assignment_py30.py", line 10
    nonlocal cnt
               ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_w0705.py ...
  File "/tmp/pip-build-eWF2jF/pylint/pylint/test/input/func_w0705.py", line 28
    __revision__ += 1
SyntaxError: default 'except:' must be last

Compiling /tmp/pip-build-eWF2jF/pylint/pylint/test/input/syntax_error.py ...
Sorry: IndentationError: expected an indented block (syntax_error.py, line 2)
  Running setup.py install for logilab-common
    changing mode of build/scripts-2.7/pytest from 644 to 755
    Skipping installation of /usr/local/lib/python2.7/dist-packages/logilab/__init__.py (namespace package)
    
    warning: no files found matching '*.py' under directory 'test/input'
    warning: no files found matching '*' under directory 'doc/html'
    Installing /usr/local/lib/python2.7/dist-packages/logilab_common-1.0.2-nspkg.pth
    changing mode of /usr/local/bin/pytest to 755
Compiling /tmp/pip-build-eWF2jF/astroid/astroid/tests/testdata/python3/data/module.py ...
  File "/tmp/pip-build-eWF2jF/astroid/astroid/tests/testdata/python3/data/module.py", line 55
    print('yo', end=' ')
                   ^
SyntaxError: invalid syntax

Compiling /tmp/pip-build-eWF2jF/astroid/astroid/tests/testdata/python3/data/module2.py ...
  File "/tmp/pip-build-eWF2jF/astroid/astroid/tests/testdata/python3/data/module2.py", line 100
    print('bonjour', file=stream)
                         ^
SyntaxError: invalid syntax

Successfully installed pylint logilab-common astroid
Cleaning up...
#pip install docutils
#pip install setuptools
#The following line crashes with a core dump
#pip install "Cython==0.22"

Dependencies for users installed (python 2 7 9)
sed -i '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1]: Entering directory '/opt/python-openzwave/openzwave'
make -C /opt/python-openzwave/openzwave/cpp/build/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.3.-1
Building tinystr.o
Building tinyxmlerror.o
Building tinyxml.o
Building tinyxmlparser.o
Building hid.o
Building aeskey.o
Building aescrypt.o
Building aestab.o
Building aes_modes.o
Building SensorAlarm.o
Building Proprietary.o
Building SensorBinary.o
Building Language.o
Building BasicWindowCovering.o
Building ClimateControlSchedule.o
Building SwitchMultilevel.o
Building Meter.o
Building Indicator.o
Building CRC16Encap.o
Building DeviceResetLocally.o
Building DoorLock.o
Building ManufacturerSpecific.o
Building ThermostatFanMode.o
Building CentralScene.o
Building Configuration.o
Building SwitchToggleBinary.o
Building ThermostatMode.o
Building NoOperation.o
Building TimeParameters.o
Building UserCode.o
Building MeterPulse.o
Building Lock.o
Building Color.o
Building ThermostatFanState.o
Building ApplicationStatus.o
Building Hail.o
Building ZWavePlusInfo.o
Building NodeNaming.o
Building WakeUp.o
Building SwitchAll.o
Building SensorMultilevel.o
Building MultiCmd.o
Building MultiInstanceAssociation.o
Building Association.o
Building Clock.o
Building SceneActivation.o
Building Powerlevel.o
Building AssociationCommandConfiguration.o
Building ThermostatOperatingState.o
Building Version.o
Building Battery.o
Building MultiInstance.o
Building SwitchBinary.o
Building Alarm.o
Building CommandClasses.o
Building ThermostatSetpoint.o
Building Security.o
Building EnergyProduction.o
Building Basic.o
Building CommandClass.o
Building DoorLockLogging.o
Building ControllerReplication.o
Building Protection.o
Building SwitchToggleMultilevel.o
Building Value.o
Building ValueList.o
Building ValueButton.o
Building ValueInt.o
Building ValueStore.o
Building ValueDecimal.o
Building ValueRaw.o
Building ValueString.o
Building ValueByte.o
Building ValueBool.o
Building ValueSchedule.o
Building ValueShort.o
Building Controller.o
Building Wait.o
Building Thread.o
Building Stream.o
Building Log.o
Building HidController.o
Building Mutex.o
Building SerialController.o
Building Event.o
Building FileOps.o
Building TimeStamp.o
Building FileOpsImpl.o
Building TimeStampImpl.o
Building WaitImpl.o
Building ThreadImpl.o
Building LogImpl.o
Building MutexImpl.o
Building SerialControllerImpl.o
Building EventImpl.o
Building Options.o
Building Scene.o
Building Utils.o
Building Driver.o
Building ZWSecurity.o
Building Group.o
Building Node.o
Building Manager.o
Building Msg.o
Building Notification.o
Creating vers.cpp
Building vers.o
Linking Static Library
Linking Shared Library
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
make -C /opt/python-openzwave/openzwave/cpp/examples/MinOZW/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
Building Main.o
Linking /opt/python-openzwave/openzwave/.lib/MinOZW
g++   -o /opt/python-openzwave/openzwave/.lib/MinOZW /opt/python-openzwave/openzwave/.lib/Main.o /opt/python-openzwave/openzwave/libopenzwave.so -pthread
Creating Temporary Shell Launch Script
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
python setup-lib.py build --build-base build/lib
running build
running build_ext
building 'libopenzwave' extension
error: unknown file type '.pyx' (from 'src-lib/libopenzwave/libopenzwave.pyx')
Makefile:257: recipe for target 'build' failed
make: *** [build] Error 1
sed -i '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1]: Entering directory '/opt/python-openzwave/openzwave'
make -C /opt/python-openzwave/openzwave/cpp/build/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.3.-1
Building SensorAlarm.o
Building Proprietary.o
Building SensorBinary.o
Building Language.o
Building BasicWindowCovering.o
Building ClimateControlSchedule.o
Building SwitchMultilevel.o
Building Meter.o
Building Indicator.o
Building CRC16Encap.o
Building DeviceResetLocally.o
Building DoorLock.o
Building ManufacturerSpecific.o
Building ThermostatFanMode.o
Building CentralScene.o
Building Configuration.o
Building SwitchToggleBinary.o
Building ThermostatMode.o
Building NoOperation.o
Building TimeParameters.o
Building UserCode.o
Building MeterPulse.o
Building Lock.o
Building Color.o
Building ThermostatFanState.o
Building ApplicationStatus.o
Building Hail.o
Building ZWavePlusInfo.o
Building NodeNaming.o
Building WakeUp.o
Building SwitchAll.o
Building SensorMultilevel.o
Building MultiCmd.o
Building MultiInstanceAssociation.o
Building Association.o
Building Clock.o
Building SceneActivation.o
Building Powerlevel.o
Building AssociationCommandConfiguration.o
Building ThermostatOperatingState.o
Building Version.o
Building Battery.o
Building MultiInstance.o
Building SwitchBinary.o
Building Alarm.o
Building CommandClasses.o
Building ThermostatSetpoint.o
Building Security.o
Building EnergyProduction.o
Building Basic.o
Building CommandClass.o
Building DoorLockLogging.o
Building ControllerReplication.o
Building Protection.o
Building SwitchToggleMultilevel.o
Building Value.o
Building ValueList.o
Building ValueButton.o
Building ValueInt.o
Building ValueStore.o
Building ValueDecimal.o
Building ValueRaw.o
Building ValueString.o
Building ValueByte.o
Building ValueBool.o
Building ValueSchedule.o
Building ValueShort.o
Building Controller.o
Building HidController.o
Building SerialController.o
Building SerialControllerImpl.o
Building Options.o
Building Scene.o
Building Driver.o
Building ZWSecurity.o
Building Group.o
Building Node.o
Building Manager.o
Building Msg.o
Building Notification.o
Linking Static Library
Linking Shared Library
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
make -C /opt/python-openzwave/openzwave/cpp/examples/MinOZW/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
Building Main.o
Linking /opt/python-openzwave/openzwave/.lib/MinOZW
g++   -o /opt/python-openzwave/openzwave/.lib/MinOZW /opt/python-openzwave/openzwave/.lib/Main.o /opt/python-openzwave/openzwave/libopenzwave.so -pthread
Creating Temporary Shell Launch Script
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
python setup-lib.py build --build-base build/lib
running build
running build_ext
building 'libopenzwave' extension
error: unknown file type '.pyx' (from 'src-lib/libopenzwave/libopenzwave.pyx')
Makefile:257: recipe for target 'build' failed
make: *** [build] Error 1
Error while install python-openzwave

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Nouveau plugin zwave/openzwave

Message par loic » 13 août 2015, 10:57

Et la avec la dernière beta ?
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

lucaseva
Timide
Messages : 165
Inscription : 12 janv. 2015, 20:39

Re: Nouveau plugin zwave/openzwave

Message par lucaseva » 13 août 2015, 12:14

Idem @loic

Code : Tout sélectionner

/opt/python-openzwave/openzwave/cpp/build/support.mk:106: recipe for target '/opt/python-openzwave/openzwave/.lib/tinystr.o' failed
make[2]: *** [/opt/python-openzwave/openzwave/.lib/tinystr.o] Error 1
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
Makefile:20: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
Makefile:268: recipe for target 'openzwave/libopenzwave.a' failed
make: *** [openzwave/libopenzwave.a] Error 2
grep: /etc/udev/rules.d/98-usb-serial.rules: No such file or directory
Starting system nodejs Daemon:.
Everything is successfully installed!
Merci pour le Travail

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Nouveau plugin zwave/openzwave

Message par loic » 13 août 2015, 12:24

Il me faut la log complète
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Technopaul
Timide
Messages : 115
Inscription : 14 nov. 2014, 19:00
Localisation : Cagnes Sur Mer

Re: Nouveau plugin zwave/openzwave

Message par Technopaul » 13 août 2015, 12:47

loic a écrit :Et la avec la dernière beta ?
bonjour Loic

Installation de la dernière bêta Version 1.5.2 - 2015-08-13 11:00:48 Ok

DIY Pentium Intel Double core
Linux Ubuntu 15.04 Ok aussi sur Ubuntu 15.10
Kernel Version 4.2.0-040200rc1-generic (SMP) x86_64
Version PHP 5.6.4-4ubuntu6.2
Version NodeJS 0.12.7

Merci Loic

Paul

lucaseva
Timide
Messages : 165
Inscription : 12 janv. 2015, 20:39

Re: Nouveau plugin zwave/openzwave

Message par lucaseva » 13 août 2015, 14:17

tout le log @loic:

Code : Tout sélectionner

Reading state information...
git is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python-pip is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python-setuptools is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python-louie is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python-sphinx is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
make is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libudev-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
g++ is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
gcc is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python-lxml is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
unzip is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Installation des dependances Python
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-blockdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.5.0 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-blockdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-actdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.5.0 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): actdiag>=0.5.3 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-actdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-nwdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.5.0 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): nwdiag>=1.0.3 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-nwdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-seqdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.5.0 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): seqdiag>=0.9.3 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-seqdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): urwid in /usr/local/lib/python2.7/dist-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): louie in /usr/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): nose>=0.8.3 in /usr/local/lib/python2.7/dist-packages (from louie)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): flask in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/local/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in /usr/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/local/lib/python2.7/dist-packages (from flask)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): flask-restful in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): aniso8601>=0.82 in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): Flask>=0.8 in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): six>=1.3.0 in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): pytz in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.8->flask-restful)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in /usr/lib/python2.7/dist-packages (from Flask>=0.8->flask-restful)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.8->flask-restful)
Cleaning up...
Sauvegarde du fichier de conf
cp: cannot stat `/opt/python-openzwave/zwcfg*': No such file or directory
Désinstallation de la version précédente
Installation de Python-OpenZwave
Cloning into 'python-openzwave'...
HEAD is now at 6320ae8 Update controller command to remove deprecated commands in pyozwman. See #5
Uninstalling Cython:
  Successfully uninstalled Cython
apt-get install -y cython
Reading package lists...
Building dependency tree...
Reading state information...
cython is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Cloning into 'openzwave'...
HEAD is now at 0432f68 fix #637 - Change Color Channels from Config to System Genre on Color CC
make -C /opt/python-openzwave/openzwave/cpp/build/ - 
make[1]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.3-414-g0432f68-dirty
Building tinystr.o
In file included from /opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:32:0:
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In copy constructor 'TiXmlString::TiXmlString(const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:86:40: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In constructor 'TiXmlString::TiXmlString(const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:92:44: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:93:33: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In constructor 'TiXmlString::TiXmlString(const char*, TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:100:27: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In member function 'TiXmlString& TiXmlString::operator=(const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:112:46: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In member function 'TiXmlString& TiXmlString::operator+=(const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:125:62: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In function 'bool operator==(const TiXmlString&, const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:272:38: error: 'strcmp' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In function 'bool operator<(const TiXmlString&, const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:276:36: error: 'strcmp' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In function 'bool operator==(const TiXmlString&, const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:284:92: error: 'strcmp' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In member function 'void TiXmlString::reserve(TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:48:39: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In member function 'TiXmlString& TiXmlString::assign(const char*, TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:61:31: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:66:28: error: 'memmove' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In member function 'TiXmlString& TiXmlString::append(const char*, TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:80:28: error: 'memmove' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In function 'TiXmlString operator+(const TiXmlString&, const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:98:78: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In function 'TiXmlString operator+(const char*, const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:108:78: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/build/support.mk:106: recipe for target '/opt/python-openzwave/openzwave/.lib/tinystr.o' failed
make[1]: *** [/opt/python-openzwave/openzwave/.lib/tinystr.o] Error 1
make[1]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
Makefile:20: recipe for target 'all' failed
make: *** [all] Error 2
sed -i '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1]: Entering directory '/opt/python-openzwave/openzwave'
make -C /opt/python-openzwave/openzwave/cpp/build/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.3-414-g0432f68-dirty
Building tinystr.o
In file included from /opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:32:0:
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In copy constructor 'TiXmlString::TiXmlString(const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:86:40: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In constructor 'TiXmlString::TiXmlString(const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:92:44: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:93:33: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In constructor 'TiXmlString::TiXmlString(const char*, TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:100:27: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In member function 'TiXmlString& TiXmlString::operator=(const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:112:46: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In member function 'TiXmlString& TiXmlString::operator+=(const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:125:62: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In function 'bool operator==(const TiXmlString&, const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:272:38: error: 'strcmp' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In function 'bool operator<(const TiXmlString&, const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:276:36: error: 'strcmp' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In function 'bool operator==(const TiXmlString&, const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:284:92: error: 'strcmp' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In member function 'void TiXmlString::reserve(TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:48:39: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In member function 'TiXmlString& TiXmlString::assign(const char*, TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:61:31: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:66:28: error: 'memmove' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In member function 'TiXmlString& TiXmlString::append(const char*, TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:80:28: error: 'memmove' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In function 'TiXmlString operator+(const TiXmlString&, const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:98:78: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In function 'TiXmlString operator+(const char*, const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:108:78: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/build/support.mk:106: recipe for target '/opt/python-openzwave/openzwave/.lib/tinystr.o' failed
make[2]: *** [/opt/python-openzwave/openzwave/.lib/tinystr.o] Error 1
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
Makefile:20: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
Makefile:268: recipe for target 'openzwave/libopenzwave.a' failed
make: *** [openzwave/libopenzwave.a] Error 2
Starting system nodejs Daemon:.
Everything is successfully installed!
Merci pour le Travail

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Nouveau plugin zwave/openzwave

Message par loic » 13 août 2015, 14:53

Je viens d'envoyer une nouvelle version mais si ca marche pas j'ai plus d'idée la
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Technopaul
Timide
Messages : 115
Inscription : 14 nov. 2014, 19:00
Localisation : Cagnes Sur Mer

Re: Nouveau plugin zwave/openzwave

Message par Technopaul » 13 août 2015, 15:16

loic a écrit :Je viens d'envoyer une nouvelle version mais si ca marche pas j'ai plus d'idée la
Loic, Pour information je viens d'essayer la mise a jour Version 1.5.2 - 2015-08-13 14:56:21


Sur Toujours la mémé bécane mais sur Debian

Kernel Version 3.16.0-4-amd64 (SMP) x86_64
Distro Name LMDE 2 Betsy
Version PHP 5.6.9-0+deb8u1
Version NodeJS 0.12.7

Résultat Ok

lucaseva
Timide
Messages : 165
Inscription : 12 janv. 2015, 20:39

Re: Nouveau plugin zwave/openzwave

Message par lucaseva » 13 août 2015, 15:41

même combat :'(

Code : Tout sélectionner

Lancement da l'installation/mise à jour des dépendance openzwave
Stopping system nodejs Daemon:.
Installation des dependances
Reading package lists...

Building dependency tree...

Reading state information...
mercurial is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
git is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
python-pip is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
python-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
python-setuptools is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
python-louie is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
python-sphinx is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
make is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
libudev-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
g++ is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
gcc is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
python-lxml is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
unzip is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Installation des dependances Python
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-blockdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.5.0 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-blockdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-blockdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-actdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.5.0 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): actdiag>=0.5.3 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-actdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-actdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-nwdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.5.0 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): nwdiag>=1.0.3 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-nwdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-nwdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): sphinxcontrib-seqdiag in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): blockdiag>=1.5.0 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): seqdiag>=0.9.3 in /usr/local/lib/python2.7/dist-packages (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Sphinx>=0.6 in /usr/lib/pymodules/python2.7 (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): funcparserlib in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): webcolors in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Pillow in /usr/local/lib/python2.7/dist-packages (from blockdiag>=1.5.0->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Pygments>=1.2 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.3 in /usr/lib/python2.7/dist-packages (from Sphinx>=0.6->sphinxcontrib-seqdiag)
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.7 in /usr/lib/pymodules/python2.7 (from Sphinx>=0.6->sphinxcontrib-seqdiag)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): urwid in /usr/local/lib/python2.7/dist-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): louie in /usr/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): nose>=0.8.3 in /usr/local/lib/python2.7/dist-packages (from louie)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): flask in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/local/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in /usr/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/local/lib/python2.7/dist-packages (from flask)
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): flask-restful in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): aniso8601>=0.82 in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): Flask>=0.8 in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): six>=1.3.0 in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): pytz in /usr/local/lib/python2.7/dist-packages (from flask-restful)
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.8->flask-restful)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in /usr/lib/python2.7/dist-packages (from Flask>=0.8->flask-restful)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.8->flask-restful)
Cleaning up...
mkdir: cannot create directory `/opt': File exists
Sauvegarde du fichier de conf
Désinstallation de la version précédente
Installation de Python-OpenZwave
Cloning into 'python-openzwave'...
HEAD is now at 6320ae8 Update controller command to remove deprecated commands in pyozwman. See #5
Uninstalling Cython:
  Successfully uninstalled Cython
apt-get install -y cython
Reading package lists...
Building dependency tree...

Reading state information...
cython is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
Installing dependencies for python : 2 7 3
apt-get install -y python-pip python-dev python-docutils python-setuptools python-louie
Reading package lists...
Building dependency tree...

Reading state information...
python-dev is already the newest version.
python-docutils is already the newest version.
python-louie is already the newest version.
python-pip is already the newest version.
python-setuptools is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
apt-get install -y build-essential libudev-dev g++
Reading package lists...
Building dependency tree...

Reading state information...
build-essential is already the newest version.
g++ is already the newest version.
libudev-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
apt-get install -y cython
Reading package lists...
Building dependency tree...

Reading state information...
cython is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.
pip install nose-html
Requirement already satisfied (use --upgrade to upgrade): nose-html in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): nose>=0.11.1 in /usr/local/lib/python2.7/dist-packages (from nose-html)
Cleaning up...
pip install nose-progressive
Requirement already satisfied (use --upgrade to upgrade): nose-progressive in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): nose>=1.2.1 in /usr/local/lib/python2.7/dist-packages (from nose-progressive)
Requirement already satisfied (use --upgrade to upgrade): blessings>=1.3,<2.0 in /usr/local/lib/python2.7/dist-packages (from nose-progressive)
Cleaning up...
pip install coverage
Requirement already satisfied (use --upgrade to upgrade): coverage in /usr/local/lib/python2.7/dist-packages
Cleaning up...
pip install nose
Requirement already satisfied (use --upgrade to upgrade): nose in /usr/local/lib/python2.7/dist-packages
Cleaning up...
pip install pylint
Requirement already satisfied (use --upgrade to upgrade): pylint in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): logilab-common>=0.53.0 in /usr/local/lib/python2.7/dist-packages (from pylint)
Requirement already satisfied (use --upgrade to upgrade): astroid>=1.3.6 in /usr/local/lib/python2.7/dist-packages (from pylint)
Requirement already satisfied (use --upgrade to upgrade): six in /usr/local/lib/python2.7/dist-packages (from pylint)
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from logilab-common>=0.53.0->pylint)
Cleaning up...
#pip install docutils
#pip install setuptools
#The following line crashes with a core dump
#pip install "Cython==0.22"

Dependencies for users installed (python 2 7 3)
Cloning into 'openzwave'...
HEAD is now at 0432f68 fix #637 - Change Color Channels from Config to System Genre on Color CC
sed -i '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1]: Entering directory '/opt/python-openzwave/openzwave'
make -C /opt/python-openzwave/openzwave/cpp/build/ -w 
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.3-414-g0432f68-dirty
Building tinystr.o
In file included from /opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:32:0:
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In copy constructor 'TiXmlString::TiXmlString(const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:86:40: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In constructor 'TiXmlString::TiXmlString(const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:92:44: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:93:33: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In constructor 'TiXmlString::TiXmlString(const char*, TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:100:27: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In member function 'TiXmlString& TiXmlString::operator=(const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:112:46: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In member function 'TiXmlString& TiXmlString::operator+=(const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:125:62: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In function 'bool operator==(const TiXmlString&, const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:272:38: error: 'strcmp' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In function 'bool operator<(const TiXmlString&, const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:276:36: error: 'strcmp' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h: In function 'bool operator==(const TiXmlString&, const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.h:284:92: error: 'strcmp' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In member function 'void TiXmlString::reserve(TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:48:39: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In member function 'TiXmlString& TiXmlString::assign(const char*, TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:61:31: error: 'memcpy' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:66:28: error: 'memmove' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In member function 'TiXmlString& TiXmlString::append(const char*, TiXmlString::size_type)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:80:28: error: 'memmove' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In function 'TiXmlString operator+(const TiXmlString&, const char*)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:98:78: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp: In function 'TiXmlString operator+(const char*, const TiXmlString&)':
/opt/python-openzwave/openzwave/cpp/tinyxml/tinystr.cpp:108:78: error: 'strlen' was not declared in this scope
/opt/python-openzwave/openzwave/cpp/build/support.mk:106: recipe for target '/opt/python-openzwave/openzwave/.lib/tinystr.o' failed
make[2]: *** [/opt/python-openzwave/openzwave/.lib/tinystr.o] Error 1
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
Makefile:20: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
Makefile:268: recipe for target 'openzwave/libopenzwave.a' failed
make: *** [openzwave/libopenzwave.a] Error 2
Starting system nodejs Daemon:.
Everything is successfully installed!



@loic si je désinstalle totalement le plugin Z-wave est ce que je perd mes équipements déclarés ?
Merci pour le Travail

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités