Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Guide Migration vers nouveau plugin

(anciennement dénommé plugin OpenZwave)
Avatar de l’utilisateur
theodine
Timide
Messages : 33
Inscription : 07 juil. 2014, 09:47
Localisation : Banlieue nantaise (44)

Re: Guide Migration vers nouveau plugin

Message par theodine » 20 juin 2015, 11:08

Bjr,

Opération : migration OpenZwave.
Jeedom 1.194 sur Raspberry PI B avec plugin version Stable.

Après synchronisation, activation de chaque module, et une bonne nuit de repose : j'obtiens l'état de mes modules suivant :
z-wave.JPG
z-wave.JPG (76.63 Kio) Consulté 471 fois
1 seul de mes anciens modules avec sa photo : oeil 1 à priori OK
tous les autres avec l'icone OpenZWave
2 nouveau device 14 et device 5
et un 2 Unknow type=2009, id=0903

Voilà un état un peu délabré style champ de bataille.... où je ne sais plus lequel est encore vivant, encore le bon ?

Mais le plus grave est que lorsque que je vais sur les modules puis je clique sur configuration j'ai des erreurs entre :

Echec de la requete http : http://:/ZWaveAPI/Run/devices[7] Curl error : Couldn't resolve host '' => Toujours présent (à priori normal, selon le dernier post)
Erreur 404 Not Found ou 502 Bad Gateway
Suivi d'un Openzwave est en cours de démarrage sur Local.

Je commence par où, Doc ?

Par avance, merci.
=Thedoine=
2 Jeedom / Raspberry
- maître Zwave
- esclave rfxcom
3 ampoules MiLight wifi
2 Fibaro FGMS-001 / 1 EZMotion 3 en 1 / 1 Fibaro FGFS-101 / 1 keypad Benext RFID z-wave / 1 sirène Vision

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Guide Migration vers nouveau plugin

Message par loic » 20 juin 2015, 11:15

Regarde sur les équipements si le champs server est bien selectionné
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
theodine
Timide
Messages : 33
Inscription : 07 juil. 2014, 09:47
Localisation : Banlieue nantaise (44)

Re: Guide Migration vers nouveau plugin

Message par theodine » 20 juin 2015, 11:25

Exact : "Champ serveur non sélectionné sur Local". Je continue mon nettoyage de module sur champ de bataille.

Comme d'hab.... : super rapide, super efficace !
2 Jeedom / Raspberry
- maître Zwave
- esclave rfxcom
3 ampoules MiLight wifi
2 Fibaro FGMS-001 / 1 EZMotion 3 en 1 / 1 Fibaro FGFS-101 / 1 keypad Benext RFID z-wave / 1 sirène Vision

DimitraBelder
Timide
Messages : 46
Inscription : 13 mai 2015, 00:11

Re: Guide Migration vers nouveau plugin

Message par DimitraBelder » 20 juin 2015, 18:48

Hydro a écrit :
loic a écrit :En SSH fait :

sudo apt-get -y install mercurial

Il va te poser une question tu appuis sur entrée et une fois fini tu relance l'installation depuis jeedom
Merci ça à fonctionné :)
Bonjour,

Même problème, mais l'installation manuelle ne fontionne pas non plus.

sudo apt-get install mercurial
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Paquets suggérés :
qct vim emacs kdiff3 kdiff3-qt kompare meld xxdiff tkcvs mgdiff
Les NOUVEAUX paquets suivants seront installés :
mercurial
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/84,1 ko dans les archives.
Après cette opération, 188 ko d'espace disque supplémentaires seront utilisés.
Sélection du paquet mercurial précédemment désélectionné.
(Lecture de la base de données... 87013 fichiers et répertoires déjà installés.)
Dépaquetage de mercurial (à partir de .../mercurial_2.2.2-4+deb7u1_armhf.deb) ...
Paramétrage de mercurial-common (2.2.2-4+deb7u1) ...
Segmentation fault
dpkg: erreur de traitement de mercurial-common (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 139
dpkg: des problèmes de dépendances empêchent la configuration de mercurial :
mercurial dépend de mercurial-common (= 2.2.2-4+deb7u1) ; cependant :
Le paquet mercurial-common n'est pas encore configuré.

dpkg: erreur de traitement de mercurial (--configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
mercurial-common
mercurial
E: Sub-process /usr/bin/dpkg returned an error code (1)

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Guide Migration vers nouveau plugin

Message par loic » 20 juin 2015, 19:23

Bonjour,
Ton soucis est plus grave "Segmentation fault" qu'as tu comme plateforme ?
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

DimitraBelder
Timide
Messages : 46
Inscription : 13 mai 2015, 00:11

Re: Guide Migration vers nouveau plugin

Message par DimitraBelder » 20 juin 2015, 19:47

J'ai une rpi b+ et razberry

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Guide Migration vers nouveau plugin

Message par loic » 20 juin 2015, 19:53

Tu l'as installé avec l'image officiel ?
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

DimitraBelder
Timide
Messages : 46
Inscription : 13 mai 2015, 00:11

Re: Guide Migration vers nouveau plugin

Message par DimitraBelder » 20 juin 2015, 20:02

Non, elle n'etait pas encore public.

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Guide Migration vers nouveau plugin

Message par loic » 20 juin 2015, 20:04

Essayes avant de faire :
sudo apt-get update
sudo apt-get dist-upgrade
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

DimitraBelder
Timide
Messages : 46
Inscription : 13 mai 2015, 00:11

Re: Guide Migration vers nouveau plugin

Message par DimitraBelder » 20 juin 2015, 20:31

toujours la pareil après ces actions :

sudo apt-get update
sudo apt-get upgrade
sudo apt-get disp-upgrade
sudo rpi-update
sudo reboot

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Guide Migration vers nouveau plugin

Message par loic » 20 juin 2015, 22:13

La je crois va falloir repartir de l'image officiel, il y a un truc qui lui plait pas et il crash assez violemment mais je ne sais pas pourquoi surtout que la il plante c'est même pas le début de l'installation d'openzwave.

On va fournir courant semaine prochaine les premières images avec openzwave si tu peux attendre c'est peut être mieux
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

DimitraBelder
Timide
Messages : 46
Inscription : 13 mai 2015, 00:11

Re: Guide Migration vers nouveau plugin

Message par DimitraBelder » 20 juin 2015, 22:20

je cherche de mon coté... Je réinstallerai si besoin.
Je tenterai de faire un restaure d'une sauvegarde...

jbval
Timide
Messages : 409
Inscription : 12 août 2014, 11:48

Re: Guide Migration vers nouveau plugin

Message par jbval » 21 juin 2015, 09:48

Bravo pour l'explication et la migration!!
La bascule a été faite chez moi sur une mini sans souci (par contre après 2h30 de compilation, je suis parti me coucher il avait toujours pas fini donc surtout ne pas paniquer sur le temps d'installation ;))
Par contre, me multiprise greenwave et mon fibaro n'affichait pas la bonne valeur et la commande déconnait. Du coup, j'ai appuyé sur la loupe pour réparer tout ça et mes scenario ont perdu tous les liens (il faut juste le savoir pour repasser sur les scenario)

Sur la multiprise, j'ai 1 prise dont la conso reste à 0 alors qu'elle devrait afficher ~50 vu ce qui tourne dessus, les 5 autres sont cohérentes.
Jeedom Mini & Rfxcom
Zwave/X10/Mysensor/Chacon DI-O/CurrentCost Envir/Netatmo

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Guide Migration vers nouveau plugin

Message par loic » 21 juin 2015, 09:51

La greenwave est un peu particuliere attend sarakha63 il la connait par coeur la conf a mettre on est en train de voir pour l'automatiser
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

jbval
Timide
Messages : 409
Inscription : 12 août 2014, 11:48

Re: Guide Migration vers nouveau plugin

Message par jbval » 21 juin 2015, 09:57

Ok no souci, rien de critique pour le moment.
Par contre, suite à la migration la mini a un peu pris cher en espace disque, il me semble qu'une procédure de nettoyage a été postée sur le forum pour faire un peu de ménage. Si quelqu'un a le lien (je ne retrouve pas le sujet) ou s'il y a une recommandation officiel, je suis preneur.
Jeedom Mini & Rfxcom
Zwave/X10/Mysensor/Chacon DI-O/CurrentCost Envir/Netatmo

jbval
Timide
Messages : 409
Inscription : 12 août 2014, 11:48

Re: Guide Migration vers nouveau plugin

Message par jbval » 21 juin 2015, 10:34

Pour tester, je suis allé dans les paramètres de la prise et j'ai forcé la mise à jour en face de la puissance et tout s'est mis à jour.
Je vais surveiller si ça le fait bien tout seul les prochains coups.
Jeedom Mini & Rfxcom
Zwave/X10/Mysensor/Chacon DI-O/CurrentCost Envir/Netatmo

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Guide Migration vers nouveau plugin

Message par loic » 21 juin 2015, 10:34

Oui c'est le git d'openzwave.... yavait un post ou j'ai mis les commande de nettoyage mais je me rappels plus ou....
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

jbval
Timide
Messages : 409
Inscription : 12 août 2014, 11:48

Re: Guide Migration vers nouveau plugin

Message par jbval » 21 juin 2015, 10:39

J'ai trouvé ce post là avec des commande auto remove mais ça ne semble pas lié à openzwave:
https://www.jeedom.fr/forum/viewtopic.p ... 9&start=20

Ce n'est pas urgent, je chercherais ce soir plus en détail.
En tout cas, la migration ne m'a fait perdre aucune fonction pour le moment, tout est réactif (ça ne ramait pas forcément avec l'ancien), les mises à jours des états sont plus rapides et ne nécessite pas de cron ou bidouillage de zway pour les everspring 157 donc du tout bon pour moi!
Jeedom Mini & Rfxcom
Zwave/X10/Mysensor/Chacon DI-O/CurrentCost Envir/Netatmo

Avatar de l’utilisateur
mich2208
Timide
Messages : 87
Inscription : 04 juil. 2014, 07:56

Re: Guide Migration vers nouveau plugin

Message par mich2208 » 21 juin 2015, 11:04

jbval a écrit :Ok no souci, rien de critique pour le moment.
Par contre, suite à la migration la mini a un peu pris cher en espace disque, il me semble qu'une procédure de nettoyage a été postée sur le forum pour faire un peu de ménage. Si quelqu'un a le lien (je ne retrouve pas le sujet) ou s'il y a une recommandation officiel, je suis preneur.
Bonjour,

tu as des pistes sur ce post :
https://www.jeedom.fr/forum/viewtopic.p ... gagn%C3%A9
RPI2 avec Zwave et RFXCOM_E et Mini en Esclave avec RFXCom
Chacon 54746, Chacon 54795, WallPlug, FGSD-002 (7), FGK-101, AeonLab 4en1, CurrentCost EnviR, Caméra DLink DCS-5020L, Compteur Eau Sferaco MID R160 + FGBS-001, FGFS-101.

Avatar de l’utilisateur
Doryphore
Actif
Messages : 893
Inscription : 12 juil. 2014, 09:06

Re: Guide Migration vers nouveau plugin

Message par Doryphore » 21 juin 2015, 13:53

Bonjour

je teste le nouveau plugin sur un 2eme rasp, mais je bute à la mise a jour du plugin, j'ai un message pour executer une commande en ssh:
"...Début de la mise à jour de : openzwave
Impossible d'écrire dans le répertoire : /usr/share/nginx/www/jeedom/core/class/../../tmp/openzwave.zip. Exécuter la commande suivante en SSH : chmod 777 -R /usr/share/nginx/www/jeedom/core/class/../../tmp[END UPDATE ERROR]

mais elle échoue, opération non permise:
chmod 777 -R /usr/share/nginx/www/jeedom/core/class/../../tmpchmod: modification des permissions de « /usr/share/nginx/www/jeedom/core/class/../../tmp »: Opération non permise
JEEDOM sur ODROID C2 & Clé AEON Gen 5 depuis 20/03/2016, strecth
90 modules zwave, 3 Squeezebox, 3 BOOM, 1 DUET, 1 Controler, 3 picoreplayer
Modules infrarouges, etc......

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités