Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Guide Migration vers nouveau plugin

(anciennement dénommé plugin OpenZwave)
DenisPac
Actif
Messages : 629
Inscription : 14 août 2014, 13:25
Localisation : Près d'Orléans (45)

Re: Guide Migration vers nouveau plugin

Message par DenisPac » 20 juil. 2015, 15:55

Donc tu confirmes bien que le nouveau plugin openzwave est bien compatible multi-contrôleurs, comme l'était le plugin zwave peu de temps avant son abandon ?
En fait j'ai lu plusieurs posts sur le sujet, dont celui-ci qui détaille plusieurs cas :
  • Migration sans déporté d'openzwave au nouveau plugin
    Migration en deporté d'openzwave au nouveau plugin
    Migration du zway à openzwave
    Migration déporté zway à openzwave
Dans mon cas je suis à la fois dans les deux suivants :
Migration sans déporté d'openzwave au nouveau plugin
ET
Migration déporté zway à openzwave

Il faut donc bien installer les dépendances sur le maître et le déporté.
C'est bien ça ?

Question subsidiaire : ne peut-on pas garder Z-Way sur le déporté pour pouvoir utiliser par exemple un clavier RFID dont certaines fonctions sont manquantes pour le moment en Openzwave ? Donc migration immédiate sur le maître, et migration ultérieure sur le déporté quand les fonctions manquantes auront été implémentée ?

Merci de tes réponses.
Jeedom Maître sur VM Debian sur ESXi (N54L) + Z-Stick 2 (non fonctionnel) + RFXCOM
Jeedom déporté Z-Wave sur Jeedom mini avec JeeLink
Antenne RPI3 BLEA, Netatmo, Philips Hue, Xiaomi Home, Yeelight, Dash Button, ...

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: Guide Migration vers nouveau plugin

Message par loic » 20 juil. 2015, 16:21

Oui oui le plugin est parfaitement compatible en déporté pas de soucis, la configuration est plus simple même car il marche comme pour le rfxcom ou autre protocole.

Pour les dépendances il ne faut les mettre que la ou tu as un contrôleur zwave (donc si tu as rien sur le maître pas besoin de les installer mais la j'ai cru comprendre que tu as un razberry si tu veux t'en servir il les faut).

Non pas possible de faire cohabiter les 2 ca n'a jamais été testé et je doute vraiment de la stabilité de l'ensemble
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

patou100
Timide
Messages : 115
Inscription : 17 juil. 2014, 10:12

Re: Guide Migration vers nouveau plugin

Message par patou100 » 22 juil. 2015, 00:06

Bonjour,

je viens de faire une tentative de migration mais je n'arrive pas à faire fonctionner le nouveau plugin.
Je suis sur un raspberry DIY avec une carte razberry, en dernière beta installée, j'ai l'impression que le demon redémarre sans raison et plante au bout de X restart, voici les logs que j'ai ... Est-ce que quelqu'un a une idée car là je sèche un peu ...

côté plugin j'ai soit :
- impossible de contacter le serveur z-wave local
- 502 Bad Gateway

Code : Tout sélectionner

Check flask dependances
--> pass
Check other dependances
--> pass
Check SQLite
--> SQLite version: 3.7.13
Check Openzwave
--> pass
validate startup arguments
--> pass
check if port is available
--> pass
22-07-2015 00:01:54 - info - validate configuration file: /opt/python-openzwave/zwcfg_0xe63767eb.xml
22-07-2015 00:01:54 - info - ******** The ZWave network is being started ********
22-07-2015 00:01:54 - info - OpenZwave Library Version 1.3.337
22-07-2015 00:01:54 - info - Python-OpenZwave Wrapper Version 0.3.0-beta3
22-07-2015 00:01:54 - info - Waiting for network to become ready
22-07-2015 00:01:54 - info - Openzwave network are started with homeId e63767eb.
22-07-2015 00:01:54 - info - A node has been added to OpenZWave list id:[1] model:[RaZberry Controller].
22-07-2015 00:01:54 - debug - The essential queries on a node have been completed. id:[1] model:[RaZberry Controller].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[3] model:[].
22-07-2015 00:01:55 - debug - The essential queries on a node have been completed. id:[3] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[4] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[5] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[6] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[7] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[8] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[9] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[10] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[11] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[12] model:[].
22-07-2015 00:01:55 - info - A node has been added to OpenZWave list id:[13] model:[].
22-07-2015 00:01:55 - info - All the initialisation queries on a node have been completed. id:[1] model:[RaZberry Controller].
22-07-2015 00:01:55 - info - write configuration file
Check flask dependances
--> pass
Check other dependances
--> pass
Check SQLite
--> SQLite version: 3.7.13
Check Openzwave
--> pass
validate startup arguments
--> pass
check if port is available
--> pass
22-07-2015 00:02:06 - info - validate configuration file: /opt/python-openzwave/zwcfg_0xe63767eb.xml
22-07-2015 00:02:07 - info - ******** The ZWave network is being started ********
22-07-2015 00:02:07 - info - OpenZwave Library Version 1.3.337
22-07-2015 00:02:07 - info - Python-OpenZwave Wrapper Version 0.3.0-beta3
22-07-2015 00:02:07 - info - Waiting for network to become ready
22-07-2015 00:02:07 - info - Openzwave network are started with homeId e63767eb.
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[1] model:[RaZberry Controller].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[3] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[4] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[5] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[6] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[7] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[8] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[9] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[10] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[11] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[12] model:[].
22-07-2015 00:02:07 - info - A node has been added to OpenZWave list id:[13] model:[].
22-07-2015 00:02:07 - info - All the initialisation queries on a node have been completed. id:[1] model:[RaZberry Controller].
22-07-2015 00:02:09 - info - write configuration file
22-07-2015 00:02:16 - error - 404: Not Found http://192.168.1.154:8083/ZWaveAPI
Check flask dependances
--> pass
Check other dependances
--> pass
Check SQLite
--> SQLite version: 3.7.13
Check Openzwave
--> pass
validate startup arguments
--> pass
check if port is available
--> pass
22-07-2015 00:03:07 - info - validate configuration file: /opt/python-openzwave/zwcfg_0xe63767eb.xml
22-07-2015 00:03:07 - info - ******** The ZWave network is being started ********
22-07-2015 00:03:07 - info - OpenZwave Library Version 1.3.337
22-07-2015 00:03:07 - info - Python-OpenZwave Wrapper Version 0.3.0-beta3
22-07-2015 00:03:07 - info - Waiting for network to become ready
22-07-2015 00:03:07 - info - Openzwave network are started with homeId e63767eb.
22-07-2015 00:03:07 - info - A node has been added to OpenZWave list id:[1] model:[RaZberry Controller].
22-07-2015 00:03:07 - info - A node has been added to OpenZWave list id:[3] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[4] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[5] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[6] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[7] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[8] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[9] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[10] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[11] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[12] model:[].
22-07-2015 00:03:08 - info - A node has been added to OpenZWave list id:[13] model:[].
22-07-2015 00:03:08 - info - All the initialisation queries on a node have been completed. id:[1] model:[RaZberry Controller].
22-07-2015 00:03:08 - info - write configuration file

kevinpato
Timide
Messages : 106
Inscription : 31 mai 2015, 17:00
Localisation : Ancenis

Re: Guide Migration vers nouveau plugin

Message par kevinpato » 22 juil. 2015, 09:49

Bonjour,

J'ai fait une tentative mais j'ai quelques soucis mineurs surtout avec mes modules fgk-101 qui ne se resynchronisent pas tout seul, obligé de refaire une inclusion puis ensuite impossible de récupérer la température (avec la sonde DS18B20 connectée dessus). Pour le moment j'ai fait une restauration avec le moteur z-way "obsolète"
Jeedom 3.3.19 sur Rpi 3 + Debian Stretch
Téléinfo + Z-Wave + Xiaomihome

ybabel
Timide
Messages : 75
Inscription : 27 nov. 2014, 11:47

Re: Guide Migration vers nouveau plugin

Message par ybabel » 23 juil. 2015, 10:00

Bonjour,
j'ai un truc bizarre : j'ai effectué une migration, le plugin remonte bien mes mesures électriques comme l'ancien via ZWay, les widgets sont OK, mais quand je vais dans la config il me dit que le serveur OpenZWave n'existe pas, et que le port (dans le slogs) 8083 est occupé.
Pourtant j'ai vérifié avec un px aux, j 'ai bien ceci qui tourne :

/usr/bin/python /usr/share/nginx/www/jeedom/plugins/openzwave/ressources/zwaveserver/openZWave.py --pidfile=/tmp/openzwave.pid --device=/dev/ttyUSB1 --log=Info --port=8083 --config=/usr/share/nginx/www/jeedom/plugins/openzwave/ressources/openzwave/config

une piste ?
le soucis, c'est que je ne peut plus rajouter de matériel du coup, ni configurer l'actuel.
jeedom sur raspberry pi3
AEON HEM3
TEMPer2 USB + 2X TEMPerHum
Fibaro WallPlug
Zipato PST02-A 4 en 1 1
Tenvis Webcam
LED MiLIght 9W Wifi

patou100
Timide
Messages : 115
Inscription : 17 juil. 2014, 10:12

Re: Guide Migration vers nouveau plugin

Message par patou100 » 23 juil. 2015, 12:15

Bonjour,

je suis toujours bloqué dans ma migration :-(

Question bête sur laquelle je n'ai pas trouvé de réponse, est-ce que Z-WAY doit être installé avec le nouveau plugin Z-WAVE lorsqu'on utilise une carte razberry ?

Merci
Patou100

ybabel
Timide
Messages : 75
Inscription : 27 nov. 2014, 11:47

Re: Guide Migration vers nouveau plugin

Message par ybabel » 23 juil. 2015, 15:54

J'ai changé le port en 8085, même binz. Tout fonctionne bien en apparence, mais dès que je vais dans le panneau de configuration du zwave : 404 Not Found

Dans le log il me dit 23-07-2015 15:38:35 | error | The port 8085 is already in use. Please check your openzwave configuration plugin page

je crois qu'il s'auto marche sur les pieds quelque part.

j'ai pourtant bien :
www-data 4461 7.6 4.8 76348 21828 ? SNl 15:37 1:13 /usr/bin/python /usr/share/nginx/www/jeedom/plugins/openzwave/ressources/zwaveserver/openZWave.py --pidfile=/tmp/openzwave.pid --device=/dev/ttyUSB1 --log=Info --port=8085 --config=/usr/share/nginx/www/jeedom/plugins/openzwave/ressources/openzwave/config
jeedom sur raspberry pi3
AEON HEM3
TEMPer2 USB + 2X TEMPerHum
Fibaro WallPlug
Zipato PST02-A 4 en 1 1
Tenvis Webcam
LED MiLIght 9W Wifi

bemar
Timide
Messages : 34
Inscription : 01 sept. 2014, 05:54

Re: Guide Migration vers nouveau plugin

Message par bemar » 24 juil. 2015, 14:37

Bonjour à tous,

J'ai, pour ma part, quelques soucis également depuis cette migration :(

Je possède une cubieboard2 sur laquelle il y a une installation sur mon ssd d'une debian de Igor Pečovnik, installation sur laquelle j'étais en 1.173 sur jeedom et en version béta openzwave (ayant toujours utilisé un z-stick en controleur zwave).
N'ayant pas fait de mises à jour depuis un bon moment... j'ai eu un peu peur de cette grosse maj et de la migration mais je me suis tout de même lancé en respectant la procédure.

A la suite de cette migration, installation des dépendances,... j'ai découvert un plantage systématique du démon ozw à la suite de la découverte d'un de mes noeuds et en parcourant le forum j'ai compris que mon HRT4 (plutôt SRT321) était certainement en cause. Une sauvegarde de mon fichier zwcfg plus tard, recréation automatique de ce fichier par ozw et cette fois mon démon plantait avec un beau Segmentation fault ... Etant resté en béta ozw, je me remets sur la version stable et toujours le même constat :'( :'(

Bref, dernier épisode de cette aventure, je décide de prendre une nouvelle µSD, j'y mets Cubian X1 et réinstalle tout ce qui va bien, puis j'y mets mon dernier backup (datant d'après la migration... peut être faut-il que je mette un backup datant de ma 1.173 ???), et là ... c'est le drame ... toujours rien de bon avec le démon ozw...

Je vous mets en pièce jointe, si besoin, le log d'un strace d'un lancement à la mano du démon... au cas où cela vous parle mais je n'y trouve rien de bien méchant, et une partie du log ozw également.

@tmartinez, @loic, je suis preneur de tout élément me permettant d'avancer...

En tout cas, malgré ces "couacs" dus à cette grosse migration (et grosse maj de ma part), le taff au global sur jeedom démeure excellent et je ne parle même pas du service que l'équipe, et l'ensemble des acteurs qui gravitent autour de vous, fournit :)

@bientôt pour de nouvelles aventures plus concluantes (ou pas :) )
Pièces jointes
ozw.log
ozw.log
(33.72 Kio) Téléchargé 13 fois
strace_ozw.zip
strace_ozw.log
(67.8 Kio) Téléchargé 13 fois

titoo92
Timide
Messages : 37
Inscription : 18 avr. 2015, 19:08
Localisation : reims

Re: Guide Migration vers nouveau plugin

Message par titoo92 » 25 juil. 2015, 14:58

Bonjour,
Je n'avais jusqu'à present pas migrė, mais ce matin l ancien plugin ne fonctionnait plus (impossible de contacter le serveur zwave), j ai donc migrė, mais dans la config tout reste en nok.
J ai bien tentė "installer mettre à jour les dépendances", mais cela s arrête sur une erreur : could not instal libudev-dev.
D habitude j évite de polluer le forum, et en persévérant arrive toujours a me débrouiller, mais la je sèche, ai je loupė un truc sur le port ou la clef (je suis en mini+)?, j ai bien lu les 19 pages précédentes et la doc du plugin, mais il y a tellement de config différentes que je suis un peu perdu.
Pièces jointes
image.jpg
image.jpg (158.32 Kio) Consulté 1244 fois
image.jpg
image.jpg (102.8 Kio) Consulté 1244 fois
Config : jeedom mini+
volet roulant somfy RTS / Divers modules emetteurs, recepteurs chacon / Tetes chauffage living connect danfoss /cameras

Technopaul
Timide
Messages : 115
Inscription : 14 nov. 2014, 19:00
Localisation : Cagnes Sur Mer

Re: Guide Migration vers nouveau plugin

Message par Technopaul » 25 juil. 2015, 15:52

Bonjour quel était ton ancien plugin ?
Si c'etait avec le serveur Z-way il faut le des installé.

Autre solution donné des droits root à Jeedom, a taper en SSH :

sudo su -
echo "www-data ALL=(ALL) NOPASSWD: ALL" | (EDITOR="tee -a" visudo)

Bon courage
Paul


Paul

titoo92
Timide
Messages : 37
Inscription : 18 avr. 2015, 19:08
Localisation : reims

Re: Guide Migration vers nouveau plugin

Message par titoo92 » 25 juil. 2015, 20:51

Merci Paul,
L ancien plugin était le zwave stable, il est toujours la mais desactivė.
J ai bien tapė la commande Sudo, même s il me semble avoir lu que la mini+ a par défaut les droits en root.
Mais rien n y fait toujours du nok partout et l installation des dépendances qui plante au même endroit
Config : jeedom mini+
volet roulant somfy RTS / Divers modules emetteurs, recepteurs chacon / Tetes chauffage living connect danfoss /cameras

bemar
Timide
Messages : 34
Inscription : 01 sept. 2014, 05:54

Re: Guide Migration vers nouveau plugin

Message par bemar » 25 juil. 2015, 22:22

Bonjour,

Tu as tenté de te connecter en ssh et de lancer :
sudo apt-get update && sudo apt-get upgrade

Et ensuite, relancer l'installation des dépendances?

Edit: je viens de remarquer que quelqu'un d'autre avait la même erreur que toi dans l'install des dépendances : https://www.jeedom.fr/forum/viewtopic.php?f=87&t=9371

ybabel
Timide
Messages : 75
Inscription : 27 nov. 2014, 11:47

Re: Guide Migration vers nouveau plugin

Message par ybabel » 25 juil. 2015, 23:05

I found that error in my nginx.error log :
[error] 2876#0: *413 open() "/usr/share/nginx/www/openzwave_0_ew3494yuxv0sudagttsdq05w859me4/ZWaveAPI/Run/devices[2]" failed (2: No such file or directory), client: 192.168.0.15, server: , request: "GET /openzwave_0_ew3494yuxv0sudagttsdq05w859me4/ZWaveAPI/Run/devices%5B2%5D HTTP/1.1", host: "salon", referrer: "http://salon/jeedom/index.php?v=d&m=ope ... =openzwave"

any hint ? (still cannot open configuration panel of openzwave)
jeedom sur raspberry pi3
AEON HEM3
TEMPer2 USB + 2X TEMPerHum
Fibaro WallPlug
Zipato PST02-A 4 en 1 1
Tenvis Webcam
LED MiLIght 9W Wifi

titoo92
Timide
Messages : 37
Inscription : 18 avr. 2015, 19:08
Localisation : reims

Re: Guide Migration vers nouveau plugin

Message par titoo92 » 25 juil. 2015, 23:18

Bonsoir Bemar,

Je crois que l on avance :
J ai envoyė le sudo update upgrade : une erreur à la fin sur fail2ban
A l installation des dépendances j ai l impression que je vais un peu plus loin ... Mais plante sur le fail2ban.

A noter, pendant l update il m a demandė plusieurs fois :
Configuration file .......
==> modified ( by you or by a script) since installation
==> package distributor has shipped an update version
What would you like to do about it ? Your options are :
Y or i : install the package maintainer's version
N or o : keep your currently - installed version
D : show the différences between the versions
Z : start a Shell to examine the situation
Le par défaut étant n , j ai fait n.
Penses tu qu il faille refaire le update upgrade en installant les maintainer's version ?
Pièces jointes
image.jpg
image.jpg (168.56 Kio) Consulté 1216 fois
Config : jeedom mini+
volet roulant somfy RTS / Divers modules emetteurs, recepteurs chacon / Tetes chauffage living connect danfoss /cameras

slide97
Timide
Messages : 3
Inscription : 25 juil. 2015, 17:04

Re: Guide Migration vers nouveau plugin

Message par slide97 » 26 juil. 2015, 00:35

Bonjour,

J'ai une jeedom mini+, et en suivant ce guide, lors de l'installation/Mise a jour des dépendances, j'ai l'erreur suivante :
The following packages have unmet dependencies:
udev : Breaks: systemd (< 222-1) but 215-12 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
could not install libudev-dev - abort

Le démon ne se lance pas non plus.

Merci d'avance pour votre aide

ybabel
Timide
Messages : 75
Inscription : 27 nov. 2014, 11:47

Re: Guide Migration vers nouveau plugin

Message par ybabel » 26 juil. 2015, 02:13

ha ! j'ai trouvé la solution avec un bon vieux RTFM
https://www.jeedom.fr/doc/documentation ... zwave.html
Quand je vais sur la configuration j’ai des erreurs 404 ?
jeedom sur raspberry pi3
AEON HEM3
TEMPer2 USB + 2X TEMPerHum
Fibaro WallPlug
Zipato PST02-A 4 en 1 1
Tenvis Webcam
LED MiLIght 9W Wifi

Avatar de l’utilisateur
Tauks
Actif
Messages : 530
Inscription : 04 avr. 2015, 19:57
Localisation : Strasbourg

Re: Guide Migration vers nouveau plugin

Message par Tauks » 26 juil. 2015, 13:47

Hello,

Peux-tu nous dire quelle partie d'un bon RTFM t'a aidé ? En effet, j'ai le meme souci d'abort sur libudev donc avant de créer un nouveau thread, peut-etre le tien m'aidera-t'il ?

D'avance merci,
Mon blog "Domotique & IoT": ici
Mon matériel: ici

Avatar de l’utilisateur
tostaky
Timide
Messages : 83
Inscription : 31 oct. 2014, 09:16

Re: Guide Migration vers nouveau plugin

Message par tostaky » 26 juil. 2015, 15:05

Salut,

Pour info j'ai réussi la migration de l'ancien plugin Zwave vers le nouveau (Open)Zwave sur un Raspberry Pi2+Razberry. Je dispose de 5 modules (2 détecteurs d'ouverture, une sirène, 1 détecteur de mouvement tous de la marque Everspring, et d'un clavier zipato).

Je n'ai pas rencontré de problème. Ce guide de migration pourrait juste être complété pour avertir qu'il faut lancer la commande "Installer/Mettre à jour" dans la page du plugin pour compiler le plugin open/zwave pour les boulets comme moi qui ne l'ont pas fait dans un premier temps.

a+

kashin
Timide
Messages : 139
Inscription : 20 avr. 2015, 16:50

Re: Guide Migration vers nouveau plugin

Message par kashin » 27 juil. 2015, 14:43

slide97 a écrit :Bonjour,

J'ai une jeedom mini+, et en suivant ce guide, lors de l'installation/Mise a jour des dépendances, j'ai l'erreur suivante :
The following packages have unmet dependencies:
udev : Breaks: systemd (< 222-1) but 215-12 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
could not install libudev-dev - abort

Le démon ne se lance pas non plus.

Merci d'avance pour votre aide
J'ai le même souci, quelqu'un a la solution?

Merci d'avance.

Michael
2 x RPI3 avec plugin Jeelink, Zwave, RFXcom), 9 FGS221, 4 Aeonlan DSB05 multisensor, 2 Fibaro RGBW, 1 Oeil Fibaro, 2 TZ65D, 3 CH54700, 4 sondes température Oregon, 5 capteur d'ouverture Chacon, 7 thermostat Danfoss, etc

Fouy
Timide
Messages : 53
Inscription : 23 juil. 2015, 15:56

Re: Guide Migration vers nouveau plugin

Message par Fouy » 27 juil. 2015, 17:12

Bonjour,

Ayant un peu de temps pour moi cette semaine je me suis dit que j'allais procéder à la migration du plugin zWave vers le nouveau openZwave (j'ai une mini+ qui m'a été livrée avec l'ancien plugin lorsque le nouveau n'était pas encore officiellement prèt).
J'ai donc téléchargé le nouveau plugin sur le market, désactivé l'ancien avant de cliquer sur "Installer/Mettre à jour" dans l'interface du nouveau (Il n'est pas dit de désactiver l'ancien dans la doc, mais sans le faire j'avais une floppée de messages d'erreurs).
Aux premiers éssais d'installation des dépendances j'avais une erreur (comme beaucoup d'autre) sur "u-dev" je ne sais plus quoi.
Je me suis donc connecté en ssh et ai fait la procédure habituelle d'update Linux.
Le problème c'est qu'à l'issue de celle-ci il y a un nouvel élément en erreur (qui sort donc maintenant en erreur lorsque je clique sur "Installer/Mettre à jour" dans OZW...
Si quelqu'un peut m'aider je suis preneur car la j'avoue être allègrement dépassé...

Voici la sortie ssl lors de l'upgrade :

Code : Tout sélectionner

root@jeedom:~# sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following package was automatically installed and is no longer required:
  libvpx1
Use 'apt-get autoremove' to remove it.
Done
The following packages have been kept back:
  cpp-4.9 curl evemu-tools g++-4.9 gcc-4.9 gcc-4.9-base initscripts
  libarchive-dev libarchive13 libasan1 libatomic1 libcgi-pm-perl libcloog-isl4
  libcurl3 libcurl3-gnutls libgcc-4.9-dev libgcc1 libgnutls-deb0-28
  libgnutls-openssl27 libgomp1 libldap-2.4-2 libpcre3 libpcre3-dev libpcrecpp0
  librtmp1 libstdc++-4.9-dev libstdc++6 libsystemd0 libubsan0 libudev1 procps
  systemd sysvinit-utils udev usb-modeswitch usb-modeswitch-data util-linux
  wget
0 upgraded, 0 newly installed, 0 to remove and 38 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up fail2ban (0.9.2-1) ...
Job for fail2ban.service failed. See 'systemctl status fail2ban.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript fail2ban, action "start" failed.
dpkg: error processing package fail2ban (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 fail2ban
E: Sub-process /usr/bin/dpkg returned an error code (1)
Merci d'avance pour toute aide....

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités