Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin jMQTT

Retrouvez ici des sujets concernant le protocole MQTT et les modules domotiques de type MQTT utilisés avec JEEDOM
/!\ Plugin MQTT non officiel
arnox
Timide
Messages : 93
Inscription : 09 sept. 2018, 00:10

Re: Plugin jMQTT

Message par arnox » 16 juil. 2019, 05:00

@Domotruc
Pfff, fausse joie, finalement rien de mieux, le broker est toujours offline... Ce qui m'étonne le plus, c'est que tout fonctionne normalement, aucun souci avec mes modules qui communiquent au travers de MQTT... Comment je peux faire pour trouver celui qui sème le bazar? Je me disais en les débranchant un par un peut-être?... D'autres recommandations plus technique?

Avatar de l’utilisateur
domotruc
Timide
Messages : 254
Inscription : 23 févr. 2018, 08:35
Contact :

Re: Plugin jMQTT

Message par domotruc » 16 juil. 2019, 07:31

Mamourette1913 a écrit :
16 juil. 2019, 00:20
Bonjour,
Je viens de me rendre compte que mes équipements MQTT (Victron Multiplus et Moniteur CCGX) n'étaient plus mis à jour depuis début juin suite à qq mises à jour.
Les equipements sont toujours présents sur les dashboard et les design, mais les valeurs ne sont pas mise à jour et les équipement n'apparaissent pas sur la page de configuration du plugins. Idem, quand je clique sur l'objet, je vais sur la page de configuration du plugin, mais les équipements ne sont pas là.
Par contre, lorsque je vais dans Outils/Résumé Domotique, ils sont bien présents et je peux accéder aux commandes et à la page de configuration.
Quand j'essaie de les recréer à l'identique, j'ai un message d'erreur m'indiquant les équipements du même nom existent déjà.
Avez vous une idée du problème?
Sinon le broker fonctionne, car je peux récupérer, en les recréant, les équipements.
Y a t'il un moyen de réactiver ces équipements et leurs configurations?
Merci d'avance pour votre aide,
Philippe.
Bonjour Philippe,
Il s'agit probablement du problème intervenant à la migration vers la version multi broker du plugin que certains ont. Je n'arrive pas à le reproduire et je manque pour le moment de données pour investiguer.
Je vais essayer de mettre au point une procédure te permettant de récupérer tes équipements.
Pourrais-tu:
* effectuer un backup au cas où (la manip ci-dessous n'est pas risquée)
* aller dans dans la page de Configuration de Jeedom, onglet OS/DB;
* dans la section Base de données, cliquer sur Lancer en face de Administration
* copier/coller la commande suivante dans le champ de commande et l’exécuter en cliquant sur OK

Code : Tout sélectionner

SELECT * FROM `eqLogic` where `eqType_name`='jMQTT'
* copier/coller la table affichée dans un fichier, et me l'envoyer en MP

Merci d'avance.
domotruc
Plugins jMQTT, jElocky
domotruc.com

Avatar de l’utilisateur
domotruc
Timide
Messages : 254
Inscription : 23 févr. 2018, 08:35
Contact :

Re: Plugin jMQTT

Message par domotruc » 17 juil. 2019, 06:43

arnox a écrit :
16 juil. 2019, 05:00
@Domotruc
Pfff, fausse joie, finalement rien de mieux, le broker est toujours offline... Ce qui m'étonne le plus, c'est que tout fonctionne normalement, aucun souci avec mes modules qui communiquent au travers de MQTT... Comment je peux faire pour trouver celui qui sème le bazar? Je me disais en les débranchant un par un peut-être?... D'autres recommandations plus technique?
Bonjour arnox,
Fais moi passer le log de ton équipement broker stp, juste après avoir Redémarrer ce dernier (en allant dans l'équipement, onglet broker, bouton Redémarrer). Puis passes par Analyse > Logs, sélectionnes le fichier jMQTT_nom_broker correspondant à ton broker, télécharges le via le bouton et joins le en fichier.
Merci.
domotruc
Plugins jMQTT, jElocky
domotruc.com

arnox
Timide
Messages : 93
Inscription : 09 sept. 2018, 00:10

Re: Plugin jMQTT

Message par arnox » 17 juil. 2019, 13:45

Merci pour ton aide Domotruc...
Voila le fichier:
jMQTT_jeedom.txt
(40.86 Kio) Téléchargé 16 fois
Pour info si ca peut aider a comprendre le probleme: j'ai débranché l'intégralité de mes clients MQTT hier et le résultat reste le meme, broker offline :evil:
Ma derniere piste (et apres ce sera reinstalle complete, un jour, peut-etre...) est liée a un github qui tourne sur mon Rpi (harmony-api)... Je ne vois pas en quoi il pourrait interferer mais bon, ca se tente...

Avatar de l’utilisateur
domotruc
Timide
Messages : 254
Inscription : 23 févr. 2018, 08:35
Contact :

Re: Plugin jMQTT

Message par domotruc » 17 juil. 2019, 21:42

Bonsoir arnox,
C'est impressionnant le traffic que tu as...
En moins de 2s, le fichier de log est rempli et je ne vois pas le début, pendant le redémarrage de l'équipement broker.
Peux tu donc augmenter la taille des fichiers de log à 1000 lignes dans les paramètres de configuration Jeedom et relancer la manip.
Merci
domotruc
Plugins jMQTT, jElocky
domotruc.com

arnox
Timide
Messages : 93
Inscription : 09 sept. 2018, 00:10

Re: Plugin jMQTT

Message par arnox » 17 juil. 2019, 23:05

domotruc a écrit :
17 juil. 2019, 21:42
Bonsoir arnox,
C'est impressionnant le traffic que tu as...
En moins de 2s, le fichier de log est rempli et je ne vois pas le début, pendant le redémarrage de l'équipement broker.
Peux tu donc augmenter la taille des fichiers de log à 1000 lignes dans les paramètres de configuration Jeedom et relancer la manip.
Merci
Voila, en PJ! Merci
jMQTT_jeedom.txt
(54.18 Kio) Téléchargé 13 fois

lychar460
Timide
Messages : 4
Inscription : 17 mai 2019, 16:26

Re: Plugin jMQTT

Message par lychar460 » 17 juil. 2019, 23:54

Bonsoir à tous,
J’utilise JMQTT depuis quelques temps notamment pour des capteurs XIAOMI et Shelly, et ce plugin fonctionne à merveille. Mais depuis quelques jours je n’arrive pas à avancer sur l’integration d’un interrupteur XIAOMI sans neutre, je m’explique, j’ai bien le retour d’infos, par contre je souhaiterais y intégrer les commandes « ON » et « OFF » mais malgré mes recherches, je ne trouve pas de solution... est ce que quelqu’un pourrait m’aiguiller svp???

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1386
Inscription : 20 oct. 2015, 17:32

Re: Plugin jMQTT

Message par Jeandhom » 18 juil. 2019, 09:34

Mise à jour de la version 2019-07-14 09:54:34.
Pas de perte d'équipement.
Tout semble correct.
Merci.

Gwladys
Timide
Messages : 250
Inscription : 27 avr. 2018, 18:22

Re: Plugin jMQTT

Message par Gwladys » 19 juil. 2019, 11:17

Dans mon cas, la migration des maj du pilote JMQTT c'est bien passée avec CCGX et mes quattro.

Mise à jour des valeurs mqtt par l abonnement sur le broker du CCGX.

Merci Domotruc de ton suivi, c'est beaucoup de boulot.

arnox
Timide
Messages : 93
Inscription : 09 sept. 2018, 00:10

Re: Plugin jMQTT

Message par arnox » 22 juil. 2019, 04:14

domotruc a écrit :
17 juil. 2019, 06:43
arnox a écrit :
16 juil. 2019, 05:00
@Domotruc
Pfff, fausse joie, finalement rien de mieux, le broker est toujours offline... Ce qui m'étonne le plus, c'est que tout fonctionne normalement, aucun souci avec mes modules qui communiquent au travers de MQTT... Comment je peux faire pour trouver celui qui sème le bazar? Je me disais en les débranchant un par un peut-être?... D'autres recommandations plus technique?
Bonjour arnox,
Fais moi passer le log de ton équipement broker stp, juste après avoir Redémarrer ce dernier (en allant dans l'équipement, onglet broker, bouton Redémarrer). Puis passes par Analyse > Logs, sélectionnes le fichier jMQTT_nom_broker correspondant à ton broker, télécharges le via le bouton et joins le en fichier.
Merci.
Salut domotruc,
As tu pu jeter un œil à mon log ?

riwelen
Timide
Messages : 6
Inscription : 17 juil. 2019, 18:11

Re: Plugin jMQTT

Message par riwelen » 22 juil. 2019, 11:12

bonjour tout le monde,
je suis novice en domotique et travaille loin du monde de l'informatique. cependant j'aime ça et je me suis donc lancé dans une installe sous jeedom. Je trouvais le protocole Zigbee très intéressant de part son faible coût. mais détestais le fait de passer par des serveurs xiaomi pour profiter de leurs modules. j'ai donc pris un kit pour flasher un cc2531. j'ai réussi à le flasher. j'ai installé mosquitto sur mon raspberry pi puis le plugin MQTT et enfin le plugin JMQTT. Le broker MQTT est bien au vert sous JMQTT mais après cela je suis perdu. je n'arrive pas à savoir si JMQTT reconnais bien ma cle flashé. (tout est en local sur le même pi). j'ai beau chercher (j'ai suivis ce tuto: https://projetsdiy.fr/test-du-pont-zigb ... -node-red/ ) j'ai bien trouvé le port crwxrwxrwx 1 root tty 204, 64 Jul 21 21:13 /dev/ttyAMA0
mais la je sèche !
j'ai l'impression qu'il me manque une étape primordiale !
merci à tous ceux qui me lirons :D

Rico31
Timide
Messages : 30
Inscription : 15 juin 2019, 11:22
Localisation : Toulouse

Re: Plugin jMQTT

Message par Rico31 » 22 juil. 2019, 12:18

riwelen a écrit :bonjour tout le monde,
je suis novice en domotique et travaille loin du monde de l'informatique. cependant j'aime ça et je me suis donc lancé dans une installe sous jeedom. Je trouvais le protocole Zigbee très intéressant de part son faible coût. mais détestais le fait de passer par des serveurs xiaomi pour profiter de leurs modules. j'ai donc pris un kit pour flasher un cc2531. j'ai réussi à le flasher. j'ai installé mosquitto sur mon raspberry pi puis le plugin MQTT et enfin le plugin JMQTT. Le broker MQTT est bien au vert sous JMQTT mais après cela je suis perdu. je n'arrive pas à savoir si JMQTT reconnais bien ma cle flashé. (tout est en local sur le même pi). j'ai beau chercher (j'ai suivis ce tuto: https://projetsdiy.fr/test-du-pont-zigb ... -node-red/ ) j'ai bien trouvé le port crwxrwxrwx 1 root tty 204, 64 Jul 21 21:13 /dev/ttyAMA0
mais la je sèche !
j'ai l'impression qu'il me manque une étape primordiale !
merci à tous ceux qui me lirons :D
Bonjour riwelen
Tu as bien modifié fichier configuration.yaml avec la localisation de la clés USB, le user, MDP, Host et port ton mosquito ?
Tu as suivi ce tuto https://www.zigbee2mqtt.io/getting_star ... 2mqtt.html ? Définition du service, ....
Et regarde s'il tourne bien via
sudo journalctl -u zigbee2mqtt.service
Si ok mettre le plugin en mode "inclusion" et tu peux faire la manip sur tes composants Xiaomi pour les lier à ta clés

Eric

Envoyé de mon Moto G (5) Plus en utilisant Tapatalk


Avatar de l’utilisateur
domotruc
Timide
Messages : 254
Inscription : 23 févr. 2018, 08:35
Contact :

Re: Plugin jMQTT

Message par domotruc » 22 juil. 2019, 20:26

arnox a écrit :
22 juil. 2019, 04:14
domotruc a écrit :
17 juil. 2019, 06:43
arnox a écrit :
16 juil. 2019, 05:00
@Domotruc
Pfff, fausse joie, finalement rien de mieux, le broker est toujours offline... Ce qui m'étonne le plus, c'est que tout fonctionne normalement, aucun souci avec mes modules qui communiquent au travers de MQTT... Comment je peux faire pour trouver celui qui sème le bazar? Je me disais en les débranchant un par un peut-être?... D'autres recommandations plus technique?
Bonjour arnox,
Fais moi passer le log de ton équipement broker stp, juste après avoir Redémarrer ce dernier (en allant dans l'équipement, onglet broker, bouton Redémarrer). Puis passes par Analyse > Logs, sélectionnes le fichier jMQTT_nom_broker correspondant à ton broker, télécharges le via le bouton et joins le en fichier.
Merci.
Salut domotruc,
As tu pu jeter un œil à mon log ?
Bonsoir arnox,
Désolé j'avais zappé. Je t'ai envoyé un courriel.
domotruc
Plugins jMQTT, jElocky
domotruc.com

Avatar de l’utilisateur
domotruc
Timide
Messages : 254
Inscription : 23 févr. 2018, 08:35
Contact :

Re: Plugin jMQTT

Message par domotruc » 23 juil. 2019, 06:44

Bonjour,
Une nouvelle version est disponible ce matin permettant de changer un équipement de broker et d'afficher les éventuels équipements orphelin de broker.
Devrait permettre à ceux d'entre vous qui ont des équipements disparus suite à la migration vers la version multi-brokers de les récupérer:
  • Un panneau devrait les lister dans la page des équipements;
  • Les éditer un à un et changer le broker associé.
domotruc
Plugins jMQTT, jElocky
domotruc.com

riwelen
Timide
Messages : 6
Inscription : 17 juil. 2019, 18:11

Re: Plugin jMQTT

Message par riwelen » 23 juil. 2019, 17:07

salut Rico et merci beaucoup pour ta réponse !
j'ai mis cette config sur le fichier

# MQTT settings
mqtt:1880
# MQTT base topic for zigbee2mqtt MQTT messages
base_topic: zigbee2mqtt
# MQTT server URL
server: 'mqtt://localhost' testé aussi avec l'ip local du pi mais ne pense pas que ça change grand chose
# MQTT server authentication, uncomment if required:
# user: (mon utilisateur jeedom)
# password: (pswd du compte jeedom
port : /dev/ttyAMA0

je pense que le problème vient de node.js
il me met bien une adresse à la fin de l’installation mais impossible d’accéder à cette adresse dans le navigateur (page introuvable).

j'ai une installation pi b+ debian lite et je sais que ça peut bloquer en version 8 pour node. j'ai donc suivi l'installation pour un pi zero.
j'ai bien la version 10 de node.

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1386
Inscription : 20 oct. 2015, 17:32

Re: Plugin jMQTT

Message par Jeandhom » 23 juil. 2019, 19:52

Pas de soucis de mise à jour sur une install avec un seul broker (celui de Jeedom par défaut).

Rico31
Timide
Messages : 30
Inscription : 15 juin 2019, 11:22
Localisation : Toulouse

Re: Plugin jMQTT

Message par Rico31 » 24 juil. 2019, 21:19

riwelen a écrit :
23 juil. 2019, 17:07
salut Rico et merci beaucoup pour ta réponse !
j'ai mis cette config sur le fichier

# MQTT settings
mqtt:1880
# MQTT base topic for zigbee2mqtt MQTT messages
base_topic: zigbee2mqtt
# MQTT server URL
server: 'mqtt://localhost' testé aussi avec l'ip local du pi mais ne pense pas que ça change grand chose
# MQTT server authentication, uncomment if required:
# user: (mon utilisateur jeedom)
# password: (pswd du compte jeedom
port : /dev/ttyAMA0

je pense que le problème vient de node.js
il me met bien une adresse à la fin de l’installation mais impossible d’accéder à cette adresse dans le navigateur (page introuvable).

j'ai une installation pi b+ debian lite et je sais que ça peut bloquer en version 8 pour node. j'ai donc suivi l'installation pour un pi zero.
j'ai bien la version 10 de node.
Salut riwelen que donne la commande

Code : Tout sélectionner

cd /opt/zigbee2mqtt (ou ton répertoire d’install de zigbee2mqtt)
npm start
Ou si tu as défini en service zigbee2mqtt

Code : Tout sélectionner

systemctl status zigbee2mqtt.service
Au moins pour vérifier s’il y a un message d’erreur.
Mon fichier de configuration

Code : Tout sélectionner

homeassistant: false
permit_join: true
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://192.168.1.112'
  user: jeedom_user
  password: Mot2Passe2Jeedom
serial:
  port: /dev/ttyACM0
  devices:
  Liste de mes devices
  .......
  
Perso j’ai zigbee2mqtt sur un rpi3 et jeedom sur rpi2. Jeedom héberge Mosquitto d’où Ip renseignée

riwelen
Timide
Messages : 6
Inscription : 17 juil. 2019, 18:11

Re: Plugin jMQTT

Message par riwelen » 24 juil. 2019, 22:19

Lors du lancement j’ai
zigbee2mqtt@1.5.1 start /opt/zigbee2mqtt
> node index.js

zigbee2mqtt:info 7/24/2019, 9:15:58 PM Logging to directory: '/opt/zigbee2mqtt/data/log/2019-07-24.21-15-39'
zigbee2mqtt:info 7/24/2019, 9:16:01 PM Starting zigbee2mqtt version 1.5.1 (commit #ac3b924)
zigbee2mqtt:info 7/24/2019, 9:16:01 PM Starting zigbee-shepherd
/opt/zigbee2mqtt/node_modules/zigbee-herdsman/node_modules/proving/index.js:5
throw new TypeError(msg || 'Input value should be a string.');
^

TypeError: path should be a string.
at Object.proving.string (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/node_modules/proving/index.js:5:15)
at new ZShepherd (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/dist/lib/shepherd.js:15:13)
at Zigbee.start (/opt/zigbee2mqtt/lib/zigbee.js:57:25)
at startupLogVersion (/opt/zigbee2mqtt/lib/controller.js:167:25)
at utils.getZigbee2mqttVersion (/opt/zigbee2mqtt/lib/controller.js:193:13)
at git.getLastCommit (/opt/zigbee2mqtt/lib/util/utils.js:102:9)
at /opt/zigbee2mqtt/node_modules/git-last-commit/source/index.js:55:4
at /opt/zigbee2mqtt/node_modules/git-last-commit/source/index.js:23:3
at ChildProcess.exithandler (child_process.js:285:7)
at ChildProcess.emit (events.js:198:13)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.5.1 start: `node index.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the zigbee2mqtt@1.5.1 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/pi/.npm/_logs/2019-07-24T20_16_02_121Z-debug.log


Pour ta deuxième commande j’ai

Unit zigbee2mqtt.service could not be found.

Aie aie aie quoi

Rico31
Timide
Messages : 30
Inscription : 15 juin 2019, 11:22
Localisation : Toulouse

Re: Plugin jMQTT

Message par Rico31 » 25 juil. 2019, 07:12

Tu peux essayer de retirer le 1880 en face de mqtt dans ton fichier de configuration ? Le port ne se paramètre pas, en tout cas pas à cette endroit.

riwelen
Timide
Messages : 6
Inscription : 17 juil. 2019, 18:11

Re: Plugin jMQTT

Message par riwelen » 25 juil. 2019, 09:51

J’avais vu qu’effectivement ce n’était pas la peine alors je l’avais déjà enlevé. J’ai vu sur GitHub qu’on était plusieurs à avoir ce problème !

Apres lors de l’installation j’ai ces messages

pi@raspberrypi:/opt/zigbee2mqtt $ sudo npm install

npm WARN bl@0.7.0 requires a peer of stream-browserify@* but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/zigbee-herdsman/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})

audited 874627 packages in 1866.487s
found 2 moderate severity vulnerabilities
run `npm audit fix` to fix them, or `npm audit` for details
Si jamais quelque chose te saute aux yeux



Envoyé de mon iPhone en utilisant Tapatalk

Verrouillé

Revenir vers « [Plugin Tiers] MQTT »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité