Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

MQTT

Retrouvez ici des sujets concernant le protocole MQTT et les modules domotiques de type MQTT utilisés avec JEEDOM
/!\ Plugin MQTT non officiel
38domo
Timide
Messages : 13
Inscription : 26 sept. 2015, 08:16

Re: [Sujet officiel] Plugin MQTT

Message par 38domo » 29 sept. 2015, 12:37

merci pour l'info.

Quand j'active le plugin --> OK. pas d'erreur dans nginx.error
Quand je sauvegarde la commande de l'objet mqtt --> OK. pas d'erreur dans nginx.error
Quand je lance la commande: j'ai l'erreur suivante dans le fichier nginx.error:
2015/09/29 12:33:48 [error] 11392#0: *1686 FastCGI sent in stderr: "PHP message: PHP Fatal error: Class 'Mo$
2015/09/29 12:33:58 [error] 11392#0: *1580 upstream prematurely closed connection while reading response hea$

Quelqu'un peut m'aider svp ?

Avatar de l’utilisateur
Al85
Timide
Messages : 184
Inscription : 18 nov. 2014, 20:59

Re: [Sujet officiel] Plugin MQTT

Message par Al85 » 29 sept. 2015, 12:39

Tu peux mettre des sceen des tes pages du plugin mqtt?

Envoyé de mon GT-I9505 en utilisant Tapatalk
Orange PI plus2e : Jeedom Stable 3.11;
Mysensors: Téléinfo, 4xRelais Tableau elec, Portail garage, 2xSondes, Boite aux lettres, 2xLumière.
Broker MQTT. Pour ESP8266
Xiaomi Home avec detecteurs d'ouverture.
RPI2:Ecran officiel.

38domo
Timide
Messages : 13
Inscription : 26 sept. 2015, 08:16

Re: [Sujet officiel] Plugin MQTT

Message par 38domo » 29 sept. 2015, 18:16

Et voici les copies d'ecran du plugin mqtt et de l'objet mqtt:
plugin mqtt.JPG
plugin mqtt.JPG (62.09 Kio) Consulté 4769 fois
objet mqtt.JPG
objet mqtt.JPG (75.46 Kio) Consulté 4769 fois
cdlt

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Plugin MQTT

Message par lunarok » 29 sept. 2015, 18:26

Si tu regardes la doc tu as tes réponses :
https://jeedom.fr/doc/documentation/plu ... /MQTT.html

Ta conf commande est pas bonne à minimum
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Avatar de l’utilisateur
Al85
Timide
Messages : 184
Inscription : 18 nov. 2014, 20:59

Re: [Sujet officiel] Plugin MQTT

Message par Al85 » 29 sept. 2015, 18:37

Ah oui en effet il faut que tu complète ta page de ton premier imprim écran ^^

Envoyé de mon GT-I9505 en utilisant Tapatalk
Orange PI plus2e : Jeedom Stable 3.11;
Mysensors: Téléinfo, 4xRelais Tableau elec, Portail garage, 2xSondes, Boite aux lettres, 2xLumière.
Broker MQTT. Pour ESP8266
Xiaomi Home avec detecteurs d'ouverture.
RPI2:Ecran officiel.

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Plugin MQTT

Message par lunarok » 29 sept. 2015, 18:40

Ah j'avais même pas regarder la conf
Donc oui faut remplir la conf
Lui la commande sur ton équipement n'est pas bonne (c'est le topic qu'il faut mettre)

depuis mon OnePlus
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Avatar de l’utilisateur
Deus Ex-Machina
Timide
Messages : 62
Inscription : 18 mai 2015, 02:23

Re: [Sujet officiel] Plugin MQTT

Message par Deus Ex-Machina » 29 sept. 2015, 22:45

Bonsoir à tous,

Je viens solliciter votre aide par rapport à ce merveilleux plugin dont on m'a tellement souvent parlé pour réaliser mes projets domotiques.
En gros, je ne parviens pas à l'exploiter sous Jeedom. Aucune remontée d'infos, aucun envoi possible. Dès que je tente d'envoyer une info (de publier un "message" sur un "topic" pour être précis), j'ai l'erreur suivante qui s'affiche en rouge dans Jeedom: 500 : Internal Server Error :?

Mon installation: 2 raspberry pi 2 sous raspbian avec la dernière version stable de Jeedom (1.209); le premier étant le maître et le second l'esclave.
J'ai préféré installer Mosquitto sur le raspberry "esclave", moins chargé en applications.
Son serveur Mosquitto semble fonctionner correctement car j'ai fait des tests avec l'application Android "MyMQTT" installée sur 2 terminaux, une tablette et un mobile. Les deux appareils communiquent parfaitement ensemble et peuvent s'échanger des messages par le biais du serveur sur le RPI2. Les publications sont immédiates, dans latences ni erreurs.

Voilà ma configuration sur la page du plugin MQTT sur Jeedom (pour rappel, l'installation du plugin est faite sur le maître dont l'ip est .90 et le serveur tourne sur le Pi esclave dont l'IP se termine en .110):
IP de Mosquitto: 192.168.1.110 (c'est mon esclave)
Port de Mosquitto: 1883
Compte de connexion: vide
Mot de passe de connexion: vide
Identifiant de connexion: Jeedom

Si je vais dans le menu "administration" de Jeedom, puis dans "Santé", voilà ce que j'obtiens pour la partie MQTT:
Cron: Résultat NOK (en rouge, le Cron n'est visiblement pas actif)
Mosquitto: OK (en vert)

Lorsque je vais dans le menu "Administration" -> "Moteur de tâches", je vois Mosquitto tourner:
#: 2589 (suivi d'un gros bouton rouge avec le symbole carré "stop" pour l'arrêter)
PID: 8389
Démon: Oui
Valeur: 1
Unique: Non
Classe: MQTT
Fonction: daemon
Programmation: *****
Timeout (min): 1440
Dernier lancement: 2015-09-29 22:30:07
Statut: run


Lorsque je regarde le log "cron_execution", voilà ce que j'obtiens:
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525+lfs/mosquitto.so' - /usr/lib/php5/20100525+lfs/mosquitto.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525+lfs/mosquitto.so' - /usr/lib/php5/20100525+lfs/mosquitto.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525+lfs/mosquitto.so' - /usr/lib/php5/20100525+lfs/mosquitto.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525+lfs/mosquitto.so' - /usr/lib/php5/20100525+lfs/mosquitto.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Fatal error: Class 'Mosquitto\Client' not found in /usr/share/nginx/www/jeedom/plugins/MQTT/core/class/MQTT.class.php on line 68

Pour le log nginx.error:
2015/09/29 21:57:40 [error] 2302#0: *681551 FastCGI sent in stderr: "PHP message: PHP Fatal error: Class 'Mosquitto\Client' not found in /usr/share/nginx/www/jeedom/plugins/MQTT/core/class/MQTT.class.php on line 199" while reading response header from upstream, client: 192.168.1.2, server: , request: "POST /jeedom/core/ajax/cmd.ajax.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "192.168.1.90", referrer: "http://192.168.1.90/jeedom/index.php?v=d&m=MQTT&p=MQTT"
2015/09/29 22:01:18 [error] 2303#0: *681641 FastCGI sent in stderr: "PHP message: PHP Fatal error: Class 'Mosquitto\Client' not found in /usr/share/nginx/www/jeedom/plugins/MQTT/core/class/MQTT.class.php on line 199" while reading response header from upstream, client: 192.168.1.2, server: , request: "POST /jeedom/core/ajax/cmd.ajax.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "192.168.1.90", referrer: "http://192.168.1.90/jeedom/index.php?v=d&m=MQTT&p=MQTT"

J'ai parcouru tout le forum et j'ai tenté de résoudre le problème par les moyens proposés, notamment en vérifiant dans les fichiers
/etc/php5/fpm/php.ini et /etc/php5/cli/php.ini si l'extension mosquitto.so s'y trouvait. Et c'est oui dans les deux cas... :cry:

J'avoue que je sèche vraiment et que je n'ai aucune idée de ce qu'il faut faire pour solutionner cela :?

Je vous remercie d'avance de l'aide que vous pourrez m'apporter !
Bonne soirée à tous.

Avatar de l’utilisateur
lunarok
Actif
Messages : 6704
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Sujet officiel] Plugin MQTT

Message par lunarok » 29 sept. 2015, 22:53

Tu es sur wheezy vu le rep PHP, ça serait bien de passer en image Jessie (évoque ce weekend sur le fil)

depuis mon OnePlus
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Avatar de l’utilisateur
Al85
Timide
Messages : 184
Inscription : 18 nov. 2014, 20:59

Re: [Sujet officiel] Plugin MQTT

Message par Al85 » 29 sept. 2015, 23:01

@deus ex-machina En tous cas super détaillé ton post !! Bravo :) et quand ça fonctionnera je te souhaite une bonne continuation avec mqtt qui est vraiment sympa à utiliser.

Envoyé de mon GT-I9505 en utilisant Tapatalk
Orange PI plus2e : Jeedom Stable 3.11;
Mysensors: Téléinfo, 4xRelais Tableau elec, Portail garage, 2xSondes, Boite aux lettres, 2xLumière.
Broker MQTT. Pour ESP8266
Xiaomi Home avec detecteurs d'ouverture.
RPI2:Ecran officiel.

Avatar de l’utilisateur
Deus Ex-Machina
Timide
Messages : 62
Inscription : 18 mai 2015, 02:23

Re: [Sujet officiel] Plugin MQTT

Message par Deus Ex-Machina » 30 sept. 2015, 19:20

@AI85: Merci pour ton message, ça fait plaisir ;) Je trouve cela plus facile d'avoir directement toutes les infos structurées sous la main en un coup, ça évite de s'éparpiller dans de multiples posts et de perdre le fil conducteur. J'espère vraiment rendre ce plugin opérationnel en tous cas !

@lunarok: Merci aussi pour ton feedback. Le fait de migrer de version debian (pardon, raspbian :D ) ne représente-t-il pas un risque pour la stabilité de Jeedom ? J'ai beaucoup d'équipements enregistrés, de plugins configurés et de programmes enregistrés. Je pétoche assez en me disant que je risque de planter tout cela :? La mise à jour même de l'OS représente-t-elle un "danger" pour le serveur PHP, les BDD MySQL, le cron, les accès SSH ou autre ?
Le plugin MQTT n'est-il pas censé fonctionner sur la version wheezy également ?

Avatar de l’utilisateur
Al85
Timide
Messages : 184
Inscription : 18 nov. 2014, 20:59

Re: [Sujet officiel] Plugin MQTT

Message par Al85 » 30 sept. 2015, 19:30

Comme la dit Lunarock il y a des problèmes avec la version wheezy. J'ai été obligé de recommencer 3 fois après raz de l'installation et un coup c'est passé je ne sais pas comment.
Au pire tu fait une sauvegarde de ta carte sd actuel (comme ça tu ne perd rien) et après tu passe sur la nouvelle image en 1.205 et tu restaure logiquement ca devrai marcher.
Au pire si ça ne marche pas tu remets ta sauvegarde d'image et tu réessayé plus tard.
Au sinon si tu as une autre carte sd c'est plus simple.

Envoyé de mon GT-I9505 en utilisant Tapatalk
Orange PI plus2e : Jeedom Stable 3.11;
Mysensors: Téléinfo, 4xRelais Tableau elec, Portail garage, 2xSondes, Boite aux lettres, 2xLumière.
Broker MQTT. Pour ESP8266
Xiaomi Home avec detecteurs d'ouverture.
RPI2:Ecran officiel.

kriss35
Timide
Messages : 128
Inscription : 17 juil. 2014, 13:33

Re: [Sujet officiel] Plugin MQTT

Message par kriss35 » 01 oct. 2015, 19:33

Bonjour, j'ai moi aussi un petit soucis avec le plugin MQTT.

Je suis sous jessie et j'ai dû rajouter la ligne extension dans le php.ini .

J'ai bien la température de mon module qui remonte dans jeedom, mais par contre si j'essai d'envoyer un 0 ou un 1 sur un topic, voilà ce que je vois passer avec mosquitto_sub -h 127.0.0.1 -t "#" -v :

aqualed/salon/temperature 51.0
aqualed/salon/temperature 49.25
aqualed/salon/relay/2 (null)
aqualed/salon/relay/2 (null)
aqualed/salon/temperature 49.25

(j'ai mis en gras ce qui m'interpelle)

Voilà ce qui apparait en debug dans les logs MQTT de jeedom :

01-10-2015 20:17:01 | debug | Envoi du message vers aqualed/salon/relay/2
01-10-2015 20:17:01 | debug | 16 : Client 0 received PUBLISH (d0, q1, r0, m1, 'aqualed/salon/relay/2', ... (0 bytes))
01-10-2015 20:17:01 | debug | 16 : Client 0 sending PUBACK (Mid: 1)
01-10-2015 20:17:01 | debug | Message sur aqualed/salon/relay/2

Sur cet essai j'ai d'abord mis 0 en valeur puis 1 .
Je ne vois pas ce qui cloche, une idée ?
Voici un screen de ma config :
MQTT1.JPG
MQTT1.JPG (51.91 Kio) Consulté 4715 fois
MQTT2.JPG
MQTT2.JPG (75.13 Kio) Consulté 4715 fois

Edit :

J'ai trouvé mon problème, les actions n'étaient pas de type message :)

Merci pour ce plugin qui roxx !
Dernière édition par kriss35 le 01 oct. 2015, 20:25, édité 3 fois.

Avatar de l’utilisateur
Deus Ex-Machina
Timide
Messages : 62
Inscription : 18 mai 2015, 02:23

Re: [Sujet officiel] Plugin MQTT

Message par Deus Ex-Machina » 01 oct. 2015, 19:44

Merci pour votre aide les gars ! C'est vraiment super sympa.
Je suis passé sous Raspbian Jessie hier soir. J'ai voulu faire les choses proprement: j'ai tout formaté et j'ai réalisé une fresh install de Jessie. Après quoi j'ai installé Jeedom et j'ai restauré ma dernière sauvegarde.
Tout s'est bien passé mis à part qqes petites tuiles avec certains équipements qui ne fonctionnent plus tout à fait, mais c'est plutôt secondaire actuellement.

Je n'ai plus l'erreur 500 qui s'affiche quand je tente d'envoyer quelque chose (chouette :D ).
J'ai fait un test avec un topic nommé "test" et un envoi de valeur numérique. J'observe ce qui se passe en utilisant toujours l'application Android MyMQTT et je vois bien les envois de Jeedom. Ca, c'est déjà une super avancée 8-) !

Par contre, je ne sais récupérer aucune info. J'ai créé une "info" dans l'interface MyMQTT et lui ai attribué un nom. Le champ "topic" reste grisé et je ne peux rien y indiquer. Je suppose que ce n'est pas nécessaire car "l'équipement MyMQTT" est déjà configuré pour être lié à un "topic" en particulier... (non :? ).

Toujours est-il que lorsque je teste si quelque chose est reçu, Jeedom m'indique qu'aucune valeur n'a été reçue...
Comment puis-je faire pour afficher des infos dans Jeedom, comme par exemple les infos transmises par l'application MyMQTT ?
J'essaie vraiment d'avancer par étape pour comprendre où se trouvent les erreurs et comment les solutionner pour rendre le système opérationnel.

Dernier "détail" assez gênant: j'ai la même erreur qu'avant ma migration sous Jessie avec le cron. L'onglet "santé" m'indique que le cron est "NOK" et qu'il ne semble donc pas être actif.
Lorsque je vais sur le moteur de tâches, je vois pourtant la ligne MQTT en fonction. Son statut est bien indiqué en "run" et le gros bouton arrêt est bien présent. J'ai tenté d'arrêter le service et de le redémarrer, mais c'est le même topo: le cron est toujours indiqué comme "NOK" dans Jeedom.
J'ai également tenté une réinstallation complète du plugin, mais rien n'y fait, cron NOK :shock:

Avez-vous des pistes pour m'aider à avancer à nouveau.
Encore une fois, un grand merci d'avance !!

kriss35
Timide
Messages : 128
Inscription : 17 juil. 2014, 13:33

Re: [Sujet officiel] Plugin MQTT

Message par kriss35 » 01 oct. 2015, 20:21

J'ai MAJ mon message avec plus de debug

edit : j'ai trouvé mon problème et ré-édité mon message

Avatar de l’utilisateur
Al85
Timide
Messages : 184
Inscription : 18 nov. 2014, 20:59

Re: [Sujet officiel] Plugin MQTT

Message par Al85 » 01 oct. 2015, 20:29

Bien joué :)
Tu es sur quoi comme module pour Infos stp ?
Deux ex essayé de voir si le php.ini et cli.ini on bien la ligne qu'il faut à la fin ?

Envoyé de mon GT-I9505 en utilisant Tapatalk
Orange PI plus2e : Jeedom Stable 3.11;
Mysensors: Téléinfo, 4xRelais Tableau elec, Portail garage, 2xSondes, Boite aux lettres, 2xLumière.
Broker MQTT. Pour ESP8266
Xiaomi Home avec detecteurs d'ouverture.
RPI2:Ecran officiel.

kriss35
Timide
Messages : 128
Inscription : 17 juil. 2014, 13:33

Re: [Sujet officiel] Plugin MQTT

Message par kriss35 » 01 oct. 2015, 21:33

J'utilise des esp8266

Avatar de l’utilisateur
Al85
Timide
Messages : 184
Inscription : 18 nov. 2014, 20:59

Re: [Sujet officiel] Plugin MQTT

Message par Al85 » 01 oct. 2015, 23:15

Ah ok avec logiciel arduino ? Si oui quelle bibliothèque ?

Envoyé de mon GT-I9505 en utilisant Tapatalk
Orange PI plus2e : Jeedom Stable 3.11;
Mysensors: Téléinfo, 4xRelais Tableau elec, Portail garage, 2xSondes, Boite aux lettres, 2xLumière.
Broker MQTT. Pour ESP8266
Xiaomi Home avec detecteurs d'ouverture.
RPI2:Ecran officiel.

kriss35
Timide
Messages : 128
Inscription : 17 juil. 2014, 13:33

Re: [Sujet officiel] Plugin MQTT

Message par kriss35 » 01 oct. 2015, 23:20


Avatar de l’utilisateur
Deus Ex-Machina
Timide
Messages : 62
Inscription : 18 mai 2015, 02:23

Re: [Sujet officiel] Plugin MQTT

Message par Deus Ex-Machina » 02 oct. 2015, 02:05

AI85.... Tu es un génie :geek: !
J'ai complètement zappé le fait de revérifier si ces extensions étaient toujours présentes... Là aussi, j'ai refait les choses dans l'ordre en vérifiant que les lib mosquitto étaient bien installées et j'ai rajouté les extensions mosquitto dans les fichiers php.ini

Après un p'tit reboot, tout fonctionne nickel ! MyMQTT a lui même créé des infos dès que je me suis mis à publier sur mon topic de test avec mes applis Android. Quel bonheur ! Je publie via Jeedom et les infos s'affichent quasi instantanément sur mes terminaux, et c'est idem dans l'autre sens !
C'est vraiment cool 8-)
Ca ouvre des possibilités incroyables.
Je n'attendais plus que ça pour faire chauffer mon fer à souder et sortir toute ma clique d'Arduinos / capteurs / senseurs divers :D

J'avancerai step by step car je crois que là aussi, les choses n'iront évidemment pas toutes seules du premier coup (ce serait trop beau, et aussi moins "amusant" :lol: :mrgreen: ).

Un énoooooorme mercii en tous cas ;) !

38domo
Timide
Messages : 13
Inscription : 26 sept. 2015, 08:16

Re: [Sujet officiel] Plugin MQTT

Message par 38domo » 02 oct. 2015, 20:54

bonsoir,
suite a mes pbs pour faire fonctionner mqtt, j'ai, une nouvelle fois, refait une install complete sur ma orangepi.
- install image wheezy fournie par orangepi ->ok
- install Jeedom -> ok
- install plugin mqtt -> ok
- install manuelle de mosquitto ( en prenant toutes commandes du script d'install fourni par jeedom) -> ok. Verification de mosquitto -> ok . mes capteurs publient bien. verification dans nodered, ecran de debug, les messages mqtt passent bien.
- activation du plugin -> ok
- creation objet -> ok
- essai d'envoi de message par jeedom -> NOK. message d'erreur : Invalid function arguments provided.
Dans le menu General/administration/sante: tout est ok sauf 'authentification par defaut'. je suis reste admin.admin. Cron et Mosquitto sont OK.
Dans le menu General/Administration/moteur de taches, le daemon mqtt est actif et run.
Dans le menu General/Administration/logs/cron: j'ai le message : PHP Warning: Module 'mosquitto' already loaded in Unknown on line 0
Dans le menu General/Administration/logs/mqtt, j'ai le message: 02-10-2015 20:37:05 | error | Erreur execution de la commande [Aucun][/ToHard][test] : Invalid function arguments provided.
Dans le menu General/Administration/logs/nginx.error, j'ai le message: 2015/10/02 20:43:57 [error] 6208#0: *6698 upstream prematurely closed connection while reading response header from upstream, client: 192.168.1.122, server: , request: "GET /socket.io/?EIO=3&transport=polling&t=1443811311808-11&sid=GkWHp8Y0J48cPfViAAA3 HTTP/1.1", upstream: "http://127.0.0.1:8070/socket.io/?EIO=3& ... 8cPfViAAA3", host: "192.168.1.111", referrer: "http://192.168.1.111/jeedom/index.php?v=d&p=cron"
ci dessous la config de mon plugin et l'ecran de l'objet.
Y a t-il des subtilites sur le format du message mqtt ? ou bien l'erreur vient d'ailleurs ?
Pièces jointes
objet_mqtt.JPG
objet_mqtt.JPG (85.32 Kio) Consulté 4668 fois
config mqtt2.JPG
config mqtt2.JPG (50.04 Kio) Consulté 4668 fois

Répondre

Revenir vers « [Plugin Tiers] MQTT »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité