Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] Pushbullet

Pour échanger sur les plugins classés en catégorie "Communication"
feipi59
Timide
Messages : 40
Inscription : 12 févr. 2016, 23:09

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par feipi59 » 16 oct. 2017, 19:49

Bonjour,

Même problème que Shakirosebebe22. Le démon ne se lance pas. Le plugin seul, le démon est OK. Dès que j'ajoute un équipement, le démon est KO.
Et pour les logs, je suis en log DEBUG et je n'ai rien qui s'affiche. Bizarre.

Cdlt

Shakirosebebe22
Timide
Messages : 45
Inscription : 20 nov. 2016, 13:54

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par Shakirosebebe22 » 16 oct. 2017, 20:13

feipi59 a écrit :
16 oct. 2017, 19:49
Bonjour,

Même problème que Shakirosebebe22. Le démon ne se lance pas. Le plugin seul, le démon est OK. Dès que j'ajoute un équipement, le démon est KO.
Et pour les logs, je suis en log DEBUG et je n'ai rien qui s'affiche. Bizarre.

Cdlt
J'ai également effectué l'installation du plugin sur une installation d'un ami (Raspbian 8 + jeedom 3.1.7), j'ai reproduit le même problème. Et toujours pas de log même en debug.

Cdlt,
Shaki

didaskein
Timide
Messages : 32
Inscription : 02 oct. 2016, 17:40

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par didaskein » 16 oct. 2017, 21:18

J'ai activé les log en debug et je n'ai pas plus d'info :(

Jonalex
Timide
Messages : 11
Inscription : 18 sept. 2016, 08:46

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par Jonalex » 18 oct. 2017, 15:11

Bonjour,

Je rencontre le même problème, log en debug pas très bavard, et démon KO :(

Si on n'ajoute 0 équipements à Pushbullet, alors le démon est OK, sinon il est KO

franjunt
Timide
Messages : 56
Inscription : 31 août 2014, 21:54

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par franjunt » 19 oct. 2017, 23:51

Bonsoir

idem pour moi statut NOK derniere version de jeedom sur plugin pushbullet nouvellement installé

Pignonduclan
Timide
Messages : 132
Inscription : 02 sept. 2015, 22:32

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par Pignonduclan » 21 oct. 2017, 19:18

Bonsoir,
Ça n'aide pas beaucoup, désolé, mais pareil chez moi en 3.1.7 + Stretch. Après, ça marche bien en sortie, donc pas trop grave pour moi...
Cedric

zoboton
Timide
Messages : 275
Inscription : 14 août 2014, 10:34

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par zoboton » 22 oct. 2017, 09:24

Est-ce que ça fonctionnait avant la 3.1.7 ?

Catmar
Timide
Messages : 219
Inscription : 18 janv. 2017, 21:38

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par Catmar » 22 oct. 2017, 09:46

Bonjour à tous

Même symptôme que ci dessus. Ok en sortie de Jeedom, ko en entrée et demon ko

Oui ça marchait avant la 3.1.5.
La migration 3.1.5. 3.1.6. 3.1.5. 3.1.7 a été trop rapide pour m'apercevoir d'un pb... en tout cas ce n'était pas le seul ..😁

Merci
Catmar, débutant, inculte en Linux, python, ssh et autres... mais volontaire
Lyon
Mini+ & Smart avec Zwave,Broadlink et rfxcom avec divers modules
Merci à toute l'équipe et à tous les forumeurs pour vos conseils !

Shakirosebebe22
Timide
Messages : 45
Inscription : 20 nov. 2016, 13:54

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par Shakirosebebe22 » 22 oct. 2017, 09:53

zoboton a écrit :
22 oct. 2017, 09:24
Est-ce que ça fonctionnait avant la 3.1.7 ?

Bonjour,

J'ai une installation de Jeedom qui date d'environ 1 an en Raspbian 8 qui a migré jusqu'à la dernière version de Jeedom (3.1.7) ou il n'y a aucun problème. Pushbullet fonctionne correctement sur cette installation.

Cdlt,
Shaki

zoboton
Timide
Messages : 275
Inscription : 14 août 2014, 10:34

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par zoboton » 22 oct. 2017, 10:03

Je pense que le pb est debian 9, et je suspecte que c'est parce que debian 9 embarque python3 (ou alors ce serait un autre pb lié à python).
J'ai pas testé pushbullet avec python 3....

Catmar
Timide
Messages : 219
Inscription : 18 janv. 2017, 21:38

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par Catmar » 22 oct. 2017, 10:06

Merci pour ta réponse

Je suis sur mini+ avec apache

Rien dans les logs en mode debug qd envoi message vers jeedom
Catmar, débutant, inculte en Linux, python, ssh et autres... mais volontaire
Lyon
Mini+ & Smart avec Zwave,Broadlink et rfxcom avec divers modules
Merci à toute l'équipe et à tous les forumeurs pour vos conseils !

zoboton
Timide
Messages : 275
Inscription : 14 août 2014, 10:34

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par zoboton » 22 oct. 2017, 10:07

C'est normal, c'est un démo donc ça va dans d'autres logs.
J'ai publié une version beta qui produit un fichier /tmp/pushbullet.log
Si tu pouvais m'envoyer le résultat par MP ...

zoboton
Timide
Messages : 275
Inscription : 14 août 2014, 10:34

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par zoboton » 22 oct. 2017, 10:11

Ok c'est bien ça, j'ai installé python3 et ça fonctionne pas en effet. Donc rien à avoir avec la 3.1.7.
Est-ce que vous avez python2 installé par défaut sur Debian Stretch ?

Pour tester, lancer en SSH sur le serveur : /usr/bin/python2 --version

zoboton
Timide
Messages : 275
Inscription : 14 août 2014, 10:34

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par zoboton » 22 oct. 2017, 10:16

Je viens du publier une version beta. J'ai espoir que ça résolve le problème. Qui peut tester ?

Shakirosebebe22
Timide
Messages : 45
Inscription : 20 nov. 2016, 13:54

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par Shakirosebebe22 » 22 oct. 2017, 10:24

zoboton a écrit :
22 oct. 2017, 10:16
Je viens du publier une version beta. J'ai espoir que ça résolve le problème. Qui peut tester ?
Il faut simplement installer la version beta dans le market ?

didaskein
Timide
Messages : 32
Inscription : 02 oct. 2016, 17:40

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par didaskein » 22 oct. 2017, 10:25

J'ai la version 2.7.13 de Python.
Je viens d'installer la version Beta.

didaskein
Timide
Messages : 32
Inscription : 02 oct. 2016, 17:40

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par didaskein » 22 oct. 2017, 10:28

Voici le log :

2017-10-22 10:22:34,890 - MainThread - pushbullet:146 - DEBUG - Check PID file
2017-10-22 10:22:34,890 - MainThread - pushbullet:151 - DEBUG - PID file '/var/www/html/plugins/pushbullet/ressources/pushbullet_daemon/../../../../tmp/pushbullet.o.XXXXXXXXXXXXt7xDoqXXXXXa.pid'
2017-10-22 10:22:34,890 - MainThread - pushbullet:160 - DEBUG - Write PID file
2017-10-22 10:22:34,890 - MainThread - pushbullet:167 - DEBUG - Start daemon
2017-10-22 10:22:34,898 - MainThread - pushbullet:92 - DEBUG - Writing PID 27137 to /var/www/html/plugins/pushbullet/ressources/pushbullet_daemon/../../../../tmp/pushbullet.o.XXXXXXXXXXXXt7xDoqXXXXXa.pid
2017-10-22 10:22:35,526 - MainThread - listener:58 - DEBUG - Listener open
2017-10-22 10:22:35,526 - MainThread - listener:67 - DEBUG - Message received:{"type": "nop"}
2017-10-22 10:23:05,528 - MainThread - listener:67 - DEBUG - Message received:{"type": "nop"}
2017-10-22 10:23:16,581 - MainThread - listener:67 - DEBUG - Message received:{"type":"tickle","subtype":"push"}
2017-10-22 10:23:17,085 - MainThread - pushbullet:123 - DEBUG - Return code: 0
2017-10-22 10:23:17,085 - MainThread - pushbullet:124 - DEBUG - Thread finished
2017-10-22 10:23:19,038 - MainThread - listener:67 - DEBUG - Message received:{"type":"tickle","subtype":"push"}
2017-10-22 10:23:19,493 - MainThread - pushbullet:123 - DEBUG - Return code: 0
2017-10-22 10:23:19,493 - MainThread - pushbullet:124 - DEBUG - Thread finished
2017-10-22 10:23:20,816 - MainThread - listener:67 - DEBUG - Message received:{"type":"tickle","subtype":"push"}
2017-10-22 10:23:21,305 - MainThread - pushbullet:123 - DEBUG - Return code: 0
2017-10-22 10:23:21,305 - MainThread - pushbullet:124 - DEBUG - Thread finished
2017-10-22 10:23:35,528 - MainThread - listener:67 - DEBUG - Message received:{"type": "nop"}
2017-10-22 10:24:05,530 - MainThread - listener:67 - DEBUG - Message received:{"type": "nop"}
2017-10-22 10:24:35,541 - MainThread - listener:67 - DEBUG - Message received:{"type": "nop"}
2017-10-22 10:25:05,542 - MainThread - listener:67 - DEBUG - Message received:{"type": "nop"}
2017-10-22 10:25:35,519 - MainThread - listener:67 - DEBUG - Message received:{"type": "nop"}
2017-10-22 10:26:05,542 - MainThread - listener:67 - DEBUG - Message received:{"type": "nop"}
2017-10-22 10:26:35,518 - MainThread - listener:67 - DEBUG - Message received:{"type": "nop"}

Shakirosebebe22
Timide
Messages : 45
Inscription : 20 nov. 2016, 13:54

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par Shakirosebebe22 » 22 oct. 2017, 10:30

Voici mes logs également :
2017-10-22 08:26:28,329 - MainThread - pushbullet:146 - DEBUG - Check PID file
2017-10-22 08:26:28,330 - MainThread - pushbullet:151 - DEBUG - PID file '/var/www/html/plugins/pushbullet/ressources/pushbullet_daemon/../../../../tmp/pushb
ullet.o.xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.pid'
2017-10-22 08:26:28,331 - MainThread - pushbullet:160 - DEBUG - Write PID file
2017-10-22 08:26:28,331 - MainThread - pushbullet:164 - ERROR - Unable to write PID file: No such file or directory [2]
2017-10-22 08:26:40,539 - MainThread - pushbullet:146 - DEBUG - Check PID file
2017-10-22 08:26:40,540 - MainThread - pushbullet:151 - DEBUG - PID file '/var/www/html/plugins/pushbullet/ressources/pushbullet_daemon/../../../../tmp/pushb
ullet.o.xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.pid'
2017-10-22 08:26:40,541 - MainThread - pushbullet:160 - DEBUG - Write PID file
2017-10-22 08:26:40,541 - MainThread - pushbullet:164 - ERROR - Unable to write PID file: No such file or directory [2]
Dernière édition par Shakirosebebe22 le 22 oct. 2017, 10:36, édité 2 fois.

didaskein
Timide
Messages : 32
Inscription : 02 oct. 2016, 17:40

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par didaskein » 22 oct. 2017, 10:32

Catpure du message d'erreur dans les logs : https://1drv.ms/i/s!Av7Pb9pv9kKUo-I727PW3DX-nUoKlg

j'ai toujours l'erreur dans les Log mais Pushbullet fonctionne tj chez moi, je recois bien la notification sur mon mobile.

didaskein
Timide
Messages : 32
Inscription : 02 oct. 2016, 17:40

Re: [Plugin Tiers][Sujet Principal] Pushbullet

Message par didaskein » 22 oct. 2017, 10:34

Shakirosebebe22 a écrit :
22 oct. 2017, 10:24
zoboton a écrit :
22 oct. 2017, 10:16
Je viens du publier une version beta. J'ai espoir que ça résolve le problème. Qui peut tester ?
Il faut simplement installer la version beta dans le market ?
oui par contre, il faut supprimer ta clé d'authent de pushbullet dans les logs ! (pour ne pas la publier sur le forum)



Capture d'ecran du code ligne 844 : https://1drv.ms/i/s!Av7Pb9pv9kKUo-I8F9Vgp_U0lvGE5A
Je pense que l'erreur doit venir d'ici.
Pour info j'ai le plugin camera donc je dois passer par ici et il doit y avoir un objet a null...
Dernière édition par didaskein le 22 oct. 2017, 10:40, édité 1 fois.

Répondre

Revenir vers « [Catégorie] Communication »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité