Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Tuto] Accès à distance Jeedom via Freebox

De l'installation à l'utilisation venez discuter de JEEDOM au quotidien
RaGE
Timide
Messages : 233
Inscription : 24 sept. 2017, 08:57

[Tuto] Accès à distance Jeedom via Freebox

Message par RaGE » 02 nov. 2017, 14:51

Suite à une longue discussion et plein de contributions de jeedomiens pour m'aider à mettre en place mon accès extérieur à Jeedom avec une Freebox Revolution en routeur, j'ai compilé les éléments dans ce tuto:

Accès à distance à Freebox OS.
* D'une part, l'accès à distance à Freebox OS et l'accès à Jeedom sont indépendants.
Donc pour activer l' aàd à Freebox OS, il faut se connecter à Freebox OS en local dans un premier temps.
Sous paramètres de la Freebox -> Connexion Internet/configuration, faire les réglages suivants:
- Décocher répondre au ping, en effet, pas besoin de répondre à quelqu'un de l'extérieur qui envoie des pings à tout va pour voir si ça répond et trouver une ciible d'attaque potentielle - si vous débuggez et avez besoin du ping, vous pouvez temporairement recocher cette case.
- Activer l'authentification par mot de passe
- Mettre deux valeurs de port d'accès distant, une pour HTTP et une pour HTTPS, qui ne soient pas 80 et 443. En effet, ces valeurs-là sont usuelles, donc un potentiel attaquant de l'extérieur commenceraient par celles-ci. Appelons-les httpport et httpSport.
- Valider avec OK.
Pour accéder à Freebox OS depuis l'extérieur, voici la marche à suivre:
*Par IP*
- Toujours dans paramètres de la Freebox -> Configuration IPv6, décochez IPv6 ( sauf si vous en avez besoin pour une raison particulière).
- Sur le menu principal de Freebox OS, dans Etat de la Freebox -> Etat Internet, notez votre IPv4, sous forme aaa.bbb.ccc.ddd
- Vous pouvez désormais accéder à Freebox OS grâce à http://aaa.bbb.ccc.ddd:httpport. Ceci ne marche QUE depuis l'extérieur de votre réseau local, donc un autre ordinateur ou un téléphone portable en 4G, pas depuis un terminal sur votre réseau local, en l'occurence pas depuis votre ordinateur relié à votre freebox.
* Par DNS*
Il est plus sécurisant de retenir son IP publique plutôt qu'un nom de domaine, car elle est noyée au milieu de millions d'autres adresses. Si vous voulez néanmoins passer par le nom de domaine, voici la marche à suivre:
- Dans paramètres de la Freebox -> Nom de domaine, ajouter un nom de domaine avec un préfixe de votre choix, disons xxx, et demandez un certificat letsEncrypt.
- Après un certain temps, le nom de domaine xxx.freeboxos.fr est validé.
- Vous pouvez désormais accéder à Freebox OS grâce à http://xxx.freeboxos.fr:httpport, ou encore mieux, en sécurisé, grâce à https://xxx.freeboxos.fr:httpSport

DHCP
Pour le support (Pi, NAS, etc...) sur lequel jeedom est installé, il est très conseillé d'avoir un bail DHCP statique pour éviter certains bugs de la Freebox:
- Dans paramètres de la Freebox -> Réseau local/DHCP, cochez:
* Activer le serveur DHCP, pour que tout le monde sur le réseau reçoivent des IPs automatiquement
* Cocher Assignation fixe par machine, pour que l'IP soit la même pour la même machine. Ainsi Freebox OS mappe les addresses MAC propres aux divers appareils sur le réseau aux IPs pour avoir toujours la même. C'est plus pratique.
* Mettre début et fin de la plage d'adresse à, par exemple, 192.168.0.10 et 192.168.0.50, ainsi tous vos appareils auront une IP comprise entre ces deux valeurs incluses. Pour les appareils auxquels vous souhaitez accéder de l'extérieur, Il vaut mieux avoir une IP, même fixe, dans cette plage d'adresse.
Toujours dans DHCP->Baux statiques, créer un bail DHCP statique pour votre support jeedom. Si dans le champ adresse MAC vous ne trouvez pas votre appareil, vous pouvez tout d'abord revenir sur la page principal de Freebox OS, puis Périphériques réseau, et le définir. Si vous ne trouvez pas à quel appareil correspond quelle IP, il faut chercher soit sur l'appareil directement (Pour un Pi, en ligne de commande, faite ifconfig). De retour dans crée un bail statique, entrez l'IP que vous souhaitez donner à votre appareil - vous pouvez garder la même que celle donnée automatiquement, disons eee.fff.ggg.hhh
De manière générale, il est recommandé de donner un bail DHCP statique à tous vos équipements. Moins ça bouge, plus c'est stable (Citation de M.Lapalisse).

Redirection des ports
Pour pouvoir accéder à Jeedom, et plus généralement, à votre appareil depuis l'extérieur, il faut indiquer à la Freebox de reporter le trafic sur l'appareil en question via la redirection des ports.
- Dans paramètres de la Freebox -> Connexion Internet/Gestion des ports, ajouter la redirection suivante:
* IP Destination, celle de votre jeedom sur le réseau, soit eee.fff.ggg.hhh
* Cochez redirection active
* Choisir "Toutes" pour IP source
* Protocole TCP
* Port de début et port de fin, le même numéro de port au choix, par exemple 14254 au pif. Appelons le httpJeedom. Attention : Ce numéro doit être différent du numéro que nous avions appelé httpport plus haut entré pour l'accès à Freebox OS !!
* Port de destination : 80
- Ajoutez ensuite une autre redirection en TCP, avec un numéro de début et de fin de port identiques aussi, mais différents de ceux plus haut (en général >32000), par exemple 42569. Appelons le httpSJeedom. Le port de destination est 443. Attention : Le numéro httpSJeedom doit être différent du numéro httpSport entré pour l'accès à Freebox OS, c'est ce qui permettra d'aiguiller soit vers Jeedom, soit vers Freebox OS !! Si le même est utilisé, la Freebox a précédence sur toute machine qui y est reliée en local, ce n'est pas ce que nous voulons.

Donc pour résumer, on a 2 redirections TCP en tout : une qui redirige de httpJeedom vers 80, et une qui redirige de httpSJeedom vers 443.
Les redirections en UDP ne sont pas nécessaires; voire dangereuses, donc à ne pas utiliser, sauf si vous en avez explicitement besoin.

Désormais, il vous est possible d'accéder à Jeedom via l'extérieur, en tapant http://aaa.bbb.ccc.ddd:httpJeedom. Cependant, cette connexion HTTP n'est pas sécurisée : quelqu'un qui "écouterait" votre communication pourrait même y lire vos identifiantes et mot de passe en clair. Il est donc très fortement recommandé de passer en SSL, c'est-à-dire d'utiliser une connexion commençant par https et non http.
Pour accéder en sécurisé, donc en SSL via https, il faut activer SSL sur votre appareil, créer un virtualhost, et ...
créer un certificat, exemple sur le Pi
Plusieurs écoles:
- Créer un certificat signé par soi, via ce tutorial par exemple :
https://technique.arscenic.org/lamp-lin ... ur-apache2
Avantage : c'est plutôt simple, Inconvénient: tous les navigteurs ne le reconnaissent pas, donc il faudra leur mettre une exception de sécurité pour valider l'accès et pour que le certificat soit reconnu comme "sûr". Pour les ordinateurs depuis lesquels on accède à son Jeedom, il est possible d'ajouter ce certificat à la banque de certificats de la machine, et cette alerte disparaîtra.
- Créer un certificat letsencrypt, via la doc officielle par exemple :
https://github.com/jeedom/documentation ... e.asciidoc
Avantage : quand ça marche, c'est nickel, Inconvénient: Ce n'est pas si évident à mettre en place pour un débutant.

Après cett étape, en interne, vous devez pouvoir accéder:
- en http, avec http://eee.fff.ggg.hhh (utilise le port 80 par défaut)
- en https, avec https://eee.fff.ggg.hhh (utilise le port 443 par défaut)
Et désormais en externe, avec https://aaa.bbb.ccc.ddd:httpSJeedom ou http://xxx.freeboxos.fr:httpSJeedom
Attention, les adresses externes ne fonctionnent pas depuis une machine à l'intérieur de votre réseau local. Autrement dit, vous devez vraiment accéder depuis l'extérieur (autre machine en-dehors de votre domicile, ou depuis votre portable en 4G) en utilisant ces adresses.

configuration de Jeedom
-Dans Jeedom, depuis la Dashboard, ouvrez Roues dentées->Configuration->Réseaux.
- Pour l'interne, entrez HTTP puis eee.fff.ggg.hhh : 80
- Pour l'externe, en ssl:
entrez HTTPS puis aaa.bbb.ccc.ddd : httpSJeedom ou bien HTTPS puis xxx.freeboxos.fr : httpSJeedom si vous avez le nom de domaine
- Pour l'externe, en normal (http):
entrez HTTP puis aaa.bbb.ccc.ddd : httpJeedom ou bien HTTP puis xxx.freeboxos.fr : httpJeedom si vous avez le nom de domaine
- Pour finir, cochez la case "Désactiver la gestion du réseau par Jeedom"

Rappel: HTTPS est le strict minimum de sécurité pour accéder depuis l'extérieur. HTTP est à exclure, donc efforcez-vous de faire a minima marcher le SSL sur votre machine faisant tourner Jeedom. Mieux est un accès en VPN ( serveur et client VPN sont d'ailleurs intégrés à Freebox OS, dans Paramètres de la Freebox -> Connexion Internet/Serveur VPN et Client VPN) en plus du HTTPS. Nec plus ultra est le Power Pack proposé par Jeedom SAS, avec un DNS et tout et tout. C'est le plus simple, et quelques dizaines d'euros bien investis. 8-)

Merci à @parrain27240, @myrmia, @SupraDolph et @drs pour leur précieux conseils.
Dernière édition par RaGE le 02 nov. 2017, 14:55, édité 2 fois.
Jeedom sur RPi3 - Installation knx/eibd

parrain27240
Actif
Messages : 1629
Inscription : 24 juil. 2015, 20:15

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par parrain27240 » 02 nov. 2017, 14:52

précieux je sais pas mdr .
inpec ton tuto ;)

Envoyé de mon Redmi 4X en utilisant Tapatalk


julosdong
Timide
Messages : 2
Inscription : 30 oct. 2017, 22:24

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par julosdong » 04 nov. 2017, 09:58

Bonjour RaGE,

Et félicitationsi pour ce tuto super clair!
J'ai démarré la domotique depuis 1 semaine sur un Raspberry 3B, je galérait depuis 3 jours sur l'accés externe, j'avais lu pas mal de post mais rien d'aussi bien expliqué. Bravo !
En 5mn c'était réglé et ça marche, au moins en HTTP. Je vais maintenant essayer de sécuriser l'accés.

J'abuserais pour avoir une explication aussi claire sur la façon d'utiliser le VPN intégré de la freebox? :roll:
==================
Noobs en domotique.
Matos: Debian 9 stretch sur Raspberry PI 3B + rfplayer et box connexoon, Freebox V6
Equipements:VELUX intégra Solaires (IO), volets Somfy Solaires RTS, Xiaomi Gateway avec capteurs de temp, prises Chacon

parrain27240
Actif
Messages : 1629
Inscription : 24 juil. 2015, 20:15

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par parrain27240 » 04 nov. 2017, 10:04

tu vois rage c'est ça qui fait plaisir quand ta fais un tuto mdrr

Envoyé de mon Redmi 4X en utilisant Tapatalk


RaGE
Timide
Messages : 233
Inscription : 24 sept. 2017, 08:57

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par RaGE » 04 nov. 2017, 19:23

@parrain27240 : Oui, c'est super sympa les retours comme ça !

@julosdong, bienvenue dans la domotique ! Pour le VPN, je ne vais pas pouvoir t'aider, je ne l'utilise pas. Mais la configuration ne me semble pas trop compliquée pour un accès de l'extérieur vers ton réseau interne.
Jeedom sur RPi3 - Installation knx/eibd

julosdong
Timide
Messages : 2
Inscription : 30 oct. 2017, 22:24

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par julosdong » 05 nov. 2017, 12:11

@RaGE: Merci pour le message de bienvenue, et pour le VPN, pas de soucis, j'ai un peu essayé mais pour l'instant ça ne marche pas, c'est déjà bien que ma connexion externe sécurisée fonctionne , j'ai utilisé le certificat "home-made", il n'y a que Safari qui ne veut rien savoir, mais sur les autres navigateurs pas de soucis.
Si j'arrive a faire fonctionner l’accès par le VPN de ma freebox je ferais un tuto! ;-)
==================
Noobs en domotique.
Matos: Debian 9 stretch sur Raspberry PI 3B + rfplayer et box connexoon, Freebox V6
Equipements:VELUX intégra Solaires (IO), volets Somfy Solaires RTS, Xiaomi Gateway avec capteurs de temp, prises Chacon

Avatar de l’utilisateur
bartounet
Actif
Messages : 2541
Inscription : 14 juil. 2016, 10:09

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par bartounet » 05 nov. 2017, 12:52

Merci pour le tuto

bien insister sur le https
Où le VPN à défaut où les deux c'est encore mieux

En HTTP il est tellement simple de sniffer le login mot de passe

après on se demande pourquoi les lumières s'allume tout seul chez soi
Jeedom à jour Debian 9
VM VMWARE ESXi 6.7 ( SSD)
Stick ZWave / FIBARO / Ikea Light / Yeelight / Google Home
Wifi Unifi / PFSENSE / Reverse Proxy DMZ SSL

Passionné de bidouillage informatique en tout genre
Mon blog : http://blog.info16.fr

guims78
Actif
Messages : 509
Inscription : 30 sept. 2017, 13:00

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par guims78 » 05 nov. 2017, 20:05

Hello, j'ai cherché un moment pour configurer mon acces distant.
J'ai suivi le tuto, mais j'ai une erreur concernant le certificat SSL.
Voci ce que j'ai tapé et le résultat :

Code : Tout sélectionner

pi@raspberrypi:~ $ sudo /opt/letsencrypt/letsencrypt-auto --apache --email brotonne.g@free.fr -d jeedom-guims.freeboxos.fr
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache

-------------------------------------------------------------------------------
Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf. You must agree
in order to register with the ACME server at
https://acme-v01.api.letsencrypt.org/directory
-------------------------------------------------------------------------------
(A)gree/(C)ancel: A

-------------------------------------------------------------------------------
Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let's Encrypt project and the non-profit
organization that develops Certbot? We'd like to send you email about EFF and
our work to encrypt the web, protect its users and defend digital rights.
-------------------------------------------------------------------------------
(Y)es/(N)o: N
Obtaining a new certificate
Performing the following challenges:
tls-sni-01 challenge for jeedom-guims.freeboxos.fr
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. jeedom-guims.freeboxos.fr (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Timeout

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: jeedom-guims.freeboxos.fr
   Type:   connection
   Detail: Timeout

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.
 - Your account credentials have been saved in your Certbot
   configuration directory at /etc/letsencrypt. You should make a
   secure backup of this folder now. This configuration directory will
   also contain certificates and private keys obtained by Certbot so
   making regular backups of this folder is ideal.
Je précise que j'ai un nom de domaine Free.

Merci d'avance.

RaGE
Timide
Messages : 233
Inscription : 24 sept. 2017, 08:57

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par RaGE » 06 nov. 2017, 08:22

J'avais la même, et ... n'ai jamais pu la résoudre, c'est pourquoi je suis revenu sur un certificat auto-signé.
Le support de let's encrypt m'indiquait que pour vérifier le challenge tls-sni-01 qui te pose problème, il faut une vérification de ton nom de domaine, mais celle-ci ne fonctionne pas, probablement parce que tu as une redirection de port, et qu'il n'arrive pas à accéder directement sur ton adresse htttps://jxxxxxxxxx.freeboxos.fr sans indication du port. Essaie de voir si tu peux mettre un numéro de port sur la ligne de commande de letsencrypt.
Mon échange avec letsencrypt :
https://community.letsencrypt.org/t/tls ... ng/44699/2
Jeedom sur RPi3 - Installation knx/eibd

guims78
Actif
Messages : 509
Inscription : 30 sept. 2017, 13:00

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par guims78 » 06 nov. 2017, 09:11

RaGE a écrit :
06 nov. 2017, 08:22
J'avais la même, et ... n'ai jamais pu la résoudre, c'est pourquoi je suis revenu sur un certificat auto-signé.
Le support de let's encrypt m'indiquait que pour vérifier le challenge tls-sni-01 qui te pose problème, il faut une vérification de ton nom de domaine, mais celle-ci ne fonctionne pas, probablement parce que tu as une redirection de port, et qu'il n'arrive pas à accéder directement sur ton adresse htttps://jxxxxxxxxx.freeboxos.fr sans indication du port. Essaie de voir si tu peux mettre un numéro de port sur la ligne de commande de letsencrypt.
Mon échange avec letsencrypt :
https://community.letsencrypt.org/t/tls ... ng/44699/2
Merci de l'info.
J'ai aussi essayé un auto certificat, mais sans succès apparemment.
Je posterai le résultat des commande ce soir.
Cependant, grace à ce tuto, j'accède à mon jeedom depuis l'extérieur et c'est déjà un tres grand pas pour moi ;-)
Même si pas encore sécurisé !

guims78
Actif
Messages : 509
Inscription : 30 sept. 2017, 13:00

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par guims78 » 06 nov. 2017, 20:36

Voici le résultat des commandes pour essayer le certificat auto-signé :

Code : Tout sélectionner

pi@raspberrypi:~ $ dpkg -l | grep ssl
ii  libflac8:armhf                        1.3.2-1                            armhf        Free Lossless Audio Codec - runtime C library
ii  libssl-dev:armhf                      1.1.0f-3+deb9u1                    armhf        Secure Sockets Layer toolkit - development files
ii  libssl-doc                            1.1.0f-3                           all          Secure Sockets Layer toolkit - development documentation
ii  libssl1.0.2:armhf                     1.0.2l-2                           armhf        Secure Sockets Layer toolkit - shared libraries
ii  libssl1.1:armhf                       1.1.0f-3+deb9u1                    armhf        Secure Sockets Layer toolkit - shared libraries
ii  libwavpack1:armhf                     5.0.0-2                            armhf        audio codec (lossy and lossless) - library
ii  openssl                               1.1.0f-3+deb9u1                    armhf        Secure Sockets Layer toolkit - cryptographic utility
ii  python-openssl                        16.2.0-1                           all          Python 2 wrapper around the OpenSSL library
ii  python3-openssl                       16.2.0-1                           all          Python 3 wrapper around the OpenSSL library
ii  ssl-cert                              1.0.39                             all          simple debconf wrapper for OpenSSL
pi@raspberrypi:~ $ sudo mkdir /etc/apache2/ssl
pi@raspberrypi:~ $ sudo /usr/sbin/make-ssl-cert /usr/share/ssl-cert/ssleay.cnf /etc/apache2/ssl/apache.pem
Could not create certificate. Openssl output was:
Error Loading extension section v3_req
1995789728:error:2207507C:X509 V3 routines:v2i_GENERAL_NAME_ex:missing value:../crypto/x509v3/v3_alt.c:496:
1995789728:error:22098080:X509 V3 routines:X509V3_EXT_nconf:error in extension:../crypto/x509v3/v3_conf.c:47:name=subjectAltName, value=DNS:localhost,jeedom-guims.freeboxos.fr
pi@raspberrypi:~ $ vi /etc/apache2/ports.conf
pi@raspberrypi:~ $ sudo vi /etc/apache2/sites-available/default-ssl
pi@raspberrypi:~ $ a2enmod ssl
Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled
pi@raspberrypi:~ $ a2ensite default-ssl
Site default-ssl already enabled
pi@raspberrypi:~ $ sudo /etc/init.d/apache2 restart
[....] Restarting apache2 (via systemctl): apache2.serviceWarning: apache2.service changed on disk. Run 'systemctl daemon-reload' to reload units.
. ok 
pi@raspberrypi:~ $ sudo /etc/init.d/apache2 restart
Des idées ?

RaGE
Timide
Messages : 233
Inscription : 24 sept. 2017, 08:57

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par RaGE » 07 nov. 2017, 11:03

Quel nom as-tu indiqué lors de l´étape sudo /usr/sbin/make-ssl-cert /usr/share/ssl-cert/ssleay.cnf /etc/apache2/ssl/apache.pem ?
Est-ce qu'il-t-'a demandé un nom ?
Dernière édition par RaGE le 08 nov. 2017, 09:45, édité 1 fois.
Jeedom sur RPi3 - Installation knx/eibd

guims78
Actif
Messages : 509
Inscription : 30 sept. 2017, 13:00

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par guims78 » 07 nov. 2017, 19:54

oui, il me semble que j'ai du mettre un nom.
J'ai laissé Localhost et ensuite comme j'avais la possibilité d'ajouter un autre domaine, j'ai ajouté celui créé par FREE.

RaGE
Timide
Messages : 233
Inscription : 24 sept. 2017, 08:57

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par RaGE » 08 nov. 2017, 09:48

Est-ce que tu es sûr du nom de domaine que tu as entré? Il n'est pas arrivé à joindre ton nom de domaine pour la création du certificat. Est-ce qu'il était actif au moment de la création du certificat ? (Tu peux par exemple joindre Freebox OS via ce nom de domaine ?)
Tu peux retenter en étant sûr de mettre xxxxx.freeboxos.fr comme nom de domaine ?
Jeedom sur RPi3 - Installation knx/eibd

guims78
Actif
Messages : 509
Inscription : 30 sept. 2017, 13:00

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par guims78 » 08 nov. 2017, 16:46

RaGE a écrit :
08 nov. 2017, 09:48
Est-ce que tu es sûr du nom de domaine que tu as entré? Il n'est pas arrivé à joindre ton nom de domaine pour la création du certificat. Est-ce qu'il était actif au moment de la création du certificat ? (Tu peux par exemple joindre Freebox OS via ce nom de domaine ?)
Tu peux retenter en étant sûr de mettre xxxxx.freeboxos.fr comme nom de domaine ?
Aujourd'hui, j'accède à distance à mon Jeedom avec le nom de domaine xxxxx.freebosos.fr:1234
Par contre, j'ai effectivement du laisser le localhost au début puis un nom de domaine complémentaire.
Cela vient probabement de ça.
Je vais essayer de relancer la commande en passant xxxxx.freebosos.fr à la place du localhost

Je reviens avec les infos.

guims78
Actif
Messages : 509
Inscription : 30 sept. 2017, 13:00

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par guims78 » 08 nov. 2017, 20:17

apres avoir refait le tuto :

Code : Tout sélectionner

pi@raspberrypi:~ $ sudo /usr/sbin/make-ssl-cert /usr/share/ssl-cert/ssleay.cnf /etc/apache2/ssl/apache.pem
pi@raspberrypi:~ $ vi /etc/apache2/ports.conf
pi@raspberrypi:~ $ sudo vi /etc/apache2/sites-available/default-ssl
pi@raspberrypi:~ $ a2enmod ssl
Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled
pi@raspberrypi:~ $ a2ensite default-ssl
Site default-ssl already enabled
pi@raspberrypi:~ $ sudo /etc/init.d/apache2 restart
[....] Restarting apache2 (via systemctl): apache2.serviceWarning: apache2.service changed on disk. Run 'systemctl daemon-reload' to reload units.
. ok 
pi@raspberrypi:~ $ 
pas de message d'erreur, mais sous Chrome, quand je vais sur : xxxxx.freeboxos.fr:12345
il me dit encore que la connexion n'est pas sécurisée.

RaGE
Timide
Messages : 233
Inscription : 24 sept. 2017, 08:57

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par RaGE » 08 nov. 2017, 21:18

Tu as un truc de ce goût-là ?
https://www.malekal.com/fichiers/forum/ ... NVALID.png ?
Si tu as fait un auto-signé, c'est normal, c'est parce que toi, tu n'es pas une autorité de délivrance de certificat reconnue :-) Tu peux mettre le certificat sur la machine depuis laquelle tu utilises Chrome, dans ce cas le message ne s'affiche plus.
Si tu fais le certif avec letsencrypt, tu n'As pas ce message, car letsencrypt est une autorité reconnue.
Jeedom sur RPi3 - Installation knx/eibd

DJo86
Timide
Messages : 290
Inscription : 29 déc. 2015, 13:48
Localisation : Poitiers

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par DJo86 » 08 nov. 2017, 22:33

Bien joué RaGE !!!
Jeedom en VM sur Proxmox Hystou I3 - Configuration complète dans mon profil.
Joli job, merci à toute l’équipe Jeedom et aux développeurs externes !!!

guims78
Actif
Messages : 509
Inscription : 30 sept. 2017, 13:00

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par guims78 » 09 nov. 2017, 09:10

Je n'arrive pas à ouvrir le lien pour comparer le message avec je que je vois chez moi. :?:

RaGE
Timide
Messages : 233
Inscription : 24 sept. 2017, 08:57

Re: [Tuto] Accès à distance Jeedom via Freebox

Message par RaGE » 09 nov. 2017, 09:53

Le lien pointe sur un screenshot d'un message d'erreur du navigateur, tu es vraiment sûr qu'il ne s'ouvre pas ou tu as pris l'image au premier degré :-) ?
Jeedom sur RPi3 - Installation knx/eibd

Répondre

Revenir vers « Utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité