Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Sujet officiel] Plugin sonos

fishton
Timide
Messages : 17
Inscription : 19 janv. 2018, 08:10

Re: [Sujet officiel] Plugin sonos

Message par fishton » 19 janv. 2018, 11:55

Plugin Sonos : 2017-12-26 09:52:29
version 2.4

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 19 janv. 2018, 12:18

Ce n'est pas la version beta du plugin. Attention faut bien activer les betas sur ton profils market et sauvegarder sinon le bouton beta installe la stable.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

fishton
Timide
Messages : 17
Inscription : 19 janv. 2018, 08:10

Re: [Sujet officiel] Plugin sonos

Message par fishton » 19 janv. 2018, 23:05

Hello

J'ai reussi à passser en mode Beta sur le market et à installer le plugin ... mais je pensais avoir PHP 7 mais non ...

bref, en rentrant à la maison, un petit grep

root@nasbrock:/tmp# find . -type f | xargs grep "192.168.0.11"

et bam :

./sonos-cache/60/5b646576696365735f4e554c4c5f5f3233392e3235352e3235352e3235305d5b315d.doctrinecache.data:a:1:{i:0;s:12:"192.168.0.11";}
./sonos-cache/98/5b687474703a2f2f3139322e3136382e302e31313a313430302f786d6c2f6465766963655f6465736372697074696f6e2e786d6c5d5b315d.doctrinecache.data: <friendl yName>192.168.0.11 - Sonos PLAY:5</friendlyName>
./sonos-cache/98/5b687474703a2f2f3139322e3136382e302e31313a313430302f786d6c2f6465766963655f6465736372697074696f6e2e786d6c5d5b315d.doctrinecache.data: <friendlyN ame>192.168.0.11 - Sonos PLAY:5 Media Server</friendlyName>
./sonos-cache/e1/5b687474703a2f2f3139322e3136382e302e31313a313430302f7374617475732f746f706f6c6f67795d5b315d.doctrinecache.data:<?xml-stylesheet type="text/xsl" h ref="/xml/review.xsl"?><ZPSupportInfo><ZonePlayers><ZonePlayer group='RINCON_000E5856411201400:3546178926' coordinator='true' wirelessmode='1' wirelessleafonly=' 0' hasconfiguredssid='1' channelfreq='2442' behindwifiext='0' wifienabled='1' location='http://192.168.0.11:1400/xml/device_description.xml' version='39.4-48021' mincompatibleversion='38.0-00000' legacycompatibleversion='25.0-00000' apiversion='1.1.1' minapiversion='1.0.0' bootseq='74' uuid='RINCON_000E5856411201400'>Piè ce à vivre</ZonePlayer></ZonePlayers><MediaServers><MediaServer location='192.168.1.22:3500' uuid='mobile-ACR-020000000000' version='' canbedisplayed='false' una vailable='false' type='0' ext=''>Samsung SM-G930F</MediaServer><MediaServer location='192.168.0.30:3500' uuid='mobile-ACR-4f341d60d3095651' version='' canbedispl ayed='false' unavailable='false' type='0' ext=''>Asus Nexus 7</MediaServer><MediaServer location='192.168.0.49:3500' uuid='mobile-ACR-4054485464dfa6eb' version=' ' canbedisplayed='false' unavailable='false' type='0' ext=''>Samsung SM-G935F</MediaServer><MediaServer location='192.168.0.14:3500' uuid='mobile-ACR-6022440478a 9bfff' version='' canbedisplayed='false' unavailable='false' type='0' ext=''>Samsung SM-G930F</MediaServer></MediaServers></ZPSupportInfo>";

Un petit rm -rf sur sonos et sonos cache


[2018-01-19 23:00:05][INFO] : creating speaker instances
[2018-01-19 23:00:05][INFO] : discovering devices...
[2018-01-19 23:00:05][DEBUG] : M-SEARCH * HTTP/1.1 HOST: 239.255.255.250:reservedSSDPport MAN: ssdp:discover MX: 1 ST: urn:schemas-upnp-org:device:ZonePlayer:1
[2018-01-19 23:00:06][DEBUG] : HTTP/1.1 200 OK CACHE-CONTROL: max-age = 1800 EXT: LOCATION: http://192.168.31.161:1400/xml/device_description.xml SERVER: Linux UPnP/1.0 Sonos/39.4-48021 (ZPS5) ST: urn:schemas-upnp-org:device:ZonePlayer:1 USN: uuid:RINCON_000E5856411201400::urn:schemas-upnp-org:device:ZonePlayer:1 X-RINCON-HOUSEHOLD: Sonos_5ZjLuTNNgnMKzboY40puHdMKJS X-RINCON-BOOTSEQ: 75 X-RINCON-WIFIMODE: 1 X-RINCON-VARIANT: 0 HOUSEHOLD.SMARTSPEAKER.AUDIO: Sonos_5ZjLuTNNgnMKzboY40puHdMKJS.ew9t5j5InGIaOwS_YBwN
[2018-01-19 23:00:06][INFO] : found device: {usn}
[2018-01-19 23:00:06][NOTICE] : Getting topology info from: http://192.168.31.161:1400/status/topology
[2018-01-19 23:00:06][NOTICE] : requesting xml from: http://192.168.31.161:1400/xml/device_description.xml
[2018-01-19 23:00:06][DEBUG] : 192.168.31.161 model: S5
[2018-01-19 23:00:06][INFO] : getting xml from cache: http://192.168.31.161:1400/xml/device_description.xml
[2018-01-19 23:00:06][INFO] : sending soap request to: http://192.168.31.161:1400/MediaServer/ ... ry/Control
[2018-01-19 23:00:06][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ContentDirectory:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encodin ... ><ObjectID xsi:type="xsd:string">R:0/0</ObjectID><BrowseFlag xsi:type="xsd:string">BrowseDirectChildren</BrowseFlag><Filter xsi:type="xsd:string">*</Filter><StartingIndex xsi:type="xsd:string">0</StartingIndex><RequestedCount xsi:type="xsd:string">100</RequestedCount><SortCriteria xsi:type="xsd:string"></SortCriteria><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:Browse></SOAP-ENV:Body></SOAP-ENV:Envelope>
[2018-01-19 23:00:06][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encodin ... seResponse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1"><Result>&lt;DIDL-Lite xmlns:dc=&quot;http://purl.org/dc/elements/1.1/&quot; xmlns:upnp=&quot;urn:schemas-upnp-org:metadata-1-0/upnp/&quot; xmlns:r=&quot;urn:schemas-rinconnetworks-com:metadata-1-0/&quot; xmlns=&quot;urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/&quot;&gt;&lt;/DIDL-Lite&gt;</Result><NumberReturned>0</NumberReturned><TotalMatches>0</TotalMatches><UpdateID>0</UpdateID></u:BrowseResponse></s:Body></s:Envelope>
[2018-01-19 23:00:06][INFO] : sending soap request to: http://192.168.31.161:1400/MediaServer/ ... ry/Control
[2018-01-19 23:00:06][DEBUG] : REQUEST: <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="urn:schemas-upnp-org:service:ContentDirectory:1" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encodin ... ><ObjectID xsi:type="xsd:string">SQ:</ObjectID><BrowseFlag xsi:type="xsd:string">BrowseDirectChildren</BrowseFlag><Filter xsi:type="xsd:string"></Filter><StartingIndex xsi:type="xsd:string">0</StartingIndex><RequestedCount xsi:type="xsd:string">100</RequestedCount><SortCriteria xsi:type="xsd:string"></SortCriteria><InstanceID xsi:type="xsd:string">0</InstanceID></ns1:Browse></SOAP-ENV:Body></SOAP-ENV:Envelope>
[2018-01-19 23:00:06][DEBUG] : RESPONSE: <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encodin ... seResponse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1"><Result>&lt;DIDL-Lite xmlns:dc=&quot;http://purl.org/dc/elements/1.1/&quot; xmlns:upnp=&quot;urn:schemas-upnp-org:metadata-1-0/upnp/&quot; xmlns:r=&quot;urn:schemas-rinconnetworks-com:metadata-1-0/&quot; xmlns=&quot;urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/&quot;&gt;&lt;/DIDL-Lite&gt;</Result><NumberReturned>0</NumberReturned><TotalMatches>0</TotalMatches><UpdateID>0</UpdateID></u:BrowseResponse></s:Body></s:Envelope>
[2018-01-19 23:00:07][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=sonos3 function=remove callInstallFunction=1
[2018-01-19 23:00:20][INFO] : Début d'activation du plugin
[2018-01-19 23:00:21][INFO] : Info sur le démon : Array ( [launchable_message] => [launchable] => nok [state] => nok [log] => nok [auto] => 0 )
[2018-01-19 23:00:21][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=sonos3 function=install callInstallFunction=1


et voila back in the game :)

TaG
Actif
Messages : 1159
Inscription : 26 oct. 2016, 11:02

Re: [Sujet officiel] Plugin sonos

Message par TaG » 20 janv. 2018, 08:03

Bien joué, mais tu as réussi à le faire tourner sans PHP 7 ou tu as aussi mis à jour la version de PHP/ Debian ?

C'est dommage, j'allais te proposer une offre pour ta play 5 :)

fishton
Timide
Messages : 17
Inscription : 19 janv. 2018, 08:10

Re: [Sujet officiel] Plugin sonos

Message par fishton » 20 janv. 2018, 14:42

hihi je garde ma play 5 :)

non, j'ai remis la version stable qui tourne sous PHP 5, aps envie de me lancer dans l'upgrade ves PHP 7

par contre il déconne à nouveau ...

[2018-01-20 14:40:52][INFO] : creating speaker instances
[2018-01-20 14:40:52][INFO] : getting device info from cache
[2018-01-20 14:40:52][NOTICE] : Getting topology info from: http://192.168.31.161:1400/status/topology
[2018-01-20 14:40:52][INFO] : getting xml from cache: http://192.168.31.161:1400/xml/device_description.xml
[2018-01-20 14:40:52][DEBUG] : 192.168.31.161 model: S5
[2018-01-20 14:40:52][INFO] : getting xml from cache: http://192.168.31.161:1400/xml/device_description.xml
[2018-01-20 14:40:52][INFO] : getting xml from cache: http://192.168.31.161:1400/status/topology
[2018-01-20 14:40:52][ERROR] : Erreur execution de la commande [Salon][Play 5][Pause] : Impossible de récuperer le sonos : [Salon][Play 5]
[2018-01-20 14:40:55][INFO] : creating speaker instances
[2018-01-20 14:40:55][INFO] : getting device info from cache
[2018-01-20 14:40:55][NOTICE] : Getting topology info from: http://192.168.31.161:1400/status/topology
[2018-01-20 14:40:55][INFO] : getting xml from cache: http://192.168.31.161:1400/xml/device_description.xml
[2018-01-20 14:40:55][DEBUG] : 192.168.31.161 model: S5
[2018-01-20 14:40:55][INFO] : getting xml from cache: http://192.168.31.161:1400/xml/device_description.xml
[2018-01-20 14:40:55][INFO] : getting xml from cache: http://192.168.31.161:1400/status/topology
[2018-01-20 14:40:55][ERROR] : Erreur execution de la commande [Salon][Play 5][Pause] : Impossible de récuperer le sonos : [Salon][Play 5

Loic, une idée ? comment je peux débugger ca ? :(

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 20 janv. 2018, 15:38

Non la désolé je sais pas et la version stable date de plus d'un ans depuis bcp de bug sont corrigés en bêta mais je peux pas la sortir... Je suis vraiment d'aucune aide sur la stable trop veille tout à changé depuis
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
Kermitlagrenouille
Actif
Messages : 1770
Inscription : 07 juin 2017, 20:46
Localisation : Alsace

Re: [Sujet officiel] Plugin sonos

Message par Kermitlagrenouille » 21 janv. 2018, 16:48

Hello
J'espère être au bon endroit (plugging sonos plutôt que plugging script)
J'essaye de lancer un scripts sonos (jamais fait de script tout court) et je ne trouve pas de tuto pour les "nuls" ^^
J'ai lu qu'on pouvait remplacer une commande scénario comme celle ci
Capture d'écran 2018-01-21 16.40.13.png
Capture d'écran 2018-01-21 16.40.13.png (26.6 Kio) Consulté 700 fois

par un script (j'en suis ici)
Capture d'écran 2018-01-21 16.41.06.png
Capture d'écran 2018-01-21 16.41.06.png (87.91 Kio) Consulté 700 fois

il parait que c'est plus rapide (pour lancer des mp3 déjà sur le NAS)

Quelqu'un peut m'envoyer une copie de script sonos?

merci
Domotique Atlantique Concept depuis 1998 et toujours à la recherche d’autre utilisateur de ce système
Fan d'Apple & Homebridge

jpcolin
Timide
Messages : 99
Inscription : 27 janv. 2017, 15:22

Re: [Sujet officiel] Plugin sonos

Message par jpcolin » 23 janv. 2018, 08:36

Kermitlagrenouille a écrit :
16 janv. 2018, 09:21
Hello
J’utilisais une appli sur iOS avant TWS (Androïd)
Elle génère un mp3 que tu t’envoies par mail


C175CAC5-731C-45EC-8103-6E3A39E0FD8F.jpeg
Bizarre, je la trouve pas cette app, c'etait sous iOS ou android?

Merci
Installation myhome bticino/legrand éclairage, volet, chauffage. Alarme Paradox Evo192 + ip 150, NAS synology DS410, 3 Rpi 3 Kodi, SONOS multiroom 3 connect + 5 amp + 1x One, camera + Dahua 3200C, Jeedom V3 sous Rpi2, Amazon Alexa Dot.

Airwolf33
Timide
Messages : 9
Inscription : 20 août 2016, 12:18

Re: [Sujet officiel] Plugin sonos

Message par Airwolf33 » 23 janv. 2018, 10:25

Bonjour,
J'ai fait une mise à jour du plugin sonos ce matin sur mon Jeedom (odroid C2) et il ne fonctionne plus...
À priori il me faut php 7...
Comment l'installer ?
Merci d'avance de votre aide

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 23 janv. 2018, 10:35

Bonjour,
Effectivement j'ai fait une betise ca devrait pas etre php7 car pas disponible partout. Je vais voir comment corriger mais ca va prendre plusieurs jours.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Airwolf33
Timide
Messages : 9
Inscription : 20 août 2016, 12:18

Re: [Sujet officiel] Plugin sonos

Message par Airwolf33 » 23 janv. 2018, 11:11

Ok merci !

Envoyé de mon SM-N950F en utilisant Tapatalk


Avatar de l’utilisateur
Shyrka973
Actif
Messages : 555
Inscription : 18 août 2014, 18:17
Localisation : Kourou / Guyane

Re: [Sujet officiel] Plugin sonos

Message par Shyrka973 » 23 janv. 2018, 11:28

loic a écrit :
23 janv. 2018, 10:35
Bonjour,
Effectivement j'ai fait une betise ca devrait pas etre php7 car pas disponible partout. Je vais voir comment corriger mais ca va prendre plusieurs jours.
C'est pourquoi le plugin est passé en obsolète pour éviter de télécharger ou de le mettre à jour ?
DIY Proxmox 5.1 / i3-6100U @ 2.30GHz / 4Go RAM / 128 Go SSD : Jeedom 3.2.12 - Stretch
Protocol: Z-Wave, EnOcean, RFXtrx433E, Xiaomi, BLEA, MQTT, ESPeasy, Jeeduino, Abeille

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 23 janv. 2018, 11:29

En faite c'est pck j'ai mis une veille version il m'en faudrait une plus recent si quelqu'un as je veux bien qu'il m'envoi un zip du dossier /var/www/html/plugins/sonos3
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
Shyrka973
Actif
Messages : 555
Inscription : 18 août 2014, 18:17
Localisation : Kourou / Guyane

Re: [Sujet officiel] Plugin sonos

Message par Shyrka973 » 23 janv. 2018, 11:40

Je t'ai envoyé en MP le tar.bz2 du plugin sonos3.
DIY Proxmox 5.1 / i3-6100U @ 2.30GHz / 4Go RAM / 128 Go SSD : Jeedom 3.2.12 - Stretch
Protocol: Z-Wave, EnOcean, RFXtrx433E, Xiaomi, BLEA, MQTT, ESPeasy, Jeeduino, Abeille

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 23 janv. 2018, 11:46

Super merci beaucoup normalement la c'est bon j'ai remis en ligne la bonne version.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
Shyrka973
Actif
Messages : 555
Inscription : 18 août 2014, 18:17
Localisation : Kourou / Guyane

Re: [Sujet officiel] Plugin sonos

Message par Shyrka973 » 23 janv. 2018, 11:52

Je viens de faire la mise à jour.

Cette mise à jour contient-elle les nouveaux changement vu sur le GitHub car le changelog n'est pas accessible (comme sur les dernières mises à jour de plugins).
DIY Proxmox 5.1 / i3-6100U @ 2.30GHz / 4Go RAM / 128 Go SSD : Jeedom 3.2.12 - Stretch
Protocol: Z-Wave, EnOcean, RFXtrx433E, Xiaomi, BLEA, MQTT, ESPeasy, Jeeduino, Abeille

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 23 janv. 2018, 11:53

Non il y a 0 changement sur cette mise à jour c'est juste de la doc. Les changements du git n'arriverons pas avant plusieurs années en stable.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
Shyrka973
Actif
Messages : 555
Inscription : 18 août 2014, 18:17
Localisation : Kourou / Guyane

Re: [Sujet officiel] Plugin sonos

Message par Shyrka973 » 23 janv. 2018, 11:55

Justement la nouvelle doc n'est pas accessible (erreur 404). Rien n'a changé sur cette mise à jour.
DIY Proxmox 5.1 / i3-6100U @ 2.30GHz / 4Go RAM / 128 Go SSD : Jeedom 3.2.12 - Stretch
Protocol: Z-Wave, EnOcean, RFXtrx433E, Xiaomi, BLEA, MQTT, ESPeasy, Jeeduino, Abeille

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Sujet officiel] Plugin sonos

Message par loic » 23 janv. 2018, 12:20

J'ai corrigé normalement
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
Shyrka973
Actif
Messages : 555
Inscription : 18 août 2014, 18:17
Localisation : Kourou / Guyane

Re: [Sujet officiel] Plugin sonos

Message par Shyrka973 » 23 janv. 2018, 15:53

C'est corrigé. Le lien du Changelog pointe bien vers une page Changelog.

Merci.

Mais le changelog indique des changements qui ne viendront pas avant des années comme tu le dis.
Ou bien je me trompe et ces changements sont bien inclus dans cette version.

Code : Tout sélectionner

Changelog détaillé : https://github.com/jeedom/plugin-sonos/commits/stable

Ajout de la gestion des favoris sonos

Ajout Sonos One et Playbase

Correction de la langue avec picotts

Ajout d’une commande “entrée de ligne”

Mise à jour de librairie de communication avec les sonos

Optimisation du chargement des playlists

Ajout de picotts pour la génération du TTS en locale

Correction du bouton play/pause lors de la mise à jour du widget
DIY Proxmox 5.1 / i3-6100U @ 2.30GHz / 4Go RAM / 128 Go SSD : Jeedom 3.2.12 - Stretch
Protocol: Z-Wave, EnOcean, RFXtrx433E, Xiaomi, BLEA, MQTT, ESPeasy, Jeeduino, Abeille

Répondre

Revenir vers « [Plugin Officiel] Sonos controller »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité