Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Pour échanger sur les plugins classés en catégorie "Protocoles domotiques"
brasletti
Timide
Messages : 43
Inscription : 11 oct. 2016, 21:39

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par brasletti » 04 juil. 2018, 11:32

lunarok a écrit :
29 juin 2018, 18:26
Faites des recherches un peu, rien à voir avec rflink ou un autre plugin. Ce problème apparaît avec l'upgrade 3.2.9 comment en venir à mettre le plugin en cause ? Réinstaller le plugin n'est qu'un cache misère

Envoyé de mon ONEPLUS A5010 en utilisant Tapatalk
J'avais fait une recherche avant, j'en ai refait une (plusieurs en fait) hier et je n'ai toujours rien trouvé. Je cherche surement mal, si tu as le lien qui renvoi vers le fil qui traite de ce problème, merci de me le donner (ou pas :D ), j'arriverai peut-être à comprendre le pourquoi de mes recherches infructueuses.
Merci.

rol-rider
Actif
Messages : 5097
Inscription : 10 août 2014, 23:50

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par rol-rider » 04 juil. 2018, 11:51

peut être ici, mais si tu es passé en 3.2.10 ça doit être résolu


viewtopic.php?f=23&t=38165
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

MaximeDu74
Timide
Messages : 219
Inscription : 29 nov. 2017, 13:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par MaximeDu74 » 16 juil. 2018, 11:39

Bonjour, j'ai un arduino mega avec l'émetteur/récepteur de branché dessus. Tout marche avec le logiciel RFLINK sur Windows mais quand je branche l'arduino au Raspberry et donc à Jeedom et que je clique sur Installation du firmware R48 en ayant sélectionné le bon port, le plugin RFlink ne reconnait pas la carte et met Firmware non reconnu. Que dois je faire?

azzola
Timide
Messages : 39
Inscription : 29 sept. 2017, 18:07

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par azzola » 16 juil. 2018, 16:00

Bonjour,

Je ne comprends pas bien, si tu avais téléversé le firmware sous Windows tu ne devrais pas avoir besoin de le faire via Jeedom ?

MaximeDu74
Timide
Messages : 219
Inscription : 29 nov. 2017, 13:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par MaximeDu74 » 16 juil. 2018, 22:27

J’ai donc juste à le brancher et normalement RFLINK devrait afficher autre chose que firmware non reconnu. Je n’ai pas à flasher le firmware?

azzola
Timide
Messages : 39
Inscription : 29 sept. 2017, 18:07

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par azzola » 16 juil. 2018, 22:49

Je te conseille de flasher le firmware sous Windows avec le logiciel mis à disposition : RFLinkLoader.
Il te suffit de choisir le firmware, de définir le port com, la carte arduino doit être reconnue puis tu cliques sur programmer le firmware.

MaximeDu74
Timide
Messages : 219
Inscription : 29 nov. 2017, 13:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par MaximeDu74 » 17 juil. 2018, 11:44

Maintenant sur RFLINK je fais quoi?Image


Envoyé de mon iPad en utilisant Tapatalk

vincecoco
Actif
Messages : 1181
Inscription : 12 oct. 2015, 09:31

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par vincecoco » 17 juil. 2018, 11:52

Tu es sur du port?

MaximeDu74
Timide
Messages : 219
Inscription : 29 nov. 2017, 13:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par MaximeDu74 » 17 juil. 2018, 11:54

Je vais essayer avec l’autre. Si je clique sur sauvegarder et que je recharge la page ça devrait ne pas mettre « firmware non reconnu »?

MaximeDu74
Timide
Messages : 219
Inscription : 29 nov. 2017, 13:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par MaximeDu74 » 17 juil. 2018, 12:08

J’essaie d’installer les dépendances mais ça s’arrête à 20% pour afficher NOK. Voilà ce qu’il y a dans le log des dépendances de RFLINKImage
Image


Envoyé de mon iPad en utilisant Tapatalk

MaximeDu74
Timide
Messages : 219
Inscription : 29 nov. 2017, 13:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par MaximeDu74 » 17 juil. 2018, 19:10

Quelqu’un sait il comment régler ce problème de dépendance?

azzola
Timide
Messages : 39
Inscription : 29 sept. 2017, 18:07

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par azzola » 17 juil. 2018, 21:06

Bonjour,

Pour ma part je n'ai jamais eu de problème lors de l'installation des différents plugins.
En recherchant sur le forum, j'ai trouvé le problème similaire :
viewtopic.php?f=185&t=38463&p=633416&hi ... es#p633416
Apparant il ne trouve pas npm qui est un gestionnaire de paquet utilisé dans Node.js (source Wikipédia).

MaximeDu74
Timide
Messages : 219
Inscription : 29 nov. 2017, 13:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par MaximeDu74 » 17 juil. 2018, 21:08

Oui j’ai installer npm mais quand je veux installer nodejs-legacy ça me met impossible car les paquets défectueux sont en mode garder en l’état.

azzola
Timide
Messages : 39
Inscription : 29 sept. 2017, 18:07

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par azzola » 17 juil. 2018, 22:04

Il te faut peut être l'installer à partir des sources comme dans l'exemple précédent.
Tu télécharges les sources :
wget https://nodejs.org/dist/v6.2.1/node-v6. ... v6l.tar.gz

Tu décompresses l'archive :
tar -xzf node-v6.2.1-linux-armv6l.tar.gz

Et tu l'installes
node-v6.2.1-linux-armv6l/bin/node -v

frenchclem
Timide
Messages : 136
Inscription : 19 août 2015, 17:18
Localisation : sarthe

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par frenchclem » 31 juil. 2018, 13:19

Salut à tous, j'ai un pb sur le plugin rflink qui n'arrive plus à installer les dépendances.
J'ai fait un ticket mais je ne demande qui le reçoit, et comment le suivi marche ?

dans le doute, si quelqu'un souhaite jeter un oeil, j'ai poster à la base ici sans succès :
viewtopic.php?f=23&t=38584&p=635473&hil ... rn#p635473

comme je pars en vacances bientot, et que pas mal de capteur de mvt/ouverture fonctionne sous 433mhz je suis bien embeté o
Nuc Intel - ESXI - VM Jeedom - IPX800 - Xiaomi - Zwave - RFLink

frenchclem
Timide
Messages : 136
Inscription : 19 août 2015, 17:18
Localisation : sarthe

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par frenchclem » 01 août 2018, 09:22

Je me répond à moi même, je progresse :
Après un npm cache clear --force
l'installation des dépendances semble avoir fonctionné :

Code : Tout sélectionner



Début de l'installation
--2018-08-01 09:18:13--  https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.120.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.120.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1458 (1.4K) [text/plain]
Saving to: 'dependencies.sh'
0K .                                                     100% 53.4M=0s
2018-08-01 09:18:13 (53.4 MB/s) - 'dependencies.sh' saved [1458/1458]
Version actuelle : 8
Ign:1 http://ftp.fr.debian.org/debian stretch InRelease
Hit:2 http://security.debian.org/debian-security stretch/updates InRelease
Hit:3 http://ftp.fr.debian.org/debian stretch-updates InRelease
Hit:4 https://deb.nodesource.com/node_8.x stretch InRelease
Hit:5 http://ftp.fr.debian.org/debian stretch Release
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Ok, version suffisante
> serialport@6.2.2 install /var/www/html/plugins/rflink/resources/node_modules/serialport
> prebuild-install || node-gyp rebuild
added 235 packages in 11.923s
Fin de l'installation
le démon est reparti !! youpiiii
Nuc Intel - ESXI - VM Jeedom - IPX800 - Xiaomi - Zwave - RFLink

petoulachi
Timide
Messages : 128
Inscription : 24 mars 2015, 10:29

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par petoulachi » 02 août 2018, 11:37

Bonjour à tous,

petite question, j'ai un collegue avec une Jeedom mini, et son plug in RFLink ne se lance plus depuis qu'il vient de tout mettre à joru (Jeedom + RFLink, il était en version jeedom 3.2.1 !)
L'install des dépendances ne fonctionnent pas, avec ces logs :

Code : Tout sélectionner

Début de l'installation
converted 'https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh' (ANSI_X3.4-1968) -> 'https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh' (UTF-8)
--2018-08-02 09:16:09--  https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.0.133, 151.101.64.133, 151.101.128.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.0.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1458 (1.4K) [text/plain]
Saving to: 'dependencies.sh'
0K .                                                     100% 8.48M=0s
2018-08-02 09:16:10 (8.48 MB/s) - 'dependencies.sh' saved [1458/1458]
Version actuelle : 5
Ign http://repo.jeedom.com ./ InRelease
Hit http://security.debian.org jessie/updates InRelease
Ign http://repo.jeedom.com ./ Release.gpg
Ign http://repo.jeedom.com ./ Release
Ign http://repo.jeedom.com ./ Sources/DiffIndex
Ign http://repo.jeedom.com ./ Packages/DiffIndex
Ign http://httpredir.debian.org jessie InRelease
Hit http://httpredir.debian.org jessie-updates InRelease
Hit http://security.debian.org jessie/updates/main Sources
Hit http://security.debian.org jessie/updates/main armhf Packages
Ign http://repo.jeedom.com ./ Translation-en
Hit https://deb.nodesource.com jessie InRelease
Hit http://httpredir.debian.org jessie Release.gpg
Err http://repo.jeedom.com ./ Sources
404  Not Found
Hit http://security.debian.org jessie/updates/main Translation-en
Err http://repo.jeedom.com ./ Packages
404  Not Found
Hit http://httpredir.debian.org jessie Release
Get:1 https://deb.nodesource.com jessie/main Sources [764 B]
Get:2 http://httpredir.debian.org jessie-updates/main Sources [17.2 kB]
Get:3 http://httpredir.debian.org jessie-updates/main armhf Packages/DiffIndex [11.8 kB]
Get:4 https://deb.nodesource.com jessie/main armhf Packages [968 B]
Get:5 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:6 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]
Get:7 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:8 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:9 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:10 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Get:11 http://httpredir.debian.org jessie/main Sources [7063 kB]
Get:12 http://httpredir.debian.org jessie/main armhf Packages [6675 kB]
Get:13 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
Fetched 17.3 kB in 1min 30s (189 B/s)
W: Failed to fetch http://repo.jeedom.com/depot/repo.jm0.eu/BSP:/IMX6/Debian_Jessie/./Sources  404  Not Found
W: Failed to fetch http://repo.jeedom.com/depot/repo.jm0.eu/BSP:/IMX6/Debian_Jessie/./Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 261 not upgraded.
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Reading package lists...
Building dependency tree...
Reading state information...
Package 'npm' is not installed, so not removed
The following packages will be REMOVED:
nodejs* rlwrap*
0 upgraded, 0 newly installed, 2 to remove and 261 not upgraded.
After this operation, 38.8 MB disk space will be freed.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 52103 files and directories currently installed.)
Removing nodejs (5.12.0-1nodesource1~jessie1) ...
Purging configuration files for nodejs (5.12.0-1nodesource1~jessie1) ...
Removing rlwrap (0.41-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
dependencies.sh: 32: [: armv7l: unexpected operator
Utilisation du dépot officiel
## Installing the NodeSource Node.js 8.x LTS Carbon repo...
## Populating apt-get cache...
+ apt-get update
Ign http://repo.jeedom.com ./ InRelease
Hit http://security.debian.org jessie/updates InRelease
Ign http://repo.jeedom.com ./ Release.gpg
Ign http://repo.jeedom.com ./ Release
Ign http://repo.jeedom.com ./ Sources/DiffIndex
Ign http://repo.jeedom.com ./ Packages/DiffIndex
Ign http://httpredir.debian.org jessie InRelease
Hit http://httpredir.debian.org jessie-updates InRelease
Hit http://httpredir.debian.org jessie Release.gpg
Hit http://httpredir.debian.org jessie Release
Ign http://repo.jeedom.com ./ Translation-en
Err http://repo.jeedom.com ./ Sources
404  Not Found
Err http://repo.jeedom.com ./ Packages
404  Not Found
Hit http://security.debian.org jessie/updates/main Sources
Hit http://security.debian.org jessie/updates/main armhf Packages
Hit https://deb.nodesource.com jessie InRelease
Hit http://security.debian.org jessie/updates/main Translation-en
Get:1 http://httpredir.debian.org jessie-updates/main Sources [17.2 kB]
Get:2 http://httpredir.debian.org jessie-updates/main armhf Packages/DiffIndex [11.8 kB]
Get:3 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]
Get:4 https://deb.nodesource.com jessie/main Sources [764 B]
Get:5 https://deb.nodesource.com jessie/main armhf Packages [968 B]
Get:6 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:7 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:8 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:9 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:10 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Get:11 http://httpredir.debian.org jessie/main Sources [7063 kB]
Get:12 http://httpredir.debian.org jessie/main armhf Packages [6675 kB]
Get:13 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
Fetched 17.3 kB in 1min 37s (176 B/s)
W: Failed to fetch http://repo.jeedom.com/depot/repo.jm0.eu/BSP:/IMX6/Debian_Jessie/./Sources  404  Not Found
W: Failed to fetch http://repo.jeedom.com/depot/repo.jm0.eu/BSP:/IMX6/Debian_Jessie/./Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
Error executing command, exiting
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
rlwrap
The following NEW packages will be installed:
nodejs rlwrap
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 2 newly installed, 0 to remove and 261 not upgraded.
Need to get 0 B/8130 kB of archives.
After this operation, 38.8 MB of additional disk space will be used.
Selecting previously unselected package rlwrap.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 48657 files and directories currently installed.)
Preparing to unpack .../rlwrap_0.41-1_armhf.deb ...
Unpacking rlwrap (0.41-1) ...
Selecting previously unselected package nodejs.
Preparing to unpack .../nodejs_5.12.0-1nodesource1~jessie1_armhf.deb ...
Unpacking nodejs (5.12.0-1nodesource1~jessie1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up rlwrap (0.41-1) ...
update-alternatives: using /usr/bin/rlwrap to provide /usr/bin/readline-editor (readline-editor) in auto mode
Setting up nodejs (5.12.0-1nodesource1~jessie1) ...
Version actuelle : v5.12.0
> serialport@6.2.2 install /usr/share/nginx/www/jeedom/plugins/rflink/resources/node_modules/serialport
> prebuild-install || node-gyp rebuild
JeedomRflink@0.0.1 /usr/share/nginx/www/jeedom/plugins/rflink/resources
+-- request@2.87.0
| +-- aws-sign2@0.7.0
| +-- aws4@1.7.0
| +-- caseless@0.12.0
| +-- combined-stream@1.0.6
| | `-- delayed-stream@1.0.0
| +-- extend@3.0.2
| +-- forever-agent@0.6.1
| +-- form-data@2.3.2
| | `-- asynckit@0.4.0
| +-- har-validator@5.0.3
| | +-- ajv@5.5.2
| | | +-- co@4.6.0
| | | +-- fast-deep-equal@1.1.0
| | | +-- fast-json-stable-stringify@2.0.0
| | | `-- json-schema-traverse@0.3.1
| | `-- har-schema@2.0.0
| +-- http-signature@1.2.0
| | +-- assert-plus@1.0.0
| | +-- jsprim@1.4.1
| | | +-- extsprintf@1.3.0
| | | +-- json-schema@0.2.3
| | | `-- verror@1.10.0
| | |   `-- core-util-is@1.0.2
| | `-- sshpk@1.14.2
| |   +-- asn1@0.2.3
| |   +-- bcrypt-pbkdf@1.0.2
| |   +-- dashdash@1.14.1
| |   +-- ecc-jsbn@0.1.2
| |   +-- getpass@0.1.7
| |   +-- jsbn@0.1.1
| |   +-- safer-buffer@2.1.2
| |   `-- tweetnacl@0.14.5
| +-- is-typedarray@1.0.0
| +-- isstream@0.1.2
| +-- json-stringify-safe@5.0.1
| +-- mime-types@2.1.19
| | `-- mime-db@1.35.0
| +-- oauth-sign@0.8.2
| +-- performance-now@2.1.0
| +-- qs@6.5.2
| +-- safe-buffer@5.1.2
| +-- tough-cookie@2.3.4
| | `-- punycode@1.4.1
| +-- tunnel-agent@0.6.0
| `-- uuid@3.3.2
`-- telnet-client@0.15.8
`-- bluebird@3.5.1
npm ERR! Linux 3.14.53-fslc-imx6-sr
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! node v5.12.0
npm ERR! npm  v3.8.6
npm ERR! file sh
npm ERR! path sh
npm ERR! code ELIFECYCLE
npm ERR! errno ENOENT
npm ERR! syscall spawn sh
npm ERR! serialport@6.2.2 install: `prebuild-install || node-gyp rebuild`
npm ERR! spawn sh ENOENT
npm ERR!
npm ERR! Failed at the serialport@6.2.2 install script 'prebuild-install || node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the serialport package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     prebuild-install || node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs serialport
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls serialport
npm ERR! There is likely additional logging output above.
JeedomRflink@0.0.1 /usr/share/nginx/www/jeedom/plugins/rflink/resources
+-- request@2.87.0
| +-- aws-sign2@0.7.0
| +-- aws4@1.7.0
| +-- caseless@0.12.0
| +-- combined-stream@1.0.6
| | `-- delayed-stream@1.0.0
| +-- extend@3.0.2
| +-- forever-agent@0.6.1
| +-- form-data@2.3.2
| | `-- asynckit@0.4.0
| +-- har-validator@5.0.3
| | +-- ajv@5.5.2
| | | +-- co@4.6.0
| | | +-- fast-deep-equal@1.1.0
| | | +-- fast-json-stable-stringify@2.0.0
| | | `-- json-schema-traverse@0.3.1
| | `-- har-schema@2.0.0
| +-- http-signature@1.2.0
| | +-- assert-plus@1.0.0
| | +-- jsprim@1.4.1
| | | +-- extsprintf@1.3.0
| | | +-- json-schema@0.2.3
| | | `-- verror@1.10.0
| | |   `-- core-util-is@1.0.2
| | `-- sshpk@1.14.2
| |   +-- asn1@0.2.3
| |   +-- bcrypt-pbkdf@1.0.2
| |   +-- dashdash@1.14.1
| |   +-- ecc-jsbn@0.1.2
| |   +-- getpass@0.1.7
| |   +-- jsbn@0.1.1
| |   +-- safer-buffer@2.1.2
| |   `-- tweetnacl@0.14.5
| +-- is-typedarray@1.0.0
| +-- isstream@0.1.2
| +-- json-stringify-safe@5.0.1
| +-- mime-types@2.1.19
| | `-- mime-db@1.35.0
| +-- oauth-sign@0.8.2
| +-- performance-now@2.1.0
| +-- qs@6.5.2
| +-- safe-buffer@5.1.2
| +-- tough-cookie@2.3.4
| | `-- punycode@1.4.1
| +-- tunnel-agent@0.6.0
| `-- uuid@3.3.2
`-- telnet-client@0.15.8
`-- bluebird@3.5.1
npm ERR! Linux 3.14.53-fslc-imx6-sr
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! node v5.12.0
npm ERR! npm  v3.8.6
npm ERR! code ELIFECYCLE
npm ERR! serialport@6.2.2 install: `prebuild-install || node-gyp rebuild`
npm ERR! Exit status -2
npm ERR!
npm ERR! Failed at the serialport@6.2.2 install script 'prebuild-install || node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the serialport package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     prebuild-install || node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs serialport
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls serialport
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR!     /usr/share/nginx/www/jeedom/plugins/rflink/resources/npm-debug.log
Fin de l'installation
Bon ya un "KO, version obsolète à upgrader" qui m'intrigue, avant de voir que serialport ne s'installe pas.
je lui a demandé, il n'a jamais fait la moindre upgrade de son linux (apt-get dist upgrade ).

Je peux lancer la commande? De mon coté j'ai du raspberry donc je me pose pas trop la question, mais là comme c'est une box officielle jeedom je me demande comment tout ça est géré ?

Merci pour votre aide !

Samuel14
Timide
Messages : 454
Inscription : 27 août 2014, 17:39
Localisation : Caen

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par Samuel14 » 03 août 2018, 19:12

Bonjour,
Quelqu'un pourrait-il m'indiquer où trouver une doc ou un tuto pour commander mon portail Somfy RTS (motorisation freevia 600) avec le rflink ?
J'ai trouvé pas mal de chose pour associer un volet mais pas une motorisation de portail.
Les tests que j'ai effectué sont pour le moment infructueux :-(
En apprentissage mon rflink détecte bien les télécommandes RTS et je pilote avec succès du Chacon/DIO.
Z83II + zstick Aeotec sw090 (51 nœuds Z-Wave), Clé 3G Huawei E172, rfplayer (portail, Pergola Somfy), Station météo Netatmo, Xiaomi (Gateway 31 nœuds, Aspi v1, lampe de chevet v1 et v2, rideau), nut, Google Home, Alexa, Squeezebox, Tondeuse Worx

lyonel
Timide
Messages : 270
Inscription : 24 oct. 2015, 21:28

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par lyonel » 13 août 2018, 13:57

Bonjour,
J'ai un souci également suite à grosse mise à jour, mon Rflink ne communique plus avec les equipements 433.

J'ai mis a jour Jeedom, passage d'nginx à apache, Jessie à Stretch, puis update de 3.0.11 à 3.2.3 puis 3.2.11

Le plugin Rflink se lance bien, le démon est Ok mais les dépendances restent en date de dernier lancement à Décembre 2017 bien qu'ayant relancer l'install ce midi. Voici le log, si vous pouviez m'aider à identifier l'anomalie, merci:

Code : Tout sélectionner

Début de l'installation
--2018-08-13 13:28:25--  https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.120.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.120.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1458 (1.4K) [text/plain]
Saving to: 'dependencies.sh'
0K .                                                     100% 10.5M=0s
2018-08-13 13:28:26 (10.5 MB/s) - 'dependencies.sh' saved [1458/1458]
Version actuelle : 8
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:3 https://deb.nodesource.com/node_8.x stretch InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125+rpi1).
0 upgraded, 0 newly installed, 0 to remove and 52 not upgraded.
Ok, version suffisante
> serialport@6.2.2 install /var/www/html/plugins/rflink/resources/node_modules/serialport
> prebuild-install || node-gyp rebuild
prebuild-install WARN install No prebuilt binaries found (target=8.11.3 runtime=node arch=arm platform=linux)
make: Entering directory '/var/www/html/plugins/rflink/resources/node_modules/serialport/build'
CXX(target) Release/obj.target/serialport/src/serialport.o
../src/serialport.cpp: In function 'void EIO_AfterOpen(uv_work_t*)':
../src/serialport.cpp:95:30: warning: 'v8::Local<v8::Value> Nan::Callback::Call(int, v8::Local<v8::Value>*) const' is deprecated [-Wdeprecated-declarations]
data->callback.Call(2, argv);
^
In file included from ../src/./serialport.h:6:0,
from ../src/serialport.cpp:1:
../../nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Local<v8::Value> argv[]) const {
^~~~
../src/serialport.cpp: In function 'void EIO_AfterUpdate(uv_work_t*)':
../src/serialport.cpp:150:30: warning: 'v8::Local<v8::Value> Nan::Callback::Call(int, v8::Local<v8::Value>*) const' is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from ../src/./serialport.h:6:0,
from ../src/serialport.cpp:1:
../../nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Local<v8::Value> argv[]) const {
^~~~
../src/serialport.cpp: In function 'void EIO_AfterClose(uv_work_t*)':
../src/serialport.cpp:188:30: warning: 'v8::Local<v8::Value> Nan::Callback::Call(int, v8::Local<v8::Value>*) const' is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from ../src/./serialport.h:6:0,
from ../src/serialport.cpp:1:
../../nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Local<v8::Value> argv[]) const {
^~~~
../src/serialport.cpp: In function 'void EIO_AfterFlush(uv_work_t*)':
../src/serialport.cpp:231:30: warning: 'v8::Local<v8::Value> Nan::Callback::Call(int, v8::Local<v8::Value>*) const' is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from ../src/./serialport.h:6:0,
from ../src/serialport.cpp:1:
../../nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Local<v8::Value> argv[]) const {
^~~~
../src/serialport.cpp: In function 'void EIO_AfterSet(uv_work_t*)':
../src/serialport.cpp:285:30: warning: 'v8::Local<v8::Value> Nan::Callback::Call(int, v8::Local<v8::Value>*) const' is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from ../src/./serialport.h:6:0,
from ../src/serialport.cpp:1:
../../nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Local<v8::Value> argv[]) const {
^~~~
../src/serialport.cpp: In function 'void EIO_AfterGet(uv_work_t*)':
../src/serialport.cpp:336:30: warning: 'v8::Local<v8::Value> Nan::Callback::Call(int, v8::Local<v8::Value>*) const' is deprecated [-Wdeprecated-declarations]
data->callback.Call(2, argv);
^
In file included from ../src/./serialport.h:6:0,
from ../src/serialport.cpp:1:
../../nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Local<v8::Value> argv[]) const {
^~~~
../src/serialport.cpp: In function 'void EIO_AfterGetBaudRate(uv_work_t*)':
../src/serialport.cpp:383:30: warning: 'v8::Local<v8::Value> Nan::Callback::Call(int, v8::Local<v8::Value>*) const' is deprecated [-Wdeprecated-declarations]
data->callback.Call(2, argv);
^
In file included from ../src/./serialport.h:6:0,
from ../src/serialport.cpp:1:
../../nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Local<v8::Value> argv[]) const {
^~~~
../src/serialport.cpp: In function 'void EIO_AfterDrain(uv_work_t*)':
../src/serialport.cpp:424:30: warning: 'v8::Local<v8::Value> Nan::Callback::Call(int, v8::Local<v8::Value>*) const' is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from ../src/./serialport.h:6:0,
from ../src/serialport.cpp:1:
../../nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Local<v8::Value> argv[]) const {
^~~~
CXX(target) Release/obj.target/serialport/src/serialport_unix.o
CXX(target) Release/obj.target/serialport/src/poller.o
../src/poller.cpp: In static member function 'static void Poller::onData(uv_poll_t*, int, int)':
../src/poller.cpp:69:29: warning: 'v8::Local<v8::Value> Nan::Callback::Call(int, v8::Local<v8::Value>*) const' is deprecated [-Wdeprecated-declarations]
obj->callback.Call(2, argv);
^
In file included from ../src/poller.cpp:1:0:
../../nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Local<v8::Value> argv[]) const {
^~~~
CXX(target) Release/obj.target/serialport/src/serialport_linux.o
SOLINK_MODULE(target) Release/obj.target/serialport.node
COPY Release/serialport.node
make: Leaving directory '/var/www/html/plugins/rflink/resources/node_modules/serialport/build'
added 239 packages in 57.893s
Fin de l'installation
[Edit 16H] déinstall du plugin puis réinstall, la date des dépendances est cohérente maintenant meme apres reboot j'ai "firmware non reconnu"
et des NPM warn

En effet aucune gateway n'apparait bien que j'ai le port usb de bien configuré


[Edit 17H] retour a mon ancienne install Jessie 3.0.11 en attendant de comprendre car je patauge mes recherches ne donnent rien

Merci
Centrale Myfox Evology Zen + Pi2, Jeedom Arduino rflink
9 modules Chacon volets roulant
1 Module Chacon 1000w pour ON/OFF VMC
3 prises Chacon 3500W
10 interrupteurs Chacon sans fils

team18fr
Actif
Messages : 1119
Inscription : 11 oct. 2014, 18:41

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par team18fr » 16 août 2018, 09:47

Bonjour depuis quelque temps mes logs rflink_node se remplissent avec ça et je ne sais pas d’où ça vient.
Mon niveau de log est mit sur "erreur".

Code : Tout sélectionner

Thu Aug 16 2018 09:37:59 GMT+0200 (CEST) - Send Value : 20;FC;DEBUG;Pulses=56;Pulses(uSec)=480,3900,390,1830,390,3900,390,3900,390,1860,390,3900,390,1860,390,1860,390,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,3930,360,1860,360,3930,360,3930,360,3930,360,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,6990;
Thu Aug 16 2018 09:38:29 GMT+0200 (CEST) - Send Value : 20;FD;DEBUG;Pulses=72;Pulses(uSec)=540,1770,450,3870,420,3870,420,1800,420,3870,420,1800,420,1800,420,1830,420,1830,420,1830,390,1830,390,1830,420,1830,390,1830,420,3900,390,1830,390,3900,420,3900,420,3900,390,1830,420,1830,390,1830,420,1830,390,1830,390,1830,390,1830,390,3900,390,3900,420,3900,390,1830,390,1830,420,3900,390,3900,420,3900,420,4020,390,6990;
Thu Aug 16 2018 09:38:30 GMT+0200 (CEST) - Send Value : 20;FE;DEBUG;Pulses=38;Pulses(uSec)=420,3690,360,3870,390,1830,390,1830,390,1830,390,1860,390,1830,390,1860,390,1860,390,3900,390,3900,390,3900,390,1860,360,1860,390,3930,390,3930,390,3900,390,4020,390,6990;
Thu Aug 16 2018 09:38:30 GMT+0200 (CEST) - Send Value : 20;FF;DEBUG;Pulses=60;Pulses(uSec)=450,1740,360,1770,330,1770,330,1800,360,1860,360,1860,360,1860,360,1860,360,3930,360,1860,360,3930,360,3930,360,3930,360,1860,360,1860,360,1860,360,1890,360,1860,360,1860,360,1860,360,3930,360,3930,360,3930,360,1860,360,1860,360,3930,360,3930,360,3930,360,4050,390,6990;
Thu Aug 16 2018 09:38:30 GMT+0200 (CEST) - Send Value : 20;00;DEBUG;Pulses=44;Pulses(uSec)=390,3750,330,1770,360,3900,360,3930,360,3930,360,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,3930,360,3930,360,3930,390,1860,360,1860,360,3930,390,3930,360,3930,390,4050,360,6990;
Thu Aug 16 2018 09:38:30 GMT+0200 (CEST) - Send Value : 20;01;DEBUG;Pulses=56;Pulses(uSec)=420,1770,330,1770,330,1770,360,1800,360,1890,360,1860,360,3930,360,1860,360,3930,360,3930,360,3930,360,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,3930,360,3930,360,3930,360,1860,360,1860,360,3930,390,3930,390,3930,360,4050,390,6990;
Thu Aug 16 2018 09:38:30 GMT+0200 (CEST) - Send Value : 20;02;DEBUG;Pulses=48;Pulses(uSec)=60,1770,330,1770,330,3720,360,1860,360,3930,360,3930,360,3930,360,1860,390,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,3930,360,3930,390,3930,390,1860,360,1860,360,3930,360,3930,360,3930,390,4050,390,6990;
Thu Aug 16 2018 09:38:30 GMT+0200 (CEST) - Send Value : 20;03;DEBUG;Pulses=54;Pulses(uSec)=240,1770,330,1770,330,1770,330,1800,360,1860,360,3930,360,1860,360,3930,360,3930,360,3930,390,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,1860,360,3930,390,3930,360,3930,390,1860,360,1860,360,3930,360,3930,360,3930,360,4050,390,6990;
Thu Aug 16 2018 09:38:47 GMT+0200 (CEST) - Send Value : 20;04;DEBUG;Pulses=164;Pulses(uSec)=30,450,330,900,330,540,750,390,330,1020,750,900,360,480,780,900,840,870,840,450,330,900,360,420,840,990,780,870,870,870,870,390,360,990,780,900,360,420,810,420,360,870,870,900,840,960,780,870,390,420,840,900,870,390,360,930,330,390,840,450,330,870,870,870,360,450,810,900,870,390,360,930,810,930,840,870,870,870,360,450,810,390,390,870,840,930,360,360,870,450,330,870,870,870,360,420,870,870,870,390,360,900,870,870,870,930,840,870,870,870,870,870,870,900,840,930,840,870,390,420,840,420,360,870,870,930,840,900,390,390,870,450,330,870,870,870,360,480,810,390,360,930,330,390,870,420,390,870,870,870,870,870,840,930,810,930,810,870,870,870,360,450,840,6990;
Thu Aug 16 2018 09:38:47 GMT+0200 (CEST) - Send Value : 20;05;DEBUG;Pulses=82;Pulses(uSec)=210,840,780,840,360,390,810,390,300,840,810,840,360,390,840,900,840,450,330,870,870,870,870,870,870,870,870,870,870,900,840,930,810,930,810,930,330,390,870,390,360,930,810,960,810,930,330,390,870,420,360,870,870,870,360,450,810,390,390,900,360,390,870,390,390,930,840,930,810,930,810,900,840,870,870,870,870,870,360,480,810,6990;


Répondre

Revenir vers « [Catégorie] Protocoles domotiques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité