Comme annoncé, ce forum est passé en lecture seule au 1er janvier 2020. Désormais nous vous invitons à vous rendre sur notre nouvelle page communauté :
Image

A très bientôt !

[Plugin Officiel] Zigbee (deconz)

Pour échanger sur les plugins classés en catégorie "Protocoles domotiques"
Avatar de l’utilisateur
akenad
Actif
Messages : 697
Inscription : 27 oct. 2017, 11:39

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par akenad » 26 juin 2019, 18:20

m.georgein a écrit :
26 juin 2019, 16:10
... quelques soucis à l'install de deconz.

Bonjour @m.georgein,

Pour connaitre les modules python3 installés :

Code : Tout sélectionner

$ pip3 list
Si websocket-client n'est pas dans la liste, tu peux tenter :

Code : Tout sélectionner

$ sudo pip3 install websocket-client
akenad :)
Dernière édition par akenad le 26 juin 2019, 19:40, édité 2 fois.
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Buster Kernel 5
RPi3B+ SSD Raspbian Stretch
RPi4B SSD Raspbian Buster
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster

Avatar de l’utilisateur
m.georgein
Timide
Messages : 299
Inscription : 18 mars 2016, 23:46
Localisation : 13820

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par m.georgein » 26 juin 2019, 19:01

OK, mais pour ouvrir un ticket il ne faut pas de plugin en beta. Hors DECONZ est un plugin payant MAIS EN BETA ! :(
Plateforme :
NUCNUC6i5SYK en VM STRETCH
Version Jeedom 4.0.9
Version PHP 7.0.33-0+deb9u1
Version OS Linux debian9 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux [9.6]
Version database 10.1.26-MariaDB-0+deb9u1

Avatar de l’utilisateur
m.georgein
Timide
Messages : 299
Inscription : 18 mars 2016, 23:46
Localisation : 13820

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par m.georgein » 26 juin 2019, 19:04

Merci akenad
je l'ai tenté, cela m'a fait passer à la version 19.1.1(18.1 avant) mais même après relance des dépendances, découverte et 'récupérer API', toujours pas de daemon ni de Port Socket ni de Clef API :(
Plateforme :
NUCNUC6i5SYK en VM STRETCH
Version Jeedom 4.0.9
Version PHP 7.0.33-0+deb9u1
Version OS Linux debian9 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux [9.6]
Version database 10.1.26-MariaDB-0+deb9u1

Avatar de l’utilisateur
akenad
Actif
Messages : 697
Inscription : 27 oct. 2017, 11:39

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par akenad » 26 juin 2019, 19:07

@m.georgein,

Le plugin Deconz est en stable depuis le 21-06-2019.

Je n'ai pas dis de faire 'pip install --upgrade pip'

Si tu fais ce que j'ai proposé, dans la log Deconz as-tu toujours ? :

Code : Tout sélectionner

from websocket import create_connection
ImportError: cannot import name 'create_connection'
Le module python ne doit pas être dans le dossier attendu par le plugin.

akenad :)
Dernière édition par akenad le 26 juin 2019, 19:50, édité 2 fois.
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Buster Kernel 5
RPi3B+ SSD Raspbian Stretch
RPi4B SSD Raspbian Buster
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster

Avatar de l’utilisateur
m.georgein
Timide
Messages : 299
Inscription : 18 mars 2016, 23:46
Localisation : 13820

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par m.georgein » 26 juin 2019, 19:13

je l'ai acheté cet AM, là je viens de faire un print du market :
Capture.PNG
Capture.PNG (15.52 Kio) Consulté 1112 fois
Je vais donc tenter une réinstall en stable
Plateforme :
NUCNUC6i5SYK en VM STRETCH
Version Jeedom 4.0.9
Version PHP 7.0.33-0+deb9u1
Version OS Linux debian9 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux [9.6]
Version database 10.1.26-MariaDB-0+deb9u1

Avatar de l’utilisateur
m.georgein
Timide
Messages : 299
Inscription : 18 mars 2016, 23:46
Localisation : 13820

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par m.georgein » 26 juin 2019, 19:47

Désinstallation, install de la stable, seule différence la découverte ne trouve plus le dongle ....
Plateforme :
NUCNUC6i5SYK en VM STRETCH
Version Jeedom 4.0.9
Version PHP 7.0.33-0+deb9u1
Version OS Linux debian9 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux [9.6]
Version database 10.1.26-MariaDB-0+deb9u1

Avatar de l’utilisateur
akenad
Actif
Messages : 697
Inscription : 27 oct. 2017, 11:39

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par akenad » 26 juin 2019, 19:53

@m.georgein,

Je t'invites à republier les 3 logs sur le forum.
Et maintenant que tu es en stable, tu pourrais ouvrir un ticket auprès du support comme suggéré par @loic.

akenad :)
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Buster Kernel 5
RPi3B+ SSD Raspbian Stretch
RPi4B SSD Raspbian Buster
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster

Avatar de l’utilisateur
m.georgein
Timide
Messages : 299
Inscription : 18 mars 2016, 23:46
Localisation : 13820

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par m.georgein » 26 juin 2019, 20:38

Oui, c'est ce que je compte faire demain ;) Merci de ton aide
Plateforme :
NUCNUC6i5SYK en VM STRETCH
Version Jeedom 4.0.9
Version PHP 7.0.33-0+deb9u1
Version OS Linux debian9 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux [9.6]
Version database 10.1.26-MariaDB-0+deb9u1

paulnux
Timide
Messages : 331
Inscription : 19 juil. 2015, 11:28
Localisation : 72

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par paulnux » 26 juin 2019, 23:06

Je voudrais bien acheter le plugin pour tester mais je possède beaucoup d'ampoule Xiaomi lumi.light.aqcn02 ZNLDP12LM et je ne l'ai voit pas dans la liste compatible.
Est ce que quelqu’un a essayé ?
Jeedom Mini+, Zigate
Temp Xiaomi
Ouverture Xiaomi
Ampoule Ikea, Xiaomi
Détecteur mouvement Xiaomi

Pi3B+, ZStick GEN5, SENA UD100, Gateway Xiaomi
PSM02
FGMS-001
ZM1602
Ampoule Yeelight
Echo Plus
Nut mini
Balance Xiaomi
MiFlora
WorxLandroidS

HugoVal11
Timide
Messages : 137
Inscription : 01 nov. 2018, 11:43

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par HugoVal11 » 28 juin 2019, 17:30

paulnux a écrit :
26 juin 2019, 23:06
Je voudrais bien acheter le plugin pour tester mais je possède beaucoup d'ampoule Xiaomi lumi.light.aqcn02 ZNLDP12LM et je ne l'ai voit pas dans la liste compatible.
Est ce que quelqu’un a essayé ?
https://github.com/dresden-elektronik/d ... ssues/1057

La liste de matériel, n'est pas a jour, faut chercher sur le github, ou demander direct.

Avatar de l’utilisateur
Theking31
Actif
Messages : 1182
Inscription : 21 sept. 2017, 11:13
Localisation : Toulouse - Le Vernet

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par Theking31 » 28 juin 2019, 17:44

mortyre a écrit :
09 mai 2019, 09:50

Actuellement, le plugin ne marche que sur rpi ou x86-64, vous ne pouvez donc pas l'installer sur une smart, un odroid C2, ou une jeedom pro. Il est à noté que sur smart/odroid C2 il ne sera pas possible de faire du Docker à cause du kernel qui est utilisé et modifié, et donc n'est pas compatible Docker.
La doc a écrit :Le plugin support plusieurs gateway deconz (1 clef conbee par gateway). Une gateway conbee peut etre installer sur :

jeedom lui meme (smart, rpi et x64_86 supporté)
un rpi deporté
ou tout autre carte compatible avec deconz.
Platforms.png
Platforms.png (9.71 Kio) Consulté 986 fois





Bonjour,

Désolé si ma question est bien bête pour certains ;)
Mais pouvez vous m'enlever un doute :

Non compatible avec mon Intel NUC 6CAYH avec debian-live-9.6.0-amd64 ?

Et si tel est le cas, le sera t'il un jour (pour Loic) ?

Merci
Jeedom 4.0.23 sur Intel NUC 6CAYH | Linux 4.9.0-11-amd64 | Debian 9.11
Rfxcom | Z-Wave Plus Z-Stick GEN5 | Conbee 2 | => sur hub alimenté
Blea| Brodlink | Xiaomi |ESPeasy | Wifilightv2

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par loic » 28 juin 2019, 19:10

C'est compatible pas de soucis je m'en sers c'est sous ubuntu.

Pour information deconz que tu vois n'est pas de nous donc si ca l'avait pas été j'aurais rien pu y faire ni meme savoir si ca sera fait un jour
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

typhoe
Timide
Messages : 79
Inscription : 21 juil. 2015, 16:53

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par typhoe » 28 juin 2019, 21:46

Bonsoir,

Loic, j'ignore si quelqu'un a déjà ouvert un ticket donc je viens de le faire au cas où.

Je rencontre le problème du websocket moi aussi, installation fraîche de ce soir, la clé conBee II vient d'arriver ;-)
Les logs d'installation des dépendances et de deconz en local semblent ok.
A noter que j'ai eu le pb du pip3 introuvable aussi (pour un autre plugin, je crois lors de la mise à jour d'open-zwave??) et que j'avais résolu ça en désinstallant et reinstallant le paquet python3-pip.

Merci.

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par loic » 28 juin 2019, 22:24

Ok je regarde ça lundi je pense j'ai peur que ce weekend il fasse trop chaud pour que j'arrive à me mettre devant un pc....
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

typhoe
Timide
Messages : 79
Inscription : 21 juil. 2015, 16:53

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par typhoe » 28 juin 2019, 22:27

Aucun soucis, et cela me parait même plus que normal ;-)
Bon we!

Avatar de l’utilisateur
Deepcore
Timide
Messages : 190
Inscription : 11 déc. 2017, 20:40
Localisation : Région Parisienne

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par Deepcore » 29 juin 2019, 08:53

Bonjour,

Juste pour dire que j'ai également le même problème de socket.

J'ai installé le plugin sur mon raspi 2 de test (qui est à jour) avec une Conbee II (bien détectée). Ras pour les modules python

Je ne peux pas ouvrir de ticket car j'ai un plug-in en beta. Mais si vous avez besoin de tester je suis dispo.

Tssuu
Pièces jointes
deconz_update.txt
(13.22 Kio) Téléchargé 13 fois
deconz_install.txt
(10.64 Kio) Téléchargé 16 fois
deconz.txt
(30.02 Kio) Téléchargé 14 fois
Dernière édition par Deepcore le 30 juin 2019, 17:06, édité 1 fois.
Jeedom Prod VM Debian 9 sous ESXi 6.7
Jeedom Dev Pi 2 Debian 9
Antenne : VM Debian 8 - HA-Bridge, Nut Serveur sous ESXi 6.0
Protocole : ZWave, ZigBee (Hue,Ikea,Xiaomi et Zigate), IP devices, Bluetooth
160 modules gérés

Avatar de l’utilisateur
loic
Administrateur
Messages : 14862
Inscription : 01 févr. 2014, 16:21

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par loic » 30 juin 2019, 10:12

Bonjour,
J'ai trouvé le soucis et je viens de pousser la correction, il faut forcer la reinstallation des dépendances et ensuite lancer le démon.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
supermenteur
Timide
Messages : 250
Inscription : 18 mai 2015, 15:39

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par supermenteur » 30 juin 2019, 12:43

Toujours pareil après avoir suivi ta procédure.

Code : Tout sélectionner

 [2019-06-30 12:41:09][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
Traceback (most recent call last):
File "/var/www/html/plugins/deconz/resources/deconzd/deconzd.py", line 32, in <module>
from websocket import create_connection
File "/usr/local/lib/python3.4/dist-packages/websocket/__init__.py", line 23, in <module>
from ._app import WebSocketApp
File "/usr/local/lib/python3.4/dist-packages/websocket/_app.py", line 36, in <module>
from ._core import WebSocket, getdefaulttimeout
File "/usr/local/lib/python3.4/dist-packages/websocket/_core.py", line 34, in <module>
from ._handshake import *
File "/usr/local/lib/python3.4/dist-packages/websocket/_handshake.py", line 40, in <module>
if six.PY34:
AttributeError: 'module' object has no attribute 'PY34'
[2019-06-30 12:41:42][ERROR] : Impossible de lancer le démon deconz, vérifiez le port


Envoyé de mon iPad en utilisant Tapatalk
Patrice

typhoe
Timide
Messages : 79
Inscription : 21 juil. 2015, 16:53

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par typhoe » 30 juin 2019, 13:05

loic a écrit :
30 juin 2019, 10:12
J'ai trouvé le soucis et je viens de pousser la correction, il faut forcer la reinstallation des dépendances et ensuite lancer le démon.
Merci Loic!
Et merci doublement pour avoir bossé là-dessus un dimanche matin!

Je confirme que ma clé conBee II est désormais reconnue et le demon deconz démarre bien.
La "découverte" et la "récupération clé api" ont fonctionné nickel aussi!

Me reste à tester quelques inclusions et attendre votre tuto de migration (j'ai du Xiaomi et du Hue chacun sur leurs plugins respectifs) pour garder mes ids pour tous mes scenarios.

Bon dimanche

flocon81
Timide
Messages : 20
Inscription : 09 mai 2018, 21:41

Re: [Plugin Officiel] Zigbee (deconz) beta

Message par flocon81 » 30 juin 2019, 13:22

loic a écrit :Bonjour,
J'ai trouvé le soucis et je viens de pousser la correction, il faut forcer la reinstallation des dépendances et ensuite lancer le démon.
Nickel ça marche. Merci.

Envoyé de mon LLD-L31 en utilisant Tapatalk


Répondre

Revenir vers « [Catégorie] Protocoles domotiques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 5 invités