Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin blea

guims78
Actif
Messages : 509
Inscription : 30 sept. 2017, 13:00

Re: Plugin blea

Message par guims78 » 19 août 2019, 11:24

Hello, j'ai de soucis de perte de liaison avec des Tag Bluetooth (gestion de présence).
Un G-Tag et un autre Noname.
Bien reconnus au début, mais depuis quelque temps, ils se déconnectent, puis reviennent au bout d'un certain temps (aléatoire, mais plusieurs heures).
Je suis en train de tester un Nut mini pour voir si cela vient des objets ou du plugin ou des antennes.
J'ai 2 antennes BLEA déportées sur 2 RPi3 qui ne servent qu'à ça.
J'ai cherché dans les Log mais je n'identifie rien.
Quels Logs seraient à partager ici ?

Jef73
Timide
Messages : 366
Inscription : 27 déc. 2017, 10:41
Localisation : Nantes

Re: Plugin blea

Message par Jef73 » 19 août 2019, 13:58

C'est un problème fréquent avec les beacons BLE, quelle que soit le modèle. Pour certains ça fonctionne parfaitement en permanence, pour d'autre un jour ça commence à déconner sans trop connaître la raison (un voisin perturbateur, un équipement avec des caractères bizarres dans le nom de l'objet, une Google Home qui sature les requêtes en balançant des trames à tout va, etc.).
Pour ma part, j'ai fait comme plusieurs autres, j'ai basculé ma gestion de présence sur le script "bluetooth-scanner" (lien dans ma signature) et ça fonctionne à la perfection depuis de nombreux mois :)

guims78
Actif
Messages : 509
Inscription : 30 sept. 2017, 13:00

Re: Plugin blea

Message par guims78 » 22 août 2019, 09:58

Hello,
je fais le teste en parallèle avec le script et seuls les Tag "Noname" ne sont pas détectés.
Effectivement, le script permet l'ajout du scan des téléphones et c'est un vrai plus à mon avis.

Zekje
Timide
Messages : 147
Inscription : 19 déc. 2016, 20:27
Contact :

Re: Plugin blea

Message par Zekje » 22 août 2019, 15:04

parrain27240 a écrit :
12 août 2019, 10:45
julien35 a écrit :Merci pour vos réponses.
Mais je vois que vous avez tous du gros matos pour faire tourner jeedom.
Personne n'a de raspberry ou équivalent ?
j'ai un pi 3 et deux antennes pi zero pas de soucis
idem, Jeedom tourne sur un pi3 dans une rack din dans mon tableau electrique, sur ses ports USB, un dongle BT a 1€ ,une antenne Zwave , un convertisseur TIC pour EDF , et un arduino car j essaye de faire une antenne 433Mhz
il manque un peu de ram , j avais prévu de le changer par un odroid XU4 , mais sur ce dernier je galere a avoir un linux pleinement fonctionnel , et puis il vas tellement bien dans le salon avec recallbox :) , le pi3 sera remplacé par un pi4 quand j aurais le temps ... en attendant j ai desactivé des scenarios de confort un peu inutile.

ailleurs dans la maison, il y a 2 PI0W , qui servent simultanément d antenne BLEA et d antenne bluetooth-scanner ( avec aussi un dongle BT car sur le pi0W tu peut pas gerer simultanement Wifi ET BT intégré ) , et sur un des 2 pi0 il y octoprint car il gere mon imprimante
et une 3ieme antenne BLEA qui est mon ancien jeedom smart (qui sert aussi de pihole :p )

l ensemble marche plutot bien ( la maison est en longeur, plus de 20m ) donc pas le choix il a fallu multiplier les antennes .

comme bcp j ai galeré en juillet avec la maj BLEA ,ça m a permis de remettre a jour tout mes linux :)
Ikari a écrit :
18 août 2019, 21:10
Bonsoir à tous,
quelqu'un à t'il réussit à mettre une antenne blea sur un pi3 sur lequel est déjà installé octoprint ?
comme dit plus haut, j ai ça sur un pi0W , il m a fallu rajouter (avec un hub usb) un dongle BT, car le pi a semble t il du mal a gerer en meme temps le BT et le Wifi onboard .
par contre je suis partit sur une install propre d octoprint ( et de raspian) , car l OS fournit tout fait j ai pas reussi a le mettre a jour ( trop de dependances foirées ) .
-> Zekje

Swr
Actif
Messages : 707
Inscription : 08 nov. 2016, 20:56
Localisation : 44

Re: Plugin blea

Message par Swr » 22 août 2019, 21:43

Il y quelques mois j'ai fait une mise à jour de bluepy, depuis je n'ai plus aucun problème. Cette version n'est pas officiellement supportée, elle a solutionné tous mes problèmes de déconnection.
https://github.com/IanHarvey/bluepy

Envoyé de mon Redmi Note 4 en utilisant Tapatalk


tetiti20
Timide
Messages : 92
Inscription : 24 nov. 2014, 20:24

Re: Plugin blea

Message par tetiti20 » 23 août 2019, 21:30

Bonjour,

Depuis quelque mise à jour j'ai ce message qui apparait:
Bluepy not up to date : expected 1.1.4

Comment je fait pour le mettre à jour? j'ai fais un update de ma debian mais ça n'a rien changer...
Merci d'avance
Jeedom stable sur serveur NAS maison (debian stretch bientôt) HP ProLiant Gen8
Labs Z-Stick S2
[Volet roulant] 5xQubino ZMNHCA2 - 4x Fibaro FGRM-221
[Capteur] 1x Fibaro FGMS-001 (oeil)
[Prises]1x Fibaro Wall Plug - 1x Greenwave - 3x Sidewinder

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 23 août 2019, 22:44

Bonjour,
Utilises-tu toujours debian wheezy (7) ou as tu fait l'upgrade ?
Peux tu montrer la page santé de jeedom ?
Wheezy n'est plus supporte depuis le 31-05-2018, ça fait plus d'un an.
Si tu es sous vm comme le dis ta signature, installe une debian 9 (stretch) neuve, pas debian 10 (buster)!
Nouvelle install de jeedom et restaure un backup.
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

raphael_malin
Timide
Messages : 485
Inscription : 10 nov. 2014, 00:20
Localisation : Nouméa - Nouvelle-Calédonie

Re: Plugin blea

Message par raphael_malin » 24 août 2019, 06:29

Hello, j'ai des soucis avec les commandes des NUT, elles se suppriment, reviennent, etc... PK?
supp.png
supp.png (110.52 Kio) Consulté 592 fois
Jeedom smart avec en général toutes les mises à jour faites (système et plugin)

tetiti20
Timide
Messages : 92
Inscription : 24 nov. 2014, 20:24

Re: Plugin blea

Message par tetiti20 » 24 août 2019, 20:45

Mips2648 a écrit :
23 août 2019, 22:44
Bonjour,
Utilises-tu toujours debian wheezy (7) ou as tu fait l'upgrade ?
Peux tu montrer la page santé de jeedom ?
Wheezy n'est plus supporte depuis le 31-05-2018, ça fait plus d'un an.
Si tu es sous vm comme le dis ta signature, installe une debian 9 (stretch) neuve, pas debian 10 (buster)!
Nouvelle install de jeedom et restaure un backup.
Merci pour tes indications. Je suis sous debian 8 (jessie) la seule que tu ne cite pas...
Du coup il faudrait quand même passer en stretch?
Jeedom stable sur serveur NAS maison (debian stretch bientôt) HP ProLiant Gen8
Labs Z-Stick S2
[Volet roulant] 5xQubino ZMNHCA2 - 4x Fibaro FGRM-221
[Capteur] 1x Fibaro FGMS-001 (oeil)
[Prises]1x Fibaro Wall Plug - 1x Greenwave - 3x Sidewinder

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 24 août 2019, 21:53

Oui, passes sous stretch.

Ta signature indiquait wheezy, c'est pourquoi j'ai supposé cela.
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

tetiti20
Timide
Messages : 92
Inscription : 24 nov. 2014, 20:24

Re: Plugin blea

Message par tetiti20 » 24 août 2019, 22:35

Mips2648 a écrit :
24 août 2019, 21:53
Oui, passes sous stretch.

Ta signature indiquait wheezy, c'est pourquoi j'ai supposé cela.
Bien vu! merci à toi Mips2648 j'essais ça quand j'aurais un peu de temps
Jeedom stable sur serveur NAS maison (debian stretch bientôt) HP ProLiant Gen8
Labs Z-Stick S2
[Volet roulant] 5xQubino ZMNHCA2 - 4x Fibaro FGRM-221
[Capteur] 1x Fibaro FGMS-001 (oeil)
[Prises]1x Fibaro Wall Plug - 1x Greenwave - 3x Sidewinder

Bruno0406
Timide
Messages : 27
Inscription : 13 mars 2018, 19:05

Re: Plugin blea

Message par Bruno0406 » 27 août 2019, 23:04

Bonjour,
Je viens de mettre a jour la version du plugin BLEA.
Il fonctionnait a merveille
Et la impossible de lancer les dependances.
J'ai une cle USB-Bluetooth sur une Jeedom SMART.
Si vous avez une idee elle est la bienvenue

Log Blea:
[2019-08-27 21:18:35][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-27 21:20:38][ERROR] : Impossible de lancer le démon blea, vérifiez la log
[2019-08-27 21:59:18][INFO] : Launching remotes ...
[2019-08-27 22:07:24][INFO] : Launching remotes ...
[2019-08-27 22:30:08][INFO] : Launching remotes ...
[2019-08-27 22:45:21][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=blea function=pre_update callInstallFunction=1
[2019-08-27 22:45:29][INFO] : Début d'activation du plugin
[2019-08-27 22:45:36][INFO] : Info sur le démon : Array ( [log] => blea [state] => nok [launchable] => nok [launchable_message] => Gestion automatique désactivée [auto] => 0 [last_launch] => 2019-08-27 21:20:05 )
[2019-08-27 22:45:36][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=blea function=update callInstallFunction=1

Log Blea_local:
[2019-05-31 19:01:18][ERROR] : GLOBAL------Exception on scanner (didn't resolve there is an issue with bluetooth) : 'ascii' codec can't encode character u'\xed' in position 1: ordinal not in range(128)
[2019-05-31 19:54:26][ERROR] : GLOBAL------Exception on scanner (didn't resolve there is an issue with bluetooth) : 'ascii' codec can't encode character u'\xed' in position 1: ordinal not in range(128)
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'

Log Blea_update:
RuntimeError: Python version >= 3.5 required.
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 17, in <module>
File "/tmp/pip-build-8stjt5co/numpy/setup.py", line 31, in <module>
raise RuntimeError("Python version >= 3.5 required.")
RuntimeError: Python version >= 3.5 required.
----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-8stjt5co/numpy
Storing debug log for failure in /root/.pip/pip.log
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
running install

Bruno0406
Timide
Messages : 27
Inscription : 13 mars 2018, 19:05

Re: Plugin blea

Message par Bruno0406 » 27 août 2019, 23:58

propositionjoe a écrit :
28 juil. 2019, 21:49
Salut,
J'ai mis à jour le plugin,
C'est fonctionnel avec jessie.

Je n'ai pas creusé si mes modifications des commandes sur le scripts y étaient ou pas pour quelque chose.
Et comme recommandé j'ai mis à jour les antennes à partir de la page http du plugin blea.
Hello,
Tu as mis a jour les antennes, mais si on est en local avec une cle usb-bluetooth
Il n y a pas d antenne dans ce cas

Bruno0406
Timide
Messages : 27
Inscription : 13 mars 2018, 19:05

Re: Plugin blea

Message par Bruno0406 » 28 août 2019, 00:16

JeJe47 a écrit :
02 août 2019, 19:36
Bonjour,

Depuis la mise à jour du plugin je n'arrive plus à relancer les dépendances du plugin et le deamon ne se lance plus.

J'ai essayé de couper la gestion automatique et de relancer de nombreuses fois les dépendances et de bien attendre mais rien n'y fait.

Pouvez vous m'aider ? PS : je n'ai pas d'antenne.

Merci beaucoup.

Voici les logs :

Code : Tout sélectionner


********************************************************
*			 Installation des dépendances			 *
********************************************************
Hit http://repo.jeedom.com stable InRelease
Ign http://ftp.debian.org jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Ign http://ftp.debian.org jessie-backports InRelease
Ign http://ftp.debian.org jessie-proposed-updates InRelease
Hit http://ftp.debian.org jessie Release.gpg
Hit http://repo.jeedom.com stable/main arm64 Packages
Hit http://security.debian.org jessie/updates InRelease
Ign http://ftp.debian.org jessie-backports Release.gpg
Ign http://ftp.debian.org jessie-proposed-updates Release.gpg
Hit http://ftp.debian.org jessie Release
Hit http://ftp.debian.org jessie-updates/main Sources
Ign http://repo.jeedom.com stable/main Translation-en
Hit http://ftp.debian.org jessie-updates/contrib Sources
Hit http://ftp.debian.org jessie-updates/non-free Sources
Get:1 http://security.debian.org jessie/updates/main Sources [331 kB]
Ign http://ftp.debian.org jessie-backports Release
Ign http://ftp.debian.org jessie-proposed-updates Release
Get:2 http://security.debian.org jessie/updates/contrib Sources [1439 B]
Get:3 http://security.debian.org jessie/updates/non-free Sources [1629 B]
Ign http://ftp.debian.org jessie-backports/main Sources/DiffIndex
Ign http://ftp.debian.org jessie-backports/contrib Sources/DiffIndex
Ign http://ftp.debian.org jessie-backports/non-free Sources/DiffIndex
Hit http://oph.mdrjr.net all InRelease
Ign http://ftp.debian.org jessie-backports/main arm64 Packages/DiffIndex
Hit http://oph.mdrjr.net jessie InRelease
Ign http://ftp.debian.org jessie-backports/contrib arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-backports/non-free arm64 Packages/DiffIndex
Get:4 http://oph.mdrjr.net all/c2 arm64 Packages
Ign http://ftp.debian.org jessie-proposed-updates/contrib Sources/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/non-free Sources/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/main Sources/DiffIndex
Get:5 http://oph.mdrjr.net all/main arm64 Packages
Hit http://oph.mdrjr.net all/c2 arm64 Packages
Get:6 http://oph.mdrjr.net all/testing arm64 Packages
Get:7 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:8 http://oph.mdrjr.net all/main Translation-en [323 B]
Hit http://oph.mdrjr.net all/main arm64 Packages
Get:9 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:10 http://oph.mdrjr.net jessie/backports arm64 Packages
Hit http://oph.mdrjr.net all/testing arm64 Packages
Get:11 http://oph.mdrjr.net jessie/main arm64 Packages
Get:12 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:13 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:14 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:15 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:16 http://oph.mdrjr.net all/testing Translation-en [326 B]
Hit http://oph.mdrjr.net jessie/backports arm64 Packages
Hit http://oph.mdrjr.net jessie/main arm64 Packages
Get:17 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:18 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:19 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:20 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:21 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:22 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:23 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:24 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:25 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:26 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:27 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:28 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:29 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Ign http://oph.mdrjr.net all/c2 Translation-en
Get:30 http://oph.mdrjr.net all/main Translation-en [323 B]
Ign http://oph.mdrjr.net all/main Translation-en
Get:31 http://oph.mdrjr.net all/testing Translation-en [326 B]
Ign http://oph.mdrjr.net all/testing Translation-en
Get:32 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Ign http://oph.mdrjr.net jessie/backports Translation-en
Get:33 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Ign http://oph.mdrjr.net jessie/main Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/contrib arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/non-free arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/main arm64 Packages/DiffIndex
Hit http://ftp.debian.org jessie/main Sources
Hit http://ftp.debian.org jessie/contrib Sources
Hit http://ftp.debian.org jessie/non-free Sources
Ign http://ftp.debian.org jessie-backports/contrib Translation-en
Ign http://ftp.debian.org jessie-backports/main Translation-en
Ign http://ftp.debian.org jessie-backports/non-free Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/contrib Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/main Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/non-free Translation-en
Err http://ftp.debian.org jessie-backports/main Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/contrib Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/non-free Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/main arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/contrib arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/non-free arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/contrib Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/non-free Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/main Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/contrib arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/non-free arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/main arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
W: There is no public key available for the following key IDs:
AA8E81B4331F7F50
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-updates/InRelease  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)
W: Failed to fetch http://security.debian.org/dists/jessie/updates/InRelease  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie/Release  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/main/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/contrib/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/non-free/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/main/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/contrib/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/non-free/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/contrib/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/non-free/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/main/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/contrib/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/non-free/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/main/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
bluetooth is already the newest version.
build-essential is already the newest version.
libffi-dev is already the newest version.
The following package was automatically installed and is no longer required:
linux-headers-3.14.29+
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
libbluetooth3 libpython3-dev libpython3.4 libpython3.4-dev libssl1.0.0
python3-chardet python3-pkg-resources python3-six python3-urllib3
python3.4-dev
Suggested packages:
python3-ndg-httpsclient python3-openssl python3-pyasn1 python3-socks
python3-wxgtk3.0 python3-wxgtk python-setuptools-doc
Recommended packages:
libssl-doc
The following NEW packages will be installed:
libbluetooth-dev libbluetooth3 libpython3-dev libpython3.4 libpython3.4-dev
python3-chardet python3-dev python3-pkg-resources python3-pyudev
python3-requests python3-serial python3-setuptools python3-six
python3-urllib3 python3.4-dev rfkill
The following packages will be upgraded:
libssl-dev libssl1.0.0
2 upgraded, 16 newly installed, 0 to remove and 178 not upgraded.
Need to get 6553 kB of archives.
After this operation, 22.6 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
libssl-dev libssl1.0.0 python3-pkg-resources python3-six python3-pyudev
python3-urllib3 python3-requests python3-serial python3-setuptools
E: There are problems and -y was used without --force-yes
Reading package lists...
Building dependency tree...
Reading state information...
The following package was automatically installed and is no longer required:
linux-headers-3.14.29+
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
python3-chardet python3-colorama python3-distlib python3-html5lib
python3-pkg-resources python3-requests python3-setuptools python3-six
python3-urllib3
Suggested packages:
python3-genshi python3-lxml python3-ndg-httpsclient python3-openssl
python3-pyasn1 python3-socks python-setuptools-doc
Recommended packages:
python3-dev python3-wheel
The following NEW packages will be installed:
python3-chardet python3-colorama python3-distlib python3-html5lib
python3-pip python3-pkg-resources python3-requests python3-setuptools
python3-six python3-urllib3
0 upgraded, 10 newly installed, 0 to remove and 180 not upgraded.
Need to get 916 kB of archives.
After this operation, 4313 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
python3-pkg-resources python3-six python3-urllib3 python3-requests
python3-setuptools
E: There are problems and -y was used without --force-yes
sudo: pip3: command not found
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
libelfg0 linux-headers-3.14.29+
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
git-man libelf1 libglib2.0-0 libglib2.0-bin
Suggested packages:
gettext-base git-daemon-run git-daemon-sysvinit git-doc git-el git-email
git-gui gitk gitweb git-arch git-cvs git-mediawiki git-svn libglib2.0-doc
The following NEW packages will be installed:
libelf1
The following packages will be upgraded:
git git-man libglib2.0-0 libglib2.0-bin libglib2.0-dev
5 upgraded, 1 newly installed, 0 to remove and 175 not upgraded.
Need to get 12.2 MB of archives.
After this operation, 7645 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
git git-man libglib2.0-dev libglib2.0-bin libglib2.0-0
E: There are problems and -y was used without --force-yes
sudo: pip3: command not found
sudo: pip3: command not found
sudo: pip3: command not found
Cloning into 'bluepy'...
Traceback (most recent call last):
File "setup.py", line 3, in <module>
from setuptools.command.install import install
ImportError: No module named 'setuptools'
Traceback (most recent call last):
File "setup.py", line 3, in <module>
from setuptools.command.install import install
ImportError: No module named 'setuptools'
sudo: pip3: command not found
sudo: pip3: command not found
********************************************************
*			 Installation terminée					*
********************************************************




Hello,
Je suis dans le meme cas que toi, as tu trouve une soution?
Bruno0406

Bruno0406
Timide
Messages : 27
Inscription : 13 mars 2018, 19:05

Re: Plugin blea

Message par Bruno0406 » 28 août 2019, 00:28

Plugin Blea:
Est il possible de reinstaller une vieille version du plugin ?

Jef73
Timide
Messages : 366
Inscription : 27 déc. 2017, 10:41
Localisation : Nantes

Re: Plugin blea

Message par Jef73 » 28 août 2019, 05:34

Bruno0406 a écrit :
27 août 2019, 23:20
kris1208 a écrit :
13 juil. 2019, 09:14
Bonjour, vraiment beaucoup de probleme (cité aussi sur un groupe FB) depuis la mise a jour du 26, il n'y aurai pas moyen de regarder avec le dev ce qui a réellement changé et causé le probleme ?
Merci.
Bonne idee, je viens aussi de mettre a jour le plugin BLEA et plus rien ne fonctionne, c'est impossible de relancer les dependances
Bruno0406
Au vu de tes messages d'erreur, je pense que tu devrais faire ceci, en ligne de commande et directement sur la machine concernée :
1) installer python 3.7
2) installer pip3 (c'est-à-dire PIP sous Python 3 et pas sous Python 2)
3) mettre à jour BluePy sous pip3
Et ton plugin devrait refonctionner, c'est ce qui avait marché pour moi après que cette màj ait aussi tout planté sur une de mes antennes.

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3424
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Plugin blea

Message par Fabrice » 28 août 2019, 10:06

Bruno0406 a écrit :
28 août 2019, 00:28
Plugin Blea:
Est il possible de reinstaller une vieille version du plugin ?
Bonjour,

Votre problème vient du fait que votre SMart est encore sous l'ancien système d'exploitation, appelé Jessie.
Pour que BLEA et d'autres plugins, puissent installer correctement les dépendances, vous devez migrer votre BOX sur Strech.
Dans la partie documentations de Jeedom, vous avez le mode opératoire pour y parvenir.

De plus en plus de packages disparaissent sur Jessie, cela est du aux développeurs des packages Linux (et pas du aux équipes de Jeedom), qui ne peuvent pas maintenir des vieux packages, ils obligent ainsi (et c'est une bonne chose) à passer sur une distribution Linux plus récente.
Helper Officiel Jeedom
- Jeedom : 3.3.36
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

seppitux
Timide
Messages : 6
Inscription : 23 janv. 2018, 19:08

Re: Plugin blea

Message par seppitux » 28 août 2019, 13:49

julien35 a écrit :
08 août 2019, 09:03
julien35 a écrit :
07 août 2019, 10:47
julien35 a écrit :
07 août 2019, 09:28
Bonjour, depuis la dernière mise à jour du plugin, avec mes 5 hygrothermometre xiaomi, j'ai ma charge système qui est passée de 0.5 à 2 sur 15 minutes... Suis je le seul à avoir eu une augmentation considérable de charge cpu ?
Je viens de désactiver le plugin et je me retrouve avec 0.6 en charge cpu 15 minutes. Ce qui était le cas avant mise à jour du plugin.
Le problème vient du rafraîchissement des valeurs de mes thermomètres qui est devenu quasi continu et qui doit demander de la puissance de calcul constamment...
Personne d'autre, qui a des hygrothermometre, n'a vu une augmentation brutale de la charge cpu ?
IDEM refresh en continu..... j'ai déja posé la question ... sans réponse depuis !!

Avatar de l’utilisateur
technarf
Timide
Messages : 124
Inscription : 30 mars 2017, 10:06

Re: Plugin blea

Message par technarf » 28 août 2019, 17:12

Jef73 a écrit :
28 août 2019, 05:34
Bruno0406 a écrit :
27 août 2019, 23:20
kris1208 a écrit :
13 juil. 2019, 09:14
Bonjour, vraiment beaucoup de probleme (cité aussi sur un groupe FB) depuis la mise a jour du 26, il n'y aurai pas moyen de regarder avec le dev ce qui a réellement changé et causé le probleme ?
Merci.
Bonne idee, je viens aussi de mettre a jour le plugin BLEA et plus rien ne fonctionne, c'est impossible de relancer les dependances
Bruno0406
Au vu de tes messages d'erreur, je pense que tu devrais faire ceci, en ligne de commande et directement sur la machine concernée :
1) installer python 3.7
2) installer pip3 (c'est-à-dire PIP sous Python 3 et pas sous Python 2)
3) mettre à jour BluePy sous pip3
Et ton plugin devrait refonctionner, c'est ce qui avait marché pour moi après que cette màj ait aussi tout planté sur une de mes antennes.
Merci pour l'info... Des jours que je galère et j'ai réussi à solutionner mon problème grâce ces infos..
Depuis 2 mises à jour, mes dépendances restaient désespérément en NOK (pas de problème particulier sur mes antennes, mais sur le serveur Jeedom en lui-même). J'étais obligé de faire des restaurations et donc impossible d'utiliser les nouvelles mises à jour.
Bref, j'ai suivi la mise à jour en python 3.7 et hô magie mes dépendances ont accepté de se mettre au vert à la relance suivante.... J'ai juste eu un warning car Bluepy n'était pas à jour (Version 1.3.0 au lieu de 1.1.4 ;) )
Par contre, c'est Zwave qui n'apprécie pas... Obligé de remettre python en 2.7.13 pour que le démon accepte de se lancer.
En gros, il faut jongler entre les versions de python pour que ça veuille bien fonctionner (une fois les dépendances à jour, BLEA semble accepter de fonctionner avec un python en 2.7.13 par défaut).
C'est pas très "user friendly", peut-être faudrait-il que ces incompatibilités de version entre plug-ins soient corrigées à l'avenir...
Si jamais le dev d'openzwave fait un tour par ici, j'ai l'erreur suivante dans la log quand j'ai python qui est par défaut sur une version 3.X

Code : Tout sélectionner

File "/var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py", line 76
except Exception, ex:
^

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 28 août 2019, 17:22

Je suis un peu surpris, tu as du faire une embrouille dans ton install mais, en tout cas sur une debian stretch (je n'ai pas testé sous jessie), tu peux parfaitement avoir python 2 et python 3 installé en parallèle...

Comment veux-tu que l'on arrive à migrer de l'un à l'autre sinon? il faudrait synchro tous les plugins ! (et tout autre soft installé sur ta box)
D'ailleurs, je doute que blea tourne en python 2, la syntaxe et le nom de certains modules ont changé, c'est impossible (comme il est impossible de faire tourner zwave en python3 (car écrit pour python2)

Je suspecte que tu as (involontairement peut-être) changé le lien symbolique "python" vers "python3" pendant l'install de python3.
Hors tous les appels actuels sont fait en utilisant "python" (dans BLEA c'est bien python3 explicitement qui est utilisé).

Et sinon, la bonne action à effectuer qui garantira que tout cela continue à fonctionner plus tard était indiquée ici:
Fabrice a écrit :
28 août 2019, 10:06
Bonjour,

Votre problème vient du fait que votre SMart est encore sous l'ancien système d'exploitation, appelé Jessie.
Pour que BLEA et d'autres plugins, puissent installer correctement les dépendances, vous devez migrer votre BOX sur Strech.
Dans la partie documentations de Jeedom, vous avez le mode opératoire pour y parvenir.

De plus en plus de packages disparaissent sur Jessie, cela est du aux développeurs des packages Linux (et pas du aux équipes de Jeedom), qui ne peuvent pas maintenir des vieux packages, ils obligent ainsi (et c'est une bonne chose) à passer sur une distribution Linux plus récente.
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité